Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 08/02/2015, à 18:06

terje
Réponses : 50

Tamarou,

merci, cependant, cela ne se produit qu'avec un DVD live, pas avec les autres. Les autres fonctionnent (toutoulinux, la 10.04) masi ne détectent pas mes disques, ou ne fonctionnent pas pour des causes apparemment différentes : un kernel panic pour la knoppix...
En plus mon pb ne provient pas du boot avec un dualboot installé (win/ubuntu), mais depuis un DVD live. Ma machine démarre très bien sur la vieille version 8.04 installée sur les disques durs. Il n'y a pas d'autre système dessus.

Terje

#1 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 08/02/2015, à 18:12

terje
Réponses : 50

Ouaich... mon soucis est d'installer les paquets LTSP pour pouvoir faire fonctionner les machines clientes légères de la salle info de mon école...
Je vais y réfléchir...
Terje

#2 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 08/02/2015, à 19:00

terje
Réponses : 50

Temps,

à propos du Bios, très clairement, je suis à la préhistoire !
Actuellement, la machine embarque un Bios de 2003 !
Bios Build Level : OPE128A
Bios Date : Apr 29, 2003

Or, sur cette page d'IBM dédiée à Xseries 225, on trouve la possibilité de flasher le bios pour une MAJ
qui date de 2007. Cependant, dans la description des différentes MAJ des bios de cette page, je ne vois pas franchement quelque chose qui pourrait agir sur le controleur de disque scsi LSI Logic.
http://www-947.ibm.com/support/entry/po … MIGR-45279

MErci pour ton suivi en tous les cas.
Terje

#3 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 10/02/2015, à 18:04

terje
Réponses : 50

Bonsoir Tewis et merci pour votre réponse.
un pb s'ajoutant aux autres, la 8.04 installée ne démarre plus, j'ai une busy box avec un prompt initramfs !

Je redémarre sur un cd live pour tenter de trouver les infos, apparemment le lspci de mon premier post est incomplet.
Terje

#4 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 10/02/2015, à 18:14

terje
Réponses : 50

Je suis en direct du serveur depuis un cd live 10.04, le seul qui veuille bien s'afficher

ubuntu@ubuntu:~/Desktop$ lspci -nn -k | grep -A1 -i lsi
04:03.0 SCSI storage controller [0100]: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI [1000:0030] (rev 07)
	Kernel driver in use: mptspi
--
04:03.1 SCSI storage controller [0100]: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI [1000:0030] (rev 07)
	Kernel driver in use: mptspi
ubuntu@ubuntu:~/Desktop$ modinfo [kernel_driver]
ERROR: modinfo: could not find module [kernel_driver]
ubuntu@ubuntu:~/Desktop$ 

En ce qui concerne

sudo update-pciids

je n'ai pas de retour

Terje

#5 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 08:24

terje
Réponses : 50

Bonjour Temps,
Effectivement, l'ajout d'un dépôt serait plus simple.
J'ai rajouté le dépôt dans le sources.list, depuis le CD-Live de la 10.04, mais les disques n'étaient quand même pas reconnus, j'avais lancé gparted, aucun disque installé.
Le serveur ne boote pas sur les clé usb, mais je vais ré-essayer ce matin avec un CD avec plop manager qui force à booter sur les clé usb, ainsi je n'aurai pas à graver à chaque fois une distro. J'ai justement une clé avec multisystem dessus.
Je relance avec une clé ce matin.
Merci en tous les cas.

#6 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 09:54

terje
Réponses : 50

J'arrive à démarrer la clé usb via le cd plop manager.
C'est bizarre, Plop remarque les partitions des 3 disques du serveur (hda1, hda2, hda3, hdb1...) puis floppy... enfin usb.
Sur usb, multisystem s'affiche, je lance un système, un xubuntu 14.04... et après l'affichage de Xubuntu 14.04 par deux fois, l'écran reste noir, la led de l'écran m'indique d'ailleurs qu'elle ne reçoit aucune donnée... elle a viré au jaune au lieu d'être au vert.
Je vais voir avec d'autres distros et surtout le flash bios, ici :

http://www-947.ibm.com/support/entry/po … MIGR-45279
Si vous avez des recommandations pour ne pas me planter...
Apparemment, pas besoin de windows, puisque il y a CD image ou un je peux passer par une disquette (faut simplement que j'en trouve une...)

http://public.dhe.ibm.com/systems/suppo … s_i386.txt

(tiens, la led écran est repassée au vert, mais l'écran lui est toujours noir)

#7 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 13:53

terje
Réponses : 50

OK, ça signifie que je dois flasher avec la version 1.51 ?
Sinon, ce que je comprends serait plutôt ceci :

si j'ai une version Bios < à la 1.48, je dois paramétrer le bios actuel avec ces instructions :

Access the BIOS Setup screen by pressing F1 during POST power on. Under:

Advanced Setup --> Chipset Feature --> DRAM Timing Configure

Make sure that the option is set for the following [Manual]
CAS Latency Time [2.5]
Active to Precharge Delay [7 ]
DRAM RAS# to CAS# Delay [3 ]
DRAM RAS# Precharge [3 ]

Save Settings and exit.Access the BIOS Setup screen by pressing F1 during POST power on. Under:

Ensuite seulement, je peux flasher le Bios avec la version 1.51C

Je vais quand même chercher la version 1.51A car effectivement, la vrsion 1.51C est une update de la 1.51, donc cela paraît logique qu'il faille déjà flasher sur une 1.51A. Ce ne sont que des suppositions de ma part, n'ayant jamais fait cela.
Qu'en pensez-vous ?
Terje

#8 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 16:17

terje
Réponses : 50

Oui Tamarou,
l'installation faite avec la 8.04 reconnaît les disques, le hic c'est la mise à jour avec des distributions > 8.04
Or, j'ai découvert cela aussi :
http://www-947.ibm.com/support/entry/po … text=61027

et notamment :

http://www-947.ibm.com/support/entry/po … nd=5350884

Bon, finalement, faut-il flasher le bios ou seulement installer les drivers LSI masi qui ne sont prévus que pour RedHat ou Suse ?

#9 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 18:12

terje
Réponses : 50

Temps,

vous conseilleriez d'installer alien sur la 8.04, puis de convertir le paquet de RedHat en .deb puis de l'installer sur la 8.04, ensuite de tenter une mise à jour ?
http://www-947.ibm.com/support/entry/po … GR-5073705
Terje

#10 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 18:30

terje
Réponses : 50

tiens je viens de redémarrer sur la 8.04 pour voir, ben ça démarre, pas de busy box avec un prompt initramfs.
Et effectivement, mes disques apparaissent dans gparted ou avec un fdisk -l

#11 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 18:32

terje
Réponses : 50
prof@LTSP:~$ sudo fdisk -l
[sudo] password for prof: 

Disque /dev/sda: 36.4 Go, 36401479680 octets
255 heads, 63 sectors/track, 4425 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xd83cd83c

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1            1246        1494     2000092+  82  Linux swap / Solaris
/dev/sda2   *           1        1245    10000431   83  Linux
/dev/sda3            1495        4425    23543257+  83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Disque /dev/sdb: 36.4 Go, 36401479680 octets
255 heads, 63 sectors/track, 4425 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xd83cd83c

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1            1246        1494     2000092+  82  Linux swap / Solaris
/dev/sdb2   *           1        1245    10000431   83  Linux
/dev/sdb3            1495        4425    23543257+  83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Disque /dev/sdc: 36.4 Go, 36401479680 octets
255 heads, 63 sectors/track, 4425 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xd83cd83c

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdc1            1246        1494     2000092+  82  Linux swap / Solaris
/dev/sdc2   *           1        1245    10000431   83  Linux
/dev/sdc3            1495        4425    23543257+  83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque
prof@LTSP:~$ 

#12 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 18:52

terje
Réponses : 50

j'ai du temps !
j'ai déjà testé une debian avec lxde, pas de disque.
Mais je vais tester avec antix et aussi handylinux, faut juste que je grave les dvd puisque ça passe pas trop avec la clé usb.

#13 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 21:25

terje
Réponses : 50

Bon, oulala... y a des trucs qui se passent !
j'ai relancé la 8.04 et... je ne sais pas pourquoi, j'ai voulu relancer l'install vers une mise à niveau 10.04 LTS.
Je voulais revoir où ça plantait exactement.
A mon grand étonnement, il a accepté après avoir fait de la place (il lui manquait 165 Mo pour télécharger les paquets, j'ai viré Gimp et les logiciels ludo-éducatifs...)
Bref, il est en cours de mise à jour vers la version 10.04

Ce qui me questionne, comment va-t-il réagir au redémarrage s'il ne reconnaît pas les disques ? Toutes les versions en CD live que j'ai testées pour refaire une install from scratch ne trouvaient pas les disques. Le CD live de la 10.04 non plus.

J'ai un peu l'imression d'avoir perdu du temps et aussi de vous en avoir fait perdre...

Ce qui n'enlève pas le fait que sur les cd live, les disques ne sont pas reconnus...

#14 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 21:27

terje
Réponses : 50

Je vais aussi tester les autres distro comme conseillé par Tamarou et Temps... quand même !
Ça serait trop simple sinon.

#15 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 11/02/2015, à 22:08

terje
Réponses : 50

Ah bah voilà !
Au demarrage, j'ai :

...
mptbase : ioc0: RAID STATUT CHANGE for PhysDisk 1 id=0
mptbase : ioc0:  PhysDisk is now missing, out of sync
...

ça ne démarre plus du tout !
Du coup, je n'ai plus le choix.

#16 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 12/02/2015, à 09:52

terje
Réponses : 50

Je suis complètement d'accord avec toi, Temps.
Je suis bien placé pour savoir que l'on apprend de ses erreurs et donc de ses expériences. Mon métier n'est pas du tout dans l'informatique, je travaille avec de l'humain (prof pour élèves en situation de handicap cognitif).
Pour aujourd'hui, je vais tester les debian, voir si elles acceptent le matériel, via cd ou dvd live et retenter par la clé usb, car effectivement comme tu le précise, je peux mettre à jour une clé avec un nouveau dépôt pour tenter de reconnaître le controleur scsi.
Je flasherai aussi le bios si ça ne marche pas.
Terje

#17 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 12/02/2015, à 13:19

terje
Réponses : 50

Sous Antix, j'ai les disques !

################### PC INFORMATION - hard drive #####################
##################### Press CTRL  + C to exit #######################

Drives:    HDD Total Size: 109.2GB (-) 1: id: /dev/sda model: MAP3367NP_FN size: 36.4GB 
           2: id: /dev/sdb model: MAP3367NP_FN size: 36.4GB 3: id: /dev/sdc model: MAP3367NP_FN size: 36.4GB 
Partition: ID: / size: 2.4G used: 5.6M (1%) fs: rootfs ID: swap-1 size: 2.05GB used: 0.00GB (0%) fs: swap 
           ID: swap-2 size: 2.05GB used: 0.00GB (0%) fs: swap 

C'est rassurant quelque part !

#18 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 12/02/2015, à 14:03

terje
Réponses : 50

Handy linux plante, il ne se lance pas du tout, j'ai un message d'erreur, j'ai testé la version i486, faut peut-être que je teste la version i686 !

Sinon, j'ai ouvert le serveur, bon les disques sont branchés sur des slots scsi mais y deux slots IDE, un sur lequel il y a le lecteur de dvd et un libre.
Puis-je mettre un disque dur sur le IDE 2, j'en ai qui traînent à l'école, je dois pouvoir récupérer cela, puis faire une install dessus et démarrer dessus en ignorant complétement les disques scsi que je débrancherais.

(tiens, j'ai relancé Antix pour faire une install, ben y le fameux message udevd timeout killing /sbin/modprobe -b pci...)

#19 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 12/02/2015, à 14:12

terje
Réponses : 50

Sous une AbulÉduLive 8.04 les disques sont aussi là :

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ fdisk -l
ubuntu@ubuntu:~$ sudo fdisk -l

Disque /dev/sda: 36.4 Go, 36401479680 octets
255 heads, 63 sectors/track, 4425 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xd83cd83c

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1            1246        1494     2000092+  82  Linux swap / Solaris
/dev/sda2   *           1        1245    10000431   83  Linux
/dev/sda3            1495        4425    23543257+  83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Disque /dev/sdb: 36.4 Go, 36401479680 octets
255 heads, 63 sectors/track, 4425 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xd83cd83c

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1            1246        1494     2000092+  82  Linux swap / Solaris
/dev/sdb2   *           1        1245    10000431   83  Linux
/dev/sdb3            1495        4425    23543257+  83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Disque /dev/sdc: 36.4 Go, 36401479680 octets
255 heads, 63 sectors/track, 4425 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xd83cd83c

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdc1            1246        1494     2000092+  82  Linux swap / Solaris
/dev/sdc2   *           1        1245    10000431   83  Linux
/dev/sdc3            1495        4425    23543257+  83  Linux

#20 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 14/02/2015, à 16:04

terje
Réponses : 50

Je tente de voir quelles debian s'affichent en live. C'est très aléatoire.
Les versions handylinux ne s'affichent pas, une erreur se produit au début du lancement du cd live.
Par contre, crunchbang s'affiche et reconnaît le disque SCSI controlé par LSI.
Je suis en train de faire une install avec une crunchbang 9.04 pour voir.
Ça a l'air de faire quelque chose... faut juste voir au reboot... trop de faux espoirs jusqu'à maintenant !
Cependant, certains d'entre vous aviaent raison d'insister en me conseillant la debian (faut juste trouver la bonne).
Si c'est ok, faut installer le LTSP ensuite.
Je vous tiens au jus.
Terje

#21 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 14/02/2015, à 16:11

terje
Réponses : 50

Incroyable !
L'installation de crunchbang est hyper rapide (15 minutes mani par le CD live)
Le démarrage est impec, la distro s'affiche rapidement...utilisation de 93 Mo en RAM,  1,88 Go d'utiliser pour le système sur les 31,95 du disque !
Reste à mettre à jour...
En espérant que ça roule toujours.
Terje

#22 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 14/02/2015, à 16:43

terje
Réponses : 50

Argh...
les versions suivantes de crunchbang (10 et 11) ne s'affichent pas, elles génèrent un message d'erreur de type no file configuration found...
Pas glop !

#23 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 14/02/2015, à 17:09

terje
Réponses : 50

Bon... finalement, le cdlive de waldorf se lance... ok
J'installe directement et là les disques ne sont plus reconnus !
Pfffffffffffffffff...
Alors avec une crunchbang basé sur une ubuntu 9.04 -> tout ok
une crunchbang sur debian pure -> pas ok
je suppose qu'une ubuntu 9.04 ça doit être bon, mais je ne vois pas l'intérêt.

#24 Re : -1 »  installation edubuntu ltsp sur serveur ibm eserver x225 » Le 17/02/2015, à 11:43

terje
Réponses : 50

Bonjour
merci pour les infos, je n'ai pas eu le temps de m'y recoller ces derniers jours mais je vais reprendre cette semaine.
Terje