Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

nombre réponses : 25

#0 -1 »  [Résolu] Démarrage service minidlna ubuntu 11.10 » Le 30/10/2011, à 13:15

NainNain
Réponses : 7

Bonjour à tous,

Besoin d'un petit coup de main, sur le démarrage automatique de mon serveur minidlna sous oneiric...
Je précise que après installation du paquet minidlna et configuration sur serveur, ça tourne très bien quand je démarre le service manuellement

sudo /etc/init.d/minidlna start

Par contre, le serveur ne démarre pas automatiquement au boot...
J'ai essayé pas mal de solutions, via une crontab, et même en relançant

sudo update-rc.d minidlna defaults

Mais rien y fait, après reboot, je ne vois jamais minidlna dans les process lancés...
J'imagine que c'est dû au fait que ubuntu utilise maintenant upstart comme gestionnaire de services mais je ne vois pas comment faire...
Merci pour votre aide smile NainNain

#1 Re : -1 »  [Résolu] Démarrage service minidlna ubuntu 11.10 » Le 30/10/2011, à 16:43

NainNain
Réponses : 7

Bon, je vais répondre à ma question, je viens de trouver wink
(inspiré ce thread)

En fait ce que se passe c'est que la configuration par défaut du paquet minidlna dans ubuntu 11.10 n'est pas totalement correcte.
Je m'explique :

- Lors de l'installation de minidlna, la commande suivante est exécutée, pour ajouter le service minidlna à la séquence de boot :

sudo update-rc.d minidlna defaults

- Le problème, c'est que par défaut la priorité d'exécution de ce service (20 je crois) est trop élevée pour attendre que tout soit prêt pour lancer le serveur (je pense par exemple à la configuration du réseau, au montage des partitions, etc...)

- Et donc, il faut abaisser la priorité du service pour qu'il s'exécute à la fin de la séquence de boot ! Les commandes qui ont résolu mon problème sont donc :

sudo update-rc.d -f minidlna remove

pour supprimer la configuration actuelle du service, puis :

sudo update-rc.d minidna defaults 99

En espérant que ce post sera utile. NainNain

#2 Re : -1 »  [Résolu] Démarrage service minidlna ubuntu 11.10 » Le 07/11/2011, à 20:32

NainNain
Réponses : 7

Bonsoir,
Je reviens sur ce POST, car j'ai toujours des soucis. J'ai formaté depuis mon dernier message, et je ne sais pas quelles manipulations m'avaient permis de réussir avant, mais là je m'arrache les cheveux...

1. Le serveur marche toujours très bien quand je démarre le service manuellement

sudo /etc/init.d/minidlna start

2. J'ai essayé le lancement automatique à la fois via UPSTART et via SystemV, aucun ne réussi à me démarrer minidlna.

3. J'ai (manuellement) ajouté des log dans le script de lancement du démon minidlna pour voir si la séquence de boot passe bien dans le script, pas de soucis il y passe.

4. J'attends pourtant le plus tard possible dans SystemV (j'utilise la priorité niveau 99), ou dans upstart (j'attends le lancement de lightdm), RIEN N'Y FAIT!

Je ne comprends vraiment pas pourquoi il n'arrive pas à lancer ce démon...
D'autant que dès après le login, aucun souci quand je le lance en console.
J'en suis actuellement à chercher à lancer le script suite à l’authentification sous PAM.

HELP smile
Merci à vous.

#3 Re : -1 »  [ RESOLU] numlock et gdm » Le 13/10/2011, à 11:17

NainNain
Réponses : 11

Bonjour winux12,
J'ai installé la beta il y a deux jours, et je constate le même souci que toi.

Comme tu disais, c'est parce que GDM a été remplacé par LightDM pour le display manager au démarrage.
Donc plus de /etc/gdm mais un /etc/lightdm qui ne contient pas de script exécutable mais des infos de configuration de LightDM (donc pas de possiblité d'ajouter les lignes pour numlockx ici).
J'ai regardé rapidement, le lancement du service LightDM est désormais fait via upstart, le gestionnaire de démarrage de services que j'avoue ne pas maîtriser. Et donc le démarrage du service lightdm qui se situe (comme tous les démarrages de services) dans /etc/init.d/lightdm est en fait un lien symbolique vers upstart... Donc NE PAS ajouter les lignes concernant numlockx ici ce serait peu élégant smile

Pour ma part, intuitivement, j'irai rajouter dans un script de démarrage de service (genre /etc/init.d/x11-common avant le "exit 0" ou beaucoup plus logique dans les cas "start" et éventuellement "restart|reload|force-reload" du case juste le "exit 0"). Mais c'est à défaut de trouver plus joli pour le moment. Mais je ne vois pas pourquoi ça ne passerait pas comme ça.
Encore une fois, je viens de regarder ça en 5 secondes, quand j'aurai plus de temps je pourrai regarder où ajouter le démarrage de numlockx, mais pas aujourd'hui ^^

Enfin, j'ajoute que toute confirmation/proposition serait utile, je ne voudrais pas faire des bêtises à tous ceux qui passent sur le post wink
NainNain

#4 Re : -1 »  Exaile 3.0 est sorti » Le 10/11/2009, à 19:43

NainNain
Réponses : 178

Bonsoir,

- Personnellement c'est mon iPod que je n'arrive plus à utiliser dans cette version 0.3.0.1. Pourtant j'ai bien installé le paquet exaile-plugin-ipod mais aucun nouveau tab n'est apparu sur le côté gauche.
- Un autre truc qui m'ennuie avec cette dernière mouture de exaile (avant dernière depuis la récente sortie de la 0.3.0.2), c'est le fait que je ne puisse pas lui dire de na pas tenir compte des articles dans les tags (le,la,les,the,...). C'est possible?
- Enfin, je n'arrive pas à remettre l'aperçu des covers dans ma musicothèque

Merci smile

#5 Re : -1 »  Exaile 3.0 est sorti » Le 11/11/2009, à 01:29

NainNain
Réponses : 178

C'est fait pourtant...

#6 Re : -1 »  Exaile 3.0 est sorti » Le 11/11/2009, à 23:54

NainNain
Réponses : 178

Petit up smile

#7 -1 »  [Resolu] Excel 2003 crash Wine » Le 16/08/2010, à 11:40

NainNain
Réponses : 2

Avant de me faire lapider, je précise : je suis depuis longtemps un fervent utilisateur d'oocalc que j'utilise dans l'immense majorité des cas wink
Mais j'ai un fichier xls super bien faire pour faire ma compta qui est en xls, donc j'ai toujours un reliquat d'office 2003 installé sous Wine.

De retour sous Ubuntu, je constate que la version de Wine de base est relativement avancée (1.2). Problème : impossible d'utiliser Excel --> dès que l'on formate le contenu d'une cellule (date, nombre monétaire, chiffres après la virgule) --> CRASH de l'appli sad

Quelqu'un a-t-il déjà rencontré/controurné ce problème?! Merci smile

(Notes: wine installé via apt sous Ubuntu x86_64 avec office 2003 pro version 32bits, donc pas de souci normalement. Word fonctionne.)

#8 Re : -1 »  [Resolu] Excel 2003 crash Wine » Le 16/08/2010, à 19:47

NainNain
Réponses : 2

Vraiment personne n'a de souci en utilisant Excel 2003 dans la version actuelle de Wine des dépôts Lucid? sad

#9 Re : -1 »  [Resolu] Excel 2003 crash Wine » Le 25/08/2010, à 20:48

NainNain
Réponses : 2

Juste pour signaler que mon problème a été résolu en ajoutant le repository de wine (cf. page de documentation de wine de ubuntu-fr) et en faisant une upgrade vers la version 1.2!
Voir ce thread : http://forum.winehq.org/viewtopic.php?t=9430&sid=86ee909189121d0d1d8444055c9487b5

#10 -1 »  [Resolu] Amarok 2.3.0 / KDE 4.4.2 sous Lucid inutilsable :( » Le 15/08/2010, à 01:37

NainNain
Réponses : 7

Bonjour!

Me voici de retour sous Ubuntu avec Lucid, après deux ans passés sous Debian... Mon matériel était très vieux et il était temps de changer, et Ubuntu s'est avéré plus facile pour les backports de ALSA (pour utiliser la sortie audio optique de la carte mere!)

Bref, j'ai eu la bonne surprise de découvrir Lucid, très agréable jusque là, sauf que... amarok est inutilisable en l'état après installation des paquets!

1. Il scanne ma musicothèque puis --> zéro pistes locales!
2. Je fais glisser une piste audio quelconque pour lecture --> il ne démarre pas!

Voici les messages d'erreurs renvoyés si je lance amarok en mode

amarok --debug

alors j'ai les retours suivants (à la fois lors du scan de la musicothèque ou lors du lancement de la lecture de la piste

[ERROR!] Tried to perform query on uninitialized MySQL

Merci pour votre aide, je galère là... (PS: phonon-backend-xine est installé, comme le propose la documentation...)

#11 Re : -1 »  [Resolu] Amarok 2.3.0 / KDE 4.4.2 sous Lucid inutilsable :( » Le 15/08/2010, à 12:22

NainNain
Réponses : 7

Je ne m'en sors toujours pas...
Quelques questions pour tenter de m'aiguiller.
- quelqu'un a-t-il récemment fait une installation fraîche de Lucid en x86_64 ? suivie d'une installation d'amarok, toujours par l'outil apt (i.e. sans .deb exotique ou compilation depuis le source de quoi que ce soit).
- pensez vous qu'il pourrait s'agir d'un problème de matériel? (carte mere asus p7p55d)
- ou d'un problème de packaging?
Merci!
NainNain

#12 Re : -1 »  [Resolu] Amarok 2.3.0 / KDE 4.4.2 sous Lucid inutilsable :( » Le 15/08/2010, à 17:40

NainNain
Réponses : 7

Personne?
Ca fonctionne direct chez vous tous après install? sad

#13 Re : -1 »  [Resolu] Amarok 2.3.0 / KDE 4.4.2 sous Lucid inutilsable :( » Le 16/08/2010, à 18:19

NainNain
Réponses : 7

En effet, j'avais vu d'autres bug trackers, mais je ne suis pas tombé sur celui ci...
Merci beaucoup! Par contre mes morceaux ne se lancent toujours pas... mais ça c'est une autre histoire...

#14 Re : -1 »  [Resolu] Amarok 2.3.0 / KDE 4.4.2 sous Lucid inutilsable :( » Le 16/08/2010, à 19:06

NainNain
Réponses : 7

A y est, ma musique tourne au moment où je vous écris ce message smile

Deux choses bêtes de ma part, dont une devrait peut être apparaître malgré tout plus en évidence sur la page de doc d'amarok, selon moi, car elle s'applique sûrement à au moins 90% des utilisateurs, qui n'ont pas toute leur musicothèque en ogg (entendez "il y a du mp3" parmi mes morceaux):

1. oubli d'installer libxine1-ffmpeg : sachant que par défaut maintenant amarok dépend de libxine1 et phonon-backend-xine, beaucoup doivent j'imagine installer libxine1-ffmpeg... bref... phonon renvoie de lui-même (quasiment, pour le commun des mortels) vers ceci : http://amarok.kde.org/wiki/FAQ#Amarok_w … an_I_do.3F donc dans tous les cas, pas difficile de trouver la solution...

2. comme mentionné dans mon premier post, j'utilise la sortie optique de ma carte mère asus p7p55d, donc, pour ceux qui tomberaient sur ce message : n'oubliez pas de configurer phonon et de mettre la sortie digitale en sortie par défaut (dans amarok : configuration > configurer amarok > lecture > configure phonon)

Voilà c'est tout! résolu smile
Merci spécial à manslipkorn pour son post wink

#15 Re : -1 »  [Resolu] Amarok 2.3.0 / KDE 4.4.2 sous Lucid inutilsable :( » Le 24/08/2010, à 21:21

NainNain
Réponses : 7

J'apporte un bémol par rapport au point numéro 2 de mon message précédent.
En mettant la sortie digitale en haut de la liste, le réglage du son sous gnome (qui agit sur pulseaudio) ne fera pas changer le volume sous amarok (de même vous ne pourrez pas mettre en mute).
Il vaut donc mieux mettre pulseaudio par défaut comme serveur de son dans phonon!!!
C'est tout smile

#16 -1 »  [Résolu] Driver propriétaire nvidia : pas de paquet proposé » Le 13/08/2010, à 13:14

NainNain
Réponses : 1

Bonjour,
Malgré les différentes manipulations proposées dans la doc, l'outil pilote de périphériques ne me propose aucun pilote pour ma carte (nvidia gtx460).
Est ce le fait que c'est une carte récente? Au pire je passe par le .run de chez nvidia, tant pis...
Merci pour les infos!
NainNain

#17 Re : -1 »  [Résolu] Driver propriétaire nvidia : pas de paquet proposé » Le 13/08/2010, à 14:05

NainNain
Réponses : 1

Quand je consulte les archives des pilotes de nvidia compatible avec les GTX460, il n'y a qu'une version disponible (256.44 datant du 02 aout). L'âge récent de la carte explique surement que ces pilotes n'ont pas encore été intégrés à la distribution... Merci!

#18 Re : -1 »  Problèmes de lenteur extrème au démarrage de 9.10 » Le 04/11/2009, à 23:20

NainNain
Réponses : 14

Bonsoir,

En effet il y a un bug dans la version beta courante de grub2
Le cas typique d'apparition du bug est le suivant :
  - Windows (XP, Vista, 7 ou autres) est sur le disque primaire de boot du BIOS (/dev/sda1) --> c'est dans la MBR de ce disque que s'installe grub.
  - La partition Ubuntu (ou autre) contenant /boot/grub est située sur un autre disque (/dev/sdb1)

Alors on observe un gros ralentissement au moment de charger le menu de grub2, et meme parfois après avoir sélectioné son OS...

Plus de détails ici, par exemple (sachez que le bug a été remonté jusque aux développeurs de grub2, un fix devrait apparaitre...) :
http://wwww.ubuntuforums.org/showthread.php?p=8214750
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/420933
http://ubuntuforums.org/showthread.php?t=1309398

Pour ce qui est d'une solution, le mieux au jour d'aujourd'hui est probablement de réinstaller grub1. Pour cela rien de plus simple, suivez ce tuto!!
https://help.ubuntu.com/community/Grub2 (section Uninstalling GRUB 2)

Pensez à :

1. Dans le cas expliqué ci-dessus, installer sur /dev/sda au moment du grub install
2. A rajouter votre partition Windows dans le menu.lst généré. Si vous avez un doute, c'est ici : http://doc.ubuntu-fr.org/grub

Voila!
Hope that helps smile

#19 Re : -1 »  quelle carte son avec sortie optique *fonctionnelle* ? » Le 23/11/2009, à 15:42

NainNain
Réponses : 4

Bonjour!
Je remonte ce post car j'ai exactement la même question!
J'avoue que le site ALSA est presque trop complet pour ce genre de recherches. Quand on arrive sans idées on ne sait trop par où commencer...
Donc si vous n'est pas trop avares de conseils pour me suggérer une carte son PCI avec sortie optique pour sortir sur le 5.1 que je viens d'acquérir, ce serait super!!
Merci smile

#20 -1 »  [Karmic] gnome-terminal bash control C » Le 10/11/2009, à 11:57

NainNain
Réponses : 5

Bonjour,

Sauriez-vous à quelle signal POSIX est associé la combinaison control+C dans le bash par défaut de la dernière mouture de Ubuntu? SIGINT/SIGTERM/autre? Et dans quel fichier de conf cette association est déclarée?

Je me pose cette question pour un détail bête mais qui m'agace smile : quand j'annule avant de lancer une commande dans mon bash, j'ai tendance a le faire via control+C. Et depuis le passage à Karmic, ca m'affiche le ^C en fin de ligne et ca m'énerve smile

Merci pour votre aide.

#21 Re : -1 »  [Karmic] gnome-terminal bash control C » Le 10/11/2009, à 19:28

NainNain
Réponses : 5

Merci pour cette réponse, mais malheureusement non, ce comportement n'est pas uniquement lié à Python2.6.
Pour preuve:

login@login-desktop:~$ test^C
login@login-desktop:~$ ^C
login@login-desktop:~$ ^C

#22 Re : -1 »  [Karmic] gnome-terminal bash control C » Le 11/11/2009, à 23:53

NainNain
Réponses : 5

Petit up smile
Je n'ai toujous pas résolu le "problème"...

#23 Re : -1 »  [Karmic] gnome-terminal bash control C » Le 15/11/2009, à 13:22

NainNain
Réponses : 5

Up? Désolé mais je ne vois toujours pas...

#24 Re : -1 »  [Wine+CS1.6] Help, très lent... » Le 23/09/2009, à 08:48

NainNain
Réponses : 8

Extrait de la page de documentation sur les pilotes Catalyst...

La version 9.4 du pilote Catalyst incluse dans Ubuntu 9.04 ne supporte que les cartes de la série HD 2000 et plus récentes. Pour les cartes plus anciennes il faut dorénavant utiliser l'un des pilotes libres radeon ou radeonhd, ou bien conserver un Ubuntu 8.10 ou plus ancien sur lequel on peut installer les Catalyst 9.3. Un patch de compatibilité est en cour de test. La version 9.3 supporte en effet toutes les cartes AMD depuis les R300 c'est à dire la série des Radeon 9500/9700 et X

Ma carte étant une 9800PRO, impossible pour moi d'installer les pilotes propriétaires dorénavant...