Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

nombre réponses : 25

#0 Re : -1 »  Skype crash apres 2 sec (cedilla failed) » Le 26/05/2011, à 18:56

thomine
Réponses : 24

Hello,
Même problème. La solution de slasher-fun fonctionne pour moi, c'est simple :
supprimer le fichier ~/.Skype/shared.xml

#1 Re : -1 »  Affichage des couleurs de certaines images défaillant sous Firefox 4 » Le 11/05/2011, à 19:45

thomine
Réponses : 12

+1, j'ai un PC sur lequel j'ai le même problème. C'est complètement dingue. Sur vente-privée.com, sur la liste des produits, certains photos sont nickels et d'autres vertes et violettes, alors que ce sont quasiment les mêmes...
J'espère qu'une solution arrivera rapidement...

#2 -1 »  Télécommande infrarouge USB : 1 touche sur 10 détectée sur mon HTPC » Le 06/12/2012, à 22:23

thomine
Réponses : 1

Bonjour,
J'ai acheté cette télécommande pour utiliser avec mon HTPC : http://www.ldlc.com/fiche/PB00101489.html.
Problème : quand j'appuie sur les boutons, c'est assez aléatoire mais environ 1 appui sur 10 est détecté :-(.
J'ai un dual boot Ubuntu / Windows 7 et j'ai le même problème sous les 2 OS.

dmesg :

usb 2-1.1: new low-speed USB device number 5 using ehci_hcd
usb 2-1.1: New USB device found, idVendor=1241, idProduct=e000
usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-1.1: Manufacturer: HOLTEK
input: HOLTEK as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input14
hid-generic 0003:1241:E000.0006: input,hidraw0: USB HID v1.10 Keyboard [HOLTEK] on usb-0000:00:1d.0-1.1/input0
input: HOLTEK as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/input/input15
hid-generic 0003:1241:E000.0007: input,hiddev0,hidraw1: USB HID v1.10 Mouse [HOLTEK] on usb-0000:00:1d.0-1.1/input1

Le pire, c'est que la télécommande marche correctement et directement sur 2 autres PC (1 Ubuntu et 1 Windows 7). Rien besoin d'installer.
Pour résumé, ma télécommande ne se comporte pas correctement sur le seul PC avec lequel je souhaite l'utiliser.
Quelqu'un aurait-il un début de piste à me fournir ? Ce ne semble pas être un problème de driver puisque je n'ai rien installé. Peut-être un conflit avec un autre driver ? En tout cas j'ai débranché tous les autres périphériques USB pour faire mes tests...
Par avance, merci !

#3 Re : -1 »  Télécommande infrarouge USB : 1 touche sur 10 détectée sur mon HTPC » Le 08/12/2012, à 15:21

thomine
Réponses : 1

J'ai fait un test avec un live CD Ubuntu et je n'ai pas ce phénomène ! Donc il doit y avoir quelque chose d'installé sur mon Ubuntu qui perturbe le récepteur infrarouge. Pour être plus précis, le disque dur était initialement sur une autre machine. Je l'ai récupéré pour mon HTPC sans réinstaller le système. Est-ce que cela peut venir de là ? Comment savoir ce qui se passe plus précisément au niveau du récepteur USB ?

#4 -1 »  [Résolu]Rechercher des fichiers et les convertir en gardant l'original » Le 28/04/2012, à 13:02

thomine
Réponses : 3

Bonjour,

Voici ce que je cherche à faire :
1. Dans une arborescence de fichiers, rechercher tous les fichiers avec l'extension .md5

find . -iname '*.md5' -type f

2. Pour chacun de ces fichiers, faire une conversion DOS 2 UNIX (je veux convertir les fins de ligne). J'ai une erreur avec la commande dos2unix, mais a priori on peut faire des choses équivalentes avec sed. Point important et qui rend la commande plus délicate, je ne veux pas écraser le fichier original mais je voudrais en faire une copie, en ajoutant par exemple "_unix" AVANT l'extension du fichier.

Ex : si dans le dossier A j'ai plusieurs fichiers dont fileA1.md5 et dans le dossier B j'ai plusieurs fichiers dont fileB4.md5, je souhaite à la fin obtenir :
Dans le dossier A :
- fileA1.md5 (inchangé, CR/LF)
- fileA1_unix.md5 (LF)
Dans le dossier B :
- fileB4.md5 (inchangé, CR/LF)
- fileB4_unix.md5 (LF)

Comment puis-je faire ça ? J'ai essayé des choses à base de find -exec sans grand succès.
Par avance, merci pour votre aide !

#5 Re : -1 »  [Résolu]Rechercher des fichiers et les convertir en gardant l'original » Le 28/04/2012, à 14:09

thomine
Réponses : 3

Merci pingouinux, ça me semble pas mal du tout. J'ai une erreur avec la commande avec la commande dos2unix :

dos2unix: problems converting file test.md5

J'ai fait un test et ça vient du fait que je travaille sur mon NAS (~/.gvfs/music on 192.168.10.3). Je vais essayer de monter mon dossier différemment pour avancer. Je confirmerai le résultat.
Merci !

#6 Re : -1 »  [Résolu]Rechercher des fichiers et les convertir en gardant l'original » Le 28/04/2012, à 16:04

thomine
Réponses : 3

Merci à pingouinux, sa solution fonctionne. J'ai mis les lignes suivantes dans un fichier test.sh :

#!/bin/bash
shopt -s globstar nocaseglob

for fic in **/*.md5
do
   [ -f "$fic" ] || continue
   deb="${fic%.*}"
   fin="${fic##*.}"
   fic_unix="${deb}_unix.$fin"
   dos2unix -n "$fic" "$fic_unix"
done

J'ai résolu mon erreur dos2unix en montant mon dossier par NFS plutôt que SMB.

#7 -1 »  Unity:Perte de bords de fenêtre + écran noir sur vidéos en plein écran » Le 14/08/2011, à 15:52

thomine
Réponses : 3

Bonjour,

Je me décide à poster mon problème qui est pénible et pour lequel je ne trouve pas de solution.

Ma conf :
- Ubuntu Natty en 64 bits avec Unity (la source de mes problèmes ?).
- lspci |grep VGA => 01:00.0 VGA compatible controller: ATI Technologies Inc Juniper [Radeon HD 5700 Series], driver propriétaire activé.

Description du problème : au bout d'un certain temps d'utilisation :
- Il m'arrive de perdre la décoration de mes fenêtres (rarement).
- Et / ou je ne peux plus regarder de vidéo avec Totem (la fenêtre s'ouvre et se ferme instantanément). Avec VLC, au delà d'une fenêtre de 400 x 300 (je suis en 1920 x 1080), la vidéo disparaît et devient noire (problème qui se produit à chaque session).
- Sous Firefox, 1 fois sur 2 un clic droit, le menu contextuel apparaît et disparaît immédiatement (problème qui se produit à chaque session).
- J'ai l'économiseur d'écran GLMatrix, il se met à clignoter.

Si je fais un

unity --replace

, cela résout le problème de décoration des fenêtres et du menu contextuel dans Firefox, mais pas le problème des vidéos.

Voici le message d'erreur qui apparait quand je lance Totem en ligne de commande :

The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 102 error_code 2 request_code 133 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Avec VLC, le message d'erreur est :

xcb_xv debug: cannot put image: X11 error 2

Pour info, le "Ubuntu Unity Plugin" est activé dans le gestionnaire de conf de Compiz et je n'avais pas ce problème avant de passer à Natty (et à Unity ?).

Par avance, un grand merci pour votre aide. Je pense que je ne suis pas le seul à rencontrer ce problème mais il est difficile sur les forums de trouver une solution claire...

#8 Re : -1 »  Unity:Perte de bords de fenêtre + écran noir sur vidéos en plein écran » Le 01/09/2011, à 21:59

thomine
Réponses : 3

Up. Je relance mon sujet... Ce problème est vraiment pénible. Dès que j'ouvre quelques vidéos, le problème apparait...
Quelqu'un aurait-il une piste ?
Merci pour votre aide.
Note : si je me déconnecte et que je rouvre une session, ça me fait comme un reboot, le problème disparaît (jusqu'à la prochaine apparition...). Il doit y avoir un problème de mémoire vidéo ou un truc dans le genre...

#9 Re : -1 »  Unity:Perte de bords de fenêtre + écran noir sur vidéos en plein écran » Le 06/12/2011, à 20:56

thomine
Réponses : 3

Bonjour, je relance mon sujet car ce problème est toujours présent sous Oneiric et c'est très pénible.
Je perds mes bords de fenêtre, parfois, pour des raisons inexpliquées.
Voilà ce que je trouve dans /var/log quand l’événement se produit :

gtk-window-deco[2367]: segfault at 0 ip 000000000040cc22 sp 00007fff9fec1090 error 4 in gtk-window-decorator[400000+1c000]

Par avance, merci pour votre aide.

#10 Re : -1 »  Unity:Perte de bords de fenêtre + écran noir sur vidéos en plein écran » Le 15/12/2011, à 19:31

thomine
Réponses : 3

A priori mon problème est référencé ici : https://bugs.launchpad.net/ubuntu/+sour … bug/825407
Sauf que chez moi il se produit aussi aléatoirement, sans que j'aie pressé les touches ALT+SPACE.

#11 Re : -1 »  Probleme avec Wally » Le 02/11/2011, à 20:45

thomine
Réponses : 7

Bonjour,
J'ai le même problème avec Wally et je cherche une solution. J'ai l'impression que Wally fonctionne mais "derrière" le wallpaper Ubuntu. Je m'explique : sur l'icone Wally, si je fais "Photo suivante" et "Explorer la source", j'ai bien le dossier de mes photos qui s'ouvre. Par contre rien à l'écran, toujours le wallpaper Ubuntu.
Merci pour votre aide.

#12 Re : -1 »  Probleme avec Wally » Le 02/11/2011, à 20:52

thomine
Réponses : 7

C'est curieux j'ai le même problème : l'historique ne fonctionne pas, tout est blanc et impossible d'avoir des infos sur l'image. Par contre, avec "Explorer la source", il m'ouvre Nautilus dans un des dossiers que j'ai configuré comme source. Je suppose donc qu'il est bien capable de récupérer une image dans ce dossier.

#13 -1 »  [Résolu] Extraire un motif de fichiers répondant à un critère donné » Le 18/08/2011, à 10:28

thomine
Réponses : 17

Bonjour,

Avis aux spécialistes du script et de la recherche. Voici mon problème :

J'ai environ 50 000 fichiers HTML. Dans le header de ces fichiers, j'ai leur ID. Je souhaite récupérer l'ID de tous les fichiers qui contiennent une chaîne de caractères donnée.

L'objectif est que je puisse récupérer la liste de tous les ID (123456 dans l'exemple) quand le fichier contient CHAINE_A_TROUVER.

Voici un exemple (désolé pour le formattage, je n'arrive pas à poster un message avec des balises <>) :

--meta http-equiv="Content-Type" content="text/html; charset=UTF-8"--
--meta name="ID" content="123456"--
...
--head--
--body--
...
blabla
CHAINE_A_TROUVER
blabla
...

Au début je pensais faire ça en 2 temps :
1. Récupérer la liste de tous les fichiers qui contiennent la chaîne CHAINE_A_TROUVER. J'ai réussi à obtenir cette liste.
2. Extraire l'ID de tous les fichiers de la liste précédente. Là je commence à bloquer...
Finalement je me dis qu'on doit pouvoir tout faire d'un coup à l'aide de find, grep ou sed...

Je suis donc ouvert à 2 solutions :
- Celle qui me permettra d'extraire un motif des fichiers qui contiennent une chaîne donnée.
- Celle qui me permettra d'extraire un motif d'une liste de fichiers donnée.

Avis aux amateurs ! Merci pour votre aide !

#14 Re : -1 »  [Résolu] Extraire un motif de fichiers répondant à un critère donné » Le 18/08/2011, à 10:49

thomine
Réponses : 17

Bonjour survietamine,
Ils sont éparpillés dans plusieurs répertoires, j'ai une arborescence sur 4 - 5 niveaux.
Merci pour ton aide.

#15 Re : -1 »  [Résolu] Extraire un motif de fichiers répondant à un critère donné » Le 18/08/2011, à 14:10

thomine
Réponses : 17

Merci survietamine pour ton aide. Je suis en train de retravailler ta commande car l'expression régulière dans sed ne fonctionne pas. En fait je n'ai pas été assez précis dans ma demande car dans mon fichier HTML, j'ai plusieurs

meta name="xxx" content="yyy"

sur la même ligne. Autre point, mon ID n'est pas un nombre mais une chaîne de caractères. Il faut donc que j'extrais ce qu'il y a entre les 2 guillemets.
J'ai donc corrigé en :

sed -r 's/(^.*name="ID" content=")(.*)/\2/g'

C'est pas mal mais je ne sais pas comment supprimer tout ce qui se trouve après le guillemet de fin de content. Je regarde comment transformer mon (.*) en tout sauf un guillemet (car mon id contient du texte mais peut-être aussi des caractères spéciaux comme des accents...).

#16 Re : -1 »  [Résolu] Extraire un motif de fichiers répondant à un critère donné » Le 18/08/2011, à 15:38

thomine
Réponses : 17

Merci beaucoup survietamine pour ton aide. Effectivement ça m'arrive d'utiliser Excel pour manipuler des données.
J'ai trouvé une expression régulière qui me convient, la voici :

while read fichier ; do grep 'name="ID" content="' $fichier | sed -r 's/(^.*name="ID" content=")([^"]*)(.*)/\2/g' ; done < $ton_fichier_contenant_ta_liste

Dans sed, le groupe 1 contient tout ce qu'il y a avant l'ID, le groupe 2 contient l'ID, et le groupe 3 ce qu'il y a après l'ID. La difficulté étant de déterminer la fin de l'ID. Pour cela, j'accepte tous les caractères sauf le guillemet, ce qui permet de trouver la fin de l'ID.
Encore merci pour ton aide, ça m'a permis d'avancer plus vite et de me plonger dans la doc de sed !
Pour info, voici un bon site sur les expressions régulières : http://regexadvice.com/.
J'ai eu une expression régulière complexe à faire et j'ai eu la réponse dans la journée avec une explication détaillée.

#17 Re : -1 »  [Résolu] Extraire un motif de fichiers répondant à un critère donné » Le 19/08/2011, à 11:02

thomine
Réponses : 17

Merci AnsuzPeorth pour ta contribution. Elle est intéressante.
J'ai juste une erreur de syntaxe à l'exécution, sur le

done < <(printf '%s\n' /home/user/dossier/**/*)

Je ne comprends pas pourquoi et j'ai du mal à corriger car je ne comprends pas trop le "< <("*
Remarque, mon champ ID est a priori toujours à la même position sur la ligne, donc le découpage sur les " devraient fonctionner.

#18 Re : -1 »  [Résolu] Extraire un motif de fichiers répondant à un critère donné » Le 19/08/2011, à 11:53

thomine
Réponses : 17

Merci survietamine pour ta réponse mais je pense que l'erreur est sur les <<.
J'ai bien setté le globstar mais j'ai une erreur d'exécution:

Syntax error: redirection unexpected

#19 Re : -1 »  [Résolu] Extraire un motif de fichiers répondant à un critère donné » Le 19/08/2011, à 14:03

thomine
Réponses : 17

Super merci AnsuzPeorth, j'avais effectivement mis ça dans un script sh et je comprends mieux cette syntaxe, avec le printf en haut ! smile

#20 -1 »  Empathy ou Emesene : je ne reçois qu'1 seul message à la connexion » Le 17/04/2011, à 11:12

thomine
Réponses : 5

Bonjour,

Mes parents utilisent Emesene, j'utilise Empathy. Nous utilisons des comptes MSN. Mes parents m'envoient souvent des messages quand je suis déconnecté.
Lorsque je me connecte, je ne reçois que le 1er message qu'ils m'ont envoyé. Il faut que je me déconnecte puis reconnecte pour avoir le 2e message. Si je veux le 3e, même manège...

Est-ce que quelqu'un a déjà rencontré ce problème ? Est-il lié à Emesene ou Empathy ?
Si quelqu'un a une piste car c'est assez pénible...

Par avance, merci !

#21 Re : -1 »  Empathy ou Emesene : je ne reçois qu'1 seul message à la connexion » Le 17/04/2011, à 11:35

thomine
Réponses : 5

Merci Loy pour ta réponse. J'ai profité de mon PC Windows pour faire un autre test. Je me suis connecté avec Windows live messager et j'ai reçu tous les messages d'un coup. Donc le problème provient plutôt de Empathy qui ne récupère pas tous les messages. Peut-être un bug relativement simple (?), puisque si je me déconnecte et reconnecte, j'obtiens le 2e message...
S'il n'y a pas de solution miracle, je vais contourner le problème (temporairement j'espère) avec Meebo.

#22 Re : -1 »  Empathy ou Emesene : je ne reçois qu'1 seul message à la connexion » Le 19/04/2011, à 19:04

thomine
Réponses : 5

Merci Loy. J'ai regardé et il y a un bug ouvert sur le sujet depuis juin 2010. A priori ce n'est pas directement lié à Empathy mais je n'ai pas trouvé de solution... A suivre.
Source : https://bugs.launchpad.net/ubuntu/+sour … bug/600009

#23 -1 »  Logiciel SIMPLE pour représenter un terrain en 3D (pas de rendu) » Le 26/09/2010, à 11:25

thomine
Réponses : 2

Bonjour,

Je souhaite représenter mon terrain en 3D avec des courbes de niveau.
Mon terrain est en pente et j'aimerais avoir une idée claire des zones à aplanir, à remblayer, notamment pour placer une terrasse.
J'ai en tête de pouvoir faire une grille ou un maillage simple (une grille de 10 cases sur 10 serait suffisant je pense) pour voir si je fais une pente douce ou une butte après la terrasse par exemple.
Je suis même en train de me dire que je vais finir par faire ça sur Excel avec un graphe en 3d...
Je ne souhaite pas passer des journées à apprendre un logiciel complexe.
J'ai jeté un oeil sur ubuntu-fr et j'ai trouvé pas mal de choses mais rien ne me semble approprié à mon besoin : ARES, ARCAD, CYCAS, DraftSight, SketchUp, Art Of Illusion, Blender, k3d, Wings 3d...

Par avance, merci pour vos retours et vos idées.

#24 Re : -1 »  Logiciel SIMPLE pour représenter un terrain en 3D (pas de rendu) » Le 29/09/2010, à 18:34

thomine
Réponses : 2

Bonjour tcharlss,
Merci pour tes conseils et ta proposition de vidéo. J'hésite un peu à me lancer dans cet apprentissage... Si t'as 5 min pour faire une vidéo, je la regarderai avec plaisir et ça permettrait de voir où je mets les pieds.
En 2 - 3h, j'ai réussi à faire un petit truc avec Excel. J'ai utilisé un graphique surface 3D à partir d'un tableau où je mets l'altitude de points de mon terrain.
Encore merci à toi.