Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  corruption de donnée: md5 d'une grande quantité de fichiers » Le 27/06/2015, à 22:53

Autiwa
Réponses : 7

Bonjour,

Devenant parano sur la corruption de données ces derniers temps, j'ai viré mon RAID1 (miroir) pour faire une solution maison afin de m'assurer que les fichiers ne sont pas corrompus. En effet, il m'est déjà arrivé plusieurs fois de trouver un fichier .jpg "rose", signe de corruption, et ça me plait vraiment moyen. j'ai aussi appris récemment que le mirroring ne permettait absolument pas de se prémunir de la corruption de données.

En résumé, j'ai donc deux partitions, la normale, et une partition miroir, les deux en ext4.

Actuellement, je stocke la liste des sommes md5 de chaque fichier sur chacune des deux partitions, et je compare.

Petit soucis, j'utilise md5deep afin de produire le fichier, et il faut environ 6h (400 minutes) pour chaque partition.

Savez-vous si cette durée est optimisable, soit en changeant de soft, soit de technique?

Je peux poster mon script si ça aide, mais il est expérimental pour l'instant. Je suis aussi ouvert à d'autres suggestions concernant le problème de corruption.

Cordialement,
Autiwa

#1 Re : -1 »  corruption de donnée: md5 d'une grande quantité de fichiers » Hier à 10:17

Autiwa
Réponses : 7

Bonjour,

Merci de ta réponse !

En fait, j'ai eu quelques fichiers corrompus, dont des fichiers brut de mon reflex. Les corruptions me semblent faire partie du processus normal d'un disque dur, raison pour laquelle sur les serveurs, des solutions en RAID6 avec redondance sont mises en place.

De mon coté, avec md5deep, je ne saurais te répondre. En effet, hier j'ai lancé un test, et ça n'a pas fonctionné. J'utilise subprocess.Popen dans un script python pour lancer deux fois md5deep, une fois sur chaque partition. J'ai supposé que la limitation venait des i/O, et je me suis donc dit que je pourrais faire ça en 6 heures en tout (contre 12h si j'avais dû le faire en séquentiel). Mais j'ai eu des problèmes de buffer je crois, et je ne sais pas trop à quoi c'est dû puisque je redirige l'output directement dans la commande, il n'y a donc rien dans stdout et stderr de la commande Popen normalement.

Concernant les fichiers, j'en ai 230 000 environ. Beaucoup sont assez petits, quelques centaines de Ko. Quelques milliers sont autour de 20 Mo, et quelques centaines de gros fichiers (quelques centaines de Mo).

#2 Re : -1 »  corruption de donnée: md5 d'une grande quantité de fichiers » Aujourd'hui à 12:06

Autiwa
Réponses : 7

Effectivement, c'est une bonne remarque. Mais comme dit plus haut, rsync fait de la sauvegarde, il ne se préoccupe pas de la corruption de fichier. S'il existe déjà des logiciels qui font ce que je souhaite faire avec mon script, je suis preneur, bien entendu. Ça ne m'amuse pas de réinventer la roue, surtout quand ça roule pas.

Concernant mon script, je l'ai de nouveau fait tourner hier, et le md5deep bugue. Je ne sais pas pourquoi, mais il s'interromp en plein milieu, sans planter, juste, il attend indéfiniment. J'imagine que c'est un soucis avec subprocess.Popen (ou subprocess.call), mais pas trouvé de solution pour l'instant.

Si vous connaissez des logiciels qui font ça, je veux bien les noms en tout cas, moi j'ai pas trouvé. Mais je ne suis pas intéressé plus que ça par des logiciels qui font du versioning, parce que j'ai déjà 800Go de données, j'ai pas envie de tout faire exploser pour des versions qui ne m'intéressent finalement pas.

Les deux logiciels, rsnapshot et rdiff-backup ne me semblent pas gérer la corruption. Et c'est un peu mon problème. Il existe des tonnes de solution de sauvegarde, mais aucune n'aborde explicitement le problème de la corruption de données, ce qui est au final est la seule chose qui m'intéresse en fait.

#3 Re : -1 »  [Resolu] Disque dur externe passe lecture seule à la moindre opération » Le 13/06/2015, à 14:18

Autiwa
Réponses : 7

Merci de ta réponse.

Je n'ai pas essayé le montage manuel. Par contre, j'ai essayé de rajouter une ligne dans le /etc/fstab, pour contrôler comment il était monté (ce qui revient normalement au même), mais ça n'a rien changé.

Je vais tenter de le monter à la main, pour ce que j'ai à perdre.

La vérification du système de fichier est une bonne idée, je vais regarder comment on fait ça.

#4 -1 »  [Resolu] Disque dur externe passe lecture seule à la moindre opération » Le 13/06/2015, à 14:00

Autiwa
Réponses : 7

Bonjour,

Voilà bien longtemps que je n'avais pas posé de question Ubuntu !

J'ai rebranché récemment mon disque dur de Backup de 3To. Branché en eSata. Une seule partition, de 3To, en ext4. La table de partition est en GPT.

Il se monte, semble avoir tous les droits qu'il faut. Sauf que dès que je veux faire un truc dessus, il passe en lecture seule. Je ne comprends pas ce qu'il se passe, et il fonctionnait bien avant (il est vrai que ça fait plusieurs mois que je ne l'ai pas branché).

Chose intéressante, si je le débranche et rebranche, il conserve la lecture seule, alors que si je redémarre, il semble à nouveau correct, pour mieux replanter derrière (le fourbe).

Une demi journée que j'épluche les forums sans la moindre piste, je désespère un peu. Est-ce qu'un expert en disque aurait du temps à consacrer à mon problème?

D'avance merci du temps que vous passerez sur mon sujet.

#5 Re : -1 »  [Resolu] Disque dur externe passe lecture seule à la moindre opération » Le 13/06/2015, à 14:31

Autiwa
Réponses : 7

Bon.

Un

sudo mkdir /media/autiwa/Backup

puis

sudo chown autiwa: Backup

Et enfin

sudo mount -t ext4 /dev/sdd1 /media/autiwa/Backup

Semble fonctionner. mon script de backup sembler fonctionner maintenant.

Quant à la raison, je n'en ai aucune idée. C'est pas ultra pratique si je dois le monter à la main à chaque fois.

Sans être résolu (je ne comprends pas pourquoi), ça semble fonctionner, ce qui est un net progrès en soi !

Merci de ton aide !

#6 Re : -1 »  [Resolu] Disque dur externe passe lecture seule à la moindre opération » Le 15/06/2015, à 12:07

Autiwa
Réponses : 7

Merci de l'info. Il faudra que je teste en branchant de nouveau. C'est bizarre parce que le disque dur n'a quasiment jamais servi. Branché une dizaine de fois (pour des backup). Je penche plutôt pour le problème de montage, puisque manuellement, il s'est monté correctement et j'ai pu transférer. Reste que je n'ai pas compris pourquoi il faisait ça.

Concernant les messages du noyau, tu sais quel fichier c'est?

#7 Re : -1 »  Nautilus 3.10.1 Selection element par motif impossible » Le 29/03/2015, à 10:08

Autiwa
Réponses : 3

J'ai moi aussi ce problème, depuis plusieurs mois en fait. Quelqu'un a trouvé une explication depuis?

Apparemment c'est un bug connu depuis quelques temps, mais pas considéré comme prioritaire, donc une solution pourrait mettre beaucoup de temps à voir le jour.

Le nom de la fonction en anglais "select with pattern"

Lien vers les rapports de bugs :
https://bugs.launchpad.net/ubuntu/+sour … ug/1300308
https://bugs.launchpad.net/ubuntu/+sour … ug/1315896

Apparemment le soucis ne survient que dans le mode d'affichage "liste". Ce problème ne semble être présent que dans la version Ubuntu de Nautilus, et pas dans la version normale de Nautilus.

#8 Re : -1 »  Diablo 3 RoS sous ubuntu 14.04 » Le 18/07/2014, à 19:41

Autiwa
Réponses : 17

Une tour. Une carte mère Asus Z87-A pour accueillir la carte (HD radeon 4850 donc)

#9 Re : -1 »  Diablo 3 RoS sous ubuntu 14.04 » Le 18/07/2014, à 19:58

Autiwa
Réponses : 17

Il est vrai que j'ai installé battle.net et diablo III avec la version normale de playonlinux. Wine était déjà installé aussi.

Tu penses que désinstaller diablo et play on linux, puis réinstaller diablo en lançant play on linux en 32 bits peut jouer?

#10 Re : -1 »  Diablo 3 RoS sous ubuntu 14.04 » Le 18/07/2014, à 21:51

Autiwa
Réponses : 17

Raté, écran gris. Je te remercie pour ton aide malgré tout. Tant pis pour Diablo III.

#11 Re : -1 »  Diablo 3 RoS sous ubuntu 14.04 » Le 18/07/2014, à 19:35

Autiwa
Réponses : 17

Bonjour !

J'essaie de jouer à Diablo III, plus exactement à la démo (ça serait con d'acheter le jeu et ne pas pouvoir y jouer).

Pour celà, j'ai installé playonlinux des dépots, installé l'application via le launcher du site web, téléchargé les 25Gio et quelques.
Ma carte graphique est une Radeon HD 4850. J'utilise les pilotes libres.

J'ai le même soucis que toi quand je lance le jeu, c'est à dire un full screen gris indéfiniment.

J'ai même eu droit à un plantage à l'instant pour vérifier. J'ai dû tuer diablo via Ctrl + Alt + F1 puis revenir dans la session X.

Bref, je poste un message ici puisque nos soucis sont similaires. Mais ta solution ne fonctionne pas pour autant.

Quand je fais :

setarch i386 -3 playonlinux

J'ai quand même le gray screen of death.

Des idées, des pistes, n'importe quoi? Par défaut, je rend la carte à son propriétaire, je ne m'en achète pas, et je renonce jouer.

#12 Re : -1 »  Diablo 3 RoS sous ubuntu 14.04 » Le 19/07/2014, à 08:35

Autiwa
Réponses : 17

Ben le driver libre a fonctionné du premier coup, c'est juste pour le jeu que ça a pêché. Les drivers libre laissent à désirer pour les nvidia (voire n'existent pas), mais c'est l'inverse pour les ATI depuis que les pilotes ont été libérés.

Je me suis fait la même réflexion que toi pour les cartes avant d'acheter mon nvidia précédente. Je n'ai jamais eu autant d'emmerdes avec une carte. Pilote proprio mal intégré au système, qui n'a jamais reconnu mon écran correctement, et qui au fil des mises à jour n'a plus supporté ma carte (obligé de prendre un vieux pilote) parce qu'ils considéraient que ma carte était trop vieille.

Du coup je me suis dit "nvidia plus jamais". Mais les cartes graphiques sous linux, dès qu'on veut faire autre chose que de la bureautique, c'est la merde, et ça le restera sûrement. Tant pis.

#13 Re : -1 »  Lecteur carte mémoire transcend RDF8 usb 3.0 incompatible » Le 20/06/2014, à 10:46

Autiwa
Réponses : 11

Merci beaucoup pour l'info ! J'ai mis à jour sur un mac, je teste la connexion usb3 dès que possible.

[edit]
Ça marche parfaitement pour moi, j'ai pu transférer sans problèmes.
[/edit]

#14 -1 »  Git comparaison outputs de différentes révisions » Le 21/05/2014, à 17:02

Autiwa
Réponses : 0

Bonjour !

Pour le code que je développe, j'ai un dépot Git. Quand je modifie le code, il y a des versions (la majorité) qui ne sont pas censés modifier les résultats du code. J'ai donc créé un script de comparaison automatique des fichiers d'outputs afin de tracer d'éventuelles différences, signes d'un bug.

Or il y a aussi des révisions qui modifient les résultats du code (et c'est normal). Du coup, je cherche un moyen d'automatiser la comparaison du code, en allant chercher l'avant dernière (ou n'importe quel nombre de révision, ou une révision spécifique).

Existe-t-il un outil qui permette de faire ça automatiquement? Le dépot n'étant pas forcément synchronisé, et les modifications par forcément committés, il faut que ce soit comparé dans CE dépot Git. Je ne sais pas encore trop comment m'y prendre. Est-ce que certains d'entre vous se sont déjà posé des questions similaires?

Merci d'avance,

#15 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 29/04/2014, à 22:25

Autiwa
Réponses : 103

Je veux bien, mais je ne sais pas ce que c'est, et encore moins où trouver ça.

#16 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 29/04/2014, à 22:57

Autiwa
Réponses : 103

Service TAG :
3MJV6X1

Express Service Code :
789 397 088 5

#17 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 29/04/2014, à 23:15

Autiwa
Réponses : 103

A priori oui, c'est exactement ce pilote que j'ai, le même nom et cie.

Après téléchargement du pilote que tu as donné et comparaison des sommes md5, c'est exactement le même fichier.

#18 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 29/04/2014, à 23:36

Autiwa
Réponses : 103

Je viens de réinstaller le pilote après avoir débranché complètement l'imprimante. Une fois l'installation du pilote terminée, j'ai rebranché l'imprimante sur un port usb2.

J'ai tenté direct la détection du scanner dans le programme dell, sans succès. J'ai lancé simple scan, sans succès. J'ai ajouté l'imprimante, aucun soucis.

Mais toujours pas de scanner, et toujours qu'un seul icone dans le logiciel DELL.

#19 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 29/04/2014, à 23:51

Autiwa
Réponses : 103

Déjà conseillé plus haut, et déjà effectué.

J'ai envoyé un mail à Dell, assez drôle parce que rien de ce que je ne voulais écrire ne rentrait dans les cases, trop de caractères. On verra bien. J'espère qu'ils auront une solution à m'apporter.

#20 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 30/04/2014, à 21:21

Autiwa
Réponses : 103

Je viens d'installer le pilote sur mac, j'ai branché l'imprimante sur un port usb (port usb3, puisqu'il n'y a que ça sur le mac que j'ai sous la main), et j'ai pu imprimer et scanner sans problème.

Mais cet ordinateur n'est pas à moi, donc ça ne résous pas mon soucis.

J'ai un technicien de chez Dell avec qui j'interagis. Si jamais une solution est trouvée, je la posterai ici et clôturerai le sujet.

#21 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 30/04/2014, à 21:43

Autiwa
Réponses : 103

L'utilitaire s'appelle "Configurateur de Dell unified driver", et pour le lancer, je tape "dell" dans la barre de recherche Ubuntu.

Mais avec Sylvain3800 on a testé en ligne de commande pour voir si l'utilitaire ne renverrait pas des messages d'erreur.

Le chemin absolu vers l'utilitaire (installé avec le driver) est :

/opt/DELL/mfp/bin/Configurator
moko138 a écrit :

  Ce qui me sidère, c'est que même dans ta dernière tentative en usb2 (ton #65), dmesg renvoie le module xhci_hcd de l'usb3 :

Je n'en suis pas certain, mais il me semblait que sur ma carte mère, les ports usb2 étaient branché sur des switch usb3. Ça pourrait expliquer la confusion de dmesg.

#22 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 30/04/2014, à 23:02

Autiwa
Réponses : 103

1) "Configurator", ce nom fait penser à un installateur plus qu'à l'application  de scan proprement dite. Il serait intéressant de voir dans synaptic s'il n'y a pas d'autres binaires installés avec celui-là.

Ce logiciel ne permet pas de scanner, mais de détecter le scanner, ce qu'il ne fait pas.

La liste des logiciel est la suivante :

/opt/DELL/mfp/bin$ ls
Configurator      ImageManager.app  printertest      smfpscan
Configurator.app  netdiscovery      printertest.app  smfpscan.app
gettext           printeradd        shhv
ImageManager      printeradd.app    shhv.app

J'ai essayé de lancer smfpscan, mais il m'insulte "le périphérique ne peut être trouvé".

2) Et alors ? pas de messages du tout ???

Non, pas de messages du tout.

#23 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 01/05/2014, à 08:05

Autiwa
Réponses : 103

J'ai tout débranché sauf la souris et l'imprimante (oui, j'ai même débranché le clavier, vraiment le minimum).

J'ai redémarré, et après la connexion avec un clavier virtuel, j'ai testé le configurateur dell, simple scan et xsane. Aucun ne détecte le scanner.

PS : Pas d'autres manip's d'ici à dimanche soir, je pars en week-end.

#24 Re : -1 »  [Résolu] scanner non reconnu : Dell B1265dfw (multifonction) » Le 04/05/2014, à 18:52

Autiwa
Réponses : 103

Sylvain3800? Merci ! Ta dernière idée fonctionne parfaitement. J'ai simplement installé suld-configurator-2-qt4, j'ai lancé le configurateur, avec les 3 icônes. Il a détecté l'imprimante, puis il a détecté le scanner.

J'ai donc lancé simple scan, et j'ai pu scanner. J'ai pu aussi imprimer (j'avais désinstallé l'imprimante).

moko138, PPdM, alca94, merci de votre aide et de votre temps. Merci à vous tous pour le temps que vous avez passé à m'aider. Sans vous, je n'aurais pas pu scanner avec mon imprimante, ce qui gâche un peu le "multifonction" de l'imprimante que je viens d'acheter.

Un merci d'autant plus grand que Dell a conclu que le problème était clos en disant "ça ne vient pas de l'imprimante puisque vous avez pu scanner sur mac". Avec en implicite un magnifique "démerdez-vous".