Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  Raccourcis bureau » Le 12/06/2014, à 00:02

Arbiel
Réponses : 15

Bonsoir

Je ne sais pas répondre à ta première question ne connaissant absolument pas Eclipse.

Je te félicite d'avoir un iPad, et je te remercie de nous en avoir fait part. Mon téléphone fonctionne lui aussi parfaitement bien !! Et ta Rolex, elle te donne l'heure exacte ?

Pour créer un "pauv'" raccourci, il te suffit, une fois ton application lancée, de fixer dans la barre des lanceurs, celui qui y a été inséré. C'est effectivement extrêmement difficile, surtout lorsqu'on ne le sait pas et qu'il n'existe pas la moindre documentation pour en parler (façon d'écrire).

Ton clavier sera maintenu dans la disposition que tu as choisie si tu appliques la manipulation décrite ici..

Ubuntu n'a pas la prétention d'envahir les salons ; son coût est bien trop élevé.

Arbiel

#1 Re : -1 »  pavé tactile » Le 10/07/2014, à 15:22

Arbiel
Réponses : 2

Bonjour

Peut-être peux-tu analyser les différences dans la réponse à la commande

xinput --list --short

passée dans chacun des trois comptes.

#2 -1 »  Quelle est la signification de "env=C" devant une commande » Le 01/07/2014, à 18:47

Arbiel
Réponses : 5

Bonsoir à tous

J'essaie d'adapter un script dans lequel je trouve la commande suivante

env=C xinput list --short

Merci d'avance à qui voudra bien m'indiquer ce que ce "env=C" signifie.

Arbiel

#3 Re : -1 »  Quelle est la signification de "env=C" devant une commande » Le 06/07/2014, à 17:45

Arbiel
Réponses : 5

Bonjour

1) Non, je ne savais pas que l'initialisation d'une variable d'environnement pouvait se faire sans le recours à la commande env. Pour moi, la manière de faire était la suivante

man env a écrit :

NAME
       env - run a program in a modified environment

SYNOPSIS
       env [OPTION]... [-] [NAME=VALUE]... [COMMAND [ARG]...]

DESCRIPTION
       Set each NAME to VALUE in the environment and run COMMAND.

J'ai bien vu la commande de Zakhar

if LANG=C diff -s file1 file2 | grep -q identical; then echo "Identical"; fi

qui montre que "env" serait facultatif.

2) Par ailleurs "env" n'est pas, à ma connaissance, une variable d'environnement, toutes les variables d'environnement étant en majuscules. Dans la commande,

env=C xinput list --short

env n'est ni la commande env dont je parle en 1, ni une variable d'environnement.

Donc je pose à nouveau ma question : que signifie "env=C", qui me semble tout à fait différent de LANG=C ?

Arbiel

#4 Re : -1 »  Probleme installation Ubuntu (/dev/mapper) » Le 16/06/2014, à 21:35

Arbiel
Réponses : 1

Bonsoir

Sans pouvoir résoudre ton problème, je peux te dire que mapper est une couche logicielle qui s'intercale entre les applications et les disques pour masquer aux applications des structures spéciales telles que LVM ou le le chiffrage de partitions. Il est probable que, dans ton cas, la présence de mapper, qui se traduit par les /dev/mapper dont tu t'étonnes. tienne effectivement à tes partitions RAID-1.

Arbiel

#5 Re : -1 »  grub » Le 10/06/2014, à 12:19

Arbiel
Réponses : 7

Bonjour

Le rapport que tu publies ne présente aucun autre système que Windows

bootinfoscript en lignes 205 et suivantes a écrit :

=================== os-prober:
/dev/sda1:Windows 7 (loader):Windows:chain

os-prober inspecte les disques pour y rechercher les systèmes présents et il n'a trouvé que Windows.

D'autre part, ta demande d'aide n'est pas dans la bonne rubrique et tu risques ainsi de ne pas alerter les spécialistes les plus aptes à te venir en aide. Demande aux modérateurs de la déplacer.

Arbiel

#6 -1 »  Déchiffrer une partition amovible sans saisie du mot de passe » Le 11/06/2014, à 19:27

Arbiel
Réponses : 6

Bonjour à tous

Un clic sur le signet Nautilus d'une partition amovible chiffrée me demande la saisie du mot de passe pour me donner accès aux données et je souhaite me passer de cette saisie.

J'ai mis en œuvre PAM pour une partition permanente (présente à l'ouverture de ma session) et je voudrais utiliser la même technique pour la partition amovible. Je pense en effet que crypttab est exploitée au démarrage alors que le support amovible n'est bien sûr pas encore connecté.

Merci d'avance à quiconque voudra bien me mettre sur la voie.

Arbiel

#7 Re : -1 »  Déchiffrer une partition amovible sans saisie du mot de passe » Le 13/06/2014, à 12:14

Arbiel
Réponses : 6

Bonjour

Merci à vous deux pour votre intervention. Je ne connaissais aucune des deux pages dont vous m'avez donné la référence. Je n'en ai pas encore entièrement pris connaissance, le problème qui me préoccupe n'étant pas d'une très haute priorité.

J'ai néanmoins pris une première précaution, la sauvegarde de l'entête de mes partitions luks comme le suggère la page indiquée par Pascal34.

La solution présentée dans la page indiquée par Titouan me paraît, après un début de lecture rapide, répondre assez bien (en attendant une lecture plus attentive) à mes besoins. L'idée de cacher la clé de chiffrement dans un espace hors partition, entre le MBR et la première partition, me paraît intéressante, mais néanmoins risquée du fait de l'augmentation progressive et vraisemblablement constante de core.img (grub est installé sur tous mes disques amovibles). Pour être tranquille, il me faudrait donc agrandir cet espace ce qui peut demander un peu de temps.

Je vais y réfléchir.

Arbiel

#8 -1 »  [Résolu] indisponibilité des raccourcis "copier", "coller" » Le 10/06/2014, à 08:47

Arbiel
Réponses : 2

Bonjour

C'est avec grande surprise que je constate la suppression des raccourcis "CTRL+c" "CTRL+v" "CTRL+x" dans des applications telles que "Firefox" et "Terminal GNOME" ("CTRL+MAJ+c" "CTRL+MAJ+v").

Merci d'avance à quiconque voudra bien m'en expliquer la raison, si cette modification est intentionnelle de la part des développeurs, ou la cause, s'il s'agit d'une erreur de ma part.

Arbiel

#9 Re : -1 »  [Résolu] indisponibilité des raccourcis "copier", "coller" » Le 11/06/2014, à 18:44

Arbiel
Réponses : 2

Bonjour

J'ai réinstallé le terminal gnome et tout semble rentré dans l'ordre.

Merci pour ton intervention.

Arbiel

#10 -1 »  Interprétation de la clé com.canonical… favorites » Le 10/06/2014, à 12:58

Arbiel
Réponses : 0

Bonjour

gsettings get com.canonical.Unity.Launcher favorites a écrit :

['application://thunderbird.desktop', 'application://nautilus-home.desktop', 'application://firefox.desktop', 'application:///home/remi/Bureau/wifi.desktop', 'application://ubuntu-software-center.desktop', 'application://simple-scan.desktop', 'application://synaptic.desktop', 'application://Launchpadlaunchpadnet.desktop', 'unity://running-apps', 'application://vlc.desktop', 'unity://expo-icon', 'unity://devices']

On constate deux types de références ; "application://" et "unity://"

Les références en "application://" pointent soit vers des lanceurs mémorisés dans /usr/share/applications lorsque suit le nom du fichier lanceur (p.e. : 'application://thunderbird.desktop'), soit n'importe où dans la hiérarchie des fichiers lorsque suit l'adresse absolue du lanceur (p.e. : 'application:///home/remi/Bureau/wifi.desktop')

Qu'en est-il de unity:// ?

Merci d'avance pour les explications ou la référence d'un document explicatif.

Arbiel

#12 -1 »  Points de montage en /media » Le 01/06/2014, à 12:17

Arbiel
Réponses : 9

Bonjour à tous

Je constate, avec une certaine stupeur et une complète incompréhension des raisons qui ont pu la motiver. une  importante modification entre la 12.04 et la 14.04 dans la définition automatique (par double clic sur un signet dans le panneau latéral de nautilus) des points de montage /media.

Le point de montage d'une partition "partition" , anciennement
/media/partition
est en effet devenu
/media/${USER}/partition.
Cette modification entraîne la nécessité de modifier tous les objets qui font une référence explicite à un dossier ou à un fichier localisé dans une partition montée de cette façon.

Qu'en pensez-vous ?

Arbiel

#13 Re : -1 »  Points de montage en /media » Le 01/06/2014, à 23:56

Arbiel
Réponses : 9

Bonsoir à vous deux

Tout d'abord merci pour vos commentaires.

Je comprends l'idée de la modification. Mais je ne monte pas systématiquement toutes mes partitions fixes, et en particulier les partitions de sauvegarde (que j'ai en "double" sur des disques amovibles),  Ce qui m'amène à penser à mes procédures de sauvegarde qui incluent des liens "statiques" vers des partitions amovibles.

Ces partitions fixes non montées, je viens de les inclure dans fstab avec l'option "noauto" et un double clic dans le panneau latéral de nautilus les monte en effet en /media/partition comme avant, ce qui résout mon problème. Je vais faire de même pour mes partitions amovibles de sauvegarde.

Arbiel

#14 Re : -1 »  Points de montage en /media » Le 02/06/2014, à 15:26

Arbiel
Réponses : 9

Au cas où d'autres seraient intéressés, la même solution fonctionne pour des partitions chiffrées

sudo blkid a écrit :


/dev/sdb5: UUID="8357f4d4-7d39-4c35-8497-117bc0e007a7" TYPE="crypto_LUKS"

/dev/mapper/luks-8357f4d4-7d39-4c35-8497-117bc0e007a7: LABEL="DonnM-CM-)es" UUID="9c634541-ed0b-4d75-b822-ae6d3102c2af" TYPE="ext4"

cat /etc/fstab a écrit :


LABEL=Données /media/Données ext4 defaults,noauto

La partition /dev/sdb5 se retrouve bien montée en

/media/Données

Arbiel

#15 Re : -1 »  Points de montage en /media » Le 05/06/2014, à 11:16

Arbiel
Réponses : 9

En fait, après quelques jours, le montage des partitions chiffrées me paraît aléatoire. Après avoir constaté que ma partition se retrouvait en
/media/${USER}/Données
j'ai modifié fstab

cat /etc/fstab | grep /media/Données a écrit :

#LABEL=Données /media/Données ext4 defaults,noauto
UUID=e8240157-8580-4fde-9d3c-591bd2e97884 /media/Données ext4 defaults,noauto    0     0

Au(x) premier(s) essai(s), la partition s'est retrouvée montée en /media/Données, mais ce n'est plus le cas

mount | grep Données a écrit :

/dev/mapper/luks-8357f4d4-7d39-4c35-8497-117bc0e007a7 on /media/remi/Données type ext4 (rw,nosuid,nodev,uhelper=udisks2)

Arbiel

#16 Re : -1 »  Points de montage en /media » Le 05/06/2014, à 14:21

Arbiel
Réponses : 9

Non, je ne crois pas que l'UUID de la partition déchiffrée change d'un déchiffrement à l'autre. Je viens de le vérifier à l'occasion de 4 arrêts et redémarrages successifs, mais ce n'est bien sûr pas une preuve. En tout état de cause, l'étiquette de la partition déchiffrée, elle ne change pas puisque je la retrouve soit en /media/Données soit en /media/${USER}/Données.

J'ai à nouveau modifié mon fichier fstab avec

/dev/mapper/luks-8357f4d4-7d39-4c35-8497-117bc0e007a7 /media/Données ext4 defaults,noauto    0     0

Pour l'instant, le montage se fait correctement, mais pour combien de temps ?

Arbiel

#17 -1 »  [Résolu] Calc se plante à la suppression ou à la modification d'un nom » Le 03/06/2014, à 01:06

Arbiel
Réponses : 3

Bonsoir

La .version que j'utilise est

libreoffice --version a écrit :

LibreOffice 4.2.3.3 420m0(Build:3)

Que faire pour éviter cette erreur ?

Arbiel

#18 Re : -1 »  [Résolu] Calc se plante à la suppression ou à la modification d'un nom » Le 03/06/2014, à 12:16

Arbiel
Réponses : 3

Bonjour Dude

Effectivement, la 4.2.4 résout le problème, bien que

libreoffice --version a écrit :

Le programme 'libreoffice' n'est pas encore installé. Vous pouvez l'installer en tapant :
sudo apt-get install libreoffice-common

Sais-tu comment compléter l'installation pour résoudre ce petit problème ?

Arbiel

#19 Re : -1 »  [Résolu] Calc se plante à la suppression ou à la modification d'un nom » Le 05/06/2014, à 10:31

Arbiel
Réponses : 3

Bonjour

Le lancement en ligne de commande se fait par

libreoffice4.2 --…
libreoffice4.2 --version a écrit :

LibreOffice 4.2.4.2 63150712c6d317d27ce2db16eb94c2f3d7b699f8

Arbiel

#20 -1 »  [Résolu] Clavier azerty gravé en dur ? » Le 01/06/2014, à 01:00

Arbiel
Réponses : 9

Bonsoir à tous

J'utilise le clavier bépo et n'ai pas installé le clavier traditionnel azerty dans mon système. Or je viens de constater
1) que le raccourci clavier Ctrl+Alt+t (j en azerty) n'ouvre pas de terminal (je dois utiliser la touche marquée "t" du clavier physique cad le "è" de bépo)
2) lors du démarrage, l'ouverture de ma partition chiffrée n'a pu se faire qu'en entrant mon mot de passe en azerty et non en bépo.
Je n'avais pas ce problème avec la 12.04.

Quelqu'un a-t-il une idée de ce qui se passe ?

Arbiel

#21 Re : -1 »  [Résolu] Clavier azerty gravé en dur ? » Le 01/06/2014, à 10:51

Arbiel
Réponses : 9

Bonjour

Merci pour ton conseil.

Non, je n'ai rien vérifié et je ne sais pas où se trouve la configuration Xorg, ni comment la vérifier. Merci de me donner quelques précisions.

Au présent démarrage, je n'ai cependant pas eu le problème : j'ai saisi le mot de passe de ma partition chiffrée et j'ai pu ouvrir un terminal en bépo.

Arbiel

#22 Re : -1 »  [Résolu] Clavier azerty gravé en dur ? » Le 01/06/2014, à 23:33

Arbiel
Réponses : 9

Bonsoir

La disposition du clavier me semble aleatoire tantot bepo tanto qwerty (et non pas azerty comme je l ai initialement cru) et pour l instant il est qwerty

Je n ai pas de fichier /etc/X11/xorg.conf

Mon fichier /etc/default/keyboard contient

# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="bepo"
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

Par contre j ai egalement installe une disposition grec polytonique

Et je viens d'avoir l'idée de basculer vers cette disposition grec polytonique puis de revenir au clavier français, qui maintenant est bien bépo.

Il semblerait donc qu'au démarrage la disposition soit aléatoirement qwerty ou bépo. Par contre, lorsque je reviens au clavier français avec le contrôle en haut à droite dans la barre de menu, la disposition est bien bépo.

Que puis-je faire pour remédier à cette situation, c'est-à-dire pour que la disposition au démarrage soit bien mon clavier français (et par conséquent bépo) ?

Arbiel

#23 Re : -1 »  [Résolu] Clavier azerty gravé en dur ? » Le 02/06/2014, à 16:09

Arbiel
Réponses : 9
ibus -setup a écrit :

-setup n'est pas une commande connue !
Utilisation : ibus COMMANDE [OPTION…]

Commandes :
  engine         Définir ou obtenir le moteur
  exit           Quitter ibus-daemon
  list-engine    Afficher les moteurs disponibles
  watch          (Non développé)
  restart        Redémarrer ibus-daemon
  version        Afficher la version
  read-cache     Afficher le contenu du cache du registre
  write-cache    Créer le cache du registre
  address        Afficher l'adresse D-Bus de ibus-daemon
  help           Afficher cette information

???

Ceci dit, je viens de constater la situation suivante ; au démarrage, lors de la saisie des mots de passe, pour le montage de ma partition chiffrée comme pour l'ouverture de ma session utilisateur, la disposition était bépo, puis, une fois la session ouverte, elle s'est retrouvée basculée en qwerty.

Mais elle ne me semble pas être systématiquement en bépo pour la saisie des mots de passe, sauf à ce que j'aie involontairement utilisé, avant la saisie du premier mot de passe, une combinaison de touches qui l'ait fait basculer de bépo à qwerty.

Arbiel

#24 Re : -1 »  [Résolu] Clavier azerty gravé en dur ? » Le 02/06/2014, à 23:55

Arbiel
Réponses : 9

J'avais effectivement invoqué la commande ibus avec l'"option" -setup et j'aurai dû analyser un peu plus en détail ton message ainsi que le message d'erreur ce qui m'aurait permis de comprendre tout seul mon erreur.

J'indiquerai "résolu" dans quelques jours après avoir constaté une gestion de mon clavier conforme à ce qu'elle doit être.

Encore merci pour ton aide.

Arbiel