Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 2

#0 Re : -1 »  Canon LBP2900 sur Kubuntu 12.04 64bits » Le 08/01/2013, à 15:41

yk
Réponses : 37

Dans mon cas je suis avec une ubuntu 12.04 x86_64
sauf que

$ sudo apt-get install gnome-keyring:i386

The following packages have unmet dependencies:
 gnome-keyring:i386 : Depends: libcap-ng0:i386 but it is not going to be installed
                      Depends: libgck-1-0:i386 (>= 2.91.1) but it is not going to be installed
                      Depends: libgcr-3-1:i386 (>= 3.2.2) but it is not going to be installed

Pour remedier a cela j ai installé getlibs
(http://askubuntu.com/questions/127848/w … -pkcs11-so)

$ wget https://launchpad.net/~jcollins/+archive/jaminppa/+build/1482994/+files/getlibs_2.06-0ubuntu1%7Eppa2_all.deb
$ sudo dpkg -i getlibs_2.06-0ubuntu1~ppa2_all.deb

Puis  gnome-keyring:i386 ( installé ds /usr/lib32 )

$ sudo getlibs -p gnome-keyring:i386

et enfin crééun lien symbolique

$ sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so  /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so

voila, j en suis pas plus loin avec l installation de ma lbp3000
jai compilé les deb et installé les driver 2.5 obtenu la
http://support-au.canon.com.au/contents … 59602.html

mais toujours pas d impression
Yk

#1 Re : -1 »  Canon LBP2900 sur Kubuntu 12.04 64bits » Le 09/01/2013, à 15:41

yk
Réponses : 37

Salut

J'ai suivi le tuto pour une lbp3000
en commencant par la http://doc.ubuntu-fr.org/tutoriel/insta … _canon_lbp
puis avec celui la http://doc.ubuntu-fr.org/imprimante_canon_capt2

eh ben figurez vous que ca fonctionne ( pas encore avec libreoffice cela dit).

dur a dire parmi ce que j ai fait depuis le debut de l install ce qui a été nécéssaire, superflux, inutile voir compliquant.
ca fonctionne donc avec les driver 64 compilés sur ma machine en version 2.5
je n avait pas reussi a compiler ceux en 2.4 en suivant un tuto en anglais qui indiquait les meme modifs a faire avant de lancer le dkpg-buildpackage.

bref temps d install entre 6 et 8h mais le coup des lib ia32 ... j lavais pas vu venir.
Cela dit je comprends pas trop pourquoi ils sont necessaires si je compile moi meme les drivers.

En tout cas fabux, murex et les autres contribs merci pour ces tutos ce sont les plus complets que j ai vus.
Bonne chance a ceux qui les suivent,
et bonne année a tous
yk