Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  Dell XPS 13 » Le 28/02/2014, à 21:00

kikislater
Réponses : 70

Ça dépend des perceptions ... 13 pour moi c'est ok

#1 Re : -1 »  Dell XPS 13 » Le 01/03/2014, à 10:17

kikislater
Réponses : 70

Et un écran externe ne serait pas mieux ?

#2 Re : -1 »  Dell XPS 13 » Le 02/03/2014, à 11:42

kikislater
Réponses : 70

13" en déplacement dans l'avion ou dans le train c'est l'idéal. Si c'est pour utiliser dans un autre espace la question ne se pose pas.
Le xps 13 est une bonne bécane mais le processeur est bridé : U => ultra low voltage et du coup le chipset graphique également.

C'est pour faire tourner quoi comme application 3d?

Le xps 13 à mon avis tu peux modéliser mais pour le rendu vu que ça prend du temps, mieux vaut avoir un desktop à côté et faire les traitements/rendus sur le desktop !

#3 Re : -1 »  Dell XPS 13 » Le 02/03/2014, à 12:23

kikislater
Réponses : 70

Au final je dirais que pour de la modélisation, les intels fonctionnent bien mais pour du calcul 3d, il faut plus puissant. Après les calculs se font souvent sur le cpu et non sur le gpu même si c'est en train de changer ...

#4 Re : -1 »  Dell XPS 13 » Le 07/03/2014, à 16:03

kikislater
Réponses : 70

smile
Bon choix

#5 Re : -1 »  Dell XPS 13 » Le 08/03/2014, à 22:44

kikislater
Réponses : 70

Ah oui ce délai !

#6 Re : -1 »  Catia V5 sous linux grâce à wine ! » Le 03/04/2014, à 19:11

kikislater
Réponses : 126

Concrètement : changer ton environnement de bureau. Ne plus utiliser Unity qui bouffe de la 3D et forcer à utiliser ton ATI en lieu et place de l'intel

#7 Re : -1 »  Catia V5 sous linux grâce à wine ! » Le 03/04/2014, à 21:15

kikislater
Réponses : 126

Il faudrait tester dans ce cas via wine direct et/ou aussi un jeu via wine

#8 Re : -1 »  Catia V5 sous linux grâce à wine ! » Le 04/04/2014, à 14:43

kikislater
Réponses : 126

Quelques infos ici :
http://appdb.winehq.org/objectManager.p … &iId=28516

Ensure you are installing Catia V5R20 on a 64 bits Wine prefix.

Default wine prefix created with PlayOnLinux is 32 bits environnement and 64 bits is available too, but only by browsing configuration menu.

#9 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 10:31

kikislater
Réponses : 146
symba a écrit :

oups en effet, merci je 'avais pas fait attention à l'absence du b

J'ai donc refait les manips, mais le résultat n'est pas bon sad

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet « qgis » n'est pas installé, et ne peut donc être supprimé
Le paquet « gdal-bin » n'est pas installé, et ne peut donc être supprimé
Le paquet « grass » n'est pas installé, et ne peut donc être supprimé
Le paquet « libgdal1 » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libjs-underscore libqgis1.8.0 libspatialindex1 linux-headers-3.8.0-27
  linux-headers-3.8.0-27-generic linux-image-3.8.0-27-generic
  linux-image-extra-3.8.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 68 non mis à jour.

et quand je réinstalle qgis:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 qgis : Dépend: libgdal1 (>= 1.8.0) mais ne sera pas installé
        Dépend: qgis-providers (= 1.8.0-3~raring1) mais ne sera pas installé
        Recommande: qgis-plugin-grass mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
apt-cache policy qgis*

#10 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 11:08

kikislater
Réponses : 146
symba a écrit :

J'ai supprimé pas mal de paquets par synaptic, en cherchant libgdal1, j'ai vu qu'il y avais un libgdal1h installé en version1.10 et que le libgdal1 qui ne veut pas s'intaller est en 1.9.
J'ai donc supprimé le ligdal1h et avec lui synaptic m'en a proposé toute une liste, j'ai tout enlevé, et là j'ai pu réinstaller qgis, qui fonctionne de nouveau.

Par contre, j'ai tellement nettoyé que je n'arrivais plus à ouvrir mes ecw sad (.ecwn'est pas une source de donnée raster gérée)
J'ai installé libgdal ecw et il m'ouvre les ecw donc tout va bien désormais j'espère wink

Je crois que mon problème avait un lien avec les versions 1.10.
Là j'ai tout en 1.9 et ça fonctionne


pour info voici le résultat de "apt-cache policy qgis*"

python-qgis-common:
  Installé : (aucun)
  Candidat : 1.8.0-3~raring1
 Table de version :
     1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.8.0-2~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
libqgis-core1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis:
  Installé : 1.8.0-3~raring1
  Candidat : 1.8.0-3~raring1
 Table de version :
 *** 1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
qgit:
  Installé : (aucun)
  Candidat : 2.4-1
 Table de version :
     2.4-1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
qgis-plugin-grass-common:
  Installé : 1.8.0-3~raring1
  Candidat : 1.8.0-3~raring1
 Table de version :
 *** 1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.8.0-2~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
python2.7-qgis:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
python-qgis:
  Installé : (aucun)
  Candidat : 1.8.0-3~raring1
 Table de version :
     1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
qgis-plugin-globe:
  Installé : (aucun)
  Candidat : 1.8.0-3~raring1
 Table de version :
     1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
     1.8.0-2~raring6 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
libqgis1-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-providers:
  Installé : 1.8.0-3~raring1
  Candidat : 1.8.0-3~raring1
 Table de version :
 *** 1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
qgis-sqlanywhere:
  Installé : (aucun)
  Candidat : 1.8.0-3~raring1
 Table de version :
     1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
qgis-mapserver:
  Installé : (aucun)
  Candidat : 1.8.0-3~raring1
 Table de version :
     1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
qgis-common:
  Installé : 1.8.0-3~raring1
  Candidat : 1.8.0-3~raring1
 Table de version :
 *** 1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.8.0-2~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
qgis-sqlanywhere1.7.0:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-sqlanywhere1.7.1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-sqlanywhere1.7.5:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
qgis-sqlanywhere1.8.0:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-plugin-grass:
  Installé : (aucun)
  Candidat : 1.8.0-3~raring1
 Table de version :
     1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.8.0-2~raring8 0
        100 /var/lib/dpkg/status
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
qgis-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-api-doc:
  Installé : (aucun)
  Candidat : 1.8.0-3~raring1
 Table de version :
     1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.8.0-2~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
libqgis0:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libqgis1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libqgis1.4.0-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libqgis1.7.5:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status
libqgis1.8.0:
  Installé : 1.8.0-3~raring1
  Candidat : 1.8.0-3~raring1
 Table de version :
 *** 1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
libqgis1.9.0:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
     1.9.90~ppa33 0
        100 /var/lib/dpkg/status
qgis-plugin-globe-common:
  Installé : 1.8.0-3~raring1
  Candidat : 1.8.0-3~raring1
 Table de version :
 *** 1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.8.0-2~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
qgis-providers-common:
  Installé : 1.8.0-3~raring1
  Candidat : 1.8.0-3~raring1
 Table de version :
 *** 1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.8.0-2~raring1 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
libqgis-dev:
  Installé : (aucun)
  Candidat : 1.8.0-3~raring1
 Table de version :
     1.8.0-3~raring1 0
        500 http://qgis.org/debian/ raring/main amd64 Packages
     1.8.0-2~raring12 0
        500 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
libqgis-gui1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :

Ben du coup tu peux refaire un

apt-cache policy qgis*

Une fois qgis installé

Puis

apt-cache policy libecwj2

Ensuite

ls /usr/lib/gdalplugins/1.10

Ton install est bizarre tu avais un reste de qgis 1.7.5 d'installé ...

#11 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 12:01

kikislater
Réponses : 146
symba a écrit :

Par contre je ne peux plus installer python-qgis sad
Il me met "réparez d'abord les paquets cassés"

Si j'essaie l'installation de python-qgis-common, là il veut bien mais en supprimant qgis et libgdal1... Je ne comprend rien.

Ah ben oui c'est normal tu mélanges les dépôts qgis.org et ceux du ppa ubuntu !

Redonne ton sources.list en faisant :

cat /etc/apt/sources.list

et

ls /etc/apt/sources.list.d/

#12 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 12:21

kikislater
Réponses : 146
symba a écrit :

Ah ok, si c'est logique c'est déjà ça ^^

voilà les résultats:

symba@symbaPC:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ dists/precise/main/binary-i386/

# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ raring main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ raring-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ raring universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring universe
deb http://fr.archive.ubuntu.com/ubuntu/ raring-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ raring multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ raring-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu raring-security main restricted
deb-src http://security.ubuntu.com/ubuntu raring-security main restricted
deb http://security.ubuntu.com/ubuntu raring-security universe
deb-src http://security.ubuntu.com/ubuntu raring-security universe
deb http://security.ubuntu.com/ubuntu raring-security multiverse
deb-src http://security.ubuntu.com/ubuntu raring-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu raring partner
# deb-src http://archive.canonical.com/ubuntu raring partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu raring main
deb http://qgis.org/debian raring main
# deb-src http://qgis.org/debian raring main
deb-src http://extras.ubuntu.com/ubuntu raring main
deb http://riderducoin.com/ubuntu1/ precise main
# deb-src http://riderducoin.com/ubuntu1/ precise main
symba@symbaPC:~$ ls /etc/apt/sources.list.d/
domenico-martella-alcacoop-ppa-precise.list
domenico-martella-alcacoop-ppa-precise.list.save
libreoffice-libreoffice-4-0-raring.list
libreoffice-libreoffice-4-0-raring.list.save
ubuntugis-ubuntugis-unstable-precise.list
ubuntugis-ubuntugis-unstable-precise.list.distUpgrade
ubuntugis-ubuntugis-unstable-precise.list.save
ubuntugis-ubuntugis-unstable-raring.list
ubuntugis-ubuntugis-unstable-raring.list.save

Il faut que tu commentes cette lignes du sources.list :

deb http://qgis.org/debian raring main

Tu sais le faire ? Si tu ne sais pas voici la manip :
Tu tapes cette commande :

gksudo gedit /etc/apt/sources.list

Un mot de passe en mode graphique t'es demandé, un éditeur de texte s'affiche à l'écran.
Tu vas à la ligne où il y a donc ça :

deb http://qgis.org/debian raring main

et  tu mets un # devant. La ligne devient donc :

# deb http://qgis.org/debian raring main

Tu enregistres et tu fermes l'éditeur de texte.

Tu recharges les paquets :

sudo apt-get update

Suppression de qgis

sudo apt-get remove ligdal1 qgis grass gdal-bin

Puis réinstallation

sudo apt-get install qgis

#13 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 14:26

kikislater
Réponses : 146
symba a écrit :

Je retrouve la même erreur sad

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 qgis : Dépend: qgis-providers (= 1.8.0-2~raring12) mais ne sera pas installé
        Dépend: qgis-common (= 1.8.0-2~raring12) mais 1.8.0-3~raring1 devra être installé
        Recommande: qgis-plugin-grass mais ne sera pas installé
        Recommande: python-qgis mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

C'est parce qu'il reste des paquets du dépôt qgis.org d'installé ...
Refait un

sudo apt-get update 

puis

apt-cache policy qgis*

#14 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 14:54

kikislater
Réponses : 146
symba a écrit :

Sous synaptic, quand je tape qgis, voilà ce qu'il me restait d'installé:

qgis-common
qgis-plugin-globe-common
qgis-plugin-grass-common
qgis-providers-common

J'ai tout supprimé par synaptic et relancé l'installation de qgis par sudo apt-get install qgis

Du coup tout fonctionne désormais wink

Merci du retour !
Évite de mélanger ces deux dépôts à l'avenir ils ont des dépendances non complémentaires comme tu as pu le voir ...

#15 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 15:08

kikislater
Réponses : 146
symba a écrit :

Oui merci beaucoup pour ton aide.
Une fois qu'on a compris le conflit ça va mieux, mais j'avais du mal à identifier ce que relève d'un dépôt ou d'un autre.
Du coup il vaut mieux que je supprime carrément mon dépôt qgis dans synaptic?

Edit: en fait le dépôt est déjà décoché.

Tu peux le supprimer carrement oui. De toute façon avec ce dépôt tu fais une croix sur l'ecw donc vu que pour toi c'est primordial tu peux le supprimer ...

#16 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 19/09/2013, à 15:36

kikislater
Réponses : 146

Ah tiens, la v2.0 est sur le ppa en effet !

Je veux bien la réponse de ça :

gdalinfo --formats | grep ECW
apt-cache policy gdal-bin
apt-cache policy gdal
apt-cache policy libgdal-ecw
apt-cache policy libgdal-ecw-src
ls /usr/lib/gdalplugins
ls /usr/src/

#17 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 19/09/2013, à 20:00

kikislater
Réponses : 146

Il manque du  coup le :
apt-cache policy qgis*

#18 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 19/09/2013, à 21:27

kikislater
Réponses : 146
sudo apt-get remove libqgis1.8.0 libqgis

Pour ta version de qgis il ne propose pas la 2.0 dans ta configuration. Tu peux refaire un

sudo apt-get update 

et renvoyer le résultat de apt-get update et de apt-cache policy qgis

#19 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 20/09/2013, à 10:47

kikislater
Réponses : 146

Tu as donc supprimé le dépôt du ppa !
Allez hop on reprend depuis le début :

# 1 - Installation de la lib ECW 3.3
cd /tmp/
wget -c http://www.riderducoin.com/ubuntu1/pool/main/libe/libecwj2/libecwj2_3.3-3_i386.deb
sudo dpkg -i libecwj2_3.3-3_i386.deb
sudo ldconfig


# 2 - Ajout du dépôt PPA UBUNTUGIS
sudo add-apt-repository -y ppa:unbuntugis-unstable
sudo apt-get update
sudo apt-get install -y qgis libgdal-ecw-src

# 3 - Compilation automatique de la lib ecw pour gdal
sudo gdal-ecw-build /usr

# 4 - Vérification du support ecw dans gdal 
gdalinfo --formats | grep ECW

Tu le renvoies chaque étape et je te dirais si ça bloque ou pas

#20 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 20/09/2013, à 15:47

kikislater
Réponses : 146

Euh en effet j'ai mal tapé le dépôt !
Il faut que tu supprimes celui que je t'ai fait rajouté unbuntugis au lieu de ubuntugis...


# 2 - Ajout du dépôt PPA UBUNTUGIS
sudo add-apt-repository -y ppa:ubuntugis-unstable
sudo apt-get update
sudo apt-get install -y qgis libgdal-ecw-src

#21 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 20/09/2013, à 17:52

kikislater
Réponses : 146
Manush a écrit :

en fait j'ai tout un tas de ppa gis-unstable dans le gestionaire de mises à jour mais ils sont décochés donc ne devraient pas poser de pbs ?

le résultat de sudo add-apt-repository -y ppa:ubuntugis-unstable :

Error reading https://launchpad.net/api/1.0/~ubuntugis-unstable/+archive/ppa: Not Found

celui de sudo apt-get update :

Réception de : 1 http://security.ubuntu.com raring-security Release.gpg [933 B]
Atteint http://extras.ubuntu.com raring Release.gpg                            
Atteint http://archive.canonical.com raring Release.gpg                        
Ign http://ppa.launchpad.net raring Release.gpg                                
Atteint http://fr.archive.ubuntu.com raring Release.gpg                        
Réception de : 2 http://security.ubuntu.com raring-security Release [40,8 kB]  
Atteint http://extras.ubuntu.com raring Release                                
Atteint http://archive.canonical.com raring Release                            
Ign http://ppa.launchpad.net raring Release                                    
Atteint http://fr.archive.ubuntu.com raring-updates Release.gpg                
Atteint http://fr.archive.ubuntu.com raring-backports Release.gpg              
Atteint http://extras.ubuntu.com raring/main Sources                           
Atteint http://archive.canonical.com raring/partner i386 Packages              
Réception de : 3 http://security.ubuntu.com raring-security/main Sources [42,1 kB]
Atteint http://fr.archive.ubuntu.com raring Release                            
Atteint http://extras.ubuntu.com raring/main i386 Packages                     
Atteint http://fr.archive.ubuntu.com raring-updates Release                    
Réception de : 4 http://security.ubuntu.com raring-security/restricted Sources [14 B]
Atteint http://fr.archive.ubuntu.com raring-backports Release                  
Réception de : 5 http://security.ubuntu.com raring-security/universe Sources [9 279 B]
Atteint http://fr.archive.ubuntu.com raring/main Sources                       
Réception de : 6 http://security.ubuntu.com raring-security/multiverse Sources [2 266 B]
Atteint http://fr.archive.ubuntu.com raring/restricted Sources                 
Réception de : 7 http://security.ubuntu.com raring-security/main i386 Packages [109 kB]
Atteint http://fr.archive.ubuntu.com raring/universe Sources                   
Atteint http://fr.archive.ubuntu.com raring/multiverse Sources                 
Atteint http://fr.archive.ubuntu.com raring/main i386 Packages                 
Réception de : 8 http://security.ubuntu.com raring-security/restricted i386 Packages [14 B]
Atteint http://fr.archive.ubuntu.com raring/restricted i386 Packages           
Réception de : 9 http://security.ubuntu.com raring-security/universe i386 Packages [37,1 kB]
Atteint http://fr.archive.ubuntu.com raring/universe i386 Packages             
Réception de : 10 http://security.ubuntu.com raring-security/multiverse i386 Packages [3 864 B]
Atteint http://fr.archive.ubuntu.com raring/multiverse i386 Packages           
Ign http://archive.canonical.com raring/partner Translation-fr_FR              
Atteint http://security.ubuntu.com raring-security/main Translation-en         
Ign http://extras.ubuntu.com raring/main Translation-fr_FR                     
Ign http://archive.canonical.com raring/partner Translation-fr                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-fr                
Ign http://extras.ubuntu.com raring/main Translation-fr                        
Ign http://archive.canonical.com raring/partner Translation-en                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-en                
Ign http://extras.ubuntu.com raring/main Translation-en                        
Err http://ppa.launchpad.net raring/main i386 Packages                         
  404  Not Found
Atteint http://security.ubuntu.com raring-security/multiverse Translation-en   
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-fr   
Ign http://ppa.launchpad.net raring/main Translation-fr_FR              
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-en   
Ign http://ppa.launchpad.net raring/main Translation-fr                 
Ign http://ppa.launchpad.net raring/main Translation-en                 
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-fr   
Atteint http://security.ubuntu.com raring-security/restricted Translation-en   
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-en          
Atteint http://fr.archive.ubuntu.com raring/universe Translation-fr            
Atteint http://security.ubuntu.com raring-security/universe Translation-en     
Atteint http://fr.archive.ubuntu.com raring/universe Translation-en            
Atteint http://fr.archive.ubuntu.com raring-updates/main Sources               
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Sources         
Atteint http://fr.archive.ubuntu.com raring-updates/universe Sources           
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Sources         
Atteint http://fr.archive.ubuntu.com raring-updates/main i386 Packages         
Atteint http://fr.archive.ubuntu.com raring-updates/restricted i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-updates/universe i386 Packages     
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-updates/main Translation-en        
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/universe Translation-en    
Atteint http://fr.archive.ubuntu.com raring-backports/main Sources             
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/universe Sources         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/main i386 Packages       
Ign http://security.ubuntu.com raring-security/main Translation-fr_FR          
Atteint http://fr.archive.ubuntu.com raring-backports/restricted i386 Packages 
Ign http://security.ubuntu.com raring-security/main Translation-fr             
Atteint http://fr.archive.ubuntu.com raring-backports/universe i386 Packages   
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr_FR    
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse i386 Packages 
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr       
Ign http://security.ubuntu.com raring-security/restricted Translation-fr_FR    
Ign http://security.ubuntu.com raring-security/restricted Translation-fr       
Atteint http://fr.archive.ubuntu.com raring-backports/main Translation-en      
Ign http://security.ubuntu.com raring-security/universe Translation-fr_FR      
Ign http://security.ubuntu.com raring-security/universe Translation-fr         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/universe Translation-en  
Ign http://fr.archive.ubuntu.com raring/main Translation-fr_FR                 
Ign http://fr.archive.ubuntu.com raring/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr
246 ko réceptionnés en 33s (7 441 o/s)
W: Impossible de récupérer http://ppa.launchpad.net/ubuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

et celui de sudo apt-get install -y qgis libgdal-ecw-src :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgdal-ecw-src est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 qgis : Dépend: libgdal1 (>= 1.9.0) mais ne sera pas installé
        Dépend: libqgis1.7.5 mais ne sera pas installé
        Dépend: qgis-providers (= 1.7.4+1.7.5~20120320-1.1) mais ne sera pas installé
        Recommande: qgis-plugin-grass mais ne sera pas installé
        Recommande: python-qgis mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Ouais pardon encore manque de rigueur c'est ça :

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable

#22 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 20/09/2013, à 18:10

kikislater
Réponses : 146

Tu as ça qui n'est pas bon :

W: Impossible de récupérer http://ppa.launchpad.net/ubuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

C'est la mauvaise ligne que je t'ai donné. Pour le nettoyer, tu peux redonner :

ls /etc/apt/sources.list.d/

#23 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 21/09/2013, à 19:22

kikislater
Réponses : 146

Il reste une manip !

Donc le plus simple :

sudo rm -rf /etc/apt/sources.list.d/ubuntugis*
sudo rm -rf /etc/apt/sources.list.d/unbuntugis*
sudo apt-get update
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable 
sudo apt-get update 

Et voilà ce sera fini

#24 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 08/10/2013, à 16:15

kikislater
Réponses : 146
bonuscad a écrit :

Bonjour,
Bonjour,
Juste un remerciement particulier à kikislater pour ce fil sur les ECW, il m'a permis (non sans mal) à rendre effectif la lecture des ECW sous QGis 2.0 sous un un environnement Xubuntu 12.04 LTS.

Question (bien que tout soit fonctionnel), est ce normal que seule la commande apt-cache policy gdal ne me renvoie rien? (N: Impossible de trouver le paquet gdal)
C'est juste par curiosité...

Merci encore, car j'aurais bien été incapable de mettre ceci en place sans ce fil de discussion.

big_smile

Oui le paquet s'appelle gdal-bin et non plus gdal c'est un méta paquet : https://launchpad.net/ubuntu/+source/gdal

Donc si tu fais

apt-cache policy gdal-bin 

tu devrais avoir une réponse ou encore

apt-cache policy gdal*

Je suis content que certaines personnes puissent utiliser apt-cache policy à présent. Est-ce de ma faute ou pas ?