Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  TVDownloader: télécharger les médias du net ! » Le 27/08/2012, à 19:42

DoUPod
Réponses : 2858

Bonjour,

Je viens de découvrir ce logiciel qui m'a l'air fort utile.

J'essaye de récupérer une vidéo sur Arte+7. Seulement, il n'y a pas moyen de lister les vidéos disponibles sur Arte+7 via tvdownloader (liste des fichiers vides). Pourtant, d'autres sites fonctionnent (M6Replay par exemple).

Voici la sortie lorsque lancé en console :

Traceback (most recent call last):
  File "/usr/lib/python2.7/logging/__init__.py", line 846, in emit
    msg = self.format(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 723, in format
    return fmt.format(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 464, in format
    record.message = record.getMessage()
  File "/usr/lib/python2.7/logging/__init__.py", line 328, in getMessage
    msg = msg % self.args
TypeError: not all arguments converted during string formatting
Logged from file APIPrive.py, line 253
Traceback (most recent call last):
  File "/usr/share/tvdownloader/APIPrive.py", line 251, in pluginRafraichir
    self.listePluginActif[nomPlugin].rafraichir()
  File "plugins/W9Replay.py", line 51, in rafraichir
    page = urllib.urlopen( self.urlFichierXML )
  File "/usr/lib/python2.7/urllib.py", line 86, in urlopen
    return opener.open(url)
  File "/usr/lib/python2.7/urllib.py", line 207, in open
    return getattr(self, name)(url)
  File "/usr/lib/python2.7/urllib.py", line 344, in open_http
    h.endheaders(data)
  File "/usr/lib/python2.7/httplib.py", line 954, in endheaders
    self._send_output(message_body)
  File "/usr/lib/python2.7/httplib.py", line 814, in _send_output
    self.send(msg)
  File "/usr/lib/python2.7/httplib.py", line 776, in send
    self.connect()
  File "/usr/lib/python2.7/httplib.py", line 757, in connect
    self.timeout, self.source_address)
  File "/usr/lib/python2.7/socket.py", line 553, in create_connection
    for res in getaddrinfo(host, port, 0, SOCK_STREAM):
IOError: [Errno socket error] [Errno -2] Nom ou service inconnu
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found
ERROR   Navigateur : Not Found

Comment puis-je résoudre ce problème ?

Merci

#1 -1 »  Logiciel de lecture de fichiers audio (équivalent iTunes) ? » Le 04/02/2013, à 21:35

DoUPod
Réponses : 2

Bonjour,

Je suis récemment passé sous Linux. Sous Windows, j'utilisais iTunes pour gérer ma bibliothèque musicale (ordonnée par dossiers Artiste/Album/...). Je ne cherche pas particulièrement à garder une interface similaire sous Linux.

J'ai testé Rhythmbox pour l'instant, mais j'ai un problème :
J'ai des pistes qui sont au format flac, mp3 ou m4a. Mais quand j'ai les pistes au format flac, je les ai en double en mp3 (pour synchroniser avec mon baladeur). Le problème, c'est que Rhythmbox m'importe tout dans sa bibliothèque, quelque soit le format. Sous iTunes, je décochais les pistes mp3 pour ne pas les lire, mais je n'ai pas trouvé de fonction similaire sous Rhythmbox. (pour l'instant, j'ai tout dans un dossier et j'ai donné ce dossier à manger à Rhythmbox en lui disant de surveiller le dossier.
De plus, j'ai également des fichiers pdf à côté de mes fichiers audio (booklets) et d'autres types de fichiers qui me font des erreurs d'importation à chaque démarrage de Rhythmbox. Y a-t-il moyen de les exclure définitivement de la bibliothèque ?

Merci !

P.S. : Une dernière chose : quand j'importais des fichiers musicaux dans iTunes, il se chargeait tout seul de les copier au bon endroit et de les renommer en suivant le modèle Artiste/Album/Pistes. Est-ce de même pour Rhythmbox ?

#3 -1 »  Licence ? » Le 16/01/2013, à 15:08

DoUPod
Réponses : 6

Bonjour,

Je m'y perd un peu dans toutes les licences libres et aurait besoin de vos lumières...

J'ai écrit un programme (en C) que je souhaiterais distribuer sous licence zlib/libpng ( http://opensource.org/licenses/zlib-license.php ).

Seulement, dans ce programme, j'utilise les bibliothèques FFTW (sous licence GPL) et OpenCV (sous licence BSD).

Tout cela est-il compatible (sachant que je ne distribue que mon code source et qu'il faut donc les bibliothèques en plus pour compiler) ?

Merci

#4 Re : -1 »  Licence ? » Le 17/01/2013, à 15:10

DoUPod
Réponses : 6

Donc si j'ai bien compris :
La FFTW est sous licence GPL, OpenCV est sous licence BSD.

Mon projet peut être sous licence zlib/libpng sans problème car compatible GPL et BSD. Et mon projet restera sous licence zlib/libpng ?

Car j'avais cru comprendre (mais surement à tort) que si une licence était compatible GPL et incluait une partie sous GPL, l'ensemble se trouvait sous GPL...

Merci

#5 Re : -1 »  Licence ? » Le 17/01/2013, à 17:39

DoUPod
Réponses : 6

Ok. Donc comme je ne redistribue pas les bibliothèques avec mon programme, pas de problème. Mon code peut donc rester sous licence zlib.

Merci !

#6 Re : -1 »  Licence ? » Le 19/01/2013, à 14:41

DoUPod
Réponses : 6

Ok.

Quelqu'un pourrait-il me confirmer cela svp ? smile

Merci !

#7 -1 »  Authentification via keyfile ? » Le 23/12/2012, à 00:29

DoUPod
Réponses : 4

Bonjour,

Mes disques durs sont cryptés et automatiquement montés au boot via cryptsetup. J'utilise un keyfile stocké sur une clé USB pour les décrypter au boot.

Mon problème est que du coup, je n'ai pas envie de rentrer un mot de passe pour ouvrir ma session. Je pourrais certes opter pour la connexion automatique, mais il me reste alors un mot de passe à entrer pour déverrouiller le trousseau de clé (Gnome-keyring)... et dans ce cas, autant entrer un mot de passe pour ouvrir la session car ça revient au même (et non, je ne veux pas supprimer le mot de passe de Gnome-Keyring).

Je cherche donc à faire une des deux choses suivantes :
- Soit déverrouiller le trousseau de clé de Gnome-keyring via un keyfile (ce qui ne me paraît pas évident)
- Soit ouvrir automatiquement une session via un keyfile sur ma clé USB. J'ai vu qu'il y avait des scripts pour PAM pour ouvrir une session via reconnaissance faciale etc. mais je n'ai rien trouvé concernant les keyfiles. Quelqu'un aurait-il une idée ?

Merci

edit modo : déplacement. Pas de demandes d'aide dans Trucs, astuces et scripts utiles.

#8 Re : -1 »  Authentification via keyfile ? » Le 23/12/2012, à 19:49

DoUPod
Réponses : 4

Pas d'accord avec la solution du trousseau sans mot de passe. Dans ce cas, mes mots de passe sont stockés en plain text (certes, chiffrés sur le disque mais déchiffrés lors de l'utilisation).

Si je mets un mot de passe au trousseau de clé, le fichier est inexploitable et les mots de passe déchiffrés sont stockés en mémoire ce qui fait que, sauf faille, seul l'utilisateur root et certains logiciels peuvent accéder à cette zone de la mémoire. Aucun problème de sécurité a priori.

Si je ne mets pas de mot de passe, n'importe quelle application peut envoyer mon fichier de mot de passe (on a déjà vu des applications comme Skype récupérer pas mal de données, pourquoi pas les mots de passe) et alors le fichier est pleinement exploitable, qu'il soit chiffré ou non sur le disque dur.

Le chiffrement du disque empêche juste de récupérer les fichiers si le système n'est pas monté.

#9 Re : -1 »  Authentification via keyfile ? » Le 23/12/2012, à 20:51

DoUPod
Réponses : 4

Disons que tant qu'à chiffrer le disque, autant que ce ne soit pas au détriment de la sécurité globale. Je considère personnellement que le stockage des mots de passe est le plus critique.

Je vais regarder ce que je peux faire avec pam_script.

Si quelqu'un a plus d'infos, je suis preneur. smile

#10 -1 »  [Routeur] Un routeur avec 2 ports USB ? » Le 26/09/2012, à 22:53

DoUPod
Réponses : 4

Bonjour,

Je souhaiterais partager plusieurs disques durs sur mon réseau local (au moins deux).

Les NAS sont très chers et je cherche une solution à moindre coût... J'ai donc pensé utiliser un routeur avec des ports USB. Mais je n'ai pas trouvé grand chose, la majorité n'ayant qu'un seul port USB...

1) Est-il possible d'utiliser un hub pour brancher deux disques durs sur un port USB du routeur (avec openWRT ou le firmware officiel) ?
2) Connaissez-vous des routeurs qui conviennent à faible prix ?

Merci !

#11 Re : -1 »  [Routeur] Un routeur avec 2 ports USB ? » Le 30/09/2012, à 14:06

DoUPod
Réponses : 4

Je vais regarder du côté des mini-Pc type raspbery pi.

Merci

#12 -1 »  [Gnome Shell] Changer le calendrier pour l'applet calendrier ? » Le 11/09/2012, à 18:47

DoUPod
Réponses : 1

Bonjour,

L'applet de calendrier de Gnome utilise evolution. Or je préfère utiliser Thunderbird avec le plugin Lightning.

J'ai pu changer l'application qui s'ouvre lorsqu'on clique sur ouvrir le calendrier (pour ouvrir Thunderbird). Mais :
1/ Je n'ai pas trouvé comment forcer Thunderbird à s'ouvrir sur Lightning (comme la commande evolution -c ...)
2/ Je n'ai pas trouvé comment utiliser le calendrier de Mozilla Thunderbird (Lightning) à la place de celui d'Evolution. Y a-t-il un moyen pour faire apparaître ce calendrier dans l'applet ?

Merci

#13 -1 »  Adresse IP dynamique -> passage en ipv6 ? » Le 01/09/2012, à 16:33

DoUPod
Réponses : 4

Bonjour,

J'héberge un petit serveur chez moi. N'ayant pas d'adresse ip(v4) fixe, je ne peux pas envoyer de mail et suis donc obligé de passer par un smtp relais ainsi que par un dynhost.

En revanche, je viens de voir que mon FAI (SFR) me proposait dans l'interface de la box d'activer la connectivité ipv6.

D'après ce que j'ai compris, ça me permettrait d'avoir une adresse différente pour chaque poste derrière ma neufbox, accessible depuis le net. Il faut donc obligatoirement avoir un pare-feu bien configuré sur chaque poste.

Mais, je n'ai trouvé aucune info sur mon problème d'ip dynamique. Est-ce que ça résoudrait le problème ? Ou mon serveur ne pourra-t-il communiquer qu'avec ses "semblables" en ipv6 ?

Merci

#14 Re : -1 »  Adresse IP dynamique -> passage en ipv6 ? » Le 01/09/2012, à 18:05

DoUPod
Réponses : 4

J'ai déjà un service équivalent à DynDNS (DynHOST chez OVH). Ma question n'est pas là.

Mon problème est de savoir si le passage à ipv6 serait bénéfique, en particulier pour héberger un serveur de mail.

#15 Re : -1 »  Adresse IP dynamique -> passage en ipv6 ? » Le 01/09/2012, à 19:22

DoUPod
Réponses : 4

Pour l'instant, j'ai déjà tout ça smile

Serveur en ipv4 (locale) fixe -> box SFR -> ip dynamique -> DNS de mon domaine chez OVH mis à jour via un champ DynHost (comme DynDNS).

#16 -1 »  [Résolu] Vhost par défaut pour Apache ? » Le 26/08/2012, à 14:56

DoUPod
Réponses : 4

Bonjour,

J'ai un nom de domaine et j'ai créé différents vhosts pour avoir des sous-domaines sur mon serveur (blog.domaine.tld www.domaine.tld etc).

Mais comment puis-je définir un vhost par défaut ? Car si le vhost correspondant au sous-domaine n'est pas défini (et que je suis sur mon réseau local, donc pas un problème de DNS), c'est le premier vhost actif par ordre alphabétique qui est servi...

Merci

#17 Re : -1 »  [Résolu] Vhost par défaut pour Apache ? » Le 29/08/2012, à 16:53

DoUPod
Réponses : 4

Pas bête ! Même si c'est pas très propre...

Faute de mieux, je vais faire ça. Mais, personne n'a d'autres solutions ? smile

#18 Re : -1 »  [Résolu] Vhost par défaut pour Apache ? » Le 30/08/2012, à 20:13

DoUPod
Réponses : 4

Ok, merci.

Sujet résolu smile

#19 -1 »  [Résolu] Problème avec wget + https ? » Le 26/08/2012, à 15:04

DoUPod
Réponses : 7

Bonjour,

J'ai un problème avec wget en https, qui ne peut pas vérifier un certificat (mauvais nom d'hôtes). Mais je n'ai pas ce problème sur mes autres postes.

La configuration du site en https a récemment changé et mes autres postes s'y sont connectés après.

Je me demande donc si ce n'est pas un problème de cache (ayant eu le même problème avec firefox et l'ayant résolu en vidant le cache).

Mais existe-t-il un cache pour wget ? et comment le vider ?

Merci

#20 Re : -1 »  [Résolu] Problème avec wget + https ? » Le 27/08/2012, à 13:41

DoUPod
Réponses : 7

J'ai déjà regardé l'option no-check-certificate. Mais elle ne me convient pas vraiment... J'aimerais résoudre le problème vraiment.

Plus d'infos :
- J'ai un PC (serveur) qui doit lancer

wget https://sousdomaine.domaine.tld/unepagequelconque

via cron à intervalles réguliers (la page à télécharger via wget est sur ce même serveur).
- Sur ce même PC, j'héberge plusieurs sous-domaines (mais un seul domaine) donc j'ai plusieurs vhosts Apache. Et pour chaque vhosts Apache, j'ai un certificat SSL différent.

Si je lance le wget depuis n'importe quel autre PC de mon réseau ou de l'extérieur, je n'ai aucun problème.

Par contre, si je lance la commande depuis le serveur, wget ne récupère pas le bon certificat (à chaque fois il prend le certificat du premier solus-domaine par ordre alphabétique... ce qui pose problème).

Merci

#21 Re : -1 »  [Résolu] Problème avec wget + https ? » Le 28/08/2012, à 12:16

DoUPod
Réponses : 7

Justement, c'est ce que je pensais, jusqu'à ce que je teste avec un autre PC (sur le réseau local et à l'extérieur du réseau local) :
- Connexion via Firefox -> aucun problème, les certificats affichés sont bien les bons (pas d'erreur de certificat, et j'ai vérifié) et tout fonctionne.
- Même commande wget lancée : aucun problème !

C'est donc un problème que je n'ai qu'en local sur le serveur !

#22 Re : -1 »  [Résolu] Problème avec wget + https ? » Le 29/08/2012, à 16:52

DoUPod
Réponses : 7

Voici le fichier dans le dossier correspondant au vhost qui pose problème :

<VirtualHost *:80>
        ServerAdmin webmaster@example.org
        ServerName leed.example.org

        DocumentRoot /home/www/leed/

        <Directory /home/www/leed/>
                Options -Indexes FollowSymLinks -ExecCGI -Includes
                AllowOverride all
                Order allow,deny
                allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        TransferLog ${APACHE_LOG_DIR}/access.log

        Redirect permanent / https://leed.example.org
</VirtualHost>

<VirtualHost *:443>
        ServerAdmin webmaster@example.org
        ServerName leed.example.org

        DocumentRoot /home/www/leed/

        SSLEngine on
        SSLProtocol all -SSLv2
        SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM

        SSLCertificateFile /etc/apache2/ssl/leed.crt
        SSLCertificateKeyFile /etc/apache2/ssl/leed.key

        SSLCertificateChainFile /etc/apache2/ssl/sub.class1.server.ca.pem
        SSLCACertificateFile /etc/apache2/ssl/ca.pem
        SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown

        <Directory /home/www/leed/>
                Options -Indexes FollowSymLinks -ExecCGI -Includes
                AllowOverride all
                Order allow,deny
                allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        TransferLog ${APACHE_LOG_DIR}/access.log
</VirtualHost>

Tous mes fichiers vhosts ont la même forme. Seul le ServerName change.

#23 Re : -1 »  [Résolu] Problème avec wget + https ? » Le 29/08/2012, à 20:06

DoUPod
Réponses : 7

Je crois que j'ai une partie de la réponse :
J'utilise un certificat SSL différent par VirtualHost, ce qui a été introduit (relativement) récemment, apparemment.

Or wget est en version 1.12.2-1 sur mon serveur et 1.14 sur mes autres PC. C'est donc dû à cela...

En attendant une mise à jour des dépôts, je vais utiliser --no-check-certificate...

Merci

#24 Re : -1 »  Serveur mail et IP dynamique ? » Le 23/08/2012, à 18:01

DoUPod
Réponses : 4

Ok. Au vu de ta réponse et de mes recherches, je pense que la meilleure solution est de passer par un relais.

Dans ma box, je peux désactiver le blocage du port 25. J'ai donc le choix entre 2 serveurs SMTP : celui que j'ai avec mon nom de domaine chez OVH et celui de SFR (qui n'est pas smtp.sfr.fr mais smtp.neuf.fr ...). Je pense utiliser celui d'OVH qui me parait plus sûr (disponibilité, taille des pièces jointes...).

Je n'ai pas besoin de réglages fins, tout mon courrier devant passer par le smtp relais (sinon SPAM / Courrier refusé).

Je vais donc utiliser la méthode a. Je vais essayer de mettre ça en place smile