Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  Backup d'un backup... » Le 21/03/2015, à 04:15

oliver2004
Réponses : 4

Bonjour à tous,
J'utilise rdiff-backup pour faire les backups des infos de mon serveur.
Ce backup je le fais sur ma machine, mais je souhaite faire un deuxième backup chez moi sur un DD externe, j'ai donc un script qui devrait me permettre de le faire mais j'ai un souci car le backup plante:

Fatal Error: File /home/olivier/Documents/.backup_server_interne/konqueror_db_backups does not look like an increment file.

Try restoring from an increment file (the filenames look like
"foobar.2001-09-01T04:49:04-07:00.diff").

J'ai donc un peu cherché et cela est dû au sous dossier rdiff-bacup-data qui se trouve dans le dossier de destination. J'ai beau exclure ce dossier lors de la tentative de backup, rien à faire, ça plante. Du coup, en changeant le nom du dossier à la main au coup par coup, le backup fonctionne. Mais il me faut ensuite renommer le dossier pour éviter des problèmes lors du prochain backup sur ma machine... pas top...

J'avais pensé à pouvoir placer ce dossier dans un sous-dossier pour que rdiff-backup n'interprète pas le dossier comme un dossier de backup ou mieux, cacher ce dossier d'office... est ce possible?

Si quelqu'un a une solution... je suis preneur... smile

Bien à vous et merci d'avance

#1 Re : -1 »  Backup d'un backup... » Le 24/03/2015, à 23:48

oliver2004
Réponses : 4
le cinglé_001 a écrit :

Bonjour.

Là tu n'indiques que l'erreur mais pas ton script donc tu n'auras pas beaucoup de réponses si tu ne postes pas la totalité de ton script.

Bonjour, le cinglé_001,
Oui, effectivement, voici mon script:

#!/bin/sh

# Backup incrémentiel
nice -n 19 rdiff-backup --force ~/Documents/.backup_server_interne/dossier /media/backups_externes/dossier && nice -n 19 rdiff-backup --force --remove-older-than 3D /media/backups_externes/dossier

Donc du coup, quand je change le nom de rdiff-backup-data, ça marche, sinon, ça me lance l'erreur indiquée plus haut...

#2 -1 »  Problème de formatage » Le 09/03/2015, à 13:53

oliver2004
Réponses : 4

Bonjour,
J'ai hérité d'un disque dur endommagé (les héritages sont pas toujours ce qu'on pense, lol)
Du coup. j'ai tenté de le formater à l'aide de Gestionnaire de partitions de KDE (Version 1.0.3), d'abord en ext4, puis ext3, puis ntfs en dernier recours et apparemment ça capote à chaque fois.
Voici l'erreur:

Gestionnaire de fichiers a écrit :

Gestionnaire de partitions de KDE : rapport sur l'opération
Date :     09/03/2015 06:48
Version de programme :     1.0.3
Version de LibParted :     2.3
Version de KDE :     4.11.97
Machine :     Linux olivier-Inspiron-3442 3.13.0-46-generic #77-Ubuntu SMP Mon Mar 2 18:23:39 UTC 2015 x86_64
ID utilisateur :     0

Créer une nouvelle table de partitions sur « /dev/sdc »
Tâche : Créer une nouvelle table de partitions sur le périphérique « /dev/sdc »
Créer une nouvelle table de partitions sur le périphérique « /dev/sdc » : Erreur
Créer une nouvelle table de partitions sur « /dev/sdc » : Erreur

Bref, il y a t'il un espoir ou dois-je abandonner ce DD?

#3 Re : -1 »  Problème de formatage » Le 09/03/2015, à 16:36

oliver2004
Réponses : 4
αjet a écrit :

smartmontools (http://doc.ubuntu-fr.org/smartmontools) peut t'aider à diagnostiquer l'état de santé de ton disque. S'il présente des signes de fatigues, c'est quand même pas très rassurant, à ta place j’abandonnerais.

Merci pour vos interventions, du coup je vais l'installer, bonne nouvelle par contre, j'ai réussi à formater le périphérique au final (j'ai juste retenté et ça a marché! smile), du coup, smartmontools a l'air intéressant je vais en profiter pour tester ce logiciel et voir quel est le diagnostique pour ce disque.
Merci à vous

#4 Re : -1 »  Problème de formatage » Le 09/03/2015, à 17:11

oliver2004
Réponses : 4

Ben non, le disque marche toujours pas... du coup, oui, il a l'air fatigué, je crois que j'abandonne... neutral

#5 -1 »  [Résolu] Impossible de monter un disque dur externe » Le 05/03/2015, à 23:41

oliver2004
Réponses : 9

Bonjour à tous, j'ai des soucis pour monter un DD via un script shell
Je suis sous Kubuntu, version 14.04 LTS
Le disque se monte correctement via Dolphin, il est donc opérationnel, j'ai cependant besoin de le monter via un script shell qui va gérer des backups sur ce disque.

J'essaye en ligne de commande ceci:

olivier@olivier-Inspiron-3442:~$ sudo mount -t ext4 28f49890-77cb-40fc-a5cc-80de6f9ff007 /media/backups_externes
[sudo] password for olivier: 
mount : le périphérique spécial 28f49890-77cb-40fc-a5cc-80de6f9ff007 n'existe pas

alors qu'avec un

olivier@olivier-Inspiron-3442:~$ ls -l /dev/disk/by-uuid
total 0 
lrwxrwxrwx 1 root root 10 mar  5 16:22 28f49890-77cb-40fc-a5cc-80de6f9ff007 -> ../../sdc1
olivier@olivier-Inspiron-3442:~$

C'est bizarre non?
Une idée

#6 Re : -1 »  [Résolu] Impossible de monter un disque dur externe » Le 06/03/2015, à 00:53

oliver2004
Réponses : 9

Bonsoir Braun,
Sur le fstab genre ceci?

UUID=28f49890-77cb-40fc-a5cc-80de6f9ff007 /media/backups_externes           ext4    defaults        0       0

#7 Re : -1 »  [Résolu] Impossible de monter un disque dur externe » Le 06/03/2015, à 18:25

oliver2004
Réponses : 9

Bonjour à tous,
Voilà, j'ai donc opté pour dans mon fstab ceci:

UUID=28f49890-77cb-40fc-a5cc-80de6f9ff007 /media/backups_externes           ext4    noauto,user 0       0

car avec l'option default, au démarrage le système me demandait s'il fallait lancer car le disque n'existait pas, du coup, c'était pas idéal, avec noauto,user, le disque ne se monte pas par défaut mais avec le script (et le système se lance sans warning comme il se doit).

Sur le script je monte maintenant simplement avec ceci:

mount /media/backups_externes

Bien sûr, le dossier /media/backups_externes existe avec des droits d'écriture...

Bien le merci à vos interventions, tellement utiles, comme d'habitude smile
Je vous souhaite à tous une bonne journée.
Bien à vous

#8 -1 »  Thunderbird cannot use the profile... » Le 15/12/2014, à 23:55

oliver2004
Réponses : 1

Bonjour à tous,
Je suis très embêté depuis aujourd'hui, impossible d'ouvrir mon client de messagerie... J'ai en fait apparemment mal éteint ma machine ce WE.
Vous avez vu le message. Je suis donc allé voir la doc et j'ai effacé les fichier parentlock et lock, j'ai relancé et puis toujours le même message.
C'est à n'y rien comprendre?
Une idée?

#9 Re : -1 »  Thunderbird cannot use the profile... » Le 16/12/2014, à 01:07

oliver2004
Réponses : 1

J'ai oublié de noter que les profil mails se trouvent sur le serveur de la boîte et que l'accès est configuré par thunderbird -profilemanager
Donc quand une autre machine est connectée sur le compte c'est normal de ne pas y avoir accès, mais après, une fois que personne n'est connecté, on devrait y avoir accès normalement en fait non?

#10 -1 »  Question sur configuration réseau NFS » Le 28/10/2014, à 18:57

oliver2004
Réponses : 1

Bonjour à tous,
Une petite question concernant mon réseau NFS
J'ai un serveur dans le bureau et toutes les autres machines sont connectées au serveur via un réseau NFS.
Le serveur est également un serveur de backup, j'utilise rdiff-backup.
Pour mes backups, je branchais habituellement un HD externe sur le serveur et lançais le backup grâce à un petit shell que j'ai réussi à écrire et tout allais bien, pas d'erreur car j'étais sur la machine même et tout se faisais en mode root, donc pas de soucis de droits.
Seulement c'était peu pratique car il fallait que j'aille régulièrement voire tous les jours dans la pièce du serveur, brancher le disque, lancer la backup et revenir pour débrancher le HD une fois le backup fini.
J'ai donc pensé à faire le backup depuis ma machine, celle qui a le plus de droits, j'ai donc copié le script sur ma machine et commencé à faire les backup depuis les partitions montées sur ma machine.
Le script a donc été modifié en conséquence et il fonctionne, seulement, il y a des erreurs car durant la journée, lorsque des fichiers sont créés ou modifiés au bureau, ceux-ci n'ont pas ou plus les droits nécessaires et je me retrouve avec des "permission denied"
Donc déjà les fichiers et dossier (je ne suis en fait pas sûr que ce soit bien, même presque sûr que pas) ont ces droits: rwxr-xr-x pour les fichiers et drwxr-xr-x pour les dossier.
Ça c'est un point, l'autre est que certains fichiers lors de la journée sont changés à -rw------- du coup lors du backup depuis ma machine, ces fichiers sont interdits.

Donc mes questions sont
quels sont les droits les plus appropriés que je devrais donner au fichiers et dossier pour que je puisse réaliser mon bakcup depuis ma machine sans risque de sécurité?
Comment puis-je forcer la création et modification de dossier et fichiers avec ces droits pendant la journée pour qu'il n'y ait plus de "permission denied"?

Mon fichier /etc/exports sur le serveur est sous cette forme là:

/home/serveur                                            client(rw,sync,subtree_check)

Et les fstab des machines clientes sous cette forme là:

server:/home/serveur /media/serveur       nfs     user,auto       0       0

Ne me tirez pas les oreilles, j'avoue ne jamais avoir demandé conseil il me semble au sujet de la configuration optimum d'un réseau NFS... smile
Merci par avance pour votre précieuse aide

#11 Re : -1 »  Question sur configuration réseau NFS » Le 05/11/2014, à 03:19

oliver2004
Réponses : 1

Bonjour, je tente un petit up?
Merci d'avance

#12 Re : -1 »  Problème knotes après changement de version » Le 27/07/2014, à 03:46

oliver2004
Réponses : 4

Bonjour
J'ose un petit UP,
Dans le dossier knotesmogrator le fichier migration.log m'annonce:

[mié jul 23 23:51:42 2014] Info   : Starting migration...
[mié jul 23 23:51:43 2014] Info   : Migration finished.

Donc ça a l'air de s'être déroulé correctement et dans .kde/share/apps/knotes j'ai:
un dossier notes avec les fichiers des notes et un fichier notes.ics avec leur contenu... mais rien, je lance knotes et aucune note ne s'affiche...
Une idée?

#13 -1 »  Problème knotes après changement de version » Le 24/07/2014, à 07:40

oliver2004
Réponses : 4

Bonjour à tous,
J'ai un petit souci. J'utilise beaucoup knotes, outil de notes sur Kubuntu.
J'étais jusqu'à aujourd'hui avec la 13.04 et je suis passé à la 14.04 LTS par une réinstallation propre. Au préalable j'ai sauvegardé mes fichiers de notes, c'est à dire le dossier knotes qui se trouve dans .kde/share/apps/
J'avais déjà réalisé cette manip sans souci auparavant: c'est à dire qu'une fois le système installé, je colle le dossier à sa place avant de lancer knotes et au moment du lancement, je retrouve mes notes. C'est donc ce que j'ai fait, et j'ai lancé knotes... un assistant de migration est arrivé (première fois que a arrive). Apparemment le système de gestion des notes à changé... j'ai donc accepté et la migration s'est lancée. Et puis après, impossible, j'ai perdu mes notes...
Elles sont toujours là apparemment, mais elle ne s'affichent pas... on clique sur l'icône knotes et aucun note n'es listée... J'ai loupé quelque chose?

#14 Re : -1 »  Problème knotes après changement de version » Le 29/07/2014, à 05:31

oliver2004
Réponses : 4
gaffeur a écrit :

Bonjour oliver2004 !

Je t'invite à lire ce topic qui a paru au début de la mise à niveau vers 14.04 http://forum.kubuntu-fr.org/viewtopic.php?id=1562411 , qui traite du sujet ; Ça pourra sans doute te donner quelques précisions sur le problème ...

Confronté au même problème, j'avais moi-même commencé à chercher de l'aide ... http://forum.kubuntu-fr.org/viewtopic.php?id=1567831.

Bonjour gaffeur, smile
Merci pour la réponse et le lien qui m'a en effet permis de mieux cerner le problème. En attendant de trouver une solution avec knotes j'ai installé Basket et au moins récupéré mes notes...
À moitié résolu donc, j'essayerai d'aller plus à fond pour remettre knotes que j'affectionne pour sa simplicité et efficacité... mais en attendant j'ai au moins mes notes... smile

#15 -1 »  Traffic web... » Le 12/06/2014, à 18:30

oliver2004
Réponses : 7

Bonjour à tous,
Dans la boîte, j'ai un serveur par lequel transite tout le traffic, messagerie, web, etc.
Je commence à être inquiet car je soupçonne fortement certains de mes employés de consulter de plus en plus facebook et youtube, et pas pour le travail... mais je retrouve pas forcément le tout sur l'historique des navigateur (ils l'effacent big_smile)... du coup, je suppose que mon serveur garde tout ça en mémoire, les accès, etc dans des logs? Où puis-je trouver ça oou bien faut installer un outil?
Tout ça pour avoir des cartes sous la manches quand je vais faire une réunion de rappel à l'ordre...

#16 Re : -1 »  Traffic web... » Le 13/06/2014, à 23:42

oliver2004
Réponses : 7
pires57 a écrit :

ton serveur a t-il le rôle de proxy d'installer (cf question de tiramiseb )

Ah, ok, j'avais pas compris...donc non... donc il faudrait que mon serveur ait le rôle de proxy... comment faire??

#17 Re : -1 »  Traffic web... » Le 13/06/2014, à 17:52

oliver2004
Réponses : 7
chinois02 a écrit :

Des perçeurs de proxy? yikes
En fait j'attaquerait différemment: Interdiction d'effacer les historiques!

Bonjour Chinois02, ça me semble pas mal pour commencer -> empêcher l'effacement de l'historique...

tiramiseb a écrit :

Salut,

Tu parles d'un serveur par lequel passe tout le trafic... Mais est-ce un proxy web (type Squid - auquel cas il y a en effet des logs) ou juste une passerelle (auquel cas il n'y a pas de log spécifique) ?

Salut, je parle d'un serveur que j'ai en local, dans le bureau, le cerveau de la boîte quoi et qui gère tout un tas de trucs, backups automatisés, serveur apache pour site en intranet su lequel on travaille, serveur de fichiers et aussi, effectivement une passerelle qui gère les IP des machines connectées au serveurs, serveur NFS pour le réseau et c'est aussi par lui que que passe tout le trafic internet.
Donc avant le serveur il y a le routeur ADSL connecté au serveur par un cable réseau, et du serveur sort un deuxième cable réseau connecté à un switch qui envoie le signal aux machines connectées. Donc logiquement, une machine qui se connecte à internet passe obligatoirement par le serveur. C'est pourquoi je me demandais si celui-ci gardait des logs en mémoire sur ces connections http, https, etc depuis les machines et où ils se trouvaient... mais apparemment, il n'y en aurait pas? Ou peut-être faut-il installer/configurer une application pour les garder?

#18 Re : -1 »  [RÉSOLU !! TB] Impossible d'effacer mes messages » Le 03/06/2014, à 17:48

oliver2004
Réponses : 10
Ivanovich a écrit :

bonjour,
Je viens de rencontrer ce problème: impossible de supprimer des messages quelque soit la méthode utilisée.
Après des recherches sur le blog mozilla j'ai trouvé ceci: Réparer la Base de Données Globale
J'ai par prudence, juste renommé le fichier: global-messages-db.sqlite (global-messages-db.sqlite.save) et suivi ce topic et le problème a disparu je peux à nouveau supprimer mes messages.

Ubuntu 14.04 / Thunderbird : 24.5.0

Bonjour,
Je reviens sur mon souci (qui apparemment n'est pas un cas isolé).
J'ai ferme TB, j'ai effacé global-messages-db.sqlite et de plus ai effacé tous les fichiers .msf, redémarré TB, ouvert tous les dossiers pour reconsctruction de l'index... je ne peux toujours pas effacer mes messages... c'est vraiment embêtant... et bizarre neutral

#19 Re : -1 »  [RÉSOLU !! TB] Impossible d'effacer mes messages » Le 03/06/2014, à 17:54

oliver2004
Réponses : 10

Trouvé!!!! smile smile smile smile
C'est bizarre.
Donc finalement, en regardant les fichiers, je vois par hasard que sur l'icône du fichier TRASH il y a un cadenas de posé... du coup, les droits étaient en INTERDITS pour tous... J'ai changé à Peut lire et écrire pour le propriétaire et le problème est résolu... smile
Eeeeet ben...
Je marque à résolu...

#20 -1 »  [Résolu] TB Problème pour réparer la base de données globale » Le 30/05/2014, à 16:40

oliver2004
Réponses : 3

Bonjour à tous,
Sur une des machines de bureau, depuis quelques semaines, la recherche globale ne fonctionne plus correctement, on fait une recherche, les messages sont bien trouvés mais quand on affiche, ceux-ci n'apparaissent plus.
J'ai d'abord pensé qu'il fallait que je répare les dossiers, genre click droit sur le dossier, Propriétés -> Réparer le dossier mais cela n'a rien résolu.
J'ai donc cherché et j'ai trouvé ce lien:
https://support.mozilla.org/fr/kb/repar … es-globale
J'ai donc suivi l'instruction, je suis allé dans le profil du compte et j'ai effacé le fichier global-messages-db.sqlite (en ayant auparavant pris a précaution de fermer Thunderbird), je redémarre et selon les instructions, l'indexation aurait dû reprendre à l'ouverture mais rien, aucun message dans la fenètre d'activités...
Ai-je loupé quelque chose?

#21 Re : -1 »  [Résolu] TB Problème pour réparer la base de données globale » Le 02/06/2014, à 22:29

oliver2004
Réponses : 3

Bonjour
Puis-je me permettre un petit UP pour relancer le sujet?

#22 Re : -1 »  [Résolu] TB Problème pour réparer la base de données globale » Le 03/06/2014, à 17:15

oliver2004
Réponses : 3
credenhill a écrit :

hello
essayer de supprimer les fichiers .msf, ce sont des index qui seront reconsruits

Super, j'ai effacé tous les fichiers .msf dans tous les dossiers du compte email, thunderbird fermé bien sûr, une fois fait, j'ai réouvert TB, j'ai ouvert un à un tous les dossiers (inbox, brouillons, archives et sous dossiers, etc) et l'index s'est reconstruit.
Je note donc cette procédure, marche impec
Merci ! smile

#23 -1 »  [Thunderbird] Transformer un compte IMAP en POP... » Le 30/05/2014, à 16:54

oliver2004
Réponses : 4

Bonjour,
Je me trouve depuis quelques jours avec un problème avec 2 de mes comptes emails. Ceux-ci ont été configurés en IMAP et non en POP comme les autres comptes de messagerie de la boîte. Du coup, les années passant les messages occupent de plus en plus d'espace sur le serveur du host et j'arrive en bout de l'espace autorisé avec le plan de host que j'ai.
Il faut donc que je rapatrie ces messages sur mon serveur. Donc j'ai désactivé le téléchargement des nouveaux messages sur le compte IMAP et créé un compte pop pour importer les messages mais cela ne m'importe que les messages dans la boîte de réception, pas ceux contenus dans les dossiers comme par exemple ceux qui ont été archivés ou envoyés et contenus dans les dossiers respectifs....
comment puis-je faire? une idée?

#24 Re : -1 »  [Thunderbird] Transformer un compte IMAP en POP... » Le 30/05/2014, à 18:14

oliver2004
Réponses : 4

Bonjour,
Merci pour la réponse,
Quand je parle de mon serveur, c'est le serveur qui se trouve dans mes bureaux, propre à la boîte qui fait office de serveur de backup, de fichiers, serveur apache pour un site en intranet et également héberge les comptes mails qui sont en POP, sauf les deux qui pour je sais pas pourquoi ont été configuré en IMAP lors de leur création... le but est donc de rapatrier ces comptes IMAP (qui sont à l'extérieur, sur le serveur du host de mon site web) en compte POP qui sont en local sur mon serveur à moi... les machines qui ouvrent les comptes courriels sont configurées avec thunderbird -profilemanage. Avoir les comptes courriels sur une seule machine (le serveur ici en local) facilite les backups journaliers notamment.
Je vais étudier ce que tu me conseilles... c'est une manipulation délicate apparemment... smile