Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  Debugger une configuration apache (virtualhost) » Le 22/03/2015, à 11:38

__fabrice
Réponses : 3

Bonjour,

Tu as aussi les commandes suivantes :

 apache2ctl -t 

et

 apache2ctl -S 

Fabrice

#1 -1 »  [GIMP] Flouter des parties d'un pdf importé. » Le 16/03/2015, à 15:22

__fabrice
Réponses : 18

Bonjour à tous,

J'essaie d'appliquer un filtre de flou sur quelques zones d'un pdf que j'ai ouvert dans GIMP.

Peut-ton faire ça ?. Il faudrait que je puise flouter quelques parties puis que je le sauvegarde toujours au format pdf ?
J'ai essayé mais si j'applique le filtre, rien ne se passe et je n'ai pas de message d'erreur ou quoique ce soit.

Merci de votre aide.
Fabrice

#2 Re : -1 »  [GIMP] Flouter des parties d'un pdf importé. » Le 16/03/2015, à 16:06

__fabrice
Réponses : 18

Bonjour,

C'est ce que je fais depuis le début smile. Mais rien ne se passe sad

#3 Re : -1 »  [GIMP] Flouter des parties d'un pdf importé. » Le 17/03/2015, à 13:56

__fabrice
Réponses : 18

Pas d'autres idées ? smile

F.

#4 Re : -1 »  [GIMP] Flouter des parties d'un pdf importé. » Le 17/03/2015, à 15:28

__fabrice
Réponses : 18

Oui, je fais ça aussi. Mais l'aperçu n'a rien à voir avec le fait que GIMP applique ou non le filtre.... non ?

Par contre, c'est bien un pdf dans l'exemple ?

F.

#5 Re : -1 »  [GIMP] Flouter des parties d'un pdf importé. » Le 17/03/2015, à 16:56

__fabrice
Réponses : 18

Je viens de me rendre compte du bug.

Ce pdf à 3 pages. Lorsque je n'importe qu'une seule page, cela fonctionne. Mais si j'importe tout (il faut le faire, c'est évident), cela ne fonctionne pas !!

Un bug de GIMP ?

#6 Re : -1 »  [GIMP] Flouter des parties d'un pdf importé. » Le 17/03/2015, à 18:21

__fabrice
Réponses : 18
jeange a écrit :

Non un bug de _fabrice hmm

Tu as mangé du clown au petit déj ? wink

#7 Re : -1 »  [GIMP] Flouter des parties d'un pdf importé. » Le 17/03/2015, à 18:41

__fabrice
Réponses : 18
moko138 a écrit :

Je viens de faire le test avec un pdf de 4 pages et Gimp 2.6.12.
À l'import, Gimp me demande si je veux importer chaque page comme calque ou comme image.

Si je choisis "calque", je n'arrive pas à changer de calque-page ;

si  je choisis "image", je peux ensuite choisir mon image-page, puis y sélectionner une zone, puis Menu>Filtres>Flou>... sans difficulté. smile

Oui, c çà smile.
J'ai testé, cela fonctionne effectivement. En fait GIMP convertit le pdf en images et après, c'est plus vraiment un pdf wink.

Et si je l'exporte après, en pdf, par contre, c'est un peu beaucoup pourri. Je re-testerais mieux smile

Merci

#8 -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 21/01/2015, à 11:49

__fabrice
Réponses : 36

Bonjour,

Après un problème avec MariaDB, j'ai dû le désinstaller (purge mariadb*), mais cela me pose un soucis maintenant...

Puisque je ne peux ni installer ni supprimerun packet, j'ai fait un

sudo apt-get install -f

mais j'ai ces erreurs  :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  kdepimlibs-kio-plugins libaccounts-qt1 libakonadi-calendar4
  libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4
  libakonadi-kmime4 libakonadi-notes4 libakonadi-socialutils4
  libakonadiprotocolinternals1 libdmtx0a libkabc4 libkalarmcal2 libkcal4
  libkcalcore4 libkcalutils4 libkfbapi1 libkgapi2-2 libkholidays4 libkimap4
  libkldap4 libkmbox4 libkmime4 libkolab0 libkolabxml1 libkpimidentities4
  libkpimtextedit4 libkpimutils4 libkresources4 libkyotocabinet16
  libmailtransport4 libmicroblog4 libprison0 libqrencode3 libsignon-qt1
  mailutils-common
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  mysql-server-5.5
Paquets suggérés :
  tinyca mailx
Les NOUVEAUX paquets suivants seront installés :
  mysql-server-5.5
0 mis à jour, 1 nouvellement installés, 0 à enlever et 53 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1 744 ko dans les archives.
Après cette opération, 31,9 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Préconfiguration des paquets...
(Lecture de la base de données... 345847 fichiers et répertoires déjà installés.)
Préparation du décompactage de .../mysql-server-5.5_5.5.40-0ubuntu0.14.04.1_i386.deb ...
Aborting downgrade from (at least) 10.0 to 5.5.
If are sure you want to downgrade to 5.5, remove the file
/var/lib/mysql/debian-*.flag and try installing again.
dpkg: error processing archive /var/cache/apt/archives/mysql-server-5.5_5.5.40-0ubuntu0.14.04.1_i386.deb (--unpack):
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/mysql-server-5.5_5.5.40-0ubuntu0.14.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Une idée pour me sortir de ce faux pas ?

Merci

Fabrice

#9 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 26/01/2015, à 12:07

__fabrice
Réponses : 36

Salut à tous,
Je viens de renommer les fichiers debian.*.
Cela partait bien, puis, il y a eu ces erreurs :

150126 10:46:04 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
150126 10:46:04 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.5 ; cependant :
 Le paquet mysql-server-5.5 n'est pas encore configuré.

dpkg: error processing package mysql-server (--configure):
 problèmes de dépendances - laissé non configuré
Traitement déclenché pour  ureadahead (0.100.0-16) ...
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

C'est arrivé après un message d'erreur de configuration, comme quoi le mot de passe root/mysql ne pourrait pas être changer sad...

PS : on avance wink, merci.
Fabrice

#10 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 26/01/2015, à 14:12

__fabrice
Réponses : 36

Je ne peux pas m'empecher d'avoir peur big_smile mad quand je lis :

sudo apt-get purge

#11 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 26/01/2015, à 22:39

__fabrice
Réponses : 36
Qid a écrit :

de toutes façon pour autant que j'en sache tu ne risque rien puisque cette commande est fausse ... tongue

Et bien non, elle est tout à fait correcte... wink. J'ai volontairement enlevé le nom du paquet smile

En fait, je n'ai pas fait ce que tu me proposais (merci au passage), parce que je pense (peut-etre à tord) que supprimer le message d'erreur sans résoudre le problème risque d'aggraver le truc smile.

Merci tout de même, je vais continuer mon investigation cool

PS : Nettoyage :

alias nettoyage='sudo apt-get clean; sudo apt-get autoclean;sudo apt-get autoremove'

#12 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 12/02/2015, à 16:17

__fabrice
Réponses : 36

Bonjour,
J'ai essayé, mais cela n'aide pas plus sad

sudo aptitude -s install mysql-server-5.5
Les paquets partiellement installés suivants seront configurés :
  mysql-server mysql-server-5.5 
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 99 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
Charger/installer/enlever des paquets.

#13 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 12/02/2015, à 17:43

__fabrice
Réponses : 36

message :

$ sudo aptitude reinstall mysql-server-5.5
Les paquets suivants seront RÉINSTALLÉS :     
  mysql-server-5.5 
Les paquets partiellement installés suivants seront configurés :
  mysql-server 
0 paquets mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 99 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
E: Internal Error, No file name for mysql-server-5.5:i386

#14 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 24/02/2015, à 17:46

__fabrice
Réponses : 36

Non, je n'ai pas commenté entre temps des dépots.

Ils étaient comment ça avant mon problème. J'ai fais du tri, oui, mais pas après.

#15 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 03/03/2015, à 12:01

__fabrice
Réponses : 36

Salut,

J'ai réussi à réinstaller la version 5.6, et cela a l'air de fonctionner.
Mais j'ai des problèmes de conflits, par exemple, en installant  le WorkBench. L'installation ne marche pas.

Par contre, filerem, as-tu essayé de faire tout pareil, mais de réinstaller la version 5-5 ?

Merci
Fabrice

#16 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 03/03/2015, à 17:43

__fabrice
Réponses : 36

Ok. Dis moi lorsque tu as des news.
Je vais continuer moi aussi à tester ce que je peux.

a+

#17 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 28/01/2015, à 17:16

__fabrice
Réponses : 36

Salut,

1- J'ai purgé mysql : ok, pas de soucis
2- je le reinstalle et il y a une erreur (voir PJ) dans la mot de passe.
capture-installation-mysql.png
Et donc ? smile

Merci
Fabrice

$ ▶ sudo apt-get install mysql-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  mysql-server-5.5 mysql-server-core-5.5
Paquets suggérés :
  tinyca mailx
Les NOUVEAUX paquets suivants seront installés :
  mysql-server mysql-server-5.5 mysql-server-core-5.5
0 mis à jour, 3 nouvellement installés, 0 à enlever et 45 non mis à jour.
Il est nécessaire de prendre 5 129 ko dans les archives.
Après cette opération, 50,7 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-server-core-5.5 i386 5.5.41-0ubuntu0.14.04.1 [3 138 kB]
Réception de : 2 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-server-5.5 i386 5.5.41-0ubuntu0.14.04.1 [1 978 kB]
Réception de : 3 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main mysql-server all 5.5.41-0ubuntu0.14.04.1 [12,4 kB]
5 129 ko réceptionnés en 11s (438 ko/s)                                        
Préconfiguration des paquets...
Sélection du paquet mysql-server-core-5.5 précédemment désélectionné.
(Lecture de la base de données... 345232 fichiers et répertoires déjà installés.)
Préparation du décompactage de .../mysql-server-core-5.5_5.5.41-0ubuntu0.14.04.1_i386.deb ...
Décompactage de mysql-server-core-5.5 (5.5.41-0ubuntu0.14.04.1) ...
Sélection du paquet mysql-server-5.5 précédemment désélectionné.
Préparation du décompactage de .../mysql-server-5.5_5.5.41-0ubuntu0.14.04.1_i386.deb ...
Décompactage de mysql-server-5.5 (5.5.41-0ubuntu0.14.04.1) ...
Sélection du paquet mysql-server précédemment désélectionné.
Préparation du décompactage de .../mysql-server_5.5.41-0ubuntu0.14.04.1_all.deb ...
Décompactage de mysql-server (5.5.41-0ubuntu0.14.04.1) ...
Traitement déclenché pour  man-db (2.6.7.1-1ubuntu1) ...
Traitement déclenché pour  ureadahead (0.100.0-16) ...
ureadahead will be reprofiled on next reboot
Paramétrage de mysql-server-core-5.5 (5.5.41-0ubuntu0.14.04.1) ...
Paramétrage de mysql-server-5.5 (5.5.41-0ubuntu0.14.04.1) ...
150128 16:03:13 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
150128 16:03:13 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.5 ; cependant :
 Le paquet mysql-server-5.5 n'est pas encore configuré.

dpkg: error processing package mysql-server (--configure):
 problèmes de dépendances - laissé non configuré
Traitement déclenché pour  ureadahead (0.100.0-16) ...
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

#18 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 11/02/2015, à 22:39

__fabrice
Réponses : 36

J'ai aussi essayer de nettoyer, mais bof.... sad :

sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 99 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Paramétrage de mysql-server-5.5 (5.5.41-0ubuntu0.14.04.1) ...
150211 21:38:18 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
150211 21:38:18 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.5 ; cependant :
 Le paquet mysql-server-5.5 n'est pas encore configuré.

dpkg: error processing package mysql-server (--configure):
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

#19 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 03/03/2015, à 18:47

__fabrice
Réponses : 36

Oui, c'est ça, on peut pas avec la version 5.6.

WorkBench est effectivement pas mal, mais y'a mieux wink

#20 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 11/02/2015, à 22:37

__fabrice
Réponses : 36

Bonjour,
Après ta commande, voici le résultat :

sudo dpkg-reconfigure mysql-server-5.5
/usr/sbin/dpkg-reconfigure: mysql-server-5.5 est cassé ou partiellement installé

J'ai essayé de tout virer, sans succes, il y a toujours le blocage.

Aussi, ceci :

sudo dpkg -l mysql*
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                    Version                  Architecture             Description
+++-======================================-========================-========================-==================================================================================
un  mysql-client                           <aucun>                  <aucune>                 (aucune description n'est disponible)
un  mysql-client-5.0                       <aucun>                  <aucune>                 (aucune description n'est disponible)
un  mysql-client-5.1                       <aucun>                  <aucune>                 (aucune description n'est disponible)
ii  mysql-client-5.5                       5.5.41-0ubuntu0.14.04.1  i386                     MySQL database client binaries
un  mysql-client-core-5.1                  <aucun>                  <aucune>                 (aucune description n'est disponible)
ii  mysql-client-core-5.5                  5.5.41-0ubuntu0.14.04.1  i386                     MySQL database core client binaries
ii  mysql-common                           5.5.41-0ubuntu0.14.04.1  all                      MySQL database common files, e.g. /etc/mysql/my.cnf
iU  mysql-server                           5.5.41-0ubuntu0.14.04.1  all                      MySQL database server (metapackage depending on the latest version)
un  mysql-server-5.0                       <aucun>                  <aucune>                 (aucune description n'est disponible)
un  mysql-server-5.1                       <aucun>                  <aucune>                 (aucune description n'est disponible)
iF  mysql-server-5.5                       5.5.41-0ubuntu0.14.04.1  i386                     MySQL database server binaries and system database setup
un  mysql-server-core                      <aucun>                  <aucune>                 (aucune description n'est disponible)
un  mysql-server-core-5.0                  <aucun>                  <aucune>                 (aucune description n'est disponible)
un  mysql-server-core-5.1                  <aucun>                  <aucune>                 (aucune description n'est disponible)
ii  mysql-server-core-5.5                  5.5.41-0ubuntu0.14.04.1  i386                     MySQL database server binaries
ii  mysql-utilities                        1.3.5-2                  all                      collection of scripts for managing MySQL servers
ii  mysql-workbench                        6.0.8+dfsg-2             i386                     MySQL Workbench - a visual database modeling, administration and queuing tool
ii  mysql-workbench-data                   6.0.8+dfsg-2             all                      MySQL Workbench -- architecture independent data

#21 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 12/02/2015, à 21:45

__fabrice
Réponses : 36
sudo dpkg --configure --pending
Paramétrage de mysql-server-5.5 (5.5.41-0ubuntu0.14.04.1) ...
150212 20:40:54 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
150212 20:40:54 [Warning] The syntax '--log-slow-queries' is deprecated and will be removed in a future release. Please use '--slow-query-log'/'--slow-query-log-file' instead.
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.5 ; cependant :
 Le paquet mysql-server-5.5 n'est pas encore configuré.

dpkg: error processing package mysql-server (--configure):
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.5
 mysql-server

Et je ne peux pas changer le mot de passe :
copie écran

#22 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 18/02/2015, à 18:13

__fabrice
Réponses : 36

Bonjour,

Merci d'avoir passé du temps sur ce problème.

filerem1, quelles sont les erreurs que tu as rencontrées ? Mysql fonctionne-t-il maintenant correctement ?. Parce que si il y a encore pas mal de soucis, est-ce la bonne solution ?
Je viens de purge mysql-5.5 avec succès.

Par contre, je fais un apt-get update après un purge pour tout remettre et j'ai des erreurs bizarres :

Lecture des listes de paquets... Fait
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : http://www.bunkus.org ./ Release : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 74AF00ADF2E32C85

W: Impossible de récupérer http://www.bunkus.org/ubuntu/trusty/./Release  

W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Est-ce lié ?

Merci

PS : j'ai pas essayé d'installer mysql-5.6 du coup

Fabrice

#23 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 24/02/2015, à 16:50

__fabrice
Réponses : 36

Salut,

Voilà mon fichiers sources.list (épuré des commentaires) :

deb http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted

deb http://fr.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

deb http://fr.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty universe
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty-updates universe

deb http://fr.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

deb http://fr.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse




deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main
# deb https://launchpad.net/~sinzui/+archive/ppa precise main
# deb-src https://launchpad.net/~sinzui/+archive/ppa precise main

# Spotify
# deb http://repository.spotify.com stable non-free

# deb http://security.ubuntu.com/ubuntu saucy-security main

# nginx
# deb http://packages.dotdeb.org saucy all
# deb-src http://packages.dotdeb.org saucy all

# deb http://security.ubuntu.com/ubuntu precise-security main

# zeal
# deb http://ppa.launchpad.net/jerzy-kozera/zeal-ppa/ubuntu precise main

# deb http://ppa.launchpad.net/canonical-qt5-edgers/qt5-proper/ubuntu precise main

# Varnish
# deb http://repo.varnish-cache.org/debian/ saucy varnish-3.0

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu saucy partner
# deb-src http://archive.canonical.com/ubuntu saucy partner

#deb http://www.bunkus.org/ubuntu/trusty/ ./
#deb-src http://www.bunkus.org/ubuntu/trusty/ ./
# deb http://ftp.igh.cnrs.fr/pub/mariadb/repo/10.0/ubuntu trusty main
# deb-src http://ftp.igh.cnrs.fr/pub/mariadb/repo/10.0/ubuntu trusty main

Merci
F.

#24 Re : -1 »  Downgrade de Mysql après installation problématique MariaDB » Le 24/02/2015, à 19:08

__fabrice
Réponses : 36

Bon, je viens de tester l'installation de mysql 5.6.. et puis.. non, marche pas sad
Dans le /etc/mysql, il n'y a pas le my.cnf comme dans mysql-5.5 :

ll /etc/mysql
total 28K
drwxr-xr-x   3 root root 4,0K févr. 24 17:58 ./
drwxr-xr-x 193 root root  12K févr. 24 17:57 ../
drwxr-xr-x   2 root root 4,0K févr. 24 17:59 conf.d/
-rw-------   1 root root  333 févr. 24 17:07 debian.cnf
-rwxr-xr-x   1 root root 1,2K août   6  2014 debian-start*

Voici le log de apt :

sudo apt-get install mysql-server-5.6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  mysql-client-5.6 mysql-client-core-5.6 mysql-common-5.6
  mysql-server-core-5.6
Paquets suggérés :
  mailx tinyca
Les paquets suivants seront ENLEVÉS :
  mysql-client-5.5 mysql-client-core-5.5 mysql-server-core-5.5 mysql-workbench
Les NOUVEAUX paquets suivants seront installés :
  mysql-client-5.6 mysql-client-core-5.6 mysql-common-5.6 mysql-server-5.6
  mysql-server-core-5.6
0 mis à jour, 5 nouvellement installés, 4 à enlever et 3 non mis à jour.
Il est nécessaire de prendre 18,9 Mo dans les archives.
Après cette opération, 22,9 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/universe mysql-client-core-5.6 i386 5.6.19-0ubuntu0.14.04.1 [4 347 kB]
Réception de : 2 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/universe mysql-client-5.6 i386 5.6.19-0ubuntu0.14.04.1 [4 873 kB]
Réception de : 3 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/universe mysql-server-core-5.6 i386 5.6.19-0ubuntu0.14.04.1 [4 223 kB]
Réception de : 4 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/universe mysql-server-5.6 i386 5.6.19-0ubuntu0.14.04.1 [5 459 kB]
Réception de : 5 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/universe mysql-common-5.6 all 5.6.19-0ubuntu0.14.04.1 [15,0 kB]
18,9 Mo réceptionnés en 1min 48s (175 ko/s)                                    
Préconfiguration des paquets...
(Lecture de la base de données... 346102 fichiers et répertoires déjà installés.)
Suppression de mysql-workbench (6.0.8+dfsg-2) ...
Suppression de mysql-client-5.5 (5.5.41-0ubuntu0.14.04.1) ...
Suppression de mysql-client-core-5.5 (5.5.41-0ubuntu0.14.04.1) ...
Suppression de mysql-server-core-5.5 (5.5.41-0ubuntu0.14.04.1) ...
Traitement déclenché pour  mime-support (3.54ubuntu1.1) ...
Traitement déclenché pour  menu (2.1.46ubuntu1) ...
Traitement déclenché pour  shared-mime-info (1.2-0ubuntu3) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Traitement déclenché pour  bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement déclenché pour  desktop-file-utils (0.22-1ubuntu1) ...
Traitement déclenché pour  gnome-menus (3.10.1-0ubuntu2) ...
Traitement déclenché pour  man-db (2.6.7.1-1ubuntu1) ...
Sélection du paquet mysql-client-core-5.6 précédemment désélectionné.
(Lecture de la base de données... 345812 fichiers et répertoires déjà installés.)
Préparation du décompactage de .../mysql-client-core-5.6_5.6.19-0ubuntu0.14.04.1_i386.deb ...
Décompactage de mysql-client-core-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Sélection du paquet mysql-client-5.6 précédemment désélectionné.
Préparation du décompactage de .../mysql-client-5.6_5.6.19-0ubuntu0.14.04.1_i386.deb ...
Décompactage de mysql-client-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Sélection du paquet mysql-server-core-5.6 précédemment désélectionné.
Préparation du décompactage de .../mysql-server-core-5.6_5.6.19-0ubuntu0.14.04.1_i386.deb ...
Décompactage de mysql-server-core-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Sélection du paquet mysql-server-5.6 précédemment désélectionné.
Préparation du décompactage de .../mysql-server-5.6_5.6.19-0ubuntu0.14.04.1_i386.deb ...
Décompactage de mysql-server-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Sélection du paquet mysql-common-5.6 précédemment désélectionné.
Préparation du décompactage de .../mysql-common-5.6_5.6.19-0ubuntu0.14.04.1_all.deb ...
Décompactage de mysql-common-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Traitement déclenché pour  man-db (2.6.7.1-1ubuntu1) ...
Traitement déclenché pour  ureadahead (0.100.0-16) ...
Paramétrage de mysql-client-core-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Paramétrage de mysql-client-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Paramétrage de mysql-server-core-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Paramétrage de mysql-server-5.6 (5.6.19-0ubuntu0.14.04.1) ...
2015-02-24 17:58:56 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2015-02-24 17:58:56 24226 [Note] Plugin 'FEDERATED' is disabled.
2015-02-24 17:58:56 24226 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-02-24 17:58:56 24226 [Note] InnoDB: The InnoDB memory heap is disabled
2015-02-24 17:58:56 24226 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2015-02-24 17:58:56 24226 [Note] InnoDB: Compressed tables use zlib 1.2.8
2015-02-24 17:58:56 24226 [Note] InnoDB: Using Linux native AIO
2015-02-24 17:58:56 24226 [Note] InnoDB: Not using CPU crc32 instructions
2015-02-24 17:58:56 24226 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2015-02-24 17:58:56 24226 [Note] InnoDB: Completed initialization of buffer pool
2015-02-24 17:58:56 24226 [Note] InnoDB: Highest supported file format is Barracuda.
2015-02-24 17:58:56 24226 [Note] InnoDB: 128 rollback segment(s) are active.
2015-02-24 17:58:56 24226 [Note] InnoDB: Waiting for purge to start
2015-02-24 17:58:57 24226 [Note] InnoDB: 5.6.19 started; log sequence number 947617268
2015-02-24 17:58:57 24226 [Note] Binlog end
2015-02-24 17:58:57 24226 [Note] InnoDB: FTS optimize thread exiting.
2015-02-24 17:58:57 24226 [Note] InnoDB: Starting shutdown...
2015-02-24 17:58:58 24226 [Note] InnoDB: Shutdown completed; log sequence number 947617294
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.6 (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de mysql-common-5.6 (5.6.19-0ubuntu0.14.04.1) ...
Traitement déclenché pour  ureadahead (0.100.0-16) ...
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.6
E: Sub-process /usr/bin/dpkg returned an error code (1)

Erreur installation mysql 5.6