Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 5

#0 -1 »  Dual-boot Vista/Ubuntu 12.04 LTS » Le 29/12/2012, à 00:46

Mariusmb
Réponses : 3

Bonsoir,
J'ai récemment installé ubuntu sur un PC contenant Vista. Le disque dur avait 2 partitions : une pour windows et une autre pour la reinstallation de windows. J'en ai créé une troisième pour mes documents, puis une dernière étendue dans laquelle j'ai crée trois partitions logiques pour installer Linux (le système, les documents et le swap). J'ai ensuite installé Grub-2 et lorsque ce dernier s'affiche J'ai 2 entrées Linux qui fonctionnent très bien, les 2 entrée memtest ainsi que 2 entrées Vista loader. Le problème c'est que la première sélection Vista Loader me dirige à la page du mdp de ma session mais le mdp ne fonctionne pas. La 2eme sélection me demande de choisir entre le mode de réparation et un windows vista récupérer. Quand je le choisis, il me demande si je veux le mode sans échec etc...Je prends le mode normal, j'arrive à la session, je mets le mdp et ça fonctionne bien.
Est-ce que cela est normal svp??? Je pense que non pcq j'ai installé Ubuntu avec seven sur un netbook auparavant et ça marchait bien. Après quelque recherches je vous donne mes hypothèses : j'ai installé un Ubuntu de 32 bits sur une machine x64, La partitions système de windows (sda1) est en fin de disque dur (sur mon écran elle se trouvait à gauche, en partitionant, j'ai insérer la partition des documents et la partition  linux entre sda1 et la partition de restauration)...
Merci de me répondre!!!
Cordialement.

#1 Re : -1 »  Dual-boot Vista/Ubuntu 12.04 LTS » Le 02/01/2013, à 15:02

Mariusmb
Réponses : 3

Bonjour,
Et bien le problème c'est le lancement de windows, dans le menu de grub il y a deux Windows vista loader, l'un me conduit à la page de session et le mot de passe ne fonctionne pas le deuxième me propose deux nouveaux choix: la réinstallation de windows et une récupération de windows qui me conduit aussi à ma session et le mdp fonctionne. J'aimerais avoir juste un Win Vista loader qui me conduit à la page de session et dt le mdp fonctionne. Merci.

PS :

bernarani@Bernarani-NM853AA-ABF-p6025fr:~$ sudo parted -l
Modèle: ATA WDC WD6400AAKS-6 (scsi)
Disque /dev/sda : 640GB
Taille des secteurs (logiques/physiques): 512B/512B
Table de partitions : msdos

Numéro  Début   Fin    Taille  Type      Système de fichiers  Fanions
 1      32,3kB  315GB  315GB   primary   ntfs                 démarrage
 2      315GB   419GB  105GB   primary   ntfs
 4      419GB   626GB  206GB   extended
 5      419GB   419GB  10,5MB  logical   linux-swap(v1)
 6      419GB   524GB  105GB   logical   ext4
 7      524GB   626GB  101GB   logical   ext4
 3      626GB   640GB  14,4GB  primary   ntfs


bernarani@Bernarani-NM853AA-ABF-p6025fr:~$ ls -l /dev/disk/by-uuid
total 0
lrwxrwxrwx 1 root root 10 janv.  2 13:15 02e29b41-6aa3-4dee-911a-8761c9341ef9 -> ../../sda6
lrwxrwxrwx 1 root root 10 janv.  2 13:15 75735226-71f5-4255-b184-75adf316a130 -> ../../sda7
lrwxrwxrwx 1 root root 10 janv.  2 13:15 75DC3EC22569119B -> ../../sda2
lrwxrwxrwx 1 root root 10 janv.  2 13:15 949CA48C9CA46A86 -> ../../sda3
lrwxrwxrwx 1 root root 10 janv.  2 13:15 959dff93-b2c0-4e95-9129-3656a5656b13 -> ../../sda5
lrwxrwxrwx 1 root root 10 janv.  2 13:15 DC920C4A920C2C18 -> ../../sda1
bernarani@Bernarani-NM853AA-ABF-p6025fr:~$ cat /boot/grub/grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="6"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set=root 02e29b41-6aa3-4dee-911a-8761c9341ef9
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root 02e29b41-6aa3-4dee-911a-8761c9341ef9
  set locale_dir=($root)/boot/grub/locale
  set lang=fr_FR
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 44,0,30; then
  clear
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
	set gfxpayload="${1}"
	if [ "${1}" = "keep" ]; then
		set vt_handoff=vt.handoff=7
	else
		set vt_handoff=
	fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "${linux_gfx_mode}" != "text" ]; then load_video; fi
menuentry 'Ubuntu, avec Linux 3.2.0-35-generic-pae' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos6)'
	search --no-floppy --fs-uuid --set=root 02e29b41-6aa3-4dee-911a-8761c9341ef9
	linux	/boot/vmlinuz-3.2.0-35-generic-pae root=UUID=02e29b41-6aa3-4dee-911a-8761c9341ef9 ro   quiet splash $vt_handoff
	initrd	/boot/initrd.img-3.2.0-35-generic-pae
}
menuentry 'Ubuntu, avec Linux 3.2.0-35-generic-pae (mode de dépannage)' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos6)'
	search --no-floppy --fs-uuid --set=root 02e29b41-6aa3-4dee-911a-8761c9341ef9
	echo	'Chargement de Linux 3.2.0-35-generic-pae ...'
	linux	/boot/vmlinuz-3.2.0-35-generic-pae root=UUID=02e29b41-6aa3-4dee-911a-8761c9341ef9 ro recovery nomodeset 
	echo	'Chargement du disque mémoire initial ...'
	initrd	/boot/initrd.img-3.2.0-35-generic-pae
}
submenu "Previous Linux versions" {
menuentry 'Ubuntu, avec Linux 3.2.0-23-generic-pae' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos6)'
	search --no-floppy --fs-uuid --set=root 02e29b41-6aa3-4dee-911a-8761c9341ef9
	linux	/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=02e29b41-6aa3-4dee-911a-8761c9341ef9 ro   quiet splash $vt_handoff
	initrd	/boot/initrd.img-3.2.0-23-generic-pae
}
menuentry 'Ubuntu, avec Linux 3.2.0-23-generic-pae (mode de dépannage)' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos6)'
	search --no-floppy --fs-uuid --set=root 02e29b41-6aa3-4dee-911a-8761c9341ef9
	echo	'Chargement de Linux 3.2.0-23-generic-pae ...'
	linux	/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=02e29b41-6aa3-4dee-911a-8761c9341ef9 ro recovery nomodeset 
	echo	'Chargement du disque mémoire initial ...'
	initrd	/boot/initrd.img-3.2.0-23-generic-pae
}
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos6)'
	search --no-floppy --fs-uuid --set=root 02e29b41-6aa3-4dee-911a-8761c9341ef9
	linux16	/boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos6)'
	search --no-floppy --fs-uuid --set=root 02e29b41-6aa3-4dee-911a-8761c9341ef9
	linux16	/boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows Vista (loader) (on /dev/sda1)" --class windows --class os {
	insmod part_msdos
	insmod ntfs
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root DC920C4A920C2C18
	chainloader +1
}
menuentry "Windows Vista (loader) (on /dev/sda3)" --class windows --class os {
	insmod part_msdos
	insmod ntfs
	set root='(hd0,msdos3)'
	search --no-floppy --fs-uuid --set=root 949CA48C9CA46A86
	chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

#2 -1 »  Ecran violet au demarrage » Le 24/11/2012, à 00:49

Mariusmb
Réponses : 6

Bonsoir,
J'ai récemment installé Ubuntu 12.04 LTS en dual-boot avec Win 7 Starter. J'ai un netbook 32 bits, processeur Intel Atom Inside, Carte graphique Intel GMA 3150. Lorsque ma machine démarre, le grub apparaît pour faire le choix de l'OS. Pour lancer Linux notamment je choisis la première option, la deuxième étant aussi Linux mais avec recovery mode, les deux suivantes mem-tests et le dernier Win7. Lorsque je choisis Linux donc, je reste bloqué sur un écran violet. J'ai consulté les ressources qui ont conseillé de réparer le grub mais cela n'a rien changé : je dois à chaque basculer en mode veille puis rallumer le PC pour atteindre la page de session Ubuntu! Auriez-vous quelque chose à me conseiller. Merci d'avance!

#3 Re : -1 »  Ecran violet au demarrage » Le 25/11/2012, à 11:23

Mariusmb
Réponses : 6

Bonjour,
Donc je suis rentré sur le tty6, je n'ai pas eu de message d'erreur en 30sec donc je me suis connecté et j'ai tapé la commande que vous m'avez donné, Ubuntu a rechargé le bureau mais le problème c'est que lorsque j'ai redémarré, j'ai encore eu la page violette et j'ai du basculer en mode veille avant de rallumer le PC pour accéder au bureau directement (j'ai désactivé la demande du mdp)!
Merci encore!

#4 Re : -1 »  Ecran violet au demarrage » Le 26/11/2012, à 22:35

Mariusmb
Réponses : 6

Bonsoir,
Donc j'ai essayé les deux méthodes mais aucune semble convenir. Auriez-vous autre choses svp?
Merci encore!