Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 12

#0 -1 »  Modification documentation, où rapportez sur la liste de discussion ? » Le 31/10/2012, à 15:36

Escienca
Réponses : 1

Bonjour,

je souhaiterais modifier une documentation du site concernant cet article:

http://doc.ubuntu-fr.org/python-visual? … ovexportpy

Je voudrais modifier cette partie pour mettre à jour les liens vers la dernière version de povexport (2012):

4.1 Téléchargement du module Python povexport.py

povexport est une module Python disponible sur le site vpython.org à cette adresse (clic droit + Enregistrer la cible du lien sous…).

Après décompression de l'archive zip, vous obtiendrez trois fichiers (attention, l'archive ne contient pas de répertoire, directement les trois fichiers) :

    povexport.py
    povexample.py
    povexample_wood.py

C'est bien entendu le premier fichier, povexport.py qui est important. Pour faire simple, il doit être présent dans le même répertoire que votre script VPython. (Les habitués de Python placeront ce script dans un répertoire du PYTHONPATH par exemple.)

J'ai bien trouvé comment modifier, mais je voudrais savoir, avant de valider la modif, où je doit le signaler exactement sur la liste de discussion.

Merci.

Vpython User-Contribuded Program: http://www.vpython.org/contents/contributed.html

#1 Re : -1 »  Son pourri » Le 14/07/2012, à 21:23

Escienca
Réponses : 5

Bonjour,

dans alsa-mixer, "Rear-mic" pourrit totalement le son. Il faut se diriger dessus avec les flèches, quand il est rouge, il faut cliquer sur M.

Vous pouvez aussi suivre ça:

http://forum.ubuntu-fr.org/viewtopic.ph … 1#p9858231

En ce moment je cherche à avoir du bon son, parce que je vais monter des vidéos, et j'ai pas envie en les testant de me cogner un son pourrave, donc je cherche, je tâte, je teste...

Voili, voilà...

À peluche...

#2 -1 »  Linux Ubuntu 12.04. Où est Povray ? (résolu) » Le 26/06/2012, à 14:32

Escienca
Réponses : 5

Bonjour,

je voudrais installer povray pour m'en servir dans Vpython, mais je ne le trouve pas dans synaptic ? Est-ce que le paquet est nommé autrement ? Je préférerais l'installer à partir des dépôts si c'est possible avant de me cogner à le compiler.

Merci

#3 Re : -1 »  Linux Ubuntu 12.04. Où est Povray ? (résolu) » Le 26/06/2012, à 15:53

Escienca
Réponses : 5

Bonjour,

j'ai trouvé un deb pour Povray3.6 mais j'ai un conflit dans Gdebi:

http://pkgs.org/ubuntu-11.10/ubuntu-mul … /download/

mais j'ai un conflit dans Gdebi:

Erreur : « libpng12-0 » : en conflit avec « povray-3.5 », mais « /home/escienca/Téléchargements/povray_3.6.1-12_amd64.deb » le fournit via « povray-3.5,povray-3.6 »

Je n'ai pas trouvé povray-3.5 dans mon système, et libpng12-0 est un paquet essentiel qu'il ne faut apparemment pas supprimer:

Les paquets suivants seront ENLEVÉS :
  accountsservice* acpi-support* acpid* activity-log-manager-control-center*
  aisleriot* algobox* alsa-base* alsa-utils* amule* amule-utils* anacron*
  apparmor* appmenu-gtk* appmenu-gtk3* appmenu-qt* apport* apport-gtk*
  aptdaemon* apturl* at* atril* avahi-daemon* avahi-utils* avidemux*
  avidemux-plugins-gtk* avidemux-plugins-qt* avidemux-qt* bamfdaemon* baobab*
  binfmt-support* blender* blender-dbg* blender-ogrexml* bluefish*
  bluefish-plugins* bluez* bluez-alsa* bluez-cups* bluez-gstreamer* brasero*
  brasero-cdrkit* brltty* caja* cdbs* checkbox* checkbox-qt* colord* compiz*
  compiz-gnome* compiz-plugins-default* compiz-plugins-main-default*
  compizconfig-backend-gconf* console-setup* consolekit* cron* cryptsetup-bin*
  cups* cups-bsd* cups-client* cups-filters* dbus* dbus-x11* default-jdk*
  default-jre* deja-dup* dh-translations* dkms* dmsetup* dvipng* e2fsprogs*
  eject* empathy* engrampa* eog* eom* evince* evolution-data-server*
  ffmpegthumbnailer* ffmpegthumbnailer-caja* file-roller* filezilla* firefox*
  firefox-globalmenu* firefox-gnome-support* flam3* flashplugin-installer*
  fracplanet* fraqtive* friendly-recovery* ftp* gcalctool*
  gconf-defaults-service* gconf-editor* gconf2* gdebi* gedit* ghostscript*
  ghostscript-cups* ghostscript-x* giac* gimp* ginn* gir1.2-appindicator3-0.1*
  gir1.2-dbusmenu-gtk-0.4* gir1.2-gdkpixbuf-2.0* gir1.2-gnomebluetooth-1.0*
  gir1.2-gtk-2.0* gir1.2-gtk-3.0* gir1.2-gtksource-3.0*
  gir1.2-launchpad-integration-3.0* gir1.2-notify-0.7* gir1.2-pango-1.0*
  gir1.2-peas-1.0* gir1.2-rb-3.0* gir1.2-totem-1.0* gir1.2-ubuntuoneui-3.0*
  gir1.2-vte-2.90* gir1.2-webkit-3.0* gir1.2-wnck-3.0* gkrellm* gksu*
  gnome-bluetooth* gnome-control-center* gnome-disk-utility*
  gnome-font-viewer* gnome-games-data* gnome-icon-theme*
  gnome-icon-theme-symbolic* gnome-keyring* gnome-media* gnome-nettool*
  gnome-online-accounts* gnome-orca* gnome-power-manager* gnome-screensaver*
  gnome-screenshot* gnome-session* gnome-session-bin* gnome-session-canberra*
  gnome-settings-daemon* gnome-sudoku* gnome-system-log* gnome-system-monitor*
  gnome-terminal* gnome-terminal-data* gnome-user-guide* gnome-user-share*
  gnomine* gnuplot* gnuplot-nox* gnuplot-x11* graphviz* grub-common*
  grub-gfxpayload-lists* grub-pc* grub-pc-bin* grub2-common* gs-cjk-resource*
  gstreamer0.10-gconf* gstreamer0.10-plugins-good* gstreamer0.10-x*
  gtk2-engines* gtk2-engines-murrine* gtk2-engines-pixbuf* gtk3-engines-unico*
  gucharmap* gvfs* gvfs-backends* gvfs-daemons* gvfs-fuse* gwibber*
  gwibber-service* gwibber-service-facebook* gwibber-service-identica*
  gwibber-service-twitter* gwyddion* gwyddion-common* gwyddion-plugins*
  hostname* hplip* humanity-icon-theme* ibus* ibus-gtk* ibus-gtk3*
  ibus-pinyin* ibus-table* ifupdown* imagemagick* indicator-application*
  indicator-appmenu* indicator-datetime* indicator-messages* indicator-power*
  indicator-printers* indicator-session* indicator-status-provider-mc5*
  indicator-status-provider-pidgin* initramfs-tools* initscripts* intltool*
  irqbalance* jarwrapper* jockey-common* jockey-gtk* kbd*
  keyboard-configuration* landscape-client-ui-install*
  language-selector-common* language-selector-gnome* libappindicator1*
  libappindicator3-1* libatk-wrapper-java-jni* libatril* libavahi-ui-gtk3-0*
  libbamf0* libbamf3-0* libbrasero-media3-1* libcairo-gobject2* libcairo-perl*
  libcairo-script-interpreter2* libcairo2* libcairo2-dev* libcairomm-1.0-1*
  libcaja-extension* libcanberra-gtk-module* libcanberra-gtk0*
  libcanberra-gtk3-0* libcanberra-gtk3-module* libcompizconfig0*
  libcryptsetup4* libcupsfilters1* libcupsimage2* libdbusmenu-gtk3-4*
  libdbusmenu-gtk4* libdbusmenu-qt2* libdconf-qt0* libdevmapper-event1.02.1*
  libdevmapper1.02.1* libdmapsharing-3.0-2* libedataserverui-3.0-1*
  libevince3-3* libfarstream-0.1-0* libffmpegthumbnailer4* libfolks-eds25*
  libgail-3-0* libgail-common* libgail18* libgcr-3-1* libgd2-xpm*
  libgdk-pixbuf2.0-0* libgdk-pixbuf2.0-dev* libgdu-gtk0* libgdu0*
  libgegl-0.0-0* libgimp2.0* libgksu2-0* libglade2-0* libglademm-2.4-1c2a*
  libgnome-bluetooth8* libgnome-control-center1* libgnome-desktop-3-2*
  libgnome-media-profiles-3.0-0* libgnome2-common* libgnomekbd7* libgoa-1.0-0*
  libgphoto2-2* libgpod4* libgrip0* libgs9* libgtk-3-0* libgtk-3-bin*
  libgtk2-perl* libgtk2.0-0* libgtk2.0-bin* libgtk2.0-dev* libgtkglext1*
  libgtkglextmm-x11-1.2-0* libgtkmm-2.4-1c2a* libgtkmm-3.0-1*
  libgtksourceview-3.0-0* libgtksourceview2.0-0* libgtkspell-3-0*
  libgtkspell0* libgucharmap-2-90-7* libgvc5* libgweather-3-0*
  libgweather-common* libgwibber-gtk2* libgwibber2* libgwyddion2-0*
  libido3-0.1-0* libindicate-gtk3* libindicator3-7* libindicator7*
  libio-socket-ssl-perl* liblaunchpad-integration-3.0-1*
  liblaunchpad-integration1* liblvm2app2.2* liblwp-protocol-https-perl*
  libmagickcore4* libmagickcore4-extra* libmagickwand4* libmarco* libmate*
  libmatecanvas* libmatecomponentui* libmateconf* libmatedesktop* libmatekbd*
  libmatenotify* libmatepanelapplet* libmatepolkit* libmateui* libmatevfs*
  libmateweather* libmetacity-private0* libmjpegtools-1.9*
  libnautilus-extension1a* libnet-dbus-perl* libnm-gtk0* libnotify-bin*
  libnotify4* libnss-mdns* libnux-2.0-0* liboobs-1-5* libopencv-calib3d2.3*
  libopencv-features2d2.3* libopencv-highgui2.3* libopencv-objdetect2.3*
  liboverlay-scrollbar-0.2-0* liboverlay-scrollbar3-0.2-0* libpango-perl*
  libpango1.0-0* libpango1.0-dev* libpangomm-1.4-1* libparted0debian1*
  libpeas-1.0-0* libplymouth2* libpng12-0* libpng12-dev* libpng3*
  libpoppler-glib8* libpoppler19* libpurple0* libqt4-declarative*
  libqt4-designer* libqt4-help* libqt4-opengl* libqt4-qt3support*
  libqt4-scripttools* libqt4-svg* libqtbamf1* libqtdee2* libqtgconf1*
  libqtgui4* libqtwebkit4* libquicktime2* librecad* libreoffice-base-core*
  libreoffice-calc* libreoffice-common* libreoffice-core* libreoffice-draw*
  libreoffice-emailmerge* libreoffice-gnome* libreoffice-gtk*
  libreoffice-help-en-us* libreoffice-help-fr* libreoffice-impress*
  libreoffice-math* libreoffice-style-human* libreoffice-style-tango*
  libreoffice-writer* librhythmbox-core5* librsvg2-2* librsvg2-common*
  libsane* libspectre1* libsyncdaemon-1.0-1* libtelepathy-farstream2*
  libtimezonemap1* libtotem0* libubuntuoneui-3.0-1* libunique-1.0-0*
  libunique-3.0-0* libunity-2d-private0* libunity-core-5.0-5* libunity-misc4*
  libvte-2.90-9* libvte9* libvtk5.8* libwebkitgtk-1.0-0* libwebkitgtk-3.0-0*
  libwmf0.2-7* libwmf0.2-7-gtk* libwnck-3-0* libwnck22* libwww-perl*
  libwxgtk2.8-0* libwxgtk2.8-dbg* libxml-parser-perl* libxml-twig-perl*
  libxml-xpath-perl* libyelp0* libzbargtk0* light-themes* lightdm*
  linux-generic* linux-image-3.2.0-23-generic* linux-image-3.2.0-24-generic*
  linux-image-3.2.0-25-generic* linux-image-3.2.0-26-generic*
  linux-image-generic* linux-sound-base* logrotate* luatex* mahjongg*
  mandelbulber* marco* mate-applets* mate-calc* mate-conf*
  mate-control-center* mate-core* mate-desktop* mate-desktop-environment*
  mate-dialogs* mate-icon-theme* mate-keyring* mate-media*
  mate-media-gstreamer* mate-menus* mate-netspeed* mate-panel* mate-polkit*
  mate-power-manager* mate-screensaver* mate-sensors-applet*
  mate-session-manager* mate-settings-daemon* mate-settings-daemon-gstreamer*
  mate-system-monitor* mate-system-tools* mate-terminal* mate-text-editor*
  mate-themes* mate-utils* mate-vfs* mate-window-manager* mayavi2*
  media-player-info* mencoder* meshlab* metacity* metacity-common* mjpegtools*
  modemmanager* module-init-tools* mountall* mousetweaks* mozo* mplayer*
  msn-pecan* mythes-en-us* mythes-fr* nautilus* nautilus-sendto*
  nautilus-sendto-empathy* nautilus-share* netbase* netpbm* network-manager*
  network-manager-gnome* network-manager-pptp* network-manager-pptp-gnome*
  notify-osd* ntfs-3g* ntpdate* obex-data-server* onboard* oneconf*
  openjdk-6-jdk* openjdk-6-jre* overlay-scrollbar* parted* pidgin*
  pidgin-libnotify* plymouth* plymouth-label* plymouth-theme-ubuntu-logo*
  plymouth-theme-ubuntu-text* pm-utils* policykit-1* policykit-1-gnome*
  poppler-utils* powermgmt-base* ppp* pppconfig* pppoeconf* pptp-linux*
  printer-driver-c2esp* printer-driver-gutenprint* printer-driver-hpcups*
  printer-driver-pnm2ppa* printer-driver-ptouch* printer-driver-sag-gdi*
  printer-driver-splix* procps* python-appindicator* python-apptools*
  python-aptdaemon* python-aptdaemon.gtk3widgets* python-aptdaemon.pkcompat*
  python-cairo* python-envisage* python-gi-cairo* python-glade2*
  python-gnomekeyring* python-gtk2* python-gtk2-dev* python-gtksourceview2*
  python-ibus* python-mate* python-mate-menu* python-matplotlib*
  python-notify* python-pyface* python-qt4* python-spyderlib* python-traitsui*
  python-ubuntu-sso-client* python-ubuntuone-control-panel* python-uno*
  python-virtkey* python-visual* python-vtk* python-wxgtk2.8*
  python-wxgtk2.8-dbg* python-zbarpygtk* python3-cairo* python3-matplotlib*
  qcad* qt-at-spi* remmina* remmina-plugin-rdp* remmina-plugin-vnc*
  resolvconf* rfkill* rhythmbox* rhythmbox-mozilla*
  rhythmbox-plugin-cdrecorder* rhythmbox-plugin-magnatune*
  rhythmbox-plugin-zeitgeist* rhythmbox-plugins* rhythmbox-ubuntuone* rsyslog*
  sane-utils* scilab-sivp* seahorse* sessioninstaller* shotwell* simple-scan*
  sni-qt* software-center* software-properties-gtk* spyder* ssh-askpass-gnome*
  stellarium* synaptic* system-config-printer-gnome* system-tools-backends*
  tcl-vtk* telepathy-haze* telepathy-indicator* telepathy-salut* telnet*
  terraintool* texlive-base* texlive-binaries* texlive-extra-utils*
  texlive-fonts-recommended* texlive-latex-base* texlive-latex-extra*
  texlive-latex-recommended* texlive-pictures* thunderbird*
  thunderbird-globalmenu* thunderbird-gnome-support* thunderbird-locale-en*
  thunderbird-locale-en-us* thunderbird-locale-fr* torcs* totem*
  totem-mozilla* totem-plugins* transmission-gtk* ubuntu-artwork* ubuntu-docs*
  ubuntu-minimal* ubuntu-mono* ubuntu-sso-client* ubuntu-sso-client-gtk*
  ubuntu-standard* ubuntu-system-service* ubuntuone-client*
  ubuntuone-client-gnome* ubuntuone-control-panel* ubuntuone-installer* udev*
  udisks* ufw* unity* unity-2d* unity-2d-panel* unity-2d-shell*
  unity-2d-spread* unity-asset-pool* unity-common* unity-greeter*
  unity-lens-applications* unity-scope-musicstores* unity-services*
  update-manager* update-notifier* upower* upstart* ureadahead*
  usb-creator-common* usb-creator-gtk* usb-modeswitch* usb-modeswitch-data*
  util-linux* vino* whoopsie* wpasupplicant* x11-apps* xaos* xcftools*
  xdg-user-dirs-gtk* xdiagnose* xorg* xserver-xorg* xserver-xorg-core*
  xserver-xorg-input-all* xserver-xorg-input-evdev* xserver-xorg-input-mouse*
  xserver-xorg-input-synaptics* xserver-xorg-input-vmmouse*
  xserver-xorg-input-wacom* xserver-xorg-video-all* xserver-xorg-video-ati*
  xserver-xorg-video-cirrus* xserver-xorg-video-fbdev*
  xserver-xorg-video-intel* xserver-xorg-video-mach64* xserver-xorg-video-mga*
  xserver-xorg-video-neomagic* xserver-xorg-video-nouveau*
  xserver-xorg-video-openchrome* xserver-xorg-video-qxl*
  xserver-xorg-video-r128* xserver-xorg-video-radeon* xserver-xorg-video-s3*
  xserver-xorg-video-savage* xserver-xorg-video-siliconmotion*
  xserver-xorg-video-sis* xserver-xorg-video-sisusb* xserver-xorg-video-tdfx*
  xserver-xorg-video-trident* xserver-xorg-video-vesa*
  xserver-xorg-video-vmware* xul-ext-ubufox* yafaray* yelp* zeitgeist*
  zeitgeist-datahub* zenity*
Les NOUVEAUX paquets suivants seront installés :
  libgpod4-nogtk
ATTENTION : Les paquets essentiels suivants vont être enlevés.
Vous NE devez PAS faire ceci, à moins de savoir exactement ce
que vous êtes en train de faire.
  e2fsprogs util-linux (en raison de e2fsprogs) hostname
0 mis à jour, 1 nouvellement installés, 677 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 124 ko dans les archives.
Après cette opération, 3 204 Mo d'espace disque seront libérés.
Vous êtes sur le point de faire quelque chose de potentiellement dangereux
Pour continuer, tapez la phrase « Oui, faites ce que je vous dis ! »
 ?]

*

Ensuite avec un tar.gz, j'ai ça comme erreur:

POV-Ray 3.6 installation
==========================

This machine does not seem to be a Linux PC.
This version of POV-Ray only runs on x86 Linux machines.
You can obtain a version appropriate for your architecture
on http://www.povray.org/

If you want to force an installation you can use

  install -no-arch-check

escienca@escienca-MS-7641:~/Bureau/povray-3.6$ sudo install -no-arch-check
[sudo] password for escienca: 
install : option invalide -- 'n'
Saisissez « install --help » pour plus d'informations.

Ça me semble dangereux, je ne préfère pas tenter ça. Je vais essayer de trouver une autre soluce. Je viendrais mettre ce que je trouve.

Merci, à bientôt...

#4 Re : -1 »  Linux Ubuntu 12.04. Où est Povray ? (résolu) » Le 02/07/2012, à 11:54

Escienca
Réponses : 5

Bonjour,

j'ai trouvé povray et je l'ai bien installé sur Ubuntu 12.04 !!! smile

Voici la soluce:

Avant de commencer, il faut déjà installer ces 6 paquets Mencoder, Python-visual, VLC, Avidemux (pour le montage vidéo avec son), povexport.py (fichiers) et donc Povray.

Pour Mencoder, Visual-python, VLC et Avidemux pas de problèmes, il sont tout les quatre présent dans les dépôts, donc dans un terminal:

sudo apt-get install mencoder python-visual vlc avidemux

Ensuite il faut installer povexport.py en suivant cette page (avec un exemple):

http://doc.ubuntu-fr.org/python-visual

Si à la fin de la création du fichiers .pov, le rendu bloque, refermez le en passant par Applications-> Outils systèmes-> Moniteur système-> Processus et tuez le processus Python (clic sur la ligne, puis Terminer le processus et ok pour tuer le processus, ça ne détruira pas la création du fichier POV mais refermera juste la fenètre)

Et pour installer povray3.6 c'est par là:

http://askubuntu.com/questions/156449/h … y-on-12-04

Pour lire le fichier rendu en AVI, j'ai utilisé VLC (avec totem j'ai des conflits de dépendances). Pour le montage, Avidemux ouvre bien le fichier.

Voili, voilà, encore une bonne chose de faite ! tongue

Vive le libre, et à bientôt pour de nouvelles aventure Linuxo-pythonniennes tongue

#5 Re : -1 »  Linux Ubuntu 12.04. Où est Povray ? (résolu) » Le 04/07/2012, à 16:22

Escienca
Réponses : 5

Bonjour,

voilà, tout va bien avec Povray3.6, j'ai trouvé des tas de magnifiques exemples ici:

http://local.wasp.uwa.edu.au/~pbourke/e … rac/final/

Pour les animations, il y a ici aussi, par exemple pour des zooms fractals:

http://203.29.75.35/povray.binaries.ani … 8&toff=350

Mais j'ai un autre problème concernant Povray 3.7.

Je l'ai trouvé ici:

http://www.povray.org/beta/source/

Je dois l'installer pour l'utiliser dans Blender 2.63, nais je n'y arrive pas, ça bloque à l'étape "Make" lors de la compilation. J'ai décompressé un dossier pour voir le prob, il n'y pas de fichiers "Make" dans l'archive tar.gz, pourtant il est clairement stipulé dans le Read.me que il faut utiliser Make pour l'installation !!! Je ne sais pas fabriquer les fichiers Make. Je veut bien tenter, mais je voudrais quand même savoir avant si quelqu'un a finalement réussi à installer Povray 3.7 sur Linux Ubuntu 12.04, histoire de ne pas perdre de temps et tourner en rond en vain et pour rien.

Merci

#6 Re : -1 »  Linux Ubuntu 12.04. Où est Povray ? (résolu) » Le 04/07/2012, à 20:37

Escienca
Réponses : 5

Re,

résolu:

http://blenderclan.tuxfamily.org/html/m … post433804

Voili, voilà...

À vous le lancer de rayons (pas dans l'oeuil ça fait mal !!! tongue)

À bientôt...

#7 Re : -1 »  sifflement » Le 30/06/2012, à 16:14

Escienca
Réponses : 3

Bonjour,

tentez d'installer flashplugin-nonfree-extrasound:

sudo apt-get install flashplugin-nonfree-extrasound

Ça devrait résoudre le problème.

À bientôt...

#8 Re : -1 »  sifflement » Le 01/07/2012, à 14:29

Escienca
Réponses : 3

Bonjour,

le paquet précité n'avait finalement rien changé chez moi pour la qualité du son, mais j'ai trouvé la soluce:

sudo apt-get install module-assistant
module-assistant a-i alsa-source
reboot

http://forum.ubuntu-fr.org/viewtopic.php?id=198304

Le problème vient apparemment du changement de noyau sur Precise Pangolin de 2.6 vers 3.2, lors de la dernière mise à jour.

Voili, voilà, mon son est revenu nickel ... et mes voisins vont se remettre à hurler: "baisse le son !!!" lol

Vive le libre, à bientôt...

#9 -1 »  Linux 12.04 - Gnofract - problème dépendance python2.7 » Le 19/06/2012, à 18:17

Escienca
Réponses : 2

Bonjour,

je suis en train d'apprendre à créer des fractales. Dur, dur ! hmm. J'ai trouvé un logiciel qui a l'air pas mal du tout: Gnofract.

J'ai trouvé le deb ici:

http://sourceforge.net/projects/gnofract4d/

Comme il ne voulait pas s'installer avec Gdebi, je suis passé par un terminal:

sudo dpkg -i /home/escienca/Bureau/gnofract4d_3.14-1ubuntu1_amd64.deb

mais l'installation me renvoie une erreur de dépendances avec python:

dpkg : des problèmes de dépendances empêchent la configuration de gnofract4d :
 gnofract4d dépend de python (<< 2.7) ; cependant :
  La version de python sur le système est 2.7.3-0ubuntu2.
dpkg : erreur de traitement de gnofract4d (--install) :
 problèmes de dépendances - laissé non configuré

Je voudrais donc savoir comment régler ces problèmes de dépendances ?

Merci de votre aide...

#10 Re : -1 »  Linux 12.04 - Gnofract - problème dépendance python2.7 » Le 19/06/2012, à 23:42

Escienca
Réponses : 2

Bonsoir,

c'est oki, j'ai trouvé. Le .deb indiqué plus haut est apparemment foireux. Il faut donc procédé comme suit:

Télécharger le tar.gz ici:

http://sourceforge.net/projects/gnofrac … ct4d/3.14/

Le décompresser, par exemple sur votre bureau, puis ouvrir un terminal, et se placer dans ce dossier:

cd /home/escienca/Bureau/gnofract4d-3.14

Puis dans ce dossier:

./setup.py build

Normalement, à partir de là, toujours dans ce dossier, vous devriez pouvoir lancer Gnofract par:

./gnofract4d

Toutefois pour le lancer plus simplement, sans forcément ouvrir tout le dossier, vous pouvez taper, toujours en étant dans le dossier (et en sudo):

sudo ./setup.py install

Voilà, normalement vous pouvez lancer Gnofract dans un terminal par:

gnofract4d

Je n'ai pas encore testé pour faire un lanceur, mais ça ne devrait pas poser de problèmes particulier. Je reviendrais mettre la "recette" pour le lanceur si il y a un prob, et vous montrer mes premiers monstres mathématiques, mes premières fractales.

À bientôt, vive le libre...

#11 Re : -1 »  Linux 12.04 - Gnofract - problème dépendance python2.7 » Le 23/06/2012, à 23:48

Escienca
Réponses : 2

Le lanceur se créé bien dans applications-graphisme !!! smile