Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  [RESOLU] Ordinateur très lent » Le 23/04/2015, à 09:27

nagadoudi
Réponses : 6

Salut à tous et à toutes,

Ces derniers temps, l'ordi a tendance à devenir extrêmement lent au fur et a mesure de la session.
Ce n'est pas parce qu'il est vieux, car il reste rapide en début de session.
Ce n'est pas parce qu'il est trop chargé, car ça arrive aussi quand la mémoire vive est vide et le processeur inutilisé. Il reste pas mal de place sur le disque dur.

J'ai regardé du côté de dmesg après le ralentissement de la bécane :

$ dmesg | tail
[ 3760.308695]  [<ffffffff811f5ef1>] SyS_ioctl+0x81/0xa0
[ 3760.308703]  [<ffffffff8178c1ad>] system_call_fastpath+0x1a/0x1f
[ 3760.308709] ---[ end trace 8d5b9b265f903d68 ]---
[ 3950.801791] systemd-hostnamed[4705]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
[ 4707.157372] audit: type=1400 audit(1429685709.749:46): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/mysqld" pid=7030 comm="apparmor_parser"
[ 4710.681074] audit: type=1400 audit(1429685713.273:47): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/mysqld" pid=7104 comm="apparmor_parser"
[ 7054.760311] systemd-hostnamed[7842]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
[ 7857.157638] perf interrupt took too long (10012 > 10000), lowering kernel.perf_event_max_sample_rate to 12500
[ 8688.094278] 7z[8508]: segfault at 7fffbd039541 ip 00007f037eb04719 sp 00007ffebd0393e0 error 6 in 7z.so[7f037e9d6000+18f000]
[ 8692.105429] 7z[8511]: segfault at 7ffe03097c51 ip 00007f99b90b8719 sp 00007ffd03097af0 error 6 in 7z.so[7f99b8f8a000+18f000]

Et une autre fois :

$ dmesg | tail
[  250.829813] sd 2:0:0:0: [sdb] Write Protect is off
[  250.829832] sd 2:0:0:0: [sdb] Mode Sense: 38 00 00 00
[  250.836723] sd 2:0:0:0: [sdb] No Caching mode page found
[  250.836742] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[  250.952346]  sdb: sdb1
[  250.976842] sd 2:0:0:0: [sdb] Attached SCSI disk
[  253.765228] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[  259.001076] perf interrupt took too long (2526 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[  715.566736] perf interrupt took too long (5122 > 5000), lowering kernel.perf_event_max_sample_rate to 25000
[ 1830.788870] systemd-hostnamed[4378]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!

C'est ça qui me questionne : “perf interrupt took too long (5122 > 5000), lowering kernel.perf_event_max_sample_rate to 25000”. Est-ce que ça pourrait en être la cause ? Comprenez-vous de quoi il s'agit ?

Ma config :
  - Distri : Ubuntu 14.10
  - Noyau / kernel : 3.16
  - Mémoire vive : 3,9 Gio
  - Processeur : Intel® Atom™ CPU D510 @ 1.66GHz × 4

#1 Re : -1 »  [RESOLU] Ordinateur très lent » Le 23/04/2015, à 22:34

nagadoudi
Réponses : 6

Merci à toi jacobus77.

Je vais surveiller le comportement de l'ordi en fonction du disque du externe allumé ou éteint et de la version du noyau Linux sur laquelle j'ai démarré.

Je n'arrive pas à récupérer les infos SMART du disque dur externe, ni avec gnome-disks, ni avec smartmontools. Le 1er grise l'entrée du menu et le 2nd affiche ceci :

$ sudo smartctl --smart=on --offlineauto=on --saveauto=on /dev/sdb1 
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.2.0-67-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
unable to enable Exception control and warning [unsupported scsi opcode]
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.


$ sudo smartctl --smart=on --offlineauto=on --saveauto=on -T permissive /dev/sdb1 
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.2.0-67-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
unable to enable Exception control and warning [unsupported scsi opcode]
Enable autosave (clear GLTSD bit) failed

Pour info, ça fonctionne bien pour mon disque dur interne dans les 2 cas.
→ C'est inquiétant ou non ? (C'est un Samsung HD103SI de 1 To.)

#2 Re : -1 »  [RESOLU] Ordinateur très lent » Le 23/04/2015, à 22:36

nagadoudi
Réponses : 6
jacobus77 a écrit :

Sinon tu ne fourni pas assez d'info pour que l'on puisse vraiment t'aider à cerner l'origine du pb.

Je ne sais pas si tu penses à des info en particulier ou non.
Sinon, je continue le test d'association du noyau et du disque externe. Pour l'instant, ça semble fonctionner avec un ancien noyau et le disque allumé.

#3 Re : -1 »  [RESOLU] Ordinateur très lent » Le 25/04/2015, à 11:07

nagadoudi
Réponses : 6
nagadoudi a écrit :

Je vais surveiller le comportement de l'ordi en fonction du disque du externe allumé ou éteint et de la version du noyau Linux sur laquelle j'ai démarré.

C'est bien le disque dur externe qui est en cause. Car lorsqu'il est allumé et branché, l'ordi rame comme pas possible, indépendamment de la version du noyau. Et lorsqu'il est éteint, tout va bien.

C'est un dysfonctionnement qui est apparu avec le temps, car jusqu'à peu, il fonctionnait bien et je m'en servais pour mes sauvegardes.

Merci encore pour ton aide, jacobus77. J'adore cette idée de la solidarité qui se vit tous les jours sur le net.

#4 Re : -1 »  [RESOLU] Ordinateur très lent » Le 28/04/2015, à 11:13

nagadoudi
Réponses : 6

D'autres diagnostics :
  - Sur mon autre ordinateur (Xubuntu 14.10), pas de soucis, le disque dur ne ralentit pas le système.
  - J'ai mis à jour mon ordi principal vers Ubuntu 15.04 (noyau 3.19) et le soucis est maintenant réglé ! C'était donc bien un dysfonctionnement lié au kernel.

(Le système de fichiers est EXT4.) Merci beaucoup pour tes pistes de réflexion jacobus77. C'est bon à prendre pour la culture G et si ce problème ou d'autres surviennent à nouveau.

#5 -1 »  Supprimer zeitgeist... logiciel fantôme ? » Le 01/09/2014, à 10:51

nagadoudi
Réponses : 16

Bonjour,

Je viens de désinstaller Zeitgeist car il consommait trop de ressources et faisait ramer ma machine. J'y suis arrivé grâce aux commandes données par fnux dans le fil 1585691 :

sudo killall -9 zeitgeist-fts zeitgeist-datahub zeitgeist-deamon
chmod -rw ~/.local/share/zeitgeist/activity.sqlite
sudo apt-get purge zeitgeist zeitgeist-core zeitgeist-datahub python-zeitgeist
sudo shutdown -r now

Ces commandes ont permis de supprimer les 2 paquets zeitgeist-core et zeitgeist-datahub encore présents.

Pourtant, j'aimerais comprendre pourquoi avant de faire ça, je pensais avoir déjà supprimé tout zeitgeist via la logithèque...

Capture d'écran de la logithèque
Logithèque > Installés > Filtre sur « zeitgeist » : rien

... alors qu'il était encore bien présent sur la machine...

$ apt list | grep zeitgeist

WARNING: apt does not have a stable CLI interface yet. Use with caution in scripts.

gir1.2-zeitgeist-2.0/trusty 0.9.14-0ubuntu4 amd64
libqzeitgeist-dbg/trusty 0.7.0-1build1 amd64
libqzeitgeist-dev/trusty 0.7.0-1build1 amd64
libqzeitgeist0/trusty 0.7.0-1build1 amd64
libzeitgeist-1.0-1/trusty,now 0.3.18-1ubuntu2 amd64 [installed]
libzeitgeist-1.0-1-dbg/trusty 0.3.18-1ubuntu2 amd64
libzeitgeist-2.0-0/trusty,now 0.9.14-0ubuntu4 amd64 [installed,automatic]
libzeitgeist-2.0-0-dbg/trusty 0.9.14-0ubuntu4 amd64
libzeitgeist-2.0-dev/trusty 0.9.14-0ubuntu4 amd64
libzeitgeist-2.0-doc/trusty 0.9.14-0ubuntu4 all
libzeitgeist-cil-dev/trusty 0.8.0.0-5 all
libzeitgeist-dev/trusty 0.3.18-1ubuntu2 amd64
libzeitgeist-doc/trusty 0.3.18-1ubuntu2 all
libzeitgeist0.8-cil/trusty 0.8.0.0-5 all
monodoc-zeitgeist-manual/trusty 0.8.0.0-5 all
python-zeitgeist/trusty 0.9.14-0ubuntu4 all
rhythmbox-plugin-zeitgeist/trusty-updates 3.0.2-0ubuntu2 all
zeitgeist/trusty 0.9.14-0ubuntu4 all
zeitgeist-core/trusty,now 0.9.14-0ubuntu4 amd64 [installed,automatic]
zeitgeist-datahub/trusty,now 0.9.14-0ubuntu4 amd64 [residual-config]
zeitgeist-explorer/trusty 0.2-1 all

... et qu'il tournait.

Capture d'écran des processus
zeitgeist-daemon et zeitgeist-fts

D'où vient cet écart entre la logithèque et la commande apt ?

La machine tourne avec Ubuntu 14.04 (pour combien de temps encore ?)

#6 Re : -1 »  Supprimer zeitgeist... logiciel fantôme ? » Le 01/09/2014, à 17:57

nagadoudi
Réponses : 16

En effet, jplemoine, la commande avec --installed affiche un rendu différent : c'est elle que je cherchais.

Ceci dit, zeitgeist était tout de même encore installé puisque le processus apparaissait dans le moniteur système d'une part et que apt-get purge m'a indiqué qu'il supprimait les 2 paquets zeitgeist-fts et zeitgeist-datahub d'autre part. Dans le même temps, la logithèque m'indiquait que zeitgeist n'était plus installé. Peut-être un bug ?

Je pensais qu'arrêter les processus avant désinstallation était réservé au monde Windows...

Ubuntu1988, tu as peut-être raison pour synaptic.

Plus le temps passe, plus je me dis qu'Ubuntu, c'était mieux avant. Ou c'est ptêt moi qui vieillit mal. smile

#7 Re : -1 »  Supprimer zeitgeist... logiciel fantôme ? » Le 01/09/2014, à 23:17

nagadoudi
Réponses : 16
tiramiseb a écrit :

Alors tu as désinstallé le logiciel, mais son instance en fonctionnement, elle, elle était toujours là...

Je ne pense pas car j'ai redémarré plusieurs fois entre temps.

tiramiseb a écrit :

Il me semble que la logithèque ne propose pas la liste de tous les paquets, seulement ceux « orientés utilisateur ».

On a habituellement un lien « Voir les n éléments techniques » en bas. Je l'avais utilisé pour supprimer ces paquets non orientés utilisateurs.
Sur la capture, ce lien n'apparaît plus.
Je pense que pour la logithèque, zeitgeist était vraiment complètement supprimé.

f.x0 a écrit :

pour savoir quels paquets liés à zeitgeist sont réellement installés,
la commande est :

dpkg -l *zeitgeist* | grep "ii"

Merci. Ça annonce qu'il me reste libzeitgeist-1.0-1 et libzeitgeist-2.0-0:amd64, de simples biblio. Donc cette fois, c'est bon.

#8 Re : -1 »  Supprimer zeitgeist... logiciel fantôme ? » Le 02/09/2014, à 09:54

nagadoudi
Réponses : 16

Après avoir désinstallé le programme zeitgeist, j'ai supprimé le dossier ~/.local/share/zeitgeist car il contenait pas mal de données binaires (base de données) dont j'ignorais le contenu... probablement des infos liées à mon historique.

#9 -1 »  Dropbox en tant que super-utilisateur ? » Le 04/12/2014, à 11:56

nagadoudi
Réponses : 6

Bonjour,

Depuis quelques temps, une fenêtre « S'authentifier » apparaît à chaque ouverture de session et me demande le mot de passe super utilisateur pour le logiciel Dropbox.

J'aimerais savoir pourquoi ce logiciel fermé me demande le mot de passe root. Est-ce possible ? Le feriez-vous à ma place ?

À noter que si j'annule, Dropbox reste parfaitement fonctionnel. C'est juste pénible d'avoir ce message tous le jours.

Le message :

« Il est nécessaire de s'authentifier pour lancer le programme « /usb/bin/dropbox » en tant que super-utilisateur

Une application tente d'effectuer une action qui nécessite des privilèges. Pour effectuer cette action, il est nécessaire de s'authentifier. »

Capture du message

J'utilise une version de Dropbox à jour (v2.10.52)

Merci.

#10 Re : -1 »  Dropbox en tant que super-utilisateur ? » Le 04/12/2014, à 20:13

nagadoudi
Réponses : 6
tiramiseb a écrit :

As-tu lancé, à un moment ou à un autre, dropbox en root (avec sudo par exemple) ?

Salut,
Non

#11 Re : -1 »  Dropbox en tant que super-utilisateur ? » Le 05/12/2014, à 10:22

nagadoudi
Réponses : 6

C'est très agréable de se sentir pris en charge. Merci tiramiseb.

La commande donne ceci :

$ ls -lh .config/autostart
total 48K
-rw-rw-r-- 1 plop plop 169 janv.  9  2012 amule.desktop
-rw-rw-r-- 1 plop plop 175 oct.   5  2012 banshee.desktop
-rw-r--r-- 1 plop plop 235 déc.   5 08:02 dropbox.desktop
-rw-rw-r-- 1 plop plop 198 oct.   5  2012 exaile.desktop
-rw-rw-r-- 1 plop plop 195 oct.  21 22:41 gpodder.desktop
-rw-rw-r-- 1 plop plop 100 avril  4  2014 hubic.desktop
-rw-rw-r-- 1 plop plop 286 sept.  1 10:03 indicator-application.desktop
-rw-rw-r-- 1 plop plop 16K déc.   5 08:01 indicator-multiload.desktop
-rw-rw-r-- 1 plop plop 238 oct.   9  2013 transmission-gtk.desktop

Le contenu du fichier ~/.config/autostart/dropbox.desktop :

[Desktop Entry]
Name=Dropbox
GenericName=File Synchronizer
Comment=Sync your files across computers and to the web
Exec=dropbox start -i
Terminal=false
Type=Application
Icon=dropbox
Categories=Network;FileTransfer;
StartupNotify=false

Extrait de man dropbox :

dropbox start [-i]
  Starts the dropbox daemon, dropboxd. If dropboxd is already running, this will do nothing.
  options:
    -i --install  auto install dropboxd if not available on the system

La commande ps aux | grep dropbox donne quelque chose qui ressemble à ça :

USER PID %CPU %MEM   VSZ    RSS  TTY STAT START TIME COMMAND
plop 3375 0.7  2.5 2456100 103956 ?   Sl  08:01 0:31 /home/plop/.dropbox-dist/dropbox-lnx.x86_64-2.10.52/dropbox /newerversion

#12 Re : -1 »  Dropbox en tant que super-utilisateur ? » Le 05/12/2014, à 12:15

nagadoudi
Réponses : 6

Je pose la question sur le forum officiel...

Existe-t-il un outil qui me permette de surveiller ce qu'il fait si je valide sa demande ? Par exemple, va-t-il envoyer mes marque-pages à la maison mère, etc. ?

#13 -1 »  [résolu] Droits, dossier et lien symbolique » Le 16/09/2014, à 21:49

nagadoudi
Réponses : 6

Bonjour,

J'ai un bête problème de droits avec dossiers et liens symboliques, mais je bloque complètement.

L'élément /var/lib/backuppc est un lien symbolique vers le dossier /media/gaston/sauvegardes/backuppc :

root@pc:/var/lib# ll | grep backuppc
lrwxrwxrwx  1 backuppc   backuppc    31 sept. 16 21:00 backuppc -> /media/gaston/sauvegardes/backuppc/

Cette commande ne fonctionne PAS :

root@pc:/# sudo -u backuppc touch /var/lib/backuppc/test
touch: impossible de faire un touch «/var/lib/backuppc/test»: Permission non accordée

Pourtant, ces 2 commandes fonctionnent :

root@pc:/var/lib/backuppc# sudo -u backuppc touch test
root@pc:/media/gaston/sauvegardes/backuppc# sudo -u backuppc touch test

Pourquoi ?


Pour info, voici les droits sur les dossiers :

  • /var : root:root ; 755

  • /var/lib : root:root ; 755

  • /var/lib/backuppc : backuppc:backuppc ; 777 (c'est un lien symbolique)

  • /media : root:root ; 755

  • /media/gaston : root:root ; 750+

  • /media/gaston/sauvegardes : root:users ; 775

  • /media/gaston/sauvegardes/backuppc : backuppc:backuppc ; 775

L'utilisateur backuppc appartient au groupe users.

#14 Re : -1 »  [résolu] Droits, dossier et lien symbolique » Le 16/09/2014, à 22:30

nagadoudi
Réponses : 6

C'est quoi le flag -E ?

Le programme touch est un indicateur pour nous permettre de savoir si BackupPC écrit ou non dans un dossier.

#16 Re : -1 »  [résolu] Droits, dossier et lien symbolique » Le 17/09/2014, à 10:42

nagadoudi
Réponses : 6

C'est exactement ça !

Le dossier /media/gaston appartient à root:root...

root@pc:/media# ll /media/ | grep gaston
drwxr-x---+  5 root root  4096 sept. 17 10:08 gaston/

... mais l'utilisateur gaston y a un accès (c'est normal) géré avec les ACL.

root@pc:/media# getfacl gaston/
# file: gaston/
# owner: root
# group: root
user::rwx
user:gaston:r-x
group::---
mask::r-x
other::---

J'ai donc ajouté un accès à l'utilisateur backuppc.

root@pc:/media# setfacl --modify user:backuppc:rX gaston/

Résultat :

root@pc:/media# getfacl gaston/
# file: gaston/
# owner: root
# group: root
user::rwx
user:backuppc:r-x
user:gaston:r-x
group::---
mask::r-x
other::---

Et ma commande initiale fonctionne !

root@pc:/var/lib/backuppc# sudo -u backuppc touch /var/lib/backuppc/test

Merci Postmortem !

#17 -1 »  BackupPC : Tar exited with error 512 () status (encore !) » Le 11/09/2013, à 10:23

nagadoudi
Réponses : 11

Bonjour à toutes et tous,

Ce fil de discussion fait suite à celui-ci, le message d'erreur étant le même, mais la cause différente.

La sauvegarde se déroule normalement pendant quelques heures (10 h la 1ère fois, 3 h la 2ème fois), puis s'arrête soudain avec le message « Tar exited with error 512 () status ».

Le journal de l'hôte :

2013-09-09 14:03:44 full backup started for directory /etc
2013-09-09 14:04:03 full backup started for directory /home/tartempion
2013-09-09 17:19:20 Got fatal error during xfer (Tar exited with error 512 () status)
2013-09-09 17:19:25 Backup aborted (Tar exited with error 512 () status)
2013-09-09 17:19:25 Saved partial dump 0

Le journal global de BackupPC :

2013-09-09 14:03:44 Started full backup on localhost (pid=7989, share=/etc)
2013-09-09 14:04:03 Started full backup on localhost (pid=7989, share=/home/tartempion)
2013-09-09 15:00:00 Next wakeup is 2013-09-09 16:00:00
2013-09-09 16:00:00 Next wakeup is 2013-09-09 17:00:00
2013-09-09 17:00:00 Next wakeup is 2013-09-09 18:00:00
2013-09-09 17:19:25 Backup failed on localhost (Tar exited with error 512 () status)

Note : il y a largement assez d'espace sur le disque de sauvegarde.

Des pistes de recherche ?

#18 Re : -1 »  BackupPC : Tar exited with error 512 () status (encore !) » Le 11/09/2013, à 12:18

nagadoudi
Réponses : 11
Haleth a écrit :

timeout ?

Je ne pense pas, car le délai serai le même à chaque fois. Or, là on a un échec au bout de 10 h un coup et de 3 h l'autre coup.

maxire a écrit :

La première sauvegarde (10h00 de temps) est-elle réussie ?

Non plus, elle a échoué comme l'autre, avec les mêmes messages d'erreur.

maxire a écrit :

10h00 pour une sauvegarde cela semble beaucoup, mais pourquoi pas.

En effet. Mais j'ai pour 190 Go de fichiers à sauvegarder, c'est peut-être pour ça.
Pour info, le disque de sauvegarde offre 1 To et est vierge.

maxire a écrit :

J'espère que tu n'essayes pas de sauvegarder la sauvegarde !

Non non ! Je sauvegarde /etc/ et /home/tartempion/, mais pas /media/sauvegardes/. Il n'y a pas de liens symboliques de l'un vers l'autre.

maxire a écrit :

Après /home/tartempion, il y a /media

Quoi ? Je n'ai pas compris.


Extrait du fichier de config /etc/backuppc/localhost.pl

$Conf{XferMethod} = 'tar';

$Conf{TarShareName} = [
  '/etc',
  '/home/tartempion',
  ''
];

$Conf{TarClientCmd} = '/usr/bin/sudo LC_ALL=C $tarPath -c -v -f - -C $shareName+ --totals';

On y voit que seuls /etc et /home/tartempion sont à sauvegardés (pas de référence à /media ici).

On voit aussi que Tar est exécuté en sudo, ce qui devrait lui donner accès à tous les fichiers sans restrictions, même ceux qui ne sont pas accessibles à l'utilisateur backuppc.

#19 Re : -1 »  BackupPC : Tar exited with error 512 () status (encore !) » Le 11/09/2013, à 12:21

nagadoudi
Réponses : 11

J'explore différentes pistes...

  • supprimer la ligne vide de TarShareName

  • m'assurer qu'en sudo on accède à tout

Tests en cours...

#20 Re : -1 »  BackupPC : Tar exited with error 512 () status (encore !) » Le 11/09/2013, à 18:16

nagadoudi
Réponses : 11

Nouvel échec après 3 h 20 min.
Ce qui me permet de dire que ce n'est pas dû à la ligne vide.
Ce n'est pas non plus dû à un dossier crypté par encfs. (Quand le dossier crypté était ouvert, « sudo ls » renvoyait « ls: impossible d'ouvrir le répertoire ./bidule: Permission non accordée » alors que « ls » fonctionnait. Quand le dossier était fermé, no problemo.)

La sauvegarde de /etc seul fonctionne.

#21 Re : -1 »  BackupPC : Tar exited with error 512 () status (encore !) » Le 12/09/2013, à 10:09

nagadoudi
Réponses : 11

Oui, je pense aussi que procéder par étapes me permettra de trouver où ça coince. Je tente là une sauvegarde de tartempion en ôtant tous les gros dossiers (Images, Documents...) Si ça ne marche pas, je tenterai sans rsync. Sinon, j'ajouterai au fur et à mesure des dossiers. Ça peut être long et fastidieux, mais j'ai bien envie de trouver !
Merci beaucoup pour ton aide.

#22 Re : -1 »  BackupPC : Tar exited with error 512 () status (encore !) » Le 16/09/2013, à 09:49

nagadoudi
Réponses : 11

Bon ben désormais ça marche, mais je ne sais pas pourquoi...

Comparons :

AVANT :

  1. J'avais une erreur 512

  2. Je tentais de sauvegarder la totalité de /home/tartempion/, soit 238 Gio. Durée : des fois 10 h + édition de liens 12 h...

  3. Parmi les fichiers à sauvegarder, root (donc sudo) n'accédait pas à tout. Par exemple : « impossible d'accéder à «/home/tartempion/.gvfs»: Permission non accordée » (.gvfs est en 500 et appartient à tartempion)

  4. Dans le fichier de conf localhost.pl, $Conf{BackupFilesExclude} contenait des erreurs de syntaxe (mea culpa) et d'encodage (car différent entre éditeur texte et interface web). Du coup, il était ignoré et tout était sauvegardé :

    $Conf{BackupFilesExclude} = {
      'exclusions' => [
        '/home/tartempion/.adobe',
        '/home/tartempion/.cache',
        '/home/tartempion/.gvfs',
        '/home/tartempion/.local/share/Trash',
        '/home/tartempion/.macromedia',
        '/home/tartempion/.thumbnails',
        '/home/tartempion/.VirtualBox',
        '/home/tartempion/VirtualBox VMs',
        '/home/tartempion/tmp',
        "/home/tartempion/T\x{e9}l\x{e9}chargements"
      ]
    };

APRÈS :

  1. La sauvegarde se fait avec succès

  2. Je ne sauvegarde que ce qui m'intéresse dans /home/tartempion/, soit 180 Gio. Durée : 2h30

  3. root a accès à tous les fichiers à sauvegarder

  4. $Conf{BackupFilesExclude} respecte la syntaxe :

    $Conf{BackupFilesExclude} = {
      '/home/tartempion' => [
        '.adobe',
        '.aMule',
        '.arista',
        [...]
        '.xscreensaver-getimage.cache',
        '.xsession-errors',
        '.xsession-errors.old'
      ]
    };

Voilà pour les erreurs que je vois. J'ignore ce qui a fait la différence...

Un GRAND MERCI à toi Maxire pour ton aide acharnée ! :-*)

#23 Re : -1 »  [résolu] BackupPC : Tar exited with error 512 () status » Le 06/09/2013, à 10:31

nagadoudi
Réponses : 9

J'ai déplacé tout le dossier comme indiqué au paragraphe 4.2... et ça marche ! Le problème était bien que les dossier cpool et localhost étaient sur des partitions différentes, d'où le message « Can't create a test hardlink between [...] these are different file systems [...] ».

Un grand merci pour ton aide Maxire.

Maintenant que j'ai bien galéré, il serait bon de corriger le tuto pour que d'autres n'essuient pas les mêmes déconvenues (ça se dit ?) Je vais voir ça...

#24 Re : -1 »  [résolu] BackupPC : Tar exited with error 512 () status » Le 11/09/2013, à 10:25

nagadoudi
Réponses : 9
maxire a écrit :

[Edit] Je viens de lire ton message de succès, super |Fin Edit]

Succès éphémère...