Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  [RESOLU]} LTS 12.04, Firefox, barre des menus » Le 11/03/2013, à 00:16

ahlner
Réponses : 4

Bonjour,

Je souhaite simplement que la barre des menus soit toujours apparente.
Dans "about:config", je n'ai rien trouvé, ce qui ne veut pas dire qu'une option soit inexistante.
Merci.

#1 Re : -1 »  [RESOLU]} LTS 12.04, Firefox, barre des menus » Le 11/03/2013, à 21:48

ahlner
Réponses : 4

Merci.
Oui, c'est bien la 12.04 avec Unity (Comment cela se prononce? (you naï ti?).
J'ai utilisé la méthode douce : désactivation du module, bien que j'affectionne aptitude qui m'a rendu quelques ervices, notamment pour une LMDE passablement bancale.

#2 -1 »  [ARRET] Ordre des disques modifié après installation : Xubuntu 12.10 » Le 08/03/2013, à 00:43

ahlner
Réponses : 4

Salut,

Tout est dit.
Précisions : refusant absolument d'utiliser le MBR /dev/sda réservé à Windows, j'utilise des disquettes et clefs en USB pour démarrer mes distributions.
Lors de l'installation, j'ai débranché tous les  dispositifs USB, car ils ils décalaient /dev/sdb en /dev/sdd.
Mais la 12.10 une fois installée, j'ai rebranché ces dispositifs pour démarrer tous mes systèmes.
Lecteur disquette USB et clef USB : sdb devient sdd
Je retire le lect de disquettes :  sdb=sdc
Parès démarrage de la 12.10, je retire la clef USB : sdb encore en sdc.
Je voudrais empécher ces décalages qui me dérzangent "esthétiquement".
Mais "device.map" n'existe plus. si je le crée, il risque de disparaître après un update-grub.
Dans les mêmes conditions, je n'ai pas ce soucis avec mes distribs rpm et deb, notamment LTS 10.04..
Merci pour vos suggestions.

#3 Re : -1 »  [ARRET] Ordre des disques modifié après installation : Xubuntu 12.10 » Le 08/03/2013, à 11:38

ahlner
Réponses : 4

J'espère obtenir une réponse plus utile que celle de l'intervenant précédent.
Merci d'avance.

#4 Re : -1 »  [ARRET] Ordre des disques modifié après installation : Xubuntu 12.10 » Le 09/03/2013, à 01:41

ahlner
Réponses : 4

Je viens préciser ma pensée : je considère ce problème comme un bug que je n'ai jamais connu avant.
Dommage pour cette version dont l'engagement ede qualité est largement respecté.
Je n'ai eu qu'un souci au moment de l'installation relatif à grub2 que j'ai résolu grâce au chroot (lien Ubuntu).
Après réparation de grub2 et update-grub dans la 10.04 Ubuntu 12.10 a démarré avec son interface graphique : merveilleux, contrairement à LM 8-14 et Debian Squeeze et Ubuntu 12.04.
Autre info : Squeeze n'a pas ce problème de disque.
Quant à Testing, gros problème avec grub2 sur ce pc32(2003-2004), alors que sur le pc64 (assemblé en 2008) LM13 n'a eu aucun problème d'installation.
J'ai parcouru ce chemin : LM13, LTS 12.04, Testing, Squeeze, Xubuntu 12.10 pour tenter de comprendre l'origine du problème de grub2 sur ce pc.
Tout ce détour est là pour décrire ma motivation.
Cela me paraît vraiment illogique (et spécialement agaçant) que les disques  connectés après se positionnent avant les premiers.

#5 Re : -1 »  [ARRET] Ordre des disques modifié après installation : Xubuntu 12.10 » Le 11/03/2013, à 00:04

ahlner
Réponses : 4

Ce que je considère comme un bug apparu sur cette configuration avec la version 12.10
A l'installation, voici quels furent mes choix :
-racine : /dev/sdb1
-grub : /dev/sdb1
Maintenant :

ahlner@ahlner-P4X400-VT8235:~$ mount
[b]/dev/sdd1 on / type ext4 (rw,errors=remount-ro)[/b]
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
gvfsd-fuse on /run/user/ahlner/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=ahlner)

Les 172 mises à jour ont été appliquées.
J'espère qu'un correctif sera disponible.
Si un utilisateur laisse branché un support USB, les partitions seront décalées.
Je vais passer à autrechose, car LTS10.04 et 12.04 me suffisent.

Edit

ahlner@ahlner-P4X400-VT8235:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 12.10
Release:	12.10
Codename:	quantal

#6 -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 02/01/2013, à 01:00

ahlner
Réponses : 18

Salutations
Bonne année 2013

Malgré plusieurs tentatives d'installation, qui se terminent par un message d'erreur sans précisions, et de deux manières différentes, à savoir avec ou sans /boot.
Mon choix d'emplacement de grub 2 n'est jamais le MBR /dev/sda que je réserve à Windows.
Donc, deux schémas de partitionnement :

1)
/dev/sdb11 /boot hébege grub2
/dev/sdb12 /

2)
/dev/sdb12 / et grub2

Echec dans les deux schémas. Ayant parcouru les notes de publication, la config minimum est respectée car la RAM a 1Go
C'est un pc 32 de 2004.

_______________________________________
Infos processeur :
Identifiant du processeur: 1
Fabricant: GenuineIntel
Nom du modèle: Intel(R) Celeron(R) CPU 2.80GHz
Famille CPUID: 15
Modèle: 2
Numéro de modèle: 9
Niveau CPUID: 2
Performances
Fréquence (MHz): 2800.000
Taille du cache: 128 KB
Bogomips: 5711.98

Divers
Drapeaux: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up pebs bts cid xtpr
Protection en écriture: Oui
____________________________________________

# parted -l
Modèle: ATA Maxtor 6E040L0 (scsi)
Disque /dev/sda : 41,1GB
Taille des secteurs (logiques/physiques): 512B/512B
Table de partitions : msdos

Numéro  Début   Fin     Taille  Type     Système de fichiers  Fanions
 1      32,3kB  41,1GB  41,1GB  primary  ntfs                 démarrage


Modèle: ATA ST3120022A (scsi)
Disque /dev/sdb : 120GB
Taille des secteurs (logiques/physiques): 512B/512B
Table de partitions : msdos

Numéro  Début   Fin     Taille  Type      Système de fichiers  Fanions
 1      32,3kB  8390MB  8390MB  primary   sun-ufs
 2      8390MB  15,7GB  7353MB  primary   ext4
 3      15,7GB  23,1GB  7353MB  primary   ext4
 4      23,1GB  120GB   96,9GB  extended                       lba
 5      23,1GB  24,2GB  1077MB  logical   linux-swap(v1)
 6      24,2GB  39,9GB  15,7GB  logical   ext4
 7      39,9GB  55,6GB  15,7GB  logical   ext4
 8      55,6GB  71,4GB  15,7GB  logical   ext4
 9      71,4GB  87,1GB  15,7GB  logical   ext4
10      87,1GB  103GB   15,7GB  logical   ext4
11      103GB   103GB   105MB   logical   ext2
12      103GB   120GB   17,1GB  logical   ext4

______________________________________________
Autres informations utiles :
--LTS 10.04 est installé sur une des partitions primaires
--openSUSE 12.2 avec grub2 dans la / sur une des partitions logiques
Sur ce même ordi, mais en remplaçant /dev/sdb par un DD partitionné en gpt, LTS 12.04 est opérationnel, avec son grub2 dans une clef USB. Cette installation date de deux mois : cas ou un paramètre, du  BIOS par exemple aurait été modifié entre temps à mon insu.
Merci de votre aide, car je ne sais où chercher.

#7 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 02/01/2013, à 09:51

ahlner
Réponses : 18

Bonjour,

C'est simple : dans /boot, sont présents :
--les noyaux
--le dossier grub, mais celui-ci ne contient que deux fichiers : gfxblacklist.txt, grubenv. Pas de .mod, boot.img, core.img, etc.

Quant à l'emplacement de grub2, je peux te certifier qu'il peut être installé ailleurs que dans le MBR /dev/sda, puisque j'utilise maintenant LTS 10.04 dont le grub2 est installé dans la /.
Ensuite, c'est le grub-legacy  de Mandriva 2010 qui démarre Ubuntu de cette manière :

title LTS 10.04
uuid e7874d6e-6037-4730-9d6d-5a69eac55a0
kernel /boot/grub/core.img

Et ça marche impeccablement depuis plusieurs semaines.
Le problème se situe donc dans LTS 12.04 ou en amont, Debian.
Un changement important est survenu.

#8 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 02/01/2013, à 17:11

ahlner
Réponses : 18

Merci.
Je connais l'option --force pour l'avoir utilisé dans le but de modifier le démarrage : il s'agissait d'un système démarrable dont le grub2 est dans la /, pour le faire démarrer par une clef USB, car le BIOS de ce pc est riche en option de cette connectique. Cela me permet de dédier le "MBR" à Windows pour qui c'est essentiel. D'autre part, je considère Windows comme une source potetielle d'ennuis à cause de ses virus et autres calamoités similaires. Donc, soyons distants de cette chose! J'ai donc lancé :

sudo grub-install --force /dev/sdc

et cela marche impeccablement.
Mais comment procéder lors de l'installation par la live, sachant que la / est montée dans l'arborescence (virtuelle) de cette live dans :

/target

il me semble. Est-ce prêt pour chroot, c'est à dire se retrouver dans le système installé, semblablement à "ssh"?

#9 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 02/01/2013, à 23:55

ahlner
Réponses : 18

Salut Yann,

Bonne année 2013.
Voici ma question : lors de l'install en live de 12.04, après le message d'erreur de l'installation (de grub 2), dont la / est montée dans  :

/target

si mes souvenirs sont exacts, est-il possible avec cette commande :

sudo chroot /target

de se trouver dans les conditions d'un système ayant démarré normalement afin de pouvoir lancer :

grub-install --force .....

sans avoir à monter /dev, /sys, /proc, etc.  avec des options "bind" et autres?
Merci.

#10 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 03/01/2013, à 00:35

ahlner
Réponses : 18

xabilon,

Je m'adressais à YannUbuntu qui m'avait bien aidé au dernier trimestre  2012.
Merci pour l'option de grub-install non documentée dans "man grub-install" de LTS 10.04.
Que signifie :

et ce, depuis un liveCD dans chroot.

#11 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 03/01/2013, à 20:23

ahlner
Réponses : 18

C'est pour cela que je t'ai demandé.
Ce qui est drôle, c'est que j'ai lu en premier "sans", puis en relisant "dans".
Mais comme il faut des explications longues pour que je comprenne rapidement, que dois-je faire depuis la live :

cd /target/boot/grub

ou

chroot /target/boot/grub

grub-install --root-directory=/target

et ensuite la génération de grub.cfg  par grub-mkconfig -o grub.cfg

juste pour confirmer!
Merci.

Edit : effectivement dans la 10.04 n'existe que l'option --root-directory

#12 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 04/01/2013, à 00:05

ahlner
Réponses : 18

Merci.
Mon cerf-volant a compris.

#13 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 07/01/2013, à 23:32

ahlner
Réponses : 18

xabilon,

Salut.
Hier, j'ai tenté encore la réinstallation de la 12.04, mais dans le but d'installer grub2 si échec, en appliquant tes propositions.
Il a été essentiel de lancer :

sudo chroot /target

sinon refus relatif à /dev non disponible pour lancer :

grub-install --force /dev/sdb12

avec un avertissement. Mais grub2 a été installé avec succès.
Dans la 12.04, l'option "--root-directory=" n'est plus disponible, notamment dans la page man. Je ne me souviens plus des messages d'erreur qui y sont relatifs.
Ensuite, en me plaçant dans :

/target/boot/grub

et en lançant :

grub-mkconfig -o grub.cfg

l'opération a réussi sans message d'erreur critique. Puis à titre d'essai :

update-grub.

Ensuite, j'ai configuré le menu-lst de Mandriva pour chainer sur le grub2, et le menu de grub2 est apparu avec de nombreuses lignes liées aux systèmes installés.
Je n'ai pas testé toutes les entrées, mais :
--LTS 12.04
--Mandriva avec grub-legacy
--deux entrées pour /dev/sdb6 : Mandriva et Debian! Mais ça, c'est relatif à l'immaturité de grub2.

ont échoué, tandis que
XP, Mepis 11 (dérivée Debian avec grub-legacy), openSUSE 12.2 avec grub2
ont réussi. Il est quasiment certain que LTS 10.04 démarre sans problème.

Lors de l'installation en live, qui m'a permis le "chroot" (bravo Ubuntu), un message d'erreur s'est affiché relatif à un arrêt de l'installtion.
Après fermeture de la fenêtre de ce message, un rapport de bugs a été généré et envoyé.
Il m'a été proposé d'ouvrir un compte :

Launchpad Login Service

que j'ai créé, qui me permettra je l'espère, de recevoir un message de l'équipe de développement. Et ensuite, de pouvoir résoudre ce problème.
L'expérience est intéressante, mais léchec partiel de l'installation m'interpelle fortement, car je me demande pourquoi grub2 de LTS 10.04 et d'openSUSE 12.2 s'installent correctement dans la /, et pas Debian testing et LTS 12.04.
Un paramètre influent du BIOS a t-il été modifié, ou autre chose. Toujours est-il que cela me préoccupe beaucoup, car sur quoi agir?

#14 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 08/01/2013, à 08:31

ahlner
Réponses : 18

J'ai attendu la fin de l'installation.
Le message d'erreur a été affiché.
Question "primordiale" : quand aucun "bootloader" n'est installé, y a t-il du code d'amorçage écrit dans le BootSector qui permettrait de démarrer ce système par un autre bootloader?
J'en doute fortement, car j'avais essayé de démarrer ce système par SG2D, opération non réussie, malheureusement, car j'aurais pu installer grub2 dans le système démarré.
Autre chose : j'ai pesté contre Unity à cause de l'absence d'un terminal ou d'émulateur de terminal. Il a fallu l'installer. Cela donne l'impression que Unity est destinée aux utilisateurs lambda.
Le côté positif de ce manque est que l'on peut construire son système.
Je reprendrai plus tard, car j'ai d'autres précisions à apporter.
Bonne journée.

#15 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 08/01/2013, à 18:32

ahlner
Réponses : 18

Si tu as un Ubuntu sans aucun bootloader installé ailleurs, il se retrouvera inclus dans le menu de lancement du Grub de Debian, et il pourra être démarré depuis celui-ci.

Merci, tu viens de m'apprendre quelquechose d'intéressant.

#16 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 09/01/2013, à 13:35

ahlner
Réponses : 18

Bonjour,

Après actualisation de LTS 10.04, LTS 12.04 est reconnu, mais le chargement échoue.

#17 Re : -1 »  [RESOLU] LTS 12.04 : grub2 non installé » Le 09/03/2013, à 17:54

ahlner
Réponses : 18

Après installation de X 12.10 sur /dev/sdb1 précédemment en type A9 (NetBSD), j'ai installé sans aucune erreur LTS 12.04 sur /dev/sdb12.
Le problème semble donc venir de la "slice" NetBSD avec ses partitions internes invisibles, mais qui perturbaient grub-install.

#18 -1 »  grub2/grub-pc, changements importants? » Le 16/02/2013, à 11:32

ahlner
Réponses : 4

Bonjour,

Y a t-il eu des modifications importantes et récentes dans l'arborescence de grub2, notamment dans :

/boot/grub

faisant apparaître de nouveaux éléments dont le dossier :

/boot/grub/i386pc

S'il existe un fil ou un lien technique, quels sont-ils et où sont-ils?
Merci beaucoup.
Bonne fin de semaine,

#19 Re : -1 »  grub2/grub-pc, changements importants? » Le 17/02/2013, à 00:02

ahlner
Réponses : 4

Merci pour vos réponses.
Depuis longtemps grub2 est grub-pc, tout au moins au niveau du paquetage.
Quant à grub 2.0, c'est sensiblement plus joli.

#20 Re : -1 »  Ubuntu - Windows7 Cohabitation - Désinstallation » Le 20/11/2012, à 22:46

ahlner
Réponses : 11

Sans réinstaller Ubuntu, formater avec gparted, par exemple, la partition Windows avec le système de fichiers ext4 (encore par exemple).
Actuellement, à mon avis :
/dev/sda1,  ntfs, 80Go
/dev/sda2, x Go, swap
/dev/sda3, y Go, ext4

Après formatage de la partition XP :
/dev/sda1, ext4, 80Go
/dev/sda2, x Go, swap
/dev/sda3, y Go, ext4

La partition /dev/sda1 pourra servir à ranger des données importantes, qu'il est préférable de protéger contre les éventuels problèmes de la partition système (mais pas des ennuis de disque dur).
Cela me paraît être le moins risqué et fatigant, puisqu'Ubuntu est probablement up to date. En ce moment, j'observe des averses de mises à jour. Dommage de tout recommencer.

#21 Re : -1 »  Ubuntu - Windows7 Cohabitation - Désinstallation » Le 21/11/2012, à 18:23

ahlner
Réponses : 11

J'imagine ce qu'est LVM, mais je ne m'en sers pas, donc ignorant.
Démonter la partition Windows, c'est obligatoire pour la formater.
Ensuite, éditetr fstab pour supprimer la ligne relative à Windows.
Ensuite, avec LVM, tu dois pouvoir ajouter cette partition, mais comment je ne sais pas, car la partition Win est primaire, et celle de Linux logique dans la partition étendue.
Mais c'est peut-être transparent avec LVM.

#22 Re : -1 »  Ubuntu - Windows7 Cohabitation - Désinstallation » Le 24/11/2012, à 20:56

ahlner
Réponses : 11

A priori, aucune raison qu'elle soit montée, vu fstab.
Avec mount,(et aussi cat /proc/mounts) tu affiches les points de montage :

mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=505496k,nr_inodes=126374,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sdb10 on / type ext4 (rw,relatime,data=ordered)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
...........

cat /proc/mounts
rootfs / rootfs rw 0 0
devtmpfs /dev devtmpfs rw,relatime,size=505496k,nr_inodes=126374,mode=755 0 0
tmpfs /dev/shm tmpfs rw,relatime 0 0
tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0
devpts /dev/pts devpts rw,relatime,gid=5,mode=620,ptmxmode=000 0 0
/dev/sdb10 / ext4 rw,relatime,data=ordered 0 0
proc /proc proc rw,relatime 0 0
..............
En la formatant avec gparted, tu seras prévenu qu'il est impossible de formater une partition montée. Imagine ce qui se passerait si un autre programme tentait d'y accéder!
De plus, LVM te signalera un montage indésirable.

#23 Re : -1 »  Menu grub 2 : répétitions apparemment inutiles. » Le 22/11/2012, à 19:14

ahlner
Réponses : 13

Salut,

Après réinstallation de la 12.2 avec grub-legacy, pas de répétiions dans grub2-12.04
12.1 et 12.2 ont la même structure : leur /boot est similaire.
Ce qui intervient est grub2.
Après remplacement de la 12.1 par LTS 10.04, pas de répétitions dans la 12.04 et la 10.04
Apparemment, problème entre grub2 Ubuntu et grub2 openSUSE.
Ma recherche semble terminée.
Quant à la cause première, il faudrait savoir comment "travaillent" ces deux grub2.

#24 Re : -1 »  Menu grub 2 : répétitions apparemment inutiles. » Le 22/11/2012, à 22:44

ahlner
Réponses : 13

Merci d'avoir répondu.
Je vais créer un thread dans mon esprit (multitâches) pour qu'il travaille en arrière-plan!
Blagons un peu.
Comment nomerais-tu un système informatique dans un bâtiment où travailleraient toutes les races et couleurs de l'humanité?
Un système multitaches!