Contenu | Rechercher | Menus

Annonce

Le forum a une nouvelle maison !
Le forum a été migré sur un nouvel hébergement. Si jamais vous trouvez le moindre problème, n'hésitez pas à nous en faire part !
Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  [resolu] - ubuntu Server - Erreur Démarage kernel panic » Le 27/01/2016, à 19:05

Vista
Réponses : 3

Bonjour à vous,

j'ai une gros problème avec mon serveur ubuntu que j'utilise pour faire pas mal de chose, serveur Web, partage TV tnt ...

Mon problème c'est que j'ai une erreur kernel Panic au démarage :

http://frechdesign.free.fr/ubuntuServer … 183949.jpg
Ma config :


Architecture:          i686
Mode(s) opératoire(s) des processeurs :32-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) par cœur : 2
Cœur(s) par socket : 1
Socket(s):             1
Famille de processeur :15
Modèle :             4
Révision :           1
Vitesse du processeur en MHz :3000.484
BogoMIPS:              6000.96
Cache L1d :           16K
Cache L2 :            1024K
Linux srv01 3.19.0-43-generic #49~14.04.1-Ubuntu SMP Thu Dec 31 15:46:00 UTC 2015 i686 i686 i686 GNU/Linux
 Memory : 1536 MB

j'ai bien sur un ubuntu server 32 bit (vieux matos oblige)


j'ai essayé de faire des mise à jour :

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

rien y fais je reste sur ce kernel panic.

pour le faire fonctionner j'ai démarrer en 3.0.19.43

http://frechdesign.free.fr/ubuntuServer … 184151.jpg

je suis obliger de lancer un vieux kernel,
mais si je redémarre BAM rebloqué sur le kernel foireux :"(

que faire svp

Merci de respecter les règles du forum, la taille des images est limitée.

#1 Re : -1 »  [resolu] - ubuntu Server - Erreur Démarage kernel panic » Le 27/01/2016, à 19:45

Vista
Réponses : 3

probléme résolu

c'est ma partition /boot qui était pleine


j'ai donc bouter sur un ancien kernel lancer la commande suivante :

apt-get purge $(dpkg -l 'linux-*' | sed '/^ii/!d;/'"$(uname -r | sed "s/\(.*\)-\([^0-9]\+\)/\1/")"'/d;s/^[^ ]* [^ ]* \([^ ]*\).*/\1/;/[0-9]/!d' | sort -t- -k3 | head -n -3)


en fait lors de l'install d'ubuntu j'install la partion boot (en fait c'est l'auto installeur d'ubuntu) qui install une petite partion de boot

et du coup quand elle est pleines et bein tu la dans l'os


merci à vous

#2 -1 »  Ubuntu 14.04 Desktopx64 - Clavier Cmstorm cooler devastatorLunineux ! » Le 07/10/2014, à 19:19

Vista
Réponses : 5

Bonjour @ tous,

comme je n'ai pas trouvé l'info sur le forum je la propose ici :

Si vous disposer d'un clavier cmstorm lumineux comme le mieux smile
cooler master devastator :

23-129-030-TS?$S300$


et que bien sur vous êtes un utilisateur d'ubuntu vous remarque qu'a prés une fraiche install il n'y a pas moyen, d'activer la superbe lumière sur le clavier,
il faut réaliser la manip suivante :

sudo xmodmap -e 'add mod3 = Scroll_Lock'

et la ça refonctionne, bien sur ça ne peut pas marcher directe il faut forcement faire une manip hmm
source : http://ubuntuforums.org/showthread.php?t=2208222
voila amusé vous bien smile

#3 Re : -1 »  Ubuntu 14.04 Desktopx64 - Clavier Cmstorm cooler devastatorLunineux ! » Le 13/09/2015, à 11:12

Vista
Réponses : 5

Hello,
j'essaye de créer un service pour que le clavier fonctionne au démarrage, mais ça ne fonctionne pas pour le moment :

j'utilise le tuto ici : http://doc.ubuntu-fr.org/tutoriel/comme … en_service

1> je créer le fichier /opt/cmstorm/cmstorm.sh

sudo xmodmap -e 'add mod3 = Scroll_Lock'

on lui donne les bon droit :
sudo chmod a+x  /opt/cmstorm/cmstorm.sh

2> Création du script daemon :

#!/bin/sh -e

DAEMON="/opt/cmstorm/cmstorm.sh" #ligne de commande du programme
daemon_OPT=""  #argument à utiliser par le programme
DAEMONUSER="vista" #utilisateur du programme
daemon_NAME="cmstorm.sh" #Nom du programme (doit être identique à l'exécutable)

PATH="/sbin:/bin:/usr/sbin:/usr/bin" #Ne pas toucher

test -x $DAEMON || exit 0

. /lib/lsb/init-functions

d_start () {
        log_daemon_msg "Starting system $daemon_NAME Daemon"
	start-stop-daemon --background --name $daemon_NAME --start --quiet --chuid $DAEMONUSER --exec $DAEMON -- $daemon_OPT
        log_end_msg $?
}

d_stop () {
        log_daemon_msg "Stopping system $daemon_NAME Daemon"
        start-stop-daemon --name $daemon_NAME --stop --retry 5 --quiet --name $daemon_NAME
	log_end_msg $?
}

case "$1" in

        start|stop)
                d_${1}
                ;;

        restart|reload|force-reload)
                        d_stop
                        d_start
                ;;

        force-stop)
               d_stop
                killall -q $daemon_NAME || true
                sleep 2
                killall -q -9 $daemon_NAME || true
                ;;

        status)
                status_of_proc "$daemon_NAME" "$DAEMON" "system-wide $daemon_NAME" && exit 0 || exit $?
                ;;
        *)
                echo "Usage: /etc/init.d/$daemon_NAME {start|stop|force-stop|restart|reload|force-reload|status}"
                exit 1
                ;;
esac
exit 0

et on test le service :

vista@vista-MS-7758:~$ sudo service cmstorm start
 * Starting system cmstorm.sh Daemon                                                               [ OK ] 
vista@vista-MS-7758:~$ sudo service cmstorm stop
 * Stopping system cmstorm.sh Daemon       

ça semble fonctionner.
mais en fait non car ça n'active pas ou désactive pas le fait de lancer

il me manque un bout quelqu'un saurait comment faire svp ?

#4 Re : -1 »  Ubuntu 14.04 Desktopx64 - Clavier Cmstorm cooler devastatorLunineux ! » Le 27/01/2016, à 19:16

Vista
Réponses : 5

oué idem,

ça saoule, en plus sans lumiére tu vois que dalle sur le clavier hmm

#5 -1 »  Oxwall - Creation d'un facebook like à la maison :) » Le 23/09/2015, à 17:27

Vista
Réponses : 1

Bonjour,

j'aime facebook, mais je n'ai me pas le fait que ça soit hébergé chez les américains et encore moins y mettre mes photos et de ne pas savoir ou il sont !!

mais j'aime le principe de me créer une page avec ce que je fais dans une journée genre un journal de bord.

du coup je me suis chercher un outil qui permettrait de faire comme facebook mais en auto hébergé et je suis tombé sur ça :

http://www.oxwall.org/

pour l'install c'est facile smile php + mysql

du coup, après une install par défaut sans ajout de plugins,

on a un chat avec les utilisateurs (juste ça c'est énorme)
un forum super basique, mais on peux créer des catégorie avec différent forum.
on peux créer des groupes et invité que les personnes qu'on veut.
on se retrouve une appli en ligne en https, qui permet de poster des messages, créer des albums photo (ajouter de s)


voila qu'en pensez vous de cette outil est ce que des personnes l'utilise ?


pas de communauté fr hmm
quelque plugins interresant mais tous payant et chér hmm

#6 -1 »  [Résolue] - VMWARE - Agrandir Partition BOOT car full blocage d'ubuntu » Le 23/07/2015, à 12:40

Vista
Réponses : 10

Bonjour,

j'utilise vmware,
j'ai donc ma ubuntu (mes ubuntus car j'a le probléme sur toutes mes machines, dégouté ! à 'apprendra à laisser le mode partition automatique)

mon porbléme c'est que ma partion /boot/ est pleine, je ne peux donc pas faiire de mise à jour.
ou même redemmarer, car ça crash la machine.

j'ai donc depuis vmware agrandi mon disque et maintenant avec gparted j'aimerais agrandir ma partion boot/
mais je ne peux pas car la partion boot est au début du disque et l'ajout de disque est à la fin du disque :


mini_533570pbgparted.jpg

comment agrandir la partition boot svp

#7 Re : -1 »  [Résolue] - VMWARE - Agrandir Partition BOOT car full blocage d'ubuntu » Le 23/07/2015, à 13:17

Vista
Réponses : 10

Pour résumé :

Voici mes partitions :

$> df -h
Sys. de fichiers            Taille Utilisé Dispo Uti% Monté sur
/dev/mapper/ubuntu--vg-root    15G    4,1G  9,6G  30% /
none                          4,0K       0  4,0K   0% /sys/fs/cgroup
udev                          487M    4,0K  487M   1% /dev
tmpfs                         100M    504K   99M   1% /run
none                          5,0M       0  5,0M   0% /run/lock
none                          497M       0  497M   0% /run/shm
none                          100M       0  100M   0% /run/user
/dev/sda1                     236M    233M     0 100% /boot
$> ll -h /boot/
total 227M
drwxr-xr-x  4 root root 3,0K juil.  7 06:36 ./
drwxr-xr-x 22 root root 4,0K juil.  7 06:35 ../
-rw-r--r--  1 root root 1,2M juil. 15  2014 abi-3.13.0-32-generic
-rw-r--r--  1 root root 1,2M mars  10 21:43 abi-3.13.0-46-generic
-rw-r--r--  1 root root 1,2M mars  12 12:52 abi-3.13.0-48-generic
-rw-r--r--  1 root root 1,2M avril 10 23:05 abi-3.13.0-49-generic
-rw-r--r--  1 root root 1,2M avril 15 15:03 abi-3.13.0-51-generic
-rw-r--r--  1 root root 1,2M mai    4 07:09 abi-3.13.0-52-generic
-rw-r--r--  1 root root 1,2M mai   20 13:11 abi-3.13.0-53-generic
-rw-r--r--  1 root root 1,2M mai   26 22:11 abi-3.13.0-54-generic
-rw-r--r--  1 root root 1,2M juin  14 21:28 abi-3.13.0-55-generic
-rw-r--r--  1 root root 162K juil. 15  2014 config-3.13.0-32-generic
-rw-r--r--  1 root root 162K mars  10 21:43 config-3.13.0-46-generic
-rw-r--r--  1 root root 162K mars  12 12:52 config-3.13.0-48-generic
-rw-r--r--  1 root root 162K avril 10 23:05 config-3.13.0-49-generic
-rw-r--r--  1 root root 162K avril 15 15:03 config-3.13.0-51-generic
-rw-r--r--  1 root root 162K mai    4 07:09 config-3.13.0-52-generic
-rw-r--r--  1 root root 162K mai   20 13:11 config-3.13.0-53-generic
-rw-r--r--  1 root root 162K mai   26 22:11 config-3.13.0-54-generic
-rw-r--r--  1 root root 162K juin  14 21:28 config-3.13.0-55-generic
drwxr-xr-x  5 root root 1,0K mai   22 06:43 grub/
-rw-r--r--  1 root root  20M mars  13 20:11 initrd.img-3.13.0-32-generic
-rw-r--r--  1 root root  20M mars  13 20:19 initrd.img-3.13.0-46-generic
-rw-r--r--  1 root root  20M mars  26 06:34 initrd.img-3.13.0-48-generic
-rw-r--r--  1 root root  20M avril 14 06:51 initrd.img-3.13.0-49-generic
-rw-r--r--  1 root root  20M avril 30 06:48 initrd.img-3.13.0-51-generic
-rw-r--r--  1 root root  20M mai    7 07:05 initrd.img-3.13.0-52-generic
-rw-r--r--  1 root root  20M mai   22 06:43 initrd.img-3.13.0-53-generic
drwx------  2 root root  12K mars  13 19:51 lost+found/
-rw-r--r--  1 root root 173K mars  12  2014 memtest86+.bin
-rw-r--r--  1 root root 174K mars  12  2014 memtest86+.elf
-rw-r--r--  1 root root 175K mars  12  2014 memtest86+_multiboot.bin
-rw-------  1 root root 3,3M juil. 15  2014 System.map-3.13.0-32-generic
-rw-------  1 root root 3,3M mars  10 21:43 System.map-3.13.0-46-generic
-rw-------  1 root root 3,3M mars  12 12:52 System.map-3.13.0-48-generic
-rw-------  1 root root 3,3M avril 10 23:05 System.map-3.13.0-49-generic
-rw-------  1 root root 3,3M avril 15 15:03 System.map-3.13.0-51-generic
-rw-------  1 root root 3,3M mai    4 07:09 System.map-3.13.0-52-generic
-rw-------  1 root root 3,3M mai   20 13:11 System.map-3.13.0-53-generic
-rw-------  1 root root 3,3M mai   26 22:11 System.map-3.13.0-54-generic
-rw-------  1 root root 3,3M juin  14 21:28 System.map-3.13.0-55-generic
-rw-------  1 root root 5,6M juil. 15  2014 vmlinuz-3.13.0-32-generic
-rw-------  1 root root 5,6M mars  10 21:43 vmlinuz-3.13.0-46-generic
-rw-------  1 root root 5,6M mars  12 12:52 vmlinuz-3.13.0-48-generic
-rw-------  1 root root 5,6M avril 10 23:05 vmlinuz-3.13.0-49-generic
-rw-------  1 root root 5,6M avril 15 15:03 vmlinuz-3.13.0-51-generic
-rw-------  1 root root 5,6M mai    4 07:09 vmlinuz-3.13.0-52-generic
-rw-------  1 root root 5,6M mai   20 13:11 vmlinuz-3.13.0-53-generic
-rw-------  1 root root 5,6M mai   26 22:11 vmlinuz-3.13.0-54-generic
-rw-------  1 root root 5,6M juin  14 21:28 vmlinuz-3.13.0-55-generic

#8 Re : -1 »  [Résolue] - VMWARE - Agrandir Partition BOOT car full blocage d'ubuntu » Le 24/07/2015, à 08:20

Vista
Réponses : 10

Bonjour,

j'ai réussi à redémarrer ma virtual machine sous ubuntu smile
ça été bien galère.

d'habitude quand ma partiion boot arrive dans les 80 % j'utilise la technique ciic --> http://forum.ubuntu-fr.org/viewtopic.php?id=1171061
mais la ça fonctionner pas car la partition boot est trop pleine.

Donc je ne pouvais faire aucune mise à jour, ou même enlever des paquets car j'ai été vraiment full niveau espace disque mais que sur la partion boot !!

donc comme c'est une vm, j'ai ajouter de la l'espace disque et grâce à gparted j'ai copie coller ma partition de boot sur la nouvelle créer
mais bien sur ça a cassé le boot de démarrage.

et pour réparer grub j'ai utiliser l’application boot-repair sur une ubuntu en live cd, après quelque manip

ma machine est de nouveau opérationnel :

 df -h
Sys. de fichiers            Taille Utilisé Dispo Uti% Monté sur
/dev/mapper/ubuntu--vg-root    15G    4,5G  9,2G  33% /
none                          4,0K       0  4,0K   0% /sys/fs/cgroup
udev                          486M    4,0K  486M   1% /dev
tmpfs                         100M    504K   99M   1% /run
none                          5,0M       0  5,0M   0% /run/lock
none                          497M       0  497M   0% /run/shm
none                          100M       0  100M   0% /run/use

en tout cas c'est la dernière fois que je laisse ubuntu partitionné mes disque tous seul !

mais pourquoi il créer une aussi petit partition pour le boot, alors qu'il y déposer des fichiers sans les nettoyer hmm


merci pour vos retour

#9 -1 »  Création d'un réseaux social pour ubuntu-fr ? Humhub ? » Le 01/05/2015, à 17:36

Vista
Réponses : 9

Bonjour, à tous !!


que pensez vous de https://www.humhub.org/en/overview

c'est un logiciel php qui permet de créer son propre réseaux social.

que pensez vous de l'adapter pour ubuntu-fr ?

#10 Re : -1 »  Création d'un réseaux social pour ubuntu-fr ? Humhub ? » Le 03/05/2015, à 13:31

Vista
Réponses : 9

dépoussiéré le forum  ubuntu-fr

ça fait 10 ans que je le connais et ça à pas changé d'un iota

#11 Re : -1 »  Minecraft sous Ubuntu 12.04 » Le 03/05/2015, à 13:40

Vista
Réponses : 19

laisse tomber minecraft et joue à minetest ---> http://www.minetest.net/

#12 -1 »  remplace un mount par une ligne dans fichier fstab » Le 26/03/2015, à 11:19

Vista
Réponses : 1

Bonjour,

J'ai ajouter un disque dur sur ma machine virtuel, j'arrive à monter le disque grâce à la commande :

mount /dev/mvg/Vol1 /Data/


voila le problème c'est qu'a chaque démarrage de la machine je perds ce montage.

comment dans FSTAB ajouter ce disque j'ai essayer avec ces lignes mais ça ne fonctionne pas :

UUID=7lGeJq-WhWS-kOMD-ky7u-VsSg-zLJh-PCA1Jd     /Data ext4 defaults    0 0
et
/dev/mvg/Vol1      /Data ext4 defaults    0 0

qu'en pensez vous svp ?

#13 Re : -1 »  remplace un mount par une ligne dans fichier fstab » Le 26/03/2015, à 11:24

Vista
Réponses : 1

ok la solution est la suivante :

j'ai ajouter dans mon fstab :

/dev/mvg/Vol1     /Data ext4 defaults    0 0


et ça fonctionne à chaque boot smile

merci

#14 -1 »  Ubuntu server 14.04 - Squid 3.3.8 - Active directory Probléme ! » Le 13/10/2014, à 18:22

Vista
Réponses : 0

Bonjour, à tous,

voici  j'ai installé un serveur Ubuntu 14.04  et Squid v3.3.8 (version par defaut sur ubuntu 14.04), et j'aimerais pouvoir faire du SSO via un active directory :
je suis donc le tuto la documentation officiel  -->  http://wiki.squid-cache.org/ConfigExamp … e/Kerberos
après une fraîche install et les mise à jour.


1> Pre-requisites for Active Directory integration

Serveur active directory :
     ip active directory : 192.168.1.60
     hostname : ws2008
     Nom de domaine : sonsofanarchy.fr
     Utilisateur de l'active directory :
            - administrateur password
            - jteller   P@ssword1

Serveur squid :
     ip : 192.168.1.62
     hostname : srv-proxy-01
     user administrateur
     password : password


Config du serveur proxy :

aprés une fraiche installe et les mise à jour compléte.

1.1> Install des prérequis :

sudo apt-get install krb5-user msktutil squid samba-common-bin 

- Vérification configuration DNS :

sudo nano  /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
domain sonsofanarchy.fr
search sonsofanarchy.fr
nameserver 192.168.1.60

- Synchronisation de la date avec l'Active directory :

sudo nano /etc/default/ntpdate
# The settings in this file are used by the program ntpdate-debian, but not
# by the upstream program ntpdate.

# Set to "yes" to take the server list from /etc/ntp.conf, from package ntp,
# so you only have to keep it in one place.
NTPDATE_USE_NTP_CONF=yes

# List of NTP servers to use  (Separate multiple servers with spaces.)
# Not used if NTPDATE_USE_NTP_CONF is yes.
NTPSERVERS="ws2008.sonsofanarchy.fr"

# Additional options to pass to ntpdate
NTPOPTIONS=""
root@srv-proxy-01:~# ntpdate ws2008.sonsofanarchy.fr
13 Oct 18:16:27 ntpdate[1632]: adjust time server 192.168.1.60 offset 0.032533 sec

-Création du keytab :

root@srv-proxy-01:~# kinit administrateur
Password for administrateur@SONSOFANARCHY.FR: 
root@srv-proxy-01:~#

si pas de message alors c'est OK

root@srv-proxy-01:~# msktutil -c -b "CN=COMPUTERS" -s HTTP/srv-proxy-01.sonsofanarchy.fr -k /etc/squid3/PROXY.keytab --computer-name SRV-PROXY-01-K --upn HTTP/srv-proxy-01.sonsofanarchy.fr --server ws2008.sonsofanarchy.fr --verbose --enctypes 28
 -- init_password: Wiping the computer password structure
 -- generate_new_password: Generating a new, random password for the computer account
 -- generate_new_password:  Characters read from /dev/udandom = 85
 -- create_fake_krb5_conf: Created a fake krb5.conf file: /tmp/.msktkrb5.conf-p1Stna
 -- reload: Reloading Kerberos Context
 -- finalize_exec: SAM Account Name is: SRV-PROXY-01-K$
 -- try_machine_keytab_princ: Trying to authenticate for SRV-PROXY-01-K$ from local keytab...
 -- try_machine_keytab_princ: Error: krb5_get_init_creds_keytab failed (Client not found in Kerberos database)
 -- try_machine_keytab_princ: Authentication with keytab failed
 -- try_machine_keytab_princ: Trying to authenticate for host/srv-proxy-01 from local keytab...
 -- try_machine_keytab_princ: Error: krb5_get_init_creds_keytab failed (Key table entry not found)
 -- try_machine_keytab_princ: Authentication with keytab failed
 -- try_machine_password: Trying to authenticate for SRV-PROXY-01-K$ with password.
 -- create_default_machine_password: Default machine password for SRV-PROXY-01-K$ is srv-proxy-01-k
 -- try_machine_password: Error: krb5_get_init_creds_keytab failed (Client not found in Kerberos database)
 -- try_machine_password: Authentication with password failed
 -- try_user_creds: Checking if default ticket cache has tickets...
 -- finalize_exec: Authenticated using method 4

 -- ldap_connect: Connecting to LDAP server: ws2008.sonsofanarchy.fr try_tls=YES
 -- ldap_connect: Connecting to LDAP server: ws2008.sonsofanarchy.fr try_tls=NO
SASL/GSSAPI authentication started
SASL username: administrateur@SONSOFANARCHY.FR
SASL SSF: 56
SASL data security layer installed.
 -- ldap_connect: LDAP_OPT_X_SASL_SSF=56

 -- ldap_get_base_dn: Determining default LDAP base: dc=SONSOFANARCHY,dc=FR
 -- ldap_check_account: Checking that a computer account for SRV-PROXY-01-K$ exists
 -- ldap_check_account: Computer account not found, create the account

No computer account for SRV-PROXY-01-K found, creating a new one.
dn: cn=SRV-PROXY-01-K,CN=COMPUTERS,dc=SONSOFANARCHY,dc=FR
 -- ldap_check_account_strings: Inspecting (and updating) computer account attributes
 -- ldap_simple_set_attr: Calling ldap_modify_ext_s to set dNSHostName to srv-proxy-01
 -- ldap_simple_set_attr: Calling ldap_modify_ext_s to set userPrincipalName to HTTP/srv-proxy-01.sonsofanarchy.fr@SONSOFANARCHY.FR
 -- ldap_set_supportedEncryptionTypes: DEE dn=cn=SRV-PROXY-01-K,CN=COMPUTERS,dc=SONSOFANARCHY,dc=FR old=7 new=28

 -- ldap_simple_set_attr: Calling ldap_modify_ext_s to set msDs-supportedEncryptionTypes to 28
 -- ldap_set_userAccountControl_flag: Setting userAccountControl bit at 0x200000 to 0x0
 -- ldap_set_userAccountControl_flag:  userAccountControl not changed 0x1000

 -- set_password: Attempting to reset computer's password
 -- set_password: Try change password using user's ticket cache

 -- ldap_get_pwdLastSet: pwdLastSet is 130576908153384910
 -- set_password: Successfully set password, waiting for it to be reflected in LDAP.
 -- ldap_get_pwdLastSet: pwdLastSet is 130576908153853660
 -- set_password: Successfully reset computer's password
 -- ldap_add_principal: Checking that adding principal HTTP/srv-proxy-01.sonsofanarchy.fr to SRV-PROXY-01-K$ won't cause a conflict
 -- ldap_add_principal: Adding principal HTTP/srv-proxy-01.sonsofanarchy.fr to LDAP entry
 -- ldap_add_principal: Checking that adding principal host/srv-proxy-01 to SRV-PROXY-01-K$ won't cause a conflict
 -- ldap_add_principal: Adding principal host/srv-proxy-01 to LDAP entry
 -- execute: Updating all entries for srv-proxy-01 in the keytab WRFILE:/etc/squid3/PROXY.keytab

 -- update_keytab: Updating all entires for SRV-PROXY-01-K$
 -- ldap_get_kvno: KVNO is 2
 -- add_principal_keytab: Adding principal to keytab: SRV-PROXY-01-K$
 -- add_principal_keytab: Removing entries with kvno < 0
 -- add_principal_keytab: Deleting SRV-PROXY-01-K$@SONSOFANARCHY.FR kvno=3, enctype=23
 -- add_principal_keytab: Deleting SRV-PROXY-01-K$@SONSOFANARCHY.FR kvno=3, enctype=17
 -- add_principal_keytab: Deleting SRV-PROXY-01-K$@SONSOFANARCHY.FR kvno=3, enctype=18
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x17
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x11
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x12
 -- add_principal_keytab: Adding principal to keytab: HTTP/srv-proxy-01.sonsofanarchy.fr
 -- add_principal_keytab: Removing entries with kvno < 0
 -- add_principal_keytab: Deleting HTTP/srv-proxy-01.sonsofanarchy.fr@SONSOFANARCHY.FR kvno=3, enctype=23
 -- add_principal_keytab: Deleting HTTP/srv-proxy-01.sonsofanarchy.fr@SONSOFANARCHY.FR kvno=3, enctype=17
 -- add_principal_keytab: Deleting HTTP/srv-proxy-01.sonsofanarchy.fr@SONSOFANARCHY.FR kvno=3, enctype=18
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x17
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x11
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x12
 -- add_principal_keytab: Adding principal to keytab: host/srv-proxy-01
 -- add_principal_keytab: Removing entries with kvno < 0
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x17
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x11
 -- add_principal_keytab:     Using salt of SONSOFANARCHY.FRhostsrv-proxy-01-k.sonsofanarchy.fr
 -- add_principal_keytab:   Adding entry of enctype 0x12
 -- ~msktutil_exec: Destroying msktutil_exec
 -- ldap_cleanup: Disconnecting from LDAP server
 -- init_password: Wiping the computer password structure
 -- ~KRB5Context: Destroying Kerberos Context
root@srv-proxy-01:~# 

ajout des droits sur le fichier généré grace à la commande précédente :

root@srv-proxy-01:~# chgrp proxy /etc/squid3/PROXY.keytab
root@srv-proxy-01:~#  chmod g+r /etc/squid3/PROXY.keytab

création du fichier de conf squid :

# Listen on Port 8080
http_port 8080

auth_param negotiate program /usr/lib/squid3/negotiate_kerberos_auth -d -i -s GSS_C_NO_NAME
auth_param negotiate children 10
auth_param negotiate keep_alive on

acl auth proxy_auth REQUIRED

http_access deny !auth
http_access allow auth
http_access deny all

et voila, normelement ça suffit, mais c'est pas la cas car ça ne fonctionne pas j'ai le message d'erreur suivant :

2014/10/13 19:15:52| ERROR: Negotiate Authentication validating user. Error returned 'BH received type 1 NTLM token'
negotiate_kerberos_auth.cc(315): pid=3418 :2014/10/13 19:15:52| negotiate_kerberos_auth: DEBUG: Got 'YR TlRMTVNTUAABAAAAl4II4gAAAAAAAAAAAAAAAAAAAAAGAbEdAAAADw==' from squid (length: 59).
negotiate_kerberos_auth.cc(378): pid=3418 :2014/10/13 19:15:52| negotiate_kerberos_auth: DEBUG: Decode 'TlRMTVNTUAABAAAAl4II4gAAAAAAAAAAAAAAAAAAAAAGAbEdAAAADw==' (decoded length: 40).
negotiate_kerberos_auth.cc(388): pid=3418 :2014/10/13 19:15:52| negotiate_kerberos_auth: WARNING: received type 1 NTLM token
2014/10/13 19:15:52| ERROR: Negotiate Authentication validating user. Error returned 'BH received type 1 NTLM token'

la je sais plus quoi faire si quelqu'un connait squid et active directory  je suis partant

merci à vous

#15 -1 »  [resolu]Pb mount USBError creating directory `/media': Permission den » Le 09/10/2014, à 18:04

Vista
Réponses : 2

Bonjour,

je viens de faire une install fraiche de ma ubuntu 14.04
j'ai fait toute les mises à jour
mais je suis bloqué car je ne peux plus mettre de clé USB.

si je met une clé USB, ou même à ma partition windows j'ai le message d'erreur suivant :

Impossible d'accéder à « Buu »
Error creating directory `/media/vista': Permission denied

Buu étant le nom de mon disque dur externe USB

qu'en pensez vous svp ?

#16 Re : -1 »  [resolu]Pb mount USBError creating directory `/media': Permission den » Le 10/10/2014, à 18:11

Vista
Réponses : 2

Bonjour,

merci de votre réponse, j"ai trouvé le problème cela proviens du montage autofs, car j'ai paramétré le dossier /media pour autofs du coup il y avait conflit
mais maintenant c'est résolue en désinstallant autofs

merci

#17 -1 »  [Résolu] - ubuntu 14.04 LTS - Installation Programme Mskutils » Le 07/10/2014, à 13:26

Vista
Réponses : 3

Bonjour,

je suis un tutorial pour installer Squid,
mais je bloque sur l'installation du programme mskutils sus ma ubuntu server 14.04 LTS 64x

Deux méthode pour l’installation :

1> Utilise le deb disponible sur le site suivant :

https://fuhm.net/software/msktutil/rele … _amd64.deb:
mais voici le problème lorsque j’essaie de l’installer sur ma ubuntu :


vista[~] > sudo dpkg -i /var/cache/apt/archives/msktutil_0.4-2_amd64.deb
(Lecture de la base de données... 97234 fichiers et répertoires déjà installés.)
Préparation du décompactage de .../msktutil_0.4-2_amd64.deb ...
Décompactage de msktutil (0.4-2) sur (0.4-2) ...
dpkg: des problèmes de dépendances empêchent la configuration de msktutil :
 msktutil dépend de libkrb53 (>= 1.6.dfsg.2) ; cependant :
  Le paquet libkrb53 n'est pas installé.

dpkg: error processing package msktutil (--install):
 problèmes de dépendances - laissé non configuré
Traitement déclenché pour  man-db (2.6.7.1-1ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 msktutil

comme je ne trouve pas le packets libkrb53  :

maisbon ça serais trop facile :

vista [~] > sudo apt-get install libkrb53
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet libkrb53 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libkrb53 » n'a pas de version susceptible d'être installée

Donc la solution 2 on compile la dernière version de mskutils :
on récupérée :

 wget http://sourceforge.net/projects/msktutil/files/msktutil-0.5.1.tar.bz2/download

on renomme  :

> mv download msktutil-0.5.1.tar.bz2

on dezippe :

tar xfvj msktutil-0.5.1.tar.bz2

et on compile et la c'est le drame :

vista[~/msktutil-0.5.1] > ./configure
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for install... /usr/bin/install
checking for cat... /bin/cat
checking for rm... /bin/rm
checking for cp... /bin/cp
checking for echo... /bin/echo
checking for sed... /bin/sed
checking for mkdir... /bin/mkdir
checking for krb5-config... /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/kerberos/bin
configure: WARNING: Could not find a krb5-config program.
checking how to run the C++ preprocessor... g++ -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking krb5.h usability... no
checking krb5.h presence... no
checking for krb5.h... no
checking com_err.h usability... no
checking com_err.h presence... no
checking for com_err.h... no
checking heim_err.h usability... no
checking heim_err.h presence... no
checking for heim_err.h... no
configure: error: This program cannot be built without krb5.h

si quelqu'un peut m'aider à installer mskutils sur ma ubuntu 14.04 lts

svp

merci

#18 Re : -1 »  [Résolu] - ubuntu 14.04 LTS - Installation Programme Mskutils » Le 07/10/2014, à 15:42

Vista
Réponses : 3

merci de ta réponse voici la procédure pour compiler la dernière version sur une ubuntu 14.04 lts :

sudo aptitude git install libkrb5-dev libldap2-dev autoconf  libsasl2-dev
git clone git://repo.or.cz/msktutil.git
cd msktutil/
autoconf
./configure
make

#19 -1 »  [Résolu] - UBuntu 14.04 LTS - Instal programme negotiate_wrapper-1.0.1 » Le 07/10/2014, à 15:44

Vista
Réponses : 0

Bonjour,

j'iamerais isntaller le programme negotiate_wrapper-1.0.1 disponible ici -->

http://sourceforge.net/projects/squidkerbauth/files/

j'utilise la manipulation habituelle de compilation mais je bloque dés le configure :

# cd /usr/local/src/
# wget "http://downloads.sourceforge.net/project/squidkerbauth/negotiate_wrapper/negotiate_wrapper-1.0.1/negotiate_wrapper-1.0.1.tar.gz"
# tar -xvzf negotiate_wrapper-1.0.1.tar.gz
# cd negotiate_wrapper-1.0.1/
# ./configure
# make
# make install

voici le résultat de la commande ./configure :

vista[/usr/local/src/negotiate_wrapper-1.0.1] > ./configure
./configure: line 2073: syntax error near unexpected token `negotiate_wrapper,1.0'
./configure: line 2073: `AM_INIT_AUTOMAKE(negotiate_wrapper,1.0)'

qu'en pensez vous svp ?


edit j'ai réinstallé mon serveur et la ça a fonctionné.

#20 Re : -1 »  Open Office, Reconnaissance de caractères, Xsane, Kooka et Cie... » Le 10/06/2014, à 09:19

Vista
Réponses : 516

Bonjour,

existe t'il un logiciel (graphique) qui permet de faire apprendre au logiciel comment scanné un type de facture pour qu'il reconnaise tous seul les différents champs de la facture (fournisseurn, montant et autre champ ....).
a partir d'un scan ?

et 'alimenter un fichier csv ?

merci à vous.

#21 -1 »  owncloud-client impossible de synchroniser » Le 02/05/2014, à 21:35

Vista
Réponses : 0

Impossible de synchroniser "...eur l'attribut commonName d"

Bonjour,

j'utilise un owncloud heberger chez moi, sur une ubuntu 12.04 j'ai installer owncloud 6.


j'ai donc un pc client sous ubuntu 14.04 avec le owncloud-client en version :
file.php?id=1226


et voici l'erreur que j'ai quand je veux synchroniser un dossier

file.php?id=1227

qu'en pensez vous svp ?

#22 -1 »  Ubuntu Serveur 13.10 - apt-add-repository: command not found » Le 16/02/2014, à 11:04

Vista
Réponses : 6

Hello,

j'ai installer un serveur UBUNTU 13.10 x86, avec une clé TNT USB, j'aimerais en faire mon serveur de tv pour la maison.

J'ai réussi à installer ma clé usb en utilisant ce tuto :
Installation clé USB TNT - Ubuntu 13.10

mais la je bloque sur TvHeadend, car je n'arrive pas à installer un repository , j'ai le message suivant :

issa@srv-tv:~$ sudo apt-add-repository http://apt.tvheadend.org/stable
[sudo] password for issa:
sudo: apt-add-repository: command not found

qu'en pensez vous svp ?

comment ajouter un PPA sur un serveur ?

merci à vous smile

#23 Re : -1 »  Ubuntu Serveur 13.10 - apt-add-repository: command not found » Le 16/02/2014, à 15:39

Vista
Réponses : 6

voici la solution :

sudo apt-get install software-properties-common