Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  [ Résolu] Clonage HDD vers SDD » Le 28/02/2013, à 12:35

mattux
Réponses : 6

Bonjour à tous,

Je viens d'acheter un SSD Samsung 840 series de 120 Go, et je voudrais l'installer sur ma machine dans laquelle se trouve un disque dur de 500 Go.
L'espace utilisé sur ma partition Ubuntu est de 66 Go, ça passe donc largement sur le SSD. Problème, cette partition est plus large que le SSD, elle fait +/- 300 Go.

Après quelques recherches, j'ai vu que je devais réduire la partition avec un Live CD de Gparted puis la copier/coller sur mon SSD.

Ma question est que va t'il se passer pour le MBR? Est-ce que après la clonage j'ai juste à mettre mon SSD dans ma machine et tout démarre normalement?
Et pour le /etc/fstab, il sera le même que celui de mon ancien disque dur? Ça ne va pas poser problème?

Merci d'avance de votre aide

#1 Re : -1 »  [ Résolu] Clonage HDD vers SDD » Le 28/02/2013, à 13:42

mattux
Réponses : 6

Merci de ta réponse.

En fait sur mon ancien disque dur j'ai Ubuntu et Windows 7, et sur le SSD je ne compte garder que Ubuntu. Donc je vais devoir modifier le fstab.

Oui effectivement pour la swap je comptais la recréer moi même.

Pour le MBR il faut faire comment du coup ?

Non malheureusement c'est pour un PC portable, il n'y a la place que pour un seul disque. Je compte l'utiliser comme disque dur externe avec un adaptateur USB.

#2 Re : -1 »  [ Résolu] Clonage HDD vers SDD » Le 28/02/2013, à 14:20

mattux
Réponses : 6

Je me dis que si le fstab correspond à mon ancien disque, alors que le nouveau est présent dans le PC, ça risque de coincer non? Sachant que la taille de la partition système ne sera pas la même, que windows ne sera plus là...

OK je vais chercher comment réinstaller Grub wink

La copie je compte faire un simple copié collé de partition sous GParted. T'en penses quoi?

#3 Re : -1 »  [ Résolu] Clonage HDD vers SDD » Le 28/02/2013, à 21:39

mattux
Réponses : 6

Bon bah voilà, tout va bien la copie s'est bien passée et je suis sur mon nouveau SSD. Merci de ton aide!

En fait j'ai pas utilisé GParted mais l'utilitaire de partitionnement d'un live USB de Kubuntu (je pense qu'il est basé sur GParted quand même). Pour cloner un disque : avoir une partition de taille supérieure ou égale à la partition à copier. Copier/coller tout simplement la partition source vers la partition cible. Et c'est tout!

Ensuite j'ai utilisé "boot-repair" pour réinstaller le Grub, et j'ai modifié le fstab avec les optimisations de la doc pour les SSD.

Par contre j'arrive pas à restaurer la taille initiale de la partition de mon vieux disque dur que j'avais réduite pour le clonage... Il me met "erreur" sans plus de précision. Je crois que je vais effacer la totalité de ce disque.

#4 -1 »  [résolu] [Maven] Unable to locate the Javac Compiler » Le 21/12/2012, à 23:17

mattux
Réponses : 2

Bonjour,

Je cherche à utiliser Maven 3.0.4 sur Ubuntu pour builder des projets Java. J'ai installé Maven manuellement à l'aide du tuto suivant : http://doc.ubuntu-fr.org/maven#manuellement

Le problème, c'est qu'en lançant mvn clean package, j'obtiens l'erreur suivante :

[ERROR] Unable to locate the Javac Compiler in:
  /usr/lib/jvm/java-6-openjdk/jre/../lib/tools.jar
Please ensure you are using JDK 1.4 or above and
not a JRE (the com.sun.tools.javac.Main class is required).
In most cases you can change the location of your Java
installation by setting the JAVA_HOME environment variable.

Mes variables d'environnement sont définies dans le fichier /etc/environment de la façon suivante :

M2_HOME="/usr/local/apache-maven/apache-maven-3.0.4"
M2=$M2_HOME/bin
JAVA_HOME="/usr/lib/jvm/java-6-openjdk"

PATH="$JAVA_HOME/bin:$M2:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"

Vous avez une idée?

Merci

#6 Re : -1 »  [Résolu] SUPPRIMER PULSEAUDIO - Problèmes de son - JAUNTY » Le 08/06/2009, à 00:04

mattux
Réponses : 28

+1 je ne vois pas trop non plus l'intérêt du chargement/déchargement de module...

#7 Re : -1 »  Connexion d'un contact Amsn » Le 01/10/2009, à 21:39

mattux
Réponses : 16

+1, je rencontre le même problème depuis peu de temps. Il semblerait que microsoft ait changé quelquechose dans le protocole MSN hmm

#8 Re : -1 »  [Resolu] Supprimer Windows et Grub pour etre 100 % Ubuntu » Le 25/09/2007, à 21:52

mattux
Réponses : 17

Bonsoir,

j'avais déjà posté pour demander la même chose que toi parce que moi aussi j'avais le drapeau boot sur ma partition Windows que je voulais supprimer.

Finalement je m'étais lancé, et aucun problème.

Je te conseille quand même de faire une sauvegarde de tes données, mais il ne devrait pas y avoir de souci, GRUB étant installé dans le MBR (et donc il ne sera pas effacé quand tu supprimera Windows).

a+

#9 Re : -1 »  [HowTo] Synchroniser son PDA sous HARDY » Le 15/08/2008, à 19:26

mattux
Réponses : 149

Bonjour  tekman54000,


une petite suggestion concernant ton tuto :

tu dis qu'il faut supprimer les anciens modules rndis pour éviter que le noyau ne les recharge automatiquement au prochain démarrage, mais je trouve cette méthode un peu "bourrin". Ne serait-il pas plus judicieux de les blacklister dans le fichier /etc/modprobe.d/blacklist ?


Une autre question :

j'essaye de synchroniser mon PDA sous wm5 avec mon PC sous Ubuntu, mais je suis bloqué à l'étape du premier branchement de l'appareil.
synce-pls me retourne :

** Message: Hal reports no devices connected

** (process:13191): WARNING **: No devices connected to odccm
synce-pls: Could not find configuration at path '(Default)'

Merci de votre aide

#10 Re : -1 »  [HowTo] Synchroniser son PDA sous HARDY » Le 15/08/2008, à 20:18

mattux
Réponses : 149

uname -r donne "2.6.24-19-generic" (c'est pour ça que j'ai sauté l'étape de la compilation de rndis).

#11 Re : -1 »  [HowTo] Synchroniser son PDA sous HARDY » Le 18/08/2008, à 15:12

mattux
Réponses : 149

Up pour mon souci svp wink

#12 -1 »  [résolu] plus de son après winecfg » Le 08/12/2008, à 14:42

mattux
Réponses : 2

Bonjour,

Suite à l'upgrade de Hardy vers Intrepid, j'avais des problèmes de son dans Trackmania sous Wine. Autrement le son des autres applications (autres que avec Wine) fonctionnait parfaitement.

Tout à l'heure j'ai essayé de changer de pilote audio dans winecfg (j'ai mis OSS à la place de ALSA) et depuis plus aucun son, que ce soit sous Wine ou autre ! Alors que je n'ai touché à rien d'autre... Aidez-moi, je ne peux même plus écouter de musique !

Merci d'avance

#13 Re : -1 »  [résolu] plus de son après winecfg » Le 08/12/2008, à 17:23

mattux
Réponses : 2

Problème résolu avec la commande

sudo /etc/init.d/alsa-utils reset

#14 -1 »  [résolu] pas de son sous kubuntu 8.04 » Le 17/08/2008, à 22:24

mattux
Réponses : 3

Bonjour,

j'ai installé kubuntu 8.04 à partir du CD (pas une mise à jour donc) et je n'ai pas de son, alors que tout fonctionnait sous gusty. J'utilise KDE 3.5.9.

Vous avez une idée ?
Merci de vos réponses

#15 Re : -1 »  [résolu] pas de son sous kubuntu 8.04 » Le 17/08/2008, à 23:30

mattux
Réponses : 3

lspci me renvoie : Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

#16 Re : -1 »  [résolu] pas de son sous kubuntu 8.04 » Le 18/08/2008, à 15:17

mattux
Réponses : 3

Problème résolu, en fait j'ai refait une installation mais en allumant les enceintes au moment du boot sur le live CD, et ça marche smile

#17 Re : -1 »  TrackMania United et wine, erreur non listé sur la doc... » Le 16/03/2008, à 13:28

mattux
Réponses : 8

As-tu bien placé le fichier d3dx9_30.dll dans le répertoire windows de wine comme indiqué dans la doc ?

Ce problème peut aussi venir d'une manette de jeu branchée sur le port USB. Débranche la et relance le jeu.

Sinon peut être que tu as oublié le no-CD nécessaire pour lancer le jeu car la protection du CD n'est pas supportée sous wine (starforce).

Les erreurs dans la console n'ont rien à voir avec le fait que le jeu ne se lance pas, je les ai également mais tout marche parfaitement.

#18 -1 »  [résolu] je n'arrive pas à  compiler avec l'option -g pour débuguer » Le 05/01/2008, à 12:48

mattux
Réponses : 4

Bonjour,

Je voudrais débuguer mon programme sous GDB. J'ai lu qu'il fallait d'abord le compiler en passant l'option -g à  GCC.

Mais le compilateur me sort tout un tas d'erreurs : "undefined reference to `fonction'" alors que j'ai bien inclus les .h correspondants. De plus quand je compile le projet normalement (sans -g dans la ligne de commande) ces erreurs n'apparaissent pas et le programme se compile.

P.S. Mon projet est composé de plusieurs fichiers .c et .h et j'utilise un Makefile.

Merci d'avance.

#19 Re : -1 »  [résolu] je n'arrive pas à  compiler avec l'option -g pour débuguer » Le 05/01/2008, à 12:56

mattux
Réponses : 4

Les voici :

make
gcc -g fonctions_cartes.c -o fonctions_cartes.o
/usr/lib/gcc/i486-linux-gnu/4.1.3/../../../../lib/crt1.o: In function `_start':
(.text+0x18): undefined reference to `main'
/tmp/ccw40xEG.o: In function `afficherCarte':
/home/matthieu/Documents/Programmation/poker/fonctions_cartes.c:185: undefined reference to `couleurCaractere'
/home/matthieu/Documents/Programmation/poker/fonctions_cartes.c:185: undefined reference to `couleurCaractere'
/home/matthieu/Documents/Programmation/poker/fonctions_cartes.c:188: undefined reference to `couleurCaractere'
/home/matthieu/Documents/Programmation/poker/fonctions_cartes.c:188: undefined reference to `couleurCaractere'
/home/matthieu/Documents/Programmation/poker/fonctions_cartes.c:191: undefined reference to `couleurCaractere'
/tmp/ccw40xEG.o:/home/matthieu/Documents/Programmation/poker/fonctions_cartes.c:191: more undefined references to `couleurCaractere' follow
collect2: ld a retourné 1 code d'état d'exécution
make: *** [fonctions_cartes.o] Erreur 1

#20 Re : -1 »  [résolu] je n'arrive pas à  compiler avec l'option -g pour débuguer » Le 05/01/2008, à 13:02

mattux
Réponses : 4

Ok merci de ta réponse ça marche maintenant ! smile

#21 -1 »  [résolu] APT cassé :( » Le 20/10/2007, à 11:01

mattux
Réponses : 1

Bonjour à tous,

Je suis sous Kubuntu Feisty et j'ai vu sur la page d'accueil du site kubuntu-fr que KDE 3.5.8 est disponible pour Feisty. J'ai donc ajouté le dépôt et fait la mise à jour, mais Adept a crashé pendant l'installation des paquetages, avant qu'elle ne se termine.

J'ai essayé de lancer un apt-get install -f pour corriger le problème, mais il me dit que la base de données des paquets est verrouillée, et il est également impossible de lancer Adept (j'ai tué tous les processus qui utilisait APT donc le problème ne vient pas de là).

Avez-vous une idée sur ce que je pourrais faire ? Je n'ose plus redémarrer mon PC parce que KDE ne se lancera pas puisque la mise à jour n'est pas terminée...

Merci d'avance

#22 Re : -1 »  [résolu] APT cassé :( » Le 20/10/2007, à 11:31

mattux
Réponses : 1

Finalement je viens de trouver la solution dans le manuel de APT smile Il suffisait de taper cette commande :

sudo dpkg --configure -a

J'ai redémarré et tout va bien j'ai le nouveau KDE. smile
Bonne journée

#23 Re : -1 »  un log comme snagit??? » Le 12/08/2007, à 22:02

mattux
Réponses : 6

Sinon il y a recordmydesktop, disponible dans les paquets (sudo apt-get install recordmydesktop).

#24 Re : -1 »  Ubuntu fait il comme windows ? » Le 08/08/2007, à 19:06

mattux
Réponses : 22

Qu'est-ce que tu veux dire par "le compilateur d'Ubuntu" ? Tu parles de GCC ? Si tu parles de GCC tu te trompes parce qu'il est sous licence GPL.

Non l'exécutable produit par tel ou tel compilateur n'est pas totalement identique, mais c'est quand même une "traduction" du code source donc si il n'y a pas de "saloperies" dans le code source il n'y en aura pas dans l'exécutable.