Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  [ VOS SCRIPTS UTILES ] (et eventuelles demandes de scripts...) » Le 05/10/2014, à 16:29

cedric.amouyal
Réponses : 1861

Script pour renommer ses vidéos et ne pas avoir des noms à rallonge.
Il est adaptable suivant les cas

IFS=$'\n'
for i in ` find ~/Vidéos/ -type f`
#for i in ` find ~/Vidéos/ -type f -mtime -30`
do
cd $(dirname $i)
file=$(basename $i)
#echo analyse de $i
 rename -v  "s/.*\] //g" "$file"
 rename -v  "s/FRENCH//gi" "$file"
 rename -v  "s/[ \.\_\-](ts|xvid|webrip|dvdrip|hdrip|brrip|dvdscr|md|french|r5|r6|2013|2014|stvfrv)?[\. \-\_]?/./ig" "$file"
 rename -v  "s/[ \.\_\-](carpediem|fuzion|brother|fqt|firetown|subforced|nikoo|shift|true|cpasbien|M0NiC0|ghost|wawa)?[\. \-\_]?/./ig" "$file"
 rename -v  "s/[ \._-]{2}/./g" "$file"
 rename -v  "s/[ ]avi$/.avi/g" "$file"
done

#1 Re : -1 »  [RESOLU] Comment trouver une commande sans Internet » Le 14/07/2015, à 20:00

cedric.amouyal
Réponses : 6

unzip
gunzip
tar xzvf
tar xjvf

En supposant que tu as l'outil en local

cd /usr/share/doc/
grep -irl "le  mot clé" *

man -k "motclé"

#2 Re : -1 »  imprimante canon et scanner » Le 28/06/2015, à 10:55

cedric.amouyal
Réponses : 17
cat <<EOF > ~/.local/share/applications/scannercanon.desktop
[Desktop Entry]
Name=Scanner Canon MG5550
Comment=
Exec=/usr/bin/scangearmp
Icon=xyscanIcon
Terminal=false
Type=Application
StartupNotify=true
EOF

#3 Re : -1 »  apt-get Lecture des listes de paquets TRÈS lent ! » Le 03/06/2015, à 22:14

cedric.amouyal
Réponses : 7

Astuce pour reduire le temps de la lecture des packages avec le apt-get update
1) Identifier un repository anormalement important

cd /var/lib/apt/lists
ls -Srlh

Si vous identifiez des repository bizarres, modifier vos /etc/atp/sources.lists

2)Si vous n'utilisez que des packages 64Bits

sed -i  's/deb ht/deb [arch=amd64] ht/g' /etc/apt/sources.list

3) Limiter les langues

#4 Re : -1 »  ksshaskpass ne veut pas passer par kwallet » Le 07/02/2013, à 15:25

cedric.amouyal
Réponses : 9

il faut que ta passphrase soit vide

#5 Re : -1 »  [Résolu] ouvrir swf avec firefox ou chromium » Le 24/03/2015, à 21:10

cedric.amouyal
Réponses : 31

Pour ma part, ni chrome ni ff n'ouvre le swf malgré les modifications.
Vous trouverez un script qui crée un fichier html par swf ci-dessous qui rempli 90% de votre résolution actuelle.
swf2html.sh

#!/bin/bash
for i in `ls  -1 *.swf`
do
echo "$i --> ${i//.swf/.html}"
cat << EOF > ${i//.swf/.html}
<!DOCTYPE html>
<html lang="en">
<head>
	<title>$i</title>
	<meta charset="utf-8">
</head>

<body>
<embed width=$( xrandr --current |awk -F, '/^Screen/ {print $2}'|awk '{print $2*9/10" height="$NF*9/10}') src="$i">
</body>
</html>
EOF

done

#6 -1 »  [RESOLU] virt-manager : installer une VM fedora 21 » Le 09/03/2015, à 23:21

cedric.amouyal
Réponses : 0

après pas mal de galère, je donne l'astuce pour pouvoir installer une  vm fedora 21 dans virtual-manager sur ubuntu.

A priori, cela a l'air d'être simple mais ce n'est pas le cas.

Lors de la création de la VM, virt-manager plante avec un message de ce type

Unable to complete install: 'internal error: process exited while connecting to ... -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channel/target/ ... Failed to bind socket: Permission denied qemu-system-x86_64:

surtout ne pas fermer la fenetre!
Lancer les commandes suivantes:

aa-complain $(ls -rt1 /etc/apparmor.d/libvirt/libvirt-* |tail -1 |sed s/.files$// )
modprobe vhost_net
echo vhost_net >> /etc/modules-load.d/modules.conf

Et après relancer le processus d'installation
et Hop, cela marche comme par magie smile

#7 Re : -1 »  Ubuntu 14.04.1 : gros soucis WIFI suite à mise à jour » Le 14/12/2014, à 12:45

cedric.amouyal
Réponses : 2

1er etape identifier ta carte wifi

lspci |grep -iE "wireless|network"

Après google est ton ami

Après c'est du cas par cas. Il se peut que la version fournit via le kernel n'est pas compatible avec ta carte, il se peut que ce soit un conflit.

Sinon voir les logs

dmesg
less /var/log/kern.log

#8 Re : -1 »  simple scan ne peut plus être paramétré » Le 27/11/2014, à 21:56

cedric.amouyal
Réponses : 21

essaie de virer ton cache

sudo rm -rf ~/.cache/simple-scan

#9 Re : -1 »  ecran noir AMD/ATI Mobility Radeon HD 5430/5450/5470 » Le 10/11/2014, à 21:26

cedric.amouyal
Réponses : 14

Le seul et vrai problème est que fglrx est incompatible pour le moment avec xorg 1.16. Il faut attendre qu'une nouvelle version sorte

#10 Re : -1 »  ecran noir AMD/ATI Mobility Radeon HD 5430/5450/5470 » Le 09/11/2014, à 22:12

cedric.amouyal
Réponses : 14

Moi j'ai abandonné fglrx. Je suis passé au driver radeon

sudo apt-get install -f xserver-xorg-video-ati mesa-vdpau-drivers 
cat << EOF |sudo tee /etc/modprobe.d/ati.conf
blacklist fglrx
options radeon dpm=1
EOF


sudo cp  /etc/X11/xorg.conf  /etc/X11/xorg.conf.$(date +%Y%m%d)
cat << EOF |sudo tee /etc/X11/xorg.conf
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
#	Option	    "DPMS" "true"
	Modeline     "1600x900"	107.90  1600 1648 1680 1920  900 903 908 936 -hsync -vsync
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "radeon"
	BusID       "PCI:0:1:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes "1600x900"
	EndSubSection
EndSection
EOF


cat << EOF |sudo tee /etc/udev/rules.d/30-radeon-pm.conf
KERNEL=="card0", SUBSYSTEM=="drm", DRIVERS=="radeon", ATTR{device/power_method}="profile", ATTR{device/power_profile}="auto"
#/sys/class/drm/card0/device/power_profile
EOF

sudo reboot

Je ne suis pas satisfait car l'ai l'impression que le ventilo surchauffe
Par contre ma carte graphique fonctionne en 3D

/usr/lib/nux/unity_support_test -p
OpenGL vendor string:   X.Org
OpenGL renderer string: Gallium 0.4 on AMD ARUBA
OpenGL version string:  3.0 Mesa 10.3.0

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes
sudo lshw -c video
  *-display               
       description: VGA compatible controller
       produit: Trinity [Radeon HD 7420G]
       fabriquant: Advanced Micro Devices, Inc. [AMD/ATI]
       identifiant matériel: 1
       information bus: pci@0000:00:01.0
       version: 00
       bits: 32 bits
       horloge: 33MHz
       fonctionnalités: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       ressources: irq:49 mémoire:e0000000-efffffff portE/S:3000(taille=256) mémoire:f0300000-f033ffff

#11 Re : -1 »  ecran noir AMD/ATI Mobility Radeon HD 5430/5450/5470 » Le 22/11/2014, à 23:29

cedric.amouyal
Réponses : 14

Bonjour,
J'apporte une correction à mon post précédent:
- Les surchauffes étaient du à des processus tracker-*  installé suite à la mise à jour

Il y en a en fait plein de processus à la con ajouté par ubuntu qui polluait ma machine comme des geoclue, mediascanner, telepathy, oneconf ...
et que je n'utilisai pas.

Ma configuration Radéon semble bonne et le fonctionnement semble correcte.

cat << EOF >  /etc/X11/xorg.conf
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Modeline     "1600x900"	107.90  1600 1648 1680 1920  900 903 908 936 -hsync -vsync
	Modeline     "1600x900"	71.87	1600 1648 1680 1920  900 903 908 936 -hsync -vsync
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "radeon"
	BusID       "PCI:0:1:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes "1600x900"
	EndSubSection
EndSection
EOF

Donc Attention, il faut surveiller ses processus tracker qui font surchauffer la CPU et dont on ne sait pas trop  à quoi ils servent à part indexé pour ubuntu.

C'est peut être à cause d'eux que ton ordi à rendu l'ame donc méfiance.

cdlt,
Cédric

#12 Re : -1 »  Ubunt ne démarre pas après mise à jour ubuntu 14.04 » Le 12/10/2014, à 13:31

cedric.amouyal
Réponses : 2

essaye de redémarrer avec un liveusb et faire un update-grub

#13 Re : -1 »  Fichiers impossibles à supprimer (le fichier n'existe pas) » Le 05/10/2014, à 16:08

cedric.amouyal
Réponses : 58

Une technique infaillible

cedric@cedric-laptop:~/Vidéos$ touch /tmp/test
cedric@cedric-laptop:~/Vidéos$ ls -i /tmp/test 
1705388 /tmp/test
cedric@cedric-laptop:~/Vidéos$ find /tmp -inum 1705388 
/tmp/test
cedric@cedric-laptop:~/Vidéos$ find /tmp -inum 1705355 
cedric@cedric-laptop:~/Vidéos$ find /tmp -inum 1705388 -delete
cedric@cedric-laptop:~/Vidéos$ ls -i /tmp/test 
ls: impossible d'accéder à /tmp/test: Aucun fichier ou dossier de ce type
cedric@cedric-laptop:~/Vidéos$

#14 -1 »  Installation de google play sous tab750 de Logicom » Le 09/11/2013, à 22:39

cedric.amouyal
Réponses : 0

Je me suis calqué sur ce tuto et adapté à ubuntu

Site comment ca marche

Activer les mode debugage sur la tablette
Applications\Paramètres\Options pour les Developpeurs\Debogages\Debogage USB  [X]

Telecharger l'archive suivante et en extraire que les 2 apk

APK pour google Play


apt-get install android-tools-adb android-tools-fastboot 

Connecter en usb votre tablette
 

adb devices
adb shell id
adb remount
adb push Vending.apk /system/app
adb remount
adb push Phonesky.apk /system/app
adb remount

adb shell
exit

Ca y est vous avez google play et installé ce que vous voulez  smile

#15 Re : -1 »  [RESOLU] Avantages et inconvénients de lvm ? » Le 09/11/2013, à 22:20

cedric.amouyal
Réponses : 5

lvm est loin d etre abandonné car c'est une technologie qui est utilisé sur nombre de serveur et de technologie linux/unix comme redhat fedora aix et j'en passe. Mais pour le commun des mortelle la sur couche lvm n'est pas obligatoire même si il y a de très bon tuto sur internet pour redimensionner les FileSystems mal dimensionné à la base. Attention il faut pas confondre lvm et gparted. Gparted est fait pour gérer ses partitions lvm

Pour resumer lvm
Il y a les pv (Physical Volume) qui sont des disques physiques ou des partition type 8e dans fdisk ou gparted.
On aggrege ces pv dans des ensembles de VG (Volume Groupe) evolutif que l'on partitionne en LV(logical volume) ou partition virtuelle que l'on peut formatter en ce que l'on veut ext4 swap ....

Sur redhat, fedora les commandes principales sont
lvm
pvcreate
vgcreate
lvcreate
pvscan
vgscan
lvscan
vgextends

Bon courage,

#16 Re : -1 »  Problème perl exécution du programme impossible » Le 10/06/2013, à 15:58

cedric.amouyal
Réponses : 1

ton entete n'est pas bon

#!/usr/bin/perl -w

#17 Re : -1 »  Linux plante...encore une fois. » Le 07/06/2013, à 13:38

cedric.amouyal
Réponses : 4

tu lis ton pdf avec quoi Adobe, le pdf viewer  ou gimp...?

Essaye de changer de lecteur ...

sinon vire tes .cache/ de ton application et réessaye
je trouve perso que xfce est léger et relativement stable... Donc xubuntu doit l'être...
ecran noir, C'est peut -être du aussi au drivers de ta carte graphique...  Regarde si tu as bien suivi les procedures d'installation de ta carte graphique...

Ton erreur parle de ta swap  qui génère une erreur kernel... Est ce que tu as bien dimensionné cela et que tu n'as pas fais de modification à ce niveau???

#18 Re : -1 »  Rewrite Rules marchent en localhost et pas à travers le réseua local » Le 12/04/2013, à 14:41

cedric.amouyal
Réponses : 3

IL faut rajouter des entrées avec des alias de ton tuto_poo_mvc
ServerAlias @IP


http://httpd.apache.org/docs/2.2/fr/vho … based.html


puis restart du service apache

#19 Re : -1 »  configuration privoxy » Le 07/02/2013, à 15:23

cedric.amouyal
Réponses : 1

tu changes ton port d'ecoute de ton privoxy par defaut sur le 8118 vers 3128

#20 Re : -1 »  [Resulo]Could not exec dpkg! » Le 01/02/2013, à 15:16

cedric.amouyal
Réponses : 5
apt-get download dpkg

cela va te récupérer ton package dpkg dans ton répertoire courant
et tu le dé-zippes
et recolle ton exécutable au bonne endroit

#21 Re : -1 »  [Resulo]Could not exec dpkg! » Le 01/02/2013, à 15:25

cedric.amouyal
Réponses : 5

tu ouvres ton archives avec le gestionnaire d'archive tu va dans  /usr/bin de l'archive et tu sors le fichier dpkg de  l'archive dans /usr/bin/

#22 Re : -1 »  [Resulo]Could not exec dpkg! » Le 01/02/2013, à 15:31

cedric.amouyal
Réponses : 5

Essaie de lire ton archive dpkg avec la commande suivante sinon tu mets le même que ton archive

ar p dpkg_1.16.7ubuntu6_amd64.deb data.tar.gz | tar tz

si ca marche

ar p dpkg_1.16.7ubuntu6_amd64.deb data.tar.gz |tar xz -C /

ca va te reextraire le contenu de ton archive

#23 Re : -1 »  impossible telecharger msvcp60.dll [RESOLU] » Le 28/01/2013, à 10:14

cedric.amouyal
Réponses : 6

si tu exécutes des exécutables Windows sur du Linux t'es mal barré smile