Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  Gmpc et pochettes [résolu] » Le 03/01/2015, à 10:19

Machtheld
Réponses : 1

Bonjour, et bonne année à tous!

Je viens d'installer Mpd sur une machine qui me sert de serveur musical, et j'aimerais la piloter à distance au moyen de Gmpc. A première vue, ça a l'air pas mal du tout: support du multitags et navigation par tags entièrement paramétrable.

Seulement, je cherche un moyen d'afficher les pochettes qui se trouvent sur le disque dur, et ça a l'air vraiment compliqué et chronophage. Apparemment, il faut installer et surtout compiler le plugin Albumview, avec tout ce que cela implique de tâtonnements, de paquets manquants etc. Sans vouloir vexer qui que ce soit, la dépense de temps et d'énergie me paraît parfaitement disproportionnée par rapport à cette toute petite fonction basique.

Donc, existe-t-il un moyen d'obtenir les pochettes sans passer une demi-journée à fouiller dans les entrailles de son système pour essayer de trouver une solution à ce @%$ de paquet manquant/incompatible?

Merci d'avance pour vos avis!

#1 Re : -1 »  Gmpc et pochettes [résolu] » Le 17/01/2015, à 19:51

Machtheld
Réponses : 1

...la réponse était on ne peut plus simple:

sudo apt-get install gmpc-plugins

roll

#2 Re : -1 »  Tuto - Contrôler sa musique avec son SmartPhone » Le 16/01/2015, à 19:16

Machtheld
Réponses : 2

Je déterre ce sujet, parce que j'ai suivi ce tuto (merci beaucoup, au passage). La partie "installation et configuration de MPD" s'est déroulée sans problème sur un petit ordi qui fait office de serveur musical. J'ai pu lancer la musique au moyen d'une autre machine.

Mais tout s'est gâté lorsque j'ai installé MPDroid sur mon téléphone. Pas de problème pour la configuration, mais MPD, ou PDroid, ont planté l'interface graphique du serveur. J'ai un écran noir avec une grande croix à la place du curseur de la souris.

C'est très bizarre, car le problème est survenu lorsque j'ai voulu lancer la lecture d'un disque au moyen de mon téléphone. J'ai désactivé l'application MPDroid, mais, même en redémarrant l'ordinateur, je n'avais pas d'interface graphique. La seule solution que j'ai trouvée a été de redémarrer en mode de dépannage, de taper "startx", et ensuite de désactiver le lancement de MPD au démarrage.

Quelqu'un aurait-il une idée de l'origine du problème? Merci d'avance.

#3 -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 03/01/2015, à 15:22

Machtheld
Réponses : 14

...et qui fonctionnait parfaitement jusqu'il y a quelques jours!

Bonjour à tous, j'ai deux machines A et B que j'ai reliées en NFS à l'aide de ce tuto: http://doc.ubuntu-fr.org/tutoriel/un_simple_partage_nfs.

Tout marchait très bien jusqu'à ce que je m'absente quelques jours avec la machine B. A mon retour, impossible d'accéder au dossier /pointdemontagesurB. On peut voir les fichiers, mais on ne peut rien copier.

J'ai vérifié que la machine n'avait pas changé d'IP, puis j'ai suivi le tuto "résolution de problèmes". Et là, ça coince au montage automatique des fichiers. Jusque-là tout va bien:

machtheld@debian:~$ showmount -e 192.168.1.78
Export list for 192.168.1.78:
/home/machtheld/musique 192.168.1.21
machtheld@debian:~$ 

Puis ça se gâte:

sudo mount -t nfs -o rw 192.168.1.78 /home/machtheld /musique/ /media/serveur/
Usage: mount -V                 : print version
       mount -h                 : print this help
       mount                    : list mounted filesystems
       mount -l                 : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
       mount device             : mount device at the known place
       mount directory          : mount known device here
       mount -t type dev dir    : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
One can change the type of mount containing the directory dir:
       mount --make-shared dir
       mount --make-slave dir
       mount --make-private dir
       mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
       mount --make-rshared dir
       mount --make-rslave dir
       mount --make-rprivate dir
       mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using  -L label  or by uuid, using  -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdf

J'ai beau chercher dans la doc', je ne vois pas pourquoi il ne veut pas de l'option -t. Et surtout, je ne comprends pas pourquoi ce qui fonctionnait il y a huit jours ne marche plus.

J'ai vérifié les /etc/fstab des deux machines, et rien ne cloche. Avez-vous des idées? Merci d'avance!

#4 Re : -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 03/01/2015, à 18:31

Machtheld
Réponses : 14

Bonjour Braun,

Non, il y avait bien un espace, et un seul, j'ai vérifié...sinon, j'ai essayé en enlevant "-o rw" (qui est pourtant dans le tuto, et qui fonctionnait il y a quelques jours).

Rien à faire, il continue à me faire un cours sur la commande "mount".

#5 Re : -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 03/01/2015, à 19:15

Machtheld
Réponses : 14

Ça ne marche pas:

mount.nfs: remote share not in 'host:dir' format

sad

#6 Re : -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 03/01/2015, à 20:23

Machtheld
Réponses : 14

C'est normal, je ne tapais jamais tout ça en console, c'était dans le fstab comme indiqué dans le tuto.

La ligne dans mon fstab (avec le : wink ):

192.168.1.78:/home/machtheld/musique /media/serveur   nfs    user,noauto	0   0

#7 Re : -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 17/01/2015, à 10:22

Machtheld
Réponses : 14

...bon, il semble que j'aie un problème de permissions sur mon point de montage sur client.

/etc/exports sur serveur:

/home/mathilde/musique/ 192.168.1.21(rw,all_squash,anonuid=1000,anongid=1000,sync)

Je peux lire les fichiers de /media/serveur, mais, même en root, je ne peux rien copier...

/etc/hosts.allow sur serveur:

portmap: 192.168.1.21
lockd: 192.168.1.21
nfsd: 192.168.1.21
mountd: 192.168.1.21
rquotad: 192.168.1.21
statd: 192.168.1.21

/etc/hosts.deny sur serveur:

portmap:ALL
nfsd:ALL
mountd:ALL

/etc/fstab sur client (déjà donné):

192.168.1.78:/home/machtheld/musique /media/serveur   nfs    user,noauto	0   0

Si ça se trouve, ce sont les options dans /etc/exports ou dans le fstab qui ne sont pas (plus) bonnes...je cherche...

#8 Re : -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 17/01/2015, à 10:47

Machtheld
Réponses : 14

Ah ça y est, j'ai compris ce qui n'allait pas:

Sur le serveur, c'est un disque externe qui est monté sur /home/machtheld/musique.

Mon partage NFS fonctionne parfaitement, mais c'est le disque dur qui se monte en lecture seule. Je pense que quelques recherches devraient résoudre le problème.

#9 Re : -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 17/01/2015, à 11:48

Machtheld
Réponses : 14

Bah, mon DD est formaté en ntfs, c'est sûrement ça qui **** la *****...j'ai essayé un sudo chmod 777 /home/machthed/musique sur le serveur.

Pas de message d'erreur, mais pas de résultat. :-(

J'ai tenté le montage manuel comme indiqué sur le tuto:

sudo mount -t nfs -o rw 192.168.1.1:/Fichiers_à_partager_sur_Serveur /Point_de_montage_sur_Client

Et là, j'arrive enfin à copier mes fichiers. En revanche, pas de montage automatique: "panne d'accès au système de fichiers nfs".

#10 Re : -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 17/01/2015, à 11:55

Machtheld
Réponses : 14

1) Le disque n'a jamais été débranché à la barbare, j'en prends un soin dévot car il contient toute ma discothèque 2) Je viens de réussir à copier des fichiers. Pour la "panne", je cherche encore.

#11 Re : -1 »  [résolu] Partage NFS qui ne fonctionne plus... » Le 17/01/2015, à 12:45

Machtheld
Réponses : 14

...et voilà, problème résolu par un petit tour ici: http://doc.ubuntu-fr.org/tutoriel/comme … ns_windows, et les options qui vont bien dans le /etc/fstab du serveur.

Merci Braun, et bon week-end!

#12 -1 »  [Astuces] Faire communiquer facilement un téléphone Android et un PC » Le 05/01/2015, à 09:09

Machtheld
Réponses : 12

J'espère que je ne suis pas en train de réinventer l'eau chaude (auquel cas vous pouvez effacer ce message), mais:

Installer gmtp
Relier le téléphone à l'ordi au moyen du câble USB
Faire dans une console "sudo gmtp"
Une fenêtre s'ouvre, appuyer sur "connecter". Voilà.

#13 Re : -1 »  [Astuces] Faire communiquer facilement un téléphone Android et un PC » Le 05/01/2015, à 23:07

Machtheld
Réponses : 12
tiramiseb a écrit :

Relier le téléphone à l'ordi au moyen du câble USB
Cliquer sur l'icône qui apparaît



Ubuntu supporte (enfin) correctement MTP nativement depuis 2 ou 3 versions.

Oui, mais cela ne marche pas chez moi (je suis sous Crunchbang smile)

#14 Re : -1 »  [Astuces] Faire communiquer facilement un téléphone Android et un PC » Le 16/01/2015, à 19:29

Machtheld
Réponses : 12

Certes, mais 1°) ça peut intéresser des gens qui ont des versions plus anciennes d'Ubuntu 2°) des tas de gens utilisent d'autres distributions Linux, et ont le réflexe de venir ici à la pêche aux informations 3°) je n'ai pas trouvé gmtp dans la documentation. En fait, l'information n'était pas si facile à trouver, c'est pourquoi j'ai pensé qu'elle pouvait dépanner quelqu'un.

#15 -1 »  Quel gestionnaire de bureau pour un smartphone? » Le 04/01/2015, à 14:06

Machtheld
Réponses : 6

Bonjour à tous, je viens d'installer Ubuntu 13.10 sur mon smartphone, au moyen de Complete Linux Installer.

Surprise, je me retrouve avec un environnement de bureau inutilisable: affichage très lent, menus microscopiques, et un look très vintage dans le plus pur style Windows 95.

La meilleure solution serait sans doute de désinstaller complètement le gestionnaire de bureau pour installer autre chose. Premier problème, je ne sais pas ce que j'ai comme gestionnaire de bureau. Y a-t-il une commande permettant de connaître les paquets à désinstaller?

Deuxième problème, quoi installer à la place? J'aimerais bien pouvoir utiliser Ubuntu dans le sens de la largeur de mon téléphone, et avoir des icônes pratiques. Y a-t-il des paquets "Ubuntu Touch"?

Il va sans dire qu'avant de poser ma question j'ai fouillé en vain dans la documentation. Merci d'avance de vos lumières.

#16 Re : -1 »  Quel gestionnaire de bureau pour un smartphone? » Le 04/01/2015, à 14:21

Machtheld
Réponses : 6

Bonjour Jean-Philippe,

Ah ouais quand même...six mois de vie ce n'est vraiment pas beaucoup!

L'installeur proposait la 13.4 et la 13.10. J'ai pris cette dernière, croyant installer Ubuntu Touch. Y a-t-il moyen de rectifier le tir sans tout réinstaller?

#17 Re : -1 »  Quel gestionnaire de bureau pour un smartphone? » Le 04/01/2015, à 14:36

Machtheld
Réponses : 6

D'accord, merci!...en plus je viens de trouver la version Open-Source de Linux Installer.

Je recommence tout, et je reviens si j'ai des questions. Merci smile

http://sourceforge.net/projects/linuxon … files/App/

#18 Re : -1 »  Quel gestionnaire de bureau pour un smartphone? » Le 04/01/2015, à 14:47

Machtheld
Réponses : 6

..."votre appareil est compatible avec les distributions suivantes: Ubuntu 13.4, 13.10" sad

J'ai donc opté pour Archlinux. Et comme environnement de bureau, qu'est-ce qui est le plus pratique? Gnome shell?

Désolée pour ces questions, mais tout cela est assez jeune, et il n'y a pas tant de documentation que cela sur le sujet...

#19 Re : -1 »  Quel gestionnaire de bureau pour un smartphone? » Le 04/01/2015, à 18:23

Machtheld
Réponses : 6

...bon, finalement, je ne m'en sors pas...

L'image d'Archlinux étant corrompue, j'ai eu la flemme d'en télécharger une autre, et j'ai voulu utiliser Ubuntu 13.4. L'installation s'est déroulée sans difficulté, mais problème, le sources.list n'est pas à jour et impossible d'installer quoi que ce soit.

Pour le mettre à jour, deux solutions:

-Lancer l'intervalle graphique, mais là je n'ai pas de clavier
-Lancer une console via Linux Installer. J'ai fait nano /etc/apt/sources.list, et modifié mon fichier...pour m'apercevoir que je ne savais pas du tout comment enregistrer mes modifications! Ben oui, normalement on fait Ctrl-X, puis O et Entrée, mais là, impossible de trouver ce qui correspond à la trouche Ctrl (les touches de volume?...ça n'a pas fonctionné).

Quelqu'un aurait-il une idée?...j'ai un fichier très important que je ne peux faire fonctionner que sous Linux...

#20 -1 »  Connexion en ssh: sudo obligatoire » Le 22/12/2014, à 11:53

Machtheld
Réponses : 1

Bonjour à tous,

J'ai une machine qui sert de serveur audio. Je me connecte à partir de ma machine principale en ssh, au moyen d'un petit script commandé par un raccourci clavier.

J'ai dû réinstaller un système tout neuf sur le serveur. Or, bien que l'adresse IP n'ait pas changé, j'ai désormais du mal à me connecter en ssh.

ssh nom@adresseIP

donne:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
6c:23:fa:dc:8f:ca:76:82:f4:blablabla
Please contact your system administrator.
Add correct host key in /home/nom/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /home/nom/.ssh/known_hosts:1
ECDSA host key for 192.168.1.XX has changed and you have requested strict checking.
Host key verification failed.

En revanche,

sudo ssh nom@adresseIP

permet de me connecter sans problème.

Comment supprimer cette demande de sudo?

[edit] ah oui, pardon, j'oubliais. J'ai bien sûr fait ce qui était indiqué dans le message, c'est-à-dire ajouter la clé à host key in /home/nom/.ssh/known_hosts. Mais cela ne change rien.

Merci d'avance!

#21 Re : -1 »  Connexion en ssh: sudo obligatoire » Le 22/12/2014, à 20:41

Machtheld
Réponses : 1

...j'ai trouvé la réponse ici: http://doc.ubuntu-fr.org/ssh

Il faut taper ceci dans un terminal:

ssh-keygen -R [IP de la machine]

#22 Re : -1 »  Installer ubuntu avec Coreboot [résolu] » Le 04/12/2014, à 19:33

Machtheld
Réponses : 6

Volontiers:

HAL

You must load the kernel first

MOI

cat (usb0)/isolinux/install.cfg

HAL

label installgui
    menu label install
    kernel /install/gtk/vmlinuz
   append initrd=/install/gtk/initrd.gz (...)

MOI

cat (usb0)/isolinux/gtk/vmlinuz

HAL

error: invalid magic number

???????

#23 Re : -1 »  Installer ubuntu avec Coreboot [résolu] » Le 09/12/2014, à 10:36

Machtheld
Réponses : 6

Salut nany,

Excuse-moi pour mon silence. Pour pouvoir reprendre pas à pas, il me faut deux machines, car c'est quand même compliqué d'éteindre la bécane et changer le disque dur pour répondre à chaque question...

Donc je reposterai la réponse détaillée dans quelques jours. Rapidement: j'avais bien vérifié, au moyen de

ls

, que "usb0" était correct.

#24 Re : -1 »  Installer ubuntu avec Coreboot [résolu] » Le 12/12/2014, à 19:30

Machtheld
Réponses : 6

Bon, eh bien finalement, problème résolu...par la mise à jour du BIOS. Il est possible de démarrer sur une clé USB sans se farcir quinze lignes de commandes ésotériques.

Comme il n'est vraiment pas évident de trouver des explications intelligibles sur la manière de flasher le BIOS Coreboot, je mets le lien ici: https://github.com/bibanon/Coreboot-Thi … inkPad-X60

Merci beaucoup Nany, pour ton aide :-)