Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 21

#0 -1 »  Squid et deuxième connexion Internet de secours [RESOLU] » Le 16/11/2012, à 14:03

frstanislas
Réponses : 3

Bonjour,
Nous utilisons squid comme serveur-proxy sur un poste Ubuntu 10.04.
Les utilisateurs du réseau passent par ce serveur-proxy pour accéder à Internet en paramétrant dans leurs navigateurs Internet l'adresse IP du serveur (192.168.1.1) et le port 8080.
Le poste du serveur-proxy accède à Internet via une passerelle (192.168.1.11), qui est un routeur D-Link, branché sur un modem ADSL. La passerelle par défaut du poste squid est donc 192.168.1.11. J'ai programmé ce routeur pour que seul le serveur-proxy puisse y accéder (évidemment).
Tout fonctionne à merveille.

J'ai à ma disposition un autre routeur sur le même réseau local (192.168.1.12), qui est lui aussi branché sur un autre modem, avec une autre connexion Internet vers un autre FAI.
J'ai fait un petit script qui ping une adresse IP sur le premier routeur, pour surveiller la connexion Internet ; si la connexion principale tombe, le script change la passerelle par défaut : 192.168.1.12 au lieu de 192.168.1.11. J'utilise : ip route change default via 192.168.1.12 dev eth0.
Dès que la connexion principale revient, la script rechange la passerelle par défaut, et remet la première.

Tout fonctionne bien, sauf squid, qui ne supporte pas !
Dès que la connexion de secours tombe (192.168.1.12), même si la connexion principale fonctionne, squid renvoie les utilisateurs vers le routeur de secours, alors que la connexion du routeur principal fonctionne !!!
Si on accède à Internet directement depuis le serveur- proxy, sans passer par squid, là tout marche : c'est donc bien squid, qui ne veut pas.

Il doit y avoir un problème de cache ou de DNS ?
Est-ce qu'il n'y aurait pas un paramètre, du genre cache_peer, à mettre dans le squid.conf ?

Merci de votre aide.

#1 Re : -1 »  Squid et deuxième connexion Internet de secours [RESOLU] » Le 16/11/2012, à 16:53

frstanislas
Réponses : 3

Encore moi. Re-bonjour.
Je me demande, maintenant, si mon problème ne vient pas plutôt de ip route, que j'utilise pour changer de passerelle par défaut : est-ce que ip route ne met pas en cache les demandes de pages Internet ?
Je cherche, je cherche...

#2 Re : -1 »  Squid et deuxième connexion Internet de secours [RESOLU] » Le 19/11/2012, à 00:19

frstanislas
Réponses : 3

Bonjour,
Ça y est : j'ai trouvé ! Ouf, j'y ai mis le temps... pour un truc tout bête.
C'était un problème de DNS : c'était le bazar sur le poste du serveur ! J'avais mis comme DNS les deux adresses IP de mes routeurs, et non pas les vrais adresses IP des DNS des FAI.
Normalement on peut le faire, mais le deuxième routeur, un Netgear, renvoie une page HTML quand il perd la connexion Internet, page HTML qui fait croire que le DNS répond, alors que ce n'est pas le cas !
J'ai mis les DNS proprement, et ça marche.
Merci à ceux qui ont tenté de m'aider.

#3 -1 »  Squid - Répartir la charge entre 2 lignes ADSL (Load balancing...) » Le 06/11/2010, à 13:43

frstanislas
Réponses : 11

Bonjour,
Nous utilisons comme serveur proxy Squid 3.1.3 sur Ubuntu Lucid.
Nous avons un routeur-modem ADSL Linksys, et une ligne ADSL 512K (on ne peut pas avoir plus dans notre bled pommé...).
Par contre, nous allons disposer d'une deuxième ligne ADSL 512, et nous avons déjà un 2ème routeur-modem (non utilisé) identique au premier.

Comment faire pour que Squid répartisse la charge web entre les 2 routeurs (c'est à dire entre les 2 lignes ADSL) ?

Merci beaucoup. smile

#4 Re : -1 »  Squid - Répartir la charge entre 2 lignes ADSL (Load balancing...) » Le 07/11/2010, à 10:58

frstanislas
Réponses : 11

Bonjour.
Merci à vous pour ces pistes: je vais creuser la question à partir de là...
Mais je ne pensais pas que ce soit si compliqué.
J'aurais aimé un truc simple, car je ne connais pas Ubuntu à fond : les règles iptables, je ne connais pas trop, trop... sad

Est-ce que, par exemple, Balance, ça ne pourrait pas faire ?
"balance 3.42 –  A simple TCP proxy with load balancing and failover mechanisms.
Balance is a simple, generic "userland" TCP proxy, which allows simple round-robin load balancing and
graceful failover between several destination servers.
Balance is available at http://balance.sourceforge.net."

Merci beaucoup pour votre aide à tous. smile

#5 Re : -1 »  Squid - Répartir la charge entre 2 lignes ADSL (Load balancing...) » Le 07/11/2010, à 21:09

frstanislas
Réponses : 11

Merci pour cette réponse : effectivement je ne suis vraiment pas à l'aise dans les routages, réseaux, ponts... Il va falloir que je bouquine un peu tout ça. Merci pour les liens.

Par contre, est-ce que je ne pourrais pas résoudre mon problème avec balance ? Je peux installer sans problème un second serveur squid sur un deuxième poste Ubuntu. Je peux mettre sur le 1er serveur, comme passerelle, l'adresse IP du 1er routeur ASDL. Et sur le 2nd serveur l'adresse IP du 2ème routeur. Si j'installe balance sur le 1er serveur, est-ce qu'il pourra répartir la charge entre les deux serveurs, et donc entre les deux routeurs, et donc entre les deux lignes ADSL ?
Bon, d'accord, ça fait deux serveur à gérer, mais ce n'est pas bien compliqué...
Qu'en pensez-vous ?

#6 Re : -1 »  Squid - Répartir la charge entre 2 lignes ADSL (Load balancing...) » Le 08/11/2010, à 09:39

frstanislas
Réponses : 11

Merci.
Avec tout ça, je vais bien finir par trouver la bonne solution.
Mais il faut d'abord que je me forme un peu sur les ip routes, ip rules, ifconfig, bond et autres bêtes de ce genre, car c'est tout emmêlé dans mon petit cerveau...
Je vais creuser.

#7 -1 »  Proxy Squid et problème de DNS (timeout DNS ?) » Le 10/09/2011, à 10:51

frstanislas
Réponses : 5

Bonjour,
Nous disposons de 2 connexions Internet, avec chacune son modem et son routeur (je peux basculer de l'une à l'autre comme je veux) :
1) ADSL 512K MagicOnline (on ne peux pas avoir plus que 512K à la campagne, et nous voudrions nous en débarrasser)
2) Satellite 10Mégas SkyDSL (rapide, malgré un temps de latence)
Nous avons un serveur proxy Squid (Squid-3.1.3 et SquidGard-1.4) sur un poste local ubuntu 10.04, avec derrière sur le réseau local une trentaine de postes.

Avec l'ADSL, tout est OK (mais c'est lent, à 512K : normal !).
Avec le satellite, si on passe par Squid, c'est bon sauf qu'on ne peux pas accéder aux sites colissimo.fr, chronopost.fr, coliposte.fr, colis-logistique.com, sherlocks.lcl.fr, et sans doute d'autres... : on obtient l'erreur timeout DNS de Squid.
J'ai fait l'essai : si on ne passe pas par Squid, mais directement par le routeur : ces sites marchent bien !

A la base, c'est un problème de DNS, car si je récupère les adresses IP de colissimo.fr...etc avec nslookup, et que je mets les adresses IP dans le fichier /etc/hosts, colissimo et ses "collègues" se mettent à marcher avec Squid !
Si je mets les DNS de MagicOnline (ADSL) dans le paramètre dns_namservers de Squid, et que je passe par le routeur satellite, ça ne marche pas. Mais si je rajoute une route pour router les DNS magicOnline vers le routeur de la connexion ADSL MagicOnline, ça marche !

Un info : quand on recherche avec nslookup l'adresse IP des sites qui posent problème, on obtient toujours un avertissement : "DNS request timed out. timeout was 2 seconds." Mais pas d'avertissement de ce genre avec tous les autres sites.

Le problème, en fait, est de savoir pourquoi ça marche en direct SANS Squid avec le satellite, mais PAS AVEC Squid ? Quel paramètre faut-il modifier dans Squid ?

Merci de votre aide à tous.:)

#8 Re : -1 »  Proxy Squid et problème de DNS (timeout DNS ?) » Le 14/09/2011, à 08:36

frstanislas
Réponses : 5

Bonjour,
Personne n'a d'idée ? sad Pourtant il ne s'agit vraisemblablement que d'un paramètre de Squid 3 à régler...

J'ai installé un serveur DNS Bind, mais ça n'améliore pas la connexion vers colissimo.

Si quelqu'un pouvait au moins me mettre sur une piste. Merci à tous.

#9 Re : -1 »  Proxy Squid et problème de DNS (timeout DNS ?) » Le 14/09/2011, à 09:47

frstanislas
Réponses : 5

Bonjour,
Merci pour la réponse. Oui, seulement les sites suivants ne fonctionnent pas (timeout DNS) :
colissimo.fr, chronopost.fr, coliposte.fr, colis-logistique.com, sherlocks.lcl.fr

Voici le résultat de : grep -i "^acl" /etc/squid/squid.conf :

acl all src all
acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32
acl localnet src 10.0.0.0/8    # RFC1918 possible internal network
acl localnet src 172.16.0.0/12    # RFC1918 possible internal network
acl localnet src 192.168.0.0/16    # RFC1918 possible internal network
acl SSL_ports port 443        # https
acl SSL_ports port 563        # snews
acl SSL_ports port 873        # rsync
acl Safe_ports port 80        # http
acl Safe_ports port 21        # ftp
acl Safe_ports port 443        # https
acl Safe_ports port 70        # gopher
acl Safe_ports port 210        # wais
acl Safe_ports port 1025-65535    # unregistered ports
acl Safe_ports port 280        # http-mgmt
acl Safe_ports port 488        # gss-http
acl Safe_ports port 591        # filemaker
acl Safe_ports port 777        # multiling http
acl Safe_ports port 631        # cups
acl Safe_ports port 873        # rsync
acl Safe_ports port 901        # SWAT
acl purge method PURGE
acl CONNECT method CONNECT
acl shoutcast rep_header X-HTTP09-First-Line ^ICY.[0-9]
acl apache rep_header Server ^Apache

C'est bizarre quand même : avec la connexion ADSL, squid fonctionne bien. Avec la connexion satellite, squid affiche une erreur DNS timeout pour les 5 sites ci-dessus comme colissimo, mais fonctionne avec tous les autres sites. Avec la connexion satellite sans squid, en direct par le routeur, tout fonctionne !
Qu'est-ce que ça peut être ?
Merci.

#10 Re : -1 »  Proxy Squid et problème de DNS (timeout DNS ?) » Le 14/09/2011, à 11:30

frstanislas
Réponses : 5

J'ai déjà essayé avec le dns_timeout de squid : ça ne change rien. De toutes façons la valeur par défaut de dns_timeout est 5 minutes !

Pas de chance alors ? Bizarre, bizarre...
Merci quand même.

#11 -1 »  Squid et colissimo.fr et chronopost.fr » Le 28/02/2011, à 00:00

frstanislas
Réponses : 1

Bonjour,
Nous utilisons un serveur proxy squid v.3.1.3 (avec squidguard1.4) sur ubuntu 10.04 64 bits.
Le serveur squid accède à Internet par un routeur D-Link DIR 100 et un modem ADSL D-Link.
Il y a une cinquantaine de clients sur le réseau local, qui se partagent la connexion ADSL.
Tout fonctionnait au poil.
Mais brusquement, depuis jeudi dernier, 3 sites ne sont plus accessibles par squid : www.colissimo.fr/, www.colis-logistique.com/ et www.chronopost.fr/ : ça patine pendant quelques minutes, puis "timeout DNS". Ceci pour tous les clients. Tous les autres sites fonctionnent, sans exception visible.

Ce qui est curieux, c'est que si on passe directement par le routeur sans passer par squid, ça marche !
Sur le poste de squid, si on utilise Mozilla (qui ne passe pas le proxy) pour accéder à ces 3 sites, ça marche !!
J'avais gardé un vieux poste, avec ubuntu 8.04 et squid 3.0 : je l'ai redémarré : les 3 sites en question fonctionnent avec ce vieux poste !
J'ai vérifié mon squid.conf, j'ai court-circuité squidguard, j'ai essayé en HTTPS : rien n'y fait !

D'où cela peut-il venir ? Ont-ils fait des changements sur ces 3 sites ?
Ce qui est aussi curieux, c'est que chronoposte.fr marche, mais pas chronopost.fr.
Merci de votre aide à tous : je suis bien embêté.:(

#12 Re : -1 »  Squid et colissimo.fr et chronopost.fr » Le 28/02/2011, à 16:37

frstanislas
Réponses : 1

Re-bonjour.
Personne ne peut m'aider ?
Merci.

#13 -1 »  [Résolu] Fetchmail - Ligne d'en-tête incorrecte - Mail supprimé » Le 25/10/2010, à 09:24

frstanislas
Réponses : 3

Bonjour,
Nous utilisons Postfix en serveur de mails local, et Fetchmail 6.3.9-rc2 pour relever les mails en POP3 ; le tout sur Ubuntu Lucid 10.04.
Malheureusement, Fetchmail ne délivre pas et supprime les mails, dont le champs To comporte plusieurs destinataires, et dont certains sont séparés par un retour à la ligne.
Exemple de champs To :
To: dquaimmest@iol.ie, bruno.mallenten@foireachtas.ie, stephanercis@aliceadsl.fr, editorfmar@fmavoice.ie,
jfedtinn@googlemail.com, 21meenogh12@hotmail.com, paulaharmen3@gmail.com, papillon2025@freesurf.fr,
aciss1961@rocketmail.com, francoisreth@northhouse.plus.com, gerna_48@yahoo.com, patricknessa@yahoo.co.uk,
ok4monnes@openworld.com, plorelys@aol.com, hippons@libertysurf.fr, damerik8@yahho.fr

Rassurez-vous : j'ai modifié les adresses, pour qu'elles ne soient pas spammées. Mais on voit bien les retours à la ligne.
Actuellement, nous recevons en moyenne 1 mail sur 10 avec ce problème ! Et la plupart ne sont PAS des spams. Donc, 1 mail sur 10 est supprimé par Fetchmail ! yikes

Fetchmail reconnaît les destinataires situés après le (ou les) retour à la ligne comme une nouvelle entête, mais INCORRECTE : et il a raison.
Mais il ne délivre pas le message et le supprime purement et simplement (voir le log plus bas).

Comment faire pour ne pas perdre ce message, qui est tout à fait lisible par Postfix et les logiciels clients de lecture de mail (même si le champs To n'est pas 100% correct) ? Comment faire pour forcer Fetchmail à transmettre le mail à Postfix purement et simplement ?

Merci de votre aide à tous : je suis bien embêté... sad

Voici le log (en verbose) :
Oct 24 16:58:52 MonServeur fetchmail[5494]: 6.3.9-rc2 interroge SMTP_FAI (protocole POP3) à dim. 24 oct. 2010 16:58:52 CEST : récupération en cours
Oct 24 16:58:52 MonServeur fetchmail[5494]: Essai de connexion avec SMTP_FAI/110...connecté.
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK <46707671.20847@domaineduserveur.com>, POP3 server ready.
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3> CAPA
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK Capability list follows
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< USER
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< TOP
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< UIDL
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< EXPIRE NEVER
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< .
Oct 24 16:58:52 MonServeur fetchmail[5494]: SMTP_FAI: échec du passage en TLS mais on continue quand-même.
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3> USER archives
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK archives is known here.
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3> PASS *
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK Welcome! 1 messages (17050 bytes)
Oct 24 16:58:52 MonServeur fetchmail[5494]: sélection ou re-réception du dossier par défaut
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3> STAT
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK 1 17050
Oct 24 16:58:52 MonServeur fetchmail[5494]: 1 message pour archives dans SMTP_FAI (17050 octets).
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3> LIST 1
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK 1 17050
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3> RETR 1
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK Here it comes...
Oct 24 16:58:52 MonServeur fetchmail[5494]: lecture du message archives@SMTP_FAI:1 parmi 1 (17050 octets)
Oct 24 16:58:52 MonServeur fetchmail[5494]: Sur le point de réécrire From: Pierre et Marie <petmgrive@aol.com>#015#012La version réécrite est From: Pierre et Marie <petmgrive@aol.com>#015#012
Oct 24 16:58:52 MonServeur fetchmail[5494]: Sur le point de réécrire To: dquaimmest@iol.ie, bruno.mallenten@foireachtas.ie, stephanercis@aliceadsl.fr, editorfmar@fmavoice.ie,#015#012La version réécrite est To: dquaimmest@iol.ie, bruno.mallenten@foireachtas.ie, stephanercis@aliceadsl.fr, editorfmar@fmavoice.ie,#015#012
Oct 24 16:58:52 MonServeur fetchmail[5494]: ligne d'en-tête incorrecte trouvée lors du scan des en-têtes
Oct 24 16:58:52 MonServeur fetchmail[5494]: ligne: jfedtinn@googlemail.com, 21meenogh12@hotmail.com, paulaharmen3@gmail.com, papillon2025@freesurf.fr,#015
Oct 24 16:58:52 MonServeur fetchmail[5494]:  éliminé
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3> DELE 1
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK Message deleted.
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3> QUIT
Oct 24 16:58:52 MonServeur fetchmail[5494]: POP3< +OK domaineduserveur.com Server closing down.
Oct 24 16:58:52 MonServeur fetchmail[5494]: 6.3.9-rc2 interroge SMTP_FAI (protocole POP3) à dim. 24 oct. 2010 16:58:52 CEST : interrogation finie
Oct 24 16:58:52 MonServeur fetchmail[5494]: ne permute pas les listes d'UID, aucun UID vu dans cette requête
Oct 24 16:58:52 MonServeur fetchmail[5494]: fin normale, état 0

#14 Re : -1 »  [Résolu] Fetchmail - Ligne d'en-tête incorrecte - Mail supprimé » Le 26/10/2010, à 10:14

frstanislas
Réponses : 3

Bonjour,
Après bien des recherches, j'ai résolu le problème.
J'ai installé la dernière version de Fetchmail : 6.3.18, qui corrige le bug.
Il y a maintenant une nouvelle option : bad-header accept (voyez man fetchmail).
Grâce à cette option, les mails avec des entêtes incorrectes sont quand même délivrés.
Ouf ! J'en ai bavé...

#15 -1 »  Procmail avec Fetchmail et Postfix - Maildrop ? » Le 08/10/2010, à 16:10

frstanislas
Réponses : 0

Bonjour,
J'utilise Postfix avec Fetchmail et Promail, en Maildir.
Fetchmail relève les messages en POP3 et les passe directement à Promail : d'abord /etc/procmailrc, puis /var/mail/"user"/.procmailrc. Et enfin, Procmail les délivre dans les boîtes.
Presque à chaque relève de mails, il y a un ou deux messages qui se perdent. Ou bien un message reste mystérieusement dans le dossier new du Maildir, sans passer dans le dossier cur après visualisation par Webmin, et Webmin ne l'affiche pas (il faut envoyer un autre message dans cette boîte pour débloquer).
Je me demande si Procmail est bien fiable ? Dans le man fetchmailrc, ils disent qu'ils peut y avoir des problèmes avec Procmail. yikes
J'ai essayé de verrouiller les règles de Procmail, mais ce n'est pas tellement mieux.
D'où cela peut-il venir ? Est-ce que Maildrop est mieux ? Merci de votre aide à tous.

Voici un échantillon de mon /etc/procmailrc :

PATH=/usr/local/bin:/usr/bin:/bin
DEFAULT=$HOME/Maildir/
ORGMAIL=/var/mail/gestion/Maildir/
LOGFILE=/var/log/procmail.log
MAILDIR=/var/mail/
DROPPRIVS=yes

# Copie de TOUS les messages en provenance de l'extérieur pour faire un test
:0c:copiearchives.lock
!archives

# Spamassassin
:0fw:spamassassin.lock
|spamc

:0:envoispam.lock
*^X-Spam-Status:.Yes
!spams

:0c:copiehams.lock
!hams

# Copie des commandes suivant les langues
:0c:copieespagnol.lock
*^Subject:.*Procesar.Pedido.*
!espagnol

:0c:copiefrancais.lock
*^Subject:.*Traitement.de.la.commande.No.*
!francais

:0c:copieanglais.lock
*^Subject:.*Order.Process.*
!anglais

# Copie des messages restants pour faire un test
:0c:copietest.lock
!test
sad

#16 -1 »  [Résolu] Postfix - Refuser l'envoi de mails externes » Le 27/09/2010, à 08:16

frstanislas
Réponses : 2

Bonjour,
Est-il possible avec Postfix de refuser à un utilisateur (un jeune enfant, par exemple) l'envoi de mails externes ? Mais il faut qu'il puisse envoyer des mails aux boîtes locales.

Merci à tous.:)

#17 Re : -1 »  [Résolu] Postfix - Refuser l'envoi de mails externes » Le 27/09/2010, à 21:53

frstanislas
Réponses : 2

Merci Uggy !
Exactement ce que je cherchais.
J'ai interdit (avec un !) l'adresse IP dans mynetworks, et hop ça marche. Super. smile
C'est simple et efficace ! wink

#18 -1 »  [Résolu] Postfix - Une copie de tous les messages sortants » Le 24/09/2010, à 16:22

frstanislas
Réponses : 5

Bonjour,
J'utilise Postfix + Procmail + Dovecot sur un réseau ethernet local, avec Fetchmail pour rapatrier les mails de l'extérieur.
On me demande de réaliser une copie automatique dans une boite locale, pour archives, de tous les messages sortants (destinataires non locaux), mais pas des messages locaux.

Je m'explique :
Tous mes utilisateurs locaux utilisent une adresse From du type : utilisateur@mondomaine.

Quand toto@mondomaine envoie un message à titi@free.fr, il faut réaliser une copie vers la boite archives@mondomaine.
Mais quand toto@mondomaine envoie un message à tata@mondomaine, il ne faut pas de copie d'archives.

Comment faire ?
J'ai essayé d'utiliser smtp_header_checks, mais en vain...:(

Merci pour votre aide.:|

#19 Re : -1 »  [Résolu] Postfix - Une copie de tous les messages sortants » Le 24/09/2010, à 17:06

frstanislas
Réponses : 5

Merci pour la réponse.
Oui les utilisateurs sont prévenus, mais ce n'est pas pour le patron : ça nous simplifierait le travail à tous (trop long à expliquer...).

Mais ça ne marche pas avec always_bcc : TOUS les messages sont copiés vers l'adresse d'archives.
Il faudrait que seuls les messages sortants (destinataires non locaux) soient copiés.

Merci.

#20 Re : -1 »  [Résolu] Postfix - Une copie de tous les messages sortants » Le 25/09/2010, à 08:50

frstanislas
Réponses : 5

Merci à Uggy : ça marche avec sa solution ! big_smile Enfin, presque : il faut utiliser recipient__bcc_maps (et non sender_bcc_maps).
recipient_bcc scrute les champs To
sender_bcc scrute le champs From

J'ai ajouté dans mon main.cf :
recipient_bcc_maps = regexp:/etc/postfix/recipient_bcc

J'ai créé un fichier /etc/postfix/recipient_bcc, qui contient :
!/(mondomaine)/    archives

Et donc, pour tous les mails qui ont au moins un destinataire qui n'est pas de mon domaine : une copie est déposée dans la boîte archives.
Et puis, cerise sur le gâteau : une seule copie d'archive est créée, même s'il y a plusieurs destinataires extérieurs. Au poil !

Encore merci à Uggy pour sa piste précieuse.:)


PS : rassurez-vous, les utilisateurs sont avertis, ils sont même tout à fait d'accord... Eh oui... wink