Contenu | Rechercher | Menus

Annonce

Le forum a une nouvelle maison !
Le forum a été migré sur un nouvel hébergement. Si jamais vous trouvez le moindre problème, n'hésitez pas à nous en faire part !
Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  historique de firefox » Aujourd'hui à 16:17

dva2tlse
Réponses : 0

Bonjour,
je voudrais ré-activer l'historique de firefox.
Bien évidemment au début il marchait, mais maintenant il n'enregistre plus rien. (enfin, les onglets fermés sont enregistrés quand même)
J'ai un raccourci pour lancer une deuxième instance de firefox, en no-remote, depuis une console, et je peux vérifier avec les bookmarks qu'il n'y a pas de confusion entre le profil de base ou le deuxième.
Hédonc je voudrais que le firefox N°1, profil de base, enregistre bien l'historique.
Je l'ai pourtant bien évidemment activé par "Remember History" dans les préférences de firefox.
J'ai aussi essayé de triturer quelques valeurs du "About Config" qui me paraissaient judicieuses, mais rien n'y fait.
Quelqu'un a-t'il une idée à laquelle je n'aurais pas songé ?
Merci,
David

#1 -1 »  historique de firefox [toujours pas RÉSOLU] » Le 09/02/2016, à 17:02

dva2tlse
Réponses : 8

Bonjour,
je voudrais ré-activer l'historique de firefox.
Bien évidemment au début il marchait, mais maintenant il n'enregistre plus rien.
J'ai un raccourci pour lancer une deuxième instance de firefox, en no-remote, depuis une console, mais je peux vérifier avec les bookmarks que le profil utilisé est bien celui de base.
Hédonc je voudrais qu'il enregistre l'historique.
Je l'ai pourtant bien évidemment activé par "Remember History" dans les préférences de firefox.
J'ai aussi essayé de triturer quelques valeurs du "About Config" qui me paraissaient judicieuses, mais rien n'y fait.
Quelqu'un a-t'il une idée à laquelle je n'aurais pas songé ?
Merci,
David

#2 Re : -1 »  historique de firefox [toujours pas RÉSOLU] » Le 09/02/2016, à 17:15

dva2tlse
Réponses : 8

Merci, mais dans cette option "custom settings", ils ne me plaisent pas vraiment; je voudrais que tout soit retenu sans réfléchir.


EDIT: Bon j'en ai eu marre de farfouiller depuis plusieurs jours déjà, dont j'ai tout effacé brutalement, et ça remarche; il devait y avoir une des entrées de l'historique qui bloquait l'enregistrement de nouvelles. Donc -> [RÉSOLU]

EDIT2: Et en fait "pas du tout", je me retrouve simplement sans historique puisque je l'ai effacé, et rien de neuf ne s'y ajoute, donc je n'ai pas avancé.

#3 Re : -1 »  historique de firefox [toujours pas RÉSOLU] » Le 09/02/2016, à 18:38

dva2tlse
Réponses : 8

oui je vais changer de nom parce que je préfère garder les cookie's de login ici et là...
Merci
PS demain sûrement...

#4 Re : -1 »  historique de firefox [toujours pas RÉSOLU] » Le 10/02/2016, à 16:13

dva2tlse
Réponses : 8

Oui, bin bon ça ne fait rien; j'avais déjà l'historique des fenêtres fermées qui marchait bien, et il marche toujours, mais l'historique de base, celui qui rappelle les pages simplement visitées, ne remarche pas en ayant renommé le dossier .mozilla: Il s'en crée simplement un nouveau, de dossier, puisque l'original est momentanément indisponible, mais il ne sert pas plus pour l'historique que je n'ai toujours pas; je soupçonne toujours qu'il y ait une issue favorable en modifiant une entrée du about:config, mais je ne sais pas laquelle.

#5 Re : -1 »  historique de firefox [toujours pas RÉSOLU] » Le 10/02/2016, à 17:30

dva2tlse
Réponses : 8

YOUPI ça remarche,
sudo apt-get update et sudo apt-get install firefox
me donnent l'historique, tout au moins en passant par l'icône "menu" de firefox, puisque j'ai perdu pour l'instant la barre de menus, mais ça, ça ne m'inquiète pas puisque j'ai déjà vu quelque part comment m'en débrouiller.
À+,
David

#6 Re : -1 »  Itérer une variable à partir d'un fichier dans shell » Le 28/12/2015, à 18:34

dva2tlse
Réponses : 16

Bonsoir Crocefisso,
je n'ai pas tout lu, j'ai été dégoutè dès que j'ai vu tes boucles C-like. Il est plus simple à mon avis d'utiliser seq. (vois man seq)

NAME
       seq - print a sequence of numbers

SYNOPSIS
       seq [OPTION]... LAST
       seq [OPTION]... FIRST LAST
       seq [OPTION]... FIRST INCREMENT LAST

HTH,
David

#7 Re : -1 »  Exécution fichier .sh » Le 28/12/2015, à 18:26

dva2tlse
Réponses : 1

Bonjour Fifidibosco,
hébin tu commences par faire

man skype

, (mais je ne l'ai pas, donc je ne peux pas t'aider plus)
puis éventuellement si ça marche, tu fais

skype < RTN.txt

HTH
avec RTN.txt un fichier qui ne contient qu'un RETURN. (ou deux, c'est selon)

#8 Re : -1 »  Problème Shutdown » Le 28/12/2015, à 11:08

dva2tlse
Réponses : 3

Bonjour bidibulle,
moi je me suis fait toute une série d'alias avec "mdp"= mon mot de passe pour passer root en sudo :
(cela me permet de contrôler la machine en console)(qu'on obtient avec CTRL+ALT+T)

alias HIB='echo mdp|sudo -S echo HIB Ok; free -h; sudo pm-hibernate'
alias RBT='echo mdp|sudo -S echo RBT Ok; sudo shutdown -r now'
alias SDN='echo mdp|sudo -S echo SDN Ok; sudo shutdown -P now'

Il faut avoir installé pm-utils auparavant avec (en console encore)

sudo apt-get install pm-utils

Bonne continuation,
David

#9 Re : -1 »  Problème Shutdown » Le 28/12/2015, à 18:05

dva2tlse
Réponses : 3

Bonsoir bidibulle,
j'ai un peu lu le post de ton lien, ça m'a juste rappelé qu'à un moment où j'ai bidouillé avec des machines virtuelles, il fallait les démarrer avec +/- APCI (je ne sais même plus) pour que l'horloge marche plus ou moins bien; mais ça fait pas beaucoup avancer le schmilblick.
  Bonnes fêtes,
David

#10 Re : -1 »  Problème de mise en veille » Le 28/12/2015, à 14:45

dva2tlse
Réponses : 1

Bonjour PoissonLune0,
je viens de répondre à une question assez similaire, donc pour l'instant je recopie bêtement et on pourra continuer à discuter s'il faut affiner la chose :
moi je me suis fait toute une série d'alias avec "mdp"= mon mot de passe pour passer root en sudo :
(cela me permet de contrôler la machine en console)(qu'on obtient avec CTRL+ALT+T)

alias HIB='echo mdp|sudo -S echo HIB Ok; free -h; sudo pm-hibernate'
alias RBT='echo mdp|sudo -S echo RBT Ok; sudo shutdown -r now'
alias SDN='echo mdp|sudo -S echo SDN Ok; sudo shutdown -P now'
alias vey='echo mdp|sudo -S echo VEY Ok; sudo s2ram -fa 3'
#                                                            <- c'est ce dernier pour la mise en veille

Il faut avoir installé pm-utils auparavant avec (en console encore)

sudo apt-get install pm-utils

Bonne continuation,
David
EDIT: à mon avis, il n'y a aucun besoin de réinstaller quoi que ce soit.

#11 -1 »  Comment désactiver des disques USB externes » Le 21/12/2015, à 15:13

dva2tlse
Réponses : 8

Bonjour
j'ai une machine Compaq presario i386 avec 1GO de RAM et 320 Go de disque, et avec W7 que je n'utilise presque pas, vista pour réparer W7 comme à l'origine en sortie d'usine, et Xubuntu 14.04 sur le même dsk. J'ai deux disques USB externes qui me servent pour les sauvegardes, et je voudrais que ceux-ci ne tournent qu'une fois pendant les sauvegardes et non pas durant tout le mois. Or il sont branchés sur une prise arrière de ma tour, sous le bureau, donc je ne les débranche jamais.

Je viens de regarder ce que faisait la commande "hdparm" qui semble me convenir à peu près, SAUF que :
Ce que je voudrais c'est carrément "désactiver" les deux disques USB, comme s'ils n'existaient même pas en dehors du 1er du mois, quand je sauvegarde tout.

Et je voudrais qu'une fois par mois, un script me permette d'en réactiver un et de tout copier dessus. (et éventuellement de le remettre en veille)

Est-ce que vous pensez que le "sudo hdparm -y /dec/sdb" (ou /sdc pour l'autre) ferait cela ? La difficulté que j'envisage est que je ne voudrais pas qu'il redémarre à chaque fois avec mon PC, avant la date de ma sauvegarde.
Merci de me donner vos avis,
David

#12 Re : -1 »  Comment désactiver des disques USB externes » Le 21/12/2015, à 16:03

dva2tlse
Réponses : 8

Bonjour Braun,
ce qui me pose question n'est pas un démontage, mais l'arrêt des disques, et qu'ils ne redémarrent pas dès le prochain reboot.
David

#13 Re : -1 »  Comment désactiver des disques USB externes » Le 22/12/2015, à 09:15

dva2tlse
Réponses : 8

Bonjour,
oui en effet, la solution logicielle n'est peut-être pas satisfaisante ou suffisante; en effet, un "hdaparm -y /dev/hdb|c" ou "hdparm -Y /dev/hdb|c" ne met le disque USB en veille que jusqu'au prochain reset ou reboot.

Je ne sais pas si la différence y|Y changerait grand chose pour moi, mais ce ne serait en veille seulement jusqu'au prochain reset ou reboot, ce qui ne me convient pas; en effet, j'aimerais que ça reste désactivé tout un moment, entre deux sauvegardes.

Donc est-ce que le fichier /etc/hdparm.conf pourrait être modifié (et maintenu par mon script) de telle sorte les disques soient ignorés la plupart du temps, avec quelque chose comme juste une ligne "-y" ou "-Y", et donc dès le boot, le périphérique IDE serait forcé à entrer immédiatement en mode de basse consommation ou en mode sommeil.
Puis mon script modifierait temporairement ce fichier pour laisser s'initialiser l'un ou l'autre de mes disques pour faire la sauvegarde mensuelle.

Cela veut dire que ce fichier devrait contenir l'une des deux lignes suivantes ou les deux la plupart du temps :
hdparm -Y /dev/hdb
hdparm -Y /dev/hdc

Merci de me donner ton avis sur la question,
David

#14 Re : -1 »  Comment désactiver des disques USB externes » Le 22/12/2015, à 13:07

dva2tlse
Réponses : 8

Bonjour Badbu,
les miens ils sont alimentés par le port USB lui-même, donc ils tournent indéfiniment dès que le PC est allumé.
David

#15 Re : -1 »  Comment désactiver des disques USB externes » Le 22/12/2015, à 15:17

dva2tlse
Réponses : 8

Rebonjour Babdu,
oui en effet j'aimerais bien pouvoir couper l'alim' du port, mais je ne crois pas que la machine puisse le faire; par contre je crois qu'il est possible de mettre mes disques externes en veille, ou un seul, dès le boot; je viens de voir des exemples dans /etc/hdparm.conf, et ça devrait me convenir.
à suivre.
David

#16 -1 »  [+/- RéSOLU] comment avoir login+mdp dès l'accueil, en -private ? » Le 03/12/2015, à 19:12

dva2tlse
Réponses : 4

Bonjour,
je suis seul à utiliser mon PC donc pas de PB de sécurité, et je voudrais que firefox affiche login+mot-de-passe dès l'accueil des sites protégés que je visite en navigation privée.
Comment faire ?
Merci,
David
PS: cela marchait il y a peu de temps, et tout est parti d'un coup.

#17 Re : -1 »  [+/- RéSOLU] comment avoir login+mdp dès l'accueil, en -private ? » Le 04/12/2015, à 15:47

dva2tlse
Réponses : 4

Bonjour Bob,
oui en effet, je sais cela, que le mode "private", ou navigation privée, sert justement à ce que les mdp ni l'historique n'apparaissent pas; ce qui m'intéresse c'est que l'historique n'apparaisse pas, et j'ai pour cela un deuxième profil que je lance en "-no-remote", et dont l'historique est "propre"; mais je voudrais que pour ce profil aussi, mes pseudo/mdp soient affichés à chaque accès aux sites qui les demandent.
Comme tu me parles d'extension, as-tu une idée de laquelle pourrait faire cela ?
À+,
David

#18 Re : -1 »  [+/- RéSOLU] comment avoir login+mdp dès l'accueil, en -private ? » Le 07/12/2015, à 12:24

dva2tlse
Réponses : 4

Bonjour Bob,
ce que j'utilise comme extensions, sont TabMixPlus qui se met à jour tout seul, adbloc, que je désactive parfois pour certains forum's qui imposent de garder les affichages de pub, et récemment un truc pour que les login et mdp s'affichent, mais ça date d'après que ça n'ait plus marché donc ça ne peut pas en être la cause.

Mais je crois avoir trouvé; c'est simplement que dans une frénésie de nettoyage intégral, j'ai un jour supprimé les cookies qui assuraient le login, donc il me faut simplement attendre qu'elle se reconstituent; et ça ne se fait malheureusement pas dès le premier login, va savoir pourquoi.
Bye et merci,
David

#19 -1 »  [RESOLU] Rentrer des pwd dans Firefox » Le 01/12/2015, à 17:30

dva2tlse
Réponses : 0

Bonjour,
je voudrais pouvoir importer des mots de passe écrits en clair dans un fichier texte, vers firefox.
Merci de m'indiquer comment le faire simplement, ou que regarder pour apprendre à le faire,
merci,
David

EDIT: Ok avec l'extension "password exporter", mais il faut connaitre les noms des champs pour le login et le pwd. (ce qui doit être nécessaire en effet pour la requête HTML "POST")

#20 -1 »  [RESOLU mais kilékon] Pourquoi un "print" fait il tout planter ? » Le 30/11/2015, à 11:14

dva2tlse
Réponses : 1

Bonjour, j'ai un programme en fortran que je développe pour mon boulot depuis pas mal de temps alors que ce n'est pas mon métier de base; mais j'ai déjà obtenu ici plusieurs pistes qui m'ont permis de surpasser d'autres écueils, donc j'y reviens.
Ce programme me fait des misères, donc je lui demande de nombreuses sorties intermédiaires pour essayer de comprendre ce qui ne va pas à chaque fois qu'une nouvelle erreur se présente; et c'est justement une de ces impressions intermédiaires qui patine aujourd'hui :
(Le programme s'appelle S comme essai, et il a comme arguments le nombre de threads sur lequel il doit s'exécuter, puis le nom du fichier de sortie, puis celui d'entrée)

Alors j'ai deux gamelles différentes; l'une en faisant ceci : (et l'autre plus loin)

$  2>&1 ./S 1 p2srfd04BAR el04BAR.inp
.
.. (sorties normales)
...
p2srfd:00 apres lecpch pour FAB, Z=0
p2srfd:00 K=1 IDelt=    1, EIDelt(IDelt)=30259813, IDpchN(EIDelt(IDelt))=  121
p2srfd:00 K=1 IDelt=    2, EIDelt(IDelt)=30259814, IDpchN(EIDelt(IDelt))=  122
p2srfd:00 K=1 IDelt=    3, EIDelt(IDelt)=30259815, IDpchN(EIDelt(IDelt))=  123
p2srfd:00 K=1 IDelt=    4, EIDelt(IDelt)=30259816, IDpchN(EIDelt(IDelt))=  124
At line 1402 of file /S/DATA/DVA/F90/BN/SS.f
Fortran runtime error: Expected INTEGER for item 12 in formatted transfer, got CHARACTER
(A,I2.2,  A,I1,  A,I5,  A,I1,  A,I1,  A,F7.2)
                                 ^
shSpch:00 DIR=0, IDpch=  121, K=1, Z=
$

---Ici, le format qui cause l'erreur en cours d'exécution est celui de l'instruction suivante, et c'est le "Z" qui déconne, alors que quelques lignes plus haut il avait bien été imprimé, avec la deuxième instruction "print" que je donne ici pour comparaison :

      print !    DIR    IDpch  K      Z      Spch(DIR, IDpch, K, Z) 
     +'(A,I2.2,  A,I1,  A,I5,  A,I1,  A,I1,  A,F7.2)', 
     +'shSpch:', TID, 
     +' DIR=', DIR, 
     +', IDpch=', IDpch, 
     +', K=', K, 
     +', Z=', Z, ! ici ligne 1402
     +', Spch(DIR, IDpch, K, Z)=', Spch(DIR, IDpch, K, Z) 

          print'(A,I2.2,  A,I1)', 'p2srfd:', TID, 
     +' apres lecpch pour FAB, Z=', Z  


---et j'obtiens une erreur un peu différente en faisant celà : (le fichier qui est redirigé vers l'entrée de gdb est donné plus loin)

$ 2>&1 gdb ./S<RUN04BAR|tee tmp04BAR
.
.. (sorties normales)
...
p2srfd:00 K=5, IDelt=    1, EIDelt(IDelt)=30259813, IDpchN(EIDelt(IDelt))=  121, Spch(0, IDpchN(EIDelt(IDelt)), K, 0)=   9.05
p2srfd:00 K=5, IDelt=    2, EIDelt(IDelt)=30259814, IDpchN(EIDelt(IDelt))=  122, Spch(0, IDpchN(EIDelt(IDelt)), K, 0)=  15.33
p2srfd:00 K=5, IDelt=    3
Program received signal SIGSEGV, Segmentation fault.
0x00002aaaaab455ca in ?? () from /usr/lib64/libgfortran.so.1
(gdb) #0  0x00002aaaaab455ca in ?? () from /usr/lib64/libgfortran.so.1
#1  0x00002aaaaab4584c in ?? () from /usr/lib64/libgfortran.so.1
#2  0x00002aaaaab41cd5 in ?? () from /usr/lib64/libgfortran.so.1
#3  0x000000000040e1f7 in shspch (dir=@0x7fffffffe4dc, idpch=@0x7fffffffe4c4, 
    k=@0x7fffffffe4cc, spch=0x7fffffffe49c, z=@0x1)
    at /S/DATA/DVA/F90/BN/SS.f:1401
#4  0x0000000000403c20 in MAIN__ () at /S/DATA/DVA/F90/BN/SS.f:302
#5  0x000000000041c45e in main ()
(gdb) A debugging session is active.

        Inferior 1 [process 22306] will be killed.

Quit anyway? (y or n) [answered Y; input not from terminal]
$

(le fichier qui est redirigé vers l'entrée de gdb est le suivant smile

$ cat RUN04BAR
run 1 p2srfd04BAR el04BAR.inp
bt
q
y
$

---Dans ce deuxième cas, ça plante en 1401, soit une ligne plus loin que précedemment et dans la même instruction "print", et je vois dans la sortie de gdb que l'adresse de la variable "Z" n'a pas le même format que les autres, j'ai "z=@0x1" au lieu d'un format en "truc=@0x7fffffffABCD" avec ABCD étant quatre chiffres hexadécimaux variables.

Bon, en fait ça a l'air d'être la même cause, c-à-d. le Z, mais pourquoi l'adresse de cette variable est elle présentée différemment des autres, et surtout pourquoi fait elle planter mon programme ?

Merci de me donner des idées de choses à chercher,
David

#21 Re : -1 »  [RESOLU mais kilékon] Pourquoi un "print" fait il tout planter ? » Le 30/11/2015, à 12:49

dva2tlse
Réponses : 1

Bon, merci de m'avoir lu, mais ne vous souciez plus de ça; je suis nul, j'avais une liste d'arguments d'un sous programme qui ne correspondait pas avec le call !

#22 Re : -1 »  [RÉSOLU un peu péniblement] Hiberner avec Firefox » Le 21/11/2015, à 17:31

dva2tlse
Réponses : 21

pour info :

david@test:~$ free -h
             total       used       free     shared    buffers     cached
Mem:          1,7G       823M       938M        16M        18M       275M
-/+ buffers/cache:       530M       1,2G
Swap:         2,0G        64M       1,9G
david@test:~$ 

Bye et merci,
David

#23 Re : -1 »  [RÉSOLU un peu péniblement] Hiberner avec Firefox » Le 22/11/2015, à 16:03

dva2tlse
Réponses : 21

Ok merci moko138, tu me fais comprendre pourquoi ça n'a plus marché la fois d'après.
Donc je repars pour un tour de live-DVD et de gparted, et ça devrait rouler "à fond" cette fois.
merci,
David
PS: Ok pour W10

#24 Re : -1 »  [RÉSOLU un peu péniblement] Hiberner avec Firefox » Le 22/11/2015, à 16:45

dva2tlse
Réponses : 21

Mouais, bin bon en fin de compte, j'ai mis deux gigas et demi de swap, puisque moko m'a fait remarquer que j'avais déjà 1,7 giga de RAM; donc en en ajoutant une petite moitié, on arrive à 2,5 et ça a l'air d'aller.
David