Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 Re : -1 »  [ VOS SCRIPTS UTILES ] (et eventuelles demandes de scripts...) » Le 15/06/2009, à 18:48

rahancrao
Réponses : 1740

Salut,

j'ai posté il y a quelques temps un script permettant de joindre des fichiers de type *.001, *.002 ...
Le revoilà car j'ai corrigé deux petits bugs :

#!/bin/bash
#script permettant de joindre des fichiers *.001


fct_autre ()
{
echo "Voulez vous joindre un autre fichier ? (o/n) :"
read nouveau
	case $nouveau in
		o)
		fct_joindre;;
		n)
		exit;;
		*)
		exit;;
	esac
}

fct_joindre ()
{
rep_courant=`pwd`
clear
echo "Liste des fichiers *.001 present sous le repertoire courant : "
ls "${rep_courant}"/*.001|awk -F "/" '{print $NF}'
echo "Entrez le nom du fichier a joindre : "
read fichier_premier
echo "Liste des fichiers a joindre : "
nom_sans_ext=`basename "$fichier_premier" .001`
ls -l "${nom_sans_ext}".[0-9][0-9][0-9]
echo "Le fichier joint sera $nom_sans_ext"
echo "Voulez vous continuer ? (o/n) :"
read reponse
case $reponse in
	o)
	echo "Compilation des fichiers ..."
	cat "$nom_sans_ext".[0-9][0-9][0-9]>"$nom_sans_ext"
	echo "voulez vous supprimer les fichiers sources ? (o/n) :"
	read supprimer
	case $supprimer in
		o)
		rm "$nom_sans_ext".[0-9][0-9][0-9]
		fct_autre;;
		n)
		fct_autre;;
		*)
		exit;;
	esac;;
	n)
	exit;;
	*)
	exit;;
esac
}

fct_joindre

=> ajout de doubles côtes autour de l'appel à la variable $rep_courant au cas ou le path contienne un espace dans un nom de répertoire + ajout d'un tout bête . avant 001 dans la même ligne.

#1 Re : -1 »  Noms de machines » Le 21/05/2010, à 21:44

rahancrao
Réponses : 96

Bouboup pour le gros fixe.
Miniboup pour le Netbook.

Débile et pas sérieux.

#2 Re : -1 »  Vos systèmes GNU/Linux et BSD [sondage] » Le 21/01/2012, à 11:54

rahancrao
Réponses : 35

PC fixe 1 (moi) : Ubuntu 10.10 (Gnome) + ArchLinux (Gnome Shell) + Seven
PC fixe 2 (mes filles) : XP
Portable (moi + mes filles) : Ubuntu 11.10 (Gnome Shell) + Seven
PC fixe 3 (moi) : une distrib light, je ne sais pas encore laquelle, pour gérer un tas de vieux disques IDE : en cours de montage

#3 -1 »  Conseils pour serveur de stockage » Le 21/01/2012, à 12:26

rahancrao
Réponses : 2

Bonjour à tous,

pour chercher des avis et des conseils. J'ai un tas de vieux bidules que je voudrais réutiliser pour monter un serveur de stockage accessible depuis n'importe quel PC connecté sur ma Freebox (c'est temporaire, pour le fun en attente d'acheter un serveur NAS 4 baies).
Il ne sera pas question de raid car les disques dont je dispose sont tous en IDE (il doit y avoir des 80, 200 ... Go) et je n'ai pas de contrôleur raid IDE. J'ai un sata 120 Go qui servira pour l'OS.

En gros, le matos :
- carte mère : Asus K8N-E Deluxe
- Processeur : Athlon 64 3400
- 1,5 Go de ram
- Alim : Forton 400W
- les disques : je n'en ai pas encore fait l'inventaire (un sata 120 Go + des IDE).
- carte graphique AGP : j'ai de tout : nvidia, ati ... A la limite on s'en fout, elle ne servira que pour la configuration initiale.

Je cherche donc une distrib light (ou pas, l'Athlon faisait tourner assez bien Ubuntu 10.04 il n'y a pas longtemps pour mon Papa) pour faire tourner et des conseils pour gérer ça.

(je sens que ça va être une Debian, mais bon).

Merci d'avance.

#4 Re : -1 »  Nouveauté : Bleachbit un logiciel pour nettoyer ubuntu » Le 01/01/2009, à 14:41

rahancrao
Réponses : 123

Testé, pas loin de 300 Mo de purgé.

#5 Re : -1 »  Questions et problèmes avec carte graphique nVIDIA sous ubuntu 10.04 » Le 17/09/2010, à 07:04

rahancrao
Réponses : 7

Bonjour,

si ton portable utilise la technologie Optimus (switch entre l'IGP du CPU et le chipset nvidia en cas d'utilisation de la 3D), ce n'est pas implémenté sous GNU/Linux.

C'est le cas de mon portable (ASUS, core i5, nVIDIA GeForce GT 325M) qui marche trés bien sans installer les pilotes nvidia.

Fait une recherche avec le mot clé "optimus" sur ce forum pour t'en convaincre.

#6 Re : -1 »  Questions et problèmes avec carte graphique nVIDIA sous ubuntu 10.04 » Le 17/09/2010, à 19:43

rahancrao
Réponses : 7

Es tu sur que ce soit de l'Optimus sur ton PC ?

Le "je sais pas trop quoi" exploitable sous Linux est l'IGP Intel (Integrated Graphical Processor) donc le GPU intégré au processeur I5. Un lien explicatif ici : http://www.hardware.fr/articles/780-4/i … -32nm.html

Sur le mien j'ai rapidement essayé Unreal Tournament 2004 pour voir, les graphiques sont pas trop mal, mais c'était injouable au niveau FPS. J'avais du trop monter les détails faudra que je réessaye en baissant pas mal de paramètres.

#7 Re : -1 »  problème drivers graphiques » Le 27/07/2010, à 22:10

rahancrao
Réponses : 5

Salut,

il me semble que ton PC fonctionne avec la techno Optimus "basculement automatique entre la carte graphique dédiée et le chipset graphique intégré". Cette techno est encore balbutiante sous Linux d'après ce que j'ai pu lire. Il n'y a pas encore de driver nvidia sous Linux le supportant.

Un lien : http://www.presence-pc.com/actualite/NV … mus-38161/

C'est donc le chipset graphique Intel intégré qui fonctionne (impeccablement d'ailleurs). J'ai le même problème avec un Asus X64J, sous Linux, la GT 325M est détectée, mais ne fonctionne pas pour le moment.

#8 Re : -1 »  Avidemux et ".mov" » Le 12/08/2009, à 18:28

rahancrao
Réponses : 9

Salut,

le lien pour l'archive contenant le .deb est là :

http://gtk-apps.org/content/download.php?content=88970&id=3&tan=46784675

je l'ai téléchargé et ouvert avec le gestionnaire d'archive et ai obtenu le .deb

#9 Re : -1 »  [ RESOLU ] probleme partage et naviguation windows-ubuntu » Le 01/05/2009, à 17:29

rahancrao
Réponses : 5

Salut,

j'ai exactement le même soucis depuis le passage en 9.04. Je peux voir le réseau windows, mais impossible de l'explorer.

#10 Re : -1 »  [ RESOLU ] probleme partage et naviguation windows-ubuntu » Le 01/05/2009, à 18:42

rahancrao
Réponses : 5

Bon, vu que ca marchait en 8.10, j'ai récupéré le fichier /etc/samba/smb.conf depuis ma partition 8.10, arrété et relancé le service :

sudo /etc/init.d/samba stop
sudo /etc/init.d/samba start

et pas mieux.

J'ai donc rebooté et sur GDM, une fois le user et mdp entré, j'ai vu un pop up disant un truc du style "user rahancrao added"

Ca marche maintenant. En fait au moment de la connexion, un fichier /etc/samba/smbpasswd a été créé avec mon user dedans.


Bien sur, j'ai la flemme de me tarter la recherche de différence entre les deux versions de fichiers smb.conf, ce genre de truc au boulot oui mais là non tongue

#11 Re : -1 »  [ RESOLU ] probleme partage et naviguation windows-ubuntu » Le 01/05/2009, à 21:32

rahancrao
Réponses : 5

Ouaip, ben un truc qui était facile et qui devient tordu, je vois pas en quoi c'est plus simple.

#12 Re : -1 »  Accélérer l'affichage MSI Wind U100 + Ubuntu Remix » Le 30/04/2009, à 11:58

rahancrao
Réponses : 4

Je teste ce soir, merci pour l'astuce.

#13 Re : -1 »  Accélérer l'affichage MSI Wind U100 + Ubuntu Remix » Le 30/04/2009, à 21:11

rahancrao
Réponses : 4

Ben sur mon akoya E1210 (clone du MSI Wind) c'est fluide, peut être encore plus avec ton astuce.
J'y suis sous la 9.04, installation complète de la remix : pas de mise à jour depuis la 8.10(j'ai tout reformaté), compiz full activé, c'est nickel.

#14 Re : -1 »  impossible de faire des mises à jour » Le 30/01/2009, à 20:43

rahancrao
Réponses : 8

Salut, j'ai la même chose sur le paquet hal-info.

Je fouille.

#15 Re : -1 »  impossible de faire des mises à jour » Le 30/01/2009, à 21:09

rahancrao
Réponses : 8

Marrant je viens de taper la même commande (sans le awk)  trouvée sur le forum english :

sudo dpkg -l | grep -v ^ii

avec le awk, donc les deux premiers champs :

rahan@bouboup:~$ dpkg -l | awk '{print $1,$2}' | grep -v ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/H=à
||/ Nom
+++-==========================================-====================================================-============================================ 
rc amule-wxcas
rc bluez-audio
rc console-tools
rc cups-pdf
rc dhcdbd
rc dolphin
rc dpatch
ic flashplugin-nonfree
rc guile-1.6-libs
iW hal-info
rc html2text
rc hwdb-client-common
rc kdebase-bin
....

C'est donc bien (dans mon cas) le paquet hal-info qui boîte.

#16 Re : -1 »  impossible de faire des mises à jour » Le 30/01/2009, à 21:13

rahancrao
Réponses : 8

Je tenterai bien de désinstaller complètement hal-info, mais il y a un bon morceaux de paquets qui en dépendent, dont ubuntu-desktop, network-manager et j'en passe.

#17 Re : -1 »  impossible de faire des mises à jour » Le 31/01/2009, à 09:28

rahancrao
Réponses : 8

Bon, je l'ai fait :

sudo apt-get remove hal-info

Les paquets suivants seront désinstallés :

gnome-device-manager gnome-mount gnome-power-manager gnome-volume-manager gparted hal hal-cups-utils hal-info libmbca0 network-manager network-manager-gnome pulseaudio-module-hal sound-juicer ubuntu-desktop update-notifier

....

Noter les paquets avant de répondre "O"
Une fois tout désinstallé, le réseau ne fonctionne forcément plus (ethernet sur eth0), donc configuration à la mimine. Un peu de lecture :

man interfaces

"Examples   of   how  to  set  up  interfaces  can  be  found  in  /usr/share/doc/ifupdown/examples/network-interfaces.gz"

Je fais une copie du fichier /etc/network/interface puis remplace ce qu'il y a dedans par :

auto eth0
iface eth0 inet dhcp
 pre-up [ -f /etc/network/local-network-ok ]

et fais un

sudo touch /etc/network/local-network-ok

puis

sudo /etc/init.d/networking restart

pour avoir le réseau et pouvoir réinstaller les paquets précédemment désinstallés

sudo apt-get install  gnome-device-manager gnome-mount gnome-power-manager gnome-volume-manager gparted hal hal-cups-utils hal-info libmbca0 network-manager network-manager-gnome pulseaudio-module-hal sound-juicer ubuntu-desktop update-notifier

Et ca fonctionne.

Un reboot est demandé mais au préalable je restaure le fichier  /etc/network/interface original et vire le fichier /etc/network/local-network-ok

Le reboot est OK, je retrouve le réseau via Network-manager

Un petit test en installant un paquet innocent au pif (perl-doc) :

 sudo apt-get install perl-doc

...

Dépaquetage de perl-doc (à partir de .../perl-doc_5.10.0-11.1ubuntu2.2_all.deb) ...
Ajout de « diversion of /usr/bin/perldoc to /usr/bin/perldoc.stub by perl-doc »
Traitement des « déclenchements (triggers) » pour « man-db »...
Paramétrage de perl-doc (5.10.0-11.1ubuntu2.2) ...

C'est réglé.

Maintenant faut que je me mette au perl lol

#18 Re : -1 »  Impossible d'ouvrir le disque dur » Le 28/11/2008, à 20:30

rahancrao
Réponses : 21

Unclean shutdown : je suppose que c'est un disque NTFS et qu'il a mal été arrété sous Windows.
Tu vas sans doute être obligé de le lancer sous Windows et de l'arreter proprement.

A moins que quelqu'un connaisse un truc pour le faire sous Linux.

#19 Re : -1 »  fichier de configuration (resolu) » Le 01/01/2009, à 13:45

rahancrao
Réponses : 33
jeanjd63 a écrit :

Voir aussi par ICI si tu y trouves ton bonheur.

@+

Ha !! j'avais le même problème depuis quelque temps, et c'était bien du à un changement d'uuid de la swap. C'est corrigé maintenant.

Rétroactivement, je pense que cela vient du jour où j'ai installé Intrepid en béta sur deux autres partitions tout en faisant swap commune avec Hardy (qui depuis est passé à Intrepid).

Merci pour le lien que j'avais eu la flemme de chercher.

#20 -1 »  [Résolu] Multi boot 8.04 - 8.10 » Le 19/10/2008, à 16:40

rahancrao
Réponses : 6

Salut,

je compte installer ce soir la 8.10 beta sur un espace non partitionné du DD qui contient déjà la 8.04. Ce n'est pas la première fois que j'ai plusieurs OS mais avant en IDE,  j'avais plusieurs DD système que j' interchangeais via des racks et je n'avais pas à me poser la question du bricolage de grub, tout était complètement hermétique.
Maintenant, je suis en full SATA et mes racks IDE prennent la poussière.

Mon but est donc de créer 3 fs (swap / et /home) sur l'espace non partitionné de mon DD. Pour celà, normalement pas de problème avec l'alternate que je viens de récupérer. La 8.10 aura son propre grub sur /.

Par contre, quid du grub de la 8.04 sur lequel je compte chainer la 8.10 (sachant qu'en plus j'ai un DD windows, Crysis tout ça ...) ?

Mon /boot/grub/menu.lst de la 8.04 :

## ## End Default Options ##

title           Ubuntu 8.04.1, kernel 2.6.24-21-generic
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.24-21-generic root=UUID=17e8a6f3-7730-469d-a06c-1cbe0ae15869 ro quiet splash locale=fr_FR
initrd          /boot/initrd.img-2.6.24-21-generic
quiet

title           Ubuntu 8.04.1, kernel 2.6.24-21-generic (recovery mode)
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.24-21-generic root=UUID=17e8a6f3-7730-469d-a06c-1cbe0ae15869 ro single
initrd          /boot/initrd.img-2.6.24-21-generic

title           Ubuntu 8.04.1, memtest86+
root            (hd0,1)
kernel          /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

title           Windows XP
map (hd0) (hd2)
map (hd2) (hd0)
root (hd2,0)
savedefault
#makeactive
chainloader     +1

Un petit fdisk -l :

rahan@bouboup:/boot/grub$ fdisk -l

Disque /dev/sda: 250.0 Go, 250059350016 octets
255 heads, 63 sectors/track, 30401 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x0002040b

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1               1         365     2931831   82  Linux swap / Solaris
/dev/sda2   *         366        2189    14651280   83  Linux
/dev/sda3            2190       14347    97659135    5  Extended
/dev/sda5            2190       14347    97659103+  83  Linux

Disque /dev/sdb: 500.1 Go, 500107862016 octets
255 heads, 63 sectors/track, 60801 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x000a41aa

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1               1       60801   488384001    5  Extended
/dev/sdb5               1       15665   125829049+  83  Linux
/dev/sdb6           15666       28413   102398278+  83  Linux
/dev/sdb7           28414       60801   260156578+  83  Linux

Disque /dev/sdc: 250.0 Go, 250059350016 octets
255 heads, 63 sectors/track, 30401 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x726c726c

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdc1   *           1        2040    16386268+   7  HPFS/NTFS
/dev/sdc2            2041       14788   102398310    7  HPFS/NTFS
/dev/sdc3           14789       17975    25599577+   7  HPFS/NTFS
/dev/sdc4           17976       30401    99811845    f  W95 Etendu (LBA)
/dev/sdc5           17976       30401    99811813+   7  HPFS/NTFS

Donc bon, je suppose qu'une fois l'installation de la 8.10 effectuée (avec son grub sur sa propre partition /) il faudra que je renseigne le grub de la 8.04 avec quelque chose du style :

title Ubuntu 8.10           root (hd0,x)
          chainloader +1

C'est sur le x que je ne suis pas sur, il me semble que grub démarre à 0, d'où le (hd0,1) pour la 8.04 (amorce sur hda2), donc la valeur serait 3 (le /home de la 8.04 étant sur une partoche étendue d'où /sda3 et sda5) ?

Si oui (ou valeur corrigée), puis-je carrément préparer le grub de la 8.04 avant l'installation de la 8.10 ?


Merci pour les éventuelles réponses. Je suppose que finalement je n'ai qu'à tester les différentes valeurs de x pour finalement tomber sur la 8.10, mais je n'ai pas non plus envie de faire trop de conneries.

#21 Re : -1 »  [Résolu] Multi boot 8.04 - 8.10 » Le 19/10/2008, à 18:02

rahancrao
Réponses : 6

Merci pour ta réponse.

Pour la partition swap j'y ai pensé, je voulais hermétiser les deux bouzins (OS) mais finalement on s'en fout, ce n'est que de la swap.

Pour le MBR : c'est bien pour celà que je compte faire l'install à partir de l'alternate (chose que je dois faire depuis Edgy).

Si tu me confirme que je peux préparer à l'avance, au pire je me plante et je corrige (j'ai un peu en fait du mal à faire la relation entre les fs étendus, et les fs niveau grub).

#22 Re : -1 »  [Résolu] Multi boot 8.04 - 8.10 » Le 20/10/2008, à 19:04

rahancrao
Réponses : 6

Merci, pour les uid, j'ai l'habitude vu les quelques petites galères que nous avons eu lors des changements de noyaux des versions précédentes.

Bref, hier soir, j'ai finalement eu la flemme et ce soir c'est pire, mais vos conseils sont bons à prendre.

#23 Re : -1 »  [Résolu] Multi boot 8.04 - 8.10 » Le 23/10/2008, à 19:17

rahancrao
Réponses : 6
sinbad83 a écrit :

Je me semble, de tête, que l'installation de 8.10 enregistrera le bon Grub directement...

Je confirme, j'ai fini par installer le bouzin sur l'espace libre de /dev/sda avant hier soir. Une partition / et une /home (je réutilise la partition swap déjà créée) tout en étendu sans créer de secteur d'amorce. Installation de grub sur / (j'y accède via le grub de la 8.04) et ben ce grub de la 8.10 repère tous les OS de mon usine à gaz : j'aurais pu finalement l'installer sur le / de la 8.04 mais cette version est pour moi stable et je préfère donc séparer le tout, la 8.10 n'étant chez moi qu'en "test".

Au fait, la valeur de x, c'était 5.


Merci pour vos conseils.

#24 Re : -1 »  partitionnement » Le 09/10/2008, à 17:24

rahancrao
Réponses : 8

/dev/sda7 est peut être une partition étendue "extended" sous laquelle je suppose que /dev/sda8 et /dev/sda9, des partitions logiques sont montées.

Vérifie celà avec gparted (sélectionne la partition et clique droit : information). Si c'est le cas tu ne peut détruire /dev/sda7 sans détruire les partitions logiques sous elle.