Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  Logithéque d'applications web très complète : waah.info » Le 31/07/2013, à 17:05

Merle
Réponses : 9

Salut à tous,

Trouvant qu'un site de ce genre manquait un peu dans le paysage j'ai fais un wiki spécialisé sur les applications web auto-hébergeables sur son serveur perso, il y'a actuellement plus de 250 applications réparties dans 52 catégories.
N'hésitez pas a participer si vous connaissez des softs sympas non encore répertoriés smile (aucune inscription obligatoire).

Waah.info

Edit :
Ajout de deux wikis :
Waah Organisations (pour les entreprises les associations et les administrations)
Waah Pros (pour les professionnels et les amateurs avancés de l'informatique)

@+

#1 Re : -1 »  Logithéque d'applications web très complète : waah.info » Le 01/08/2013, à 06:46

Merle
Réponses : 9

Merci à vous pour vos compliments c'est gentil, agensbur j'ai fais une petite erreur je n'avais pas donné les droits de création au utilisateurs non identifiés ton problème venait peut-être de là ... problème corrigé maintenant j'ai créé la page Généalogie au passage (http://waah.info/doku.php/genealogie) merci c'est une excellente idée smile
Si vous avez des idées d'amélioration ou des critiques à formuler n'hésitez pas.

#2 Re : -1 »  Logithéque d'applications web très complète : waah.info » Le 08/09/2013, à 19:01

Merle
Réponses : 9

Petit message pour vous dire que le site dépasse désormais la barre des 300 applications recensées, les applications mobiles ont étaient ajoutées de même qu'une rubrique d'aide pour monter son serveur perso.
@+

#3 Re : -1 »  Une page facebook pour la promotion de vos sites » Le 31/07/2013, à 21:27

Merle
Réponses : 17

Si tu te créées un pod Diaspora je te conseil Diaspora-fr.org, joindiaspora le pod principal est saturé de temps en temps et diaspora-fr.org marche bien et en plus est administré par un passionné de Diaspora.

#4 Re : -1 »  Seafile, une alternative viable à Ubuntu One / Dropbox / Hubic ? » Le 22/04/2013, à 10:38

Merle
Réponses : 18

Bonjour à vous,

J'ai quelques problèmes à configurer seafile que je suis en train d'installer sur mon serveur apache et je trouve pas bien d'où vient le problème (j'ai suivi parfaitement le wiki d'installation mais je débute et je peux faire une erreur) :

voici mon vhost :

<VirtualHost *:80>
  ServerName seafile.domaine.fr
  DocumentRoot /var/www
  Alias /media    /home/julien/haiwen/installed/seafile-server-1.6.0/seahub/media      
  RewriteEngine On
  RewriteRule ^/(media.*)$ /$1 [QSA,L,PT]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule ^(.*)$ /seahub.fcgi$1 [QSA,L,E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
</virtualhost>

j'ai aussi entré l'alias dans la config d'apache de même que :

 FastCGIExternalServer /var/www/seahub.fcgi -host 127.0.0.1:8000

le domaine est bien paramétré dans la config de seafile et pourtant quand je le tappe dans mon navigateur je tombe sur une page d'erreur.

Merci à ceux d'entre vous qui pourront m'aider.

#6 -1 »  Configurer dns pour serveur mail local » Le 19/04/2013, à 11:57

Merle
Réponses : 4

Bonjour,

Je me suis créé un serveur perso que je souhaite utiliser avec quelques applis (leed, owncloud, roundcube), tout fonctionne nickel mais j'ai un peu de mal à comprendre les paramétrages au niveau des dns mx pour les mails ... j'ai un nom de domaine chez 1&1 que j'ai configuré sans problème pour mes applis avec 2 sous-domaines du genre :

leed.domaine.fr et owncloud.domaine.fr

mon problème vient maintenant de la configuration mx pour les mails (je dois avoir le cerveau sur off aujourd'hui je comprends vraiment pas ce que j'ai lu ailleurs ^^⁾ :

- il faut créé une entrée A (un sous-domaine si je comprends bien) du genre mx.domaine.fr qui pointe vers l'ip fixe de mon serveur, (ça j'ai réussi)
- après il faut modifier les dns de domaine.fr, choisir "autre serveur de mail" et entrer mx.domaine.fr 10, j'ai pas dû bien comprendre parce que ça ne fonctionne pas.

Merci.

#7 Re : -1 »  Configurer dns pour serveur mail local » Le 19/04/2013, à 12:41

Merle
Réponses : 4

Oui il n'y a pas d'ip fixe chez orange, no-ip ou dydns permettent d'en avoir une (mais à ce niveau là ça marche no problem).

#8 -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 10:49

Merle
Réponses : 16

Bonjour à vous,

J'ai quelques problèmes à configurer seafile que je suis en train d'installer sur mon serveur apache et je trouve pas bien d'où vient le problème (j'ai suivi parfaitement le wiki d'installation mais je débute et je peux faire une erreur) :

voici mon vhost :

<VirtualHost *:80>
  ServerName domaine.fr
  DocumentRoot /var/www
  Alias /media    /home/julien/haiwen/installed/seafile-server-1.6.0/seahub/media      
  RewriteEngine On
  RewriteRule ^/(media.*)$ /$1 [QSA,L,PT]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule ^(.*)$ /seahub.fcgi$1 [QSA,L,E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
</virtualhost>

j'ai aussi entré l'alias dans la config d'apache de même que :

 FastCGIExternalServer /var/www/seahub.fcgi -host 127.0.0.1:8000

le domaine est bien paramétré dans la config de seafile et pourtant quand je le tappe dans mon navigateur je tombe sur la page "it works !", mais pas de problème en localhost.

Merci à ceux d'entre vous qui pourront m'aider.

#9 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 11:14

Merle
Réponses : 16

Pas de problème, ça veut dire quoi ?
Quand tu vas sur "http://localhost" tu obtiens l'interface de Seafile ?

Quand je vais sur localhost:8000 je tombe bien sur l'interface de seafile.

Autre chose ?

Oui j'avais pas remarqué tout de suite mais apache est paramétré en ssl et mon domaine seafile est redirigé en https peut-être que le problème vient de là (mais je n'ai pas encore creusé).

Peux-tu confirmer que tu n'as rien de spécial dans les fichiers de log d'Apache (access.log et error.log) ?

Non rien pas de problème à ce niveau la.

Que donne la commande suivante ?

root@julien-Inspiron-530s:~# ls /etc/apache2/mods-enabled/
alias.conf            cgi.load      mime.load         reqtimeout.conf
alias.load            deflate.conf  mod-evasive.conf  reqtimeout.load
auth_basic.load       deflate.load  mod-evasive.load  rewrite.load
authn_file.load       dir.conf      negotiation.conf  setenvif.conf
authz_default.load    dir.load      negotiation.load  setenvif.load
authz_groupfile.load  env.load      php5.conf         ssl.conf
authz_host.load       fastcgi.conf  php5.load         ssl.load
authz_user.load       fastcgi.load  proxy.conf        status.conf
autoindex.conf        headers.load  proxy_http.load   status.load
autoindex.load        mime.conf     proxy.load        unique_id.load

#10 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 11:33

Merle
Réponses : 16

Le VirtualHost que tu nous montres est en HTTP sur le port 80, il n'a pas de redirection vers du HTTPS...

Tu as raison j'avais désactivé le vhost default pour faire une manip et je ne l'avais pas réactivé seul default-ssl était prit en compte ... donc ça c'est réglé, par contre sur mes autres domaines j'étais obligé d'ajouter un vhost pour la redirection no-ip et là pas besoin la redirection se fait toute seule.
Mais bon problème tjs présent.

#11 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 11:51

Merle
Réponses : 16

Voici ma config seafile qui se trouve dans le ccnet.conf, ça pourra peut-être aider :

[General]
USER_NAME = my-seafile
ID = 7a89803b47e1d7fd95be53d8b4deb477fca82496
NAME = my-seafile
SERVICE_URL = http://mondomaine.fr

[Network]
PORT = 10001

[Client]
PORT = 13419

#12 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 12:28

Merle
Réponses : 16

Quand tu vas sur "http://seafile.mondomaine.fr", ça se connecte où et ça donne quoi ?

Ca se connecte sur apache avec le "it works !".

Petite question sur le wiki de seafile il y a un vhost pour le non root domain avec proxy (ici), je ne suis pas spécialiste mais est-ce que ce ne serait pas celui-là qu'il faudrait choisir ?

#13 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 13:10

Merle
Réponses : 16

En HTTP ou en HTTPS ?

En http.

Es-tu sûr que ton vhost est bien activé ?

Oui il est bien dans sites-enabled.

Ah ben c'est toi qui dis si tu veux avoir Seafile à la racine ou si tu veux que Seafile soit un sous-répertoire...

A la racine avec mon domaine.

Ben je comprends pas ça devrait marcher ....

#14 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 13:22

Merle
Réponses : 16

Petite question quand même sur le wiki il est indiqué que :

FastCGIExternalServer /var/www/seahub.fcgi -host 127.0.0.1:8000

doit se trouver dans httpd.conf, donc c'est bien dans apache2.conf ?

Pour les alias c'est bien aussi dans apache2.conf ?

#15 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 13:59

Merle
Réponses : 16

Ok merci pour ton aide, je vais attendre voir je referai une install propre en dernier ressort.

#16 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 14:35

Merle
Réponses : 16

Petite question tu connais la commande pour désinstaller seafile, supprimer le dossier d'install tout simplement ?

#17 Re : -1 »  Problème pour paramétrer seafile » Le 22/04/2013, à 14:38

Merle
Réponses : 16

Très bien merci.

#18 -1 »  Connection owncloud-client/serveur apache ssl » Le 17/04/2013, à 20:08

Merle
Réponses : 8

Bonjour,

J'ai un petit problème pour connecter owncloud-client à mon serveur apache configuré en ssl, j'ai lu qqpart sur internet qu'il fallait que "owncloud" apparaisse dans le common name du certificat ssl de mon serveur, pour moi cette manip ne règle pas mon problème ...

Merci.

#19 Re : -1 »  Connection owncloud-client/serveur apache ssl » Le 19/04/2013, à 10:53

Merle
Réponses : 8

Salut ssdg et merci pour ta réponse, je n'ai pas de message concernant cette erreur sur les logs d'apache ni sur ceux d'owncloud ... je vais essayer de me connecter sans ssl voir si le problème a bien un rapport avec le cryptage.

#20 Re : -1 »  Connection owncloud-client/serveur apache ssl » Le 19/04/2013, à 13:15

Merle
Réponses : 8

Bon le problème perdure même sans la connection ssl ... avec la même config je n'avais aucun problème sur une ancienne install sans le ssl, ça doit être un bug d'owncloud.

#21 Re : -1 »  Connection owncloud-client/serveur apache ssl » Le 19/04/2013, à 14:58

Merle
Réponses : 8

Tu as vérifié que la version du client et du serveur correspond?

Les deux ont étaient installées à partir des sources d'owncloud à priori ça devrait être bon.

Tu peux y accéder depuis Firefox sur le même ordinateur?

Oui, pas de problème depuis le net avec ssl ou sans.

Tu ne passerai pas par un proxy dans un cas et pas dans l'autre?

Non.

#22 Re : -1 »  Connection owncloud-client/serveur apache ssl » Le 22/04/2013, à 11:45

Merle
Réponses : 8

Non il ne faut pas de plugin, pour la config du client j'ai trouvé les infos de config ici, j'ai créé un fichier owncloud.cfg avec les infos données par défaut :

remotePollInterval 30000

localPollInterval 10000

PollTimerExceedFactor 10

maxLogLines 20000

mais aucun changement.

#24 Re : -1 »  Problème apache et sslengine [résolu] » Le 16/04/2013, à 10:23

Merle
Réponses : 6

Merci à toi problème réglé, j'avais fais un second virtualhost pour rediriger mon adresse no-ip sur lequel je n'avais pas mis SSLEngine On.