Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  logiciel devis facture pour une entreprise de batiment » Le 09/06/2015, à 19:19

Jean49
Réponses : 33

Bonjour,

Larcenn a écrit :

J'utilise Dolibarr et j'en suis très satisfait tu peu l'installer simplement avec la solution clé en main :

http://sourceforge.net/projects/dolibar … oliDeb%29/

wink

Moi aussi, c'est un très bon outil qui va de la gestion des prospects-clients jusqu'au pointage des encaissements en passant par la gestion du catalogue (produits et services), la rédaction des devis, la transformation en factures et la gestion des stocks. Le tout avec une approche très intuitive. On peut tester gratuitement chez plusieurs hébergeurs : http://www.dolibarr.fr/demo-en-ligne.

Bonne quête.

Jean

#1 -1 »  NVidia GT9500 » Le 07/06/2015, à 10:25

Jean49
Réponses : 32

Bonjour,

Une UC équipée d'une carte vidéo NVidia GT9500 me pose des problèmes curieux. Quand je démarre Ubuntu 14.04 version 32 bits à partir du DVD tout va bien. Le pilote utilisé est le xserver-xorg-video-nouveau.

C'est à l'installation que çà se gâte.
1. Le pilote xserver-xorg-video-nouveau est installé par défaut mais au 1er démarrage je suis limité à un affichage en 640*480
2. Pas grave, j'installe le pilote propriétaire préconisé (nvidia-331), je redémarre et c'est nickel
3. J'ai crié victoire trop vite car au second démarrage avec ce nouveau pilote, j'ai un écran noir pour l'affichage graphique. C'est, à priori, un simple problème lié à l'affichage de l'interface graphique car j'ai encore accès au mode console (Ctrl+F1)
4. Par curiosité, je fais un sudo apt-get install nvidia-331-update, je redémarre et çà marche !
5. Même problème qu'en 3 au second redémarrage

Auriez-vous des pistes pour tenter de comprendre et résoudre ce drôle de processus ?

Merci d'avance et bon dimanche.

Jean

#2 Re : -1 »  NVidia GT9500 » Le 07/06/2015, à 21:03

Jean49
Réponses : 32

Re,

Voici les résultats :

lspci -k | grep VGA -A3

01:00.0 VGA compatible controller: NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1)
    Kernel driver in use: nvidia
02:01.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)
    Subsystem: ASUSTeK Computer Inc. Device 4860

lsmod | grep nvidia

nvidia               9704610  29
drm                   244037  2 nvidia

/usr/lib/nux/unity_support_test -p

Là, je crois qu'il manque une commande et un cat me donne des caractères inexploitables.

#3 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 09:21

Jean49
Réponses : 32

Bonjour,

lsb_release -a

No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 14.04.2 LTS
Release:    14.04
Codename:    trusty

echo "${XDG_CURRENT_DESKTOP}"

Vide !!! Aucun desktop ?

sudo apt-get install --reinstall mesa-utils

Fait !

glxinfo | grep "direct rendering"

Error: unable to open display

/usr/lib/nux/unity_support_test -p

Error: unable to open display

J'avoue ne pas tout comprendre dans ces actions mais pour l'instant cette sacrée interface graphique a des problèmes. En tous cas, merci f.x0 pour guidage.

Excellent début de semaine.

Jean

#4 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 10:04

Jean49
Réponses : 32

Bonjour alca94,

alca94 a écrit :

Bonjour
vous n'avez pas le pilote 304 de proposé ,c'est celui que j'avais pour une GTX9800 et aucun problème

Sais-tu ou trouver les spécificités des différents pilotes proposés par Nvidia ? Je viens de le tester mais rien n'y fait. Je pense que le problème se situe en amont du pilote. J'ai donc réinstallé le 331 proposé par ma distribution.

Merci pour cette piste et bonne journée.

Jean

#5 Re : -1 »  NVidia GT9500 » Le 07/06/2015, à 18:48

Jean49
Réponses : 32

Bonjour f.x0,

Merci de te pencher sur mon problème.

f.x0 a écrit :

Tout d'abord vérifions ton matériel graphique.
Ouvres un terminal
tapes

lspci | grep "VGA"

01:00.0 VGA compatible controller: NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1)

f.x0 a écrit :

puis

lshw -enable pci -class display

*-display               
       description: VGA compatible controller
       produit: G96 [GeForce 9500 GT]
       fabriquant: NVIDIA Corporation
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       version: a1
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       ressources: irq:18 mémoire:fa000000-faffffff mémoire:d0000000-dfffffff mémoire:f8000000-f9ffffff portE/S:ef00(taille=128) mémoire:fb000000-fb07ffff

Voilà pour cette 1ère étape.

Bonne fin de WE.

Jean

#6 Re : -1 »  NVidia GT9500 » Le 07/06/2015, à 19:37

Jean49
Réponses : 32

Rebonsoir,

f.x0 a écrit :

ensuite réessaies de redémarrer plusieurs fois, c'est OK ???

Non, çà ne change rien.

Si j'ai bien compris, j'ai mis à jour mon pilote (47Mo) à partir d'un autre dépôt ? Plus récent ? modifié ?

J'ai même essayé différentes combinaisons :
1. sans utiliser et en utilisant le paramètre nomodeset
2. en démarrant avec le noyaux actuel (3.13.0.53-generic) et avec celui installé à partir du DVD (3.13.0.24-generic)
et dans tous les cas, je n'ai pas d'interface graphique.

Sinon j'ai tenté un

grep /drivers/ /var/log/Xorg.0.log

et le résultat m’interpelle. Pas de trace d'un pilote Nvidia :
[    23.862] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    23.872] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    23.873] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    23.873] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so

Pas simple cette affaire !

A+

Jean

#7 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 10:24

Jean49
Réponses : 32

Re,

f.x0, suite à la réinstallation du pilote en version 331 après l’incursion en 304, j'ai retrouvé l'interface graphique. Donc avant de redémarrer, je reprends ta dernière question :

/usr/lib/nux/unity_support_test -p

OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce 9500 GT/PCIe/SSE2/3DNOW!
OpenGL version string:  3.3.0 NVIDIA 331.113

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

lsb_release -a

No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 14.04.2 LTS
Release:    14.04
Codename:    trusty

echo "${XDG_CURRENT_DESKTOP}"

echo "${XDG_CURRENT_DESKTOP}"

sudo apt-get install --reinstall mesa-utils

Pas fait puisque /usr/lib/nux/unity_support_test -p m'a répondu.

glxinfo | grep "direct rendering"

direct rendering: Yes

Voilà avant redémarrage. La suite dans 5 minutes ;-)

#8 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 10:31

Jean49
Réponses : 32

Re,

Jean49 a écrit :

Re,
Voilà avant redémarrage. La suite dans 5 minutes ;-)

Et voilà ! Après redémarrage je suis de nouveau sans interface graphique et j'ai les mêmes réponses qu'à 9h21.

Bizarre cette GT9500 !

A+

Jean

#9 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 10:33

Jean49
Réponses : 32

Re, re,

alca94 a écrit :

Sais-tu ou trouver les spécificités des différents pilotes proposés par Nvidia ?

A part sur leur site ,je ne vois pas (mais c'est a éviter de l'installer a partir de là)
http://www.nvidia.fr/Download/index.aspx?lang=fr

Dommage, ces différents pilotes Linux restent assez obscurs et vraiment pas grand chose sur leur site.
Merci pour ton retour.

Jean

#10 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 10:42

Jean49
Réponses : 32
alca94 a écrit :

Avec cette commande que vous avez lancé
sudo apt-get install --reinstall mesa-utils
vous devriez maintenant voir la référence exacte de votre carte dans "Détails"

"Détails" ? Je n'ai pas cette option dans ma console ;-)

#11 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 11:36

Jean49
Réponses : 32
alca94 a écrit :

Par contre avez vous vérifier la connexion de votre cable (VGA-HDMI ou DVI) ,a chaque extrémité ?

Oui, je viens même de faire une connexion directe car cette UC était derrière un KVM TRENDnet TK-209K mais rien de différent.

#12 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 23:22

Jean49
Réponses : 32

Bonsoir f.x0,

ps -ef | grep nvidia

nvidia-+  1334     1  0 23:19 ?        00:00:00 /usr/bin/nvidia-persistenced --user nvidia-persistenced
linux     1397  1378  0 23:20 pts/0    00:00:00 grep --color=auto nvidia

et voilà !

Jean

#13 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 23:40

Jean49
Réponses : 32
f.x0 a écrit :

Je pars au lit, on continuera demain soir, OK ???

No soucis, je vais faire pareil. Bonne nuit.

#14 Re : -1 »  NVidia GT9500 » Le 08/06/2015, à 20:28

Jean49
Réponses : 32
f.x0 a écrit :

C'est embêtant cette histoire.

A oui alors ! Pire, je rencontre le même problème sur une autre UC de la même époque qui, elle, est équipée d'un Nvidia 7500.

f.x0 a écrit :

supprimer le fichier Xorg si tu en as un :

sudo rm /etc/X11/xorg.conf

Çà a été vite fait, il n'y en avait pas ;-)

f.x0 a écrit :

désactiver le dépôt PPA ppa:xorg-edgers/ppa
recharger la liste des dépôts

sudo apt-get update

Je ne connais pas la méthode en mode console. J'ai édité  /etc/apt/sources.list mais je ne trouve pas ce dépôt. J'ai donc continué pour désinstaller les paquets nvidia :

sudo apt-get purge nvidia-*

Çà s'est terminé avec un
"Des erreurs ont été rencontrées pendant l'exécution :
nvidia-331
nvidia-331-updates
E: Sub-process /usr/bin/dpkg returned an error code (1)"

sudo apt-get autoremove

Idem :
"Des erreurs ont été rencontrées pendant l'exécution :
nvidia-331
E: Sub-process /usr/bin/dpkg returned an error code (1)"
J'ai tenté un

sudo apt-get install -f

qui détecte bien ce qui reste à faire
"Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  nvidia-331
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 134 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] "

Mais la réponse oui abouti à un message d'erreur :
"Suppression de nvidia-331 (331.113-0ubuntu1~xedgers14.04.1) ...
stop: Unknown job: nvidia-persistenced
userdel: user nvidia-persistenced is currently used by process 1346
dpkg: error processing package nvidia-331 (--remove):
le sous-processus script post-removal installé a retourné une erreur de sortie d'état 8
Des erreurs ont été rencontrées pendant l'exécution :
nvidia-331
E: Sub-process /usr/bin/dpkg returned an error code (1)"

sudo apt-get install --reinstall xserver-xorg-video-nouveau

Du coup, cette action est impossible.

Au redémarrage, plus d'interface graphique mais possibilité de faire les opérations précédente. Cependant, malgré 2 redémarrages, xserver-xorg-video-nouveau ne me donne toujours pas d'image. PAs grave, je continue...

sudo add-apt-repository ppa:mamarley/nvidia
sudo apt-get update
sudo apt-get install nvidia-340 nvidia-settings
sudo mv /etc/apt/sources.list.d/mamarley-nvidia-trusty.list /etc/apt/sources.list.d/mamarley-nvidia-trusty.list.old
sudo apt-get update

Là j'ai un "N: « mamarley-nvidia-trusty.list.old » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable" qui est cohérent avec le renommage précédent.

J'ai redémarré le PC 3 fois.

glxinfo | grep OpenGL

La première fois, alors que j'avais une interface graphique OK, j'ai eu un "Error: unable to open display"
La seconde fois, plus d'interface graphique et "Error: unable to open display"
La troisième, idem qu'en 2.

Étrange !!! Très étrange !!!

#15 Re : -1 »  NVidia GT9500 » Le 09/06/2015, à 18:51

Jean49
Réponses : 32

Bonsoir,

sudo kill 1334
sudo killall nvidia-persistenced
sudo apt-get purge -f nvidia-*
sudo apt-get autoremove --purge

Aucun soucis pour tout çà sauf le "N: « mamarley-nvidia-trusty.list.old » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable" lié aux manipulations d'hier.

sudo apt-get install --reinstall -f xserver-xorg-video-nouveau
sudo reboot

Pas de soucis sauf l'affichage ; j'ai toujours un écran noir après 2 reboots. J'ai tenté un startx, en Ctrl+Alt+F8 j'ai un morceau de bureau en 640*480 (partie centre droite sans avoir aucun bouton, juste un clic droit pour changer l'arrière plan). Ctrl+Alt+F7 reste sur un écran noir.

#16 Re : -1 »  NVidia GT9500 » Le 09/06/2015, à 19:07

Jean49
Réponses : 32

Re,

lshw -enable pci -class display

  *-display NON-RÉCLAMÉ   
       description: VGA compatible controller
       produit: G96 [GeForce 9500 GT]
       fabriquant: NVIDIA Corporation
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       version: a1
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       ressources: mémoire:fa000000-faffffff mémoire:d0000000-dfffffff mémoire:f8000000-f9ffffff portE/S:ef00(taille=128) mémoire:fb000000-fb07ffff

glxinfo | grep OpenGL

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.6, 128 bits)
OpenGL version string: 3.0 Mesa 10.6.0-rc2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

#17 Re : -1 »  NVidia GT9500 » Le 09/06/2015, à 19:20

Jean49
Réponses : 32
lsmod

Module                  Size  Used by
rfcomm                 53664  0
bnep                   18895  2
bluetooth             342208  10 bnep,rfcomm
binfmt_misc            13140  1
hid_generic            12492  0
snd_atiixp             19305  0
snd_ac97_codec        105709  1 snd_atiixp
saa7134_alsa           18080  0
ac97_bus               12642  1 snd_ac97_codec
snd_pcm                85501  3 snd_ac97_codec,saa7134_alsa,snd_atiixp
snd_page_alloc         14230  2 snd_pcm,snd_atiixp
tda1004x               22760  1
nouveau               969577  0
saa7134_dvb            33618  0
videobuf_dvb           13820  1 saa7134_dvb
dvb_core              101206  1 videobuf_dvb
snd_seq_midi           13132  0
tuner_simple           22016  2
tuner_types            19268  1 tuner_simple
snd_seq_midi_event     14475  1 snd_seq_midi
mxm_wmi                12893  1 nouveau
tuner                  26740  1
snd_rawmidi            25135  1 snd_seq_midi
wmi                    18673  2 mxm_wmi,nouveau
video                  18903  1 nouveau
usbhid                 47070  0
snd_seq                55383  2 snd_seq_midi_event,snd_seq_midi
hid                    87604  2 hid_generic,usbhid
usb_storage            48417  0
saa7134               157142  2 saa7134_dvb,saa7134_alsa
ttm                    80983  1 nouveau
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              28584  2 snd_pcm,snd_seq
tveeprom               16984  1 saa7134
serio_raw              13230  0
drm_kms_helper         48868  1 nouveau
videobuf_dma_sg        18710  3 saa7134_dvb,saa7134,saa7134_alsa
rc_core                26724  1 saa7134
snd                    60939  9 snd_ac97_codec,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_device,saa7134_alsa,snd_atiixp,snd_seq_midi
v4l2_common            15132  2 tuner,saa7134
k8temp                 12842  0
videobuf_core          25098  3 videobuf_dma_sg,saa7134,videobuf_dvb
drm                   244037  3 ttm,drm_kms_helper,nouveau
soundcore              12600  1 snd
videodev              108503  3 tuner,saa7134,v4l2_common
i2c_piix4              17723  0
i2c_algo_bit           13197  1 nouveau
ati_agp                13177  0
shpchp                 32128  0
mac_hid                13037  0
parport_pc             31981  1
ppdev                  17391  0
lp                     13299  0
parport                40836  3 lp,ppdev,parport_pc
pata_acpi              12886  0
8139too                32571  0
firewire_ohci          35529  0
8139cp                 27171  0
firewire_core          61867  1 firewire_ohci
psmouse                95353  0
crc_itu_t              12627  1 firewire_core
mii                    13654  2 8139cp,8139too
pata_atiixp            13058  0
sata_sil               13256  3

#18 Re : -1 »  Epson XP-215 : impression et scan OK en wifi (Mint 14 Nadia) » Le 19/07/2014, à 18:46

Jean49
Réponses : 30

Bonjour,

Je me permets une petite incursion dans ce post sur lequel je suis tombé lors de l'installation de cette sacrée XP-215. Afin de garder une trace de mes manipulations et d'aider ceux qui auront cette machine à installer sous Ubuntu 14.04, j'ai rédigé un petit article. Bonnes installations.

Jean

#19 Re : -1 »  Epson XP-215 : impression et scan OK en wifi (Mint 14 Nadia) » Le 19/07/2014, à 19:23

Jean49
Réponses : 30

Bonsoir Alca94,

Merci pour ce retour.

alca94 a écrit :

il est dommage de mettre "sudo gedit" qui crée des problèmes d'authentification futurs alors qu'en graphique  on doit mettre "gksudo gedit"

Pour l'instant, je n'ai pas rencontré de problèmes avec sudo gedit. Çà peut fonctionner aujourd'hui et pas demain ? Je viens de tenter une rapide recherche sur le sujet et je n'ai pas trouvé d'explication claire et précise sur le sujet. Si vous avez, je suis preneur.

Bon WE.

Jean

#21 Re : -1 »  Epson XP-215 : impression et scan OK en wifi (Mint 14 Nadia) » Le 19/07/2014, à 19:45

Jean49
Réponses : 30

Re,

michel_04 a écrit :

*** 1)  gksudo paramètre le dossier personnel (la variable d'environnement $HOME) pour l'application exécutée en mode privilégiée à /root plutôt qu'à /home/<identifiant> et copie le fichier .Xauthority dans un dossier temporaire. Ceci empêche que des fichiers du dossier personnel de l'utilisateur changent de propriétaire (et donc corrompent la session graphique en cours).

Edit :
Mouais, j'ai posté un peu tard on dirait.

Effectivement, l'argument est clair et précis. Je ne ferai plus la boulette et je me coucherai moins bête ce soir.
Il faut toujours mieux tard que jamais. Un grand merci.

Jean

#22 Re : -1 »  Epson XP-215 : impression et scan OK en wifi (Mint 14 Nadia) » Le 15/08/2014, à 19:51

Jean49
Réponses : 30

Bonsoir,

alca94 a écrit :

@ laurentdavou

Je n'ai pas d'ordi sur windows. peut on configurer l'imprimante en wifi sans passer par windows?

Heureusement que OUI sinon on deviendrai quoi les utilisateurs d'ubuntu
Par contre il faut récupérer votre adresse IP sur l'imprimante directement

Et oui ! Mais pour récupérer une adresse IP, il faut que l'imprimante en ait une et, pour cela, il faut activer les fonctions réseau de la XP215... Et pour activer le réseau, je n'ai pas encore trouvé de solution sans passer par l'application fournie par Epson. J'ai tenté de la faire tourner sous Wine mais sans succès sad
Peut-être y aura t'il ici des solutions proposées. Je vais suivre ce fil avec attention wink

Bon été.

Jean

#23 Re : -1 »  Epson XP-215 : impression et scan OK en wifi (Mint 14 Nadia) » Le 15/08/2014, à 20:06

Jean49
Réponses : 30

Rebonsoir,

alca94 a écrit :

perso j'ai aider à distance une amie qui avait une epson sx435 (je crois) et on a trouvé l'adresse ip dans le menu de l'imprimante en imprimant sa config

Oui, mais quand on édite ces 2 pages de configuration avec la xp215 flambant neuve, on voit une adresse IP arborant un méchant none sad

Affaire à suivre.

Jean

#24 Re : -1 »  Epson XP-215 : impression et scan OK en wifi (Mint 14 Nadia) » Le 19/08/2014, à 10:11

Jean49
Réponses : 30

Bonjour,

Petite incursion au cœur des vacances smile

laurentdavou a écrit :

Oui. D'ailleurs, quand on imprime ces feuilles, le wifi s'allume pour la procédure.

Le problème ne vient pas de l'imprimante. Son composant wifi peut être actif, si elle ne prend pas l'initiative de se connecter à un réseau elle n'obtient pas d'adresse IP. C'est ce qui explique le rapport ci-dessus. Il y a peut-être une astuce pour lui attribuer une adresse par défaut afin de prendre la main sur son interface web mais je ne la connait pas. Peut-être essayer de contacter le SAV d'Epson ? Si vous avez des tuyaux, je suis preneur wink

Bonne semaine.

Jean