Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  Problèmes avec Emacs pendant et après migration 12.04 => 14.04 » Le 01/05/2014, à 15:23

DieNah
Réponses : 3

Bonjour,

Je viens de finir ma migration vers trusty, mais voilà que emacs me pose des problèmes... J'ai eu déjà pendant la migration des alertes comme quoi ubuntu n'arrivait pas à mettre à jour emacsen-common. Mais ça n'a pas arrêté la migration. Idem, au moment du nettoyage, même message. Il n'arrive pas à supprimer emacsen-common. Du coup, une fois la migration complète, je me dis que je vais tenter de virer emacs pour faire une réinstall. Mais impossible. Voilà ce que j'obtiens (et c'est idem si je fais install au lieu de remove) :

sudo apt-get remove emacs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libcompfaceg1 xemacs21-basesupport
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  emacs
0 mis à jour, 0 nouvellement installés, 1 à enlever et 3 non mis à jour.
6 partiellement installés ou enlevés.
Après cette opération, 25,6 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 329283 fichiers et répertoires déjà installés.)
Suppression de emacs (45.0ubuntu1) ...
Paramétrage de emacsen-common (2.0.7) ...
Install emacsen-common for xemacs21
emacsen-common: Handling install of emacsen flavor xemacs21
/usr/lib/emacsen-common/packages/install/emacsen-common: 29: /usr/lib/emacsen-common/packages/install/emacsen-common: xemacs21: not found
ERROR: install script from emacsen-common package failed
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                  Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                    Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                    Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                    dpkg: error processing package emacsen-common (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de emacs24-common :
 emacs24-common dépend de emacsen-common (>= 1.4.10) ; cependant :
 Le paquet emacsen-common n'est pas encore configuré.

dpkg: error processing package emacs24-common (--configure):
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de emacs24-bin-common :
 emacs24-bin-common dépend de emacs24-common (= 24.3+1-2ubuntu1) ; cependant :
 Le paquet emacs24-common n'est pas encore configuré.

dpkg: error processing package emacs24-bin-common (--configure):
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de emacs24 :
 emacs24 dépend de emacs24-bin-common (= 24.3+1-2ubuntu1) ; cependant :
 Le paquet emacs24-bin-common n'est pas encore configuré.

dpkg: error processing package emacs24 (--configure):
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de ocaml-mode :
 ocaml-mode dépend de emacs23 | emacsen ; cependant :
  Le paquet emacs23 n'est pas installé.
  Le paquet emacsen n'est pas installé.
  Le paquet emacs24 qui fournit emacsen n'est pas encore configuré.
  Le paquet xemacs21-nomule qui fournit emacsen n'est pas installé.

dpkg: error processing package ocaml-mode (--configure):
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 emacsen-common
 emacs24-common
 emacs24-bin-common
 emacs24
 ocaml-mode
E: Sub-process /usr/bin/dpkg returned an error code (1)

Quelqu'un aurait déjà eu ce problème ou saurait comment m'aider ?

Merci d'avance !

#1 Re : -1 »  Problèmes avec Emacs pendant et après migration 12.04 => 14.04 » Le 04/05/2014, à 14:18

DieNah
Réponses : 3

Personne ? hmm Ca me balance des erreurs quand j'allume mon ordi en plus... Genre "erreur logicielle, voulez-vous faire suivre l'erreur" blablabla. Mais après il m'envoie une nouvelle erreur pour me dire qu'il a pas réussi à construire le rapport...

#3 Re : -1 »  Problèmes avec Emacs pendant et après migration 12.04 => 14.04 » Le 08/05/2014, à 16:56

DieNah
Réponses : 3

J'ai résolu mon problème toute seule comme une grande...

#4 -1 »  Des raccourcis Fn+Fx ne fonctionnent plus » Le 08/03/2014, à 11:02

DieNah
Réponses : 0

Bonjour,

Je suis sous ubuntu 12.04 avec un eeePC 1015PX, et j'ai un problème avec certains de mes raccourcis Fn. Les raccourcis Fn+ : F2 (WiFi), F3 (Touchpad Off), F4 (changement de résolution), F7 (éteindre l'écran), F9 (task manager (même si pour le coup je pense que sous ubuntu il ne sert à rien)), mais surtout F10 à F12 pour le son ne fonctionnent pas/plus.

Je sais qu'au moins les raccourcis pour le son fonctionnaient, puisque je les ai déjà utilisé. Mais depuis un certain temps, impossible de les faire fonctionner ! J'ai essayer de réactiver les raccourcis via les paramètres du clavier, mais rien à faire, ça ne marche pas.

J'espère que vous pourrez m'aider smile

#5 -1 »  Installation d'OpenGL » Le 29/05/2013, à 17:07

DieNah
Réponses : 6

Bonjour,

J'ai un projet à réaliser en C++ et je dois utiliser Glut et OpenGL. J'installe donc le package freeglut3, celui de développement aussi, Mais lorsque je tente de compiler le projet, j'obtiens

): error||undefined reference to 'dlopen'|
): error||undefined reference to 'dlopen'|
): error||undefined reference to 'dlopen'|
): error||undefined reference to 'dlsym'|
): error||undefined reference to 'dlsym'|
): error||undefined reference to 'dlsym'|
||=== Build finished: 6 errors, 0 warnings ===| 

Je fais des recherches, et je tombe sur ce lien : http://www.kiwwito.com/article/installi … -in-ubuntu
Je fais exactement ce qu'il y a d'écrit, mais lors de la compilation du fichier test j'ai ceci :

/usr/bin/ld: fatal error: test: open: Is a directory
collect2: ld a retourné 1 code d'état d'exécution

J'y comprends strictement rien... Ca a l'air d'être un problème de linkage, mais binutils-machin est pas censé servir à ça ?!

Précisions supplémentaires : le projet est un truc fait par des étudiants depuis plusieurs années, le tout sur codeblocks et avec cmake, et mon binôme a travaillé dessus juste avant moi, donc je ne pense pas que ça vienne du code du projet en lui-même. Je suis sur Ubuntu 12.04.

Merci d'avance pour votre aide !

#6 Re : -1 »  Installation d'OpenGL » Le 29/05/2013, à 17:23

DieNah
Réponses : 6

Alors niveau carte graphique :

lspci | grep "VGA compatible controller"
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)

Pour le pilote je sais pas du tout. Comment savoir ?

#7 Re : -1 »  Installation d'OpenGL » Le 29/05/2013, à 17:45

DieNah
Réponses : 6

Donc si je me réfère à ce lien http://www.larsen-b.com/Article/231.html présent dans la doc, j'ai bien les drivers DRM et AGP.

#8 Re : -1 »  Installation d'OpenGL » Le 29/05/2013, à 18:36

DieNah
Réponses : 6

Donc c'est encore plus incompréhensible >.< Est-ce qu'il y aurait une commande supplémentaire à faire pour le linkage ?

#9 Re : -1 »  [Récupération de données] Aide et centralisation des cas » Le 23/06/2011, à 13:52

DieNah
Réponses : 301

Bonjour,

J'ai formaté et ré-écrit sur mon disque dur par erreur, et j'ai donc perdu toutes mes données, que je voudrais récupérer. J'ai posté un topic ICI pour décrire mon problème avec plus de détails.

Merci par avance de votre aide smile

#10 Re : -1 »  [Résolu]Pour mettre Firefox 5 en français » Le 04/07/2011, à 17:26

DieNah
Réponses : 19

Merci beaucoup! Je peux enfin remettre mon firefox en français maintenant ^^

#11 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 23/06/2011, à 16:04

DieNah
Réponses : 37

Merci pour ce site smile

mjdon : Pour la fragmentation, je le sais tout à fait. C'est pour ça que je ne m'attends pas à tout récupérer, mais sauver ce qui peut être sauvé, si je peux m'exprimer ainsi ^^
J'ai essayé d'utiliser photorec sur la partition fat32 (la plus petite et la moins pleine), mais il n'a rien trouvé. Et comme je l'ai précisé, on dirait qu'il ne copie que les photos déjà existantes sur le DD. J'ai surveillé au fur et à mesure, et il ne m'a "sauvé" que des photos de la sauvegarde du pc de ma mère que j'ai faite et qui est toujours sur mon DD.

rmy : Reste pu qu'à voir s'il y a un centre sur Paris ou environs qui pourrait me faire un diagnostic sad Mais si tu peux m'en faire un, je suis preneuse lol
Et m'acheter un autre DD... Pas les moyens >.< Déjà que j'étais limite pour me prendre celui-là... ^^' [/ma life] Mais normalement l'intégralité de mes photos tient sur mon ordi. Mais comme photorec n'a copié que des trucs dont je me fous et qui sont à ma mère, forcément ça a saturé. sad
Ya pas moyen de "filtrer" ce qu'il copie? Je me souviens que lors d'un problème antérieur j'avais utilisé testdisk et j'ai pu copier ce que je voulais. Mais là je ne peux pas utiliser testdisk sur mon ordi. DD trop gros, ordi qui surchauffe, badaboum. Oui car j'ai tenté une analyse approfondie que j'ai finalement du faire sur un autre ordi, et qui n'a rien donné de concluant. En gros, il m'a trouvé pleins de partitions ext3 et ntfs sans rien dedans (j'en ai conclu que c'étaient mes tests de formatage), et des fat32 des erreurs de lecture. Peut-être que j'ai fait une connerie en lançant tout ça... Mais ça a tourné pendant plusieurs jours pour finir l'analyse. Du coup j'ai limite peur de recommencer.

#12 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 23/06/2011, à 22:17

DieNah
Réponses : 37

Je pense que je le ferai en dernier recours. Pas que je n'ai pas confiance, mais j'ai pas trop de moyens, et ça me ferait chier que tu réussisses et que je ne te donne que 10€ tu vois... Je sais que le prix est libre, mais tout travail mérite salaire.

Sinon pour photorec qui copie tout et n'importe quoi... personne? sad

#13 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 24/06/2011, à 14:20

DieNah
Réponses : 37

Wow wow wow... que d'informations xD

Juste une petite question avant que je me lance : blkls fait une copie de l'espace libre, c'est ça? Donc sachant que mon espace libre fait environs 800Go, ça veut dire qu'il me faut un autre DD, puisque je n'ai pas de place hmm

#14 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 24/06/2011, à 14:39

DieNah
Réponses : 37

Hum ouais je vois... Mais comment chaîner les deux?

#15 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 24/06/2011, à 15:10

DieNah
Réponses : 37

rmy : J'ai demandé à faire la recherche uniquement sur l'espace non alloué, mais il m'a balancé des fichiers qui existaient déjà hmm

Julien : Merci, j'vais tenter de faire ça smile

#16 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 24/06/2011, à 15:26

DieNah
Réponses : 37

Non non, pas du tout. Puisque je surveille en même temps le dossier que je choisis (mon dossier Images), qui n'est donc pas sur mon dd.

Mais par contre, j'comprends rien aux commandes blkls et foremost sad J'essaye de lancer les commandes comme indiquées, mais ça ne marche pas. Je dois taper quoi comme commande exactement?

#17 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 24/06/2011, à 16:42

DieNah
Réponses : 37

Ok, mais comment j'indique quel disque doit être copié? J'pensais me placer dans le media correspondant, mais j'ai 2 partitions sur le même disque.

Désolée, je sais que je suis un peu un boulet hmm

#18 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 25/06/2011, à 12:38

DieNah
Réponses : 37

Ha bah si il faut mettre le dev, c'est bon j'peux mettre le disque en entier, il est détecté comme /dev/sdb smile Merci beaucoup! J'vais tester ça et je vous tiens au courant, ou je reviendrai vers vous si j'ai toujours pas compris lol

#19 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 25/06/2011, à 13:26

DieNah
Réponses : 37

Bon, bah désolée du double post, mais blkls me renvoie les erreurs suivantes (certainement parce que mon disque est partitionné):

diana@diana-laptop:~$ sudo blkls /dev/sdb
Cannot determine file system type

diana@diana-laptop:~$ sudo blkls -f fat /dev/sdb
Invalid magic value (Error: sector size (64543) is not a multiple of device size (512)
Do you have a disk image instead of a partition image?)

diana@diana-laptop:~$ sudo blkls -f ext3 /dev/sdb
Invalid magic value (not an EXTxFS file system (magic))

Mais j'ai qu'un seul dev pour mon disque entier... Que faire?

#20 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 25/06/2011, à 20:59

DieNah
Réponses : 37

30€?! Faudra m'dire où alors. Parce même à Montgallet (quartier asiat de Paris où il n'y a que des magasins d'informatique) j'ai payé mon disque ~50€.

Enfin je vais quand même essayer les commandes, on verra bien.

#21 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 25/06/2011, à 21:33

DieNah
Réponses : 37

Et moi qui pensais que tout était moins cher à Montgallet... On peut dire que j'l'ai dans le... Enfin là où ça fait mal quoi. >.<

EDIT : J'viens d'avoir un flash. J'crois qu'il était à 37 en fait. J'l'ai acheté ya quelques mois déjà. Donc j'me souviens plus très bien. Enfin bref...

#22 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 25/06/2011, à 23:11

DieNah
Réponses : 37

Sauf que c'est pas ce disque là. Mais bon osef xD

La bonne nouvelle c'est que... ÇA MARCHE! Je suis en train de récupérer pas mal de photos déjà sur ma partition fat32. Quand ça sera fini je m'occuperai de la grosse partition ext3. J'espère juste que mon ordi ne va pas surchauffer >.<

P.S : C'est la "double commande" blkls | foremost que je suis en train d'utiliser.

Je mettrai résolu quand j'aurais tout récupéré wink Parce que si mon ordi surchauffe, je vais devoir trouver un moyen de le faire sur l'ordi de ma mère, qui elle est sur seven.

#23 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 26/06/2011, à 14:14

DieNah
Réponses : 37

J'ai fait toutes les solutions possibles. Le disque entier, une partition, que l'espace disponible ou non,... Je veux bien réessayer une fois pour voir mais bon...

C'est un portable. J'ai déjà voulu l'ouvrir, mais il a tellement chauffé que le plastique s'est déformé. Donc impossible de dévisser sad

EDIT : Je viens de relancer photorec. Ça donne plus ou moins la même chose, mais beaucoup plus lentement... Et encore, ya des photos que j'avais récupéré avec blkls | foremost que je n'ai pas récupéré là.

#24 Re : -1 »  Disque dur externe : Récupérer des données [Résolu] » Le 04/07/2011, à 17:21

DieNah
Réponses : 37

Oups désolée j'ai oublié de donner suite. J'ai fini de récupérer ce qu'il y avait à récupérer, sauf mes vidéos. Je suppose que c'est normal... Merci à tous pour votre aide en tout cas smile