Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  TVDownloader: télécharger les médias du net ! [2] » Le 11/05/2013, à 15:41

Frédéric Stemmelin
Réponses : 527

EDIT: problème réglé, c'était l'url pour le téléchargement du script qui était erronée, je l'ai mis à jour dans ce post et tout fonctionne parfaitement.

Bonjour,

j'ai installé les paquets "php5-cli" et "php5-curl" en plus du plugin "HDS Link Detector" https://addons.mozilla.org/addon/hds-link-detector/ pour Firefox sous Linux Mint 13.
J'ai téléchargé la dernière version du script "AdobeHDS.php" de K-S-V sur github "https://raw.github.com/K-S-V/Scripts/ma … obeHDS.php".

Après avoir redémarré Firefox j'ai récupéré la commande que me propose le plugin HDS Link Detector en rejouant la vidéo de l'émission "Maison France 5" depuis le site de pluzz:

"http://pluzz.francetv.fr/videos/la_maison_france_5.html"

Voici à quoi ressemble la ligne de commande (avec des retours chariots pour la clarté):

php AdobeHDS.php --manifest "http://ftvodhdsecz-f.akamaihd.net/z/streaming-adaptatif/2013/S19/J3/81446656-20130508-,398,632,934,
k.mp4.csmil/manifest.f4m?hdnea=exp=1368279682~acl=%2fz%2fstreaming-adaptatif%2f2013%2fS19%2fJ3%2f81446656-20130508-
*~hmac=44669b0843437b01575cd3a97e4946f7a09d78e6405a9255be2b63021882ce9b&hdcore=2.8.0&g=YKHSSINKTSBA" 
--delete 
--auth "hdntl=exp=1368365482~acl=%2fz%2fstreaming-adaptatif%2f2013%2fS19%2fJ3%2f81446656-20130508-
*~data=hdntl~hmac=e6d4bd80bea278091c4582b7645ce54044e91d6a6752089a62358ac0861b34ec
&als=0,0.1,0,0,0,NaN,0,0,0,65,f,0,2690.64,f,s,YKHSSINKTSBA,2.8.0,65&hdcore=2.8.0" 
--useragent "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0"

En lançant cette commande dans un terminal je vois défiler plein de lignes, mais ensuite plus rien ne se passe, pas de téléchargement.
Avec l'option "--play" et vlc je ne vois pas non plus de vidéo, bref ou est le soucis ?

Quelqu'un qui a un plus d'expérience avec cet outil pourrait-il avoir la gentillesse de tester de télécharger cette émission et me dire si ça fonctionne ?
Ceci m'aiderait grandement à comprendre si le problème vient de mon PC, ma distribution Linux ou si simplement le script (qui semble avoir été modifié il y 6 jours) ne fonctionne plus.

Merci.

La ligne me semble cohérente, avec les paramètres auth et useragent qui sont bien présents ...
Je ne vois pas ou ça coince et pas moyen d'avoir des logs d'erreur.

#1 Re : -1 »  TVDownloader: télécharger les médias du net ! [2] » Le 12/05/2013, à 11:59

Frédéric Stemmelin
Réponses : 527

Bonne nouvelle, le problème est réglé, et je remercie toutes les personnes qui m'ont aidées à trouver la solution ainsi que la personne à l'origine de ce merveilleux script (K-S-V).

@bibichouchou

Merci pour ta réponse, ça n'a pas marché, mais j'ai quand même compris quelque chose.

@thom83

Merci d'avoir testé pour moi, du coup j'ai bien compris que le problème venait de mon PC et non pas du site web ou du script en lui-même, vu que nos commandes sont semblables aux chiffres près.

@k3c

Je suis d'accord avec toi, copier la sortie du script aurai été intéressant et j'ai d'ailleurs essayé de le faire.
Dans mon explication plus bas tu va comprendre pourquoi je n'avais pas réussi à copier/coller la sortie du script (il faisait même planter pluma, l'éditeur de texte).


Pour faire simple, le problème vient de la façon dont j'ai téléchargé le fameux script php.
Sous Firefox, avec un clic droit sur l'ancien lien github du script que j'avais posté (https://github.com/K-S-V/Scripts/blob/m … obeHDS.php), avec option "enregistrer la cible sous", j'obtiens quelque chose comme ça:


<!DOCTYPE html>
<html>
  <head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# githubog: http://ogp.me/ns/fb/githubog#">
    <meta charset='utf-8'>
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <title>Scripts/AdobeHDS.php at master · K-S-V/Scripts · GitHub</title>
    <link rel="search" type="application/opensearchdescription+xml" href="/opensearch.xml" title="GitHub" />
    <link rel="fluid-icon" href="https://github.com/fluidicon.png" title="GitHub" />
    <link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-114.png" />
    <link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114.png" />
    <link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-144.png" />
    <link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144.png" />
    <link rel="logo" type="image/svg" href="http://github-media-downloads.s3.amazonaws.com/github-logo.svg" />
    <link rel="xhr-socket" href="/_sockets" />

Maintenant que j'ai trouvé comment télécharger proprement le script depuis github (https://raw.github.com/K-S-V/Scripts/ma … obeHDS.php), voici ce que j'obtiens:

<?php
  define('AUDIO', 0x08);
  define('VIDEO', 0x09);
  define('SCRIPT_DATA', 0x12);
  define('FRAME_TYPE_INFO', 0x05);
  define('CODEC_ID_AVC', 0x07);
  define('CODEC_ID_AAC', 0x0A);
  define('AVC_SEQUENCE_HEADER', 0x00);
  define('AAC_SEQUENCE_HEADER', 0x00);
  define('AVC_SEQUENCE_END', 0x02);
  define('FRAMEFIX_STEP', 40);
  define('INVALID_TIMESTAMP', -1);
  define('STOP_PROCESSING', 2);

  class CLI
    {
      protected static $ACCEPTED = array();
      var $params = array();

      function __construct($options = false, $handleUnknown = false)

Bref, on vois maintenant qu'il s'agit enfin d'un script php valide (70ko) alors que lors de la première tentative il s'agissait d'une page html (600ko) qui englobait le script php, donc pas du tout exécutable. En essayant d’exécuter du code html (sous forme de fichier .php) avec la commande php ça ne pouvait bien sur ne pas fonctionner.

Solution => télécharger le script en faisant un clic droit "enregistrer la cible du lien sous" sur cette url: https://raw.github.com/K-S-V/Scripts/ma … obeHDS.php
C'est la partie "raw" de l'url qui est importante ici smile

Me voila reparti à l'assaut avec cette fois-ci le bon script et le manifeste, mais j'ai encore un soucis de paquet.
Au moment de lancer la commande (que j'ai volontairement tronqué ici pour une plus grande lisibilité):

php AdobeHDS.php --manifest "http://ftvodhdsecz-f.akamaihd.net/z/streaming-adaptatif/2013/S19/J3/81446656-20130508-,398,632,934,k.mp4.csmil/manifest.f4m?hdnea= ...

J'obtiens la réponse suivante:

KSV Adobe HDS Downloader

You don't have 'curl' extension installed. please install it before continuing.

Solution =>

apt-get install php5-curl

Je lance la commande (j'ai rajouté des retours chariots pour la lisibilité):

php AdobeHDS.php 
--manifest "http://ftvodhdsecz-f.akamaihd.net/z/streaming-adaptatif/2013/S19/J3/81446656-20130508-,398,632,934,k.mp4.csmil/manifest.f4m
?hdnea=exp=1368351568~acl=%2fz%2fstreaming-adaptatif%2f2013%2fS19%2fJ3%2f81446656-20130508-*
~hmac=1578446290e5b6983eddecc8f077afeddc1cbcf8eb201b4da40b1d08ae9108f4&hdcore=2.8.0&g=GPSACDKUDOHO" 
--delete 
--auth "hdntl=exp=1368437369~acl=%2fz%2fstreaming-adaptatif%2f2013%2fS19%2fJ3%2f81446656-20130508-*~data=hdntl
~hmac=433f96b09104c8dd61edec2dcc75f894fbfb56e20fe3396157eece83c02ab057&als=0,0.1,0,0,0,NaN,0,0,0,18,f,0,2690.64,f,s,GPSACDKUDOHO,2.8.0,18
&hdcore=2.8.0" 
--useragent "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0"

Et maintenant le téléchargement se passe très bien. Il ne faut que quelques minutes pour télécharger les fichiers pour former la vidéo de 280Mo qui correspond à une émission de 45 minutes:

KSV Adobe HDS Downloader

Processing manifest info....                                                   
Quality Selection:                                                             
 Available: 833 577 304
 Selected : 833
Downloading 448/448 fragments                                                  
Found 448 fragments                                                            
Finished
-rw-r--r-- 1 fred users 283967418 mai   12 11:39 bea259013a49a3b4e2ea26e22f920d8d_2_f1614de61a57c735_Seg1-Frag.flv

Merci encore à tous pour votre aide précieuse.

#2 -1 »  [tuto] Steam + Ubuntu 12.04 (64bits) + AMD 4770 Radeon HD » Le 10/02/2013, à 01:23

Frédéric Stemmelin
Réponses : 32

** (15/02/2014) MAJ du tuto pour corriger un problème de paquet Ubuntu, qui génère un message d'erreur Steam "glXChooseVisual failed" **

Bonjour,

ce WE, Counter Strike Source est disponible dans le magasin Steam à moitié prix, et ce jeu fonctionne maintenant nativement sous Linux.
Par contre la version fglrx (pilotes AMD proprio) fournie avec Ubuntu 12.04 est un peu ancienne, en tout cas pas assez récente au niveau du support OpenGL.

Malheureusement il ne semble pas exister de paquets tout faits par Canonical pour l'instant. J'ai donc décidé d'installer les Catalyst Legacy en version 13.1.
Pour cela il faut télécharger et décompacter le fichier ZIP fourni par AMD à l’adresse suivante:

AMD Catalyst Legacy 13.1

Il faut ensuite installer quelques paquets Ubuntu:

sudo apt-get install dh-make dh-modaliases execstack libqtgui4 lib32gcc1 libc6-i386 dkms

Il faut aussi enlever toute version fglrx installé sur le PC:

sudo apt-get remove --purge fglrx fglrx-amdcccle fglrx-updates fglrx-amdcccle-updates

Il faut maintenant redémarrer le PC.
J'ignore simplement le message d'erreur qui m'informe que je me trouve en low résolution et j'ouvre une console texte avec la combinaison de touches:

CTRL+ALT+F1 pour me loguer en console  => pas toujours nécessaire, parfois on se retrouve en mode graphique tout seul smile

Dans cette console texte, je lance la commande suivante, à partir du répertoire où j'ai dé-zippé le fichier des pilotes AMD téléchargé un peu plus haut:

sudo sh amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run --buildpkg Ubuntu/precise

Cette commande va me créer 3 paquets .deb que j'installe alors facilement:

sudo dpkg -i fglrx*.deb

Je configure la carte graphique avec l'utilitaire en ligne de commande fourni:

sudo aticonfig --initial

*** Suite à une MAJ de Ubuntu non voulue, un nouveau pilote amd fglrx non fonctionnel est installé, on va donc empêcher son installation. Par contre, si un jour on désire revenir en arrière et quand même installer les nouveaux paquets fglrx officiels fournis par Ubuntu, il suffira d'effacer le fichier que l'on va créer ci-dessous, puis il faudra lancer une MAJ de la distribution ... ***

sudo pluma

Ceci ouvre une fenêtre graphique pour pouvoir créer un nouveau fichier que l'on va nommer "amd_legacy_fglrx_8_970_0ubuntu1" et que l'on va enregistrer sous le répertoire "/etc/apt/preferences.d/", avec le contenu suivant:

Package: fglrx*
Pin: version 2:8.970-0ubuntu1
Pin-priority: 1050

Un dernier reboot et on est prêt pour jouer à Counter Strike Source en ligne sous Linux.

sudo reboot

Attention quand même, les admins des serveurs CS:S ont le ban/kick facile !
Bref, il faut un peu de temps avant d'être à nouveau à l'aise avec ce jeu, qui ressemble quand même beaucoup à Counter Strike 1.6, qui lui est bizarrement encore en beta sous Linux.

Je n'ai pas testé de casque/micro et j'ai eu un changement de langue de l'interface qui est passée de français vers anglais au moment ou j'ai voulu toucher à la configuration de la partie voix.

Voila si ça peut dépanner quelqu'un j'en serais ravis.

MAJ (11/03/2013): J'ai rajouté le paquet "dkms" à la liste car il n'est pas toujours installé par défaut (par exemple si l'on n'active pas le pilote propriétaire avant d'utiliser cette méthode).

MAJ2 (07/06/2013): Si Steam plante quand vous désirez aller dans la partie magasin, voici la solution:

Flash pour Steam sous Linux 64

Il y a 2 étapes: Télécharger une version 32 bits de flash pour Linux, puis créer un répertoire pour y déposer un fichier extrait de l'archive que l'on vient de télécharger.

Flash32 pour Linux (tar.gz)

mkdir ~/.steam/bin/plugins

Allez dans le répertoire ou l'on a décompressé l'archive flash32, puis:

cp libflashplayer.so ~/.steam/bin/plugins/

MAJ3 (15/02/2014): Malheureusement une MAJ de Ubuntu installe une nouvelle version des pilotes AMD legacy, mais celle ci ne fonctionne pas, chez pas mal de monde. J'ai donc mis à jour ce tuto pour bloquer les paquets installés et éviter ce genre de désagréments (source: http://forum.ubuntu-fr.org/viewtopic.php?id=1493141).

#3 Re : -1 »  [tuto] Steam + Ubuntu 12.04 (64bits) + AMD 4770 Radeon HD » Le 11/03/2013, à 21:08

Frédéric Stemmelin
Réponses : 32

Bonjour,
je ne suis pas un spécialiste, mais mon tuto était surtout déstiné aux personnes qui utilisent Ubuntu 12.04, soit la version LTS (ou Mint version 13).
Cela devrait quand même marcher, mais il vaut mieux préférer la 12.04 à la 12.10 qui est buggée de mon point de vue.

J'ai utilisé les pilotes "legacy" car j'ai une vielle carte, Radeon HD 4770 qui n'est pas supportée par les derniers catalyst comme la version 13.2 (beta ou pas).
Ta carte par contre semble être encore supportée, il ne faut donc pas utiliser la version legacy.

Merci de un faire essai sur une Ubuntu LTS (12.04 donc) ou Mint 13 pour voir si ça fonctionne.
Pour info j'utilisais Unity sous Ubuntu, cet environnement devrait donc fonctionner avec cette méthode.

DKMS est un système qui permet de recompiler un module au démarrage du système si un changement du noyau est détecté, et de façon automatique.
Si tu rencontre un problème à ce niveau il y a peu de chances que cela fonctionne.

Essaie d'abord de résoudre ce problème DKMS avant d'espérer voir quelque chose à l'écran, par exemple en détaillant ce que tu fais et à quel moment tu obtiens l'erreur.


Je confirme que le paquet dmks est installé chez moi (peut-être d'origien sur Mint), il est donc sûrement nécessaire, je vais modifier mon post en conséquence.
Pour l'installer, rien de plus simple (a faire avant d'installer les 3 paquets générés):

sudo apt-get install dkms

#4 Re : -1 »  [tuto] Steam + Ubuntu 12.04 (64bits) + AMD 4770 Radeon HD » Le 10/07/2013, à 15:23

Frédéric Stemmelin
Réponses : 32

Bonjour,

je pense que le noyau n'est pas installé complètement.
Que donne la commande:

dpkg -l | grep linux-

Chez moi j'obtiens:

ii  linux-firmware                         1.79.4                                  Firmware for Linux kernel drivers
ii  linux-generic                          3.2.0.45.54                             Complete Generic Linux kernel
ii  linux-headers-3.2.0-23                 3.2.0-23.36                             Header files related to Linux kernel version 3.2.0
ii  linux-headers-3.2.0-23-generic         3.2.0-23.36                             Linux kernel headers for version 3.2.0 on 64 bit x86 SMP
ii  linux-headers-3.2.0-43                 3.2.0-43.68                             Header files related to Linux kernel version 3.2.0
ii  linux-headers-3.2.0-43-generic         3.2.0-43.68                             Linux kernel headers for version 3.2.0 on 64 bit x86 SMP
ii  linux-headers-3.2.0-45                 3.2.0-45.70                             Header files related to Linux kernel version 3.2.0
ii  linux-headers-3.2.0-45-generic         3.2.0-45.70                             Linux kernel headers for version 3.2.0 on 64 bit x86 SMP
ii  linux-headers-generic                  3.2.0.45.54                             Generic Linux kernel headers
ii  linux-image-3.2.0-23-generic           3.2.0-23.36                             Linux kernel image for version 3.2.0 on 64 bit x86 SMP
ii  linux-image-3.2.0-43-generic           3.2.0-43.68                             Linux kernel image for version 3.2.0 on 64 bit x86 SMP
ii  linux-image-3.2.0-45-generic           3.2.0-45.70                             Linux kernel image for version 3.2.0 on 64 bit x86 SMP
ii  linux-image-generic                    3.2.0.45.54                             Generic Linux kernel image
ii  linux-libc-dev                         3.2.0-48.74                             Linux Kernel Headers for development
ii  linux-sound-base                       1.0.25+dfsg-0ubuntu1.1                  base package for ALSA and OSS sound systems
ii  syslinux-common                        2:4.05+dfsg-2                           collection of boot loaders (common files)
ii  syslinux-legacy                        2:3.63+dfsg-2ubuntu5                    Bootloader for Linux/i386 using MS-DOS floppies

Essaie de nous donner le contenu du fichier de log:

/var/lib/dkms/fglrx/8.970/build/make.log

ou si le fichier n’existe pas, donne nous le contenu de celui-la:

/var/lib/dkms/fglrx/8.970/build/make.sh.log

#5 Re : -1 »  [tuto] Steam + Ubuntu 12.04 (64bits) + AMD 4770 Radeon HD » Le 10/07/2013, à 19:48

Frédéric Stemmelin
Réponses : 32

Bon, je crois qu'il s'agit d'un bug, voici des liens qui en parlent:

https://bugs.launchpad.net/ubuntu/+sour … ug/1198514
https://bugs.launchpad.net/ubuntu/+sour … bug/859101

Je pense qu'il manque simplement le fichier version.h qui devrait se trouver dans le répertoire (et qui devrait être fourni par le paquet "linux-headers-3.8.0-26-generic"):

/lib/modules/3.8.0-26-generic/build/include/linux/

Regarde si tu le trouve, sinon regarde si tu trouve celui (version.h) de ton ancien noyau qui devrait se trouver ici:

/lib/modules/3.8.0-19-generic/build/include/linux/

Bref, sans ce fichier tu es bloqué.
Voici le contenu du miens pour le noyau 3.2.0-43:

#define LINUX_VERSION_CODE 197162
#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))

Et celui pour le noyau 3.2.0-45:

#define LINUX_VERSION_CODE 197164
#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))

On voit que le nombre 197162 est incrémenté de 2 si on passe du noyau 3.2.0-43 au noyau 3.2.0-45.
Dans ton cas si tu prends comme point de départ le noyau 3.8.0-19, tu devra ajouter "7" au nombre inscrit pour arriver au noyau 3.8.0-26

#6 Re : -1 »  [tuto] Steam + Ubuntu 12.04 (64bits) + AMD 4770 Radeon HD » Le 16/11/2013, à 12:31

Frédéric Stemmelin
Réponses : 32

Je pense qu'extraire d'abord le fichier est la chose à faire.

Pour revenir au mode graphique, il faut appuyer simultanément sur la combinaison de touches CTRL+ALT+F7 (voir F8 ou F6 dans certains cas).
Il ne faut hésiter à tester ces combinaisons de touches avant de toucher au pilote graphique, au moins on saura alors comment ça fonctionne.

Si on lance les commandes en mode graphique et que l'on veut désinstaller le pilote graphique alors que celui-ci est en cours d’utilisation ça risque de poser problème, et c'est pourquoi je conseille de faire les manipulations en mode console et non depuis un terminal en mode graphique.

Pour le shutdown -r il faut lui indiquer le temps et c'est normal. Le plus simple est de lui indiquer "now" ce qui veut dire maintenant.
La commande devient alors "shutdown -r now" et la machine reboote immédiatement.

#7 Re : -1 »  [tuto] Steam + Ubuntu 12.04 (64bits) + AMD 4770 Radeon HD » Le 16/11/2013, à 14:55

Frédéric Stemmelin
Réponses : 32

En fait, non, il s'agit bien d'un fichier zip à télécharger.
Il faut choisir les options "Desktop Graphics", "Radeon HD series", "Radeon HD xxxx PCIe", puis enfin "Linux_64", ce qui nous donne finalement:

AMD catalyst legacy driver

Malheureusement le lien direct ne fonctionne pas. Il faut absolument passer par la sélection manuelle de la carte avec les menus ...

#8 Re : -1 »  Tuner TNT USB Avermedia A835: du nouveau ?! :-/ » Le 05/01/2013, à 14:51

Frédéric Stemmelin
Réponses : 100

Je confirme que cela fonctionne bien, y compris le scan des chaines. Mais il faut absolument passer par une compilation de media_build quelle que soit la distribution Linux choisie.
Dans mon cas j'ai recompilé media_build (version 2012-10-28) sur une vielle Linux Mint avec un noyau 2.6.35-32.

git clone git://linuxtv.org/media_build.git
cd media_build

Sous Ubuntu 12.04, la dernière version de média build ne fonctionnait pas bien chez moi, je me suis donc fixé sur une vielle version.
Sous Linux Mint 13 Mate, cette modification empêche le paquet de se compiler, il ne faut donc pas modifier le fichier Makefile dans ce cas précis.

vi linux/Makefile

J'ai donc modifié les 2 lignes suivantes du fichier Makefile (on peut utiliser gedit comme éditeur de texte à la place de vi), pour récupérer une version précise du fichier linux-media (http://linuxtv.org/downloads/drivers):

LATEST_TAR := http://linuxtv.org/downloads/drivers/linux-media-2012-10-28.tar.bz2
LATEST_TAR_MD5 := http://linuxtv.org/downloads/drivers/linux-media-2012-10-28.tar.bz2.md5

! Sous Mint 13 Mate, sans modifier le fichier, la version téléchargée est la suivnate: linux-media-2013-02-14.tar.bz2

puis j'ai lancé la compilation:

! Si vous êtes sur une Mint 13 Mate, il va falloir d'abord installer 2 paquets supplémentaires:

sudo apt-get install patchutils libproc-processtable-perl
./build
sudo make install; sudo make load

Maintenant on scanne:

w_scan -ft -c FR > Ville.conf
scan Ville.conf > channels.conf

Et finalement j'ouvre le fichier channels.conf avec vlc ...  (il faudrait l'épurer un peu).
Voici ce que j'obtiens avec dmesg:

[   15.736175] usbcore: registered new interface driver dvb_usb_af9035
[   15.736363] usb 1-4: dvb_usb_v2: found a 'AVerMedia AVerTV Volar HD/PRO (A835)' in cold state
[   15.895576] usb 1-4: dvb_usb_v2: downloading firmware from file 'dvb-usb-af9035-02.fw'
[   16.204687] usb 1-4: dvb_usb_af9035: firmware version=11.5.9.0
[   16.204695] usb 1-4: dvb_usb_v2: found a 'AVerMedia AVerTV Volar HD/PRO (A835)' in warm state
[   16.206602] usb 1-4: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[   16.206626] DVB: registering new adapter (AVerMedia AVerTV Volar HD/PRO (A835))
[   16.353296] i2c i2c-0: af9033: firmware version: LINK=11.5.9.0 OFDM=5.17.9.1
[   16.357059] usb 1-4: DVB: registering adapter 0 frontend 0 (Afatech AF9033 (DVB-T))...
[   16.415177] i2c i2c-0: tda18218: NXP TDA18218HN successfully identified
[   16.426789] Registered IR keymap rc-empty
[   16.426841] input: AVerMedia AVerTV Volar HD/PRO (A835) as /devices/pci0000:00/0000:00:12.2/usb1/1-4/rc/rc0/input5
[   16.426876] rc0: AVerMedia AVerTV Volar HD/PRO (A835) as /devices/pci0000:00/0000:00:12.2/usb1/1-4/rc/rc0
[   16.426878] usb 1-4: dvb_usb_v2: schedule remote query interval to 500 msecs
[   16.426880] usb 1-4: dvb_usb_v2: 'AVerMedia AVerTV Volar HD/PRO (A835)' successfully initialized and connected

Voici un petit extrait de mon fichier channels.conf actuel:

M6:482000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:120:130:1025
W9:482000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:220:230:1026
NT1:482000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:320:330:1027
PARIS PREMIERE:482000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:420:430:1028
ARTE HD:482000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE:720:731:1031

#9 Re : -1 »  Tuner TNT USB Avermedia A835: du nouveau ?! :-/ » Le 03/07/2013, à 19:13

Frédéric Stemmelin
Réponses : 100

Bonjour,

le message me semble clair:

[  685.945767] usb 1-5: dvb_usb_v2: Did not find the firmware file 'dvb-usb-it9135-02.fw'. Please see linux/Documentation/dvb/ for more details on firmware-problems.

Bref, il te manque le firmware que tu dois déposer dans le répertoire /lib/firmware.

Peut être quelque chose comme ça:

wget https://github.com/OpenELEC/dvb-firmware/blob/master/it9135/dvb-usb-it9135-02.fw?raw=true
mv ./dvb-usb-it9135-02.fw?raw=true dvb-usb-it9135-02.fw
sudo cp ./dvb-usb-it9135-02.fw /lib/firmware/

Alternativement tu peux essayer cette méthode aussi (http://www.linuxtv.org/wiki/index.php/ITE_IT9135)
Il te faut pour cela commencer par télécharger le fichier zippé suivant:

dvb-usb-it9135.zip

Une fois le fichier téléchargé, tu le dézippe:

unzip dvb-usb-it9135.zip

Maintenant tu peux extraire le firmware qui t'intéresse:

dd if=dvb-usb-it9135.fw ibs=1 skip=12866 count=5817 of=dvb-usb-it9135-02.fw

Et enfin copier le firmware que tu viens juste d'extraire au bon emplacement:

sudo cp ./dvb-usb-it9135-02.fw /lib/firmware/

Il faut enfin débrancher, puis rebrancher la clé USB.

J'ai testé les 2 méthodes et les fichiers obtenu sont identiques smile

#10 Re : -1 »  Tuner TNT USB Avermedia A835: du nouveau ?! :-/ » Le 10/09/2013, à 19:16

Frédéric Stemmelin
Réponses : 100

Il semble qu'il te manque le firmware: "dvb-usb-it9135-01.fw".
Donne nous le résultat de la commande:

ls -l /lib/firmware

Sinon, tu peux tout de suite executer ces 3 commandes:

wget https://github.com/OpenELEC/dvb-firmware/blob/master/it9135/dvb-usb-it9135-01.fw?raw=true
mv ./dvb-usb-it9135-01.fw?raw=true dvb-usb-it9135-01.fw
sudo cp ./dvb-usb-it9135-01.fw /lib/firmware/

#11 Re : -1 »  Tuner TNT USB Avermedia A835: du nouveau ?! :-/ » Le 11/09/2013, à 14:55

Frédéric Stemmelin
Réponses : 100

Tu pourrais tester avec un kernel récent:

Ubuntu kernels récents sous format .deb

Il faut installer les paquets correspondants à ton architecture (i386 ou amd64) et les paquets communs ".all.deb"

#12 Re : -1 »  Tuner TNT USB Avermedia A835: du nouveau ?! :-/ » Le 07/03/2014, à 21:39

Frédéric Stemmelin
Réponses : 100

Bonjour,

je pense qu'il faut peut-être attendre que la 14.04 soit réellement sortie.
Je pense que tout ceux qui utilisent une LTS vont upgrader, mais probablement avec un mois de retard pour ne pas essuyer les plâtres.

C'est ce que je vais probablement faire, même si je n’utilise plus de tuner TV depuis longtemps. Je pourrais néanmoins refaire un test d'ici 2 mois et faire un retour ici.

Depuis que Linux est devenue ma machine de tous les jours je n'installe plus que des versions LTS.
J'avais tenté une installation de la 14.04 beta 1 sur une autre machine, mais ça bloque déjà au niveau du support EFI pendant l'installation de grub. Ensuite, une fois la distrib. installée (64bits), Steam se vautre au lancement, du coup j'ai arrêté les frais.

#13 Re : -1 »  Nouveau membre, présentation » Le 03/03/2014, à 23:47

Frédéric Stemmelin
Réponses : 66

Bonjour,

je me permets également d'intervenir.
Vous avez finalement installé quelle version d'Ubuntu ? la 12.04, la 12.10 ? une autre ?

Pour en être sur, une fois que vous êtes logué (après le login/mot de passe donc), tapez la commande suivante:

lsb_release -d

Ensuite pour connaître précisément la carte graphique de votre portable, toujours au même endroit, tapez:

lspci -nn | grep VGA

Ensuite, cette vielle carte (RV515 probablement) n'est plus supportée par les pilotes Catalyst (AMD propriétaires) mais par le pilote libre radeon.

Cette commande enlève les paquets propriétaires s'ils sont installés, afin de pouvoir utiliser tranquillement le pilote radéon:

sudo apt-get remove --purge fglrx fglrx-amdcccle fglrx-updates fglrx-amdcccle-updates

Il est conseillé de rebooter maintenant.

Merci de vérifier quels sont les messages au démarrage du PC relatif au pilote libre:

dmesg | egrep 'drm|radeon'

Si votre problème d'affichage concerne l'écran il pourrait être judicieux de connecter un écran externe à votre portable pour tester. Sinon il va falloir regarder les logs du serveur Xorg:

cat /var/log/Xorg.0.log

Attention c'est un peu long comme log. Nous pouvons afficher les erreurs seulement:

cat /var/log/Xorg.0.log  | grep EE

Vous pouvez également tester en livecd et utiliser l'option "nomodeset" (touche F6) comme vous l'a conseillé nam1962.

#14 Re : -1 »  M4A78LT-M LE, (ati radeon 3000) problèmes affichage » Le 16/11/2013, à 13:42

Frédéric Stemmelin
Réponses : 38

Bon, pour savoir quelles sont les fréquences actuellement utilisées par ton moniteur quand tu es sous Linux, je vais te donner une commande à exécuter en root, depuis un terminal graphique.
ATTENTION une mauvaise manipulation peut endommager physiquement ton moniteur et le rendre inutilisable et la panne ne sera sûrement pas couvert par la garantie constructeur.

Bon, lance la commande ci-dessous, valide le message "warning" avec OK, puis appuie sur le bouton "Show", et enfin sur le bouton "Quit" en bas à gauche. Surtout ne joue pas avec les curseurs si tu ne veux pas endommager ton moniteur:

sudo xvidtune

Chez moi j'obtiens ceci:

Thunder ~ # xvidtune
Vendor: (null), Model: (null)
Num hsync: 1, Num vsync: 1
hsync range 0:  30.00 -  81.00
vsync range 0:  55.00 -  76.00
"1920x1080"   148.50   1920 2008 2052 2200   1080 1084 1089 1125 -hsync -vsync

La dernière ligne que tu obtiens est un Modeline.
Mais on peut aussi retrouver ces informations et bien plus encore dans le fichier de log de xorg:

less /var/log/Xorg.0.log

Ensuite pour la partie configuration proprement dite, c'est dans ce fichier que ça se passe.
La section qui nous intéresse est la partie "Monitor":

less /etc/X11/xorg.conf

Dans la partie "Monitor" tu peux rajouter 2 lignes qui correspondent à ton modèle d'écran:

HorizSync 30-81
VertRefresh 55-76

Attention, à nouveau ces valeurs représentent les valeurs MIN-MAX de rafraîchissement de ton moniteur. Ici ce sont les valeurs de mon moniteur perso à titre d'exemple, et qui sont donc de 30 à 81 KHz pour le balayage horizontal, et 55 à 76Hz pour le rafraîchissement vertical. Il faut prendre la référence de ton moniteur et aller sur le site du fabricants pour récupérer ces valeurs. Parfois elles sont inscrites sur une étiquette au dos de ton écran même. Il faudra ensuite mettre tes propres valeurs sur ces 2 lignes. Ces lignes n'existent pas par défaut dans ton fichier. Il faudra alors les rajouter, dans la section "Monitor".

Tu l'aura sûrement compris, on peut aussi rajouter un Modeline personnalisé, pour configurer finement ton écran.
Il ne faut pas créer de Modeline au hasard mais prendre un de ceux que tu trouve dans le fichier de log de xorg que l'on a vu plus haut. Cependant ceci est à faire en dernier recours seulement. Avec le DCC utilisé par les moniteurs modernes ça ne devrait plus être nécessaire de nos jours. Mais j'avais du le faire sur des vieux moniteurs cathodiques justement, mais ça remonte à longtemps maintenant.

Sous Windows il doit exister un utilitaire qui permet d'afficher les modeline utilisés, il s'agirait de Powerstrip.
Comme je n'ai pas de Windows je ne peux pas tester.

#15 -1 »  [Tuto] Caps Lock devient une touche MAJ verouillable » Le 13/09/2013, à 19:47

Frédéric Stemmelin
Réponses : 17

Bonjour,

si quand vous appuyez sur la touche "Caps Lock" Verrouillage Majuscule en français, et que vous désirez obtenir des chiffres sur la première rangée du clavier, il faut changer une option.
Par défaut vous obtenez des lettres majuscules avec des accents comme la touche "é" qui donne "É" au lieu de "2".

Il suffit d'aller dans la configuration du clavier, puis de choisir:

"Comportement de la touche Verr. Maj." puis "Verr. Maj. active ou désactive maj. ce qui affecte toutes les touches".

En anglais:

"Caps Lock key behavior" puis "Caps Lock toggles Shift so all keys are affected"

Cette astuce n'était pas évidente à trouver, donc si ça peut aider quelqu'un c'est tant mieux.

#16 Re : -1 »  [Tuto] Caps Lock devient une touche MAJ verouillable » Le 17/09/2013, à 09:50

Frédéric Stemmelin
Réponses : 17
nam1962 a écrit :

Intéressant, sauf que... pas trouvé cette option dans les paramètres clavier sous Xfce 4.10 (Saucy)

Apparemment, sous Xfce je ne vois pas d'autre solution que de modifier le fichier "/etc/X11/xorg.conf", et d'y rajouter la ligne suivante dans la partie "Input Devices" :

Option "XkbOptions" "caps:shiftlock"

Bon je dois avouer que chez moi cette section n'est pas présente, il faudrait donc la rajouter, avec probablement d'autres paramètres comme le clavier sélectionné ...

#17 Re : -1 »  [Tuto] Caps Lock devient une touche MAJ verouillable » Le 17/09/2013, à 10:00

Frédéric Stemmelin
Réponses : 17
tiramiseb a écrit :

Et du coup, comment tu fais pour écrire des majuscules accentuées ?

Il faut utiliser les touches mortes. Ce sont des touches qui n'affichent rien a l’écran lors de la première pression sur la touche, mais qui s'utilisent en combinaison avec d'autres touches comme les voyelles. Deux appuis successif sur une touche morte la fait s'afficher.

Exemples:

- "É", il faut utiliser la combinaison "AltGr" + "?" puis la combinaison "MAJ" + "e". La première combinaison active la touche morte "´" qui est l'accent aiguë, et la deuxième le "e" en majuscule.
- "È", il faut utiliser la combinaison "AltGr" + "µ" puis la combinaison "MAJ" + "e". La première combinaison active la touche morte "`" qui est l'accent grave, et la deuxième le "e" en majuscule.

J'avoue que c'est moins pratique que d'utiliser la touche Caps Lock, mais ce tuto était surtout fait pour répondre à un windowsien qui ne retrouvait pas le même comportement sous Linux.

#18 -1 »  [tuto] Installation JRE 7update 21 de SUN sous 12.04 LTS (Mint 13_64) » Le 07/06/2013, à 19:59

Frédéric Stemmelin
Réponses : 0

Bonjour,

la doc officielle pour installer java sous Ubuntu se trouve ici:
Installer java

Je n'ai pas trouvé ce que je cherchais, et pour être honnête j'avais oublié que cette doc existait.
J'ai remplacé "icedtea" car il n'arrêtait pas de planter chez moi, avec firefox 21 64 bits.

Voici comment j'ai procédé:

Je commence par enlever l'ancienne version, soit "openjdk", de la façon suivante:

sudo apt-get purge openjdk*

J'ai ensuite téléchargé la dernière version du JRE depuis le site officiel SUN (maintenant Oracle), sous forme de fichier tar.gz:
Page SUN java  => jre-7u21-linux-x64.tar.gz

Ensuite on décompacte et on l'installe, assez facilement:

tar -xvzf jre-7u21-linux-x64.tar.gz
sudo mkdir -p /usr/lib/jvm/jre1.7.0
sudo mv jre1.7.0_21/* /usr/lib/jvm/jre1.7.0/
sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jre1.7.0/bin/java 0
mkdir ~/.mozilla/plugins
ln -s /usr/lib/jvm/jre1.7.0/lib/amd64/libnpjp2.so ~/.mozilla/plugins/

Optionnellement on peut aussi faire ceci:

sudo update-alternatives --config java
sudo update-alternatives --install "/usr/bin/javaws" "javaws" "/usr/lib/jvm/jdk1.7.0/bin/javaws" 1

A la fin de la commande "update-alternatives" on trouve parfois un "0" et parfois un "1", si quelqu'un à une explication je suis preneur.

#19 Re : -1 »  [RESOLU]Installation Theme Hospital » Le 30/04/2013, à 23:12

Frédéric Stemmelin
Réponses : 5

Bonjour,

je viens d'installer ce magnifique jeu et il fonctionne parfaitement, y compris en plein écran smile

Voici les étapes de mon installation:
D'abord il faut télécharger le fichier "setup-00714-ThemeHospital-PC.exe" sur le site abandonware:

ThemeHospital

Il faut ensuite lancer l'installation avec crossover (ce qui est mon cas) ou wine.
J'ai choisis "autre programme" et une bouteille windows 98 sous crossover, vu que ce jeu n'est pas dans la liste des programmes supportés.

J'ai ensuite installé et configuré dosbox:

sudo apt-get install dosbox
dosbox -c 'config -writeconf dosbox.conf'

Une fois l'installation terminée, j'ai copié les fichiers de Thème Hospital de la façon suivante:

mkdir -p ~/dosbox/ThemeHospital/cd 
cp -pr ~/.cxoffice/ThemeHospital/drive_c/users/crossover/Application Data/Abandonware-France/ThemeHospital/C/HOSPITAL/* ~/dosbox/ThemeHospital/
cp ~/.cxoffice/ThemeHospital/drive_c/users/crossover/Application Data/Abandonware-France/ThemeHospital/CD/* ~/dosbox/ThemeHospital/cd/
cp ~/.dosbox/dosbox-0.74.conf ~/dosbox/ThemeHospital/ThemeHospital.conf

J'ai ensuite adapté le fichier de configuration "ThemeHospital.conf" de la façon suivante:

# fullscreen=false
fullscreen=true
fulldouble=false
fullresolution=original
# windowresolution=original
windowresolution=1024x768
#output=surface
output=opengl

[autoexec]
# Lines in this section will be run at startup.
# You can put your MOUNT lines here.

mount c ~/dosbox/ThemeHospital
imgmount D: "/home/fred/dosbox/ThemeHospital/cd/ThemeH.iso" -t iso
c:
keyb fr

Il ne reste maintenant plus qu'à lancer le jeu:

dosbox -conf /home/fred/dosbox/ThemeHospital/ThemeHospital.conf -c HOSPITAL.EXE -c exit

Bien sur, dans l'idéal il faudrait rajouter un raccourcis sur le bureau ou dans les menus, mais je me suis arrêté la et j'ai préféré lancer le jeu.
Tout fonctionne à merveille en plein écran avec le son. Apparemment cette version corrige même un bug dans le niveau 5.
N'hésitez pas à modifier le chemin "/home/fred/" par quelque chose comme "~/" la ou ça vous semble intéressant, je n'ai pas pris la peine de vérifier que cela fonctionne partout, mais il n'y a pas de raison qu'il n'en soit pas ainsi.

Dernière chose, dans le jeu il faut rester appuyé sur le bouton de la souris pendant que l'on sélectionne les menu en haut de l'écran.
Profitez bien de ce jeu, qui est sublime smile

#20 Re : -1 »  TUTO Ubuntu 12.10 carte son M-audio audiophile 2496 ICE1712.conf » Le 30/01/2013, à 19:28

Frédéric Stemmelin
Réponses : 4

De rien, si ça peut aider smile
Pour la petite histoire j'avais ouvert un rapport de bogue et j'ai reçu un mail quelques semaines plus tard. J'ai répondu à ce mail en expliquant ma solution.
Je n'ai pas suivi plus avant ce rapport de bogue, mais j'espère qu'ils corrigerons le problème pour la prochaine version, si ce n'est déjà fait.

#21 Re : -1 »  TUTO Ubuntu 12.10 carte son M-audio audiophile 2496 ICE1712.conf » Le 27/04/2013, à 19:55

Frédéric Stemmelin
Réponses : 4

Bonjour,

dans cette partie de ton fichier:

ICE1712.pcm.front.0 {

il semblerai qu'il manque une ligne très importante:

slave.format S32_LE

Je n'en connais pas la signification, mais ça avait résolu mon problème.

#22 Re : -1 »  Problème de démarrage avec mdadm, initrams (busybox) raid 5 incorrect » Le 16/12/2012, à 15:50

Frédéric Stemmelin
Réponses : 13

Bon, on va y aller par étapes.

Résumé de ta configuration actuelle:

/dev/sda 160Go, disque de BOOT utilisé pour le système.
/dev/sdb 1To RAID5
/dev/sdc 1To RAID5
/dev/sdd 1To RAID5

As-tu des données importantes sur les 3 disques utilisés pour le RAID5, à savoir /dev/sdb, /dev/sdc et /dev/sdd ?
Peut-on effacer le contenu de ces 3 disques ?

Je posterais la suite en fonction de ta réponse.

#23 Re : -1 »  Problème de démarrage avec mdadm, initrams (busybox) raid 5 incorrect » Le 16/12/2012, à 16:17

Frédéric Stemmelin
Réponses : 13

Merci pour ta réponse rapide.

Je confirme que transférer 1To sur un NAS peut-être long, mais je pense que c'est la meilleure solution.
Dis moi si tu es prêt à le faire, car je n'ai pas envie de te faire perdre tes données. Ma solution passe obligatoirement par un effacement de ces 3 disques.

Si tu ne souhaite pas sauvegarder tes données et essayer de résoudre le problème sans effacer les 3 disques je laisse quelqu'un d'autre le soin de s'occuper de ton problème.

Idem, je posterais la suite en fonction de ta réponse.

#24 Re : -1 »  Problème de démarrage avec mdadm, initrams (busybox) raid 5 incorrect » Le 16/12/2012, à 16:29

Frédéric Stemmelin
Réponses : 13

Très bien, je vais suivre cette discussion et poster dès que tu sera sur que tes données seront à l'abri.