Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 10

#0 -1 »  Bind / Webmin - Problème de configuration » Le 06/03/2013, à 20:30

ThePeach
Réponses : 3

Bonsoir,

J'ai migré mon ancien serveur 1and1 pour un serveur Kimsufi qui me convenait mieux et ai au passage migré le serveur DNS Bind que j'avais configuré à l'aide de Webmin.
Le soucis est que seuls l'enregistrement ns1.xxx.com pointe vers la bonne adresse IP.

Voici mes fichiers de configuration :

named.conf

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";

named.conf.locals

zone "xxx.com" {
        type master;
        file "/var/lib/bind/xxx.com.hosts";
        };

mine-wars.com.hosts

$ttl 38400
xxx.com.  IN      SOA     ns1.xxx.com. xxx.mail.fr. (
                        1362157067
                        10800
                        3600
                        604800
                        38400 )
xxx.com.  IN      A       5.135.xxx.xxx
ns1.xxx.com.      IN      A       5.135.xxx.xxx
ns2.xxx.com.      IN      A       5.135.xxx.xxx
forum.xxx.com.    IN      A       5.135.xxx.xxx
launcher.xxx.com. IN      A       5.135.xxx.xxx
skins.xxx.com.    IN      A       5.135.xxx.xxx
www.xxx.com.      IN      A       5.135.xxx.xxx
mail.xxx.com.     IN      A       5.135.xxx.xxx
xxx.com.  IN      MX      10 mail.xxx.com.
xxx.com.  IN      TXT     "v=spf1 all"
ubuntu.xxx.com.   IN      A       5.135.xxx.xxx
chat.xxx.com.     IN      A       5.135.xxx.xxx
login.xxx.com.    IN      A       5.135.xxx.xxx
wordpress.xxx.com.        IN      A       5.135.xxx.xxx
v3.xxx.com.       IN      A       5.135.xxx.xxx
lg2d.xxx.com.     IN      CNAME   lg2d.yyy.com.
panel.xxx.com.    IN      A       5.135.xxx.xxx
; DKIM
_domainkey.xxx.com. IN TXT "t=y; o=-;"
dkim._domainkey.xxx.com. IN TXT "k=rsa; t=s; p=blabla"
xxx.com.  IN      NS      ns1.xxx.com.
xxx.com.  IN      NS      ns2.xxx.com.

Voila smile
Si vous avez une idée de ce qui cloche, merci de m'aider ! (C'est quand même assez embêtant de couper ainsi un site x) )

#2 Re : -1 »  Bind / Webmin - Problème de configuration » Le 07/03/2013, à 18:18

ThePeach
Réponses : 3

Une âme charitable pour me venir en aide ?

#3 Re : -1 »  Bind / Webmin - Problème de configuration » Le 07/03/2013, à 20:01

ThePeach
Réponses : 3

O_o j'avais laissé la directive listen-on { 127.0.0.1; }
Pas étonnant que ça ne fonctionne pas wink

Ce sujet ressemble étrangement à un monologue...

#4 Re : -1 »  Sécurité FTP vsftpd » Le 06/12/2012, à 17:28

ThePeach
Réponses : 15

Pour modifier le fichier tu fais :

nano /etc/proftpd/proftpd.conf

Tu navigues avec les flèches jusque

# Use this to jail all users in their homes 
# DefaultRoot                    ~

et tu supprimer le # pour obtenir ceci :

# Use this to jail all users in their homes 
DefaultRoot                    ~

Pour sauvegarder le fichier, tu fais Ctrl+O, pour le fermer Ctrl+X

#5 -1 »  Configuration BIND & Webmin » Le 06/12/2012, à 17:24

ThePeach
Réponses : 1

Bonjour !

J'ai récemment choisi de passer le cap : me détacher du serveur de noms fourni par mon hébergeur pour une configuration avec BIND, l'hébergeur ne gérant pas le SPF.
J'ai donc, par facilité, choisi d'installer Webmin. Aucun soucis, j'ai même réussi à y ajouter la double authentification de Google !

Par contre, pour ce qui est de BIND lui-même... yikes Perdu devant tant de champs, j'ai préféré faire mes tests avec mon domaine thepeach.tk lol
J'ai suivi ce tutoriel et j'ai :
1- Crée une zone primaire
2- Rentré deux serveurs de noms : ns1.thepeach.tk & ns2.thepeach.tk
3- Configuré ces serveurs de noms chez mon hébergeur
4- Entré des sous-domaines et des enregistrements
Et... bien évidemment ca marche pas ! (Sinon je posterais pas ici smile ). En fait, seuls les serveurs de noms sont bien redirigés, le ping renvoie bien à mon serveur. Par contre aucun des enregistrements n'est pris en compte, même en ayant baissé les valeurs de rafraîchissement du DNS.

Pourriez-vous m'aider ? tongue

ThePeach

#6 Re : -1 »  Configuration BIND & Webmin » Le 06/12/2012, à 18:00

ThePeach
Réponses : 1

C'était pas si compliqué au final... Mais bon, quand on oublie de définir les enregistrements de ns2.thepeach.tk... on va pas bien loin !

#7 -1 »  Problème de sécurité Postfix » Le 02/12/2012, à 01:31

ThePeach
Réponses : 4

Bonjour !

J'utilise Postfix sur un serveur Ubuntu 12.10 et ai des problèmes de relai de spams.
J'ai pourtant configuré Postfix correctement, installé saslauthd (avec /etc/shadow), configuré Postfix pour n'accepter que les mails provenant d'une machine locale. J'ai même bloqué le port 25 avec une règle IPTABLES !
Les différents sites qui permettent de vérifier les vulnérabilités de l'open relay affichent bien le port comme fermé et, avant que je ne le bloque, affichaient bien mon serveur comme sécurisé.

Malgré cela, lorsque je lance la commande "postqueue -p", j'obtiens une centaine de requètes. D'où cela vient-il ?

Merci d'avance pour votre aide.

ThePeach

#8 Re : -1 »  Problème de sécurité Postfix » Le 02/12/2012, à 11:27

ThePeach
Réponses : 4

Voilà le main.cf :

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mine-wars.tk
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mine-wars.tk, s15968234.onlinehome-server.info, localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = loopback-only
inet_protocols = ipv4
home_mailbox = Maildir/
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions =
    permit_sasl_authenticated,
    permit_mynetworks,
    reject_unauth_destination,
    check_policy_service unix:private/policy-spf
smtp_tls_security_level = may
smtpd_tls_security_level = may
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/ssl/certs/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

Et l'extrait d'un postqueue :

6F76A1E720     3136 Sat Dec  1 02:39:31  2mbdoy@4d55fx.jufj3.com
(delivery temporarily suspended: host mx2.comcast.net[76.96.40.147] refused to talk to me: 554 imta03.emeryville.ca.mail.comcast.net comcast 217.160.78.4 Comcast block for spam.  Please see http://postmaster.comcast.net/smtp-erro … #BL000000)
                                         stuartlanding@comcast.net

6C5261C897     7202 Thu Nov 29 10:56:20  0pkd9ze1q@s0q3dur2r.ppy7d.com
(host mx00.kundenserver.de[212.227.15.150] said: 421 invalid sender domain 's0q3dur2r.ppy7d.com' (misconfigured dns?) http://postmaster.1and1.com/error-messa … nderdomain (in reply to RCPT TO command))
                                         info@hfcarbon.de

68A1F2312B     7237 Thu Nov 29 13:09:33  t7zas7s@ayd7kcdfz5.ppy7d.com
(host mx00.kundenserver.de[212.227.15.134] said: 421 invalid sender domain 'ayd7kcdfz5.ppy7d.com' (misconfigured dns?) http://postmaster.1and1.com/error-messa … nderdomain (in reply to RCPT TO command))
                                         u53198946@krakow-shop.com

660CC1E705     3118 Sat Dec  1 02:13:21  ppg2q@3m7.jufj3.com
(delivery temporarily suspended: host gateway-f2.isp.att.net[207.115.11.16] refused to talk to me: 550-217.160.78.4 blocked by ldap:ou=rblmx,dc=att,dc=net 550 Error - Blocked for abuse. See http://att.net/blocks)
                                         wrbean1@bellsouth.net

6EC131E717     7193 Thu Nov 29 11:30:14  y7no@7c4s.ppy7d.com
(host mx01.kundenserver.de[212.227.15.134] said: 421 invalid sender domain '7c4s.ppy7d.com' (misconfigured dns?) http://postmaster.1and1.com/error-messa … nderdomain (in reply to RCPT TO command))
                                         info@vistherm.de

6B64C1C890     5089 Sat Dec  1 01:20:06  MAILER-DAEMON
(Host or domain name not found. Name service error for name=ihri.jufj3.com type=MX: Host not found, try again)
                                         u4dhoa@ihri.jufj3.com

68D8D1E71D     3169 Sat Dec  1 02:35:36  4dcr2en@5yc8.jufj3.com
(host mx01.1and1.com[74.208.5.21] said: 451 Requested action aborted (in reply to RCPT TO command))
                                         sa1@denver-property-management.com

-- 786 Kbytes in 121 Requests.

#9 Re : -1 »  Problème de sécurité Postfix » Le 02/12/2012, à 22:00

ThePeach
Réponses : 4

Désolé de ne répondre que maintenant : je n'étais pas là aujourd'hui et je viens juste de faire ce que tu m'as conseillé.

En effet, les mails s'arrêtent le 1er Décembre vers 2h30 du matin. Ce qui est assez étrange car je n'ai fait aucune manipulation sur le serveur à cette heure là et aucune tache automatique ne s'effectue à 2h30... Par ailleurs, je ne savais pas que les mails qui n'ont pas été envoyés correctement étaient renvoyés.

Par contre, je ne sais pas comment faire pour voir l'origine du mail...

J'ai tout de même lancé la commande

postsuper -d ALL

et postqueue ne renvoie maintenant plus que

Mail queue is empty

ce qui est plutôt bon signe smile

Merci beaucoup pour ces réponses rapides !