Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 -1 »  Création d'un CMS dédié à la généalogie » Le 03/07/2017, à 10:00

Tabouet
Réponses : 2

Bonjour tout le monde,

Quand j'étais à la Fac, j'ai réalisé un systéme qui permettait aux généalogistes de publier leurs généalogies, bien génial quand j’y repense. Il s’agissait juste d’une série de pages HTML (avec un peu de javascript et de css) qui servaient t’interface à la consultation d’une base de données Access. A l’origine, j’avais proposé au professeur qui suivait mon projet la réalisation d’un logiciel de généalogie « online » mais il m’a freiné car selon lui, c’est un projet trop important et j’aurais cruellement manqué de temps. Quoi qu’il en soit, l’idée est toujours restée dans un petit coin de ma tête.

Depuis 2007, je publie ma généalogie sur mon site via des pages générées par Heredis XX, c’est bien pratique, mais de vous à moi, l’optimisation pour le référencement du code source est loin d’être géniale et la modification des centaines de pages n’est pas possible.
C’est ainsi qu’en 2016, j’ai pris la décision de créer mon propre outil de publication de généalogie. A l’origine destiné à un usage personnel, Publiged est désormais en voie de deviner un logiciel libre.

PubliGED est ce que j’appelle un GMS (Genealogy Management System) par analogie avec les CMS, comme Joomla, WordPress ou Spip. Développé essentiellement en PHP et SQL, avec quelques gouttes de CSS et de HTML, PubliGED a pour but de permettre aux généalogistes de publier facilement et rapidement leurs généalogies en utilisant le gedcom, un format de fichier commun à la plupart des logiciels de généalogie.

PubliGED a deux grandes fonctionnalités :

- Une partie concerne la transformation du gedcom en pages web qui permettent de consulter facilement la base d’ancêtres.

capture02.jpg

capture05.jpg

- La seconde partie est un mini-blog qui permet de publier des articles pour parler de ses recherches ou pour raconter la vie de ses ancêtres.

capture01.jpg

Pour l'instant, je ne peux pas encore vous proposer de démo, mais j'ai quelques captures d'écran.
C'est encore très moche par je me concentre sur les fonctionnalités avant l’esthétique:

J'ai créé une page sur Tipeee pour m'aider à concrétiser le projet : https://www.tipeee.com/genealexis/
Ainsi qu'un site où je commence à présenter le projet: http://publiged.genealexis.fr

A bientôt,
Alexis.

#1 Re : -1 »  Création d'un CMS dédié à la généalogie » Le 03/07/2017, à 17:02

Tabouet
Réponses : 2

Bonjour,

Merci beaucoup pour ton message, c'est le genre de choses qui m'encourage à continuer et à affronter les centaines de lignes de code en PHP.

Je note que tu es volontaire pour tester si besoin, mais bon... pas avant un petit moment, j'ai encore pas mal de boulot.

A bientôt,
Alexis.

#2 Re : -1 »  vol de clefs usb : comment se protéger LL antivol » Le 25/01/2012, à 12:28

Tabouet
Réponses : 9

Bonjour à tous,

Perso, pour pas que l'on me vole ma clé USB, je la mets dans ma poche quand je ne m'en sers pas.

@+
Alexis

#3 -1 »  Votre premier linux » Le 18/10/2011, à 11:34

Tabouet
Réponses : 61

Bonjour,

C'est un sujet que je n'ai pas trouvé sur le forum, pourtant je suis sûr qu'il peut-être intéressant.

Quel a été votre "premier linux", Celui avec lequel vous avez fait vos premiers pas au pays des pingouins ?

Pour ma part, c'était "Redmond Linux" et le bureau gnome... c'était en 2002...
Je me souviens de quelques petits détails, par exemple gnome avait une "barre des tâches" en bas, et dans le coin en bas à
gauche, une patte d'ours permettait d'afficher un menu qui contenait les applications installées.

J'ai très vite abandonné car j'ai planté mon PC lol

A bientôt,
Alexis

#4 Re : -1 »  Votre premier linux » Le 18/10/2011, à 19:51

Tabouet
Réponses : 61

Désolé pour le pingouin à la place du Manchot...

#5 Re : -1 »  Votre premier linux » Le 25/01/2012, à 17:05

Tabouet
Réponses : 61

Merci pour vos témoignages.

Il y a tout de même des jours (comme aujourd'hui) où je doute.
A chaque mise à jour je perds un de mes périphériques : d'abord ma carte tuner TV, puis la télécommande de mon PC (media center), puis ma webcam et aujourd'hui je n'ai plus d'accès à Internet.

Je passe plus de temps à faire des réglages qu'à utiliser mon PC.

#6 -1 »  plus de wifi depuis quelques jours » Le 25/01/2012, à 11:54

Tabouet
Réponses : 6

Bonjour à tous,

Depuis quelques jours, je n'arrive plus à me connecter à ma box via le wifi.
J'ai parcouru le forum et la doc mais sans trouver de réponses à mon soucis.

Voici le resultat de la commande iwconfig :

lo            no wireless extensions.

eth0        no wireless extensions.

wlan0     IEEE 802.11bgn ESSID:off/any
              Mode:managed   Access Point:Not-Associated    Tx-power=16  Dbm
              Retry long limit:7    RTS  thr:off        Fragment    thr:off
              Encryption   key:off
              Power Management:on

et voici le contenu de mon fichier interfaces :

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp

Avant, j'avais une quinzaine de réseaux wifi dans la liste, dont le mien. Depuis quelques jours, je n'en ai plus un seul.

Merci et à bientôt,
Alexis

#7 Re : -1 »  plus de wifi depuis quelques jours » Le 25/01/2012, à 14:21

Tabouet
Réponses : 6

Merci pour l'info !

yayals a écrit :

tout les fichiers qui sont demandés sont dans le cd d'installation

Toujours pas sur le mien sad qui n'est pas reconnu comme tel par ubuntu.

#8 Re : -1 »  plus de wifi depuis quelques jours » Le 25/01/2012, à 16:47

Tabouet
Réponses : 6

Je ne comprends pas ce que le pilote vient faire dans cette histoire.
En clair, un soir ça marche et le lendemain matin sans rien changer à mon PC (même pas une mise à jour)
ça ne marche plus.

#9 Re : -1 »  plus de wifi depuis quelques jours » Le 25/01/2012, à 17:59

Tabouet
Réponses : 6

J'ai de nouveau une connexion mais je ne sais pas si le problème est résolu ou simplement contourné.

En fait, j'ai fait un clic sur le petit icone en haut à droite et j'ai choisi "créer un nouveau réseau sans fil".
Pour l'instant ça à l'air de marcher puisque je suis même en train de mettre à jour la distribution.

Edit de 18h26 :
La mise à jour à bien eu lieu, avec téléchargements et installations mais par contre je n'ai pas
accés à internet avec un navigateur hmm

#10 -1 »  Installation de Blue Mars ? » Le 25/10/2011, à 13:28

Tabouet
Réponses : 3

Bonjour,

J'aimerai installer Blue Mars sous Ubuntu, j'ai testé avec Wine mais il y a quelques bugs d'affichage et c'est
quasi inutilisable.

Est-ce que certains d'entre vous en réussi ?

Merci et à bientôt,
Alexis

#11 Re : -1 »  Installation de Blue Mars ? » Le 25/01/2012, à 11:59

Tabouet
Réponses : 3

Bonjour,

Désolé pour la réponse tardive ^^
Je n'ai plus Windows sur ce PC.

A bientôt,
Alexis

#12 Re : -1 »  [Resolu] Comment puis-je empêcher Ubuntu de démarrer sous Unity ? » Le 18/10/2011, à 11:07

Tabouet
Réponses : 13

Bonjour,

Peut-être que le paragraphe 6 de cette page pourra t'aider :
http://doc.ubuntu-fr.org/unity

A bientôt,
Alexis

#13 Re : -1 »  Dennis Ritchie le créateur du langage C est mort (dans l’indifférence) » Le 13/10/2011, à 11:18

Tabouet
Réponses : 97

Bonjour,

J'ai relayé l'info sur G+ et sur Twitter

A bientôt,
Alexis

#14 -1 »  [Résolu] Tableau périodique des éléments » Le 17/10/2011, à 22:27

Tabouet
Réponses : 2

Bonsoir,

Vous allez sans doute vous  demandez ce qu'un message sur le tableau périodique des éléments vient faire ici...
Pas de panique, je ne vais pas vous faire un cours de chimie.

Pour faire bref, disons que depuis que j'ai mis à jour vers la 11.10, j'ai perdu le super fond d'écran que j'avais trouvé sur synaptic.
Ce fond d'écran representait le tableau périodique des éléments sous la forme d'un casse-brique.

Si quelqu'un sait où je peux le trouver, ce serait sympa.

Merci et à bientôt,
Alexis

#15 Re : -1 »  [Résolu] Tableau périodique des éléments » Le 18/10/2011, à 11:01

Tabouet
Réponses : 2

Bonjour,

C'est tout à fait ça !

Merci beaucoup.
Alexis

#16 Re : -1 »  Le réseau TOR compromis » Le 13/10/2011, à 11:24

Tabouet
Réponses : 18

Bonjour,

Heureusement, que j'ai cliqué sur les liens de ton message...
Je croyais que les ITespresso étaient des machines à café utilisant windows.

A bientôt,
Alexis

#17 -1 »  Petite calculatrice » Le 12/10/2011, à 19:05

Tabouet
Réponses : 4

Bonjour,

J'ai développé une petite calculatrice avec Gambas.
Elle est un peu simple mais elle a le mérite de fonctionner, sauf la touche 'ANS' et la touche '.' mais j'y travaille.

calculette en gambas

http://boitasite.com/logiciels/calculet … -1_all.deb

Oups... je me suis trompé d'endroit pour mettre mon message,
je voulais le mettre là : http://forum.ubuntu-fr.org/viewforum.php?id=35 hmm

A bientôt,
Alexis

#18 Re : -1 »  Petite calculatrice » Le 13/10/2011, à 17:08

Tabouet
Réponses : 4

Bonjour,

Merci pour tes encouragements.

J'ai ajouter quelques fonctions que je suis en train de tester : M+ , M-, MR et MC

J'attends un peu avant de partager avec vous car il y a encore quelques petits bugs.
Par contre je n'ai pas réussi à faire fonctionner la touche '.'

Pour ce qui est de voir à quoi ressemble une calculatrice de l'intérieur...  Je le déconseille car mon code source ne doit pas être beau à voir.
Je pense que dés le début, je n'ai pas choisi la bonne méthode pour coder ma calculatrice.

A bientôt,
Alexis

#19 Re : -1 »  Petite calculatrice » Le 14/10/2011, à 17:15

Tabouet
Réponses : 4

Je ne sais pas si vous avez testé mais je viens de me rendre compte que dans certains cas,
l'addition ne marche pas sad

Par exemple :
23+65 donne bien 88 comme resultat
mais
123+456 donne un joli syntax error

Je crois que je vais revoir l'algorythme, pourtant elle marchait plutôt bien quand j'ai commencé à la développer (en VB6 avant de passer à Gambas)

#20 -1 »  Touchad reveille toi ! » Le 13/10/2011, à 16:18

Tabouet
Réponses : 1

Bonjour à tous et à toutes,

J'ai pour habitude d'utiliser le touchpad de mon portable (un Acer) il fonctionne tout à fait normalement.
Comme ce portable me sert aussi pour le boulot, j'ai eu envie d'y brancher une souris USB car je travaille plus
vite avec une souris qu'avec un touchpad.

A côté du touchpad, il y a un bouton pour l'activer et le desactiver. Quand j'ai branché la souris j'ai desactivé le
touchpad car j'ai les pouces qui frottent dessus et c'est franchement em****ant. big_smile

Bref...

Le hic c'est que quand je débranche ma souris  et que j'appuie sur le bouton pour réactiver le touchpad, rien ne ce
passe. Le touchpad reste comme mort... sad

Je suis obligé de reboot mon ordinateur pour retrouver mon touchpad.


A bientôt,
Alexis

#21 -1 »  CCleaner ? » Le 12/10/2011, à 14:01

Tabouet
Réponses : 23

Bonjour à tous,

J'aimerai savoir si il y a un équivalent de CCleaner disponible sous Linux.

Je sais que les puristes vont me dire que Linux n'en a pas besoin, mais il doit surement
y avoir des trucs inutiles qui s'accumulent un peu partout au fil du temps ?

Bonne journée à tous,
Alexis

#22 Re : -1 »  CCleaner ? » Le 13/10/2011, à 10:11

Tabouet
Réponses : 23

Bonjour,

Merci pour vos réponses,
Je ne pensais pas que ça lancerai un débat sur Linux et la base de registre...

Bonne journée à tous,
Alexis

#23 Re : -1 »  Ubuntu Desktop et Unity par défaut » Le 15/04/2011, à 10:19

Tabouet
Réponses : 357

Oui oui dans le gestionnaire de mise à jour comme d'habitude, ça ne m'a trop étonné puisque je me souvenais qu'il devait y avoir une nouvelle version au mois d'avril.

#24 Re : -1 »  Ubuntu Desktop et Unity par défaut » Le 15/04/2011, à 10:24

Tabouet
Réponses : 357
abelthorne a écrit :
Tabouet a écrit :

Oui oui dans le gestionnaire de mise à jour comme d'habitude, ça ne m'a trop étonné puisque je me souvenais qu'il devait y avoir une nouvelle version au mois d'avril.

C'est vraiment bizarre. Peut-être un bug dans une mise à jour du gestionnaire de mises à jour, qui aurait été corrigé depuis (mais je ne me souviens pas en avoir vu passer). En tout cas, quand je le lance, il ne me dit pas qu'une nouvelle version est disponible.
Tu as vérifié ses paramètres (le réglage qui indique pour quelles versions il doit prévenir d'une disponibilité) ? Tu n'as pas fait une modif manuelle quelque part dans le passé pour forcer la mise à jour vers une beta d'une version précédente ?

Peut-être... je me souviens plus...

Mais bon, y'a pas mort d'homme ce sera mis à jour dans quelques semaines et l'affaire sera réglée.