Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  créer raccourcis clavier pour lancer une application » Le 25/10/2009, à 17:55

expmux
Réponses : 2

salut la compagnie

je suis Kubuntu KDE4
bizarrement je n'ai rien trouvé sur le sujet, les astuces qu'on donne valent pour gnome. C'est normal car Kubuntu le fait nativement.

Il y a bien sûr config système>Clavier& souris>Raccourcis clavier généraux : on peut définir des raccourcis glavier mais pour un nombre restreint d'applications : amarok, kwin, kopete, etc
Impossible d'ajouter une application dans la combo box (je ne sais pas où se trouve le fichier texte associé...qqn sait il ?)

La solution se trouve dans config système>Clavier& souris>Action d'entrée. Aller sur KMenuEdit et Edition>Nouveau. Définir le raccourcis (onglet déclencher) puis la ligne de commande dans l'onglet action

ca marche !

#1 Re : -1 »  skype impossible de le trouver[resolu] » Le 14/10/2012, à 17:14

expmux
Réponses : 8

clic droit, lien vers une application
dans l'onglet application tu vas sur la ligne "commande" et tu tapes la réponse a la question

which skype

que tu auras tapé dans un terminal

#2 Re : -1 »  [RESOLU]choix imprimante avec commande lpr » Le 14/10/2012, à 16:49

expmux
Réponses : 12

que donne lpstat ?
normalement le nom de l'imprimante apparait dans la liste et tu le reportes derrière le -P de lpr

tchô

#3 -1 »  port 22 bloqué (ssh connexion refused) » Le 14/10/2012, à 16:41

expmux
Réponses : 1

Bonjour la communauté

je n'arrive pas a me connecter à mon serveur en réseau local (connexion refused).
le problème (port 22 connexion refused) est le meme que j'attaque le serveur depuis un client ou depuis le serveur lui même (ssh sur un autre compte par exemple)
je suis sur kubuntu 11.10

j'ai installé sur le server openssh-server
je n'ai pas modifié /etc/ssh/sshd_config donc le port 22 est utilisé par défaut
ssh tourne (service ssh start)
lorsque je fais un nmap 192.168.xx.yy (ip local du serveur) sur mon serveur le port 22 n'apparait pas dans la liste
a priori ce n'est pas un pbl de firewall (j'ai vérifié avec gufw : meme désactivé le port 22 reste "refused")

toute aide est la bienvenue !

#4 Re : -1 »  port 22 bloqué (ssh connexion refused) » Le 14/10/2012, à 18:15

expmux
Réponses : 1

hyper intéressant ce qui m'arrive :

j'utilise mon tél portable comme carte wifi (relié au serveur par usb).

au niveau de ma box l'adresse du serveur est 192.168.xx.xx
au niveau du serveur (relié au tél portable) l'ip local est  192.168.yy.yy

lorsque je fais (depuis le serveur) nmap sur 192.168.xx.xx le port 22 n'est pas ouvert
lorsque je fais (depuis le serveur) nmap sur 192.168.yy.yy le port 22 est ouvert

de fait, depuis le serveur j'arrive a faire un ssh sur 192.168.yy.yy (et pas sur 192.168.xx.xx)
donc tout semble fonctionner sauf que...
depuis l'exterieur (sur un client de mon réseau local) :
ping 192.168.xx.xx fonctionne et ping 192.168.yy.yy ne fonctionne pas

donc il faudrait que je redirige automatiquement 192.168.xx.xx vers 192.168.yy.y, non ? C'est avec NAT ? quelqu'un sait faire ?

Merci d'avance

#5 Re : -1 »  KBluetooth : problème » Le 14/04/2012, à 08:26

expmux
Réponses : 10

misère,

kbluetooth reste grisé
je tourne sur une lucid 10.4
a la console j'obtiens (rien d'alarmant) :

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kbluetooth(2929) KBlueTray::initMenu: Enabling obex server
kbluetooth(2929)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/solid_bluez.so" does not offer a qt_plugin_instance function.
kbluetooth(2929) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded:  "BlueZ"
kbluetooth(2929) Solid::Control::BluetoothManager::buildDeviceList: UBI List  ()
kbluetooth(2929) KBlueTray::offlineMode: offline Mode

bref je n'arrive pas a entrer dans le menu configuration

#6 -1 »  mauvais comportement (mappage) du clavier » Le 12/02/2011, à 16:56

expmux
Réponses : 15

Bonjour la communauté et merci d'avance !

il m'arrive un truc de fou, c'est arrivé je ne sais comment, du jour au lendemain !

mon clavier ne répond pas correctement. j'ai un eeePC (asus 901) qui tourne sous eeebuntu (équivalent à netbook remix). Via la touche Fn, je peux normalement activer un clavier numérique : Fn+u donne 4, Fn+i donne 5, etc.

Mais ce n'est plus ce que j'obtiens maintenant :
- quand j'appuie sur la touche u ou ctr+u ou Fn+u : mon curseur se décale sur la gauche !
- quand j'appuie sur shift_gauche+u, j'ai le chiffre 4 qui apparait (la touche shift_droit ne fonctionne pas)

même comprtement pour toutes les touches auxquelles un caractère Fn est associé (par exemple à la touche "flêche de droite" est associé avec Fn+"fléche de droite" à la touche "fin/end" et quand je tape sur la flèche de droite j'obtiens le même resultat que si j'avais tapé sur la touche "fin/end" sur un clavier normal.

Non le "Num lock" n'est pas bloqué !

j'ai fait un test avec xev et quand je tape sur la touche u j'obtiens

...keycode 83 ... KP_Left

au lieu d'avoir normalement

...keycode 30 ... u

je suis allé dans préférence>clavier, j'ai bien un clavier 104 touche, dans 'layout options" il n'y a rien de coché (c'est peut-être là le pbl ?). Pour info setxkbmap -print donne :

xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(azerty)"    };
    xkb_types     { include "complete"    };
    xkb_compat    { include "complete"    };
    xkb_symbols   { include "pc+fr(latin9_nodeadkeys)+inet(evdev)"    };
    xkb_geometry  { include "pc(pc104)"    };

dans /etc/default/console-setup

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.
XKBMODEL=""
XKBLAYOUT="fr"
XKBVARIANT="latin9_nodeadkeys"
XKBOPTIONS=""

NB : Lorsque je branche un clavier usb, il se comporte correctement

#7 Re : -1 »  mauvais comportement (mappage) du clavier » Le 13/02/2011, à 12:43

expmux
Réponses : 15
rogue-spectre a écrit :
   setxkbmap fr bepo

Ca modifie bien les touches (le a devient un b, etc) mais j'ai toujours le problème sur les touches associées à une fonction Fn : la touche u associé au caractère 4 (Fn+u) me donne toujours le comportement d'une flèche droite (c'est ce qui est associé normalement à la touche 4 d'un clavier numérique lorsque la touche verr num n'est pas activée).

Je n'arrive pas à retablir un comportement normal. J'ai fait un test à partir d'une live usb avec network edition (10.4) : pas mieux.

#8 Re : -1 »  mauvais comportement (mappage) du clavier » Le 15/02/2011, à 23:38

expmux
Réponses : 15

je le remonte sur la pile

svp...je craque !

#9 Re : -1 »  mauvais comportement (mappage) du clavier » Le 04/11/2011, à 22:28

expmux
Réponses : 15

Bonjour,

je suis passé sur ubuntu 10.10 (netbook) sur mon eeepc .
le probleme ne s'est pas résolu pour autant

j'ai ajouté apci_osi=Linux à la ligne de commande /etc/defaut/grub (merci le forum)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

et resolu le pbl des touches décrit au #1

Maintenant nouveau pbl : la touche ctrl ne répond plus càd que même avec xev je n'ai aucune réponse.

pour info xmodmap

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x69)
mod1        Alt_L (0x40),  Meta_L (0xcd)
mod2        Num_Lock (0x4d)
mod3      
mod4        Super_L (0x85),  Super_R (0x86),  Super_L (0xce),  Hyper_L (0xcf)
mod5        ISO_Level3_Shift (0x5c),  Mode_switch (0xcb)

#10 Re : -1 »  mauvais comportement (mappage) du clavier » Le 12/11/2011, à 11:51

expmux
Réponses : 15

bon je suis allé un peu vite dans ma conclusion
acpi_os=Linux n'apporte rien

par contre j'ai remarqué que :
la combinaison ctrl+shift+1-des-4-fléches (appartion d'une lettre sous la console) permet de retrouver un clavier normal [edit : pas toujours]
la succession rapide d'une touche où il n'y a de bleu (lié à Fn) avec une touche qui en a régénère un clavier pourri

une idée ??

#11 Re : -1 »  mauvais comportement (mappage) du clavier » Le 12/11/2011, à 12:02

expmux
Réponses : 15

j'ai l'impression que sous la console
shift+alt+n puis flèche droite permet de retouver un clavier normal (qui repasse en clavier anormal dès qu'on tape trop vite sur une touche "bleue")

PS : toujours pas de touche ctrl (pas de reponse avec xev!)
si un gourou passe dans le coin...

#12 Re : -1 »  mauvais comportement (mappage) du clavier » Le 12/11/2011, à 17:55

expmux
Réponses : 15

Merci pour cette bonne idée... mais malheusement je n'ai vu aucun changement...

en tapant sur u puis j rapidement (2 touches bleues) je bascule vers le bon mappage du clavier (mais pas systématiquement, je pense qu'il y a une histoire de tempo)

PS : je ne pense pas a un pbl matériel car quand j'active "montrer la position de la souris lorsque la touche ctrl est enfoncée" j'avais (plus maintenant) un petit cercle qui se formait autour de ma souris, alors que xev restait muet

#13 Re : -1 »  mauvais comportement (mappage) du clavier » Le 13/11/2011, à 16:45

expmux
Réponses : 15

il faut dire que je rencontre mon problème dès le démarrage (les flèches ne se comportent pas correctement pour faire un choix sous grub)

j'ai déjà réinstallé le bios, la même version que celle que j'avais car asus n'en a pas sorti de plus récente. Pas de modifications.

je pensais m'en sortir avec un bon "mappage" du clavier vu que toutes les touches fonctionnent (sauf ctr) ; mon problème est que le keycode ne correspond pas à quoi je m'attends (exemple touche u donne KP_Left)

je crois encore a une combinaison de touche qui permettrait de passer d'un type de clavier à un autre, un peu comme ce post : http://forum.ubuntu-fr.org/viewtopic.php?id=428217&p=1 (post #16)

#14 Re : -1 »  mauvais comportement (mappage) du clavier » Le 14/11/2011, à 23:38

expmux
Réponses : 15

hum, je dois admettre que tu as raison...
tout se passe comme si :
- la touche ctr est HS
- la touche Fn est coincée aléatoirement
et mes combinaisons clavier qui permettaient (aléatoirement) de décoincer la situation ne sont pas reproductibles !

sachant ca, je suis en train de créer mon propre mappage pour avoir un clavier a peu près fonctionnel avec 2 touches (capitales) en moins

PS : j'ai bien essayé de démonter mon clavier mais n'y suis pas (totalement) parvenu. je vais réessayer et poster si résultats probants

#15 Re : -1 »  Problème avec Gparted : impossible de démonter !! [Résolu] » Le 04/11/2011, à 23:08

expmux
Réponses : 16

je pense que ce n'est pas utile d'utiliser un live car ton DD est déjà formaté (il n'est pas utilisé par l'OS)

j'ai l'impression qu'il n'est simplement pas monté

sudo fdisk -l

pour le reconnaitre puis creer un repertoire par ex dans

/media/DDexterne

puis monte ton disque

sudo mount /dev/sdxxx1 /media/DDexterne

xxx est la lettre qui correspond a ton DD externe

#16 Re : -1 »  [Résolu] Début dans bash. problème d'apostrophe et d'antislash » Le 12/02/2011, à 23:18

expmux
Réponses : 6

c'est quoi cette double cote avant 'message=' ? tu veux faire quoi au juste ?

message="Bonjour tout le monde. C'est moi!"
echo $message

la différence avec ' c'est qu'avec " le shell interpréte les variables
par ex echo '$message' affichera $message

EDIT : c'est vrai que ca ne marche pas a cause du point d'exclamation
ma solution (si il y en a d'autres je suis preneur !

aze='!'
message="Bonjour tout le monde. C'est moi$aze"
echo $message

#17 Re : -1 »  [Résolu] Début dans bash. problème d'apostrophe et d'antislash » Le 13/02/2011, à 15:22

expmux
Réponses : 6

je pense que c'est parce que " est un caractère qui sert aux regexp alors que ' ne l'ai pas. Du coup \' n'a pas de sens, ni \! . Mais comme ! est une instruction du shell, il l'interprète...sauf si tu le mets entre apostrophes.

message='Salut !' fonctionne
message='C'est moi' ne fonctionne pas et a part mettre des guillemets je ne sais pas comment faire pour remplacer le deuxième apostrophe (mais ca doit forcément exister)
message="c'est moi !" ne fonctionne pas a cause du ! qui est interprété. La solution que je t'ai proposée fonctionne (post #2)

#18 Re : -1 »  Démarrage aléatoire » Le 12/02/2011, à 23:40

expmux
Réponses : 3

je crois que si tu appuies sur la touche echap tu vois les étapes au fur et a mesure.
il se peut qu'il bloque sur une (par exemple la carte wifi...)

#19 -1 »  tutorial rsync et ACL » Le 25/12/2010, à 16:19

expmux
Réponses : 4

allez, je me lance, ce tuto servira peut être à qqn cool

Le but de la manip : faire de la synchroniqation entre 2 répertoires (par exemple une clé USB et un DD) tout en préservant les ACL (de destination)

J'ai été obligé de mettre en place les ACL uniquement pour pouvoir modifier localement l'umask.
Pour moi les ACL ont servi à mettre en place un dossier partagé par plusieurs utilisateurs : chacun peut modifier le fichier de l'autre

Donc je créé un rapertoire "racine" et modifie le group : sudo chown n'importequelutilisateur:partage ou partage est un groupe auquel appartient tous mes utilisateurs (utiliser la commande sudo kuser pour ajouter le groupe "partage" et l'associer a des utilisateurs).
"racine" doit avoir rwx pour le propriétaire+le groupe, 0 (car je suis parano) pour les autres donc :

chmod 770 racine 

je veux que, par défaut, le fichier créé dans le répertoire racine ait le groupe "partage" et non pas le groupe de l'"utilisateur" donc je vais imposer un GUID à mon répertoire :

chmod g+s racine

on peut le vérifier avec :

cd racine
touch toto
ls -l

je veux que par défaut, le fichier créé dans le répertoire racine ait les options rwx pour propriétaire:groupe et 0 pour les autres et par ailleurs je ne veux pas modifier la variable UMASK de mon shell (positionnée à 002) donc je suis obligé d'introduire les ACL sur mon répertoire racine :

setfacl -m d:g:partage:rwx racine

voilà mon répertoire de partage est fonctionnel. Maintenant je veux faire une synchronisation avec ma clè usb.

le problème c'est que la commande de base :

rsync -rtv rpertoire-de-ma-clé-usb répertoire-de-mon-DD

ne préserve pas les ACL (elle utilise l'UMASK du shell)
pour y remédier, il suffit d'utiliser l'option --chmod=ugo=rwX de rsync (contrairement a ce qu'on peut penser, elle n'impose pas rwx partout ; c'est en quelque sorte un "non"-filtre)
donc

rsync -rtv  --chmod=ugo=rwX repertoire-de-ma-clé-usb répertoire-de-mon-DD

et le tour est joué

voilà pourquoi je n'utilise plus windows ! Linux c'est ~simple et puissant !

Merci à http://forum.ubuntu-fr.org d'exister.

#20 Re : -1 »  tutorial rsync et ACL » Le 08/01/2011, à 00:51

expmux
Réponses : 4

Content que ce soit utile tongue

#21 Re : -1 »  commande de base » Le 25/12/2010, à 16:57

expmux
Réponses : 6

réponse graphique sous kde :
Configuration du système
Gestion des utilisateurs [en choisir un]>modifier
onglet mot de passe/sécurité

#22 Re : -1 »  Lancement automatique de commandes côté client » Le 25/12/2010, à 16:50

expmux
Réponses : 1

ai je bien compris : tu as un serveur windows qui doit envoyer régulièrement des commande ssh vers 3 serveurs linux ? Si c'est ca c'est un pbl windows non ?

#23 Re : -1 »  Convertir un divx en xvid » Le 22/11/2010, à 22:43

expmux
Réponses : 4

En une ligne de code et ça se fait en 1/10 de sec :

cfourcc -u DIVX nom-fichier.avi; cfourcc -d DIVX nom-fichier.avi

j'ai essayé avec l'option -ud, ça ne marche pas.

u = codec utilisé
d = description du codec

De rien

#24 Re : -1 »  [Résolu] Problème après tentative d'installation nvidia 195 » Le 09/01/2010, à 03:09

expmux
Réponses : 20

Bonjour

merci a ceux qui ont trouvé...moi je cherche encore wink

Comment avez vous su qu'il s'agissait de ces liens là et qu'il n'y en a pas d'autres ?