Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

nombre réponses : 14

#0 -1 »  [RESOLU] extraire une chaine de caractere d'une autre » Le 09/02/2010, à 03:15

ceddes
Réponses : 3

Bonjour,

J'ai besoin d'extraire la fin d'une chaine de caractere (d'1 chemin complet d'1 fichier pour avoir le seul nom de fichier).
J'ai un chemin complet, du genre :
/tmp/rep1/fic1
et après traitement je voudrais retrouver fic1.

Les contraintes sont : que je ne connais jamais d'avance le chemin, puisqu'il sera traité par un script et que l'extraction se fera quand ça marchera dans le même script.

J'ai entendu parler de sed, mais je crois qu'il traite le contenu du fichier.
Avez-vu une commande qui va bien ?
Merci

#2 -1 »  paquets python2.4-gtk2 python2.4-glade2 introuvable sous synaptic » Le 01/05/2009, à 23:10

ceddes
Réponses : 5

Bonjour,
Après de années de Microsoft Windows, je passe à Ubuntu 9-04. J'ai déjà eu quelques difficultés et voici l'une d'entre elles, que je n'arrive pas à résoudre.

Je souhaite installer les 2 paquets python2.4-gtk2 et python2.4-glade2.
Dans Synaptic, je ne trouve que python-gtk2 et python-glade2 en versions 2.14.1 (déjà installés)à ce jour 01/05/2009.
Mes dépôts de mise à jour sont les deux par défaut après installation.

Ces deux paquets me sont demander lors de l'installation de Easycam 2.
J'en ai besoin pour voir si cette application trouve le driver de ma Webcam : NGS SpinCam

Si vous pouvez m'éclairer pour trouver une solution à mon problème, merci d'avance.

#3 Re : -1 »  paquets python2.4-gtk2 python2.4-glade2 introuvable sous synaptic » Le 02/05/2009, à 02:08

ceddes
Réponses : 5

Merci pour ta réponse,

Je viens donc d'essayer ta solution, j'ai installé la paquet chesse version 1:2.26.1
L'application me renvoie le message suivant : Aucune caméra détéctée !
Et j'ai en effet aucune image de la webcam qui s'affiche, mais juste une mire multicolore...

Celle-ci est bien branché, j'ai également lancé la commande : lsusb
La commande comporte cette ligne en plus lorsque je branche ma webcam : Bus 001 Device 007: ID 176b:a169

Avec la commande dmesg, j'ai ces lignes en plus qui s'inscrivent :
    [28185.832096] usb 1-6: new high speed USB device using ehci_hcd and address 14
    [28186.068080] usb 1-6: configuration #1 chosen from 1 choice

Avec la commande : gstreamer-properties
lorsque je teste le greffon d'entrée vidéo, j'ai les messages d'erreurs suivant :
gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': Impossible d'identifier le périphérique « /dev/video0 ». [v4l2_calls.c(463): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src4:
system error: Aucun fichier ou dossier de ce type]
gstreamer-properties-Message: Error running pipeline 'Video for Linux (v4l)': Le périphérique « /dev/video0 » n'existe pas. [v4l_calls.c(168): gst_v4l_open (): /GstPipeline:pipeline1/GstV4lSrc:v4lsrc2]

Le fichier /dev/video0 n'existe pas. J'ai créé un dossier /dev/video0 et j'ai cette erreur :
gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': Ceci n'est pas un périphérique « /dev/video0 ». [v4l2_calls.c(470): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src3:
system error: Ressource temporairement non disponible]

Je n'ai pas essayé de créer un fichier pipe, je ne sais pas quoi mettre comme paramètre.

Je pense donc que le système détecte bien le périphérique sur le port usb et que je dois d'abord trouver le pilote de cette webcam pour la faire fonctionner, d'où mon espoir avec Easycam 2.

Peut-être avez-vous une autre piste ?


#4 Re : -1 »  paquets python2.4-gtk2 python2.4-glade2 introuvable sous synaptic » Le 14/05/2009, à 05:31

ceddes
Réponses : 5

merci pour ta recherche, en effet, c'est bien a priori le seul projet qui ait été développé pour linux concernant les pilote ALI m560x (m5603 me concernant). Le projet permet après une compilation, d'installer les pilotes m5602 facilement, par contre pour le pilote m5603, la partie n'est pas gagné. Avec le projet est joint un fichier d'aide à l'installation dans le dossier m5603c-gspca, mais le contenu est pour le moment un peu technique pour moi. Je tiens pourtant le bon bout, mais il me manque un peu d'aide. Si vous avez déjà installé ce pilote, merci de m'apporter votre assistance, mais je continue à chercher en parallèle.

#5 Re : -1 »  paquets python2.4-gtk2 python2.4-glade2 introuvable sous synaptic » Le 02/02/2010, à 04:00

ceddes
Réponses : 5

Salut,
Depuis le temps, rien de neuf à ce sujet.

#6 -1 »  [RESOLU] recherche fichiers "de la semaine en cours" avec find... » Le 27/01/2010, à 22:19

ceddes
Réponses : 7

Bonjour,

Je souhaite effectuer une recherche de fichiers qui ont étaient créés ou modifiés lors de la semaine courante.
Exemple : nous sommes jeudi de la semaine 4 et je souhaite donc trouver les fichiers créés ou modifiés du lundi, mardi, mercredi et jeudi de la semaine en question.

Je voudrai que cette commande s'appuie sur la date du jour où elle est exécutée, ainsi je pourrai l'utiliser dans un cron associé avec d'autres commandes.

Avec la commande ls, j'ai l'impression d'être plus limité concernant les filtres sur les dates, alors que find semble disposer de plus fonctionnalité concernant la recherche par date.
Quoiqu'il en soit, je suis bloqué et je ne sais pas avec quelle(s) autre(s) commande(s) associer "ls" ou "find" pour arriver à mes fins.

Je suis preneur d'une commande pratique. Merci d'avance pour le coup de pouce. smile

#7 Re : -1 »  [RESOLU] recherche fichiers "de la semaine en cours" avec find... » Le 28/01/2010, à 10:09

ceddes
Réponses : 7

Merci pour vos réponses,
La piste de Ferod me plait, le truc est de trouver la valeur de X le nombre de jours et avec la commande suivante je pense avoir la réponse :

date + %w

Il ne reste plus qu'à l'intégrer à find

find /Lien/vers/ton/repertoire -daystart -mtime -$(date +%w)

par contre je ne suis pas certain de la façon dont je doit la passer en paramètre, ça se semble fonctionner mais je ne sais pas si ça marche réellement à chaque fois.

Encore un peu d'aide svp pour me confirmer que ça marche pour vous et que c'est bon.

#8 Re : -1 »  [RESOLU] recherche fichiers "de la semaine en cours" avec find... » Le 02/02/2010, à 03:57

ceddes
Réponses : 7

Personne pour confirmer, c'est pas grave.
Pour ceux qui voudraient s'en inspirer, ça donne à priori le résultat voulu.

#9 -1 »  envoi plusieurs pieces jointes avec commande mail » Le 29/01/2010, à 01:41

ceddes
Réponses : 5

Re bonjour à tous,

Je souhaite envoyer 1 mail avec plusieurs pièces jointes.
J'utilise la commande suivante pour en envoyer avec 1 PJ :

echo “le message du mail.” | mail -s “l'objet du mail” adresse.mail@du.destinataire < /chemin/de/la/piece.jointe

Comment faire avec la commande mail pour joindre plusieurs pièces jointes, même s'il faut la combiner avec d'autres commandes.
Un point important à prendre en compte, permettre l'envoi de PJ volumineuses (en scindant le mail par tranche de X Mo, où X = 2 ou 3 ou 4...

Merci d'avance pour votre aide.

#10 Re : -1 »  envoi plusieurs pieces jointes avec commande mail » Le 29/01/2010, à 19:04

ceddes
Réponses : 5

Salut,
En fait, je souhaite envoyer des fichiers de logs d'un serveur distant dans un mail, par un cron.
J'ai installé la version 1.5.20 de Mutt pour essayer, mais je comprend qu'il faut préciser le serveur smtp quelque part. La doc semble très complète, c'est très bien, mais je ne trouve pas comment renseigner le serveur smtp.
Quelqu'un a-t-il la réponse, quelle est l'option ou quel fichier de conf modifier.

Merci.

#11 Re : -1 »  envoi plusieurs pieces jointes avec commande mail » Le 29/01/2010, à 23:10

ceddes
Réponses : 5

Après quelques tests, j'ai aussi la commande mailx sur ma machine.
Du coup j'ai desinstallé mutt au profit de mailx.
avec la commande suivante :

echo "le message du mail" | mailx -s "objet du mail" -a "/le/chemin/du/fichier1 -a /le/chemin/du/fichier2 adresse.mail@du.destinataire

je peux envoyer maintenant plusieurs fichiers, mais la taille du mail est trop importante pour le serveur mail, je dois donc le scinder en tranche de 4Mo.

Maintenant mon souci est de savoir comment couper un mail en plusieurs. Il bien sûr hors de question de toucher aux PJ, mais bien au mail.

Encore un petit effort, plus que ça et c'est terminé !

#12 Re : -1 »  envoi plusieurs pieces jointes avec commande mail » Le 02/02/2010, à 03:55

ceddes
Réponses : 5

Salut sputnick,

Si je comprend bien, je suis contraint de couper les PJ (via split par exemple) avant de les envoyer.
Je pensais trouver une fonction similaire à celle d'IE (scinder les messages supérieurs à ...), mais ça n'y est pas apparemment, au passage je n'ai pas trouvé non plus cette fonction dans Thunderbird.
Et dans mutt, il n'y a pas non plus cette fonction, je suppose ?

Je vais devoir plutôt créer un script alors :
1) pour lister les fichiers qui correspondent à mes critères de recherches
2) pour les spliter un à un
3) pour les envoyer un à un

Ou peut-être une commande à rallonge qui fait tout ça.
Merci

#13 -1 »  webcam ngs spicam ne fonctionne pas » Le 02/05/2009, à 03:14

ceddes
Réponses : 0

Bonjour,

Je cherche le moyen de faire fonctionner ma webcam usb.
C'est une SpinCam de marque NGS.
Le constructeur à un site http://www.ngslurbe.com.
Je suis sur Ubuntu 9.04, voici mon "uname -a" : Linux computer 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
Je n'ai pas de pilote fourni dans le CD d'install, sauf un pour Microsoft Windows.

Avec la commande lsusb, j'ai cette ligne en plus qui s'inscrit lorsque je la branche :
    Bus 001 Device 013: ID 176b:a169

Avec la commande dmesg, j'ai ces lignes en plus qui s'inscrivent :
    [28185.832096] usb 1-6: new high speed USB device using ehci_hcd and address 14
    [28186.068080] usb 1-6: configuration #1 chosen from 1 choice

Avec la commande : gstreamer-properties
lorsque je teste le greffon d'entrée vidéo, j'ai les messages d'erreurs suivant :
gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': Impossible d'identifier le périphérique « /dev/video0 ». [v4l2_calls.c(463): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src4:
system error: Aucun fichier ou dossier de ce type]

Puisque le fichier pipe /dev/video0 n'existe pas je l'ai créé à la main avec les commandes (vu sur http://doc.ubuntu-fr.org/webcam#video0_not_found) :
sudo mknod /dev/video0 c 81 0
sudo chmod 777 /dev/video0
sudo ln -s /dev/video0 /dev/video

et j'obtiens le message suivant avec gstreamer-properties
gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': Impossible d'ouvrir le périphérique « /dev/video0 » en lecture et écriture. [v4l2_calls.c(477): gst_v4l2_open (): /GstPipeline:pipeline1/GstV4l2Src:v4l2src2:
system error: Aucun périphérique ou adresse]

J'ai aussi ces messages avec un "tail -f /var/log/messages" lorsque je branche la webcam
May  1 16:22:09 computer kernel: [35113.916061] usb 1-6: new high speed USB device using ehci_hcd and address 21
May  1 16:22:09 computer kernel: [35114.152070] usb 1-6: configuration #1 chosen from 1 choice
May  1 16:22:10 computer pulseaudio[3670]: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 8000 Hz.
May  1 16:22:10 computer pulseaudio[3670]: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.
May  1 16:22:10 computer pulseaudio[3670]: alsa-util.c: Cannot find fallback mixer control "Mic" or mixer control is no combination of switch/volume.

J'ai testé avec VLC 0.9.9a et avec Chesse 2.26.0, aucun des 2 ne trouvent de caméra.

J'aimerai essayer de trouver une réponse à ma question avec EasyCam 2, mais lors de l'installation, il me manque les 2 paquets python2.4-gtk2 et python2.4-glade2, qui ne sont apparemment pas disponibles, j'ai les paquets python-gtk2 et python-glade2 en versions 2.14.1 (déjà installés) à ce jour 01/05/2009, mais c'est insuffisant.
Peut-être des paquets encore plus à jour existent ?
J'ai posté mon problème de paquets à http://forum.ubuntu-fr.org/viewtopic.php?pid=2610309

Si quelqu'un peut donc m'éclairer pour trouver une solution à mon problème de webcam, merci d'avance.