Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

nombre réponses : 25

#0 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 10:20

cqfd93
Réponses : 129
jplemoine a écrit :

@cqfd93 :
Donnes tes instructions pour le faire : il ne faut qu'un donneur d'ordre et sur cette discussion, c'est toi... smile
Perso, je serais pour :
- supprimer les proposed (et les backport ?)
- faire un update
--> si pas d'erreur, dist-upgrade et analyse du retour.

Voilà, c'est fait wink
Les backports posent beaucoup moins de problèmes donc je préfère les garder.
Si pas d'erreur après update et upgrade, on fera dist-upgrade et on installera gksu.

#2 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 13:38

cqfd93
Réponses : 129

En parcourant le net, on voit que ce problème avec libsane n'est apparemment pas nouveau et qu'il est difficile de trouver une solution.

Dans ce message http://ubuntuforums.org/archive/index.p … 78792.html, sur la fin; il est suggéré de faire :

sudo apt-get purge ia32-libs ia32-libs-multiarch

et

sudo apt-get purge libsane

et de réinstaller libsane avec synaptic.

Qu'en pensez-vous jplemoine et PPdM ?

(edit : correction de faute dans la 1ère commande)

#3 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 13:51

cqfd93
Réponses : 129
PPdM a écrit :

Ça on l'avait déjà tester avant nettoyage, mais cela ne risque rien de recommencer.

En #18, tu avais dit de tenter :

sudo apt-get remove -f libsane*

Et le retour en #25 se termine par :

Les paquets suivants contiennent des dépendances non satisfaites :
 colord : Dépend: libsane (>= 1.0.11-3) mais ne sera pas installé
 hplip : Dépend: libsane (>= 1.0.11-3) mais ne sera pas installé
         Dépend: libsane-hpaio (= 3.14.3-0ubuntu3.2) mais ne sera pas installé
 ia32-libs-multiarch:i386 : Dépend: libsane:i386 mais ne sera pas installé
 sane-utils : Dépend: libsane mais ne sera pas installé
 simple-scan : Dépend: libsane (>= 1.0.11-3) mais ne sera pas installé
 xsane : Dépend: libsane (>= 1.0.11-3) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).

Je suggère de faire d'abord :

sudo apt-get purge ia32-libs ia32-libs-mutiarch

#4 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 14:16

cqfd93
Réponses : 129

Essaye les 2 commandes du #71.

#5 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 14:32

cqfd93
Réponses : 129

Oops, j'ai copié une commande avec faute de frappe :

sudo apt-get purge ia32-libs ia32-libs-multiarch

#6 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 15:05

cqfd93
Réponses : 129

Là, je dois dire que je sèche :-(

#7 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 15:33

cqfd93
Réponses : 129

Et m*** on tourne en rond, et m*** on tourne en rond, et m*** on tourne en rond !!! :-(

Je viens de trouver ce rapport de bug
Le message #3 donne une longue liste de commande qui peut marcher, sait-on jamais :

sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sudo rm -rf /var/lib/dpkg/updates/*
sudo rm -rf /var/lib/apt/lists/*
sudo mkdir /var/lib/apt/lists/partial
sudo rm /var/cache/apt/*.bin
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update
sudo dpkg --configure -a
sudo apt-get install -f

Attention à bien couper/coller (les sudo rm avec fautes de frappe ou espaces en trop peuvent faire des catastrophes !)

#8 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 15:55

cqfd93
Réponses : 129
jplemoine a écrit :

je ne suis pas sûr... mais essaies à tout hasard :

sudo mv /lib/udev/rules.d/40-libsane.rules /lib/udev/rules.d/40-libsane.rules.000
sudo apt-get -f install

On dirait que tu as tapé dans le mille !

#9 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 15:58

cqfd93
Réponses : 129

Y'a plus qu'à faire update et upgrade (ou dist-upgrade)...

#10 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 16:22

cqfd93
Réponses : 129

Super !!!

Et maintenant, tu peux installer gksu :

sudo apt-get install gksu

Et si tu ne les as pas encore installés, tu peux y ajouter synaptic et gdebi (ça peut dépanner et c'est moins lourd que la logithèque) :

sudo apt-get install synaptic
sudo apt-get install gdebi

#11 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 16:58

cqfd93
Réponses : 129
marybzh22 a écrit :

Est-ce qu'il faut que je fasse la manip en #99 ?

Oui, tu peux y aller. Maintenant, à priori, c'est tout bon.

#12 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 17:07

cqfd93
Réponses : 129
jplemoine a écrit :
sudo apt-get autoremove

Après on peut aussi regarder le nombre de noyaux.

 dpkg -l | grep linux-h
 dpkg -l | grep linux-i

marybzh22 est sous trusty, donc autoremove devrait enlever les noyaux < n-1 ?

#13 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 17:32

cqfd93
Réponses : 129

Ça ne mange pas de pain de vérifier.

#14 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Hier à 18:24

cqfd93
Réponses : 129

Il faut probablement rebooter car là, tu n'es pas avec le plus récent noyau installé.

#15 Re : -1 »  Sens interdit, impossible d'effectuer les mises à jour » Aujourd'hui à 08:42

cqfd93
Réponses : 129

Bonjour,

marybzh22 a écrit :

Même en redémarrant l'ordi, ça ne marche pas. Voici le message d'erreur :

Vous utilisez actuellement le noyau 3.13.0-36
Or, au moins un noyau plus récent ( image-3.13.0 ) a été détecté.
Ce phénomène peut avoir plusieurs causes mais,
par securité, ce script va s'arreter.

Si vous souhaitez réelement supprimer ce (ou ces) noyaux,
lancez kclean en ligne de commande.

C'est bizarre mais je ne sais pas comment le régler.
Fais encore une fois

dpkg -l | grep linux-h
dpkg -l | grep linux-i

juste pour voir...

#16 Re : -1 »  Problème de téléchargement de paquet » Hier à 18:22

cqfd93
Réponses : 28

Bonjour,

Il y a aussi plusieurs lignes comme ça :

Atteint http://archive.canonical.com precise Release 

alors que tu es sous trusty. Il faut donc enlever ces dépôts precise de ton sources.list.

#17 Re : -1 »  Problème de téléchargement de paquet » Hier à 19:10

cqfd93
Réponses : 28
cat /etc/apt/sources.list
ls /etc/apt/sources.list.d

devraient t'éclairer.

#18 Re : -1 »  Problème de téléchargement de paquet » Hier à 20:20

cqfd93
Réponses : 28

Ça me parait bien.

Que donnent ces commandes ?

sudo apt-get update
sudo apt-get upgrade

Normalement, ça devrait être bon...

#19 Re : -1 »  Problème de téléchargement de paquet » Hier à 21:53

cqfd93
Réponses : 28
marcodel a écrit :

@NéoUbuntonien
ton sources.list n'est pas tres propre
tu devrais le nettoyer

Il n'est pas très propre mais il ne contient pas d'erreurs, c'est déjà ça.

C'est bien de le débarrasser des lignes commentées qui ne font que le rendre illisible et de faire des regroupements comme par exemple :

deb http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted
...
deb http://fr.archive.ubuntu.com/ubuntu/ trusty universe
...
deb http://fr.archive.ubuntu.com/ubuntu/ trusty multiverse

en une seule ligne :

deb http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse

#20 Re : -1 »  Installation 14.04, le processus ne se termine jamais » Hier à 23:20

cqfd93
Réponses : 4

Bonsoir,

Est-ce bien la version 14.04 (sortie en avril) ou la version 14.04.1 sortie en août ? J'ai eu un problème semblable avec 14.04 qui a été résolu avec 14.04.1.

De toutes façons, tu peux nous en dire plus sur ton netbook (processeur, ram, carte graphique) et la version que tu essaye d'installer : Ubuntu, Xubuntu,...

Tu as bien vérifié la somme md5 de l'iso utilisée pour faire ta clé ?

#21 Re : -1 »  Installation 14.04, le processus ne se termine jamais » Hier à 23:45

cqfd93
Réponses : 4
Bougron a écrit :

Je n'ai jamais entendu parlé de la question "qui êtes-vous".
Je ne sais pas d'où tu as récupéré la version ubuntu.  Repars à la base en téléchargeant à partir d'ici. http://releases.ubuntu.com/

Si, il y a bien cette question en titre de la page de l'installateur où on crée le premier utilisateur avec le nom de l'utilisateur, le nom de la machine et le mot de passe.
Voir page 17 du manuel Premiers pas avec Ubuntu 14.04.

#22 Re : -1 »  J'ai trébuché dans un tuto T_T » Hier à 17:13

cqfd93
Réponses : 10

Bonjour,
La réponse à ta question est dans ce message :

E: dpkg a été interrompu. Il est nécessaire d'utiliser « sudo dpkg --configure -a » pour corriger le problème.

Commence donc par exécuter cette commande (et donne le retour) :

sudo dpkg --configure -a

#23 Re : -1 »  J'ai trébuché dans un tuto T_T » Hier à 17:30

cqfd93
Réponses : 10

On ne peut pas savoir si ça a marché ou pas, donne quand même le retour.

#24 Re : -1 »  J'ai trébuché dans un tuto T_T » Hier à 20:58

cqfd93
Réponses : 10

Refais cette commande :

sudo apt-get install linux-firmware-nonfree

et si tu n'arrives pas à copier le contenu du terminal, fais une copie d'écran que tu retailles pour qu'elle ne soit pas trop monstrueuse.