Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  [Resolu] Java Oracle problème de certificat » Le 03/02/2014, à 16:21

dubis22
Réponses : 11

Bonjour,

J'ai besoin d'installé la version sad propriétaire sad de java pour me connecter sur des interfaces HTML de serveurs Oracle. Grâce à la page de documentation JAVA , j'ai suivit la procédure de l'installation avec le dépôt PPA. L'installation s'est bien faite,

java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

Au niveau du plugin cela à l'aire correcte aussi "about:plugins" :

Java(TM) Plug-in 11.0.2

    Fichier : libnpjp2.so
    Chemin : /usr/lib/jvm/java-7-oracle/jre/lib/amd64/libnpjp2.so
    Version : 11.0.2
    État : Activé
    Next Generation Java Plug-in 11.0.2 for Mozilla browsers

Malheureusement quand je fais le test sur le site :JAVA.COM
J'ai l'erreur suivante :

Plug-in Java 10.51.2.13
Utilisation de la version JRE 1.7.0_51-b13 Java HotSpot(TM) 64-Bit Server VM
Répertoire de base de l'utilisateur = /home/user

J'ai essayé le paquet oracle-java8-installer, avec les même vérification. LE  test est en erreur mais un peut plus verbeux :

java.lang.NullPointerException
	at sun.plugin2.applet.JNLP2Manager.initialize(Unknown Source)
	at sun.plugin2.main.client.PluginMain.initManager(Unknown Source)
	at sun.plugin2.main.client.PluginMain.access$200(Unknown Source)
	at sun.plugin2.main.client.PluginMain$2.run(Unknown Source)
	at java.lang.Thread.run(Thread.java:744)
Error while initializing manager: java.lang.NullPointerException, bail out

Dans mes investigations j'ai désinstallé des paquets IceTea et autre paquet distribué par défaut.

sudo aptitude search java | grep "^i"
i A java-common                     - base pour tous les paquets Java           
i A libjavascriptcoregtk-3.0-0      - bibliothèque du moteur Javascript pour GTK
i   oracle-java7-installer          - Oracle Java(TM) Development Kit (JDK) 7   
i   oracle-java8-installer          - Oracle Java(TM) Development Kit (JDK) 8   
i   plasma-scriptengine-javascript  - JavaScript script engine for Plasma 

Merci de m'aider à installer java

#1 Re : -1 »  [Resolu] Java Oracle problème de certificat » Le 10/02/2014, à 12:14

dubis22
Réponses : 11

Merci de la réponse je commençais un peut à désespérer smile

Voici 2 snaptshot que j'obtiens quand je tapes la commande jconsole. LE premier est peut être intéressant car il a un warning ssl. Je reste donc dans le sujet :
nd8nrt.jpg
Ensuite si je clique sur insecure j'obtiens cette interface.
2yv41le.jpg

Cependant je pense pour régler les problèmes de sécurité je devrais passer cette commande :

/usr/lib/jvm/java-7-oracle/bin/ControlPanel 

Qui donne cette interface :
30aav78.png

Bref problème non résolu merci de l'aide.

#2 Re : -1 »  [Resolu] Java Oracle problème de certificat » Le 10/02/2014, à 22:34

dubis22
Réponses : 11

Salut Titouan,

Oui cela marche sur http://javatester.org/ et sur ce site : http://www.cis.upenn.edu/~matuszek/Gene … Tests.html

Mais pas sur la page officielle de java :
http://www.java.com/fr/download/installed.jsp

Je vais aller essayé sur les interfaces HTML  des serveurs ORACLE, mais je suis pessimiste....
Je te tiens au courant.

#3 Re : -1 »  [Resolu] Java Oracle problème de certificat » Le 12/02/2014, à 21:02

dubis22
Réponses : 11

Cela fonctionne sur un serveur sur deux en utilisant le navigateur rekonq. mad

J'ai fait des essais et cela est très difficile a d’écrire mais en gros pour prendre la main ou partager le disque dur je dois lancer  une application jar. Normalement cette application est la même d'un serveur à un autre. Cela fonctionne donc sur un serveur mais pas sur l'autre. J'ai l'erreur de certificat suivante :
29gn6hh.png

Je ne comprend plus

#4 Re : -1 »  [Resolu] Java Oracle problème de certificat » Le 13/02/2014, à 11:45

dubis22
Réponses : 11

J'ai modifié le fichier /etc/hosts pour faire correspondre l'adresse IP 10.0.1.50 et le nom sun-ilom mais cela ne fonctionne pas.
Est ce quelqu'un peut m'aider à comprendre ceci :
2ue1edh.png
D'avance merci

#5 Re : -1 »  [Resolu] Java Oracle problème de certificat » Le 18/02/2014, à 12:59

dubis22
Réponses : 11

Toujours pareil .........

#6 Re : -1 »  [Resolu] Java Oracle problème de certificat » Le 21/02/2014, à 12:43

dubis22
Réponses : 11

Apparemment avec la version jdk1.6.0_45, cela fonctionne sur autre machine qui n'est pas un portable mais un serveur debian et le navigateur Iceweasel. Auparavant, j'ai fais la mise à jour  java 1.7.0_51 et effectivement cela ne fonctionnait plus.

J'ai donc modifié l’environnement java avec upadte-aleternatives mais reste un dernier problème avec le plugin. J'ai bien modifié celui de firefox avec cette commande :

update-alternatives --install "/usr/lib/mozilla/plugins/libjavaplugin.so " "mozilla-javaplugin.so" "/usr/lib/jvm/jdk1.6.0_45/jre/lib/amd64/libnpjp2.so" 1

mais j'ai toujours un problème d'affichage du site.
Par contre le navigateur Rekonq démarre toujours la version 7 de java.

Comment faire pour que rekonq démarre la version6 de java installée? Ou puis je trouver ce fameux plugin java de Rekonq?

D'avance merci.

#7 Re : -1 »  [Resolu] Java Oracle problème de certificat » Le 24/02/2014, à 20:17

dubis22
Réponses : 11
sudo apt-get remove oracle-java7-installer
sudo apt-get install oracle-java6-installer

C'est la solution... En effet, la gestion drastique des certificats a commencé vers la version 7 donc en installant la version on est sur de ne pas être gêner par les certificats.
merci pour les aides

#8 Re : -1 »  Plus de son, claquement régulier. » Le 11/12/2013, à 16:02

dubis22
Réponses : 16

Salut,

Dans un terminal tapes la commande alsamixer

#9 Re : -1 »  kde et le son via bluetooh, ça marche mais..... » Le 11/12/2013, à 16:07

dubis22
Réponses : 2

Salut Jajax,

Si tu as un smartphone as tu déjà partagé la fonction son avec ???
En espérant aider

#10 -1 »  [Resolu] Fail2ban comment le rendre plus efficace » Le 19/11/2013, à 20:07

dubis22
Réponses : 5

Bonjour,

J'ai installé fail2ban qui fonctionne avec un bannissement au bout de trois mauvais mot de passe sur l’accès ssh.
Cela fonctionne si l'adresse et l'utilisateur sont 3 fois les même. Malheureusement, j'ai un petit malin qui m'attaque en force brute mais il change d'utilisateur à chaque fois et impossible de le bloquer. J'ai reproduit ce qu'il essayait de faire en me connectant sur avec mon téléphone  en ssh et effectivement si je change à chaque tentative de connexion l’utilisateur je ne suis pas banni.
Comment renforcer la règle du filtre ssh ? Documentation ?

Quelqu'un peut me dire la différence entre le jail et l'action bannissement. Si j'ajoute mon petit malin comme ceci :

#sudo fail2ban-client set ssh banip 89.174.116.126
89.174.116.126

Il  n’apparaît nulle part :

#sudo fail2ban-client status ssh
Status for the jail: ssh
|- filter
|  |- File list:        /var/log/auth.log 
|  |- Currently failed: 2
|  `- Total failed:     14
`- action
   |- Currently banned: 1
   |  `- IP list:       176.42.4.141 
   `- Total banned:     1

#sudo iptables -L fail2ban-ssh
Chain fail2ban-ssh (1 references)
target     prot opt source               destination         
DROP       all  --  asy141.asy4.tellcom.com.tr  anywhere            
RETURN     all  --  anywhere             anywhere    

Merci de votre aide.

#11 Re : -1 »  [Resolu] Fail2ban comment le rendre plus efficace » Le 19/11/2013, à 21:10

dubis22
Réponses : 5

Je pense qu'en fait je me suis peut être mal exprimer. l'adresse est la même seul le login change.

exemple de ce que j'ai essayé sans me faire bannir:

ssh user@serveur.com
user@serveur.com's password: 
ssh toto@serveur.com
toto@serveur.com's password: 
ssh coco@serveur.com
coco@serveur.com's password: 
etc ... 

Par contre si je fais

ssh user@serveur.com
user@serveur.com's password:
wrong password
user@serveur.com's password:
wrong password
user@serveur.com's password:

Je suis banni

#12 Re : -1 »  [Resolu] Fail2ban comment le rendre plus efficace » Le 20/11/2013, à 10:15

dubis22
Réponses : 5

Bon j'ai désinstallé puis réinstallé fail2ban cela à l'air de fonctionner....

#13 -1 »  [Resolu] Recherche de Nepomuk dans Kmail ne fonctionne pas » Le 18/11/2013, à 16:13

dubis22
Réponses : 9

Bonjour,

Mes recherches dans Kmail donne une réponse vide.
Pourtant j'ai bien coché "Indexation du courrier électroniques", dans la configuration du système Nepomuk.
Quand je fais un clique droits sur mes répertoires locaux , puis je choisi "propriété du dossier", puis la tabulation Maintenance, je vois une date de la dernière indexation qui n'est pas toujours à jours.

Que pourrai je vérifier?
Merci de votre aide
Cordialement.

#14 Re : -1 »  [Resolu] Recherche de Nepomuk dans Kmail ne fonctionne pas » Le 19/11/2013, à 10:08

dubis22
Réponses : 9

Salut Jajax,

Je suis en KDE 4.11.2. J'ai pourtant installé les kubuntu backports avec la commande suivante :

sudo add-apt-repository ppa:kubuntu-ppa/backports

Je n'ai pas de mise à jour sad
Comment faire ?

#15 Re : -1 »  [Resolu] Recherche de Nepomuk dans Kmail ne fonctionne pas » Le 20/11/2013, à 10:17

dubis22
Réponses : 9

Je viens de recevoir la notification de la mise à jour du paquet :
libnepomukdatamanagement4 - Basic Nepomuk data manipulation interface

sudo apt-get install libnepomukdatamanagement4

Cela ne fonctionne toujours pas et je n'ai pas de notification pour la mise à jour de KDE

#16 Re : -1 »  [Resolu] Recherche de Nepomuk dans Kmail ne fonctionne pas » Le 20/11/2013, à 10:41

dubis22
Réponses : 9

L'indexation du courrier électronique  à démarrer pour moi après avoir désactiver et réactiver Nepomuk dans la fenêtre Configuration du Système.
C'est bon la recherche fonctionne pour moi
Je met donc le sujet en resolu

#18 -1 »  [Resolu] Probleme de Micro web cam » Le 04/11/2013, à 16:01

dubis22
Réponses : 3

Bonjour,

Mon système ne détecte pas le micro de ma webcam de mon portable.

La commande suivante me retourne ceci :

cat /proc/asound/modules 
snd_hda_intel

alors que normalement d’après la doc http://doc.ubuntu-fr.org/son_problemes , elle devrait me retourner ceci :

0 snd_hda_intel
 1 snd_usb_audio

Comment faire pour avoir le module snd_usb_audio?

D'avance merci

#19 Re : -1 »  [Resolu] Probleme de Micro web cam » Le 04/11/2013, à 17:11

dubis22
Réponses : 3

Merci Aryal,

Ma webcam fonctionne bien, j'ai vraiment un soucis au niveau du module du noyau :

~$ sudo lsmod | grep snd_usb
[sudo] password for :
snd_usb_audio         140732  0 
snd_usbmidi_lib        24938  1 snd_usb_audio
snd_hwdep              13602  2 snd_usb_audio,snd_hda_codec
snd_pcm                97451  5 snd_usb_audio,snd_hda_codec,snd_hda_intel
snd_rawmidi            30180  2 snd_usbmidi_lib,snd_seq_midi
snd                    68876  22 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
~$ sudo insmod snd_usb_audio
Error: could not load module snd_usb_audio: No such file or directory
~$  sudo insmod /sys/module/snd_usb_audio
Error: could not insert module /sys/module/snd_usb_audio: Invalid parameters

#20 Re : -1 »  [Resolu] Probleme de Micro web cam » Le 05/11/2013, à 12:44

dubis22
Réponses : 3

résolu en desinstallant alsa-base alsa-oss pulseaudio et linux-sound-base

j'ai ensuite renommer les répertoires et fichiers caché dans mon home qui commençait par ".pulse"

un reboot et j'ai réinstaller les 3 paquets plus haut et cela fonctionne.....  Remarque en essayant d’insérer le module j'étais sur la fausse voie.

Merci de votre aide.

#21 -1 »  [RESOLU] Interface taille et orientation non présente » Le 15/10/2013, à 16:56

dubis22
Réponses : 5

Bonjour,

J'ai un portable avec Kubuntu 13.04 et donc KDE 4.10.5. Je n'arrive pas à avoir l'interface qui gère la taille et l'orientation de l'écran. Cela est très gênant surtout quand j'ai un retro projecteur de branché sur mon PC.  Il y a bien la partie "Configuration du verrouillage de l'écran" dans "affichage et surveillance" de la "Configuration du Système".

Comment faire pour faire réapparaître la partie Taille et Orientation sans tout réinstaller?
Merci de votre aide

#22 Re : -1 »  [RESOLU] Interface taille et orientation non présente » Le 15/10/2013, à 20:29

dubis22
Réponses : 5

Salut Jajax,

Oui il est installé car il est dans les extra packages. Je l'ai quand même désinstaller pour voir mais cela n'a rien changé, et les extras package m'ont demandé de le réinstaller sad......

#23 Re : -1 »  [RESOLU] Interface taille et orientation non présente » Le 16/10/2013, à 10:06

dubis22
Réponses : 5

En fait pour moi, kscreen ne fonctionne pas en mode console. J'avais donc fait en avance la même vérification que toi sans pour autant vérifier Configuration du Système.
Donc Balo et Mea Culpa...  Effectivement, la configuration de l'affichage est revenu, si je l'avais vérifier la Configuration du Système plutôt j’aurais pu économiser un post :-)

Encore merci .

#24 Re : -1 »  Connexion impossible au wifi (12,04 LTS fraichement installée) » Le 07/10/2013, à 15:59

dubis22
Réponses : 12

Ah Ok ... Je pensais que tu l'avais déjà installé.... En tout cas pas besoin d'être connecter à Ethernet pour installer Kubuntu big_smile
Sinon tu peut essayé en mode commande :
Wifi en Mode Commande
Ne modifie pas le fichier /etc/network/interfaces cela ne sert  à rien dans ton cas, car tu es en mode LiveCD. Passe à la partie suivante  : Pour se connecter à un réseau en mode console

Puisqu’apparemment, tu as une connexion qui fonctionne pour écrire dans le forum.
2eme point : des fois sur les PC portables il y a un interrupteur qui désactive le wifi .... A vérifier
3eme point : vois tu un wlanX quand tu tapes la commande ifconfig -a  Si ce n'est pas le cas il y a un problème de driver (oui il y en a aussi sur Ubuntu ). Essaye une connexion directe par câble sur ta box .... Ensuite vérifie que ta carte est bien supportée : http://doc.ubuntu-fr.org/wifi_liste_car … carte_wifi

En espérant aider.....