Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 6

#0 Re : -1 »  encore un problème lors d'une mise à jour [RESOLU] » Le 25/03/2013, à 15:50

duthen-mac
Réponses : 58

Mille mercis, Inbox!!!
J'étais tombé dans un trou noir:
"no space left on device" pendant une mise à jour
"apt-get -f install" échoue car "no space left on device"
"apt-get remove" échoue etc.
Du coup, impossible de réinstaller les guest additions pour VirtualBox.
Conséquence: plus de copier/coller plus de montage de volume partagé
(pas commode pour tester des commandes trouvées sur internet)
Je ne savais comment lancer grub (j'y suis arrivé mais ça ne m'a pas vraiment servi)..
Je voyais bien que "/usr/src" était encombré de vieux "linux-headers-*" et "linux-headers-*-generic-pae"
et "/boot" plein de vieux "vmlinuz-3.2.0-*" mais je ne savais pas si je pouvais juste les supprimer sans tout casser.
Et, finalement, la commande magique:

sudo dpkg -P linux-headers-3.2.0-30
sudo dpkg -P linux-image-3.2.0-20-generic-pae
etc.

a libéré suffisamment de place pour

sudo apt-get clean
sudo apt-get update
sudo apt-get install synaptic

puis "menu -> System tools -> Administration -> Synaptic package manager"
J'ai sélectionné les vieux "linux-image" (dans kernel) et "linux-headers" (par recherche) avec "mark for complete removal" (en en gardant un ou deux récents!!!).
Du coup, j'ai pu réinstaller les guest additions et tout baigne!

J'ai juste eu un message d'erreur genre:

/lib/modules/3.2.0-30-generic-pae not empty -> not removed

Puis-je le supprimer, sachant qu'il ne contient qu'un répertoire 'misc' vide?

Existe-t-il d'autres "commandes de ménage" pour supprimer des vieilleries installées par un utilisateur naïf, utilisant simplement l'update manager (click sur "install updates")?

$ uname -a
Linux jack-VirtualBox 3.2.0-39-generic-pae #62-Ubuntu SMP Wed Feb 27 22:25:11 UTC 2013 i686 i686 i386 GNU/Linux

$ ls -AlRF /lib/modules/3.2.0-29-generic-pae
/lib/modules/3.2.0-29-generic-pae:
total 4
drwxr-xr-x 2 root root 4096 Sep 17  2012 misc/

/lib/modules/3.2.0-29-generic-pae/misc:
total 0

$ du -sk /lib/modules/3.2.0-* | sort -n
8	/lib/modules/3.2.0-29-generic-pae
8	/lib/modules/3.2.0-30-generic-pae
8	/lib/modules/3.2.0-31-generic-pae
8	/lib/modules/3.2.0-32-generic-pae
111028	/lib/modules/3.2.0-33-generic-pae
111052	/lib/modules/3.2.0-34-generic-pae
111056	/lib/modules/3.2.0-35-generic-pae
111064	/lib/modules/3.2.0-36-generic-pae
111064	/lib/modules/3.2.0-37-generic-pae
111120	/lib/modules/3.2.0-38-generic-pae
111332	/lib/modules/3.2.0-39-generic-pae

#1 -1 »  [Résolu] Update Manager - firefox et libgrail => Hash Sum mismatch » Le 01/10/2012, à 12:01

duthen-mac
Réponses : 8

Bonjour, je n'arrive pas à résoudre mon problème de "Hash Sum mismatch"!

Je précise que, si je connais bien Unix, je suis tout nouveau sur Linux.

Chaque fois que j'essaie de faire des mises à jour avec l'Update Manager, il échoue toujours avec le même message:

Failed to fetch http://fr.archive.ubuntu.com/ubuntu/poo … 1_i386.deb Hash Sum mismatch
Failed to fetch http://fr.archive.ubuntu.com/ubuntu/poo … 1_i386.deb Hash Sum mismatch

J'arrive péniblement à contourner le problème en essayant de charger ce qui n'utilise pas ces 2 modules,
mais ce n'est pas facile car je n'ai pas trouvé de mécanisme de gestion des dépendances permettant de le faire.
En effet, si je désélectionne tout, puis sélectionne A qui a besoin de B, il charge A et B,
mais l'inverse ne fonctionne pas:
si je sélectionne tout et que je désélectionne B, il ne désélectionne pas automatiquement A. :-(

Après avoir cherché sur le net, j'ai essayé (au pif):
sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update
sudo apt-get upgrade

qui ont terminé par:
Get:1 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main firefox-globalmenu i386 15.0.1+build1-0ubuntu0.12.04.1 [47.5 kB]
Fetched 47.5 kB in 0s (269 kB/s)       
Failed to fetch http://fr.archive.ubuntu.com/ubuntu/poo … 1_i386.deb  Hash Sum mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Apparemment, il y a du mieux du côté du libgrail smile mais pas du firefox sad

J'ai ensuite essayé (toujours au pif):
sudo apt-get update -m   # pour essayer d'utiliser l'option '--fix-missing'
puis:
sudo apt-get upgrade

=>
Failed to fetch http://fr.archive.ubuntu.com/ubuntu/poo … 1_i386.deb  Hash Sum mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

J'ai tenté:
sudo apt-get upgrade -m
=>
Failed to fetch http://fr.archive.ubuntu.com/ubuntu/poo … 1_i386.deb  Hash Sum mismatch

Si je relance l'Update Manager, je retrouve 15 updates (dont firefox et libgrail) sad

Apparemment, au moins, les autres upgrades sont passés!

Mais si je clique update, j'ai de nouveau l'erreur:
check your internet connection:
Failed to fetch http://fr.archive.ubuntu.com/ubuntu/poo … 1_i386.deb Hash Sum mismatch
Failed to fetch http://fr.archive.ubuntu.com/ubuntu/poo … 1_i386.deb Hash Sum mismatch

Quelqu'un aurait-il une proposition (si possible honnête) à me faire?

Merci d'avance
)jack(

#2 Re : -1 »  [Résolu] Update Manager - firefox et libgrail => Hash Sum mismatch » Le 01/10/2012, à 16:36

duthen-mac
Réponses : 8

Merci d'avoir répondu.

Oops!  Je n'ai pas pensé à vérifier le contenu de partial avant de le supprimer.

$ sudo rm -rf /var/lib/apt/lists/partial/* ; echo $?
0
$ sudo apt-get update
Ign http://fr.archive.ubuntu.com precise InRelease
Ign http://extras.ubuntu.com precise InRelease
Ign http://security.ubuntu.com precise-security InRelease            
Ign http://fr.archive.ubuntu.com precise-updates InRelease           
Hit http://extras.ubuntu.com precise Release.gpg
Get:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
[snip]
Hit http://fr.archive.ubuntu.com precise-backports/restricted Translation-en                                                                                                        
Hit http://fr.archive.ubuntu.com precise-backports/universe Translation-en                                                                                                          
Fetched 374 kB in 9s (41.3 kB/s)                                                                                                                                                    
Reading package lists... Done

$ echo $?
0

$ sudo apt-get safe-upgrade
E: Invalid operation safe-upgrade
$ echo $?
100

D'après ce que je vois sur le net, "safe-update" serait plutôt une commande "aptitude".  J'essaie "update" pour voir:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  ginn libgrip0 libunity-2d-private0 libunity-core-5.0-5 unity unity-2d-common unity-2d-panel unity-2d-shell unity-2d-spread unity-common unity-services
The following packages will be upgraded:
  firefox firefox-globalmenu
2 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
Need to get 47.5 kB/19.9 MB of archives.
After this operation, 1,810 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main firefox-globalmenu i386 15.0.1+build1-0ubuntu0.12.04.1 [47.5 kB]
Fetched 47.5 kB in 0s (134 kB/s)        
Failed to fetch http://fr.archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-globalmenu_15.0.1+build1-0ubuntu0.12.04.1_i386.deb  Hash Sum mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

$ echo $?
100

$ ls -ld /var/lib/apt/lists/partial/*
ls: cannot access /var/lib/apt/lists/partial/*: No such file or directory

$ sudo apt-get upgrade -m
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  ginn libgrip0 libunity-2d-private0 libunity-core-5.0-5 unity unity-2d-common unity-2d-panel unity-2d-shell unity-2d-spread unity-common unity-services
The following packages will be upgraded:
  firefox firefox-globalmenu
2 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
Need to get 47.5 kB/19.9 MB of archives.
After this operation, 1,810 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main firefox-globalmenu i386 15.0.1+build1-0ubuntu0.12.04.1 [47.5 kB]
Fetched 47.5 kB in 0s (230 kB/s)        
Failed to fetch http://fr.archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-globalmenu_15.0.1+build1-0ubuntu0.12.04.1_i386.deb  Hash Sum mismatch

$ echo $?
0

Est-ce grave, docteur?

#3 Re : -1 »  [Résolu] Update Manager - firefox et libgrail => Hash Sum mismatch » Le 01/10/2012, à 17:48

duthen-mac
Réponses : 8

Voici le contenu de mon "sources.list":

$ cat /etc/apt/sources.list
#deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release i386 (20120817.3)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise universe
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

et le résultat complet de l'update:

$ ls -ld /var/lib/apt/lists/partial/*
ls: cannot access /var/lib/apt/lists/partial/*: No such file or directory

$ sudo apt-get update
Ign http://fr.archive.ubuntu.com precise InRelease
Ign http://security.ubuntu.com precise-security InRelease
Ign http://extras.ubuntu.com precise InRelease
Ign http://fr.archive.ubuntu.com precise-updates InRelease
Get:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Hit http://extras.ubuntu.com precise Release.gpg                           
Ign http://fr.archive.ubuntu.com precise-backports InRelease               
Get:2 http://security.ubuntu.com precise-security Release [49.6 kB]
Hit http://extras.ubuntu.com precise Release                             
Hit http://fr.archive.ubuntu.com precise Release.gpg                     
Hit http://fr.archive.ubuntu.com precise-updates Release.gpg
Hit http://fr.archive.ubuntu.com precise-backports Release.gpg         
Hit http://fr.archive.ubuntu.com precise Release                                               
Hit http://extras.ubuntu.com precise/main Sources                                                                                        
Hit http://fr.archive.ubuntu.com precise-updates Release                                                                                 
Get:3 http://security.ubuntu.com precise-security/main Sources [46.7 kB]                                           
Hit http://extras.ubuntu.com precise/main i386 Packages                                                                    
Hit http://fr.archive.ubuntu.com precise-backports Release                                           
Ign http://extras.ubuntu.com precise/main TranslationIndex                                                                                        
Hit http://fr.archive.ubuntu.com precise/main Sources                  
Hit http://fr.archive.ubuntu.com precise/restricted Sources                                                                                                   
Hit http://fr.archive.ubuntu.com precise/universe Sources                                                                                                     
Hit http://fr.archive.ubuntu.com precise/multiverse Sources                                 
Get:4 http://security.ubuntu.com precise-security/restricted Sources [1,950 B]              
Hit http://fr.archive.ubuntu.com precise/main i386 Packages                                                       
Get:5 http://security.ubuntu.com precise-security/universe Sources [14.5 kB]                
Hit http://fr.archive.ubuntu.com precise/restricted i386 Packages                           
Hit http://fr.archive.ubuntu.com precise/universe i386 Packages                                                                         
Get:6 http://security.ubuntu.com precise-security/multiverse Sources [1,386 B]              
Hit http://fr.archive.ubuntu.com precise/multiverse i386 Packages                                                 
Get:7 http://security.ubuntu.com precise-security/main i386 Packages [174 kB]                                     
Hit http://fr.archive.ubuntu.com precise/main TranslationIndex                              
Hit http://fr.archive.ubuntu.com precise/multiverse TranslationIndex                                
Ign http://extras.ubuntu.com precise/main Translation-en_US                                          
Hit http://fr.archive.ubuntu.com precise/restricted TranslationIndex                                 
Ign http://extras.ubuntu.com precise/main Translation-en                                            
Hit http://fr.archive.ubuntu.com precise/universe TranslationIndex                                  
Get:8 http://security.ubuntu.com precise-security/restricted i386 Packages [3,968 B]
Hit http://fr.archive.ubuntu.com precise-updates/main Sources               
Hit http://fr.archive.ubuntu.com precise-updates/restricted Sources                                                
Get:9 http://security.ubuntu.com precise-security/universe i386 Packages [48.3 kB]                                 
Hit http://fr.archive.ubuntu.com precise-updates/universe Sources                                   
Hit http://fr.archive.ubuntu.com precise-updates/multiverse Sources                                    
Get:10 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,369 B]        
Hit http://fr.archive.ubuntu.com precise-updates/main i386 Packages                          
Hit http://security.ubuntu.com precise-security/main TranslationIndex 
Hit http://fr.archive.ubuntu.com precise-updates/restricted i386 Packages                                          
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://fr.archive.ubuntu.com precise-updates/universe i386 Packages                                            
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex                                        
Hit http://fr.archive.ubuntu.com precise-updates/multiverse i386 Packages                     
Hit http://security.ubuntu.com precise-security/universe TranslationIndex
Hit http://fr.archive.ubuntu.com precise-updates/main TranslationIndex
Hit http://security.ubuntu.com precise-security/main Translation-en   
Hit http://fr.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://fr.archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://fr.archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://fr.archive.ubuntu.com precise-backports/main Sources       
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://fr.archive.ubuntu.com precise-backports/restricted Sources 
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Hit http://fr.archive.ubuntu.com precise-backports/universe Sources   
Hit http://security.ubuntu.com precise-security/universe Translation-en
Hit http://fr.archive.ubuntu.com precise-backports/multiverse Sources
Hit http://fr.archive.ubuntu.com precise-backports/main i386 Packages
Hit http://fr.archive.ubuntu.com precise-backports/restricted i386 Packages
Hit http://fr.archive.ubuntu.com precise-backports/universe i386 Packages
Hit http://fr.archive.ubuntu.com precise-backports/multiverse i386 Packages
Hit http://fr.archive.ubuntu.com precise-backports/main TranslationIndex
Hit http://fr.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Hit http://fr.archive.ubuntu.com precise-backports/restricted TranslationIndex
Hit http://fr.archive.ubuntu.com precise-backports/universe TranslationIndex
Hit http://fr.archive.ubuntu.com precise/main Translation-en
Hit http://fr.archive.ubuntu.com precise/multiverse Translation-en
Hit http://fr.archive.ubuntu.com precise/restricted Translation-en
Hit http://fr.archive.ubuntu.com precise/universe Translation-en
Hit http://fr.archive.ubuntu.com precise-updates/main Translation-en
Hit http://fr.archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://fr.archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://fr.archive.ubuntu.com precise-updates/universe Translation-en
Hit http://fr.archive.ubuntu.com precise-backports/main Translation-en
Hit http://fr.archive.ubuntu.com precise-backports/multiverse Translation-en
Hit http://fr.archive.ubuntu.com precise-backports/restricted Translation-en
Hit http://fr.archive.ubuntu.com precise-backports/universe Translation-en
Fetched 343 kB in 5s (67.4 kB/s)
Reading package lists... Done

Je pense que s'il y avait eu des erreurs, je les aurais vues...

Juste pour info, au cas où ça pourrait aider au diagnostic (voire à la résolution du problème):
Je fais une utilisation très très basique d'Ubuntu qui me permet, sur un Windows (imposé), d'avoir un bash, un emacs, un ssh et un firefox.
Je me contenterais parfaitement d'un firefox 3.6.28 (si c'était possible...)
Je n'ai aucun idée de ce à quoi peut servir la gestion des "gestures" (demandée par libgrail), mais je peux très probablement m'en passer.
J'ai installé les Guest Additions dans VirtualBox.
J'ai installé gnome-session-fallback (pour avoir un environnement proche de U 10.10).

#4 Re : -1 »  [Résolu] Update Manager - firefox et libgrail => Hash Sum mismatch » Le 02/10/2012, à 09:51

duthen-mac
Réponses : 8

Un seul mot: perfect!

J'ai tout fait depuis l'Update Manager: sélectionné le dépôt "main", update, install => tout s'est bien passé!

Faut-il signaler quelque part que le dépôt http://fr.archive.ubuntu.com/ubuntu/ est défaillant?

#5 Re : -1 »  [Résolu] Update Manager - firefox et libgrail => Hash Sum mismatch » Le 05/10/2012, à 10:50

duthen-mac
Réponses : 8
inbox a écrit :

Je ne pense pas que ce soit le dépôt qui soit défaillant. Il y aurait beaucoup plus de problème de ce genre signalés.

Je pense plutôt à un dysfonctionnement du système de mise à jour local.

alors que j'ai supprimé tous les fichiers de /var/lib/apt/lists et /var/lib/apt/lists/parts ?

Le fait de changer de dépôt l'oblige à lister de nouveau correctement les paquets disponibles. Je pense que tu peux même retourner sur le dépôt francophone, maintenant que ton problème est réglé.

[EDIT] Je modère ce que j'ai écrit, car je viens de constater le même problème (Somme de contrôle de hachage incohérente) sur un paquet...
Par contre, je n'ai pour le moment, rencontré cette erreur que dans une machine virtuelle Ubuntu hébergée sur un Windows.

Rappel: je suis justement sous Windows XP avec Oracle VirtualBox...