Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  12.04 et lbp2900 » Le 14/03/2014, à 15:13

murex
Réponses : 10

Bonjour,

En principe la version 260 du driver Canon n'a plus besoin de cet ancien paquet de transition (gs-esp).
Lors de l'installation du driver puis de l'imprimante as-tu eu un message concernant le paquet gs-esp ?
Par contre il faut que le paquet ghostscript soit installé, mais en principe il l'est par défaut.

As-tu suivi l'ensemble de la procédure d'installation :
http://doc.ubuntu-fr.org/installer_canon_lbp
puis :
http://doc.ubuntu-fr.org/tutoriel/insta … _canon_lbp

Ton imprimante as-t-elle fait parlé la poudre wink

A+

#1 Re : -1 »  12.04 et lbp2900 » Le 18/03/2014, à 14:20

murex
Réponses : 10

Bonjour,

Tous les fichiers log sont dans le répertoire /var/log, tu peux essayer de jeter un œil.
As-tu eu des retours de commande "suspects" lors de l'exécution des commandes dans le terminal pour l'installation du driver puis de l'imprimante ?

Sinon, que donne la commande :

captstatusui -P [nom de l'imprimante]

Bien sur tu remplaces [nom de l'imprimante] par celui que tu as utilisé lors de l'installation wink

A+

#2 Re : -1 »  12.04 et lbp2900 » Le 21/03/2014, à 15:53

murex
Réponses : 10

Bonjour,

C'est les joies de l'installation de ces imprimantes big_smile mad
Je pars ce soir et ne reviendrai sur le forum que début avril.
Ce que tu peux essayer (imprimante allumée) :
Arrêter ccpd

sudo service ccpd stop

Arrêter puis relancer cups

sudo service cups stop
sudo service cups start

Relancer ccpd

sudo service ccpd start

Vérifier que ccpd est OK (cf la doc)

sudo service ccpd status

doit te donner : ccpd: 8956 8954 (aux chiffres près)

Sinon je crois qu'il faudra "tout reprendre depuis le début"...
Courage
A+

#3 Re : -1 »  12.04 et lbp2900 » Le 02/04/2014, à 15:54

murex
Réponses : 10

Bonjour,

Pour les besoins de cette affaire, j'ai installé 12.04.4 LTS - 32bits sur un bout de partition libre.
J'ai installé ma LBP5000 qui utilise le même driver et la même procédure que ta LBP2900.
Je te récapitule ce que j'ai fait (suivant procédure Doc).

Imprimante allumée et connectée au PC (vérification de l’existence de : /dev/usb/lp0)
1) Téléchargement du driver Canon CAPT v260
2) Installation du paquet : libglade2-0
3) Installation du paquet : cndrvcups-common_2.60-1_i386.deb
4) Installation du paquet : cndrvcups-capt_2.60-1_i386.deb
5) Reboot du PC en gardant l'imprimante allumée
6) Installation de l'imprimante dans CUPS (commandes adaptées à ton imprimante wink)

sudo /usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd  -v ccp://localhost:59787 -E

7) Enregistrer l'imprimante dans le démon ccpd

sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0

8) Lancement de ccpd

sudo service ccpd start

A ce stade la page test s'imprime normalement.
Je n'ai pas fait la partie automatisation de la détection de l'imprimante.

Voilà ce que je peux te rapporter, te ton côté où en es-tu ?

A+

#4 Re : -1 »  12.04 et lbp2900 » Le 03/04/2014, à 12:52

murex
Réponses : 10

Oui, je sais, as-tu regardé et testé le point 4.3 de http://doc.ubuntu-fr.org/tutoriel/insta … _canon_lbp ?

A+

Edit : tu peux tester et vérifier avec le Moniteur système pour voir dans quel état se trouve ccpd.

#5 Re : -1 »  imprimante LBP1120 » Le 18/01/2014, à 16:01

murex
Réponses : 23

Bonjour les amis,

Je vais peut-être vous décevoir, mais "à ma connaissance et de ma propre expérience" le driver Canon CAPT pour les imprimantes LBP n'est pas compatible avec 13.10 64bits. sad

Comme expliqué dans le tuto http://doc.ubuntu-fr.org/tutoriel/insta … _canon_lbp

"Avec les versions 64bits, il faut installer le paquet ia32-libs. Il fournit les bibliothèques 32bits pour les systèmes 64bits. Elles sont indispensables au fonctionnement du pilote Canon.
Depuis 12.04, la gestion des bibliothèques 32bits pour les systèmes 64bits a changé dans Ubuntu. Le paquet ia32-libs, fourni dans les dépôts correspondants, n'est plus compatible avec le pilote Canon.
Il faut donc installer manuellement une version antérieure du paquet ia32-libs."

Jusqu'à 13.04 on pouvait encore installer cet ancien paquet ia32-libs car les dépendances étaient encore assurées.
Avec 13.10 certaines dépendances du paquets ia32-libs sont supprimées (lib32asound2) et d'autres ont changé de version ce qui rend pratiquement impossible l'installation de cet ancien paquet ia32-libs.

Résultat, je pense qu'il faut utiliser 12.04LTS (ou 12.10 / 13.04) en attendant que Canon veuille bien sortir une nouvelle version qui prendra en charge cette évolution de Debian/Ubuntu ...
Je n'ai pas encore eu le temps de faire une mise à jour de la Doc dans ce sens. Pas mal pris ailleurs ces derniers temps et je surveillais l'ensemble des forums des fois qu'un "super dev" trouve une solution... mais rien pour le moment.

A+

#6 Re : -1 »  imprimante LBP1120 » Le 19/01/2014, à 18:15

murex
Réponses : 23

Bonjour,

Tu ne te "sens" pas de faire une installation neuve de 12.04 ?
Regarde dans la Doc, il y a les explications pour faire une installation, cela te donnera une idée de la difficulté wink
A+

#7 Re : -1 »  imprimante LBP1120 » Le 23/01/2014, à 15:10

murex
Réponses : 23

@UnMamouth
Bonjour,

UnMamouth a écrit :

En fait, juste après l'installation, l'impression fonctionne. Par contre, une fois redémarré l'ordinateur, cela ne fonctionne plus : les documents sont envoyés à l'imprimante, mais restent bloqués dans la file de travail avec 'Traitement en cours'.
Y aurait-il un process bloqué ou non-démarré quelque part ?

Dans le tuto http://doc.ubuntu-fr.org/tutoriel/insta … _canon_lbp as-tu fait la partie automatisation de la détection de l'imprimante ?
J'ai constaté ces deniers temps que lorsque l'imprimante était déjà allumée au boot du PC, et malgré le job Upstart qui relance ccpd, cela ne fonctionne pas à tous les coups ??? Pour le moment je n'ai pas eu le temps de me repencher sur le problème.
Dans ce cas là, le plus simple c'est de rebooter le PC avec l'imprimante débranchée ou éteinte; et de la brancher/allumer une fois le PC opérationnel.
A+

#8 Re : -1 »  imprimante LBP1120 » Le 25/01/2014, à 13:52

murex
Réponses : 23

Bonjour,

Supprime la LBP1120 pour ne conserver que la LBP-1120
La LBP1120 correspond peut-être à la tentative d'installation auto de Udev.
Si elle revient tu la désactives au lieu de la supprimer. 
A+

#9 Re : -1 »  Utiliser Pyrename pour renommer des photos par ordre de prise de vue » Le 15/09/2013, à 17:42

murex
Réponses : 3

Bonjour,

J'utilise cette régle :

{imageyear}{imagemonth}{imageday}_{num2+1}.jpg

qui me donne par exemple : 20130901_04.jpg

si cela peut d'aider ?
A+

#10 Re : -1 »  imprimante canon lbp810 » Le 17/01/2014, à 11:50

murex
Réponses : 41

Bonjour,

Canon ne fournit pas de drivers Linux pour cette imprimante, contrairement à d'autres modèles (série LBP en particulier).
Ceci est mentionné dans la Doc : http://doc.ubuntu-fr.org/installer_canon_lbp, dans la liste des imprimantes officiellement supportées.
Avec des versions antérieures d'Ubuntu et du driver Canon CAPT certains avaient réussi à faire fonctionner cette imprimante en la considérant comme une LBP1120...
Désolé de ne pouvoir faire plus, mais s'il se confirme que cette "astuce" ne fonctionne plus aujourd'hui, il faudra peut-être retirer la LBP810 de la liste pour éviter toute confusion.
A+

#11 Re : -1 »  imprimante canon lbp810 » Le 18/01/2014, à 15:23

murex
Réponses : 41

Bonjour luciole135

Le lien du forum LinuxMint date de 2012, donc avec un peu de chance ton imprimante pourrait fonctionner sous Ubuntu 12.04 32bits.

De passer sous Kubuntu ne fera que changer l'interface graphique, mais la gestion des imprimantes reste identique.
Debian 5 est une version obsolète et je ne sais pas si elle est toujours maintenue pour les mises à jour ???

Si tu veux bien rester avec ton installation 12.04 je te propose de faire les commande suivantes pour essayer d'installer ton imprimante.
Tu peux faire des copier-coller des lignes de commande dans un terminal.
Ton imprimante doit être connectée au PC et allumée.

1) Faire le ménage pour les drivers Canon précédemment installés :

sudo /usr/sbin/ccpdadmin -x LBP810

pour retirer l'imprimante.

et

sudo dpkg --purge cndrvcups*

pour supprimer les drivers

2) Je suppose que tu as installé le paquet libglade2-0, sinon :

sudo apt-get install libglade2-0

3) Installe les 2 paquets du driver Canon vers 2.60 :

sudo dpkg -i cndrvcups-common_2.60-1_i386.deb cndrvcups-capt_2.60-1_i386.deb

Attention avant de lancer cette commande déplace toi dans le répertoire qui contient les 2 paquets (commande : cd)

4) Redémarrer CUPS :

sudo sercice cups stop

puis

sudo service cups start

5) Installer ton imprimante dans CUPS :

sudo /usr/sbin/lpadmin -p LBP810 -m CNCUPSLBP1120CAPTK.ppd -v ccp://localhost:59787 -E

6) Enregistrer l'imprimante dans ccpd :

sudo /usr/sbin/ccpdadmin -p LBP810 -o /dev/usb/lp0

7) Lancer le démon ccpd :

sudo service ccpd start

8) Vérifications de l'installation :

sudo service ccpd status

doit te retourner : /usr/sbin/ccpd: 4775 4774 aux chiffres prés.

puis

captstatusui -P LBP810

doit ouvrir la fenêtre du Statusmonitor et si tout est OK tu liras "Ready to print"

Essaie tout ça, et bonne chance wink
A+

EDIT : si c'est OK, on verra pour automatiser la gestion du démon ccpd.

#12 Re : -1 »  imprimante canon lbp810 » Le 19/01/2014, à 17:33

murex
Réponses : 41

@ L'Africain
Merci mon ami, mais je ne suis pas "l'expert" des imprimantes LBP big_smile
J'utilise une LBP5000 depuis Ubuntu 6.10, alors forcement avec le temps... Surtout que chaque nouvelle version d'Ubuntu apporte son lot de nouveaux problèmes d'installation. Actuellement, cerise sur le gâteau, il n'est plus possible de faire fonctionner ces imprimantes avec 13.10 64bits. La compatibilité multiarch est rompue et je crois qu'il va falloir attendre que Canon veuille bien prendre en compte la nouvelle façon de gérer le multiarch sous Debian/Ubuntu hmm
Je ne comprends pas pourquoi ils sont si "mauvais" avec les distributions basées sur Debian. Avec celles qui fonctionnent avec les paquets RPM (Fédora par exemple) l'installation n'a jamais posé de problème 32 ou 64bits.

@luciole135
Super tes explications, c'est rare d'avoir quelque chose d'aussi clair smile

Pour moi tout est "normal" pour les 7 premiers points, le reboot du PC n'a pas d'impact négatif (au contraire) et le retour de la commande ccpd staus est OK.

On se trouve pratiquement dans la situation du forum LinuxMint...
Quand tu écris :

La colonne emplacement est vide !

cela veut-il dire que tu as vérifié que le répertoire /usr/lib/cups/backend/ccp n'existe pas ? Si c'est le cas alors quelque chose foire dans l'installation sad
Peux-tu me dire quels sont les répertoires dans : /usr/lib/cups

A+

#13 Re : -1 »  imprimante canon lbp810 » Le 19/01/2014, à 18:52

murex
Réponses : 41

@ L'Africain

Oui sur Fédora en particulier, ma LBP5000 s'est toujours installée sans problème (32 ou 64bits) en suivant les instructions fournies dans la Doc des drivers. De plus pas besoin de se casser la tête avec l'automatisation de la gestion du démon ccpd.
A une époque j'ai même failli abandonner Ubuntu pour Fédora, mais bon ne le répête à personne big_smile big_smile big_smile
A+

#14 Re : -1 »  imprimante canon lbp810 » Le 20/01/2014, à 13:52

murex
Réponses : 41

Bonjour,

Je n'ai pas voulu dire qu'il ne fallait pas installer Fedora,  c'était une boutade (voir les 3 smyles lol).
Fedora est une excellente distribution, pour l'avoir testée . La Doc de leur site est peut-être un peu moins fournie que celle d'Ubuntu. Si tu veux tenter l'expérience va sur leur site et télécharge la dernière version en date.

Pour ton problème je commence à arriver en limite de mon expérience.
Combien d'imprimantes as-tu de listées ? LBP810-1   /  LBP810-2  .....
En fait UDEV cherche lui aussi à configurer automatiquement les imprimantes lorsqu'il en voit arriver sur le bus USB. Ce qui explique parfois la présence d'une même imprimante avec les numéros d'ordre.
Sinon, il faut peut-être que tu refasses encore quelques installations pour que comme dans le fil de Mint ça finisse par marcher sans savoir pourquoi...

A+

#15 Re : -1 »  imprimante canon lbp810 » Le 24/01/2014, à 16:45

murex
Réponses : 41

Bonjour,

L'Africain a écrit :

Bon au moins c'est clair. Ce que je voulais dire avec ufrII, c'est que c'est Canon qui le propose et que le 64 bits s'installe sans aucun problème avec le ia32 des dépots, sans problème, alors je m'étonne de tant de difficultés pour les lbp !

Comme je te le disais dans un autre fil, je n'ai pas d'imprimante qui relève du driver UFR II, donc impossible de tester pour moi.
La seule chose que je peux te dire c'est que sur les 2 paquets qui composent ce driver, le "common" semble identique à celui du driver CAPT.
Avec quelle version d'Ubuntu 64bits as-tu fait une installation réussie du driver URF II et avec quelle imprimante ?

A+

@ alca94
Bonjour,

alca94 a écrit :

Je n'ai pas tout suivi par contre ia-32 n'existe plus pour la version 13.10 ,pour Brother il faut installer ces deux lignes en lieu et place pour que l'imprimante fonctionne

Oui, en ce moment on se parle sur plusieurs fils au sujet des imprimantes LBP et 13.10-64bits.
Le problème c'est justement que ia32-libs et certaines de ses dépendances ont disparu de 13.10.
Donc plus possible de bidouiller avec une ancienne version de ia32-libs.
Canon indique clairement que ce paquet est nécessaire pour le 64bits :

In a 64-bit Ubuntu environment, all the 32-bit libraries required for
  printing are not installed. As a result, printing will fail if 32-bit
  libraries are not installed.
  Before printing, it is required that you execute the following commands to
  install a 32-bit library package.
    # apt-get install ia32-libs
    # apt-get install libpopt0:i386

Pour le moment je n'ai pas encore réussi à trouver les bibliothèques 32bits qui sont nécessaires au driver CAPT parmi toutes celles qui étaient installées par ia32-libs.
Sinon effectivement je connais la nouvelle façon de faire :

alca94 a écrit :

via le terminal
sudo dpkg --add-architecture i386
puis installer le paquet dont aura besoin le pilote :
sudo apt-get install libc6:i386

A+

#16 Re : -1 »  imprimante canon lbp810 » Le 26/01/2014, à 16:23

murex
Réponses : 41

Bonjour,

Je peux te confirmer qu'avec ma LBP5000, le paquet ia32-libs dans les dépôts 12.04 - 12.10 et 13.04 (en fait ce n'est plus le "vieux" paquet mais un paquet de transition) ne marche pas. Il faut absolument que j'utilise le paquet d'une version antérieure à 12.04, comme je l'indique dans la Doc. Le paquet de transition n'installe pas les bibliothèques dans les mêmes répertoires et ça fout le b...

Je me demande si ces drivers Canon ne sont pas en fait une "compilation" de pilotes pour toutes les imprimantes d'une même série.
Je m'explique, ma LBP5000 qui est une des premières sortie de la série LBP, m'affiche toujours "Canon LBP5000 CAPT ver.1.3" alors que j'ai installé le driver 2.60.
Ce qui me laisse à penser que Canon ne fait pas évoluer les pilotes à chaque version mais se contente d'ajouter les pilotes pour les nouvelles imprimantes sorties.
Donc peut-être qu'une imprimante récente de la série LBP à un pilote qui utilise multiarch pour gérer le 32/64bits et peut s'installer sans problème alors que les anciennes restent toujours avec un pilote basé sur ia32-libs ???

Comme on est en face d'un driver propriétaire, on ne peut que tâtonner et supputer big_smile

A+

#17 Re : -1 »  installation de la canon lbp-1120 sous 13.10 64 bits » Le 22/01/2014, à 15:43

murex
Réponses : 5

Bonjour,

Ça y est, j'ai mis la Doc à jour hier concernant "l'impossibilité" d'installation des imprimantes LBP avec 13.10 64bits.

A+

#18 Re : -1 »  installation de la canon lbp-1120 sous 13.10 64 bits » Le 23/01/2014, à 15:19

murex
Réponses : 5

@ L'Africain,

J'ai téléchargé le driver 2.60 de la Doc https://help.ubuntu.com/community/CanonCaptDrv190.
En première analyse c'est la version 2.60 distribuée par Canon depuis juillet 2013.
Déjà avec les versions précédentes d'Ubuntu, ce tuto présentait l'installation 64bits de cette manière et j'avais cru comme toi qu'il y avait du nouveau. En fait non, pour 64bits les indications ne sont pas bonnes. Je pense que le rédacteur reprend la procédure Canon fournie avec le Driver mais elle n'est valable que pour du 32bits.

Pour le driver ufr II je ne connais pas, il ne s'applique pas à mon imprimante.

A+

#19 Re : -1 »  scanner Epson perfection V300 PHOTO sur 12.04 LTS JPEG en grisé » Le 19/12/2013, à 15:01

murex
Réponses : 1

Bonjour,

Tu peux vérifier si le paquet : libjpeg est installé.
Il se peut que ce soit la cause de ton problème.

A+

#20 Re : -1 »  Désactivez votre option achat internet + sur orange » Le 11/12/2013, à 17:04

murex
Réponses : 3

Merci de l'info,

J'ai désactivé paiements internet et Contact +
Ils étaient activés par défaut tous les 2.
Tu as raison, sage précaution ...

A+

#21 Re : -1 »  android:j'arrive pas à avoir la permis de root » Le 09/12/2013, à 16:51

murex
Réponses : 10

Bonjour,

De quel smartphone s'agit-il (marque, modèle) ??? wink

sinon as-tu fais des recherches sur ces sites :
www.phonandroid.com  (forum)

et forum.xda-developers.com

A+

#22 Re : -1 »  Installation snapscan e20 et Canon LBP 2900 » Le 08/10/2013, à 11:49

murex
Réponses : 11

Bonjour,

Pour ton imprimante, les infos du site Le-libriste datent un peu.
As-tu essayé la Doc du site ?
Pour installer le driver Canon : http://doc.ubuntu-fr.org/installer_canon_lbp
Ensuite pour installer l'imprimante : http://doc.ubuntu-fr.org/tutoriel/insta … _canon_lbp
En principe ton imprimante est supportée. Tiens nous au courant.

Pour le scanner je laisse la main à d'autres ...
A+

#23 Re : -1 »  problème installation LBP1120 » Le 25/09/2013, à 16:56

murex
Réponses : 1

Bonjour, regarde cette page pour installer le driver Canon
http://doc.ubuntu-fr.org/installer_canon_lbp

Puis celle-ci pour installer l'imprimante
http://doc.ubuntu-fr.org/tutoriel/insta … _canon_lbp

tu verras que ta commande

sudo /usr/sbin/lpadmin -p LBP1120 -m CNCUPSLBP1120CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E

n'est plus "d'actualité"

A+