Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Le 22/04/2015, à 19:15

hr
Réponses : 43

Bonjour.
Je n’ai pas réussi depuis longtemps à démarrer un Mac sur une clef USB mais avec une ISO gravée sur un DVD exactement comme pour un PC, aucun problème. J’ai fait ça plusieurs fois il n’y a pas longtemps et ça a marché sans aucun problème. C’était d’ailleurs un DVD que j’avais aussi utilisé pour un PC, de ce côté-là, aucune manœuvre particulière à faire. Par contre avec une clef qui démarre parfaitement sur un PC, rien à faire sur un Mac.

Pour savoir si la machine peut démarrer dessus, il faut redémarrer le mac en maintenant la touche Alt appuyée. Toutes les partitions démarrables apparaissent et on choisit le DVD qui, en général (ça a l’air d’un gag mais c’est comme ça !) est marqué Windows.
On démarre dessus et c’est bon.
Si le DVD n’apparaît pas dans la liste, alors c’est qu’il y a un hic.

Ceci dit, le DVD que j’ai utilisé était gravé sur un PC Ubuntu. Je vais essayer de mettre la main sur un DVD et j’essaye. Je raconterai ce que ça a donné.

#1 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Le 22/04/2015, à 20:30

hr
Réponses : 43

Je viens de faire la manœuvre complète :
— Gravure de l’ISO d’Ubuntu 14.04-2 sur un DVD sur le Mac avec l’utilitaire disque, avec vérification, aucun problème.
— Démarrage du Mac avec l’ISO dans le lecteur et appui sur la touche Alt : l’icône apparaît avec la mention « Windows ».
— Démarrage sur le DVD.
— C’est long, ce qui est normal sur un DVD, mais le bureau d’Ubuntu vient d’apparaître pendant que je tapais…
Donc aucune difficulté chez moi avec la gravure sur le Mac.
Il faut savoir que mon Mac, quoique relativement vieux (iMac alu début 2008) est en OS 10.10, donc dernière version. Ça a peut-être une importance pour la capacité à graver les ISO, je n’en sais rien.
As-tu un autre DVD sous la main ? Il m’est arrivé des difficultés avec des DVD défaillants même après effacement complet (j’utilise toujours des DVD réinscriptibles).
---------------------------------
Un détail : il est normal que tu n’arrives pas à monter un disque ISO sur le bureau du Mac, les Macs ne reconnaissent pas le format d’image ISO sauf pour démarrer dessus ! big_smile bizarroïde mais c’est comme ça…

#2 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Le 22/04/2015, à 22:54

hr
Réponses : 43

En fait tu devrais avoir boot EFI  mais aussi Windows et c’est windows qu’il faut lancer. J’ai essayé de démarrer sur boot EFI pour voir et j’ai aussi le message d’erreur mais après quelques secondes j’ai un menu grub qui permet de lancer Ubuntu ou de l’installer de façon normale. De toute façon, si tu ne vois pas l’autre partition du DVD, c’est que quelque chose ne va pas soit dans le DVD, soit ton mac n’est pas compatible avec ce type de démarrage. Est-il récent ? Les miens sont assez anciens.

Donc, que ce soit pour une raison ou pour une autre, ton DVD n’est pas correctement reconnu au démarrage. Tu ne peux pas essayer le DVD sur un PC ? Ce serait intéressant de savoir au moins si c’est le DVD ou la machine qui pose problème. Ah ben si, tu disais que tu avais gravé sur WIndows 7, tu devrais pouvoir au moins essayer si le DVD démarre sur le PC.

Tout de même, pourquoi chez moi je n’ai strictement aucun problème et chez toi c’est impossible ?
Ah oui, je voulais te demander, quelle est la version d’OS de ton mac ? Ce serait intéressant de le savoir parce que l’utilitaire de disque évolue avec l’OS. Ça pourrait expliquer que tu n’arrive pas à graver avec

#3 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Le 22/04/2015, à 23:23

hr
Réponses : 43

Ah, voilà au moins une différence qui peut être significative puisque le mien est en 10.10.3

#4 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Le 22/04/2015, à 23:36

hr
Réponses : 43

Ce sera instructif, je pense.

#5 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Le 23/04/2015, à 23:46

hr
Réponses : 43

Attends, un truc me chiffone, si le DVD a démarré sur le PC, il devrait démarrer sur le Mac. J’ai toujours utilisé les mêmes DVD pour les PC et les Macs. Par contre, si le Mac est dans un état bizarre, tu peux vider la PRAM. C’est sans risque et ça permet souvent de repartir sur des bases saines, en particulier pour des questions de disques, ce qui est le cas.

Il faut démarrer avec quatre touches simultanément (déjà enfoncées avant le démarrage) : Alt + Commande + P + R (PR comme PRAM) et surtout tu les maintiens enfoncées jusqu’à ce que tu entendes le son genre tchooooommp ! de démarrage une deuxième fois, silence puis une troisième fois et ensuite seulement tu relâches les touches.

Ça a l’air bizarre mais il y a plusieurs procédures de maintenance du même style, celle-là est la plus courante. C’est un peu comme d’ouvrir le BIOS d’un PC quand on change de disque pour qu’il mette  à jour ses données.

Donc essaye ça, il est loin d’être impossible que ça mette de l’huile dans les rouages au moment de démarrer sur le DVD.

#6 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Le 24/04/2015, à 21:06

hr
Réponses : 43

Pour le problème de ton PC, c’est un tout autre sujet tu devrais ouvrir un autre fil de discussion pour qu’il puisse être repéré. Enterré dans celui-là, il n’est pas visible.

En attendant pour aller vite, j’ai eu des problèmes similaires et je dirais que tu pourrais, dans grub (le menu au démarrage pour choisir l’OS) dans les options avancées, lancer la version générique du système et non pas celle par défaut. Si c’est un problème d’affichage, en générique ça passera peut-être (une définition plus basse et quelques bizarreries sont possibles mais c’est provisoire jusqu’au prochain démarrage) et si tu arrives à ouvrir une session, tu fais les mises à jour et tu relances. Le démarrage normal avec la vidéo correcte se passera correctement si tout va bien. C’est comme ça que j’ai procédé quand ce mauvais gag m’est arrivé sur trois machines et ça a toujours réglé le problème. Sans garantie, c’est peut-être un autre problème chez toi mais essaye toujours.

De toute façon, si ça résout le problème, tu peux tout de suite en profiter pour passer à 15.04 qui vient de sortir et qui est meilleur !

#7 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Hier à 12:33

hr
Réponses : 43

Et tu as essayé l’autre icône pour démarrer ?
Comme je le disais, chez moi sur l’une d’elle ça démarre, sur l’autre j’ai le message d’erreur mais au bout d’un temps d’attente, ça démarre tout de même.

Après ça, j’aurai du mal à t’aider plus que ça dans la mesure où je n’arrive pas à reproduire ton problème.

#8 Re : -1 »  Installer Ubuntu en dual-boot avec Mac OS X » Hier à 15:42

hr
Réponses : 43
D@rren a écrit :

Bonjour,

@hr : J'ai voulu réessayer : j'ai donc commencé par l'icône de gauche (nommée EFI boot), j'ai ce message :
error: attempt to read or write outside of disk 'hd0'.
unaligned pointer 0xbbfc9c08
Aborted. Press any key to exit.

Donc j'attends un peu, puis j'obtiens cet écran :

http://pix.toile-libre.org/upload/thumb/1430653950.jpg

Donc bon je redémarre pour essayer l'icône de droite (qui était aussi nommée EFI boot), sauf que y'a plus qu'une seule icône (je vous laisse deviner son nom). Donc bon je la tente quand même, et là bon bah rien de très original : le fameux Could not open "\EFI\BOOT\fallback.efi": 14 et i8042: No controller found...

Aïe, carrément un kernel panic, oui évidemment ça ne risque pas d’aller plus loin. C’est comme si le DVD était mauvais or si tu l’as utilisé sur une autre machine, ça ne peut pas être le cas. Es-tu sûr de ton lecteur de DVD, tu n’as jamais eu de problème avec lui ?

Tu n’as pas de disque dur externe libre ou sur lequel tu pourrais installer une partition ? Ce serait possible avec unetbootin, normalement.
Après ça, je suis sec, malheureusement…

#9 -1 »  Fermeture de session laborieuse » Le 22/04/2015, à 12:59

hr
Réponses : 4

Bonjour tout le monde.
J’ai un petit problème pas très grave mais qui commence à un peu m’user les nerfs…
Lorsque je quitte une session, quel que soit le compte, j’ai un écran vide pendant exactement 1 mn 30 avant de pouvoir retourner dans l’écran de connexion de lightdm.

Ça ressemble à une appli, un service ou je ne sais quoi qui tourne en arrière plan et qui refuse de se fermer puis qui, après un time out, est tué par le système. Mais quoi ?
J’ai plusieurs choses qui tournent, Apache, Syncthing, ssh, netatalk mais tout ça n’est pas lié à la session et, bien entendu, j’ai fait des essais en les arrêtant l’un après l’autre, en vain. Je suis allé jusqu’à les désinstaller tous sans plus de résultat.

J’imagine aussi qu’il pourrait y avoir un problème de droits sur quelque chose qui doit s’exécuter pour fermer la session et qui est altéré. Je sèche complètement.
Réinstaller le système, c’est une journée complète de boulot, pas vraiment envie…
En attendant, pour aller plus vite, je passe en console et lance un restart lightdm mais c’est un peu lourd.

Autant vous dire que si quelqu’un a une idée, bonne ou même mauvaise, j’en serais ravi !

J’ai évidemment cherché sur le forum mais n’ai rien trouvé d’approchant.
Ubuntu 14.04 en 64 bits

#10 Re : -1 »  Fermeture de session laborieuse » Le 22/04/2015, à 18:39

hr
Réponses : 4

Merci pour l’idée ! smile
Le problème n’était pas de ce côté-là mais il était bon de vérifier.
De plus ça me rappelle la commande blkid que j’avais oubliée ce qui faisait que je me compliquais inutilement la vie pour trouver les id des partitions. wink
Je cherche aussi du côté des applications lancées à l’ouverture de session mais je ne trouve rien de louche là non plus.

#11 Re : -1 »  Fermeture de session laborieuse » Le 22/04/2015, à 19:31

hr
Réponses : 4

Non, pas du tout. D’ailleurs tout est normal par ailleurs.
J’essaye ta manœuvre mais si ça coinçait 1 Mn 30, je m’en apercevrais, c’est un PC un peu vieux mais le démarrage est rapide.
J’essaye tout de même dans quelques minutes, dès qu’il a fini ce qu’il est en train de faire.
-------------------------
Voilà, j’ai essayé et il n’y a rien d’anormal, le démarrage est fluide et rapide d’un bout à l’autre. Bigre, ce pépin m’embête, décidément !
Je n’ai pas procédé exactement comme tu l’as dit mais ça revient au même : j’ai édité la ligne dans grub en supprimant le quiet splash et j’ai bien eu le défilement de tous les messages.

#12 Re : -1 »  [Ubuntu 14.04] Problème clavier » Le 14/08/2014, à 11:39

hr
Réponses : 27

Vieux problème chronique depuis maintenant un bon nombre de versions. Explications et solution :

Chacune des dispositions de clavier utilisées, que ce soit par les comptes utilisateurs ou par le mode console, sont compilées sous forme de fichiers. Pour qu’une modification des fichiers de disposition des touches puissent être prise en compte il faut d’abord effacer ces compilations.

– En root , ouvrir le dossier /var/lib/xkb

– Supprimer tous les fichiers de forme server-7E1185B3FB6C72A7916D9959F7592B3A1655A011.xkm

– Redémarrer la machine si la modification concerne la disposition par défaut du système, sinon sélectionner la nouvelle disposition dans le compte.

Ces fichiers peuvent tous être supprimés puisqu’ils seront reconstitués à partir des fichiers de configuration du clavier dès que le type de clavier correspondant sera utilisé, qu’il soit modifié ou d’origine. De même, la
disposition par défaut du mode console sera compilée après le démarrage du système.

#13 Re : -1 »  [Ubuntu 14.04] Problème clavier » Le 24/09/2014, à 16:03

hr
Réponses : 27
pope81 a écrit :

à chaque démarrage, je suis obligé de cliquer sur l'icône 'Fr' puis 'Français Variante' pour ne pas avoir le clavier UK

Un autre grand classique. Je ne sais pas non plus pourquoi il résiste au temps celui-là aussi.
Ma manière de régler ce problème (différent du précédent) jusqu’ici sans échec sur pas mal de machines :
— Dans le support des langues, supprimer l’anglais et toute autre langue qu’on utilise pas. Vérifier que lors d’une nouvelle session, on reste bien en clavier français.
— Dans l’agencement du clavier, supprimer tout autre clavier que celui qu’on veut utiliser.
Si le problème est résolu, on peut enlever l’icône du Fr sauf si on l’utilise le menu pour d’autres raisons que changer de clavier (accès à la table de caractères, etc.)

#14 Re : -1 »  Firefox : second navigateur le plus utilisé en France ? » Le 13/08/2014, à 13:03

hr
Réponses : 28

Si je comprend bien, la majorité des gens installent Chrome, donc volontairement un splendide spyware sur leur machine. Si encore c’était Chromium, pourquoi pas, mais non…

#16 Re : -1 »  Firefox : second navigateur le plus utilisé en France ? » Le 27/08/2014, à 20:13

hr
Réponses : 28
love2hate a écrit :

Je sais pas si sa a changer mais au *debut* de chromium le *spyware* de google etait encore dans le code ... Me sembler que chromiun, c'etait  en gros le logo et nom qui etait changer pas que deposer. (A note que je pas fait recherche depuis, je peut me tromper)

Chromium est un logiciel libre qui est la base sur laquelle Google greffe quelques fonctionnalités et ses fonction de collectage d’informations. Chromium n’est donc pas un nettoyage de Chrome mais c’est plutôt Chrome qui est une pollution extension propriétaire de Chromium.

#17 Re : -1 »  aspire t120 probleme d'affichage. » Le 08/07/2014, à 12:47

hr
Réponses : 1

Je suis tombé par hasard sur ton fil parce que j’ai depuis peu exactement la même configuration, Aspire T120 et Radeon 9200 SE.
Je n’ai aucun problème d’affichage. Quelle version d’Ubuntu veux-tu installer ?
En principe Ubuntu ne passe pas sur cette carte graphique, j’ai donc installé Xubuntu 14.04.

Tu dis avoir essayé en live, quelle version ? Les anciennes versions d’Ubuntu passaient sur la Radeon 9200 SE mais plus depuis 12.04 ou 12.10 (je ne suis plus très sûr de la version mais dans ces eaux-là).

#18 Re : -1 »  sauvegarde » Le 10/06/2014, à 17:27

hr
Réponses : 88

Surtout il y a un problème très clair à utiliser un format exotique comme NTFS : si on essaye de cloner un compte, les attributs et droits seront perdus. Pour une simple recopie de document, ça peut faire l’affaire mais dès qu’on veut faire une sauvegarde un peu solide, ça ne va plus du tout. Sans parler des problèmes de vitesse dont parle melixgaro.
Le fait que NTFS soit disponible dans gparted tient surtout à la nécessité de faire des partitions exploitables alternativement par Windows et Ubuntu pour un système en double boot. En dehors de ça, c’est un format qui n’est pas adapté du tout à un système Linux.

#19 Re : -1 »  sauvegarde » Le 10/06/2014, à 17:35

hr
Réponses : 88
pitoufo3 a écrit :

alors,
pour hr la commande sudo chmod -R 777 /media/pitoufo3/disque-externe ne fait rien, a moins toujours que je ne vois pas ce qu'elle doit faire?

Elle ne fait rien de visible à l’œil nu, en tout cas. Mais si la commande a bien été exécutée, as-tu essayé de copier un fichier sur ton disque ?

Sinon, avais-tu un message d’erreur à la suite de ta commande ?
Le mot de passe a bien été pris en compte ? Ou as-tu aussi eu un message d’erreur après l’avoir saisi + touche Entrée

Si tu ne sais plus s’il y a eu un message d’erreur ou lequel, tu peux très bien refaire la commande, ça ne pose pas de problème.

#20 Re : -1 »  sauvegarde » Le 21/06/2014, à 18:22

hr
Réponses : 88

Je veux bien reprendre mais il faut d’abord que tu répondes à mes questions pour refaire le point clairement :
- As-tu plusieurs comptes ou seulement le tien sur cette machine ?
- Ton disque externe est-il bien vide ?
- Veux-tu simplement sauvegarder de temps en temps des fichiers ou faire régulièrement une opération de sauvegarde du ou des comptes en entier, fichiers et configurations compris ?
- As-tu essayé la ligne de commande que je t’avais indiquée (qui commence par sudo chmod etc.) et si oui, quelle est la ligne de commande que tu as tapée et quelle a été la réponse (ou son absence de réponse) après que tu l’aies tapée ?

#21 Re : -1 »  [Résolu] Partition créée avec Gparted: propriétaire, point de montage. » Le 10/06/2014, à 16:00

hr
Réponses : 55
Tamarou a écrit :

Parce que tu n'as donc jamais ajouté une partition à fstab.

Si mais j’ai bêtement copié ce que l’installation avait faite elle-même avec mes autres partitions… Pas cherché plus loin. En tout les cas, les premières fois que j’ai joué avec ça, j’y allais sur la pointe des pieds et je n’aurais jamais eu l’idée de prendre des initiatives sur ce genre de choses ! Quoiqu’il en soit, comme tout nouveau disque se met là, pourquoi pas ? Où les places-tu ? Dans /mnt ? Il y a déjà des trucs dedans que j’sais même pas c’que c’est.
Froidement à la racine du disque ? Bon, je sèche.

Tamarou a écrit :

il y a check-file-integrity

Oui, mais il n'est pas dans les dépôts. Son utilisation n'est pas dans la logique du reste de la distribution. Mais bon ...

Pas idéal, c’est certain, mais faute de mieux…

#22 Re : -1 »  [Résolu] Partition créée avec Gparted: propriétaire, point de montage. » Le 10/06/2014, à 16:24

hr
Réponses : 55
tiramiseb a écrit :

le FHS, le standard qui régit l'organisation des fichiers, précise que /media est dédié aux volumes amovibles... Et les normes, si on ne les respecte pas, on termine par faire de la merde...

Vu comme ça…

Par exemple, si tu as un disque (ou une partition) dédié(e) à tes musiques, pourquoi ne pas les placer directement dans /home/<ton_utilisateur>/Musique ?

Pourquoi pas, effectivement.

#23 Re : -1 »  [Résolu] Partition créée avec Gparted: propriétaire, point de montage. » Le 10/06/2014, à 17:48

hr
Réponses : 55
agensbur a écrit :

Par exemple, si tu as un disque (ou une partition) dédié(e) à tes musiques, pourquoi ne pas les placer directement dans /home/<ton_utilisateur>/Musique ?

Je suis votre topic en paysan du Danube, mais n'est-on pas très grossièrement là dans un des types de variations qui font qu'une distrib peut finir par dévier sensiblement d'une autre - même au sein d'une même famille  - et loin de moins l'idée de faire peur à hr qui a des capacités d'absorption qui force le respect :-)

Je pense que ce n’était pas une préconisation générale à implémenter. Juste un exemple très particulier de jeu avec les points de montage. Du moment qu’on sait ce qu’on fait, on peut toujours bidouiller sur sa machine pour se faciliter la vie. Mais on peut aussi se la compliquer si on préfère.

hr, dit l’éponge…

#24 Re : -1 »  [Résolu] Partition créée avec Gparted: propriétaire, point de montage. » Le 10/06/2014, à 20:48

hr
Réponses : 55
Tamarou a écrit :

Je viens de regarder le sujet de pitoufo3, mais il me semble que la commande chmod ne porte pas sur le vrai nom de son disque. Il a recopié tel quel.

Je suis allé voir. Quelle pagaye. Comment expliquer à quelqu’un sans pouvoir savoir ce qu’il fait, je ne sais pas. Devant sa machine ce serait si simple de lui expliquer et pour lui de se rendre compte que ça n’a rien de compliqué… Je ne suis pas disponible du tout ce soir et vraiment très peu demain, je ne crois pas pouvoir l’aider.