Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  Achat disque dur NAS - Serveur WEB » Le 12/07/2014, à 11:26

__fabrice
Réponses : 3

Bonjour à tous,

Je suis dev web. et je voudrais me prendre un disque NAS pour installer un Ubuntu, ceci pour "simuler" un serveur web dédié (même si j'ai le localhost évidemment).
Est-ce possible ?

Quelles sont les bonnes solutions, les bons disques, les bonnes marques, etc ?
Puis-je aussi m'en servir de disque de stockage, de backup ?

Il n'y aura qu'un seul pc connecté dessus (déjà en ubuntu)

Merci à tout
Fabrice

#1 Re : -1 »  Achat disque dur NAS - Serveur WEB » Le 15/07/2014, à 09:45

__fabrice
Réponses : 3

Merci pour ces infos smile

#2 -1 »  No apache MPM package installed, après upgrade de php 5.5 » Le 17/03/2014, à 17:50

__fabrice
Réponses : 4

Salut à tous,

J'ai un soucis plutot... tres ennuyeux smile
Je suis sur la 12.04, et j'ai voulu passer de php 5.3 à 5.4. Bon, en fait, cela m'a installé la php 5.5, mais bon, jusque là smile

J'ai donc fait :

sudo add-apt-repository ppa:ondrej/php5

puis avec apt-get un :

- update
- upgrade
- et dist-upgrade.

Tous a bien marché, sauf qu'Apache ne fonctionne plus sad :

No apache MPM package installed

Voici ma config du coup :

$ dpkg -l |grep apache2

ii  apache2-utils                                                          2.2.22-1ubuntu1.4                                   utility programs for webservers
ii  apache2.2-bin                                                          2.2.22-1ubuntu1.4                                   Apache HTTP Server common binary files
rc  apache2.2-common                                                       2.2.22-1ubuntu1.4                                   Apache HTTP Server common files
rc  libapache2-mod-php5                                                    5.3.28-1~dotdeb.0                                   server-side, HTML-embedded scripting language (Apache 2 module)
$ aptitude show -D apache2-mpm-prefork
Paquet : apache2-mpm-prefork                  
État: non installé
Version : 2.4.7-1+sury.org~precise+1
Priorité : supplémentaire
Section : oldlibs
Responsable : Debian Apache Maintainers <debian-apache@lists.debian.org>
Architecture : i386
Taille décompressée : 22,5 k
Dépend: apache2 (= 2.4.7-1+sury.org~precise+1)
Fournit: httpd, httpd-cgi
Description : transitional prefork MPM package for apache2
 This is a transitional package to apache2 for users of apache2-mpm-prefork and can be safely removed after the installation is complete.

php -v me renvoi çà (bon, j'ai une erreur de openssl, mais j'avais çà avant, donc c pas çà :

$ php -v
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20121212/curl.so' - /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4) in Unknown on line 0
PHP 5.5.9-1+sury.org~precise+1 (cli) (built: Feb 13 2014 15:48:37) 
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies

Quelqu'un pourrait me filer un coup de main svp ?

Merci
Fabrice

#3 Re : -1 »  No apache MPM package installed, après upgrade de php 5.5 » Le 17/03/2014, à 18:33

__fabrice
Réponses : 4

Et si j'essaie d'installer apache-prefork :

apache2-mpm-prefork: Depends: apache2 (= 2.4.7-1+sury.org~precise+1) mais la version 2.4.7-1+sury.org~precise+1 va être installée

#4 Re : -1 »  No apache MPM package installed, après upgrade de php 5.5 » Le 17/03/2014, à 23:31

__fabrice
Réponses : 4

Je suis du genre à jouer avec les PPA. C'était dans un lien d'un site très (re)connu. Je n'ai rien de bien transcendant en même temps.

Et oui, voyant ce bronx, j'ai fait le ménage :

sudo apt-get remove apache2* ph5*

et

sudo apt-get purge apache2* ph5*

et

sudo apt-get autoremove apache2* php5* --purge

Maintenant en réinstallant  apache2 :

Les paquets suivants ont des dépendances non satisfaites :

 apache2 : Dépend: apache2-mpm-worker (= 2.2.22-1ubuntu1.4) mais ne sera pas installé ou
                    apache2-mpm-prefork (= 2.2.22-1ubuntu1.4) mais ne sera pas installé ou
                    apache2-mpm-event (= 2.2.22-1ubuntu1.4) mais ne sera pas installé ou
                    apache2-mpm-itk (= 2.2.22-1ubuntu1.4) mais ne sera pas installé
           Dépend: apache2.2-common (= 2.2.22-1ubuntu1.4) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Que faire ? sad

#5 -1 »  Upgrade de svn + version d'ubuntu » Le 15/09/2013, à 10:43

__fabrice
Réponses : 1

Salut,

J'ai la version 1.6.17 de svn (avec ubuntu 12.04.3 LTS); J'ai besoin de passer en 1.8.2.
J'ai bien fait un update et upgrade d'Ubuntu mais cela ne marche pas.

Je comprends que la version de svn est liée à celle d'ubuntu. Mais en fesant des upgrade d'ubuntu, on ne passe pas aux versions plus récentes ?

Merci
Fabrice

#6 -1 »  Postfix & thunderbird : port 587 et erreur chez certains FAI » Le 19/03/2013, à 10:38

__fabrice
Réponses : 1

Salut à tous,

Je viens de suivre le tuto sur postfix (à la lettre), et à priori tout marche, merci smile

Par contre, lorsque j'envoie un mail chez free, c ok, mais sur gmail ou yahoo, je ne le reçois jamais. Dans les log, j'ai çà :

Mar 19 09:24:13 localhost postfix/smtpd[9542]: 4F1466803AD: client=localhost[127.0.0.1], sasl_method=PLAIN, sasl_username=fabrice
Mar 19 09:24:13 localhost postfix/cleanup[9545]: 4F1466803AD: message-id=<514820AC.3000300@blabla.fr>
Mar 19 09:24:13 localhost postfix/qmgr[9479]: 4F1466803AD: from=<contact@blabla.fr>, size=5515, nrcpt=1 (queue active)
Mar 19 09:24:13 localhost postfix/smtpd[9542]: disconnect from localhost[127.0.0.1]
Mar 19 09:24:44 localhost postfix/smtp[9546]: connect to gmail-smtp-in.l.google.com[173.194.67.27]:25: Connection timed out
Mar 19 09:24:44 localhost postfix/smtp[9546]: connect to gmail-smtp-in.l.google.com[2a00:1450:400c:c05::1a]:25: Network is unreachable
Mar 19 09:24:44 localhost postfix/smtp[9546]: connect to alt1.gmail-smtp-in.l.google.com[2a00:1450:4008:c01::1a]:25: Network is unreachable
Mar 19 09:25:14 localhost postfix/smtp[9546]: connect to alt1.gmail-smtp-in.l.google.com[173.194.69.27]:25: Connection timed out
Mar 19 09:25:44 localhost postfix/smtp[9546]: connect to alt2.gmail-smtp-in.l.google.com[74.125.143.27]:25: Connection timed out
Mar 19 09:25:44 localhost postfix/smtp[9546]: 4F1466803AD: to=<monmail@gmail.com>, relay=none, delay=91, delays=0.18/0.01/91/0, dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[74.125.143.27]:25: Connection timed out)
Mar 19 09:32:07 localhost postfix/qmgr[9479]: 901D76802EF: from=<contact@blabla.fr>, size=5521, nrcpt=1 (queue active)
Mar 19 09:32:07 localhost postfix/qmgr[9479]: 4F1466803AD: from=<contact@blabla.fr>, size=5515, nrcpt=1 (queue active)
Mar 19 09:32:08 localhost postfix/smtp[9727]: connect to gmail-smtp-in.l.google.com[2a00:1450:400c:c05::1a]:25: Network is unreachable
...
...
Mar 19 09:34:35 localhost postfix/smtp[9726]: connect to mx-eu.mail.am0.yahoodns.net[188.125.69.79]:25: Connection timed out
Mar 19 09:35:05 localhost postfix/smtp[9726]: 4641E681891: to=<fabrice_blabla@yahoo.fr>, relay=none, delay=60, delays=0.14/0/60/0, dsn=4.4.1, status=deferred (connect to mx-eu.mail.am0.yahoodns.net[77.238.177.9]:25: Connection timed out)

( j'ai juste modifié les noms des emails, c'est tout)

Donc, c'est yahoo et gmail (j'ai pas testé d'autres), çà marche pas

Ensuite, j'ai essayé de mettre le port 587, en changeant cette ligne dans /etc/postfix/master.cf :

submission inet n      -       n       -       -       smtpd

, et j'ai une erreur d'authentification (saslauthd est actif) et dans Thunderbird, j'ai testé avec STARTTLS et SSL/TLS

Pourquoi ? smile

#7 -1 »  Package "rsyslogd" qui plante... » Le 05/06/2013, à 13:26

__fabrice
Réponses : 0

Bonjour,

J'ai ce message d'erreur (et la console plante, impossible de faire CTRL+C) :

Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd

.. dans plusieurs commandes.

Du coup, j'ai essaye de la supprimer (+ apt-get remove + apr-get purge). Et ensuite, de faire un clean, autoremove et autoclean, un update et un upgrade. J'ai aussi utiliser "Tweak" pour faire le ménage.
Et piur finir un

dpkg --configure -a

... mais rien n'y fait. J'ai toujours ce message d'erreur dans la commande précédente et lors de l'installation aved apt-get.

C'est normal et/ou grave docteur ? smile

Merci
Fabrice

#8 -1 »  Utiliser XP depuis Ubuntu (avec VirtualBox ?) » Le 11/03/2013, à 16:07

__fabrice
Réponses : 11

Bonjour,

Je souhaiterai, pour utiliser IE8, avoir acces à un XP déja installé (qui collabore avec Ubuntu). Je ne veux pas utiliser Wine, mais avoir une fenêtre XP virtuel (installé) comme si j'y étais.

J'ai testé VirtualBox, mais je ne comprends pas très bien si il peut faire çà et comment le faire. Car je ne veux installer XP avec la virtualBox, mais utiliser mon XP existant depuis Ubuntu.

On peut faire çà ?

Merci
Fabrice

#9 Re : -1 »  Utiliser XP depuis Ubuntu (avec VirtualBox ?) » Le 12/03/2013, à 09:55

__fabrice
Réponses : 11

Salut,

Merci pour ces réponses... mais cela me semble un peu délicat.

Le tuto de Luigifab est impressionnant, bravo. Encore une fois, cela reste un peu risqué smile... je vais faire autrement.

a+

Fabrice

#10 Re : -1 »  Utiliser XP depuis Ubuntu (avec VirtualBox ?) » Le 12/03/2013, à 15:50

__fabrice
Réponses : 11

Salut,

Je viens de tester kvm et mon CPU ne supporte pas la virtualisation (kvm-ok).

Donc, voilà, je sais à quoi m'en tenir smile

Fab

#11 Re : -1 »  Utiliser XP depuis Ubuntu (avec VirtualBox ?) » Le 12/03/2013, à 15:55

__fabrice
Réponses : 11

Et je peux lancer mon IE dans mon XP existant ? , comme dans VirtualBox ?

F.

#12 Re : -1 »  Utiliser XP depuis Ubuntu (avec VirtualBox ?) » Le 12/03/2013, à 16:06

__fabrice
Réponses : 11

Ok, merci, je vais voir. Mais çà me parait bien compliqué smile. Je teste déjà IE8 avec IE10 (qui simule IE8 en mode IE8), cela me semble bon.

IETESTER est bidon et plus qu'instable.

J'aurai voulu tester avec le vrai IE8, mais bon.

#13 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 05/02/2013, à 15:55

__fabrice
Réponses : 31

J'ai çà :

Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                          Version                      Description
+++-============================-============================-========================================================================
ii  libcurl3                     7.22.0-3ubuntu4              Multi-protocol file transfer library (OpenSSL)

#14 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 05/02/2013, à 16:47

__fabrice
Réponses : 31
ldd  /usr/lib/x86_64-linux-gnu/libcurl.so.3
ldd: /usr/lib/x86_64-linux-gnu/libcurl.so.3: Aucun fichier ou dossier de ce type

Je n'ai pas de dossier x86_64-linux-gnu

#15 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 05/02/2013, à 16:48

__fabrice
Réponses : 31

J'ai çà à la place :

ldd  /usr/lib/i386-linux-gnu/libcurl.so.3
/usr/lib/i386-linux-gnu/libcurl.so.3: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.3)
	linux-gate.so.1 =>  (0xb7728000)
	libidn.so.11 => /usr/lib/i386-linux-gnu/libidn.so.11 (0xb7679000)
	liblber-2.4.so.2 => /usr/lib/i386-linux-gnu/liblber-2.4.so.2 (0xb766a000)
	libldap_r-2.4.so.2 => /usr/lib/i386-linux-gnu/libldap_r-2.4.so.2 (0xb7617000)
	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb760e000)
	libgssapi_krb5.so.2 => /usr/lib/i386-linux-gnu/libgssapi_krb5.so.2 (0xb75d0000)
	libssl.so.1.0.0 => /lib/i386-linux-gnu/libssl.so.1.0.0 (0xb7583000)
	libcrypto.so.1.0.0 => /lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xb73df000)
	librtmp.so.0 => /usr/lib/i386-linux-gnu/librtmp.so.0 (0xb73c4000)
	libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xb73ae000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb7204000)
	libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xb71ec000)
	libsasl2.so.2 => /usr/lib/i386-linux-gnu/libsasl2.so.2 (0xb71d0000)
	libgssapi.so.3 => /usr/lib/i386-linux-gnu/libgssapi.so.3 (0xb7192000)
	libgnutls.so.26 => /usr/lib/i386-linux-gnu/libgnutls.so.26 (0xb70ce000)
	libgcrypt.so.11 => /lib/i386-linux-gnu/libgcrypt.so.11 (0xb7049000)
	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb702e000)
	libkrb5.so.3 => /usr/lib/i386-linux-gnu/libkrb5.so.3 (0xb6f5f000)
	libk5crypto.so.3 => /usr/lib/i386-linux-gnu/libk5crypto.so.3 (0xb6f36000)
	libcom_err.so.2 => /lib/i386-linux-gnu/libcom_err.so.2 (0xb6f31000)
	libkrb5support.so.0 => /usr/lib/i386-linux-gnu/libkrb5support.so.0 (0xb6f28000)
	libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb6f23000)
	/lib/ld-linux.so.2 (0xb7729000)
	libheimntlm.so.0 => /usr/lib/i386-linux-gnu/libheimntlm.so.0 (0xb6f1b000)
	libkrb5.so.26 => /usr/lib/i386-linux-gnu/libkrb5.so.26 (0xb6e97000)
	libasn1.so.8 => /usr/lib/i386-linux-gnu/libasn1.so.8 (0xb6df2000)
	libhcrypto.so.4 => /usr/lib/i386-linux-gnu/libhcrypto.so.4 (0xb6dbd000)
	libroken.so.18 => /usr/lib/i386-linux-gnu/libroken.so.18 (0xb6da7000)
	libtasn1.so.3 => /usr/lib/i386-linux-gnu/libtasn1.so.3 (0xb6d95000)
	libp11-kit.so.0 => /usr/lib/i386-linux-gnu/libp11-kit.so.0 (0xb6d82000)
	libgpg-error.so.0 => /lib/i386-linux-gnu/libgpg-error.so.0 (0xb6d7d000)
	libkeyutils.so.1 => /lib/i386-linux-gnu/libkeyutils.so.1 (0xb6d79000)
	libwind.so.0 => /usr/lib/i386-linux-gnu/libwind.so.0 (0xb6d50000)
	libheimbase.so.1 => /usr/lib/i386-linux-gnu/libheimbase.so.1 (0xb6d41000)
	libhx509.so.5 => /usr/lib/i386-linux-gnu/libhx509.so.5 (0xb6cf9000)
	libsqlite3.so.0 => /usr/lib/i386-linux-gnu/libsqlite3.so.0 (0xb6c54000)
	libcrypt.so.1 => /lib/i386-linux-gnu/libcrypt.so.1 (0xb6c23000)

#16 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 05/02/2013, à 16:50

__fabrice
Réponses : 31
ldd  /usr/lib/i386-linux-gnu/libcurl
libcurl.a                libcurl-gnutls.so.4      libcurl.la               libcurl-nss.so.4         libcurl.so               libcurl.so.4
libcurl-gnutls.so.3      libcurl-gnutls.so.4.2.0  libcurl-nss.so.3         libcurl-nss.so.4.2.0     libcurl.so.3             libcurl.so.4.2.0

#17 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 05/02/2013, à 17:42

__fabrice
Réponses : 31
ldd  /usr/lib/i386-linux-gnu/libcurl.so.4
/usr/lib/i386-linux-gnu/libcurl.so.4: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)
	linux-gate.so.1 =>  (0xb776e000)
	libidn.so.11 => /usr/lib/i386-linux-gnu/libidn.so.11 (0xb76bf000)
	liblber-2.4.so.2 => /usr/lib/i386-linux-gnu/liblber-2.4.so.2 (0xb76b0000)
	libldap_r-2.4.so.2 => /usr/lib/i386-linux-gnu/libldap_r-2.4.so.2 (0xb765d000)
	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb7654000)
	libgssapi_krb5.so.2 => /usr/lib/i386-linux-gnu/libgssapi_krb5.so.2 (0xb7616000)
	libssl.so.1.0.0 => /lib/i386-linux-gnu/libssl.so.1.0.0 (0xb75c9000)
	libcrypto.so.1.0.0 => /lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xb7425000)
	librtmp.so.0 => /usr/lib/i386-linux-gnu/librtmp.so.0 (0xb740a000)
	libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xb73f4000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb724a000)
	libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xb7232000)
	libsasl2.so.2 => /usr/lib/i386-linux-gnu/libsasl2.so.2 (0xb7216000)
	libgssapi.so.3 => /usr/lib/i386-linux-gnu/libgssapi.so.3 (0xb71d8000)
	libgnutls.so.26 => /usr/lib/i386-linux-gnu/libgnutls.so.26 (0xb7114000)
	libgcrypt.so.11 => /lib/i386-linux-gnu/libgcrypt.so.11 (0xb708f000)
	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb7074000)
	libkrb5.so.3 => /usr/lib/i386-linux-gnu/libkrb5.so.3 (0xb6fa5000)
	libk5crypto.so.3 => /usr/lib/i386-linux-gnu/libk5crypto.so.3 (0xb6f7c000)
	libcom_err.so.2 => /lib/i386-linux-gnu/libcom_err.so.2 (0xb6f77000)
	libkrb5support.so.0 => /usr/lib/i386-linux-gnu/libkrb5support.so.0 (0xb6f6e000)
	libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb6f69000)
	/lib/ld-linux.so.2 (0xb776f000)
	libheimntlm.so.0 => /usr/lib/i386-linux-gnu/libheimntlm.so.0 (0xb6f61000)
	libkrb5.so.26 => /usr/lib/i386-linux-gnu/libkrb5.so.26 (0xb6edd000)
	libasn1.so.8 => /usr/lib/i386-linux-gnu/libasn1.so.8 (0xb6e38000)
	libhcrypto.so.4 => /usr/lib/i386-linux-gnu/libhcrypto.so.4 (0xb6e03000)
	libroken.so.18 => /usr/lib/i386-linux-gnu/libroken.so.18 (0xb6ded000)
	libtasn1.so.3 => /usr/lib/i386-linux-gnu/libtasn1.so.3 (0xb6ddb000)
	libp11-kit.so.0 => /usr/lib/i386-linux-gnu/libp11-kit.so.0 (0xb6dc8000)
	libgpg-error.so.0 => /lib/i386-linux-gnu/libgpg-error.so.0 (0xb6dc3000)
	libkeyutils.so.1 => /lib/i386-linux-gnu/libkeyutils.so.1 (0xb6dbf000)
	libwind.so.0 => /usr/lib/i386-linux-gnu/libwind.so.0 (0xb6d96000)
	libheimbase.so.1 => /usr/lib/i386-linux-gnu/libheimbase.so.1 (0xb6d87000)
	libhx509.so.5 => /usr/lib/i386-linux-gnu/libhx509.so.5 (0xb6d3f000)
	libsqlite3.so.0 => /usr/lib/i386-linux-gnu/libsqlite3.so.0 (0xb6c9a000)
	libcrypt.so.1 => /lib/i386-linux-gnu/libcrypt.so.1 (0xb6c69000)

PS : Merci de passer autant de temps smile

#18 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 05/02/2013, à 18:42

__fabrice
Réponses : 31

Voilà :

ls -l /usr/lib/php5/20090626+lfs/curl.so
-rw-r--r-- 1 root root 71172 janv. 19 00:50 /usr/lib/php5/20090626+lfs/curl.so
cat  /etc/php5/cli/conf.d/curl.ini
; configuration for php CURL module
extension=curl.so
curl -V
curl: /lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /usr/lib/i386-linux-gnu/libcurl.so.4)
apt-cache policy curl
curl:
  Installé : 7.22.0-3ubuntu4
  Candidat : 7.22.0-3ubuntu4
 Table de version :
 *** 7.22.0-3ubuntu4 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     7.21.6-3ubuntu3.2 0
         -1 http://security.ubuntu.com/ubuntu/ oneiric-security/main i386 Packages

#19 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 06/02/2013, à 09:41

__fabrice
Réponses : 31

Moi aussi sad...

Je peux pas désinstaller CURL et la libssl et tout réinstaller après ?. Y'a une manip de précise à faire ?
Merci
Fab

#21 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 07/02/2013, à 10:36

__fabrice
Réponses : 31

Salut,
J'ai fait çà, et cela ne répare pas le problème sad. De plus, pourquoi cela supprimé beaucoup de lib... ? :

sudo apt-get remove --purge curl php5-curl libssl-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  php-fpdf libjs-jquery-ui php-mail-mime libgnutlsxx27 ckeditor libtasn1-3-dev libkadm5clnt-mit8 libgpg-error-dev librtmp-dev comerr-dev
  libgcrypt11-dev libphp-adodb libregexp-assemble-perl libkrb5-dev libapt-pkg-perl libldap2-dev libphp-pclzip libgssrpc4 libgnutls-dev
  krb5-multidev libp11-kit-dev libgnutls-openssl27 libkadm5srv-mit8 php5-geoip libkdb5-6 liblist-moreutils-perl libnusoap-php libidn11-dev
  libconfig-file-perl php-mail-mimedecode

et

sudo apt-get autoremove --purge
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  ckeditor* comerr-dev* krb5-multidev* libapt-pkg-perl* libconfig-file-perl* libgcrypt11-dev* libgnutls-dev* libgnutls-openssl27*
  libgnutlsxx27* libgpg-error-dev* libgssrpc4* libidn11-dev* libjs-jquery-ui* libkadm5clnt-mit8* libkadm5srv-mit8* libkdb5-6* libkrb5-dev*
  libldap2-dev* liblist-moreutils-perl* libnusoap-php* libp11-kit-dev* libphp-adodb* libphp-pclzip* libregexp-assemble-perl* librtmp-dev*
  libssl-doc* libtasn1-3-dev* php-fpdf* php-mail-mime* php-mail-mimedecode* php5-geoip* shtool*

Y'a pas un problème là ?
Fabrice

#22 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 21/02/2013, à 16:10

__fabrice
Réponses : 31

Salut,

Merci pour ta solution, mais j'avais déjà essayé. Lorsque je fais çà, la logithèque Ubuntu s'ouvre (évidemment smile ), et j'ai ce message d'erreur :

casse le paquet existant "libssl-dev" à cause de sa dépendance libssl1.0.0 (=1.0.0e-23ubuntu4.6)

Mais si je passe effectivement par :

sudo wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.0.0_1.0.1-4ubuntu5.3_i386.deb

et

sudo dpkg -i libssl1.0.0_1.0.1-4ubuntu5.3_i386.deb

çà marche smile... étonnant, mais çà marche... merci smile

Fabrice

#23 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 21/02/2013, à 16:54

__fabrice
Réponses : 31

Sauf que... sauf que smile, la libssl-dev est maintenant en erreur  sad :

vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.

Les paquets suivants contiennent des dépendances non satisfaites :

 libssl-dev : Dépend: libssl1.0.0 (= 1.0.0e-2ubuntu4.7) mais 1.0.1-4ubuntu5.3 est installé

On peut enlever la libssl-dev ??, je crois pas. Ou l'as ré installer/linker sur la 1.0.1, ici  ? :

sudo apt-get install libssl-dev=1.0.1-4ubuntu5

Fab

#24 Re : -1 »  Impossible d'utiliser CURL, erreur OPEN_SSL_1.0.1 » Le 01/03/2013, à 12:46

__fabrice
Réponses : 31

Pas de réponse sur le soucis de la libssl-dev maintenant ? smile

Merci
F.