Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 Re : -1 »  [Résolu] Extraire l'audio d'une vidéo .flv » Le 27/12/2010, à 14:14

Link Mauve
Réponses : 20
casseta a écrit :

En console, essayez ffmpeg2theora, qui avec son option « --novideo » permet de convertir très facilement le son de n'importe quelle vidéo (ou fichier son) en Ogg Vorbis.

J'ai essayé mais j'obtiens un fichier ogv, comment le convertir en ogg ou wav?

Réponse un peu tardive… ^^'
Ce fichier à l'extension ogv est déjà un Ogg, comme tu peux le voir avec la commande file, il suffit donc de le renommer pour obtenir un fichier à l'extension ogg.

#1 Re : -1 »  Ella : projet de logiciel d'animation Flash & SVG pour Linux » Le 27/12/2010, à 16:26

Link Mauve
Réponses : 2505

Bonjour,

Je souhaite compiler Ella, mais je rencontre quelques problèmes qui m'en empêchent.

Le premier un simple warning de configure, « --enable-maintainer-mode ».

Le suivant, pas bien grave mais assez gênant pour certaines personnes, est que le autogen.sh détecte mal la version de gettext, le Makefile du dossier po est donc faux. Le message d'erreur est :

*** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version 0.17 but the autoconf macros are from gettext version 0.18

J'ai donc s/0\.17/0.18/ le fichier po/Makefile après sa génération, pour continuer à compiler.

Le dernier, bien plus grave, est l'impossibilité de compiler certains fichiers (comme callbacks.c ou lecteur.c) qui demandent swfdec-gtk. (Je n'ai pas l'intention d'utiliser flash pour éditer du SVG, donc installer ce paquet est hors de question.)

J'ai un peu regardé le code, et j'ai l'impression que swfdec-gtk est utilisé à l'affichage. C'est un bug qu'il faudrait corriger, au moins le rendre optionnel.

J'ai également remarqué que vous n'utilisez aucune bibliothèque XML pour la génération du SVG, vous faites tout avec des printf. Cette méthode, plus simple pour des fichiers simples, est une horreur à maintenir sur le long terme.

L'indentation des fichiers que j'ai lu est totalement inconsistante, un programme comme indent vous la corrigerait et rendrait le code beaucoup plus agréable à lire.

Merci d'avance, j'ai hâte d'essayer cet éditeur de SMIL ! (Le premier WYSIWYG que je connaisse !)

#2 Re : -1 »  Ella : projet de logiciel d'animation Flash & SVG pour Linux » Le 27/12/2010, à 16:40

Link Mauve
Réponses : 2505

D'accord, j'attendrai que vous ayez fini de rendre swfdec-gtk optionnel pour retester Ella, en attendant je continuerai d'utiliser le combo SVG-Edit et Vim pour créer des animations SMIL.

#3 Re : -1 »  Ella : projet de logiciel d'animation Flash & SVG pour Linux » Le 27/12/2010, à 16:50

Link Mauve
Réponses : 2505

Ah, aussi, il n'y a personne sur votre chan IRC. L'IM permet un contact plus direct, et certaines personnes (dont je fais partie) préfèrent ce moyen à un forum. Vous devriez au moins idler sur votre chan au cas où un utilisateur curieux passerait par là. Et un salon XMPP serait le bienvenu aussi, afin de laisser le choix du protocole aux utilisateurs.

#4 Re : -1 »  Ella : projet de logiciel d'animation Flash & SVG pour Linux » Le 27/12/2010, à 17:20

Link Mauve
Réponses : 2505

J'ai créé ella@muc.linkmauve.fr, vous pouvez le rejoindre avec n'importe quel client qui supporte la XEP-0045. smile
Si j'ai du temps, je mettrai en place un bot pour faire le pont entre le salon et le chan.

#5 -1 »  Installation/suppression impossible par la logithèque » Le 27/12/2010, à 20:37

Link Mauve
Réponses : 17

Bonjour,

La logithèque ne permet plus l'installation ou la suppression de logiciels, l'appui sur le bouton ne déclenche rien, même pas la demande de mot de passe de PolicyKit. apt-get, aptitude, synaptic, etc. fonctionnent ; le problème provient uniquement de la logithèque.
C'est une Ubuntu 10.10, upgradée depuis une 9.10 puis une 10.04.
Comment réparer ça ?

Merci d'avance. smile

#6 Re : -1 »  Installation/suppression impossible par la logithèque » Le 27/12/2010, à 22:04

Link Mauve
Réponses : 17

Je l'avais déjà fait, et ça n'avait rien changé. Je viens de réessayer et toujours pareil.
(Le paquet s'appelle software-center.)

#7 Re : -1 »  Installation/suppression impossible par la logithèque » Le 27/12/2010, à 23:18

Link Mauve
Réponses : 17

Ah, j'ai une erreur dans la console :

2010-12-27 23:17:37,174 - softwarecenter.backend - WARNING - _on_trans_error: org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name':  ':1.64'}): org.debian.apt.install-or-remove-packages

#8 Re : -1 »  Installation/suppression impossible par la logithèque » Le 28/12/2010, à 01:10

Link Mauve
Réponses : 17

J'ai essayé ça, sans beaucoup d'espoir, mais mon problème persiste. L'utilisateur qui veut installer est dans le bon groupe, il a le droit d'avoir plus de pouvoirs.

#9 Re : -1 »  Installation/suppression impossible par la logithèque » Le 30/12/2010, à 17:48

Link Mauve
Réponses : 17

guapitao, tu peux lancer la commande software-center dans un terminal, et me dire si tu as le même warning que dans le message №4 ? Si oui on a le même problème, dû à PolicyKit.

De manière générale, la première étape quand un logiciel graphique ne fonctionne pas comme il faut est de le lancer dans un terminal, pour voir ce qu'il affiche.

#10 Re : -1 »  Installation/suppression impossible par la logithèque » Le 31/12/2010, à 02:24

Link Mauve
Réponses : 17

Bon, ton erreur est beaucoup plus parlante, c'est simplement que ton utilisateur n'a pas le droit d'installer un logiciel. Il ne doit pas être dans le groupe administrateur, ou bien il manque des droits d'installation dans polkit.

Ah, un kit de polices et PolicyKit n'ont absolument rien à voir. Rien. (Et aucune chance que ça ralentisse le système.)

#11 Re : -1 »  Chromium et HTML5 » Le 27/12/2010, à 20:44

Link Mauve
Réponses : 19

coucou123, tu devrais tester Firefox 4.0, son interface a été pas mal changée depuis Firefox 3.x.
Tu peux aussi faire un clic droit sur n'importe quelle barre à un endroit vide et virer les barres qui ne te servent à rien, personnaliser les boutons et barres affichées, etc.
Il existe aussi des extensions pour retirer la barre des menus, mais Firefox 4.0 le fait par défaut.

#12 Re : -1 »  Chromium et HTML5 » Le 27/12/2010, à 22:08

Link Mauve
Réponses : 19

J'ai 192 Mio de RAM, pas de swap, et des centaines d'onglets. Firefox est le navigateur graphique le plus léger ici, il consomme à peu près 80 Mio de RAM. Sur d'autres ordinateurs avec beaucoup plus de mémoire il est effectivement plus gourmand, mais toujours proportionnellement à la quantité totale.
Par contre, quand j'avais essayé Chromium, il se faisait tuer par l'OoM Killer au bout d'à peine une dizaine d'onglets…

Tu as combien de Mio de RAM ?

#13 Re : -1 »  openfire et le serveur à serveur » Le 05/01/2010, à 23:09

Link Mauve
Réponses : 10

Tu as bien paramétré les enregistrements SRV de ton DNS pour XMPP ? Ils doivent être de la forme suivante, en remplaçant domaine.tld par ton domaine :
_xmpp-server._tcp.domaine.tld. 3600 IN SRV 5 0 5269 domaine.tld.
_xmpp-client._tcp.domaine.tld. 3600 IN SRV 5 0 5222 domaine.tld.

Le premier sert au s2s, le second au c2s.

Et je te recommande Prosody, qui est un serveur Jabber très léger, écrit en Lua, qui évolue très vite. OpenFire est écrit en Java, et est donc de ce fait extrêmement lourd.

#14 Re : -1 »  openfire et le serveur à serveur » Le 06/01/2010, à 17:29

Link Mauve
Réponses : 10

Pour les enregistrements SRV, c’est dans ton DNS (Bind, ou autre).

Sinon, tu as pensé à autoriser la création de compte dans Prosody ? Dans le fichier de configuration, il suffit de passer la variable allow_registration à true. Tu peux aussi créer le compte directement depuis le serveur, ça te permet d’avoir une modération a priori et non a posteriori des comptes créés.

Si tu as des problèmes avec, je te conseille de venir poser tes questions sur le MUC prosody@conference.prosody.im (en anglais, et après avoir bien évidement cherché dans la doc avant tongue).

#15 Re : -1 »  openfire et le serveur à serveur » Le 06/01/2010, à 22:49

Link Mauve
Réponses : 10

Donc c’est sûrement du côté de ton registrar qu’il faut que tu te tournes.

Prosody, c’est juste un conseil, parce que Java c’est lourd… Très lourd. J’ai utilisé Ejabberd (écrit en Erlang) pendant plusieurs années, et Prosody est extrêmement léger en comparaison.

#16 Re : -1 »  Vidéo, quels outils utilisés. » Le 24/03/2010, à 19:01

Link Mauve
Réponses : 1

Bonjour Alph,

1) Pour copier sur mon disque dur un DVD créé avec DeVeDe (je n’ai pas de DVD du commerce pour tester), je passe par mplayer en ligne de commande pour faire un dump du DVD, puis je transcode en Theora avec ffmpeg2theora :

mplayer -dumpstream -dumpfile dvd.vob dvd://
ffmpeg2theora --optimize dvd.vob

Normalement, tu devrais obtenir un fichier dvd.ogv qui contient ton film, prêt à être posté sur le Web dans une balise video. smile

Je te conseille de jouer avec les options de ffmpeg2theora pour obtenir une qualité et un poids qui te conviendraient mieux.

2) Je n’ai pas de caméra DV, mais ffmpeg2theora a un exemple d’une telle utilisation :

dvgrab - | ffmpeg2theora -f dv -x 352 -y 288 -o output.ogv -

Pour le montage, essaie PiTiVi (disponible dans les dépôts et préinstallé dans Ubuntu 10.04). Il permet aussi de convertir en Theora pour un usage sur le Web.

#17 Re : -1 »  Last days - trailer 2 HD VOST - 911 » Le 05/01/2010, à 22:51

Link Mauve
Réponses : 81

Et on pourrait avoir la vidéo originale, non recompressée par dailymotion ? Si c’est trop gros passe par ed2k ou crée un torrent.

#18 Re : -1 »  Probléme javascript epiphany » Le 05/01/2010, à 23:55

Link Mauve
Réponses : 2

JavaScript en Java sont deux langage totalement différents. Tu devrais changer le titre de ton sujet, ça risque d’attirer plus de monde. Sinon, pour ton problème, je ne peux pas t’aider je n’utilise pas Epiphany.

#19 Re : -1 »  Je suis repassé sous windows ! » Le 05/01/2010, à 19:40

Link Mauve
Réponses : 48

Et le mien, duquel je poste cette réponse, est un G3 qui a à peu près 12 ans. Je ne l’ai pas eu à sa sortie, mais il y a trois ans, et il tourne parfaitement sous ArchLinuxPPC. tongue

Alors les conneries sur la durée de vie « normale » d’un ordinateur, voilà quoi. hmm

Il suffit de bien estimer ses besoins, et de prendre une machine adaptée. À part pour lire du Theora 1080p ou faire du transcodage vidéo, je n’ai jamais eu besoin de mieux.

#20 Re : -1 »  firefox freeze lors de l'envoi de fichier - résolu » Le 05/01/2010, à 23:51

Link Mauve
Réponses : 2

Essaie en mode sans échec de Firefox (sans rien réinitialiser) et, si c'est pareil, avec un nouveau profil (sans supprimer l'actuel).
Si nécessaire, plus d'explications ici: http://www.geckozone.org/forum/viewtopic.php?p=326044#p326044.

#21 Re : -1 »  Firefox + Adobe reader... » Le 05/01/2010, à 23:37

Link Mauve
Réponses : 1

Il existe l’extension mozplugger pour Firefox (disponible dans les dépôts) qui permet d’afficher n’importe quel programme dans le navigateur. Ça fonctionne plutôt bien avec Evince, donc pas besoin de pourrir ta machine avec des binaires proprio. wink

#22 Re : -1 »  1474 megapixels » Le 21/12/2009, à 15:59

Link Mauve
Réponses : 47

Déjà, en grepant « http » dans le fichier swf fourni après l’avoir décompressé, je trouve ces quelques adresses :
http://gc.cs.cmu.edu/gigapan/PruNorthEast2.qtree
http://www.cs.cmu.edu/~globalconn
http://www.efran.org

Mais aucune ne semble contenir les images haute résolutions qu’on serait supposés voir.

Je fais essayer de désassembler le fichier swf pour voir ce qu’il contient, mais c’est assez illisible l’asm flash™, donc je ne garantis rien…

#23 Re : -1 »  1474 megapixels » Le 21/12/2009, à 16:19

Link Mauve
Réponses : 47

Donc en fait, si ils avaient utilisé un logiciel libre comme OpenLayers (utilisé notemment pour la carte du site principal d’OpenStreetMap) plutôt qu’une merde proprio en flash™, tout le monde aurait pu la voir leur image, sans avoir besoin de faire du reverse engineering. smile

#24 Re : -1 »  1474 megapixels » Le 21/12/2009, à 16:24

Link Mauve
Réponses : 47

C’est comme si c’était fait ! big_smile