Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  pas de grub apres installation kubuntu 14.04 » Le 22/07/2014, à 08:56

ikewdu
Réponses : 33

Salut,

La réponse de l'Africain est la bonne. Aucune commande ne permettra d'avoir "directement" un dual boot, car tu as deux formats de disques différents:

sda: Ubuntu installé sur un disque en mode mbr (bios traditionnel... autrement dit legacy)
sdb: W7 installé en mode gpt (bios uefi et donc pas de mbr dans ce format)

Perso, je déconseille une conversion en gpt via boot-repair qui fait pas mal de dégâts. Le plus simple est de refaire l'installation d'ubuntu, en vérifiant bien dans le bios que le cd boote en uefi. Si grub s'affiche en noir et blanc au démarrage du cd, c'est bon. Tu convertis le disque au format gpt avec gparted et tu installes. Ton W7 sera alors reconnu par Grub.

#1 Re : -1 »  Impossible d'accéder à Windows7 en dual boot avec ubuntu » Le 16/07/2014, à 08:22

ikewdu
Réponses : 24

Salut,

Les lenovo possèdent en principe un clé spéciale appelée "one key" qui permet de démarrer en obtenant des options.

onekey

Je n'ai plus en tête toutes ces options, mais regarde l'une d'elles propose un menu de démarrage (uefi compris). En revanche, pour le secure boot c'est peu probable si c'est bien W7 qui est installé.

Enfin, si ton Ubuntu fonctionne, tu n'as pas besoin de booter sur une clé pour installer boot-repair, puisque tu peux l'installer directement. Tu peux aussi nous donner tout simplement une capture gpaterd ou le résultat de plusieurs commandes (c'est moins complet, mais ça donne une idée tout de même):

sudo parted -l
blkid
sudo efibootmgr /v

Selon moi (mais je peux me tromper), le problème vient de la version d'ubuntu que tu as choisie. La version 12.04 est déjà ancienne, et l'uefi y était encore mal géré.

#2 Re : -1 »  Impossible d'accéder à Windows7 en dual boot avec ubuntu » Le 16/07/2014, à 22:38

ikewdu
Réponses : 24

Re,

Au vu de la capture faite avec gparted, ta partition windows est à un format inconnu. Sans doute passée en raw... Ca explique ton message d'erreur. Il faudrait voir avec testdisk si tu peux la récupérer.

#3 Re : -1 »  Impossible d'accéder à Windows7 en dual boot avec ubuntu » Le 18/07/2014, à 20:21

ikewdu
Réponses : 24

Re,

Le souci, c'est que c'est la partition windows qui est "inconnue. Donne-moi une capture d'écran de ce qu'affichent "analyse" et "quick search" dans testdisk.

#4 Re : -1 »  Impossible d'accéder à Windows7 en dual boot avec ubuntu » Le 20/07/2014, à 08:32

ikewdu
Réponses : 24

Tu as fait les photos trop tôt :

Installe testdisk, tu exécutes, puis

- No Log
- Tu choisis ton disque dur
- Intel
- Analyse (une capture d'écran du résultat)
- Quick Search (une autre capture d'écran du résultat)

#5 Re : -1 »  Impossible d'accéder à Windows7 en dual boot avec ubuntu » Le 21/07/2014, à 09:05

ikewdu
Réponses : 24

Re,

J'aurais préféré 2 captures d'écran. Une pour analyse, une pour quick search. Le but est de voir les différences. Car là, ça ne sert pas à grand chose. Et si celle-ci est le résultat d'un quick search, tu peux déjà passer à l'étape suivante et proposer le résultat d'un deeper search (donc 3 captures), car rien ne correspond à ta structure actuelle.

#6 Re : -1 »  Impossible d'accéder à Windows7 en dual boot avec ubuntu » Le 22/07/2014, à 18:34

ikewdu
Réponses : 24

Re,

Tu confirmes que ce sont bien les captures de "Analyse" et "quick search". Si oui, il faut passer par "deeper search", car la structure des deux captures ne correspond pas à ce que montre gparted.

Les partitions Windows et "recovery" sont déclarées "Linux" dans le "quick search"... là, on ne peut rien faire pour l'instant. Passe à la dernière étape.

#7 Re : -1 »  Problème avec Grub, tripleboot - Rapport » Le 27/07/2014, à 08:25

ikewdu
Réponses : 3

Salut,

Je vois tout de même une petite bizarrerie dans le boot-info (mais elle ne me semble pas suffisante pour expliquer le problème)

Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of  the same hard drive for core.img. core.img is at this location and looks in partition 112

Puis, plus loin:

Grub2 (v1.99) is installed in the boot sector of sda3 and looks at sector 587479144 of the same hard drive for core.img. core.img is at this location and looks in partition 112

Bref, tu as (semble-t-il) installé grub deux fois, à deux endroits différents. La réinstallation via super Grub disk semble donc nécessaire, et peut-être sera-t-il utilise de passer par un sudo dpkg-reconfigure grub-pc  pour bien finaliser la manipulation.

#8 Re : -1 »  Problème boot après installation - Rapport boot repair » Le 22/07/2014, à 08:12

ikewdu
Réponses : 58

Salut,

La technologie "raid" pose pas mal de problèmes à gparted (et visiblement à Ubuntu). Vois cette conversation qui confirme mon propos :

http://forum.ubuntu-fr.org/viewtopic.php?id=1233271

Quant à la séquence de démarrage (j'avoue n'avoir pas tout relu), dis-moi si, quand tu "forces le démarrage" sur Ubuntu, une entrée Windows est proposée et si elle fonctionne.

#9 Re : -1 »  Problème boot après installation - Rapport boot repair » Le 22/07/2014, à 18:53

ikewdu
Réponses : 58

Re,

Personnellement, une chose me gêne dans ton installation (mais je n'ai jamais été confronté au cas du raid, donc ce que je dis est peut-être stupide). Tout me semble supposé devoir fonctionner, mais des choses clochent:

 Entre 474 et 496:
RAID set "isw_cecjeehbjh_RAID0IMSVolume" already active
dmraid -sa -c: isw_cecjeehbjh_RAID0IMSVolume
boot-repair is executed in live-session (Ubuntu 14.04 LTS, trusty, Ubuntu, x86_64)
ls: cannot access /home/usr/.config: No such file or directory
CPU op-mode(s):        32-bit, 64-bit
BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
[dmraid -sa -c] isw_cecjeehbjh_RAID0IMSVolume
[dmraid -sa -c] isw_cecjeehbjh_RAID0IMSVolume
[dmraid -sa -c] isw_cecjeehbjh_RAID0IMSVolume
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdc1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
mount -t ntfs-3g -o remove_hiberfile /dev/sdc1 /mnt/boot-sav/sdc1
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdc1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
mount /dev/sdc1 : Error code 14
mount -r /dev/sdc1 /mnt/boot-sav/sdc1
ls: cannot access /sys/block/mapper/isw_cecjeehbjh_RAID0IMSVolume/: No such file or directory
507: Disk /dev/mapper/isw_cecjeehbjh_RAID0IMSVolume3 doesn't contain a valid partition table

Pas mal d'erreur, et en outre, ton W8 semble en hibernation, et non à l'arrêt complet.

534 sfdisk: ERROR: sector 0 does not have an msdos signature
535 /dev/sdb: unrecognized partition table type
536 No partitions found

Le disque sdb possède des entrées ms-dos (mbr) ce qui n'est pas apprécié par le système.

639 Error: Invalid argument during seek for read on /dev/sda

Erreurs de lecture sur sda.

691 à 693
Error: The backup GPT table is not at the end of the disk, as it should be.
This might mean that another operating system believes the disk is smaller.
Fix, by moving the backup to the end (and removing the old backup)?

Un problème de backup dans la table de partitions.

Je m'arrête là. Trop d'erreurs sont signalées. Visiblement sdb (de quoi s'agit-il ?) n'est pas identifié... et même les deux autres disques semblent générer des problèmes. Je te conseillerais bien de désactiver le raid, mais ça devient dangereux pour ton W8. Donc, je n'irai pas plus loin, ceci dépassant mes compétences.

#10 Re : -1 »  Problème de GRUB après installation d'Ubuntu 14.04 » Le 21/07/2014, à 20:05

ikewdu
Réponses : 3

Salut,

Ton pc a probablement un bios uefi de classe 2 (possibilité d'activer uefi et legacy - ou "launch csm").

Ton disque sdc est au format gpt (donc le pc fonctionne en uefi avec lui). Ton W7, en l'occurrence sdb, est au format mbr (donc le pc fonctionne au format legacy avec lui). Les deux formats ne savent pas vraiment cohabiter et il faut

- soit réinstaller ton W7 en uefi (un peu galère mais faisable).
- soit réinstaller ton ubuntu 14.04 en legacy (il faudra bien vérifier dans le bios que le DVD boote au format legacy).

PS. Le disque sda est également au format gpt (uefi).

#11 Re : -1 »  Problème de GRUB après installation d'Ubuntu 14.04 » Le 22/07/2014, à 18:57

ikewdu
Réponses : 3

Re,

Regarde dans le bios si tu peux désactiver complètement l'UEFI. Sinon, tu cherches les options avancées de boot dans le bios (ou le menu de démarrage) et tu lances ton live-cd dans le mode qui convient. Avec gparted tu recrées une table de partition "ms-dos" et ça doit rouler.

#12 Re : -1 »  Ubuntu 13.10 refuse que je démarre sous windows 8 et/ou windows 7 » Le 20/07/2014, à 08:42

ikewdu
Réponses : 14

Salut,

Ton problème est apparemment assez clair. Tu as cette situation (confirme-moi que j'ai bien compris)

Disque 1: Windows 7 et Windows 8.
Disque 2: Ubuntu

Si oui, sache qu'Ubuntu utilise un "lanceur" nommé grub, qui tend toujours à s'installer sur une disque possédant des partitions actives. Ici, il s'est installé non pas sur le disque 2 mais sur le disque 1. Ce qui explique le message d'erreur lorsque tu retires le disque Ubuntu.

Ca se répare assez facilement (si tes Ws n'ont pas été supprimés), mais comme tu parles de W8, il faut qu'on vérifie si ton PC fonctionne en mode traditionnel (legacy et disque au format mbr) ou en mode uefi (disque au format gpt). Pour le savoir, il faut que tu nous donnes le résultat des commandes:

sudo parted -l   (L minuscule)
sudo fdisk -l
sudo blkid

Précise-moi si tu possèdes le DVD de W7 ou de W8. On en a besoin pour rétablir la situation.

#13 Re : -1 »  Ubuntu 13.10 refuse que je démarre sous windows 8 et/ou windows 7 » Le 20/07/2014, à 17:13

ikewdu
Réponses : 14

Re,

Débranche ton disque dur Ubuntu. Démarre avec le DVD W7 ou W8, choisis l'option "réparer l'ordinateur", et choisis l'invite de commandes. Là, tu vas taper ceci:

bootrec /fixmbr
bootrec /fixboot

Tes  Windows devraient redémarrer. En revanche, Ubuntu ne démarrera plus. On s'en occupera dans un second temps. Je pense que comme tu utilises déjà un double boot (W7 / W8), le plus simple serait d'utiliser le lanceur windows (bootmgr) pour avoir un triple boot. Donc, il faudra réinstaller grub, mais autrement.

#14 Re : -1 »  Ubuntu 13.10 refuse que je démarre sous windows 8 et/ou windows 7 » Le 20/07/2014, à 21:06

ikewdu
Réponses : 14

Re,

Maintenant, il faut réparer / réinstaller Grub pour que le disque Ubuntu sache où le trouver. Ici, on a deux possibilités:

1. Soit l'installer dans le mbr du disque ubuntu: avantage, le disque est autonome. Inconvénient: tu auras un menu (Grub /windows) puis un second menu (W7 /W8)

2. L'installer dans la partition Linux elle-même: avantage, tu n'auras qu'un seul menu W7/W8/ubuntu ; inconvénient: il faudra utiliser bootmgr, et ton ubuntu dépendra toujours du bon fonctionnement de Windows.

Dans les deux cas, il faudra booter sur le live-cd ubuntu et restaurer, voire réinstaller grub. O verra ça demain selon le choix que tu auras fait.

#15 Re : -1 »  Ubuntu 13.10 refuse que je démarre sous windows 8 et/ou windows 7 » Le 21/07/2014, à 00:30

ikewdu
Réponses : 14

Re,

Démarre sur le live-cd Ubuntu. Commence par ceci :

sudo fdisk -l 

Vérifie que le résultat est toujours:

Disk /dev/sda: 1500.3 GB, 1500301910016 bytes
255 têtes, 63 secteurs/piste, 182401 cylindres, total 2930277168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0xed1e85b1

Périphérique Amorçage  Début         Fin      Blocs    Id. Système
/dev/sda1   *        2048   976758783   488378368    7  HPFS/NTFS/exFAT
/dev/sda2       976758784  1953515519   488378368    7  HPFS/NTFS/exFAT
/dev/sda3      1953515520  2930276351   488380416    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 160.0 GB, 160000000000 bytes
255 têtes, 63 secteurs/piste, 19452 cylindres, total 312500000 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0xeede9d79

Périphérique Amorçage  Début         Fin      Blocs    Id. Système
/dev/sdb1       292020224   312498175    10238976   82  partition d'échange Linux / Solaris
/dev/sdb2            2048   292019626   146008789+  83  Linux

Si oui, on va installer grub sur sdb2 en suivant l'une des procédures suivantes.

1. Le plus simple est d'utiliser boot-repair

Tu l'installes ainsi (point 1, pc connecté à Internet):

http://doc.ubuntu-fr.org/boot-repair

Puis tu choisis les options avancées, et tu prends réinstaller grub, et tu choisis de forcer l'installation dans sdb2, qui est ta partition racine.

http://doc.ubuntu-fr.org/lib/exe/fetch. … 333371.png

2. Sinon, on va s'inspirer de la procédure avec chroot pour réinstaller grub (partie 3.7):

http://doc.ubuntu-fr.org/tutoriel/comme … aurer_grub

sudo mount /dev/sdb2 /mnt 
for i in /dev /dev/pts /sys; do sudo mount -B $i /mnt$i; done 
sudo mount -t proc /proc /mnt/proc 
sudo chroot /mnt /bin/bash  
mount -a  
apt-get install grub-pc  
update-grub 

Ici, on change:

grub-install --force /dev/sdb2

On reprend le tuto :

umount -a
sudo umount /mnt/{dev/pts,dev,sys,proc}
sudo umount /mnt
sudo update-grub

3. Procédure finale (commune, quel que soit le choix entre 1 ou 2)

Si tout ça s'est passé correctement, grub est au bon endroit. Il ne restera plus qu'à démarrer sous Windows, ajouter l'entrée ubuntu dans le menu de démarrage grâce au logiciel easybcd, en suivant ce qui est proposé ici (point 3.4)

http://doc.ubuntu-fr.org/tutoriel/comme … ec_bootmgr

Après ça, tu dois avoir un triple boot dirigé par le lanceur de Windows. Si l'entrée ubuntu conduit à un autre menu, on n'aura plus qu"à le masquer. On verra une fois arrivés là.

#16 Re : -1 »  [Résolu] Double amorçage Ubuntu/Windows 7 instable » Le 18/07/2014, à 07:33

ikewdu
Réponses : 14

Salut,

Perso, je pencherais plutôt pour un problème de carte graphique. Si ça démarre correctement plusieurs fois, et qu'au bout d'un certain temps, ça plante, on peut penser à une surchauffe. D'autant que ce que tu indiques ressemble pas mal à des artefacts, phénomène bien connu lorsque les cartes graphiques sont malades. Tu devrais réinitialiser le mbr (pour écarter la piste ubuntu) et faire des démarrages multiples sous Windows. Si le phénomène se reproduit, tu seras fixé. Si ce n'est pas le cas, on pourra imaginer que ton Linux gère mal ta carte graphique (pilote, ou accélération graphique) et tu n'auras plus qu'à essayer une version "xubuntu", moins exigeante, pour voir si elle réagit mieux.

#17 Re : -1 »  [Résolu] Double amorçage Ubuntu/Windows 7 instable » Le 18/07/2014, à 12:30

ikewdu
Réponses : 14

Re

Babdu89 a écrit :

Je parviens à amorcer sans problème 5 fois sous Windows mais au bout de la sixième, écran mauve et traits blancs, etc.

Je répète... aucune raison logicielle ne peut expliquer un tel phénomène. Une fois sur deux, admettons, et encore. Seul un problème matériel justifie cette situation (pilote, carte graphique...)

#18 Re : -1 »  Problème partition lors de l'installation Ubuntu 14.04 » Le 16/07/2014, à 19:15

ikewdu
Réponses : 34

Salut,

Perso, une chose m'étonne... il démarre ce windows? A ta place, je commencerais par convertir ce disque dynamique en disque de base. C'est faisable avec pas mal de logiciels (testdisk ou autres "partitionneurs")

Par exemple :
http://www.commentcamarche.net/forum/af … ue-de-base

Ceci à faire après avoir sauvegardé les données, bien sûr. Ensuite, il faudra en effet supprimer une partition pour pouvoir installer. Moi, je supprimerais le bootloader (la première partition) qu'on peut facilement intégrer à la partition Windows (quelques petites manips suffisent....).

#19 Re : -1 »  Problème partition lors de l'installation Ubuntu 14.04 » Le 18/07/2014, à 07:19

ikewdu
Réponses : 34

Re

Maxime a écrit :

Bon mauvaise nouvelle... L'installation s'est super bien passé et Ubuntu à demandé à redémarrer mais je ne peut plus démarer sur ubuntu ni Windows...

ikewdu a écrit :

Perso, une chose m'étonne... il démarre ce windows? A ta place, je commencerais par convertir ce disque dynamique en disque de base

A nouveau, je suis fort surpris que Windows ait démarré alors que le disque était dynamique. Si tu ne l'as pas reconverti en disque de base, ta situation ne me surprend pas.

#20 Re : -1 »  error : no such partition (GRUB) » Le 16/07/2014, à 08:28

ikewdu
Réponses : 9

Salut,

Ca veut dire que ton disque dur est en priorité dans le bios, et que tu bootes dessus. Acronis à formaté les partitions, mais n'a pas supprimé grub qui est probablement dans le mbr. Ou alors, ta clé est mal faite et comme elle n'est pas bootable, le bios enchaîne sur la ligne suivante, et boote sur le disque dur.

Lorsque tu es passé en legacy, branche ton usb, et redémarre dans le bios. Cherche l'option boot et modifie l'ordre pour démarrer sur usb. Tu réessaies. Si ça ne se lance pas, clé mal faite.

#21 Re : -1 »  error : no such partition (GRUB) » Le 16/07/2014, à 12:57

ikewdu
Réponses : 9

Re

Tu utilises soit Linux usb live creator, soit unetbootin, soit rufus. Tous les trois savent très bien générer une clé bootable à partir d'une image iso Ubuntu.

#22 Re : -1 »  error : no such partition (GRUB) » Le 16/07/2014, à 15:21

ikewdu
Réponses : 9

Re,

J'avais mal lu. Si le bios est passé en legacy, que l'ordre du boot est bon, que la clé est bien faite, et que le pc continue de booter sue le disque dur, alors on entre dans la quatrième dimension.

#23 Re : -1 »  error : no such partition (GRUB) » Le 16/07/2014, à 19:01

ikewdu
Réponses : 9

Je voulais simplement dire que c'est impossible:
Mode legacy + bios bien réglé pour l'usb en priorité + clé bootable bien faite = démarrage obligatoire

#24 Re : -1 »  error : no such partition (GRUB) » Le 16/07/2014, à 22:35

ikewdu
Réponses : 9

Re,

Pas de quoi. Bye.