Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 Re : -1 »  Envoi inhabituel des données » Le 11/05/2016, à 22:18

lgmdmdlsr
Réponses : 9

Adiu.

120 Kio/s en permanence upload, ça fait beaucoup.

Ça peut être un service de cloud (genre Dropbox, Owncloud, etc.).

Sinon, une lecture et application de la documentation ubuntu-fr concernant le trafic réseau peut être utile.

#1 Re : -1 »  Envoi inhabituel des données » Le 11/05/2016, à 23:40

lgmdmdlsr
Réponses : 9

Si le port en question est bien 33445, la  commande

sudo lsof -i :33445

devrait renvoyer le nom du processus à analyser.

#2 Re : -1 »  Envoi inhabituel des données » Le 12/05/2016, à 20:11

lgmdmdlsr
Réponses : 9

Ben, il y a qtox (pid 2488) qui fonctionne. S'il est là de façon intempestive, un bon

kill 2488
kill -9 2488

lui expliquera qu'il doit la fermer ... Ceci dit, dans cette hypothèse il faudra investiguer pour savoir comment il se lance.

Évidemment, si c'est l'utilisateur qui le lance, il ne faut pas s'étonner que qtox se mette à faire son travail O:-)

#3 Re : -1 »  [RESOLU]15.10 > 16.04 - Démarrage reste en console tty ne charge pas » Le 29/04/2016, à 08:22

lgmdmdlsr
Réponses : 15

Adiu. Si le serveur d'affichage graphique ne démarre pas, ça peut être délicat. C'est ce qui m'est arrivé, avec la saveur Mate d'Ubuntu. La solution que j'ai trouvée a consisté à supprimer les fichiers de configuration de x.org et de lightdm, et dans la foulée de réinstaller les paquets correspondants. Ah, en amont j'ai dégagé le paquet "upstart", qui semble créer des problèmes lors de la configuration de lightdm.

sudo systemctl stop lightdm
sudo apt-get purge upstart
sudo mv /etc/X11 /etc/X11.sauve
sudo apt-get install --reinstall $(dpkg -l|grep xserver|cut -f 3 -d " ")
sudo mv /etc/lightdm /etc/lightdm.sauve
sudo apt-get install --reinstall $(dpkg -l|grep lightdm|cut -f 3 -d " ")

suivi d'un redémarrage.

(édition : substitution de la commande d'arrêt par celle 100% pur systemd, pour faire plaisir aux intégristes de la conformité à la nouvelle norme - même si l'ancienne commande fonctionne aussi ...)

#4 Re : -1 »  [RESOLU]15.10 > 16.04 - Démarrage reste en console tty ne charge pas » Le 29/04/2016, à 15:01

lgmdmdlsr
Réponses : 15

Oui, Ubuntu 16.04 est passé à systemd. Mais, après que j'eusse fait la mise à niveau (14.0.4->16.04) , le vieux upstart était toujours présent. Le virer (par "apt-get purge upstart") n'est pas dangereux (je n'ai pas écrit d'éliminer systemd, par contre ...)

NB : la commande "service lightdm stop" fonctionne toujours, sûrement à titre de rétro-compatibilité ...

Édition : jojo81, ce serait une bonne chose de lire correctement le contenu des posts avant de critiquer ...

#5 Re : -1 »  [Résolu] Le système de paquets est cassé » Le 28/06/2014, à 11:17

lgmdmdlsr
Réponses : 21

Attention, les noyaux, comme les headers, ne sont pas que dans /boot ...

Si le problème constaté (trop de fichiers dans la partition) est dû à trop de noyaux installés, le tutoriel de tiramiseb devrait fonctionner.

PRÉCISION
Le problème est bien une saturation du NOMBRE de fichiers (df -i renvoie 100%) et non une saturation de l'espace (df -h ne renvoie pas 100 %).

Une fois qu'un peu de place est fait, il faut lancer la commande

sudo apt-get -f install

#6 Re : -1 »  [Résolu] Le système de paquets est cassé » Le 28/06/2014, à 12:30

lgmdmdlsr
Réponses : 21

La commande

echo $(dpkg -l | grep linux-i | cut -f 3 -d " ")

renvoie sur une même ligne l'ensemble des paquets des noyaux.

Il suffit ensuite de sélectionner la partie de ligne utile (i.e. tout sauf le dernier noyau et celui sans numéro), et de remplacer <blabla> par la sélection (rappel : copier en ligne de commande : Contrl+maj+C et coller : Contrl+maj+V).

NB : ensuite il faut faire pareil avec les headers, en remplaçant "linux-i" par "linux-h", et toujours en vérifiant bien ne ne pas éffacer la dernière version ...

#7 Re : -1 »  connecter une tablette Iconia A500 sur Ubuntu [résolu] » Le 11/12/2011, à 12:24

lgmdmdlsr
Réponses : 16

En complément d'information, avec Ubuntu 10.04, le paquet mtpfs ne fonctionne pas. Il faut récupérer la version 0.9.3 à la page :
ftp://ftp.ubuntu.com/ubuntu/pool/universe/m/mtpfs/ .

Avec une architecture i386, ça donne :

wget [url]ftp://ftp.ubuntu.com/ubuntu/pool/universe/m/mtpfs/mtpfs_0.9-3_i386.deb[/url]
sudo dpkg -i mtpfs_0.9-3_i386.deb
rm mtpfs_0.9-3_i386.deb

Redémarrer la machine semble nécessaire.

#8 Re : -1 »  connecter une tablette Iconia A500 sur Ubuntu [résolu] » Le 01/03/2012, à 12:04

lgmdmdlsr
Réponses : 16

Comme ça concenre un autre appareil que l'iconia a500, merci d'ouvrir un autre sujet, avec éventuellement celui-ci en référence.

#9 Re : -1 »  connecter une tablette Iconia A500 sur Ubuntu [résolu] » Le 16/01/2013, à 10:01

lgmdmdlsr
Réponses : 16

Adiu.

Après de nombreuses expériences, j'ai laissé tomber le protocole MTP, sauf s'il s'agit de transférer un petit fichier. En effet le transfert finit par planter tôt ou tard.

En conséquence, j'utilise soit un partage SAMBA, soit un serveur owncloud, soit la dropbox. Mais il est vrai que ça nécessite le réseau.

#10 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 15/09/2011, à 23:00

lgmdmdlsr
Réponses : 23

Si j'ai bien compris ce qui est écrit à :
http://www.gossamer-threads.com/lists/l … el/1263098

il y a eu un changement dans les dernières versions du noyau, qui empêche le pilote de compiler. Il faudrait visiblement bricoler le code source du pilote pour l'adapter aux exigences du noyau, mais là je ne suis pas compétent ...

Donc, à moins qu'un programmeur ne s'intéresse à la question, nous sommes condamnés à utiliser la Lucid si on veut utiliser le starboard.

MISE À JOUR
J'ai trouvé un patch pour fakemouse.c et lsadrv-main.c .
http://packages.altlinux.org/en/Sisyphu … un-def/get

En ouvrant le fichier kernel-modules-lsadrv-un-def-2.0.1-alt1.196612.1.src.rpm avec le gestionnaire d'archive, on trouve un fichier ioctl_and_mutex.patch

Après avoir copié ce fichier dans le répertoire du code source du pilote, et lancé la commande

patch -p1 < ioctl_and_mutex.patch

la compilation du pilote réussit.

Et là, en fait, comme je n'ai pas de Maverick ou de Natty ailleurs que dans une machine virtuelle, je ne peux tester si le pilote est fonctionnel. Appel aux volontaires testeurs !

#11 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 16/09/2011, à 16:55

lgmdmdlsr
Réponses : 23
Romtaz a écrit :
lgmdmdlsr a écrit :

Et là, en fait, comme je n'ai pas de Maverick ou de Natty ailleurs que dans une machine virtuelle, je ne peux tester si le pilote est fonctionnel. Appel aux volontaires testeurs !

Sous Natty le pilote se compile sans problème avec la manip ci-dessus big_smile , mais quand on branche le Tableau Blanc Interactif sur l'ordi, rien ne se passe ... mad

Je sais qu'avec la lucid, bien que le module soit chargé en mémoire dès la fin du make install, il faut redémarrer la machine pour que le TBI fonctionne. Il est possible qu'il en soit de même avec les versions ultérieures.

L'analyse du dmesg quand le TBI est branché peut être intéressante.

--
lgmdmdlsr

#12 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 17/09/2011, à 19:09

lgmdmdlsr
Réponses : 23

Déja, vérifier que le module est chargé.

lgmdmdlsr@ordi:~$ lsmod | grep lsadrv
lsadrv                 26779  0 

Ensuite

tail -f /var/log/messages

et brancher le TBI pour voir ce qui se passe.

#13 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 19/09/2011, à 12:49

lgmdmdlsr
Réponses : 23

Alors.

J'ai récupéré un ordi sur lequel j'ai installé la 11.04.

Le pilote compile, si on applique le patch (et sans bricoler le makefile).

Mais, l'attirail logiciel Starboard ne détecte pas le TBI. Donc, pas d'étalonnage, et le message "starboard n'est pas connecté" apparait.

Par contre l'utilisation comme souris du TBI fonctionne.

#14 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 20/09/2011, à 17:36

lgmdmdlsr
Réponses : 23
Romtaz a écrit :

Qu'entends-tu par : "L'utilisation comme souris du TBI fonctionne" ?

Parce que moi, rien du tout ...

Romtaz

Moi quand je touche le TBI avec le doigt, ça clique, et le pointeur bouge en suivant le doigt. Donc le pilote a l'air de fonctionner.

Romtaz a écrit :

Qu'entends-tu par : "L'utilisation comme souris du TBI fonctionne" ?


tail -f /var/log/messages

Mais quand je l'ai tapée, il m'a affiché un message d'erreur :

tail: impossible d'ouvrir «/var/log/messages» en lecture: Aucun fichier ou dossier de ce type

Romtaz

Eh oui, il semble que le fichier /var/log/messages n'existe pas dans la 11.04.

Par contre /var/log/kern.log semble avoir le même rôle.

#15 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 13/10/2011, à 08:52

lgmdmdlsr
Réponses : 23

Bonjour.
L'ordinateur sur lequel je faisais mes tests avec 11.04 est mort ...

Dans le journal, la ligne

Oct  6 09:20:46 xxx kernel: [  852.397492] usb 3-1: new full speed USB device using ohci_hcd and address 3

est-elle la seule qui apparaisse quand on branche le TBI, avec lsadrv chargé ?

#16 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 13/10/2011, à 21:42

lgmdmdlsr
Réponses : 23

Si je me souviens bien il est chargé au démarrage ...
Un coup de

lsmod|grep lsadrv

doit fournir la réponse.

Une précision : nous somme bien d'accord que le pilote est bien compilé après application du patch ioctl_and_mutex.patch , mais sans bricoler la ligne ARCH du makefile, par contre ...

#17 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 11/01/2012, à 19:09

lgmdmdlsr
Réponses : 23

Petit retour de la version 9.31 avec Lucid Lynx

L'installation du paquet starboardsoftware emeche le lancement d'applications utilisant les bibliothèques qt. Donc exit Avogadro, Stellarium, VirtualBox ... (non, en fait, exit starboardsoftware 9.31 ...)

#18 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 04/09/2012, à 09:46

lgmdmdlsr
Réponses : 23

Complément : ça fonctionne avec Ubuntu Precise Pangolin

Remarques pour la compilation du pilote
* garder le code source d'origine
* appliquer le patch  ioctl_and_mutex
* compiler et installer le pilote
* redémarrer la machine

Installer Starboard, afin d'avoir l'outil de calibrage du tableau numérique.

Lancer ledit outil.

C'est alors opérationnel.

#19 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 02/12/2012, à 16:59

lgmdmdlsr
Réponses : 23

Adiu.

SBS0931_LINUX_OCT2011.ZIP contient le logiciel Starboard, pas forcément le pilote, qui doit être recompilé à chaque mise-à-jour du noyau.

Pour le pilote lui-même, le mieux est de m'envoyer un courriel personnel afin que je l'envoie par le même chemin (comme aucune licence n'est fournie nulle part à ma connaissance je ne peux le poser dans un espace librement téléchargeable).
Le fichier fait 25,1 Ko.

#20 Re : -1 »  [Information] Tableau numérique Hitachi Starboard et Lucid Lynx » Le 02/12/2012, à 19:11

lgmdmdlsr
Réponses : 23

Le code source du pilote modifié compile sans problème sur toutes les machines testées.

Starboard n'est pas intéressant en lui-même, mais il faut l'installer pour pouvoir utiliser l'outil de calibration d'écran, qui est indispensable.

NB : ce n'est pas à moi d'envoyer le courriel personnel, mais à ceux qui demandent le fichier ... utiliser le lien de contact sur la page de mon profil du forum !
http://forum.ubuntu-fr.org/profile.php?id=12214

#21 -1 »  [ac100] 12.04, toshiba ac100 : réglage de la luminosité (gnome shell) » Le 27/06/2012, à 23:19

lgmdmdlsr
Réponses : 0

Bonjour, Adishats.

Une information qui peut intéresser celles et ceux qui utilisent le Toshiba ac-100.

Contexte : ac100-114, noyau 3.0.27-1-ac100 , environnement Gnome-shell.

Je me suis débrouillé pour faire fonctionner les touches F6 (lum -) et F7 (lum +) pour ajuster la luminosité de l'écran.

Tout d'abord, un script, qui doit être rendu exécutable :
/usr/local/bin/ac100changebrightness

#!/bin/bash

POINTEUR=/sys/devices/platform/pwm-backlight/backlight/pwm-backlight/brightness
VALEUR=$(cat $POINTEUR)
PAS=20

case $1 in
  "+" )
    NOUVEAU=$(($VALEUR+$PAS))
    if [ "$NOUVEAU" -le "255" ] 
      then
        echo "$NOUVEAU" > $POINTEUR
      else
        echo 255 > $POINTEUR
    fi
    ;;
  "-" )
    echo "-"
    NOUVEAU=$(($VALEUR-$PAS))
    if [ "$NOUVEAU" -ge "2" ] 
      then
        echo "$NOUVEAU" > $POINTEUR
      else
        echo 2 > $POINTEUR
    fi
    ;;
  * )
    echo "Syntax error"
esac

Ensuite, un ligne à ajouter à /etc/sudoers, avec la commande visudo :

ALL    ALL=NOPASSWD:/usr/local/bin/ac100changebrightness

(les paranoïaques y verront une légère brèche de sécurité)

Enfin, les raccourcis à créer dans "Applications" > "Outils système" > "Paramètres système" > "Clavier" > "Raccourcis personnels".
Pour F6, la commande est :

sudo ac100changebrightness -

Pour F7, la commande est :

sudo ac100changebrightness +

.

#22 -1 »  [Precise Pangolin et Maté] Problème avec le bouton Power » Le 24/04/2012, à 12:30

lgmdmdlsr
Réponses : 2

Adishats.

Situation : un netbook Asus (eeepc 1001px), initialement équipé d'Ubuntu 10.04, mis à niveau mi-mars vers la 12.04, les mises à jour étant faites.

L'environnement Maté a été mis en place en utilisant le dépôt idoine.

Quand le bouton Power est pressé, la boite de dialogue des choix possible s'affiche brèvement, mais visiblement le script /etc/apci/powerbtn.sh n'arrive pas à interagir avec Maté (et je ne m'y connais pas assez pour en déterminer la raison ...) ; la conséquence est que la commande d'arrêt de la machine est lancée.

Contournement : commenter la dernière ligne de /etc/apci/powerbtn.sh (celle qui lance halt) permet de retrouver un comportement correct.


NB : je poste ce souci dans ce forum, ne sachant pas, de Maté ou acpi, ce qui est responsable du souci.

#23 Re : -1 »  [Precise Pangolin et Maté] Problème avec le bouton Power » Le 24/04/2012, à 16:11

lgmdmdlsr
Réponses : 2

Ah, ce goinre de ressources qu'est Unity ...

Par contre, pas de souci avec Unity, donc il s'agit d'un souci d'interaction entre Maté et le scipt acpi ...

#24 -1 »  [Information 10.04] Mise à jour de Firefox et soucis de langue » Le 28/01/2012, à 23:46

lgmdmdlsr
Réponses : 0

Bonjour.

Dans la 10.04 le logiciel Firefox a été très récemment mis à jour de la version 3 à la version 9. Et, ma session étant dans une langue qui n'est plus supportée par Firefox, this f*cking b*stard speaks now in english.

Évidemment, du coup, je le veux en français, j'installe le paquet firefox-locale-fr. But, no way, english spoken only ... Bien que dans les paramètres de langue de Gnome j'aie spécifié le français avant l'anglais ...

Contournement : lancer firefox par la commande :

env LC_ALL=fr_FR.utf-8 firefox

et là, ô joie, Firefox consent enfin à me parler la France ...

Si ça peut aider quelqu'un ...

--
lgmdmdlsr