Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 -1 »  Rooter un galaxy note 4 (1er step) » Le 30/11/2014, à 15:36

lemoineo
Réponses : 1

Bonjour, venant d'hériter d'un Galaxy Note 4, en remplacement d'un Galaxy Note 1,
je voudrais le rooter (évidemment). Et n'ayant plus de pc sous windows à ma main,
je souhaite utiliser la procédure standard de root proposé par Chainfire, depuis linux.
donc en récupérant son fichier CF-Auto-Root-trelte-treltexx-smn910c.tar.md5 (pour un SM-N910C) issu du zip autoroot (utilisable sous windows)
donc j'installe les outils adb et je commence :
1- le galaxy en mode download (arret+home+vol-bas)
2- sous la console

sudo adb devices

et là... rien (List of devices attached ... vide)
Comme j'ai repris un 51.android.rules qui marchait pour ma nexus 7, je pense qu'il n'y a qu'un code pour le S910C a trouver ... ce qui n'est pas si simple
et un petit

sudo service udev restart

à relancer (peut-être).
Ce code est-il connu de la communauté (MODE=) ?
Olivier

PS. Ci-joint mon 51.android.rules

# Nexus 7
SUBSYSTEM=="usb", SYSFS{idVendor}=="18d1", MODE="0666"
# Galaxy Note
SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="6860"

#1 -1 »  Mariadb bouffe toute la ressource » Le 04/12/2014, à 21:08

lemoineo
Réponses : 1

Bon, je sais que la communauté connaissant Mysql est restreinte, et utilisant Mariadb encore plus.
J'avais des problèmes de souris, temps de réponse, pouvant aller jusqu'au blocage et nécessiter un reboot,
pour finalement constater que c'est le démon mysql qui bouffe tout ! 98 à 100% de la ressource CPU dans top !
J'ai nettoyé les journaux, tenté d'optimiser mes bases mysql, rien n'y fait et ceci, même sans requête particulière, même aucune pour être précis.
Qui a une idée ?
Là, je sèche.
Olivier

#2 -1 »  coupure session sous PhpMyadmin » Le 06/10/2014, à 14:33

lemoineo
Réponses : 4

Bonjour,
je développe une application PHP et MYSQL(mariadb) sous APACHE (jusque là, rien d'extraordinaire).
Afin de garder une cohérence entre les pages, j'utilise le mécanisme des sessions (là encore, normal).
Pour analyser mon développement, j'utilise PhpMyadmin (super ! tu nous fais languir).
Lorsque je ferme une connexion dans mon application (fermeture de session) et que je reviens dans PhMyadmin,
celui-ci m'indique que j'ai passé un timeout et qu'il faut me reconnecter !
pourtant, j'ai mis .. session.gc_maxlifetime = 6000
Quel rapport entre l'appli que je développe et PhpMyadmin ?
Bizarre, non ?
Olivier

#3 Re : -1 »  coupure session sous PhpMyadmin » Le 06/10/2014, à 14:39

lemoineo
Réponses : 4

Les fichiers des sessions sont bien indépendants pourtant ...

#4 Re : -1 »  coupure session sous PhpMyadmin » Le 10/10/2014, à 14:04

lemoineo
Réponses : 4

Merci de tes hypothèses, je ne sais pas bricoler directement les cookies, et sans doute c'est mieux.

#5 -1 »  Crash Apache2 ou Php ? ou Mysql ? Ou Firefox ? » Le 28/09/2014, à 10:19

lemoineo
Réponses : 2

Bonjour,
j'utilise Apache2 avec Php pour des développements de site.
Et depuis quelques temps, j'ai des sorties de session brutales ou ma page HTML (sous Firefox) se retrouve vide ..
bien sûr, les logs APACHE (/var/log/apache2/error.log), PHP (php_error.log), MYSQL (/var/log/mysql.log) sont vides,
seul, le log général se trouve affublé d'un message dont je ne comprends pas le sens, mais qui correspond à la seconde près.

Sep 28 10:42:44 croissyol dbus[710]: [system] Activating service name='org.freedesktop.hostname1' (using servicehelper)
Sep 28 10:42:44 croissyol kernel: [ 6274.100883] systemd-hostnamed[7786]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
Sep 28 10:42:44 croissyol dbus[710]: [system] Successfully activated service 'org.freedesktop.hostname1'

J'ai déjà posté un message de ce genre avant les vacances, sans réponse ...
Si déjà quelqu'un pouvait me renseigner sur ce qu'est ce service .... org.freedesktop.hostname1 ?

Merci
Olivier

#6 -1 »  [Résolu] Perte de session aléatoire » Le 25/05/2014, à 11:00

lemoineo
Réponses : 2

Bonjour,
j'observe assez fréquemment une perte de session aléatoire sous Php. Pas d'erreur directe,
Celà n'a peut-être rien à voir, mais je constate qu'à l'heure exacte du souci, j'ai un message dans syslog:

May 25 11:52:42 croissyol dbus[740]: [system] Activating service name='org.freedesktop.hostname1' (using servicehelper)
May 25 11:52:42 croissyol dbus[740]: [system] Successfully activated service 'org.freedesktop.hostname1'

J'ai demandé sur le forum ce que signifiait ce service, sans doute mal posé la question, pas eu de réponse :-(
Ce message semble habituel, c'est un service d'information sur la machine, qui fournit le nom de la machine,
pourquoi ce lance-t-il ? A ce moment ou ma session plante ?
Merci si vous avez une piste.

#7 Re : -1 »  [Résolu] Perte de session aléatoire » Le 28/06/2014, à 10:09

lemoineo
Réponses : 2

Je persiste sur l'incident, j'ai firefox qui bosse (qobuz) et ma session php est ouverte.
Et paf ! à l'occasion d'un changement de page, je me retrouve sous la page d'ouverture du serveur (http://localhost)
et dans le syslog.log, l'erreur incompréhensible (pour moi)

Jun 28 11:04:51 croissyol dbus[742]: [system] Activating service name='org.freedesktop.hostname1' (using servicehelper)
Jun 28 11:04:51 croissyol dbus[742]: [system] Successfully activated service 'org.freedesktop.hostname1'

Bien sûr, pas d'erreur php , histoire de bien rendre le truc cafouilleux ...
Même pas une piste ?

#8 Re : -1 »  [Résolu] Perte de session aléatoire » Le 28/06/2014, à 10:20

lemoineo
Réponses : 2

En fait , j'ai retrouvé le dernier php_errors.log (il y en avait un peu partout)
Et là, l'anomalie semble être résolu. Imagick est appelé 2 fois
Un xml package.xml concernant Imagick traînait d'une installation via pear qui avait dû planter.
Ca ne me dit pas pourquoi les php_errors s'installent un peu partout, mais au moins, je suis en terrain connu
Merci aux nombreuses personnes qui ont participé à ce post tongue
Olivier

#9 Re : -1 »  erreur mysql et apache » Le 25/05/2014, à 13:34

lemoineo
Réponses : 7

Copie déjà le contenu de /var/log/apache2/error.log
puisqu'une erreur est sans doute dans ce fichier ...

#10 Re : -1 »  erreur mysql et apache » Le 25/05/2014, à 13:52

lemoineo
Réponses : 7

Regarde le document
http://serverfault.com/questions/364424 … avicon-ico
c'est une erreur un peu secondaire (et facile à contourner). Par contre, je ne sais pas pourquoi elle apparaît.
Ce sont des produits (apache et mysql) qui fonctionnent très bien sur linux.
Peut-être pour remettre tout à zéro.

sudo apt-get remove --purge mysql
sudo apt-get remove --purge apache2

avant de réinstaller

sudo apt-get install apache2 mysql

C'est pour faire du php ?
A toi :-)
Olivier

#12 Re : -1 »  erreur mysql et apache » Le 25/05/2014, à 15:07

lemoineo
Réponses : 7

Tu as désinstallé d'abord ? Cela permet de faire le vide et d'être sûr de relancer une installation propre.

#13 -1 »  défaut sécurité ou installation "normale" » Le 11/05/2014, à 11:02

lemoineo
Réponses : 1

Bonjour,
je cherchais l'origine d'une panne php (rien à voir je pense)
et dans le /var/log/syslog le message suivant m'intrigue

May 11 11:47:52 barbatrol dbus[653]: [system] Activating service name='org.freedesktop.hostname1' (using servicehelper)
May 11 11:47:52 barbatrol dbus[653]: [system] Successfully activated service 'org.freedesktop.hostname1'

pourquoi un service distant serait nécessaire ? Et quel module s'en sert ?
Quelqu'un a une idée ?
Olivier

#14 -1 »  cette étiquette de partition GPT ne contient pas de partition d'amorça » Le 02/05/2014, à 08:28

lemoineo
Réponses : 2

"cette étiquette de partition GPT ne contient pas de partition d'amorçage BIOS"

Bonjour, revenant sur mon pc de vacances,
plus utilisé depuis l'été dernier,
j'y avais installé 2 partitions (une avec ubuntu, l'autre avec mint).
impossible de rebooter autrement que depuis un clé usb ou j'ai installé multisystem

après moult manip peu convaincantes, j'ai lancé grub2-rescue
et je me retrouve sous ma partition mint en état de marche,
mais sans pouvoir booter directement cette partition (ou l'autre).

l'utilitaire gparted ne semble pas accessible ni installable ????

j'install boot-repair et suivant les conseils de ce forum, j'ai lancé l'info du bios 
http://paste.ubuntu.com/7377949/
si quelqu'un peut m'aider à démeller tout ce fatras sans doute dû à ma précipitation et à mon incompétence sur les BMR et autre GPT
Merci
Olivier

#15 -1 »  Grub pas glop ! » Le 05/05/2014, à 11:13

lemoineo
Réponses : 1

Bonjour, j'ai deux disques , sur chacun plusieurs partitions

sudo blkid
/dev/sda1: LABEL="mint" UUID="ebb54abf-7bf4-4dc2-bf85-b791c99d8975" TYPE="ext4" 
/dev/sda2: LABEL="boulot" UUID="33faa1ae-fbc3-4b7b-854c-8da029772f2e" TYPE="ext4" 
/dev/sda3: UUID="e9239ffe-be9d-4891-b253-a73555e561dc" TYPE="swap" 
/dev/sdb1: LABEL="groslinux" UUID="628f2593-6fcb-4b31-9798-c0dcfe9ea310" TYPE="ext4" 
/dev/sdb3: UUID="fdbb3ee1-f7a7-4e6b-ba9b-337de5bd94c7" TYPE="swap" 
/dev/sdb2: UUID="f399f80e-94f1-46f9-a955-487577708e79" TYPE="ext4" 

Lors du boot sur le disque sda, je ne vois qu'un Os sur sda1 (mint),
pas l'autre sur l'autre disque, sdb sur la partition sdb2 (trusty)

sudo update-grub

me renvoie

sudo update-grub
[sudo] password for olivier: 
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.11-2-amd64
Found initrd image: /boot/initrd.img-3.11-2-amd64
  No volume groups found
done

Que signifie ce "no volume groups found" ?
Comment trouver un grub polyvalent ?
Merci
Olivier

#16 -1 »  php5-gd (undefined function imagecreatetruecolor()) » Le 18/04/2014, à 14:12

lemoineo
Réponses : 3

Bonjour,
j'ai un code (que j'ai écrit sous Windows) et qui utilise imagecreatetruecolor, donc la bibliothèque Gd.
conformément à la commande suggéré sur un post ,

php5 -m

ne ramène pas gd.
et un

sudo apt-get install php5-gd

ramène

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet php5-gd n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
E: Le paquet « php5-gd » n'a pas de version susceptible d'être installée

Et je me sens modérément prêt à me lancer dans la compilation de php5 ...
Un peu d'aide ?
Olivier

#17 Re : -1 »  php5-gd (undefined function imagecreatetruecolor()) » Le 18/04/2014, à 14:30

lemoineo
Réponses : 3

En fouillant, j'ai trouvé php5-gd et donc installé la bête, mais le message initial

undefined function imagecreatetruecolor()

est toujours là.
Evidemment, l'installation de imagick peut remplacer gd, mais il faut recoder toute la création d'images.. pfff...
Olivier

#18 Re : -1 »  php5-gd (undefined function imagecreatetruecolor()) » Le 18/04/2014, à 14:43

lemoineo
Réponses : 3

Je suis sous linuxmint tetra, fork d'ubuntu.
La version de Gd est ramenée par gd_info()

array ( 'GD Version' => '2.1.1-dev', 'FreeType Support' => true, 'FreeType Linkage' => 'with freetype', 'T1Lib Support' => false, 'GIF Read Support' => true, 'GIF Create Support' => true, 'JPEG Support' => true, 'PNG Support' => true, 'WBMP Support' => true, 'XPM Support' => true, 'XBM Support' => true, 'JIS-mapped Japanese Font Support' => false, )

et je me suis laissé dire que selon la version de GD, la fonction imagecreatetruecolor était ou non disponible.
Bon après avoir fait mon savant, j'ai enfin pensé à relancer le serveur Apache2, après la réinstallation de php5-gd (via un autre source) cela marche enfin ....
Merci à tous.
Olivier

#19 Re : -1 »  Php5-gd fait tout planter » Le 18/04/2014, à 14:18

lemoineo
Réponses : 2

Ancien post, mais imagick a des fonctions plus puissantes que Gd

#20 -1 »  Lettres tronquées, c'est grave docteur ? » Le 28/02/2014, à 10:40

lemoineo
Réponses : 1

Bonjour
depuis quelques temps j'ai des lettres qui sont raccourcies , le haut est tronqué, pas forcément toutes les lettres,
mais à l'usage, c'est assez gênant.
Dans un premier temps, j'avais supposé un problème Cinnamon, installé sous Mint Petra,
ce message est actuellement rédigé sous Saucy Gnome, et même punition.
C'est surtout Nautilus (ou Nemo) qui semblent concernées, et quand je clique sur la fenêtre,
les lettres s'affichent de nouveau normalement.
Alors, carte mémoire, écran (HP x2448hc) ou soft (Gnome) ?
Olivier

#21 -1 »  Préférences de Gedit » Le 14/03/2014, à 13:53

lemoineo
Réponses : 1

Vous utilisez Gedit je suppose ?
Comme beaucoup d'utilisateurs Ubuntu, moi aussi !
A chaque fois que j'ouvre une session, je retrouve mes préférences perdues ...
Qu'en pensez vous ?
Ol

#22 Re : -1 »  Préférences de Gedit » Le 14/03/2014, à 13:58

lemoineo
Réponses : 1

Une petite précision, le répertoire

/home/olivier/.gconf/apps/gedit-2/preferences/editor

est protégé et impossible à lire par moi sans droits root.
Effectivement il contient mes choix ... alors, pourquoi ce changement de droits impromptus ?
Ol

#23 Re : -1 »  Installation Mysql infernale » Le 14/03/2014, à 10:59

lemoineo
Réponses : 8

Merci de vos efforts smile
Malheureusement, je n'ai pas réussi
les logs mysql.err et mysql.log sont vides.
Ce qui est agaçant, c'est le fait que la DESINSTALLATION doive relancer mysqld alors que l'installation est plantée.
Et les installations entre MYSQL et MARIADB sont trop proches.
Sur WINDOWS, je n'ai pas eu ce problème, car c'est une installation sans service, donc il suffit de remplacer le répertoire par un autre.
Sous LINUX, tout est intégré, ça a son avantage, mais ici, c'est la galère.
Je suis reparti d'une partition neuve et j'éviterais d'installer l'un ... puis l'autre
Sous FEDORA, c'est MARIADB, point ! Et sous UBUNTU, c'est MYSQL , c'est tout ! sans préférence pour l'instant
Merci encore
Olivier

#24 Re : -1 »  Passage à Mariadb bloqué par Mysql, il resiste le bougre :-( » Le 27/02/2014, à 19:12

lemoineo
Réponses : 2

Bon, ça va pas s'arranger , je peux même pas désinstaller Mariadb qui marche sur les plate-bande de Mysql.
Du coup, je ne sais plus ce que je veux installer ! Un petit Sqlite ? roll

sudo apt-get remove --purge mariadb-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet « mariadb-server » n'est pas installé, et ne peut donc être supprimé
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Paramétrage de mariadb-server-10.0 (10.0.8+maria-1~saucy) ...
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: erreur de traitement de mariadb-server-10.0 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 mariadb-server-10.0
E: Sub-process /usr/bin/dpkg returned an error code (1)