Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  Problème : carte wifi détectée mais "no wireless extensions"... Help ! » Le 12/11/2012, à 12:48

C'est Moi
Réponses : 2

vérifie que les modules soient bien chargé avec lsmod. si tu voix qqch en relation avec le wifi c'est bon signe...

#1 -1 »  [résolu] c++ methode class template specialisation » Le 05/02/2013, à 17:46

C'est Moi
Réponses : 1

voici mon code

template<typename T>
classe A{
  public:
//je n'indique pas les constructeurs et destructeurs
    void do_something();
    void do_something_else(double a);

  private:
    T t;
}

template<>
void A<double>::do_something(){
//lié au type double si une instance de classe A est déclarée par A<double>
}

template<>
void A<int>::do_something(){
//lié au type int si  une instance de classe la classe A est déclarée A<int>
}

template<>
void A<double>::do_something_else(double a){
//lié au type double si  une instance de classe A est déclarée A<double>
}

template<>
void A<int>::do_something_else(double a){
//lié au type int si  une instance de classe A est déclarée A<int>
}

mais ça ne compile pas... la première fonction void, semble ok (elle ne contient pas d'argument)  mais la deuxième me revoie une erreure

erreur: template-id ‘do_something_else<>’ for ‘void A<double>::do_something_else(double a)’ does not match any template declaration
note: saw 1 ‘template<>’, need 2 for specializing a member function template

j'ai regardé
http://stackoverflow.com/questions/7791 … late-class

mais la première réponse n'aide pas... ou alors je comprends pas comment faire

#2 Re : -1 »  [résolu] c++ methode class template specialisation » Le 06/02/2013, à 11:37

C'est Moi
Réponses : 1

laisser tomber, mon erreur était ailleure... ce code devrait fonctionner ! déso

#3 Re : -1 »  ssh, re-ssh et scp » Le 14/12/2012, à 12:23

C'est Moi
Réponses : 12

pk tu peux pas de connecter directement sur le serveur ? et pas d'abbord sur la station puis ensuite sur le serveur ? ca résoudrait ton problème...
sinon une petite clé usb résoud ton prob... si c'est la synchronisation qui te pose problème, il existe de très bon logiciel...

#4 Re : -1 »  [Resolu] automatisation de l'extinction du PC avec confirm et decompte » Le 18/11/2012, à 20:49

C'est Moi
Réponses : 34

pour la sauvegarde incrémentiel, rsync est suffisant (pas besoin d'interface graphique vu que tu ne veux pas laisser le choix à l'utilisateur, de toute façon tu veux une sauvegarde) il te suffit de mettre un script dans /etc/init.d de créer les liens et ton script s'activera à chaque shutdown (en fait je cherche à faire la même chose mais ça marche pas très bien, cf
http://forum.ubuntu-fr.org/viewtopic.ph … #p11363061). ceci peut donc être indépendant de ton script principal qui éteint l'ordi à 18h si personne n'est devant...

#5 Re : -1 »  Installation de make » Le 12/11/2012, à 12:45

C'est Moi
Réponses : 7

si t'as un fichier avec une extensio .deb. entre dans un terminal et tape

sudo dpkg -i nomdupaquet.deb

#6 Re : -1 »  Installation de make » Le 12/11/2012, à 12:59

C'est Moi
Réponses : 7

ah, alors c'est pas vraiment un package... un package c'est un seul fichier deb qui s'intalle très facilement...

ici je pense que t'auras un souci, car pour installer make, d'après la liste de fichiers que tu as donné, il semble qu'il faudra compiler. mais pour compiler il te faut déjà make... c'est le serpent que se mord la queue... car de manière générale, pour compiler des programmes il faut faire un truc du genre

make configure
make install

alors regarde ce qu'ils disent dans README et INSTALL... et vérifie que make ne soit pas intallé, en général c'est un paquet assez standard, il est par défaut dans ta distribution...

#7 Re : -1 »  [script] Changer l'adresse ip » Le 07/11/2012, à 12:11

C'est Moi
Réponses : 2

j'ai pas testé ton script mais visiblement il faut faire un sudo ifdown eth0 puis sudo ifup. ou alors /etc/init.d/networking restart. ou un truc du genre qui redémarre la connexion

#8 -1 »  execution d'un script au shutdown » Le 02/11/2012, à 12:12

C'est Moi
Réponses : 1

salut,

j'ai un script de backup que j'aimerais exécuter à chaque fois que j'éteins l'ordi. J'ai copié ce script dans /etc/ini.d/ et exécuté la commande

update-rc.d backup start 99 3 .

cela a créé un lien vers /etc/rc3.d/S99backup

ce que je ne comprends pas, c'est que lorsque que j'appuie sur le boutton power de l'ordi, acpi gere l'extinction de l'ordi via /etc/acpi/powerbtn.sh mais ne semble pas exécuter mon script...  pour info voici le scripte backup (qui fonctionne quand je lance ./backup):

#!/bin/bash

jour=$(date +%A)
source="/home/username/repertoire/source"
destination="username@serveur-distant:/chemin/vers/repertoire"

rsync -avze ssh --progress --delete  --filter '- articles' --filter '- perime' $source $destination/$jour
if [[ $jour == "vendredi" ]]; then
        semaine=$(date +%V)
        rsync -avze ssh --progress --delete  --filter '- articles' --filter '- perime' $source $destination/$semaine
fi

#10 Re : -1 »  arret du wifi » Le 02/11/2012, à 20:15

C'est Moi
Réponses : 14

hello, si tu veux qu'on t'aide, il nous faut plus d'info...

alors ouvre un terminal et tape

ifconfig
iwconfig
cat /etc/network/interfaces

à chaque fois ces commandes vont répondre qqch. donne nous-en le retour.

ps. ubuntu c'est pas le meilleur, c'est très bien pour commencer, il possède souvent tous les drivers et les dernières versions des softwares mais c'est pas la distribution que j'utiliserais si je commençais une école (comme j'ai l'iimpression que c'est le cas pour toi) ou si je voulais utiliser mon ordi pour faire des simulations et du calucl numérique...

#11 Re : -1 »  arret du wifi » Le 02/11/2012, à 20:37

C'est Moi
Réponses : 14

ok alors tout semble normal, ton interface wifi s'appelle wlan4 et tu es connecté à "NEUF_5C3C", le signal que tu reçois est suffisemment fort pour qu'il ne coupe pas comme ça s'est bizzare.

c'est un portable, je suppose, donc il se peut que si t'es à cours de batterie, le gestionnaire d'alimentation éteigne le wifi... ou que tu t'éloigne trop du sigal. en tout cas ta carte wifi semble gérée par l'ordi correctement. donne moi le retour de

lspci

et

lsmod

ps. ubuntu suffira largement. mais si tu continues tes études dans un domaine scientifique qui nécessite bcp de ressources numériques (ou graphiques), ubuntu n'est pas forcément au top

#12 Re : -1 »  arret du wifi » Le 02/11/2012, à 20:47

C'est Moi
Réponses : 14

alors ta carte wifi est détectée, c'est

04:00.0 Network controller: Atheros Communications Inc. AR9462 Wireless Network Adapter (rev 01)

et les modules qui la gèrent sont chargé... tout semble vraiment nickel

ath9k_common           14053  1 ath9k
ath9k_hw              411151  2 ath9k,ath9k_common
ath                    24067  3 ath9k,ath9k_common,ath9k_hw

le jour ou ca te refais ça tape

dmesg

dans un terminal juste après et post le résultat

#13 -1 »  bouton d'alimentation non détecté par xev » Le 24/10/2012, à 13:29

C'est Moi
Réponses : 1

bonjour,

j'ai un léger prob, le bouton on/off de mon laptop ne répond pas. j'ai installé acpid, j'ai bien un script powerbtn.sh dans /etc/acpi ainsi que powerbtn dans /etc/acpi/events. mais rien ne fonctionne. de même quand je lance xev, le bouton ne semble pas détecté...

merci de votre aide

#15 -1 »  [Résolu] Adresse IP statique perdue après redémarrage » Le 22/10/2012, à 18:45

C'est Moi
Réponses : 13

hello

après 4 ans sur debian je suis repassé sur ubuntu... enfin presque

j'ai fais un installation minimale via le cd alternate et je n'utilise pas d'interface graphique classique (kde, gnome...) mais dwm. j'ai donc une installation minimale... je vous explique mon prob en détail. j'ai à disposition deux prises ethernet, une qui me donne un adresse ip fixe et une qui me permet d'utiliser dhcp.

une fois connecté avec la prise à ip fixe, si je configure /etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 128.xxx.xx.xxx
        netmask 255.255.255.0
        gateway 128.xxx.xx.x
        dns-nameservers truc.qqpart.ch

puis que je lance

sudo ifdown -a

puis

sudo ifup -a

tout se passe bien, j'ai accès à internet et tout roule.

mais si je reboot l'ordi, la connexion disparait. pour l'obtenir à nouveau, je dois changer de prise ethernet, reconfiguer /etc/network/interfaces avec dhcp et refaire ifdown/up. la conexion se lance alors correctement et j'ai accès à internet via dhcp.
si maintenant je rechange de prise internet pour celle à ip fixe, réutilise /etc/network/interfaces avec les parametres pour ip static et relance ifdown/up, la connexion est rétablie avec ip fixe...

si vous avez une idée pour éviter de brancher/débrancher deux fois les cables ethernet et tout ce que cela entraîne... merci bcp !!!

#16 Re : -1 »  [Résolu] Adresse IP statique perdue après redémarrage » Le 23/10/2012, à 08:12

C'est Moi
Réponses : 13

lol...

non je ne peux pas, car je suis sur un réseau d'une école et que je dois utiliser cette adresse statique pour que d'autres utilisateurs (et moi depuis chez moi) puissent se connecter sur mon ordi via ssh... donc ip static obligatoire...

mais merci pour ta réponse...

#17 Re : -1 »  [Résolu] Adresse IP statique perdue après redémarrage » Le 23/10/2012, à 08:57

C'est Moi
Réponses : 13

alors le résultat de ifconfig :

eth0      Link encap:Ethernet  HWaddr 70:71:bc:9b:41:a5  
          inet adr:128.xxx.xxx.xxx  Bcast:128.xxx.xxx.xxx  Masque:255.255.255.0
          adr inet6: fe80::7271:bcff:fe9b:41a5/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:337549 erreurs:0 :36 overruns:0 frame:0
          TX packets:79283 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:121364721 (121.3 MB) Octets transmis:65873529 (65.8 MB)
          Interruption:20 Mémoire:fe700000-fe720000 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:291 erreurs:0 :0 overruns:0 frame:0
          TX packets:291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:22817 (22.8 KB) Octets transmis:22817 (22.8 KB)

je ne crois pas avoir de carte manquante... lspci :

00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:16.2 IDE interface: Intel Corporation 5 Series/3400 Series Chipset PT IDER Controller (rev 06)
00:16.3 Serial controller: Intel Corporation 5 Series/3400 Series Chipset KT Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82578DC Gigabit Network Connection (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Radeon HD 4350]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV710/730 HDMI Audio [Radeon HD 4000 series]
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-Core Registers (rev 04)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 04)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 04)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 04)
3f:03.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller (rev 04)
3f:03.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Target Address Decoder (rev 04)
3f:03.4 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Test Registers (rev 04)
3f:04.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Control Registers (rev 04)
3f:04.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Address Registers (rev 04)
3f:04.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Rank Registers (rev 04)
3f:04.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Thermal Control Registers (rev 04)
3f:05.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Control Registers (rev 04)
3f:05.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Address Registers (rev 04)
3f:05.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Rank Registers (rev 04)
3f:05.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Thermal Control Registers (rev 04)

#18 Re : -1 »  [Résolu] Adresse IP statique perdue après redémarrage » Le 23/10/2012, à 09:10

C'est Moi
Réponses : 13

normalement je n'ai pas besoin de network manager (genre wicd) si je configure à la main /etc/network/interfaces...

et oui, wicd  viens sans interface si on installe wicd-curses...

#19 Re : -1 »  [Résolu] Adresse IP statique perdue après redémarrage » Le 23/10/2012, à 09:35

C'est Moi
Réponses : 13

ok merci mais tu n as pas compris mon prob,

je ne veux pas switcher de connexion mais je veux utiliser l'adress ip statique à tout moment. le truc c'est que lorsque je redémarre l'ordi, la connexion ne se fait plus... et je dois passer repasser par toutes les étapes décrites dans le post 1... c'est très chiant !

#20 Re : -1 »  [Résolu] Adresse IP statique perdue après redémarrage » Le 23/10/2012, à 10:13

C'est Moi
Réponses : 13

@superDude : je vois ce que tu veux dire mais je ne peux pas scripter le changement de cable ethernet... or un ne fonctionne qu'en ip statique et l'autre qu'en dhcp... donc même avec un scripte qui m'interchange les fichiers  /etc/network/interfaces, j'y gagne rien...

@faucon50 : alors oui j'ai bien des truc dans /etc/resolv.conf dans l'en-tête, il est dit de ne pas modifier manuellement ce fichier... de plus les adress ip qui y sont notées n'ont rien à voire avec celle à laquelle je dois me connecter... quand tu dis de virer resolvconf, tu veux dire de virer /etc/resolv.conf et non pas virer le paquet via apt-get ???

#21 Re : -1 »  [Résolu] Adresse IP statique perdue après redémarrage » Le 23/10/2012, à 11:47

C'est Moi
Réponses : 13

magnifique, ça marche...

comment ta su corriger mon problème ? j'ai chercher pendant longtemp et j'ai rien trouvé !!!
bravo

#22 Re : -1 »  [Résolu] Adresse IP statique perdue après redémarrage » Le 23/10/2012, à 13:30

C'est Moi
Réponses : 13

mais du coup le répertoire /etc/resolvconf ne me sert plus a rien, je peux le virer ?

je vois que t'es aussi un adept de la config minimale... je tourne avec moins de 3G de  pour l'OS...

#23 -1 »  C++ problème d'héritage de classe contenant un ofstream (débutant) » Le 24/12/2011, à 17:37

C'est Moi
Réponses : 4

salut à tous
petite question : j'ai deux classes

class A{
public:
A(string nom):file_(nom.c_str(),ios::out | ios::trunc){}
protected:
ofstream file;
}

et

class B: public A{
B(A a):A(a){}
}

chaque classe est fonctionnelle si je ne déclare pas d'attribut "ofstream file", mais si je compile le tout je recois une erreure du genre :

/usr/include/c++/4.4/bits/ios_base.h: In copy constructor ‘std::basic_ios<char, std::char_traits<char> >::basic_ios(const std::basic_ios<char, std::char_traits<char> >&)’:
/usr/include/c++/4.4/bits/ios_base.h:790: error: ‘std::ios_base::ios_base(const std::ios_base&)’ is private

je suis sur que c'est une erreur très bête mais je ne vois vraiment pas... merci de m'aider !
bon noel!!!

#24 Re : -1 »  C++ problème d'héritage de classe contenant un ofstream (débutant) » Le 28/12/2011, à 22:56

C'est Moi
Réponses : 4

hi,

en effet, j'ai fait une erreur de copie déso... mais mon prog est long et je voulais juste synthétiser là où j'ai mon prob !!!

alors oui, je fais une copie implicite de ma classe mais je croyais que par défaut le compilateur me fournit une constructeur de copie... de plus, un pote m'a dit que si je commence à définir une fois un constructeur de copie, je dois tous les définir : en fait ma classe A hérite d'une classe Z qui elle même hérite d'une classe Y... si il faut juste que je définisse le constructeur de la classe A, aucun souci (genre : A(const A &a):file_(a.nom.c_str(), ios::out|ios::trunc){}, en ayant déclaré un attribut string nom à ma classe A), mais sinon jusqu'où je dois remonter?

par aillieur, si à la place de mettre un ofstream je mets un double, je n'ai aucun problème... pourquoi le constructeur de ofstream est privé (question réthorique, je ne pense de toute façon pas comprendre la réponse...)?!

au fait, en quoi ce ne serait pas légitime de faire une copie de A?

merci beaucoup pour vos réps !!!
@+