Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 -1 »  Utiliser kwin dans XFCE » Le 14/12/2014, à 11:24

Christophe C
Réponses : 11

Le gestionnaire de fenêtre de xfce est solide et efficace, mais un peu tristounet (pas d'effets 3D, de cube, de fenêtres molles, d'effets de fermetures ou d'ouverture, etc...).

Compiz, mutter ou gala peuvent le remplacer, mais dans mes expériences c'était toujours un peu instable. Kwin par contre est très efficace.

sudo apt-get install kwin-style-qtcurve kde-window-manager-common kde-window-manager kdeartwork-theme-window qtcurve kde-window-manager-active kde-l10n-fr

Puis remplacer dans le fichier /home/user/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml
dans la section <property name="sessions" type="empty">, la ligne <value type="string" value="xfwm"/> par la ligne <value type="string" value="kwin"/> (on inverse si on veut revenir à xfwm, bien sur).

Puis clic droit sur n'importe quelle barre de titre d'une fenêtre, "actions supplémentaires" / "réglage du gestionnaire de fenêtre". Et là on peut définir toutes sortes d'effet.
On peut décider que tel logiciel se lancera sur tel bureau pré-défini, on peut demander des transitions de bureau sur le modèle "cube", on peut affecter des fonctions aux 4 coins de l'écran (genre un mode exposé, le mur des bureaux, réduire les programmes ouverts, ....). C'est très riche, assez léger, et chez moi en tout cas ultra-stable.

Quelques exemples du résultat :
* https://www.youtube.com/watch?v=YtQuT8T3sFs
* https://www.youtube.com/watch?v=601OkJkN3Zw
* https://www.youtube.com/watch?v=Mv3Db_HDgfc

#1 Re : -1 »  Utiliser kwin dans XFCE » Le 24/12/2014, à 12:49

Christophe C
Réponses : 11

Non, cela ne ressemble pas au bon fichier. Tu es sur de ton coup ?

#2 Re : -1 »  Utiliser kwin dans XFCE » Le 25/12/2014, à 11:32

Christophe C
Réponses : 11

Dans xubuntu 14.10, voilà le début de mon fichier, qui est bien celui indiqué :

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-session" version="1.0">
  <property name="general" type="empty">
    <property name="FailsafeSessionName" type="string" value="Failsafe"/>
    <property name="SaveOnExit" type="empty"/>
    <property name="SessionName" type="string" value="Default"/>
    <property name="StartAssistiveTechnologies" type="bool" value="false"/>
  </property>
  <property name="sessions" type="empty">
    <property name="Failsafe" type="empty">
      <property name="IsFailsafe" type="bool" value="true"/>
      <property name="Count" type="int" value="5"/>
      <property name="Client0_Command" type="array">
            <value type="string" value="kwin"/>
      </property
      <property name="Client0_PerScreen" type="bool" value="false"/>
      <property name="Client1_Command" type="array">
        <value type="string" value="xfsettingsd"/>
      </property>

Je n'ai pas tout mis, je me suis arrété un peu en-dessous de la ligne ad-hoc. Le point important qui semble manquer chez vous deux c'est  :

      <property name="Client0_Command" type="array">
            <value type="string" value="kwin"/>
      </property

Essayez d'ajouter cela en dessous de        <property name="Count" type="empty"/>

#3 Re : -1 »  Utiliser kwin dans XFCE » Le 26/12/2014, à 12:10

Christophe C
Réponses : 11

Aujourd'hui, KDE n'est pas vraiment modulaire (c'est tout l'objet de son actuel révision). Donc c'est clair que les dépendances sont assez importantes (on installe un gros bout de KDE). Ceci dit, si on a de la place disque, ce n'est pas gènant.

je vais envoyer mon ficheir entier.

#4 Re : -1 »  Utiliser kwin dans XFCE » Le 26/12/2014, à 19:49

Christophe C
Réponses : 11

Le fichier complet

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-session" version="1.0">
  <property name="general" type="empty">
    <property name="FailsafeSessionName" type="string" value="Failsafe"/>
    <property name="SaveOnExit" type="empty"/>
    <property name="SessionName" type="string" value="Default"/>
    <property name="StartAssistiveTechnologies" type="bool" value="false"/>
  </property>
  <property name="sessions" type="empty">
    <property name="Failsafe" type="empty">
      <property name="IsFailsafe" type="bool" value="true"/>
      <property name="Count" type="int" value="5"/>
      <property name="Client0_Command" type="array">
        <value type="string" value="kwin"/>
      </property>
      <property name="Client0_PerScreen" type="bool" value="false"/>
      <property name="Client1_Command" type="array">
        <value type="string" value="xfsettingsd"/>
      </property>
      <property name="Client1_PerScreen" type="bool" value="false"/>
      <property name="Client2_Command" type="array">
        <value type="string" value="xfce4-panel"/>
      </property>
      <property name="Client2_PerScreen" type="bool" value="false"/>
      <property name="Client3_Command" type="array">
        <value type="string" value="Thunar"/>
        <value type="string" value="--daemon"/>
      </property>
      <property name="Client3_PerScreen" type="bool" value="false"/>
      <property name="Client4_Command" type="array">
        <value type="string" value="xfdesktop"/>
      </property>
      <property name="Client4_PerScreen" type="bool" value="false"/>
    </property>
  </property>
  <property name="splash" type="empty">
    <property name="Engine" type="string" value=""/>
  </property>
  <property name="compat" type="empty">
    <property name="LaunchGNOME" type="empty"/>
  </property>
  <property name="startup" type="empty">
    <property name="screensaver" type="empty">
      <property name="type" type="empty"/>
    </property>
  </property>
</channel>

#6 Re : -1 »  Abiword, mais qu'est ce que c'est que ce délire ? » Le 26/12/2014, à 12:14

Christophe C
Réponses : 10

Le problème doit venir du fait que l'extension LO n'est pas associée à Abiword. Donc clic sur le fichier, et affectation à Abiword. Il n'ouvrira alors plus le xml sans l'interpréter (le format LO n'est rien d'autre qu'un XML), il ouvrira son équivalence bureautique.

Et tous les futures fichiers LO s'ouvrirons de même. j'ai eu ce pb avec des fichiers Word qui s'ouvraient aussi en xml.

#7 Re : -1 »  Bug installation flashplugin » Le 24/12/2014, à 12:55

Christophe C
Réponses : 15

A tout hasard (désolé si cela ne traite pas le problème), si tu n'utilise flash que pour youtube (ce qui est mon cas), tu peut le désinstaller complètement, car aujourd'hui, en activant le mode HTML5 dans youtube, la totalité des vidéos semblent passer, ce qui n'était pas le cas il y a quelques mois (c'était plutôt une minorité).
Là, j'ai pas mal testé, et je n'ai rien trouvé qui ne marche pas. J'ai qd même installé le codec H264 (qui est d'ailleurs intégré de base dans Fx, aujourd'hui, dans une implémentation libre).

Bref, si tu n'utlise flash que pour youtube, enlève-le définitivement. De toute façon il n'est plus vraiment maintenu sous linux, donc ça va devenir une contrainte.

#8 Re : -1 »  Masquage intelligent du tableau de bord » Le 17/12/2014, à 12:12

Christophe C
Réponses : 16

le mail n'est pas clair sur ce qu'il y a dans ce PPA staging en terme de nouveautés d'interface. Xfce4-panel, bien sur, mais quelq'un saurait-il ce qu'il y a en plus ?

#9 Re : -1 »  Masquage intelligent du tableau de bord » Le 17/12/2014, à 16:14

Christophe C
Réponses : 16

Et donc, logiquement, ce sont des versions > à celles présentent dans la 14.10 ?
Enfin, je peux vérifier cela chez moi.

#10 Re : -1 »  Masquage intelligent du tableau de bord » Le 21/12/2014, à 10:39

Christophe C
Réponses : 16

Bon, j'ai testé. Les version qui sont dans le ppa:xubuntu-dev/xubuntu-staging sont en fait celles de la 14.10, avec un doute sur mousepad, dont la version est indiquée comme mousepad 0.3.github au lieu de 0.3.0. Et il semble y avoir un changement dans le traitement de l'UTF8.

mais en gros c'est la même chose.

#11 -1 »  logiciels non libre dans ubuntu » Le 14/12/2014, à 10:33

Christophe C
Réponses : 9

Bonjour,

Je fais une petite commande vmrs, pour lister les paquets non libres (il faut d'abord installer vmrs), et il me donne

(chris - 3.16.0-25-generic) ~ : vrms
           Non-free packages installed on chris-desktop

intel-microcode                     Processor microcode firmware for Intel CPUs
libfaac0                            AAC audio encoder (library)
libfdk-aac0                         Fraunhofer FDK AAC Codec Library - runtime files

            Contrib packages installed on chris-desktop

iucode-tool                         Intel processor microcode tool
ttf-mscorefonts-installer           Installer for Microsoft TrueType core fonts

Contrib packages with status other than installed on chris-desktop

conky-all                           ( dei)  highly configurable system monitor (all featur

  3 non-free packages, 0.1% of 2125 installed packages.
  3 contrib packages, 0.1% of 2125 installed packages.

Ce qui me choque, c'est le conky-all. Qui ne serait pas libre. Quelqu'un peut confirmer ?

#12 Re : -1 »  logiciels non libre dans ubuntu » Le 14/12/2014, à 13:02

Christophe C
Réponses : 9

non, il y a des paquets non libre dans contrib, genre ttf-mscorefonts-installer. Ca ne veut rien dire.

Là il indique un truc bizarre dans le commentaire : "Contrib packages with status other than installed on chris-desktop" que je ne comprends pas.

#13 Re : -1 »  logiciels non libre dans ubuntu » Le 21/12/2014, à 09:29

Christophe C
Réponses : 9

Non, conky-all était bien installé et actif. Bizarre.

Je l'ai désinstallé et réinstallé (en le téléchargeant, il n'est plus dans les dépôts de la 14.10), et je n'ai plus le message. Il y avait un pb dans l'install, manifestement.

Par contre conky-all apparait tjs comme un paquet non-libre, ce qui me surprend. :

(USER - 3.16.0-28-generic) ~ : vrms
           Non-free packages installed on USER-desktop

intel-microcode                     Processor microcode firmware for Intel CPUs
libfaac0                            AAC audio encoder (library)
libfdk-aac0                         Fraunhofer FDK AAC Codec Library - runtime files

            Contrib packages installed on USER-desktop

conky-all                           highly configurable system monitor (all features enabl
iucode-tool                         Intel processor microcode tool
ttf-mscorefonts-installer           Installer for Microsoft TrueType core fonts

  3 non-free packages, 0.1% of 2119 installed packages.
  3 contrib packages, 0.1% of 2119 installed packages.

#14 Re : -1 »  logiciels non libre dans ubuntu » Le 22/12/2014, à 12:48

Christophe C
Réponses : 9

Chez moi, conky-std ne marche pas, alors que conky-all oui. j'avoue ne pas avoir creusé pourquoi.

vrms n'est donc pas très fiable pour ce qui est lister les paquets non-libres. Sauf si le paquet nvidia dont tu parle n'est pas libre.

#15 Re : -1 »  logiciels non libre dans ubuntu » Le 23/12/2014, à 13:28

Christophe C
Réponses : 9

Merci de ces précisions.

#16 Re : -1 »  Remplacer le panel par docky » Le 22/12/2014, à 12:44

Christophe C
Réponses : 11

Un dock permet d'avoir à la fois l'icone de lancement, et l'icone du prog lancé (l'icone change alors d'apparence, avec un point ou un soulignement, selon les docks et les thèmes).

Le panel utilisé comme dock ne sert que de lanceur. Il faut alors une zone identifiant le prog lancé : ne barre de tâche. Intégrée aussi dans un lanceur. Le prog apparait donc 2 fois.

Ma suggestion visait à se passer d'un dock, mais un dock, c'est bien aussi, si on veut se passer totalement d'un panel. Sauf qu'en général, ne serait-ce que pour la zone affichant les indicateurs, on en garde un.

Sinon, j'aime bien planck

#17 -1 »  Tiens, youtube marche sans flash ? » Le 14/12/2014, à 10:28

Christophe C
Réponses : 8

Cela fait des années qu'on peut avoir certaines vidéos sans flash dans youtube, mais seulement certaines. Suite à une lecture quelques part sur le web, j'ai désinstallé pepperflashplugin-nonfree (la version de flash pour chromium) et flashplugin-installer (pour Fx), et aucun problème, tout passe. Apparemment, youtube a terminé ses migrations. On peut donc se passer de flash, au moins sur ce site, qui en est qd même le grand utilisateur.

Il faut activer le mode de lecture HTML5 dans youtube, par contre.

Quelqu'un a plus d'info là-dessus ?

#18 Re : -1 »  Tiens, youtube marche sans flash ? » Le 14/12/2014, à 17:02

Christophe C
Réponses : 8

flash et le h264 sont différents. A une époque j'avais les codecs h264, et youtube ne marchait que sur certaines vidéos.

Aujourd'hui, youtube semble avoir tout recodifié. En h264 ou en vp9 (ou dans les 2), je ne sais pas. Mais la nouveauté, pour moi, c'est que flash ne semble plus nécessaire sur aucune vidéo.

#19 Re : -1 »  Tiens, youtube marche sans flash ? » Le 14/12/2014, à 18:28

Christophe C
Réponses : 8

Ce n'est pas ce qu'indique ton lien.
En pratique, c'est bien comme cela que ça marche SI la lecture vidéo HTML5 est activée. Comme indiqué, cela fait des années que c'est comme cela, mais sur une petite partie du catalogue seulement.

Ma question porte sur le fait de savoir ce qui s'est passé récemment pour que tout le catalogue (apparemment) soit convertit. Quelqu'un en a entendu parlé ?

#20 Re : -1 »  Tiens, youtube marche sans flash ? » Le 21/12/2014, à 08:25

Christophe C
Réponses : 8

smile Je sais comment marche le lecteur HTML5. Forcément, puisque je dis que chez moi ça marche sans flash.

Je demandais des infos sur le fait que depuis peu toutes les vidéos semblent avoir été migrées. Mais apparemment il n'y a eu aucune communication de youtube sur le sujet.

#21 Re : -1 »  Avenir de Lubuntu » Le 20/12/2014, à 12:45

Christophe C
Réponses : 80

j'ai installé LXQT, et chez moi c'est vraiment stable. Je trouve cela assez mature.

#22 Re : -1 »  Compiz, le tearing et la stabilité. » Le 17/12/2014, à 12:37

Christophe C
Réponses : 5

tu peux aussi tester kwin. Chez moi il est nettement plus stable que compiz. mais commence par tester compton, effectivement.

#23 Re : -1 »  [résolu] gestionnaire thunar "pollué" » Le 17/12/2014, à 12:35

Christophe C
Réponses : 7

L'interet de imagemagik ne sera pas tellement de faire de la ligne de commande, mais plutôt de paramétrer quelque chose dans "Éditer" puis "Configurer les actions personnalisées".

Là on met une commande imagmagik avec un passage de variable (la commande se termine donc par un %F, de mémoire), et on a une ou des fonctions dispo au clic droit dans thunar, fonction(s) qu'on lance(nt) donc sur un fichier ou un groupe de fichiers sélectionnés.

Sinon, imagemagik à la main à chaque fois, en ligne de commande, c'est pas très sympa.