Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 -1 »  Etendre partition lvm2 » Le 02/12/2014, à 14:00

cedric31
Réponses : 28

Bonjour,

J'ai besoin d'étendre une partition lvm2 /dev/mapper/ubuntu-root

Je sais qu'elle est sur le disque /dev/sda sur lequel j'ai 45 Go de libre mais je ne sais pas comment faire parce que je ne vois nulle part le lien entre ma partition et mon disque

#1 Re : -1 »  Etendre partition lvm2 » Le 02/12/2014, à 15:06

cedric31
Réponses : 28

j'ai oublié une capture écran smile
la partition /dev/sda5 est de type inconnue, du coup je ne peux pas l'étendre !

119219ubuntu.png

merci wink

#2 Re : -1 »  Etendre partition lvm2 » Le 02/12/2014, à 15:36

cedric31
Réponses : 28
MrRaph_ a écrit :
cedric31 a écrit :

j'ai oublié une capture écran smile
la partition /dev/sda5 est de type inconnue, du coup je ne peux pas l'étendre !

http://img4.hostingpics.net/pics/992618ubuntu2.jpg

merci wink


C'est normal, c'est du LVM wink

Vous ne pourrez l'étendre avec GParted !

Avez vous essayé le vgdisplay ? Que retourne la commande ?

sudo vgdisplay -v

ok, je ne connais pas ce LVM wink

la commande vgdisplay -v me donne ça :

163221vgdisplay1.jpg

124190vgdisplay2.jpg

Merci

#3 Re : -1 »  Etendre partition lvm2 » Le 02/12/2014, à 16:31

cedric31
Réponses : 28

je vais vous éviter de partir dans des supputations wink

j'ai fait des captures écran, parce que ce n'est pas la machine de prod, c'est un clone et j'ai désactivé le réseau wink

#4 Re : -1 »  Etendre partition lvm2 » Le 02/12/2014, à 16:32

cedric31
Réponses : 28
tiramiseb a écrit :

cedric31, s'il-te-plaît la prochaine fois mets les retours de commandes sous forme de texte, entre balises "code". C'est plus agréable que de devoir lire des images, qui sont des milliers de fois plus lourdes à charger et qui ne nous permettent pas de te répondre avec des copier-collers...

Soit tu veux faire tout propre et il faut jouer avec du redimensionnement de partitions (et les risques qui vont avec), soit on peut partir en gardant les partitions existantes telles quelles.
Dans ce second cas, l'approche serait la suivante:
- créer deux partitions, une /dev/sda6 dans la partition étendue et une /dev/sda3 en partition principale
- mettre ces deux partitions comme volumes physiques LVM
- joindre ces deux volumes physiques au groupe de volumes
- agrandir le volume logique qui t'intéresse

Cette approche convient-elle ?


je suis partant
feu !

merci encore

#5 Re : -1 »  Etendre partition lvm2 » Le 02/12/2014, à 16:58

cedric31
Réponses : 28

j'ai pas le type "linux lvm" ...
ça part mal smile

#6 Re : -1 »  Etendre partition lvm2 » Le 02/12/2014, à 17:09

cedric31
Réponses : 28

ok je regarde

merci

#7 Re : -1 »  Etendre partition lvm2 » Le 03/12/2014, à 12:09

cedric31
Réponses : 28

bon je n'ai pas reussi

je vais voir si je peux faire autrement, en déplaçant les données sur un autre fs...

merci de ton aide

#8 Re : -1 »  Etendre partition lvm2 » Le 03/12/2014, à 13:46

cedric31
Réponses : 28

je n'abdique pas, je voulais pas vous emme... avec ça wink

je ne maitrise pas le truc alors je merdouille...

#9 Re : -1 »  Etendre partition lvm2 » Le 03/12/2014, à 18:55

cedric31
Réponses : 28

j'ai un peu avancé grâce à tes conseils et ce site : http://madoc.over-blog.com/article-13220316.html
j'ai créé une autre partition en linux-lvm comme tu m'avais dit puis j'ai étendu le VG

j'en suis au lvresize que je teste demain


merci encore

#10 Re : -1 »  Etendre partition lvm2 » Le 04/12/2014, à 09:43

cedric31
Réponses : 28

c'est bon ça a marché !

merci beaucoup

#11 -1 »  Installation modules apache2 » Le 13/08/2013, à 15:52

cedric31
Réponses : 26

Bonjour,

Je suis sous 12.04 LTS 64b, afin de pouvoir activer le SSO avec GLPI je dois avoir le module "mod_auth_sspi.so"
J'ai apache 2.2.22 mais impossible d'y arriver... j'ai récupérer plusieurs mod_auth_sspi.so, sur plusieurs sites différents mais à chaque fois que je démarre apache il me dit :

sweb:/etc/init.d$ sudo ./apache2 start
* Starting web server apache2   
apache2: Syntax error on line 214 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/httpd.conf: Cannot load /etc/apache2/modules/mod_auth_sspi.so into server: /etc/apache2/modules/mod_auth_sspi.so: invalid ELF header
Action 'start' failed.
The Apache error log may have more information.

sachant que le fichier est bien dans /etc/apache2/modules

Une petite idée ?
Merci

#12 Re : -1 »  Installation modules apache2 » Le 19/08/2013, à 08:53

cedric31
Réponses : 26

Salut et merci pour vos réponses,

j'ai essayé de faire "a2enmod" mais il me dit "module introuvable"

Je l'ai récupéré sur la forge (http://sourceforge.net/projects/mod-auth-sspi/), y'avait le choix entre apache1 et apache2, j'ai pris pour apache2

#13 Re : -1 »  Installation modules apache2 » Le 19/08/2013, à 13:12

cedric31
Réponses : 26

ça doit pas être sur ce site alors... il me demandait si j'étais sous apache1 ou apache2...
je vais essayer de retrouver alors smile

#14 Re : -1 »  Installation modules apache2 » Le 19/08/2013, à 17:16

cedric31
Réponses : 26

C'est moi qui n'ai pas du comprendre peut-être
C'est pour activer le SSO avec GLPI, mon serveur glpi est sous ubuntu 12.04 LTS et mon domaine sous 2008

j'ai suivi cette doc :  http://www.glpi-project.org/wiki/doku.p … authautoad
Dans laquelle ils disent bien que ce module n'est que pour Windows sauf que dans le fichier de conf apache ils s'en servent..... je comprends rien...
du coup j'ai essayé celle ci : http://em-corporation.fr/sysadmin/?p=272
mais c'est pas mieux...

Argh !

#15 Re : -1 »  Installation modules apache2 » Le 19/08/2013, à 17:41

cedric31
Réponses : 26
tiramiseb a écrit :

Ben oui, ils utilisent Apache sous Windows...

oui d'accord mais le reste n'est pas clair.....enfin pour moi.... smile

tiramiseb a écrit :

Qu'est-ce qui est pas mieux ? Qu'est-ce qu'il se passe ? Des détails s'il te plaît ! smile

je refais un essai demain et je te dirai, je me souviens plus du message, c'est une histoire de module qui n'est pas chargé je crois... quand je veux démarrer apache

#16 Re : -1 »  Installation modules apache2 » Le 20/08/2013, à 08:30

cedric31
Réponses : 26

Voici le message quand je démarre apache :

Syntax error on line 9 of /etc/apache2/conf.d/glpi:
Invalid command 'NTLMAuth', perhaps misspelled or defined by a module not included in the server configuration

Je sais pas pourquoi j'ai posté l'autre message, j'ai dû me mélanger les pinceaux avec l'ancien serveur....

#17 Re : -1 »  Installation modules apache2 » Le 20/08/2013, à 09:02

cedric31
Réponses : 26

ça y est j'ai réussi à l'activer ! en fait il fallait activer NTLM_Auth_winbind !
maintenant ça bloque sur NTLMAuthoritavice... mais ça doit être un truc du même genre....
je te tiens au jus wink
merci

#18 Re : -1 »  Installation modules apache2 » Le 20/08/2013, à 10:06

cedric31
Réponses : 26

je trouve pas comment installer les modules NTLMDomain, NTLMAuthoritative, NTLMServer et NTLMBackup

si vous avez une idée...

#19 Re : -1 »  Installation modules apache2 » Le 20/08/2013, à 10:12

cedric31
Réponses : 26

Quand je suis la doc d'install des modules ntlm (http://fossies.org/linux/www/apache_httpd_modules/mod_ntlm2-0.1.tgz:a/mod_ntlm2-0.1/Documentation/mod_ntlm.html )

j'ai cette erreur lors de l'install :

apxs -c -o mod_ntlm.so -Wc,-shared mod_ntlm.c
make: apxs : commande introuvable
make: *** [mod_ntlm.so] Erreur 127

#20 Re : -1 »  Installation modules apache2 » Le 20/08/2013, à 10:45

cedric31
Réponses : 26
tiramiseb a écrit :

Mais pourquoi n'utilises-tu pas le paquet fourni par Ubuntu ?

$ apt-cache search apache2 ntlm
libapache2-authenntlm-perl - Perform Microsoft NTLM and Basic User Authentication
libapache2-mod-auth-ntlm-winbind - apache2 module for NTLM authentication against Winbind

je les ai déjà installé ces packages...

#21 Re : -1 »  Installation modules apache2 » Le 20/08/2013, à 10:55

cedric31
Réponses : 26

qu'est ce que tu as besoin de plus comme info que les messages d'erreurs que j'ai donné, le site que je suis et pour quoi je le fais ?
dis moi, je te donnerai ces infos avec plaisir smile

#22 Re : -1 »  Installation modules apache2 » Le 20/08/2013, à 11:13

cedric31
Réponses : 26

Je reprends :
Je voudrais activer le SSO pour GLPI, mon serveur est un ubuntu 12.04 et mon domaine en 2008
Pour activer le SSO, je dois rajouter la conf suivante dans mon fichier de conf apache :

PerlModule Apache2::AuthenNTLM
<Directory "/var/www/glpi">
PerlAuthenHandler Apache2::AuthenNTLM
AuthType ntlm,basic
AuthName paipartners
require valid-user
PerlAddVar ntdomain  "domain dc1 dc2"
PerlSetVar defaultdomain domain
PerlSetVar splitdomainprefix 1
PerlSetVar ntlmdebug 0 (1 ou 2 pour test)
PerlSetVar ntlmauthoritative off
</Directory

Comme indiqué sur le site : http://em-corporation.fr/sysadmin/?p=272

Mais lorsque je veux démarrer apache, il me dit que les modules NTLMDomain, NTLMBackup, NTLMServer et NTLMAuthoritative ne sont pas présent (alors que j'ai installé les packages libapache2-authenntlm-perl - et
libapache2-mod-auth-ntlm-winbind)
Du coup j'ai essayé de suivre la doc : http://fossies.org/linux/www/apache_htt … _ntlm.html

Mais j'ai ce message :

cp: cannot stat `mod_ntlm.so': No such file or directory
apxs:Error: Command failed with rc=65536
.
make: *** [install] Erreur 1

D'après ce que j'ai compris c'est parce qu'il cherche les modules apache dans /lib/apache2/modules alors que je les ai dans /etc/apache2/modules...

Merci encore de ton aide wink

#23 Re : -1 »  Installation modules apache2 » Le 21/08/2013, à 11:06

cedric31
Réponses : 26
tiramiseb a écrit :

lorsque je veux démarrer apache, il me dit que les modules NTLMDomain, NTLMBackup, NTLMServer et NTLMAuthoritative ne sont pas présent (alors que j'ai installé les packages libapache2-authenntlm-perl - et
libapache2-mod-auth-ntlm-winbind)

Quelle est l'erreur exacte (copier-coller) ?

le message d'erreur c'est toujours le même, il n'a pas changé, c'est celui que je t'ai mis dans le post de 8h30

Invalid command 'NTLMAuth', perhaps misspelled or defined by a module not included in the server configuration
tiramiseb a écrit :

As-tu remarqué que cette documentation date d'il y a 13 ans ? Peut-être que les technologies ont évolué depuis ce jour-là... Surtout que tu essaies de te connecter à un domaine Windows 2008.

oui mais c'est toujours la même conf, j'ai mis ce lien mais si tu regardes celui que j'avais mis sur le wiki glpi c'est pareil

#24 Re : -1 »  Installation modules apache2 » Le 21/08/2013, à 11:28

cedric31
Réponses : 26

j'ai fait differemment, j'ai utilisé cette conf :

PerlModule Apache2::AuthenNTLM
<Directory "/var/www/glpi">
PerlAuthenHandler Apache2::AuthenNTLM
AuthType ntlm,basic
AuthName paipartners
require valid-user
PerlAddVar ntdomain  "domain dc1 dc2"
PerlSetVar defaultdomain domain
PerlSetVar splitdomainprefix 1
PerlSetVar ntlmdebug 0 (1 ou 2 pour test)
PerlSetVar ntlmauthoritative off
</Direc

Maintenant apache démarre mais GLPI ne s'ouvre plus...
je vais chercher car je n'ai pas de message d'erreur

Merci de ton aide