Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 15

#0 -1 »  [résolu]Plus de mises à jour : souci de dépendances. » Le 15/01/2013, à 19:07

bilouck
Réponses : 4

Bonsoir la communauté !
Me revoici avec un souci de mise à jour, voici ce que m'affiche l'onglet "détail" :

Les paquets suivants ont des dépendances non-satisfaites :

firefox-globalmenu: Depends: firefox (= 18.0+build1-0ubuntu0.12.04.3) mais la version 17.0.1+build1-0ubuntu0.12.04.1 est installée

Accessoirement j'ai aussi un souci avec mozilla qui est devenu anglais mais ça fait un peu plus longtemps, je m'habitue...

J'ai 27 mises à jour qui attendent sad
Help siouplait !
Merci

#1 Re : -1 »  [résolu]Plus de mises à jour : souci de dépendances. » Le 15/01/2013, à 19:42

bilouck
Réponses : 4

Personne n'a de solution ?

Je viens d'essayer ça :

sudo apt-get remove 17.0.1+build1-0ubuntu0.12.04.1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet 17.0.1+build1-0ubuntu0.12.04.1
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « 17.0.1+build1-0ubuntu0.12.04.1 »

Genre le truc est installé mais introuvable...  ?

#2 Re : -1 »  [résolu]Plus de mises à jour : souci de dépendances. » Le 15/01/2013, à 20:24

bilouck
Réponses : 4
 sudo apt-get -f install

Apparemment ça fonctionne !

#4 -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 08/12/2012, à 19:19

bilouck
Réponses : 20

Depuis des semaines :

Les paquets suivants ont des dépendances non-satisfaites :

linux-image-generic-pae: Depends: linux-image-3.2.0-33-generic-pae mais il n'est pas installé


Et donc bonsoir à la communauté et d'avance merci !
Je suis une archi débutante.

#5 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 08/12/2012, à 19:54

bilouck
Réponses : 20

Salut et merci mais ça n'a pas fonctionné sad

#6 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 08/12/2012, à 19:56

bilouck
Réponses : 20

Au cours de la première opération ça cause d'erreurs à partir d'ici :
dpkg-deb (sous-processus) : données : erreur de lecture interne de bzip2 : « DATA_ERROR »
dpkg-deb : erreur : le sous-processus <decompress> a retourné une erreur de sortie d'état 2
dpkg : erreur de traitement de /var/cache/apt/archives/linux-image-3.2.0-33-generic-pae_3.2.0-33.52_i386.deb (--unpack) :
lecture courte (short read) lors d'une copie de buffer pour backend dpkg-deb pendant « ./lib/firmware/3.2.0-33-generic-pae/bnx2x/bnx2x-e1h-6.2.9.0.fw »
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-33-generic-pae /boot/vmlinuz-3.2.0-33-generic-pae
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-33-generic-pae /boot/vmlinuz-3.2.0-33-generic-pae
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/linux-image-3.2.0-33-generic-pae_3.2.0-33.52_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et après la seconde opération, à la fin j'ai ça :
W: Impossible de récupérer gzip:/var/lib/apt/lists/partial/fr.archive.ubuntu.com_ubuntu_dists_precise-updates_universe_binary-i386_Packages  Somme de contrôle de hachage incohérente

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

#7 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 08/12/2012, à 20:12

bilouck
Réponses : 20

De quelle erreur parle-tu ?

sudo apt-get clean  ne fonctionne pas, enfin rien ne se passe wink

#8 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 08/12/2012, à 20:19

bilouck
Réponses : 20

E: L'option « p » de la ligne de commande [d'origine -purge] est inconnue.

#9 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 08/12/2012, à 20:20

bilouck
Réponses : 20

Là je sors, je m'y remettrai demain, en tout cas merci !!

#10 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 08/12/2012, à 20:24

bilouck
Réponses : 20

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
linux-image-generic-pae : Dépend: linux-image-3.2.0-33-generic-pae mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

#11 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 09/12/2012, à 09:06

bilouck
Réponses : 20

Bonjour, c'est reparti big_smile

apt-get -f install
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?

>> euh, logiquement je devrais avoir les privilèges en question sinon je ne vois pas qui d'autre mais vu que ça ne me demande pas de réponse à cette question, ben.... stand by.

Bon dimanche à tous.

#12 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 09/12/2012, à 09:28

bilouck
Réponses : 20

Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main linux-generic-pae i386 3.2.0.34.37 [1 722 B]
Réception de : 2 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main linux-image-generic-pae i386 3.2.0.34.37 [2 564 B]
4 286 o réceptionnés en 0s (20,0 ko/s)       
dpkg : des problèmes de dépendances empêchent la configuration de linux-image-generic-pae :
linux-image-generic-pae dépend de linux-image-3.2.0-33-generic-pae ; cependant :
  Le paquet linux-image-3.2.0-33-generic-pae n'est pas installé.
dpkg : erreur de traitement de linux-image-generic-pae (--configure) :
problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg : des problèmes de dépendances empêchent la configuration de linux-generic-pae :
linux-generic-pae dépend de linux-image-generic-pae (= 3.2.0.33.36) ; cependant :
Le paquet linux-image-generic-pae n'est pas encore configuré.
dpkg : erreur de traitement de linux-generic-pae (--configure) :
problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Des erreurs ont été rencontrées pendant l'exécution :
linux-image-generic-pae
linux-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)



En fait c'est ce paquet linux image generic pae qui bloque mais hier avec mon frère on essayé de le chercher et de l'installer ou de le désinstaller mais on ne peut rien faire, c'est le serpent qui se mord la queue hmm

#13 Re : -1 »  [résolu]Dépendances non satisfaites : plus de mises à jour.. » Le 09/12/2012, à 11:38

bilouck
Réponses : 20

Hé ben ça alors !
ça a fonctionné !

Un GRAND merci pierguiard ! cool