Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 -1 »  [IMPORTANT] Vieilles cartes ATI et pilote proprio » Le 23/09/2009, à 13:45

raph986
Réponses : 441

0) Pour bien commencer

Documentation Ubuntu-fr sur le pilote propriétaire Catalyst: http://doc.ubuntu-fr.org/catalyst
Documentation Ubuntu-fr sur le pilote libre radeon/ati: http://doc.ubuntu-fr.org/radeon
Documentation Ubuntu-fr sur le pilote libre radeonhd: http://doc.ubuntu-fr.org/radeonhd
Statut du développement des pilotes libres: http://xorg.freedesktop.org/wiki/RadeonFeature


Suite à la prolifération de personnes ne comprenant pas pourquoi elle ne peuvent plus installer le pilote propriétaire d'ATI depuis Ubuntu 9.04, je propose de faire un petit récapitulatif de la situation puis de proposer quelques solutions.

1) Rappels des faits

Depuis des temps immémoriaux, les cartes ATI sous Linux n'ont jamais eu une bonne réputation, à raison la plupart du temps. Cependant depuis près de deux ans (depuis qu'AMD les a racheté en fait), on note une certaine amélioration dans la qualité des pilotes mais également dans le support des nouveautés sous Linux.

Malheureusement, cette belle marche en avant s'est pris une bonne gifle en Avril dernier: ATI/AMD ne supportera plus les cartes radeon Directx 9, soit les puces R300 à R500, ou encore les numéro 9500 à x1950, et ce pour TOUS LES SYSTEMES D'EXPLOITATION. La raison était certainement pour "simplifier" le code de leurs pilotes, même si on remarquera que les catalyst pour Linux ont continué de grossir, même après la fin du support des cartes Dx9.... Passons.

Une liste non exhaustive des modèles qui ne sont plus supportés, qui concerne aussi leurs équivalents FireGL et Mobility:

9500
9600
9700
9800
x300
x550
x600
x700
x800
x850
x1200
x1300
x1400
x1600
x1700
x1800
x1900
x1950

La liste est longue donc. On pourrait légitimement se dire que puisque les pilote d'Avril ne supportent plus ces cartes, ceux de Mars pourraient faire l'affaire. ET BIEN NON!
En effet, tous les 6 mois, Ubuntu sort une nouvelle version, avec des versions récentes des logiciels qu'elle utilise. Cela est valable pour Gnome, mais aussi le noyau, le serveur graphique, etc... Et il se trouve justement que c'est là que le bas blesse.
Et donc, le pilote catalyst 9.3 qui n'est prévu pour supporter que jusqu'à Xorg 7.3 et le noyau 2.6.27 ne peut marcher sur Jaunty qui est sortie avec Xorg 7.4 et le noyau 2.6.28. Je ne sais pas pourquoi ça ne marche pas, des fois c'est juste le pilote qui reconnait pas le numéro et qui bloque l'installation, des fois les changements sont plus profonds.

Mais le résultat est là:
- On a un pilote qui supporte Jaunty mais pas les cartes Dx9
- On a un pilote qui supporte les cartes Dx9 mais pas Jaunty

2) Une solution?

Il ne reste donc que quelques solutions pour les personnes souhaitant installer le pilote Catalyst:
- Changer de carte graphique: difficile pour les pc portables et les cartes AGP
- Installer une ancienne version d'Ubuntu: Certainement le choix par défaut

Mais il existe un autre choix, telle la tranche de la pièce à pil ou face! 

Il est possible d'utiliser le pilote libre! Je dis le, mais il en existe deux: radeon qui supporte toutes les cartes ati, et radeonhd qui supporte que les R500 (X1x00) et plus. Je ne sais pas s'il y a vraiment de grandes différences entre les deux pilotes, mais pour ceux que ça intéresse la documentation d'Ubuntu-fr est pas mal si vous voulez compiler la dernière version de chaque pilote. Évidemment, vous pouvez tout aussi bien vous contentez du pilote libre fourni de base avec Ubuntu (c'est le pilote radeon, aussi nommé ati).

Concernant le pilote libre, il y a des trucs qu'il fait bien ( 2D, video ) et d'autre qu'il fait moins bien (3D, gestion de l'énergie non implémenté). Je ne m'y connais pas vraiment à ce sujet, mais sur mes deux machines (x1600 et HD4870) ça fait l'affaire pour du surf sur internet, regarder une vidéo, ou épater ses amis avec Compiz/Kwin (sur la x1600). Le mieux est encore d'utiliser un live-CD ou live-USB et de se faire sa propre idée de la situation. Quoi qu'il en soit, AMD a, à de nombreuses reprises, ouvert les spécifications de ses cartes, donc le pilote libre va gagner en puissance plus rapidement qu'avant, 2010 devrait être sympa de ce côté là.

3) Enfin, un petit rappel qui ne fait jamais de mal:

- Avec Catalyst, vous avez des bugs et autres freeze quand vous regardez une vidéo avec les effets 3D activés?
   => Désactivez les effets 3D ou utilisez le module de sortie X11 dans les options du lecteur vidéo
- Avec Catalyst, redimensionner une fenêtre est très lent avec les effets 3D activés?
   => Cela varie d'un pilote à l'autre. Je n'ai pas ce souci avec les 9.1 mais je l'ai depuis les 9.6 sur ma HD 4870, on peut donc penser qu'ATI tente d'améliorer son pilote et que cela a des répercutions.
- Avec Catalyst: l'image d'une vidéo est "déchirée" lors des scènes où ça bouge vite?
   => Ce n'est pas un bug, c'est juste qu'ATI n'a pas (encore) implémenté la synchronisation verticale pour les vidéos.
- Avec radeon (libre), vous perdez des dizaines de minutes d'autonomie?
   => c'est normal, il n'y a aucune gestion de l'énergie implémentée pour l'instant
- Avec radeon, certains jeux ne se lancent pas ?
   => c'est normal, le pilote libre n'implémente pas encore l'OpenGL 2

4) Concernant les Radeon HD XXXX?

Pour ces cartes ("directx 10"), il y a toujours le pilote Catalyst ou les 2 pilotes libres de disponibles.

Voilà je pense que c'est à peu près bon comme ça, si certaines choses ne sont pas claires je pourrez développer. par contre si vous avez un souci créez un topic, n'en parlez pas ici.
Enfin, je tiens à rappeler que ce "problème" d'incompatibilité est quand même présentez dès le début de la doc du pilote proprio d'ATI (http://doc.ubuntu-fr.org/catalyst) et que si Ubuntu ne vous propose pas le pilote propriétaire, c'est que normalement vous ne pouvez pas l'installer.

A plus

#2 Re : -1 »  [IMPORTANT] Vieilles cartes ATI et pilote proprio » Le 31/10/2009, à 23:04

raph986
Réponses : 441
φlip a écrit :
raph986 a écrit :

Concernant le pilote libre, il y a des trucs qu'il fait bien ( 2D, video ) et d'autre qu'il fait moins bien (3D, gestion de l'énergie non implémenté).

A confirmer.

man radeon

Option "ForceLowPowerMode" "boolean"

Enable a static low power mode. This can help reduce heat and increase battery life by reducing power usage at the expense of performance. The default is off.

Option "DynamicPM" "boolean"

Enable dynamic power mode switching. This can help reduce heat and increase battery life by reducing power usage when the system is idle (DPMS active). The default is off.

Option "ClockGating" "boolean"

Enable dynamic clock gating. This can help reduce heat and increase battery life by reducing power usage. Some users report reduced 3D performance with this enabled. The default is off.

J'ai installé Karmic depuis quelques jours et j'ai testé les options dont tu parles. Première blague, le xorg.conf n'existe plus, il a fallut le recréer.
Bon sinon pour parler des performances, effectivement ça marche !!! Je suis actuellement avec une consommation de 28 watts, alors qu'avec les catalyst sur Intrepid j'étais à 24w. Avant avec les pilotes libres, j'étais à près de 40 watts! Le gain est donc là, malheureusement mes batteries sont mortes donc je ne peux pas trop en profiter xD

Je vais mettre à jour le premier post wink

#3 Re : -1 »  [ATI] Retour sur les drivers libres radeon sous Lucid Lynx. » Le 21/03/2010, à 01:40

raph986
Réponses : 290
Lefantomedurezo a écrit :

j'ai une ATI radeon mobility HD 2600. la 3D fonctionne mais problème de température: lors d'une session normal ou idle, je constate que le ventilot passe des fois de la vitesse 0 à la vitesse maxi (comme si il se mets en alarme) et je sens le clavier plus chaud que d'habitude: (intrepid avec le pilote proprio).

En fait c'est pas vraiment un problème, c'est juste que pour l'instant il n'y a pas de gestion de la tension avec les pilotes libres, donc si ta carte est comme ma X1600 c'est tension maximale tout le temps, et du coup ça chauffe. Les quelques options qui concernent la gestion de l'énergie ne modifient pour l'instant que les fréquences.

#4 Re : -1 »  Un ppa pour xfce 4.8? » Le 07/11/2010, à 20:45

raph986
Réponses : 1

Bonjour

Je pense que tu pourras le trouver à l'adresse ci-dessous:
https://launchpad.net/~xubuntu-dev/+archive/ppa

Attention par contre le PPA n'a pas été mis à jour depuis plusieurs semaine, il va donc falloir attendre qu'une des personnes qui s'occupe du PPA le mette à jour.

#5 Re : -1 »  Xfce 4.7.x (futur 4.8) pour lucid » Le 21/09/2010, à 20:49

raph986
Réponses : 2

Bonjour

Je me permets de remonter ce topic car j'aurai une question mais je ne pense pas que ce soit un bug.

J'ai installé les paquets du ppa Xubuntu-dev, et depuis je n'ai plus la possibilité d'éteindre mon pc depuis Xfce, les options sont grisées. Je dois me déconnecter et passer par le menu de l'écran de login pour éteindre redémarrer ma machine.
De même, le gestionnaire d'énergie ne peux plus mettre en veille mon PC.

Une idée? Il doit y avoir quelque chose de mal configuré mais je ne vois pas quoi.

En espérant que quelqu'un pourra m'aider.
Raf

#6 Re : -1 »  probleme driver fglrx » Le 23/09/2009, à 15:10

raph986
Réponses : 49

@mydjey
Pour avoir taté un peu les cartes via comme la tienne, je vais dire que c'est la croix et la bannière pour en tirer quelque chose. Il me semble qu'à part l'accélération 2D le pilote libre ne fait rien d'autre.

#7 Re : -1 »  [VOS PROPRES IMPRESSIONS] Le Koala Karmique est-il VRAIMENT bien ? » Le 27/10/2009, à 01:15

raph986
Réponses : 607

Je viens de passer la soirée sur Xubuntu 9.10 RC et je dois dire que c'est vraiment bon.
Le thème et le boot sont vraiment joli, encore plus que 9.04 selon moi. Ristretto est de nouveau le visionneur d'image par défaut, Xfce-power-manager est enfin installé par défaut, et Exaile a l'air d'être bien efficace. notify-osd est une bonne idée, même si c'est dommage qu'on ne puisse pas avoir plus de 2 lignes à priori.
Par contre le réseau à l'air moins efficace, quand je tape une url il y a comme un lag de 5 secondes avant que le navigateur fasse quelque chose, et le fichier xorg.conf a disparu, il a fallu le recréer.

Pas de gros changement sinon, pas de souci majeur, tout marche du premier coup comme d'habitude, je pense que je vais remplacer mon Intrepid par cette version, histoire d'avoir au moins des logiciels un peu plus récents.

#8 Re : -1 »  Le dernier Patch de Microsoft provoquerait un écran noir » Le 02/12/2009, à 09:19

raph986
Réponses : 14

Je pense qu'on pourra se moquer quand la section serveur graphique du forum sera moins remplie...

#9 Re : -1 »  Problème affichage/driver ATi hd4570 » Le 01/12/2009, à 18:36

raph986
Réponses : 2

Bonjour

Pour commencer comment as-tu installé le pilote fglrx? Je te conseille de le désinstaller et de le réinstaller, généralement ça marche. Supprime aussi manuellement le fichier /etc/X11/xorg.conf avant de le réinstaller.

#10 Re : -1 »  Radeon HD 4850, Catalyst 9.10 et Karmic » Le 04/11/2009, à 21:40

raph986
Réponses : 63

Perso j'ai une ATI HD4870 et l'installation des 9.10 sur Karmic s'est faite sans problème, ça a même réglé un problème de couleurs que j'avais au boot, et j'ai les effets 3D qui fonctionnent.
Tout ce que j'ai fait, c'est installé Karmic, la mettre à jour, télécharger le pilote ATI sur le site d'ATI, le rendre exécutable et de taper la commande magique:

sudo ./ati-driver-installer-9-10-x86.x86_64.run --buildandinstallpkg

Et de redémarrer.

#11 Re : -1 »  Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy » Le 05/10/2009, à 23:01

raph986
Réponses : 131

Même souci pour Intrepid, on dirait que le ppa de jeromeg ne marche plus. Pourtant les paquets sont encore en ligne, où est-ce que cela peut coincer?

#12 Re : -1 »  ubuntu 9.10 et Ati radeon 9600 » Le 01/11/2009, à 12:32

raph986
Réponses : 2

Bonjour

Tu n'as pas à chercher de drivers pour ta carte graphique, il n'y en a qu'un seul de disponible, le pilote libre radeon, et il est utilisé par défaut wink

#13 Re : -1 »  Problème démarrage après installation de pilote ati » Le 01/11/2009, à 04:39

raph986
Réponses : 5

As-tu essayé de redémarrer en mode recovery?
Si ce n'est pas le cas, lorsque tu arrives sur grub choisis le mode recovery puis root. Après tape

aticonfig --initial -f

ça peut résoudre ton problème.

#14 Re : -1 »  Question sur la mise à jour des pilotes ATI » Le 31/10/2009, à 22:56

raph986
Réponses : 2

Si tu as installé les 9.9 en générant les paquets ça devrait passer en faisant la même chose avec les 9.10. Si tu as juste utiliser l'installateur graphique désinstalle avant de mettre les 9.10.

#15 Re : -1 »  [Résolu] Bruits parasites après l'installation du pilote pour [...] » Le 25/09/2009, à 09:20

raph986
Réponses : 9

Bonjour

As-tu étudié la possibilité de mettre à jour le pilote?

#16 Re : -1 »  Combien de personnes avez vous convaincu ? » Le 23/09/2009, à 11:31

raph986
Réponses : 58

[HS]
Elles marchent bien les cartes ATI sous Linux, c'est juste qu'il n'a pas eu l'info essentiel qui lui aurait évité bien des prises de tête
[/HS]

#17 Re : -1 »  Suis je limité dans choix taille écran : CG ATI Radeon 9200 /128 mo » Le 24/09/2009, à 08:52

raph986
Réponses : 10

J'ai cette écran et il est pas mal du tout. Concernant la connectique, moi je l'utilise avec du DVI mais je pense que tu ne perdras pas trop en qualité d'image avec le VGA. Au pire je fais un test ce soir si tu veux.
Par contre je n'utilise pas les réglages par défaut, je les ai un peu modifier dans l'interface de l'écran.

#18 Re : -1 »  Suis je limité dans choix taille écran : CG ATI Radeon 9200 /128 mo » Le 24/09/2009, à 13:34

raph986
Réponses : 10

La taille ne veut rien dire, ce qui compte c'est la résolution.

#19 Re : -1 »  Suis je limité dans choix taille écran : CG ATI Radeon 9200 /128 mo » Le 24/09/2009, à 15:39

raph986
Réponses : 10

Bin la carte est vieille est pas très performante, ça devrait suffire pour du surf sur internet, du traitement de texte et de la vidéo.
Par contre de là à lire une vidéo avec compiz en même temps, ça risque d'être plus difficile même si pas impossible. Au pire regarde si tu ne trouves pas un écran avec une résolution de 1280*800 ou un peu plus élevé. Dans cette résolution tu ne verras aucune différence entre le vga et le dvi.

#20 Re : -1 »  Ma carte graphique est-elle reconnu ? » Le 23/09/2009, à 11:28

raph986
Réponses : 26

La 9.10 contiendra un nouveau noyau, qui apporte pas mal de choses aux radeon direct x9, donc ça devrait être mieux que le pilote libre actuel. Un live CD devrait te permettre de pouvoir tester ça plus simplement et sans danger.

Sinon, s'il te faut absolument une fonction que ne contient que le pilote propriétaire Catalyst, comme la gestion de l'énergie pour les cartes de PC portables, il faudra installer une version d'Ubuntu plus vieille.

#21 Re : -1 »  Ma carte graphique est-elle reconnu ? » Le 23/09/2009, à 11:36

raph986
Réponses : 26
zack13 a écrit :

Ben je vais attendre alors, mais ca me gonfle parce qu'aujourd'hui la plupart des PCs monté vendu le sont avec une ATI (raison de cout ?).

Certes mais si les PCs sont vendus  avec des cartes ATI aujourd'hui, ce sont des cartes "direct X10", les radeon HD 2000, 3000, ou 4000, qui elles sont supportées par le pilote catalyst (en plus du pilote libre bien sûr).

#22 Re : -1 »  Ma carte graphique est-elle reconnu ? » Le 23/09/2009, à 11:39

raph986
Réponses : 26

Bin tu as un matos vieux de 5 ans, j'ai le même souci que toi, et pour l'instant je reste avec une "vieille" Ubuntu car j'ai besoin de la gestion d'énergie de la carte. Sache qu'il est tout à fait possible d'utiliser des logiciels plus récents sur une Ubuntu un peu vieille.

Concernant Firefox, tu es sûr(e) que tu n'as pas "zommé" sur la page ?!
Clique sur Affichage -> zoom -> normal pour en être sûr(e).

#23 Re : -1 »  Ma carte graphique est-elle reconnu ? » Le 23/09/2009, à 11:48

raph986
Réponses : 26

Bah si elle l'est, mais c'est un bug, le genre de chose qui peut-être corrigée avec la prochaine Ubuntu.

#24 Re : -1 »  ATI pilote proprio » Le 23/09/2009, à 11:46

raph986
Réponses : 2

Attention, tu ne peux pas installer le pilote proprio de ATI sur Jaunty, ta carte n'est plus supportée.
Pour l'installer, il faudra se rabattre sur ubuntu 8.10 ou 8.04.