Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

nombre réponses : 25

#0 Re : -1 »  [Centralisation] "tuxguitar" » Le 30/04/2010, à 15:31

azmeuk
Réponses : 867
royto a écrit :

Bonjour,

je viens de passer à Lucid et TuxGuitar de fonctionne plus.

J'obtiens l'erreur suivante au démarrage  :

Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Control
	at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Control
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
	... 1 more

J'utilise le Opendjk

java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (6b18-1.8-0ubuntu1)
OpenJDK Server VM (build 14.0-b16, mixed mode)

j'ai essayer un réinstall ==> NOK
j'ai rajouter le dépot rzr ==> Tuxguitar n'est pâs encore packagé pour Lucid

Ma version est celle des dépots ubuntu qui est la 1.1-1ubuntu4

Même problème et j'utilise la JRE de Sun.

ramoloss@salameche:~$ java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Client VM (build 16.3-b01, mixed mode, sharing)
ramoloss@salameche:~$ tuxguitar 
Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Control
	at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Control
	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
	... 1 more
ramoloss@salameche:~$

Et pourtant aujourd'hui Lucid est en version stable…
Une idée ?

edit :

sudo aptitude reinstall libswt-gtk-3.5-java libswt-gtk-3.5-jni

Et ensuite ça roule !

#1 Re : -1 »  [Résolu] Vidéos bleutées drivers nvidia » Le 31/10/2009, à 19:14

azmeuk
Réponses : 69
Kanor a écrit :

Il y a aussi la possiblité dans nvidia-setting
X server Xvideo settings
Reset Hardware default

Testé et approuvé.

#2 Re : -1 »  Ctrl - V ( On ne triche pas) » Le 02/11/2008, à 15:24

azmeuk
Réponses : 1377

64a4e8faed1a1aa0bf8bf0fc84938d25

#3 -1 »  Timidity monopolise la sortie audio » Le 13/10/2010, à 14:21

azmeuk
Réponses : 2

Bonjour à tous,
Le problème n'est pas nouveau mais je n'ai pas trouvé de solution sur ce forum, ni sur le forum officiel.
Lorsqu'un programme ( tel que NoteWorthy ) joue via Timidity des sons midi, tous les autres programmes sont rendus muets.

J'essaie d'écrire d'oreille la partition d'un morceau de musique que j'ai en Ogg. D'un coté j'ai donc NoteWorthy pour l'écrire, et d'un autre VLC pour l'écouter. Dans mon cas le problème est que je dois systématiquement fermer NoteWorthy dès que je veux écouter un bout du morceau.

Y'a-t-il donc un moyen pour rendre Timidity un peu moins égoïste ?
Merci d'avance pour votre aide.

#4 Re : -1 »  Timidity monopolise la sortie audio » Le 15/10/2010, à 14:01

azmeuk
Réponses : 2

Salut,
Oui, lancer « aoss ./Noteworthy.exe » ne changer rien à mon problème.

#5 Re : -1 »  [Résolu] LIBVA, VAAPI et VDPAU: nvidia_drv_video.so init failed » Le 06/08/2010, à 11:30

azmeuk
Réponses : 16
wledoux a écrit :

Bon, j'ai essayé de compiler moi-même et maintenant libva semble ok d'après vainfo:

libva: libva version 0.31.1-sds1
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/va/drivers/nvidia_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.31
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA API - 0.6.10
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD

Voici la procédure que j'ai suivi, même si elle est déjà expliquée un peu partout:
….

Après avoir suivi ta méthode, j'obtiens les mêmes résultats que toi avec vainfo. La HD dépasse mon Pentium 4 mais ma Geforce 8600gt devrait se débrouiller avec, or la vidéo n'est pas plus fluide. J'ai VLC 1.1.1 et mplayer installé depuis un dépot obscur. Comment savoir si le lecteur vidéo utilise libva ou pas ?

#6 -1 »  Décodage MPEG matériel, VLC 1.1.1 et Nvidia Geforce 8600gt » Le 02/08/2010, à 13:18

azmeuk
Réponses : 1

Bonjour à tous,
En deux mots, j'ai un ordinateur qui commence à dater, mais qui était haut de gamme à l'époque où je l'ai acheté. Ainsi donc j'ai un Pentium4 3Ghz, 2Go de ram et une Geforce 8600gt. Avec une configuration telle que celle-ci, je fais tout ce que je veux depuis quelques années, excepté lire les vidéos en HD 1080p — les 720i elles, passent généralement bien. J'utilise le driver nvidia propriétaire.

Visiblement, une des nouveauté apporté par la dernière mouture de VLC était l'accélération matérielle pour lire les vidéos, et j'espérai pouvoir alors lire les vidéos HD. Ce n'est pas le cas, et j'aimerais savoir pourquoi.
* Ma carte graphique n'est-elle pas assez puissante ?
* Y a-t-il quelque chose à configurer quelque part ( drivers, vlc, whatever… )
* Faut-il que je cède et m'achète un quad core ?

Merci de m'éclairer.

#7 -1 »  Liens symboliques et NFS » Le 20/11/2009, à 11:53

azmeuk
Réponses : 5

Bonjour à tous
J'ai chez moi un serveur NFS qui partage un dossier /fooobar et un client qui essaye de s'y connecter.
Pour des raisons de praticité j'ai mis dans /foobar des liens symboliques vers d'autres dossiers de mon serveur.
Le problème est que le client interprète les liens symboliques localement, et non plus sur le serveur.

Si par exemple j'avais mis dans ./foobar un lien symbolique vers /home, et voulant que le dossier pointe vers le /home de mon serveur, alors depuis le client le lien aurait pointé vers le /home de mon client.

Comment faire donc pour faire des liens symboliques "en dur" sur le serveur ?

Merci pour votre aide.

#8 Re : -1 »  Liens symboliques et NFS » Le 20/11/2009, à 15:52

azmeuk
Réponses : 5

Tu ne te trompes pas, je suis donc parti pour partager tous mes liens symboliques proprement dans /etc/export ?

#9 -1 »  Problème au lancement de Dragon Naturally Speaking 9.5 via wine » Le 20/03/2009, à 16:10

azmeuk
Réponses : 3

Salut à tous
J'ai une Ubuntu à jour et la dernière version de wine obtenue sur les dépots de wine. J'ai installé Dragon Naturally Speaking 9.5 sans encombre mais le programme refuse de se lancer.
Les messages d'erreurs obtenus sont relativement vagues :
"Une erreur sérieuse est survenue lors de l'initialisation du moteur vocal de NaturallySpeaking. Essayez de réinstaller afin de réparer ce problème."
"Une erreur interne est survenue"
Comment faire pour régler ce problème. Y a-t-il des version de DNS qui ne bugguent pas ? Est-ce que la même erreur survient chez vous ?
Merci pour votre aide.

#10 -1 »  Questions sur l'inclusion de fichier avec Anuta » Le 02/06/2009, à 00:42

azmeuk
Réponses : 1

Bonjour à tous.
J'ai un projet avec Anjuta, et avant de vous expliquer mon problème je vais vous montrer brièvement ce qu'il contient :

/mesfichiers/main.cpp
/sesfichiers/foo/fichier1.cpp
/sesfichiers/bar/fichier2.cpp

La première ligne de main.cpp est :

#include "../sesfichiers/foo/fichier1.cpp"

La première ligne de fichier1.cpp est :

#include "bar/fichier2.cpp"

J'ai ajouté les répertoires "mesfichiers" et "sesfichiers" en tant que "groupes" dans anjuta. Les trois fichiers sources ont été ajoutés à mon exécutable dans anjuta.
Voici dans quelle situation je me trouve. J'ai besoin dans mon projet d'inclure des fichiers appartenant à un autre projet (sesfichiers) et de ne pas les modifier. (Si je commence à les modifier alors il faudra que je fasse ça à chaque release, c'est assez embettant)

A la compilation, le compilateur me dit bien évidemment qu'il ne trouve pas "bar/fichier2.cpp". J'aimerais savoir s'il existe une astuce pour ajouter "sesfichiers" à la liste des répertoires à parcourir par le compilateur pour inclure un fichier.
Si je ne suis pas clair dites le moi, je tenterais de réexpliquer.

Merci pour votre aide.

#11 -1 »  VLC et Jaunty - Comment re-grouper le player et l'interface ? » Le 12/05/2009, à 13:13

azmeuk
Réponses : 5

Salut à tous
Je suppose que c'est la même chose chez vous, VLC depuis le passage à Jaunty garde l'écran de lecture vidéo séparé de l'interface, et ce sur tous les pays que j'ai vu sous Jaunty. J'ai eu beau chercher dans la configuration et changer les différents modes d'affichage, rien n'y fait. J'ai cherché dans la documentation du site officiel et je ne trouve rien.
Quelqu'un aurai-t-il une idée pour résoudre tout ça ?

Merci d'avance

#12 Re : -1 »  Problèmes résolution intel x3100 ubuntu 8.04 » Le 20/07/2008, à 20:15

azmeuk
Réponses : 6

Je remonte ce post car je suis dans la même situation. Si quelqu'un a la solution, elle est toujours la bienvenue

#13 -1 »  Faire un système de MX failover » Le 20/04/2009, à 05:43

azmeuk
Réponses : 1

Salut à tous
J'aimerais pour quelques raisons héberger moi même mes emails. J'ai donc un serveur qui tourne sous ubuntu avec un postfix plus ou moins configuré dessus, plus ou moins fonctionnel, et des amis qui ont chez eux leur propre serveur.
Le problème que j'ai est que comme je n'ai qu'une connexion ADSL, elle est soumise aux aléas de la maintenance, des travaux dans ma rue etc ... et de plus il arrive (rarement mais tout de même) à mon serveur d'avoir des interruptions. Bref ce que je voudrais c'est que lorsque mon serveur est indisponible, les mails soient récupérés par les serveurs de mes amis, et que par la suite mon serveur se synchronise avec les autre et récupère les mails.
Je ne sais pas trop par où commencer à part donner leurs adresse IP comme MX secondaire, je n'ai aucune idée sur la manière de resynchroniser les serveurs.
Je peux au besoin créer un VPN entre les serveurs afin de sécuriser et de faciliter les échanges.
Auriez-vous une piste à me donner, voire des explications sur comment m'y prendre ?
Merci

#14 -1 »  Enregistrer du son et l'écouter simultanément sur les enceintes » Le 02/02/2009, à 12:59

azmeuk
Réponses : 2

Bonjour
J'ai un problème qui ne devrait pas être trop compliqué à régler, mais que me pose réellement souci. J'aimerais m'enregistrer jouer de la guitare. J'utilise jokosher et l'enregistrement marche très bien, à ça près que je n'entends pas dans les enceintes ce que j'enregistre, je n'ai aucun retour. J'ai essayé de farfouiller les divers menus de configuration sonore, et ce forum, mais en vain. L'un d'entre vous sait-il comment résoudre ce problème ?
Merci

#15 Re : -1 »  Enregistrer du son et l'écouter simultanément sur les enceintes » Le 02/02/2009, à 13:13

azmeuk
Réponses : 2

Audacity me pose le même problème. smile
Je pensais à une solution plus générale en passant directement par alsa/pulseaudio mais trouver un logiciel d'enregistrement qui corrige ça est une bonne idée.
Audacity refuse d'enregistrer lorsque je coche "Passage ausio logiciel" dans les préférences...

#16 -1 »  Faire un pont entre l'entrée audio et la sortie audio » Le 29/10/2008, à 20:21

azmeuk
Réponses : 0

Bonjour à tous
Je tourne sous Intrepid et je joue un peu de guitare électrique, que j'ai branchée à l'entrée audio de ma machine. Le problème que j'ai est que je ne peux m'entendre qu'en enregistrant ce que je joue et le lire ensuite. Est-il possible avec pulseaudio (ou n'importe quoi d'autre) d'avoir un retour en temps réel de ce qui rentre ? Ce qui reviendrait à faire un "pont" entre l'entrée audio et la sortie audio.
Merci pour votre aide
Au passage si vous avez des conseils pour la MAO sous Linux (Faut que je fouille Linuxmao.org)...

#17 Re : -1 »  topic des ingé qui s'ennuient au boulot » Le 29/05/2008, à 15:22

azmeuk
Réponses : 3033

Plaignez vous tous, moi à mon stage ils veulent me faire faire de l'ASP...
C'est une telle horreur que je suis surpris de voir qu'on a donné un nom à ce langage ....

#18 -1 »  Gérer plusieurs claviers et souris indépendemment » Le 09/08/2008, à 22:16

azmeuk
Réponses : 1

Salut à tous
Une question me passe par la tête. Existe-t-il un programme permettant de gérer indépendamment deux souris avec ubuntu (à savoir deux curseurs à l'écran), contrôlant chacune le focus d'un clavier ?
Avez-vous donc entendu parler de quelque chose du genre?

#19 Re : -1 »  Google ! :/ » Le 28/05/2008, à 01:49

azmeuk
Réponses : 50

Ah la bonne vieille théorie du complot ...
Pour ma part j'ai essayé exalead pendant un moment, et je dois avouer que j'étais assez déçu. J'ai pas d'exemple concret à l'appui, mais en général les résultats sont moins pertinents (enfin la pertinence c'est très subjectif ...). Un exemple qui m'est souvent arrivé c'est d'entrer un mot clé en cherchant son site officiel (du genre je tape "rape à fromage" et si le site rapeafromage.com n'est pas en premier, ça me gêne un peu).
C'est difficile je trouve de cracher sur la figure de google parce qu'ils sont performants et accessibles (ils font pas payer beaucoup de choses, leurs pages sont simples)...

Ça me fait un peu marrer. La plupart des gens crient à l'espionnage et au voyeurisme, et les réseaux sociaux du genre de facebook n'ont jamais connu un tel essor. Faudrait savoir sur quel pied danser hein smile

En revanche je dois bien avouer que le fait que Google joue sur tous les terrains devient finalement un peu oppressant. Enfin au stade où c'en est, faudrait que Google devienne libre smile

#20 Re : -1 »  Google ! :/ » Le 29/05/2008, à 15:00

azmeuk
Réponses : 50

Personnellement si je suis chez gmail c'est pour son filtre antispam super puissant (c'est vrai je peux donner mon mail en clair sur nimporte quel site, j'ai une chance sur mille d'avoir un spam dans ma boîte de réception). Connaissez vous un serveur mail qui a un tel antispam?

#21 Re : -1 »  Windows Seven, le tactile et doigts sales ? Arrêt de travail... » Le 29/05/2008, à 19:33

azmeuk
Réponses : 19

Et en quoi un écran tactile c'est plus sale qu'un clavier, qu'une souris ou qu'une poignée de porte ?

#22 Re : -1 »  Windows Seven, le tactile et doigts sales ? Arrêt de travail... » Le 29/05/2008, à 20:48

azmeuk
Réponses : 19

Nan mais sans déconner faut arrêter un peu la parano.
Quand t'ouvres un poignée de porte tu te demande pas qui est passé par là avant, et ce qu'il a pû faire de ses mains. Quand tu t'agrippes à une barre dans un bus ou dans un tram c'est pareil.
A mon avis une lunette de chiotte ne contient pas plus de microbe que n'importe quel objet que tu peux trouver dans ta maison. L'urine et les selles étant stériles j'ai du mal à croire qu'on y trouve des hordes de microbes prêts à sauter sur le premier signe de vie qui passe. Et oui c'est pas facile de se dire que contrairement aux apparences notre cul est bien plus propre que notre bouche...
Donc, arrêtons un peu la parano, un clavier, un écran tactile ou ce que vous voulez d'autre n'est pas "sale". La grippe ne se transmet pas au moyen d'un clavier d'ordinateur, et personne n'est jamais tombé malade en allant pisser dans les chiottes publiques les plus dégueux qui soient...

#23 Re : -1 »  (RESOLU) Problème carte réseau Realtek RTL 8168C/8111C Family PCI-E » Le 04/05/2008, à 00:06

azmeuk
Réponses : 12

Bonjour
Tout d'abord est-il possible d'enlever le [Résolu] dans le titre ? Aucune réponse satisfaisante n'a été donnée.
Moi aussi j'ai le même problème, mais étant avec un pc portable je peux pas changer de carte réseau smile

Bref l'erreur se passe lors de la compilation du driver, j'ai la même.

Un mec a le même problème ici et je ne comprend pas bien ce que demande de faire le rien contenu dans une réponse plus bas.

#24 -1 »  Problèmes à l'installation de timidity, alsa ou puleaudio en cause ? » Le 07/05/2008, à 02:36

azmeuk
Réponses : 4

Bonjour à tous
J'ai innocemment voulu installer timidity pour pouvoir faire marche tuxguitar, mais les dieux en ont décidé autrement. (C'est Apollon le dieu de la musique me semble-t-il, on va dire que c'est de sa faute alors!).
J'ai une upgrade toute fraiche depuis gusty (toute fraîche parcequ'une fois installée, gusty ne m'a pas servi, j'ai juste upgradé vers hardy ensuite), le son marche très bien, mais j'arrive pas à installer timidity. Voici un dump:

azmeuk@bulbi:~$ sudo aptitude install timidity
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Construction de la base de données des étiquettes... Fait
Les NOUVEAUX paquets suivants vont être automatiquement installés :
  libartsc0 
Les NOUVEAUX paquets suivants vont être installés :
  libartsc0 timidity 
0 paquets mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 666ko d'archives. Après dépaquetage, 2093ko seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Écriture de l'information d'état étendu... Fait
Prendre :1 http://be.archive.ubuntu.com hardy/main libartsc0 1.5.9-0ubuntu2 [17,4kB]
Prendre :2 http://be.archive.ubuntu.com hardy/universe timidity 2.13.2-19ubuntu1 [649kB]
666ko téléchargés en 1min8s (9775o/s)                                           
Sélection du paquet libartsc0 précédemment désélectionné.
(Lecture de la base de données... 157867 fichiers et répertoires déjà installés.)
Dépaquetage de libartsc0 (à partir de .../libartsc0_1.5.9-0ubuntu2_amd64.deb) ...
Sélection du paquet timidity précédemment désélectionné.
Dépaquetage de timidity (à partir de .../timidity_2.13.2-19ubuntu1_amd64.deb) ...
Paramétrage de libartsc0 (1.5.9-0ubuntu2) ...

Paramétrage de timidity (2.13.2-19ubuntu1) ...
 * Starting TiMidity++ ALSA midi emulation...                                   ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
                                                                         [fail]
invoke-rc.d: initscript timidity, action "start" failed.
dpkg : erreur de traitement de timidity (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Des erreurs ont été rencontrées pendant l'exécution :
 timidity
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
Paramétrage de timidity (2.13.2-19ubuntu1) ...
 * Starting TiMidity++ ALSA midi emulation...                                   ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
                                                                         [fail]
invoke-rc.d: initscript timidity, action "start" failed.
dpkg : erreur de traitement de timidity (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 timidity
Lecture des listes de paquets... Fait             
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Construction de la base de données des étiquettes... Fait
azmeuk@bulbi:~$

On dirait qu'alsa a un petit problème, d'ou viendrait-ce ? Est-ce la faute à pulseaudio ?
Merci de m'éclairer.