Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 25

#0 Re : -1 »  Darktable » Le 16/12/2014, à 21:54

kikislater
Réponses : 350

+1 pour l'upgrade + l'ajout du ppa darktable pour bénéficier d'une version plus récente. La version 1.0 étant sortie en 2012 et la 0.9.5 date de 2011 ça me parait normal que ton boitier ne soit pas supporté. Le support du 100D est apparu dans la 1.2.2 => http://www.darktable.org/2013/06/releas … ble-1-2-2/
On est actuellement à la 1.6

#1 Re : -1 »  vos creations blender » Le 05/09/2014, à 09:37

kikislater
Réponses : 551

Tu fais de jolies lumières maintenant, c'est sympa, j'aimerais pouvoir en faire autant !

#2 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 13:54

kikislater
Réponses : 153
symba a écrit :

Sous synaptic, quand je tape qgis, voilà ce qu'il me restait d'installé:

qgis-common
qgis-plugin-globe-common
qgis-plugin-grass-common
qgis-providers-common

J'ai tout supprimé par synaptic et relancé l'installation de qgis par sudo apt-get install qgis

Du coup tout fonctionne désormais wink

Merci du retour !
Évite de mélanger ces deux dépôts à l'avenir ils ont des dépendances non complémentaires comme tu as pu le voir ...

#3 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 09/09/2013, à 14:08

kikislater
Réponses : 153
symba a écrit :

Oui merci beaucoup pour ton aide.
Une fois qu'on a compris le conflit ça va mieux, mais j'avais du mal à identifier ce que relève d'un dépôt ou d'un autre.
Du coup il vaut mieux que je supprime carrément mon dépôt qgis dans synaptic?

Edit: en fait le dépôt est déjà décoché.

Tu peux le supprimer carrement oui. De toute façon avec ce dépôt tu fais une croix sur l'ecw donc vu que pour toi c'est primordial tu peux le supprimer ...

#4 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 19/09/2013, à 14:36

kikislater
Réponses : 153

Ah tiens, la v2.0 est sur le ppa en effet !

Je veux bien la réponse de ça :

gdalinfo --formats | grep ECW
apt-cache policy gdal-bin
apt-cache policy gdal
apt-cache policy libgdal-ecw
apt-cache policy libgdal-ecw-src
ls /usr/lib/gdalplugins
ls /usr/src/

#5 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 19/09/2013, à 19:00

kikislater
Réponses : 153

Il manque du  coup le :
apt-cache policy qgis*

#6 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 19/09/2013, à 20:27

kikislater
Réponses : 153
sudo apt-get remove libqgis1.8.0 libqgis

Pour ta version de qgis il ne propose pas la 2.0 dans ta configuration. Tu peux refaire un

sudo apt-get update 

et renvoyer le résultat de apt-get update et de apt-cache policy qgis

#7 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 20/09/2013, à 09:47

kikislater
Réponses : 153

Tu as donc supprimé le dépôt du ppa !
Allez hop on reprend depuis le début :

# 1 - Installation de la lib ECW 3.3
cd /tmp/
wget -c http://www.riderducoin.com/ubuntu1/pool/main/libe/libecwj2/libecwj2_3.3-3_i386.deb
sudo dpkg -i libecwj2_3.3-3_i386.deb
sudo ldconfig


# 2 - Ajout du dépôt PPA UBUNTUGIS
sudo add-apt-repository -y ppa:unbuntugis-unstable
sudo apt-get update
sudo apt-get install -y qgis libgdal-ecw-src

# 3 - Compilation automatique de la lib ecw pour gdal
sudo gdal-ecw-build /usr

# 4 - Vérification du support ecw dans gdal 
gdalinfo --formats | grep ECW

Tu le renvoies chaque étape et je te dirais si ça bloque ou pas

#8 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 20/09/2013, à 14:47

kikislater
Réponses : 153

Euh en effet j'ai mal tapé le dépôt !
Il faut que tu supprimes celui que je t'ai fait rajouté unbuntugis au lieu de ubuntugis...


# 2 - Ajout du dépôt PPA UBUNTUGIS
sudo add-apt-repository -y ppa:ubuntugis-unstable
sudo apt-get update
sudo apt-get install -y qgis libgdal-ecw-src

#9 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 20/09/2013, à 16:52

kikislater
Réponses : 153
Manush a écrit :

en fait j'ai tout un tas de ppa gis-unstable dans le gestionaire de mises à jour mais ils sont décochés donc ne devraient pas poser de pbs ?

le résultat de sudo add-apt-repository -y ppa:ubuntugis-unstable :

Error reading https://launchpad.net/api/1.0/~ubuntugis-unstable/+archive/ppa: Not Found

celui de sudo apt-get update :

Réception de : 1 http://security.ubuntu.com raring-security Release.gpg [933 B]
Atteint http://extras.ubuntu.com raring Release.gpg                            
Atteint http://archive.canonical.com raring Release.gpg                        
Ign http://ppa.launchpad.net raring Release.gpg                                
Atteint http://fr.archive.ubuntu.com raring Release.gpg                        
Réception de : 2 http://security.ubuntu.com raring-security Release [40,8 kB]  
Atteint http://extras.ubuntu.com raring Release                                
Atteint http://archive.canonical.com raring Release                            
Ign http://ppa.launchpad.net raring Release                                    
Atteint http://fr.archive.ubuntu.com raring-updates Release.gpg                
Atteint http://fr.archive.ubuntu.com raring-backports Release.gpg              
Atteint http://extras.ubuntu.com raring/main Sources                           
Atteint http://archive.canonical.com raring/partner i386 Packages              
Réception de : 3 http://security.ubuntu.com raring-security/main Sources [42,1 kB]
Atteint http://fr.archive.ubuntu.com raring Release                            
Atteint http://extras.ubuntu.com raring/main i386 Packages                     
Atteint http://fr.archive.ubuntu.com raring-updates Release                    
Réception de : 4 http://security.ubuntu.com raring-security/restricted Sources [14 B]
Atteint http://fr.archive.ubuntu.com raring-backports Release                  
Réception de : 5 http://security.ubuntu.com raring-security/universe Sources [9 279 B]
Atteint http://fr.archive.ubuntu.com raring/main Sources                       
Réception de : 6 http://security.ubuntu.com raring-security/multiverse Sources [2 266 B]
Atteint http://fr.archive.ubuntu.com raring/restricted Sources                 
Réception de : 7 http://security.ubuntu.com raring-security/main i386 Packages [109 kB]
Atteint http://fr.archive.ubuntu.com raring/universe Sources                   
Atteint http://fr.archive.ubuntu.com raring/multiverse Sources                 
Atteint http://fr.archive.ubuntu.com raring/main i386 Packages                 
Réception de : 8 http://security.ubuntu.com raring-security/restricted i386 Packages [14 B]
Atteint http://fr.archive.ubuntu.com raring/restricted i386 Packages           
Réception de : 9 http://security.ubuntu.com raring-security/universe i386 Packages [37,1 kB]
Atteint http://fr.archive.ubuntu.com raring/universe i386 Packages             
Réception de : 10 http://security.ubuntu.com raring-security/multiverse i386 Packages [3 864 B]
Atteint http://fr.archive.ubuntu.com raring/multiverse i386 Packages           
Ign http://archive.canonical.com raring/partner Translation-fr_FR              
Atteint http://security.ubuntu.com raring-security/main Translation-en         
Ign http://extras.ubuntu.com raring/main Translation-fr_FR                     
Ign http://archive.canonical.com raring/partner Translation-fr                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-fr                
Ign http://extras.ubuntu.com raring/main Translation-fr                        
Ign http://archive.canonical.com raring/partner Translation-en                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-en                
Ign http://extras.ubuntu.com raring/main Translation-en                        
Err http://ppa.launchpad.net raring/main i386 Packages                         
  404  Not Found
Atteint http://security.ubuntu.com raring-security/multiverse Translation-en   
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-fr   
Ign http://ppa.launchpad.net raring/main Translation-fr_FR              
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-en   
Ign http://ppa.launchpad.net raring/main Translation-fr                 
Ign http://ppa.launchpad.net raring/main Translation-en                 
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-fr   
Atteint http://security.ubuntu.com raring-security/restricted Translation-en   
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-en          
Atteint http://fr.archive.ubuntu.com raring/universe Translation-fr            
Atteint http://security.ubuntu.com raring-security/universe Translation-en     
Atteint http://fr.archive.ubuntu.com raring/universe Translation-en            
Atteint http://fr.archive.ubuntu.com raring-updates/main Sources               
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Sources         
Atteint http://fr.archive.ubuntu.com raring-updates/universe Sources           
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Sources         
Atteint http://fr.archive.ubuntu.com raring-updates/main i386 Packages         
Atteint http://fr.archive.ubuntu.com raring-updates/restricted i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-updates/universe i386 Packages     
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-updates/main Translation-en        
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/universe Translation-en    
Atteint http://fr.archive.ubuntu.com raring-backports/main Sources             
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/universe Sources         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/main i386 Packages       
Ign http://security.ubuntu.com raring-security/main Translation-fr_FR          
Atteint http://fr.archive.ubuntu.com raring-backports/restricted i386 Packages 
Ign http://security.ubuntu.com raring-security/main Translation-fr             
Atteint http://fr.archive.ubuntu.com raring-backports/universe i386 Packages   
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr_FR    
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse i386 Packages 
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr       
Ign http://security.ubuntu.com raring-security/restricted Translation-fr_FR    
Ign http://security.ubuntu.com raring-security/restricted Translation-fr       
Atteint http://fr.archive.ubuntu.com raring-backports/main Translation-en      
Ign http://security.ubuntu.com raring-security/universe Translation-fr_FR      
Ign http://security.ubuntu.com raring-security/universe Translation-fr         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/universe Translation-en  
Ign http://fr.archive.ubuntu.com raring/main Translation-fr_FR                 
Ign http://fr.archive.ubuntu.com raring/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr
246 ko réceptionnés en 33s (7 441 o/s)
W: Impossible de récupérer http://ppa.launchpad.net/ubuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

et celui de sudo apt-get install -y qgis libgdal-ecw-src :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgdal-ecw-src est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 qgis : Dépend: libgdal1 (>= 1.9.0) mais ne sera pas installé
        Dépend: libqgis1.7.5 mais ne sera pas installé
        Dépend: qgis-providers (= 1.7.4+1.7.5~20120320-1.1) mais ne sera pas installé
        Recommande: qgis-plugin-grass mais ne sera pas installé
        Recommande: python-qgis mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Ouais pardon encore manque de rigueur c'est ça :

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable

#10 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 20/09/2013, à 17:10

kikislater
Réponses : 153

Tu as ça qui n'est pas bon :

W: Impossible de récupérer http://ppa.launchpad.net/ubuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

C'est la mauvaise ligne que je t'ai donné. Pour le nettoyer, tu peux redonner :

ls /etc/apt/sources.list.d/

#11 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 21/09/2013, à 18:22

kikislater
Réponses : 153

Il reste une manip !

Donc le plus simple :

sudo rm -rf /etc/apt/sources.list.d/ubuntugis*
sudo rm -rf /etc/apt/sources.list.d/unbuntugis*
sudo apt-get update
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable 
sudo apt-get update 

Et voilà ce sera fini

#12 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 08/10/2013, à 15:15

kikislater
Réponses : 153
bonuscad a écrit :

Bonjour,
Bonjour,
Juste un remerciement particulier à kikislater pour ce fil sur les ECW, il m'a permis (non sans mal) à rendre effectif la lecture des ECW sous QGis 2.0 sous un un environnement Xubuntu 12.04 LTS.

Question (bien que tout soit fonctionnel), est ce normal que seule la commande apt-cache policy gdal ne me renvoie rien? (N: Impossible de trouver le paquet gdal)
C'est juste par curiosité...

Merci encore, car j'aurais bien été incapable de mettre ceci en place sans ce fil de discussion.

big_smile

Oui le paquet s'appelle gdal-bin et non plus gdal c'est un méta paquet : https://launchpad.net/ubuntu/+source/gdal

Donc si tu fais

apt-cache policy gdal-bin 

tu devrais avoir une réponse ou encore

apt-cache policy gdal*

Je suis content que certaines personnes puissent utiliser apt-cache policy à présent. Est-ce de ma faute ou pas ?

#13 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 04/09/2014, à 09:34

kikislater
Réponses : 153

Salut Silvio,

En effet ça a changé un petit peu. Je te donne la méthode ici :
Si tu n'as pas compilé la lib ECW il faut que tu fasses ça :

### ECW source : https://aur.archlinux.org/packages/li/libecwj2/
sudo mkdir -p /opt/compil-sig
sudo chown $USER -R /opt/compil-sig
cd /opt/compil-sig
wget -c http://mirror.ovh.net/gentoo-distfiles/distfiles/libecwj2-3.3-2006-09-06.zip
wget -c https://aur.archlinux.org/packages/li/libecwj2/libecwj2.tar.gz
unzip libecwj2-3.3-2006-09-06.zip
tar zvxf libecwj2.tar.gz
cd libecwj2-3.3/
# Memory leak patches from http://trac.osgeo.org/mapserver/ticket/3245
patch -p0 -i ../libecwj2/libecwj2-3.3-3245a.patch
patch -p0 -i ../libecwj2/libecwj2-3.3-3245b.patch
# Memory overflow patch from http://trac.osgeo.org/gdal/ticket/3366
patch -p0 -i ../libecwj2/libecwj2-3.3-NCSPhysicalMemorySize-Linux.patch
# Fix crash creating 16bit JP images on x86_64 from http://trac.osgeo.org/gdal/ticket/2593
patch -p0 -i ../libecwj2/libecwj2-3.3-2593.patch
# Gentoo patch
patch -Np 0 -i ../libecwj2/libecwj2-3.3-nolcms.patch
rm -rf Source/C/libjpeg Source/C/NCSEcw/lcms
# Gentoo bug 328075
sed -i -e "s:includeHEADERS_INSTALL:INSTALL_HEADER:" \
Source/NCSBuildGnu/Makefile.am || return 1
# std::length_error bug
patch -p0 -i ../libecwj2/libecwj2-3.3-wcharfix.patch
autoreconf -i
./configure --prefix=/usr
make -j8 # j8 = nombre de cores
sudo checkinstall -D -y --install=yes --maintainer=sylvain.poulain@yahoo.fr --pkgname=libecwj2 --pkgversion=3.3
sudo ldconfig
sudo mv *.deb ../

Puis le plugin ECW pour gdal :

#Ajout du dépôt 
sudo add-apt-repository -y ppa:ubuntugis/ubuntugis-unstable 
sudo apt-get -y update 
sudo apt-get install -y gdal-bin
wget -c http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/pool/main/libg/libgdal-ecw/libgdal-ecw-src_1.10.0-1~quantal3_all.deb
dpkg-deb -x libgdal-ecw-src_1.10.0-1~quantal3_all.deb ecw-src
sudo cp ecw-src/usr/bin/gdal-ecw-build /usr/local/bin/
sudo cp ecw-src/usr/src/libgdal-ecw-1.10.0.tar.gz /usr/src/
sudo gdal-ecw-build /usr
sudo mkdir -p /usr/lib/gdalplugins/1.11/
sudo cp /usr/lib/gdalplugins/1.10/gdal_ECW_JP2ECW.so /usr/lib/gdalplugins/1.11/
gdalinfo --formats | grep ECW # Vérification

#14 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 04/09/2014, à 16:44

kikislater
Réponses : 153

Non c'est bien pour ubuntu. La méthode et notamment les patch a bien été résumé sur archlinux dont je me suis inspiré pour répondre.
Quand une ligne commence par # il s'agit de commentaires :-;

Tiens nous au courant

#15 Re : -1 »  [QGis 1.8] Lire ECW sous Ubuntu 12.10 » Le 05/09/2014, à 09:24

kikislater
Réponses : 153

Effectivement ça fait partie des dépendances.
Désolé pour l'oubli

Le checkinstall sert juste à créer un deb et pour désinstaller la lib ecw avec apt-get par la suite si jamais vous n'en voulez plus.
Exemple :

sudo apt-get remove libecwj2

#16 Re : -1 »  Dell XPS 13 » Le 28/02/2014, à 20:00

kikislater
Réponses : 70

Ça dépend des perceptions ... 13 pour moi c'est ok

#17 Re : -1 »  Dell XPS 13 » Le 01/03/2014, à 09:17

kikislater
Réponses : 70

Et un écran externe ne serait pas mieux ?

#18 Re : -1 »  Dell XPS 13 » Le 02/03/2014, à 10:42

kikislater
Réponses : 70

13" en déplacement dans l'avion ou dans le train c'est l'idéal. Si c'est pour utiliser dans un autre espace la question ne se pose pas.
Le xps 13 est une bonne bécane mais le processeur est bridé : U => ultra low voltage et du coup le chipset graphique également.

C'est pour faire tourner quoi comme application 3d?

Le xps 13 à mon avis tu peux modéliser mais pour le rendu vu que ça prend du temps, mieux vaut avoir un desktop à côté et faire les traitements/rendus sur le desktop !

#19 Re : -1 »  Dell XPS 13 » Le 02/03/2014, à 11:23

kikislater
Réponses : 70

Au final je dirais que pour de la modélisation, les intels fonctionnent bien mais pour du calcul 3d, il faut plus puissant. Après les calculs se font souvent sur le cpu et non sur le gpu même si c'est en train de changer ...

#20 Re : -1 »  Dell XPS 13 » Le 07/03/2014, à 15:03

kikislater
Réponses : 70

smile
Bon choix

#21 Re : -1 »  Dell XPS 13 » Le 08/03/2014, à 21:44

kikislater
Réponses : 70

Ah oui ce délai !

#22 Re : -1 »  Catia V5 sous linux grâce à wine ! » Le 03/04/2014, à 18:11

kikislater
Réponses : 126

Concrètement : changer ton environnement de bureau. Ne plus utiliser Unity qui bouffe de la 3D et forcer à utiliser ton ATI en lieu et place de l'intel

#23 Re : -1 »  Catia V5 sous linux grâce à wine ! » Le 03/04/2014, à 20:15

kikislater
Réponses : 126

Il faudrait tester dans ce cas via wine direct et/ou aussi un jeu via wine

#24 Re : -1 »  Catia V5 sous linux grâce à wine ! » Le 04/04/2014, à 13:43

kikislater
Réponses : 126

Quelques infos ici :
http://appdb.winehq.org/objectManager.p … &iId=28516

Ensure you are installing Catia V5R20 on a 64 bits Wine prefix.

Default wine prefix created with PlayOnLinux is 32 bits environnement and 64 bits is available too, but only by browsing configuration menu.