Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  Ubuntu 11.04 + broadcom device = Wifi qui ne fonctionne pas ! » Le 06/06/2011, à 04:14

Sylau
Réponses : 30

J'ai toujours eu ce problème aussi, si vous désactivez (Fn+F2) sous Windows, il est comme vérouillé et vous ne pouvez pas l'activer sous Ubuntu, faut toujours le laisser activé sous Window$ à l'arrêt!!!

#1 -1 »  serveur secondaire teste serveur primaire via le web, et inversement » Le 20/08/2010, à 16:07

Sylau
Réponses : 2

Voici ma config:

[réseau privé]----[switch]----[serveur #1]----{web}----[routeur]----[serveur #2]
Postulats:
    - J'ai deux adresses no-ip puisque j'ai des ip dynamiques
    - #1 est mon gateway, dhcp, pxe, etc pour mon réseau privé (chez moi)
    - #1 est aussi mon serveur web, ftp, svn, etc PRINCIPAL
    - Le switch fut jadis un routeur, mais #1 ayant pris le relais, il ne sert plus que de switch
    - À partir de routeur et vers la droite, tout est chez ma partenaire
    - Le routeur est configuré avec une redirection des ports utiles vers #2
    - #2 est mon serveur backup, il sert de serveur de développement, il doit prendre le relai si #1 est down
    - Les deux serveurs sont de vieux ordis (#2: p3 600mhz, #1 AMD 1Ghz), NE PAS SORTIR D'USINE À GAZ

Donc, voici le problème:
je cherche un moyen efficace, pas trop coûteux en traffic (je suis encore sous quotas, pour l'instant), pour que #2 teste (via internet, évidemment) si #1 est toujours up et qu'il prenne le relai si #1 est down.
Et inversement aussi, je veux que #1 teste si #2 est actif.

Je sais configurer les no-ip en ligne de commande, là où je patauge, c'est dans la méthode de vérif.

J'ai pensé au ping, tout simplement, mais je ne saurai que si #1 roule, pas ce qui est accessible.
J'ai pensé ouvrir un socket, pour que #2 demande à #1 "teste-toi", #1 vérifie ses services, et réponde "c'est bon!!", mais je ne sais pas utiliser les sockets en shell script

Quelqu'un à une idée???

#2 Re : -1 »  serveur secondaire teste serveur primaire via le web, et inversement » Le 21/08/2010, à 20:31

Sylau
Réponses : 2

Merci beaucoup, déjà pouvoir mettre un terme sur ce que je cherche, c'est un très bon début.

Sinon, j'aimerais faire de l'ip failover complet, puisque je vois mal #2 servir le site, et devoir contacter #1 pour la bdd, ou pour le php.

#3 -1 »  lftp et un nom d'utilisateur du type mon@user » Le 30/06/2010, à 21:58

Sylau
Réponses : 10

Voilà, sur mon serveur, je tente de me connecter sur un serveur ftp.
La commande est simple: lftp username@serveur.com.
Mon problème est que mon username contient un '@' et je ne peux pas le changer pour un username n'en contenant pas, comme dans mon@username.
J'ai l'étrange impression que lftp comprend que mon est mon nom d'utilisateur, et que username est le serveur sur lequel je veux me connecter.
J'ai tenter de lui ajouter mon mot de passe (mon@username:motdepasse@serveur.com), sans succès, j'ai tenté avec un fichier lftp -f fichier (où fichier contenait 'user mon@user motdepasse'), sans succès, j'ai essayé 'mon@user'@serveur.com, en vain, j'ai même tenté mon\@user@serveur.com sans réussir.
Comment faire pour qu'il fasse ce que je pense, pas ce que je lui dis???
merci

#4 Re : -1 »  lftp et un nom d'utilisateur du type mon@user » Le 01/07/2010, à 04:51

Sylau
Réponses : 10

D'accord, peut-être que la connexion est bonne.  J'avais assumé ceci puisque j'avais toujours le même comportement, bon mot de passe ou pas.
Par contre, après quelques essais supplémentaires, je constate que lors d'un cd, il change quand même de dossier, même avec un mauvais mot de passe.
Par contre, lors d'un ls, il me donne un "520 Bad login", ou quelque chose du genre
Aussi, lors d'un pwd, je constate "ftp://mon%40user.com:password@serveur.com/", je me demande si le %40 est normal à la place du '@'
Sinon, avec le bon mot de passe, le comportement est le suivant:
1) lftp "mon@user":password@serveur.com
2) lftp mon@user:password@serveur.com:~>cd dossier
cd ok, cwd=/dossier
3) mirror -R /path/pour/mon/dossier
Getting directory contents (0) [Making data connection...]
*puis, après quelque secondes*
Getting directory contents (0) [Delaying before reconnect: 20]
Getting directory contents (0) [Not connected]
et ça boucle, avec un décompte de plus en plus long

C'est quand même le backup de ma base de données.
ÀÀÀÀÀ LLL'AAAAIIIIIDDDDEEEE

#5 Re : -1 »  lftp et un nom d'utilisateur du type mon@user » Le 04/07/2010, à 16:49

Sylau
Réponses : 10

Je viens d'essayer à l'instant, et toujours le même comportement sad

J'ai une solution alternative (ftp à l'université), mais l'espace étant très limité, ce ne peut être que temporaire.

#6 Re : -1 »  lftp et un nom d'utilisateur du type mon@user » Le 13/07/2010, à 16:18

Sylau
Réponses : 10

toto@titi:~$ lftp
lftp :~> open ftp.mon.serveur.com
lftp ftp.mon.serveur.com:~> user user@username.com pass
lftp user@username.com@ftp.mon.serveur.com:~> ls
Getting directory contents (0) [Making data connection...]
*puis, après quelque secondes*
Getting directory contents (0) [Delaying before reconnect: 20]
Getting directory contents (0) [Not connected]

Donc, je suis toujours dans la même position.

Merci beaucoup wangzi

Inspiré par Uggy, j'ai aussi essayé:

lftp :~> open ftp.mon.serveur.com
lftp ftp.mon.serveur.com:~> user user%40username.com pass
en vain

Avis à tous, il n'est toujours pas trop tard.

#7 Re : -1 »  lftp et un nom d'utilisateur du type mon@user » Le 19/07/2010, à 05:18

Sylau
Réponses : 10

Merci BDR,
tu as remplacé ton véritable username par un +, ou le + se 'fait passer' pour un @ lors de la connexion.

Parce que, en fait, je n'ai malheureusement pas de contrôle sur mon username, il DOIT comporter un @.

#8 -1 »  [RESOLU]Command not found » Le 15/06/2010, à 15:51

Sylau
Réponses : 3

Bonjour à tous,

c'est la première fois que je poste pour un problème, et c'est bon signe: j'ai toujours trouvé les réponses smile

J'ai fait l'installation d'un Ubuntu Server et j'aimerais installer le paquet qui donne des suggestions du genre:

sylvain@sylvain-laptop:~$ python1
No command 'python1' found, did you mean:
 Command 'python' from package 'python-minimal' (main)
 Command 'python3' from package 'python3-minimal' (main)
 Command 'python2' from package 'python-minimal' (main)
python1: command not found

Quelqu'un connaît le nom de ce paquet??

Merci

#9 Re : -1 »  [RESOLU]Command not found » Le 15/06/2010, à 16:30

Sylau
Réponses : 3

C'est bon, c'est bien ça.

C'était trop simple pour que je le trouve seul sad

#10 Re : -1 »  Google gears pour linux 64 bits » Le 25/08/2009, à 18:11

Sylau
Réponses : 8

Wow, merci.

Ça fait des semaines que je cherche cette solution

#11 -1 »  Dossier critique supprimé /etc/default/ » Le 24/11/2009, à 18:59

Sylau
Réponses : 9

Bonjour à tous,

premièrement, désolé si ce post comporte certains problèmes éventuels.  C'est la première fois que je poste un problème.
J'ai absolument besoin de mon laptop aujourd'hui, je n'ose donc pas redémarrer de peur qu'il ne reparte plus.  Aussi, puisque je suis à l'école, je ne dispose pas de live-cd sous la main.
J'ai donc voulu supprimer les fichiers temporaires du dossier /etc/default/ (par la commande sudo rm *~), mais la tilde '~' n'est pas entré correctement, ce qui a donné sudo rm *;
J'ai donc vidé entièrement le dossier /etc/default/.  En regardant la liste des fichiers après coup (que j'avais listé avant ouf) je constate que des progs critiques ont leurs valeurs par défaut là (comme halt, rcS, tmpfs, ...)
Je veux donc savoir si je peux redémarrer en toute sécurité, et sinon, s'il y a un moyen de récupérer/re-créer ces fichiers

merci

(edit modo : merci de relire les cas d'utilisation du mot "urgent")

#12 Re : -1 »  Dossier critique supprimé /etc/default/ » Le 24/11/2009, à 20:15

Sylau
Réponses : 9

Au final, un TECHNICIEN de mon université m'a dit que ce n'était pas des fichiers critiques, et qu'il était sécuritaire de redémarrer, ce que je fis, et mon ordi ne démarre plus.
JOIE, JOIE.
Alors, j'annulle mon appel à l'aide, et je ré-installerai ubuntu ce soir, puisque celui-ci ne démarre plus du tout.

#13 Re : -1 »  Dossier critique supprimé /etc/default/ » Le 25/11/2009, à 03:35

Sylau
Réponses : 9

C'est un fait, il les créera lors de la live-session.
J'ai encore quelque réflexes windowsiens.  Ça fait quand même juste 1½ an que je roule sous linux
Merci

#14 Re : -1 »  Dossier critique supprimé /etc/default/ » Le 25/11/2009, à 03:48

Sylau
Réponses : 9

Oui, je sais que c'est une grosse bourde
C'est que je tape tellement souvent cette ligne que je ne regarde même plus ce que j'écris.  Lorsque rm s'est plaint qu'il n'avait pas les permission, j'ai suivi tout aussi machinalement d'un 'sudo !!'
Un vieux réflexe qui consiste a enlever les fichiers temporaires.
En tout cas, merci à tous.

#15 Re : -1 »  Dossier critique supprimé /etc/default/ » Le 25/11/2009, à 03:52

Sylau
Réponses : 9

Désolé pour le ur*ent.  Je ne recommencerai plus, j'ignorais cette règle

#16 Re : -1 »  Plus de multiTouch » Le 05/11/2009, à 20:34

Sylau
Réponses : 4

J'ai installé le paquet 'gpointing-device-settings' via synaptics qui m'a permis de ré-intégrer le 'taper 2 doigts' pour bouton droit, 'taper 3 doigts' pour bouton milieu, 'glisser 2 doigts' pour défilement, etc.

Cependant, je cherche toujours pour inverser les options 2 doigts et 3 doigts, avant c'était dans le Xorg.conf, mais il ne semble plus exister

#17 Re : -1 »  firfox demarre sans la barre de titre et sans la barre d'etat » Le 24/12/2008, à 04:07

Sylau
Réponses : 23

Merci eomister, problème résolu avec démaximiser/réduire/remaximiser/redémarrer.

#18 -1 »  [RESOLU]Droits d'écriture partiels sur une fat32 (vfat) » Le 30/12/2008, à 07:33

Sylau
Réponses : 2

Je suis relativement nouveau sur ubuntu et ceci est mon premier topic que je crée pour obtenir de l'aide, j'ai pris l'habitude (bonne d'ailleurs) de recycler les solutions des autres.

J'ai un léger problème avec ma partition d'échange en fat32:

Je dis que j'ai des droit d'écriture partiels parce que je ne peux pas créer un fichier sur cette partition, mais j'arrive à modifer les fichiers existants.

Ce que j'ai fait:

sous M$ Windows:

scandisk (aucune erreur)
defragmentation (qui s'est complété)

fsck.vfat -ar

qui ne m'a donné aucune erreur

un extrait de mon fstab:

# /dev/sda6
/dev/sda6 /media/docs vfat rw,users,auto,gid=100,uid=1000,umask=027,iocharset=utf8,codepage=850  0 0

À noter (corrigez si je me trompe) que:
          gid=100, donc appartient à users (dont je fais partie, vérifié à l'instant)
          uid=1000, donc m'appartient à moi (vérifié mon uid à l'instant)
          de toutes façons, j'ai les droits en écriture puisque je peux modifier les fichiers

Je patauge dans les interrogations, c'est vraiment étrange.

#19 Re : -1 »  [RESOLU]Droits d'écriture partiels sur une fat32 (vfat) » Le 31/12/2008, à 06:47

Sylau
Réponses : 2

Merci beaucoup, je crois avoir réglé grace à storage device manager, qui m'a rajouté des valeurs dmask et fmask (réglées à 007).

un [resolu] s'impose.

Merci beaucoup.

#20 -1 »  [Résolu]Droits d'écriture partiels sur une fat32 (vfat) » Le 30/12/2008, à 07:33

Sylau
Réponses : 4

Je suis relativement nouveau sur ubuntu et ceci est mon premier topic que je crée pour obtenir de l'aide, j'ai pris l'habitude (bonne d'ailleurs) de recycler les solutions des autres.

J'ai un léger problème avec ma partition d'échange en fat32:

Je dis que j'ai des droit d'écriture partiels parce que je ne peux pas créer un fichier sur cette partition, mais j'arrive à modifer les fichiers existants.

Ce que j'ai fait:

sous M$ Windows:

scandisk (aucune erreur)
defragmentation (qui s'est complété)

fsck.vfat -ar

qui ne m'a donné aucune erreur

un extrait de mon fstab:

# /dev/sda6
/dev/sda6 /media/docs vfat rw,users,auto,gid=100,uid=1000,umask=027,iocharset=utf8,codepage=850  0 0

À noter (corrigez si je me trompe) que:
          gid=100, donc appartient à users (dont je fais partie, vérifié à l'instant)
          uid=1000, donc m'appartient à moi (vérifié mon uid à l'instant)
          de toutes façons, j'ai les droits en écriture puisque je peux modifier les fichiers

Je patauge dans les interrogations, c'est vraiment étrange.

#21 Re : -1 »  [Résolu]Droits d'écriture partiels sur une fat32 (vfat) » Le 30/12/2008, à 07:36

Sylau
Réponses : 4

J'ai oublié un détail, c'est une partition de 39.80 Gio, dont sont occupés 32,54 Gio.  Ce qui laisse donc 7.25 Gio libres.

#22 Re : -1 »  [Résolu]Droits d'écriture partiels sur une fat32 (vfat) » Le 30/12/2008, à 08:19

Sylau
Réponses : 4

Et bien, je suis vraiment étonné, mon problème est résolu grâce à un prog nommé pysdm (ou storage device manager)

Je lui ai spécifié les options que je voulais, y compris deux valeurs que je ne connaissais même pas (dmask et fmask) et tout était parfait ensuite.

je laisse le post ouvert pour recevoir des éclaircissements sur ceux-ci.

Merci quand même de me lire.

#23 Re : -1 »  [Résolu]Droits d'écriture partiels sur une fat32 (vfat) » Le 31/12/2008, à 06:45

Sylau
Réponses : 4

Merci beaucoup, c'est bien ce que je croyais.

En tout cas, ça semble avoir réglé mon problème.

#24 Re : -1 »  Vos scores à "Cinq ou plus" » Le 07/11/2008, à 21:00

Sylau
Réponses : 5

Oups, désolé, je croyais que le forum downloaderait l'image, mais je viens d'apprendre qu'il faut la mettre en ligne quelque part pour qu'il la loade.  En tout cas, je suis à 250 pts.