Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  xubuntu 11.10: Partageons nos expériences » Le 23/10/2011, à 19:52

toma75
Réponses : 148

Bonjour

j'ai testé XFCE via la distribution Voyager et je suis bluffé : du très bel ouvrage.

MAIS comme j'ai un gros blocage avec un driver realtek (mettre r8168 à la place du r8169), je ne peux pas en profiter car je n'ai pas de connexion.

J'ai essayé deux scripts en faisant les manip suivantes :
1- sudo -i
2- cd /home/philippe/Documents
3-tar xjf r8168_scripts.tar.bz2
4-cd r8168_scripts
5-chmod +x switchmods
8- ./switchmods

et ca galère toujours autant :
philippe@philippe-H67MA-UD2H-B3:~$ sudo -i 
[sudo] password for philippe: 
root@philippe-H67MA-UD2H-B3:~# cd /home/philippe/Documents
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents# cd r8168_scripts 
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168_scripts# chmod +x switchmods
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168_scripts# ./switchmodsAttempting to remove running r8168 and r8169 modules if loaded...
Attempting to move /lib/modules/3.0.0-12-generic-pae/kernel/drivers/net/r8169.ko to /lib/modules/3.0.0-12-generic-pae/kernel/drivers/net/r8169.ko.bak.
Blacklisting r8169 in /etc/modprobe.d/blacklist...
Creating a tmp dir in which to build the module...
Checking for gcc and linux-headers-3.0.0-12-generic-pae...    OK
Attempting to build the module...    OK
mv: impossible d'évaluer «/src/r8168.ko»: Aucun fichier ou dossier de ce type
Inserting the module into running kernel code...insmod: can't read '/lib/modules/3.0.0-12-generic-pae/kernel/drivers/net/r8168.ko': No such file or directory
    OK
Attempting to rebuild the initrd to include r8168 at boot...    OK
All done! You should now have a working wired ethernet connection, persistant at boot.
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168_scripts# 


Bref, grosse frustration...

#1 -1 »  (RESOLU) Comment installer un script pour realtek » Le 23/10/2011, à 09:56

toma75
Réponses : 3

Bonjour

je m'adresse aux experts de ce forum : comme d'autres amateurs (je ne suis sous gnu/linux que depuis 2 ans), je me heurte à la galère concernant le driver realtek r8168 (qu'il faut installer à la place du r8169).

J'ai passé plusieurs heures sur des forums où j'ai constaté que je n'étais pas le seul à galérer pour faire cette manip. Passionné par linux, je commence à etre dégouté de ne pas pouvoir l'utiliser sur mon nouveau PC (à cause de cette fameuse carte ethernet). De la à revenir sous Seven, ca me ferait un peu mal...

Puis, j'ai découvert un script qui a priori facilite la tâche :
http://www.jamesonwilliams.com/hardy-r8168

Seul problème, j'ai un peu de mal à faire la manip et surtout à taper les bonnes commandes nécessaires au préalables. Que taper dans le terminal avant de taper les commandes suivantes :
tar xjf r8168_scripts.tar.bz2
cd r8168_scripts
sudo ./switchmods;



Merci.

Je suis sûr que vos conseils n'aideront pas que moi. Et ce sera tout à votre honneur.

#2 Re : -1 »  (RESOLU) Comment installer un script pour realtek » Le 23/10/2011, à 11:55

toma75
Réponses : 3

Bonjour

en fait le script ne marche pas :

philippe@philippe-H67MA-UD2H-B3:~$ sudo -i
[sudo] password for philippe:
root@philippe-H67MA-UD2H-B3:~# cd /home/philippe/Documents
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents# tar xjf r8168_scripts.tar.bz2
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents# cd r8168_scripts
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168_scripts# ./switchmods;
Attempting to remove running r8168 and r8169 modules if loaded...
Attempting to move /lib/modules/3.0.0-12-generic-pae/kernel/drivers/net/r8169.ko to /lib/modules/3.0.0-12-generic-pae/kernel/drivers/net/r8169.ko.bak.
Blacklisting r8169 in /etc/modprobe.d/blacklist...
Creating a tmp dir in which to build the module...
Checking for gcc and linux-headers-3.0.0-12-generic-pae... OK
Attempting to build the module...Could not build module.
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168_scripts#

J'ai donc téléchargé le bon driver sur realtek et je vais faire ca :
1-Je mets le dossier compressé dans Documents
2-J'ouvre un terminal
3-tapes sudo -i
4-cd /home/philippe/Documents
5- tar xvjf r8168-8.025.00.tar.bz2
6-cd r8168-8.025.00/
7-./autorun.sh


Il faut décharger l'ancien module :
8-rmmod r8169

Et le mettre dans la blackliste pour l'empêcher de se charger au prochain démarrage :
9-echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf

et pour vérifier que c'est bon :
10 lsmod | grep r8168
11- ifconfig -a

Vous voyez des erreurs ?

Merci

EDIT

J'ai fait ca après réflexion :

1-Je mets le dossier compressé dans Documents
2-J'ouvre un terminal
3-tapes sudo -i
4-cd /home/philippe/Documents
5- tar xvjf r8168-8.025.00.tar.bz2
6-cd r8168-8.025.00/
7-./autorun.sh


Il faut décharger l'ancien module :
8-rmmod r8169

Et le mettre dans la blackliste pour l'empêcher de se charger au prochain démarrage :
9-echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf

et pour vérifier que c'est bon :
10 lsmod | grep r8168
11- ifconfig -a



Mais a priori, il y a encore un bug qq part .... :

philippe@philippe-H67MA-UD2H-B3:~$ sudo -i
[sudo] password for philippe:
root@philippe-H67MA-UD2H-B3:~# cd /home/philippe/Documents
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents# tar xvjf r8168-8.025.00.tar.bz2
r8168-8.025.00/
r8168-8.025.00/Makefile
r8168-8.025.00/src/
r8168-8.025.00/src/rtl_eeprom.h
r8168-8.025.00/src/r8168_asf.h
r8168-8.025.00/src/rtltool.h
r8168-8.025.00/src/r8168_asf.c
r8168-8.025.00/src/r8168_n.c
r8168-8.025.00/src/rtl_eeprom.c
r8168-8.025.00/src/rtltool.c
r8168-8.025.00/src/Makefile
r8168-8.025.00/src/r8168.h
r8168-8.025.00/src/Makefile_linux24x
r8168-8.025.00/README
r8168-8.025.00/autorun.sh
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents# cd r8168-8.025.00/
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168-8.025.00# ./autorun.sh

Check old driver and unload it.
Build the module and install
[: 48: r8168: unexpected operator
Backup r8169.ko
rename r8169.ko to r8169.bak
Depending module. Please wait.
load module r8168
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module r8168 not found.
Completed.
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168-8.025.00# rmmod r8169
ERROR: Module r8169 does not exist in /proc/modules
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168-8.025.00# lsmod | grep r8168
root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168-8.025.00# ifconfig -a
lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:8 erreurs:0 :0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:712 (712.0 B) Octets transmis:712 (712.0 B)

root@philippe-H67MA-UD2H-B3:/home/philippe/Documents/r8168-8.025.00#

#3 Re : -1 »  (RESOLU) Comment installer un script pour realtek » Le 03/11/2011, à 23:53

toma75
Réponses : 3

Mais comme la galère continuait, j'ai trouvé une solution plus pratique et plus rapide : installer une carte PCI TP-Link  TG-3468.

A priori, pour l'instant ca marche !

#4 -1 »  (RESOLU) Quelle carte ethernet sous Linux ? » Le 24/10/2011, à 11:37

toma75
Réponses : 8

Bonjour


comme je galère avec la carte ethernet Realtek (galère à installer le driver r8168 à la place du r8169...) intégrée à ma carte mère gigabyte, j'envisage de changer de carte ethernet.

Quelles sont les marques qui ne posent aucun soucis de reconnaissance sous Linux ?

Merci

#6 Re : -1 »  (RESOLU) Quelle carte ethernet sous Linux ? » Le 24/10/2011, à 12:56

toma75
Réponses : 8

Est-ce qu'Ubuntu va etre capable de faire la différence entre la carte ethernet intégrée et celle en PCI que je vais acheter ? Il me proposera de choisir l'une des deux ?

Merci

#8 Re : -1 »  (RESOLU) Quelle carte ethernet sous Linux ? » Le 03/11/2011, à 23:53

toma75
Réponses : 8

j'ai trouvé une solution plus pratique et plus rapide : installer une carte PCI TP-Link  TG-3468.

A priori, pour l'instant ca marche !

#9 -1 »  Sudo et authentification impossible » Le 21/10/2011, à 09:03

toma75
Réponses : 2

Bonjour

petit casse-tête du matin : quand je lance le terminal depuis mon compte administrateur et que je tape sudo et ensuite le mot de passe, j'ai un message qui me dit : erreur d'authentification.:mad:

Comment est-ce possible puisque j'ai tapé le bon mot de passe ?

Merci et bonne journée

#10 Re : -1 »  Sudo et authentification impossible » Le 21/10/2011, à 13:20

toma75
Réponses : 2

bonjour

non puisque je n'ai pas eu de soucis pour taper le mot de passe permettant d'ouvrir la session du compte administrateur. Et j'ai aussi vérifié sur libreoffice

#11 -1 »  (RESOLU) Comment installer le bon driver realtek. Carte mère Gigabyte » Le 16/09/2011, à 09:07

toma75
Réponses : 0

Bonjour

j'ai installé Ubuntu sur mon PC ce week end. Impecable. Mais au bout de quelques jours, je suis surpris de constater que par moment je n'ai plus de connexion internet (or, tous les voyants de ma BBox sont au vert). Par exemple, aujourd'hui, j'ai pu me connecter toute la journée mais ce soir c'est impossible pendant qq instants et ca revient plus ou moins.

En gros, j'ai l'impression d'avoir une connexion bas débit. Et des fois, je n'arrive même pas à accéder à google.com

J'ai fait un test depuis Seven (même PC que celui sur lequel est installé LinuxMint mais pas en Dual boot; les 2 OS sont sur 2 HD distintcs) et ca marche !

Voici ma carte mère : Gigabyte GA-H67MA. Concernant l'ethernet c'est le Realtek RTL8111E.

J'ai vu sur ce forum que ma arte mère utilise un chipset "Realtek RTL8111E" qui nécessite le pilote "r8168" et non pas le pilote "r8169" qui parfois est utilisé automatiquement et pose des problèmes de déconnexion.

J'ai vérifié et j'ai en effet le r8169 d'installé !

Je vais essayer de récupérer le "r8168" mais j'ai qq soucis pour comprendre comment désinstaller le 8169 et installer (il parait qu'il faut compiler...) le 8168.

Comment faire ?


Merci

J'ai trouvé une solution qui marche :
Tu télécharges la dernière version du driver :
ftp://WebUser:r3iZ6vJI@95.130.192.218/cn/nic/r8168-8.025.00.tar.bz2

Depuis Linux et terminal
tar xvjf r8168-8.025.00.tar.bz2

Terminal :
Tu entres dans le répertoire nouvellement créé :
cd r8168-8.025.00/
sudo ./autorun.sh

Bien évidemment il faut que ton système ait les sources du noyau installées ainsi que les outils de compilation tel gcc et make.
Si ils n'étaient pas installés :
sudo aptitude install build-essential linux-headers-$(uname -r)


Une fois le driver compilé, c'est expliqué dans le README (n'oublies pas le "sudo") :
Depuis le terminal :
# tar vjxf r8168-8.aaa.bb.tar.bz2
Change to the directory:
# cd r8168-8.aaa.bb
If you are running the target kernel, then you should be able to do :
# ./autorun.sh  (as root or with sudo)
You can check whether the driver is loaded by using following commands.
# lsmod | grep r8168
# ifconfig -a


Auparavant il te faudra décharger l'ancien module :
sudo rmmod r8169

Et le mettre dans la blackliste pour l'empêcher de se charger au prochain démarrage :
sudo echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf

#12 -1 »  (RESOLU) Plantage. Grub Rescue » Le 14/09/2011, à 22:46

toma75
Réponses : 2

Bonjour

j'ai un PC avec deux disques durs.

Sur le D1 j'ai LinuxMint. Aujourd'hui, avec Gparted j'ai réduit la partition linux qui prenait 90% du D1 pour avoir la moitié de libre.
J'ai redémarré sur LinuxMint : ca marche !

Ce soir, je démarre sur le D2 où il y a Seven et j'ai formaté la partition libre du D1 en NTFS. Résultat : gros caca pour moi.

Quand je redémarre sur le D1 pour avoir linuxmint j'ai le message suivant : loading OS..., Error : unknown filesystem. Grub rescue>

Comment faire ? Je crois que si je remets le LiveCD je peux réparer ?

Merci

#13 Re : -1 »  (RESOLU) Plantage. Grub Rescue » Le 15/09/2011, à 10:03

toma75
Réponses : 2

Bonjour

j'ai récupéré l'ISO de Boot Repair et tout est rentré dans l'ordre.

Merci

#14 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 20:02

toma75
Réponses : 79

reconfiguring interfaces ; j'ai eu un message indiquant RTNETLINK anwsers : no such process puis OK

#15 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 21:06

toma75
Réponses : 79

Pas mieux : wifi mais pas filaire.

J'ai essayé avec le 2.6.38 ou le 3. Pas mieux

#16 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 21:23

toma75
Réponses : 79

ca merde toujours: je ne comprends pas pourquoi je n'ai pas eu de soucis 4 jours durant après l'instal et d'un seul coup ce gros bug...

je teste avec le cD : c'est pas mieux. Je n'arrive pas à lancer firefox.

C'est quand même bizzare car samedi quand j'ai installé ubuntu unity ca marchait. Est-ce que le fait que je sois passé sous gnome classique est une cause ?

#17 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 21:34

toma75
Réponses : 79

dur, dur; c'est obligatoirement un soft qui se connecte ? J'ai supprimé Xsane, Synkron et Ubuntu Tweak. Les derniers softs installés sont VLC et Gparted. C'est eux ?

Ca ne peut pas etre les différents drivers realtek plus ou moins bien installés depuis hier soir ?

Si je fais un test avec le CD d'Opensuse j'aurais donc le même soucis ?

#18 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 21:50

toma75
Réponses : 79

des réglages pour avoir les dernieres mises à jour de firefox, chromium et thunderbird ;-(

Il n'y a pas un moyen de revenir en arrière comme avec les points de restauration de windows ?

#19 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 21:53

toma75
Réponses : 79
chibbata a écrit :

tu as fais quoi avec ubuntu tweak?
tu as changé quelque chose avec cet utilitaire?

si ça ne marche pas avec le livecd,c'est un probleme materiel dans ce cas (surchauffe du chipset reseau par exemple)

Je vais faire un test avec Seven sur le même PC. Il n'y a pas de soucis; je peux me connecter sans aucun probleme !

#20 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 21:56

toma75
Réponses : 79
chibbata a écrit :

avec le livecd,la connexion fonctionne ou pas ?


non

Et si je fais le test avec le livecd de suse que j'ai ?

#21 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 22:06

toma75
Réponses : 79
chibbata a écrit :

oui,vas y!!

Ca marche avec suse...

#22 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 22:31

toma75
Réponses : 79

ca ne marche toujours pas.

Pour vous éviter d'y passer encore une soirée et de vous ennuyer, n'est il pas préférable que je suis suprise la partition root sda et que je réinstalle buntu de nouveau ?

Sinon, la cause viendrait de quoi, histoire que je ne la refasse pas

#23 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 22:35

toma75
Réponses : 79
chibbata a écrit :

opensuse utilise le kernel 2.6.37
tu peux effacé le 3.0.3 et installé le 2.6.37 pour ubuntu

comment installer le 2.6.37 ?

#24 Re : -1 »  Connexion internet parfois absente » Le 24/08/2011, à 22:45

toma75
Réponses : 79

Merci je teste une derniere fois. Si ca marche c'est un GRAND BRAVO

Ca ne marche pas : j'arrete.

Je n'ai pas envie d'y passer encore une soirée de plus et continuer à vous prendre la tête.

Pour résumer :

1-Est-ce que je peux effacer la partition buntu pour la réinstaller ?
2-La cause de tout ce cirque ? Ubuntu Tweaks, ubuntu, ma pomme ?
3-Pourquoi ca ne merde pas avec le cd de suse ?


En tous les cas, chapeau pour votre extrême dévouement !!!