Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 5

#0 -1 »  Cron et GREP » Le 12/11/2009, à 15:08

orangepulpe
Réponses : 10

Bonjour à tous,

Je suis nouveau sur le  forum, mais j'utilise Ubuntu depuis un petit bout de temps.
Je suis actuellement bloqué à cause d'un script pour la mise en place de MRTG.

Voici la ligne qui me pose problème:
(J'utilise i4blt pour récupérer les informations d'un serveur de licence IBM)

/opt/lum/ls/bin/i4blt -s -n server_name | grep  "0,00" > /etc/bin/mrtg

Lorsque j'éxecute le script contenant le code précédent ça fonctionne, par contre dès que je l'utilise dans le cron ça pose problème. De plus j'utilise quasiment la même ligne dans mon cron, mais avec un autre pattern pour le grep et ça fonctionne:

/opt/lum/ls/bin/i4blt -s -n server_name | grep  "Product NAme" > /etc/bin/mrtg

Pourriez-vous m'aidez ou me dire comment écrire un script réalisant cette commande, qui soit entièrement utilisable par le cron?

Merci d'avance

orangepulpe

#1 Re : -1 »  Cron et GREP » Le 12/11/2009, à 16:46

orangepulpe
Réponses : 10

Oui c'est bien "Product Name", mais le problème concerne la recherche du "0.00".
Pour le product name ça fonctionne parfaitement avec le cron ou en manuel, alors qu'avec la recherche du "0.00" ça ne fonctionne pas avec le cron.


J'ai fait encore d'autres tests, en passant par un script intermédiaire et ça ne fonctionne pas...

orangepulpe

#2 Re : -1 »  Cron et GREP » Le 12/11/2009, à 17:05

orangepulpe
Réponses : 10

Oui je récupère bien les infos que je souhaite avec la ligne suivante:

/opt/lum/ls/bin/i4blt -s -n server_name | grep  "0,00"

Je récupère bien un fichier avec la ligne suivante:

/opt/lum/ls/bin/i4blt -s -n server_name | grep  [b]"0,00"[/b] > file

Je récupère bien un fichier avec la ligne suivante:

/opt/lum/ls/bin/i4blt -s -n server_name | grep  [b]"0.00"[/b] > file

Par contre quand je mets la ligne suivant dans un cron, je récupère un fichier vide ...:

/opt/lum/ls/bin/i4blt -s -n server_name | grep  "0,00" > file

Orangepulpe

#3 Re : -1 »  Cron et GREP » Le 12/11/2009, à 17:35

orangepulpe
Réponses : 10

ça ne change rien
j'obtiens toujours un fichier vide....
Je comprends pas.. et je sais pas quels option de la commande je dois utiliser....

orangepulpe

#4 Re : -1 »  Cron et GREP » Le 13/11/2009, à 11:21

orangepulpe
Réponses : 10

Merci pour ton aide Totor.
J'ai bien compris pour la recherche du motif. Mais pourrait tu m'expliquer le fonctionne du tee notament pour

tee /etc/bin/mrtg /etc/bin/mrtg

Encore merci

Orangepulpe