Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  [résolu] screen après reboot machine » Le 18/12/2013, à 18:37

NimS
Réponses : 2

Hello,

j'ai une question plus qu'un problème concernant screen.

Est-il possible qu'après un reboot de machine (serveur entre autre) qu'un screen, qui est donc kill suite au reboot, puisse supprimer des fichiers/dossiers qui ont été créé avec ce même screen?

Car j'ai eu récemment la mauvaise surprise d'un reboot serveur, qui a donc kill sans pitié tous mes screens, et j'ai perdu plusieurs fichiers/dossiers... Je ne sais pas si c'est du à la perte du screen ou tout autre chose...

j'espère avoir été assez clair, donc si quelqu'un pouvait m'éclairer sur ce point..

Merci,
NimS

#1 Re : -1 »  [résolu] screen après reboot machine » Le 18/12/2013, à 19:08

NimS
Réponses : 2

ok merci, c'était exactement ça que je voulais savoir! Ca ne va pas restaurer mes fichiers perdus, mais ce n'est pas screen qui sera inquiété! wink

#2 -1 »  [résolu] fichier corrompu (?) error input/ouput » Le 17/12/2013, à 12:03

NimS
Réponses : 2

Hello,

je viens de rencontrer un problème jamais vu encore, et je ne serai même pas le définir avec certitude... (corrompution du fichier?)
Je souhaitais lancer un projet android en cours, mais compilation impossible, avec ce message d'erreur :

[2013-12-17 10:50:12 - tp1_jduval] getFileType got errno=5 on '/home/nims/workspace/android/glasscloud/bin/resources.ap_'
[2013-12-17 10:50:12 - tp1_jduval] ERROR: output file '/home/nims/workspace/android/glasscloud/bin/resources.ap_' exists but is not regular file

je vais directement voir le fichier en question via terminal, et voilà que j'ai ça :

nims@ubuntu:~/workspace/android/glasscloud/bin$ ls -l
ls: cannot access resources.ap_: Input/output error
ls: cannot access glasscloud.apk: Input/output error
-????????? ? ?    ?         ?              ? resources.ap_
-????????? ? ?    ?         ?              ? glasscloud.apk

impossible de faire un cp/mv/rm -rf en sudo ou pas... toujours input/output error...

qu'est ce que c'est qu'ce truc? ^^

Merci,
NimS

#3 Re : -1 »  [résolu] fichier corrompu (?) error input/ouput » Le 17/12/2013, à 12:31

NimS
Réponses : 2

Merci pour la réponse rapide, d'autant plus que la solution fonctionne!! smile)

je peux continuer à vendre du rêve sur android O:-)

Merci,
NimS

#5 -1 »  [résolu] Serveur dédié multidomaines » Le 10/12/2012, à 12:15

NimS
Réponses : 6

Salut,

je dispose d'un serveur dédié kimsufi (ovh) et de plusieurs domaines (tous chez ovh également).
Au départ, je n'avais qu'un seul domaine, et j'effectuais une redirection sur l'ip de mon serveur.

Aujourd'hui 3 domaines différents et je voudrai qu'ils redirigent tous vers un dossier différent de mon serveur, par exemple /var/www/site1/ /var/www/site2/ et /var/www/site3/

Est-il possible d'avoir un domaine "par défaut" pour les dossiers /var/www/* et de préciser un domaine particulier pour un dossier spécifique?

je m'explique :
www.mondomaine1.fr redirige vers tout les dossiers /var/www/*
www.mondomaine2.fr redirige vers /var/www/monsite2
www.mondomaine3.fr redirige vers /var/www/monsite3

Je crois que j'ai fais n'importe quoi au niveau des DNS...
pour chaque domaine, j'ai ajouté les DNS de mon serveur dédié, puis j'ai édité /etc/apache2/sites-availables/default en ajoutant le nom du domaine (par exemple www.mondomaine1.fr qui tape sur le dossier choisi /var/www/monsite1)

<VirtualHost *:80>
        ServerAdmin admin@gmail.com
        ServerName www.mondomaine1.com
        ServerAlias *.mondomaine1.com mondomaine1.fr
        DocumentRoot /var/www/monsite1/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/monsite1/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride all
                Order allow,deny
                Allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

pourtant je n'ai pas du tout l'effet escompté... la seule redirection qui fonctionne c'est mon tout premier domaine qui redirige vers /var/www/
En plus, si j'utilise mon ip de serveur, il me redirige vers un dossier /var/www/dossier1 (que j'ai associé à un nom de domaine dans /etc/apache2/sites-availables/default)

yé souis au bout du rouleau !

J’espère avoir été assez clair,
NimS

#6 Re : -1 »  [résolu] Serveur dédié multidomaines » Le 10/12/2012, à 13:49

NimS
Réponses : 6
tiramiseb a écrit :

Commençons par la fin : si tu utilises l'adresse IP tu seras dirigée vers le premier VirtualHost défini.

ça c'est une bonne nouvelle!

tiramiseb a écrit :

Par ailleurs je vois une incohérence entre ton explication et ta configuration :

www.mondomaine1.fr redirige vers tout les dossiers /var/www/*
[...]

DocumentRoot /var/www/monsite1/

Une fois corrigée, cette configuration fera que www.mondomaine1.fr dessert les fichiers de /var/www/monsite1/.

en effet, j'ai fais un mauvais exemple, mais je veux avoir mon domaine1 qui redirige par défaut vers tout les dossiers /var/www/*

donc c'est possible d'avoir une redirection vers /var/www/* mais également de spécifier une redirection d'un autre domaine vers un dossier spécifique grave à la configuration de sites-availables?

En fait je me demande actuellement si ma configuration DNS est mauvaise ou si simplement ce n'est pas encore fait chez OVH (apparement ça prend du temps)...

Merci,
NimS

#7 Re : -1 »  [résolu] Serveur dédié multidomaines » Le 10/12/2012, à 15:35

NimS
Réponses : 6

Merci pour les indications vhosts, c'est top!

tiramiseb a écrit :

En fait je me demande actuellement si ma configuration DNS est mauvaise ou si simplement ce n'est pas encore fait chez OVH (apparement ça prend du temps)...

Si tes requêtes arrivent bien sur ton serveur, alors la configuration DNS est bonne...
Par contre si ça ne connecte même pas, alors il faut attendre que les DNS se propagent, oui...

quand tu parles de requêtes sur le serveur, tu fais référence à un ping? car actuellement, si je ping un des deux domaines que j'ai acquis très récemment je reçois comme réponse :

La requête Ping n'a pas pu trouver l'hôte domaine.fr. Vérfiez le nom et essayez à nouveau

(évidemment, j'ai essayé avec mon vrai domaine ^^)

NimS

#8 Re : -1 »  [résolu] Serveur dédié multidomaines » Le 10/12/2012, à 16:02

NimS
Réponses : 6

oki, je vais donc prendre mon mal en patience!

Merci pour ton aide!

NimS

#9 Re : -1 »  permlssion non accordée » Le 05/12/2012, à 18:41

NimS
Réponses : 11

en effet, sur un fichier et/ou dossier, root:root correspond à user:group

tu peux modifier le propriétaire du fichier et/ou dossier avec un :

chown bob:mongroupe <nomdossier/fichier>

le fichier ou dossier aura comme propriétaire l'user bob, qui appartient au groupe "mongroupe".

Cela dit, il ne faut pas s'amuser à changer le propriétaire des fichiers, surtout s'il s'agit de fichier system...

Si tu créer un fichier en étant connecté avec root, et que tu veux le copier/modifier avec un autre user tu ne pourra pas. Il faut modifier le propriétaire ou utiliser sudo devant tes commandes (cp/mv/etc etc...)
Evidemment, pour pouvoir utiliser sudo, il faut que l'user ait des droit d'admin.

NimS

#10 -1 »  [résolu] permissions groupe » Le 04/12/2012, à 20:50

NimS
Réponses : 4

Hello,

pour un projet précis j'ai créé un nouveau groupe sur mon serveur : disont grp_projet
j'ai ajouté les utilisateurs que je veux à ce groupe et ai configuré une connexion via ftp qui redirige directement vers le dossier choisi : entre autre /var/www/monprojet

Moi, j'ai mon compte utilisateur nims qui appartient au groupe "nims" (qui est admin).

J'ai effectué un chown nims:grp_projet sur le dossier pour que les users (non admin) du groupe "grp_projet" puisse y accéder et editer des fichiers.

Ma question est la suivante : si j'édite un fichier, test.html, avec mon compte nims:nims, ses permissions seront bien entendu nims:nims. Mais si un membre du groupe "grp_projet" souhaite editer ce fichier test, il ne disposera pas des droits. Alors est-il possible d'éditer un fichier et de spécifier a quel groupe il appartient, sans devoir effectuer un chown par la suite à chaque fois ?

NimS

#11 Re : -1 »  [résolu] permissions groupe » Le 05/12/2012, à 15:27

NimS
Réponses : 4

ah yes!!! moi je m'incline!!!

merci à tout les deux!! smile

NimS

#12 Re : -1 »  [Résolu] Problème connexion Mysql » Le 04/12/2012, à 20:58

NimS
Réponses : 4

en ligne de commande, tu as bien spécifié une connexion avec mot de passe ?

mysql -u root -p

Es-tu bien sur de ton mot de passe root pour SQL? (il diffère peut etre de celui du serveur)

#13 -1 »  Problème suite à l'installation Ubuntu 12.04.1 LTS » Le 01/10/2012, à 14:32

NimS
Réponses : 4

Bonjour,

je viens d'installer Ubuntu avec l'installateur windows et j'ai quelques problèmes... J'ai installé Ubuntu sur deux autres machines de la même manière sans avoir de problèmes.

Par exemple au Boot, je ne vois pas le chargement Ubuntu avec les points, mais j'arrive directement sur le login, plusieurs bug graphique.
L'installation de programme pose des problème (impossible d'installer chrome par exemple)

l'erreur que j'ai quand je tente l'installation :

There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks.

EDIT : pour cette erreur j'ai tenté un

dpkg --configure -a
apt-get update
apt-get upgrade

mais toujours des problèmes..

une autre erreur que j'ai eu en lançant le gestionnaire d'installation :

[Errno 1] Operation not permitted: '/var/crash/_usr_sbin_aptd.ed833e360bbc456e97b2abb714262785.crash'

Lors du premier boot, j'ai eu différent erreur en parlant d'un password... je ne sais pas exactement de quoi il s'agit...

Aussi, mais la je pense qu'il s'agit d'un changement de version, dans la barre du haut, l'icone courier pouvait me permettre d'ouvrir thunderbird pour mes mails. Ce n'est à présent plus que pour les chats, c'est normal?

j'ai l'impression que mon installation d'ubuntu s'est mal déroulée, est-il possible de faire des actions pour tenter une réinstallation directement via ubuntu? je ou je relance via windows?

Merci,
NimS

#14 Re : -1 »  Problème suite à l'installation Ubuntu 12.04.1 LTS » Le 01/10/2012, à 18:17

NimS
Réponses : 4
alca94 a écrit :

il doit parler de WUBI ? voir ici http://doc.ubuntu-fr.org/wubi

exactement!

bon sinon, j'ai pu installer chromium directement par ligne de commande.. mais ces bugs restent quand même bizarres...

#15 -1 »  changer de kernel » Le 28/09/2012, à 20:09

NimS
Réponses : 1

Hello,

je suis le (presque-)heureux tout nouveau propriétaire d'un ZenBook d'Asus. J'ai direcT installé Ubuntu dessus... mais déjà quelques problème, entre autre sur le pad. Je suis tombé là dessus : https://help.ubuntu.com/community/AsusZenbook#Touchpad

Faut apparement changer de kernel... ok... mais, comment qu'on fait? ^^

j'ai ajouté le repertoire (enfin je crois), mais quel paquet dois-je installer? Le repertoire en question : https://launchpad.net/~ubuntu-x-swat/+a … er=precise

Je suis un peu perdu...

Merci,
NimS

#16 Re : -1 »  linux et virus » Le 15/09/2012, à 21:29

NimS
Réponses : 53
ArkSeth a écrit :

Sympa... j'avoue être resté bloqué sur des fausses idées... ^^

#17 Re : -1 »  linux et virus » Le 16/09/2012, à 19:31

NimS
Réponses : 53
afilmore a écrit :

Pour ceux que ça intéresse, un article qui parle vraiment de sécurité informatique (en anglais)
https://wiki.ubuntu.com/BasicSecurity

Interessant!! Decidement en moins de 24h j'aurai énormément modifié ma vision sur la sécurité et ubuntu ^^

#18 Re : -1 »  linux et virus » Le 16/09/2012, à 20:07

NimS
Réponses : 53
afilmore a écrit :

Par exemple dans la page de wiki on te parle de mot de passe fort, ils expliquent pas vraiment ce que c'est, un bon mot de passe faut utiliser des minuscules, des majuscules et des chiffres, c'est beaucoup plus dur à casser. tongue Voila par exemple, un truc tout simple à connaitre, après faut se rapeller du mot de passe. big_smile

Ça me dérange quand on dit que Linux est plus sécurisé que les autres systèmes, d'une part y a des mythes tenaces, et d'autre part, croire son système sécurisé, en soit, je trouve que c'est une faille.

Disons plutôt qu'en général j'essai d'être un maximum safe, j'utilise des mots de passes dur à casser (que je galère parfois à retrouver ^^).
Moi je suis resté naïf sur "Ubuntu c'est un truc de geek, et eux ils savent comment ne pas se faire avoir! Avec Ubuntu je suis safe à 100%! Windows c'est mal, surtout avec le pr0n!", et j'avais comme ça plusieurs idées reçues... smile

#19 Re : -1 »  changement de groupe et chmod » Le 16/09/2012, à 18:48

NimS
Réponses : 4

Je n'ai pas la réponse à ta question, mais j'utilise ton topic car j'ai un problème qui semble équivalent.

Je suis entrain de configurer un serveur mail sur mon serveur web. J'ai une création de group à faire, entre autre

sudo groupadd --system virtual -g 5000

seulement voilà, j'ai déjà un group existant avec 5000. Je ne sais pas si cet id GID de "5000" est une obligation pour le serveur web, ou si je peux en utiliser un nouveau.

Dans le cas ou j'ai besoin de cet id GID, j'ai tenté de supprimer mon group déjà existant, mais j'ai :

'vmail' still has 'vmail' as their primary group!

du coup, il ne me reste plus que la modification, c'est bien ça?

#20 Re : -1 »  Installation d’un serveur mail : petit(s) problème(s) ! » Le 25/07/2012, à 18:09

NimS
Réponses : 16

j'évite de créer un topic différent, même si je n'ai pas vraiment le même problème.

je viens d'installer mon serveur mail, qui marche au top! Par contre je me demandais si cela était possible d'utiliser plusieurs nom de domaine et de switcher entre eux... actuellement l'envoi de mail se fait en user@domaine.com, et j'aimerai aussi pouvoir envoyer depuis user@domaine.fr

c'est possible?

#22 Re : -1 »  crontab : tous les premier samedi tous les 3 mois » Le 06/07/2012, à 12:15

NimS
Réponses : 2

Salut,

pour tous les premiers samedi du mois je ne serai pas te dire, mais pour le reste ça ressemble plus à ça :

00 06 * */3 7 ce qui va exectuer le script tous les samedi d'un mois sur 3 à 6h

NimS

#23 -1 »  Ubuntu 12.04 - copier / coller » Le 22/05/2012, à 16:12

NimS
Réponses : 4

Salut,

j'aimerai savoir pourquoi le copier / coller ne s'effectue pas comme sur mes terminaux putty sous windows, c-à-d surligner pour copier et clic droit pour coller.

Et bien sûr, comment y remedier, ou se passe la configuration?..

Merci,
NimS

#24 Re : -1 »  Ubuntu 12.04 - copier / coller » Le 22/05/2012, à 16:32

NimS
Réponses : 4

non non, juste l'action de surligner (clic gauche laché) enregistre la selection, et,  par la suite, à l'endroit choisi, un clic droit colle le contenu sauvegardé. (pas de choix dans un menu)

exactement comme ça fonctionne dans putty...

j'ai aussi vu ce fonctionnement directement sur ubuntu.. je pensais que c'etait natif...